Subject: how to disable a doc from appearing as a WG doc

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 7 May 2014 16:02:15 -0400

This is probably a very basic question.
Someone mistakenly submitted a draft with name
"draft-ietf-forces-xxx" which makes it show up as an
active WG document instead of "Related Internet-Drafts".
How do i move it out of there? I have asked the authors to resubmit
with proper naming.

The draft sat for a while waiting for manual approval and i clicked on the wrong
(and only) button which i thought was going to return me a url to go
and reject.  Instead it may have sent a url for approval. It would be nice if
there was a reject button with some opportunity to explain why the doc
was rejected.

cheers,
jamal

---

From: Benoit Claise <[email-masked]>
Date: Wed, 07 May 2014 16:22:06 -0500

Hi Jamal,

The solution is to ask the secretariat to remove the draft.
Ask your AD to do it for you.

Regards, Benoit

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 7 May 2014 22:29:41 +0100

Benoit overstates the case

https://www.ietf.org/iesg/statement/removal-of-an-internet-draft.html

However, this is an unusual circumstance, and I can work with this.

But I would prefer that you simply arrange for the posting of a tombstone file that replaces the current one (as -01) and says: move along, there is nothing to see.

Cheers,
Adrian

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: 07 May 2014 22:22
> To: Jamal Hadi Salim; wgchairs
> Cc: Adrian Farrel
> Subject: Re: how to disable a doc from appearing as a WG doc
> 
> Hi Jamal,
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 8 May 2014 06:33:20 -0400

On Wed, May 7, 2014 at 5:29 PM, Adrian Farrel <[email-masked]> wrote:
> But I would prefer that you simply arrange for the posting of a tombstone file that replaces the >current one (as -01) and says: move along, there is nothing to see.
>

I am going to ask the authors to do that.
I was hoping it would be a lot simpler ;-> I dont necessarily need to
delete it, but
change its category from "WG doc" to "not WG doc" in the WG document page.
Sounds like a tools job with authority delegated to a chair (I promise
not to abuse
the power bestowed on me).

cheers,
jamal

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 08 May 2014 13:54:25 +0200

Hi Jamal, Adrian,

These are the things which can, and probably should, be done:

1. The draft state should be changed, so as to remove it from the IETF stream
   again.  The secretariat can do that, and so can I. I tried to go to do this
   just now, but didn't find any draft "draft-ietf-forces-xxx" -- I assume
   the 'xxx' was just a shorthand for the rest of the actual draft name?

2. When the personal replacement draft has been submitted, you as a WG chair
   should mark the "draft-ietf-forces-xxx" document as replaced by the
   replacement draft, or ask the secretariat to do so for you.  That will
   have the effect of both marking "draft-ietf-forces-xxx" as replaced, which
   will cause it to be moved out of the draft repository, and providing
   information of which draft to look at instead of "draft-ietf-forces-xxx".

As for tombstone files: these aren't being used any more, but getting the
replacement information into the system should provide the correct link in
most places (and in more places than the tombstone file would influence).

Best regards,

	Henrik

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 8 May 2014 08:47:31 -0400

Hi Henrik,

>    the 'xxx' was just a shorthand for the rest of the actual draft name?

draft-ietf-forces-consistent-control-00

>    information of which draft to look at instead of "draft-ietf-forces-xxx".

This will be fine as well.

cheers,
jamal

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 08 May 2014 15:19:46 +0200

> draft-ietf-forces-consistent-control-00

Ok, I've removed it from the IETF stream, and it doesn't show on 
http://datatracker.ietf.org/wg/forces/ any more.  When the authors submit a new
individual draft, that one will show up in the Related section.

> This will be fine as well.

Ok, good.

Best regards,

	Henrik

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 8 May 2014 09:33:35 -0400

On Thu, May 8, 2014 at 9:19 AM, Henrik Levkowetz <[email-masked]> wrote:

> individual draft, that one will show up in the Related section.

Much thanks Henrik.
No good deeds should go unpunished. So here's another query:

When i received the request to manually approve - there was one button i could
click on. It seems to indicate that if i clicked on it i will get back
a universal url.
I think what happened is it approved the doc instead. It thats what happened,
a more useful message would be helpful such as "if you click on this
you are approving
the doc". To supplement this, would it be possible to have a "reject
with comment"
option? Maybe such a reject would also be forwarded to the AD to sign on etc
for accountability purposes.

cheers,
jamal

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 08 May 2014 15:59:26 +0200

Hi Jamal,

On 2014-05-08 15:33 Jamal Hadi Salim said:
>> http://datatracker.ietf.org/wg/forces/ any more.  When the authors
>> submit a new individual draft, that one will show up in the Related
>> section.
>> 
> 
> Much thanks Henrik. No good deeds should go unpunished. So here's
> another query:
> 
> When i received the request to manually approve - there was one
> button i could click on. It seems to indicate that if i clicked on it
> i will get back a universal url.

Hmm.  I don't see this on the submission status page.  There I see, under
a title in bold 'Approve Submission', a button with the title
'Approve this submission'.  I think that's pretty clear.

However:  There have been places in the datatracker where we haven't adhered
properly to the concept of 'a link takes you to another page, a button
causes data to be submitted'.  We've been working on changing buttons
which actually didn't cause changes into links instead, so as not to foster
a feeling that a button would work as a link, but there could still be
places around which needs this change.  Once we're consistent in this, the
chances should be smaller for this kind of misunderstanding, I hope.

> I think what happened is it approved
> the doc instead. It thats what happened, a more useful message would
> be helpful such as "if you click on this you are approving the doc".
> To supplement this, would it be possible to have a "reject with
> comment" option? Maybe such a reject would also be forwarded to the
> AD to sign on etc for accountability purposes.

The secretariat and the authors/submitters have a 'Cancel submission' button,
just above the approval section.  I wonder if that is sufficient?

It might maybe be a good thing, anyway, to send an email to the authors,
explaining the situation, so that they can cancel the submission themselves?

Best regards,

	Henrik

---

From: Olafur Gudmundsson <[email-masked]>
Date: Thu, 8 May 2014 10:43:46 -0400

> explaining the situation, so that they can cancel the submission themselves?

Henrik, 
if a chair does not approve a draft in a timely manner a reminder message will be sent
I think a Refuse button is a good idea 
	a) as that is an instant feedback to document submitter that the draft is not acceptable. 
	b) it would turn off reminders 

I asked  for this feature some time back, when the approval email link automatically approved the draft, 
the newer system of link taking chair to a page to approve is better but there should be two explicit choices 
approve or reject. 

	Olafur

---

From: Loa Andersson <[email-masked]>
Date: Thu, 08 May 2014 17:01:57 +0200

Folks,

> the newer system of link taking chair to a page to approve is better but there should be two explicit choices

I agree - reject button is a good idea ! Whatever reason is there to
ask me to approve of anything if I don't have a choice? Control should
be with the charis, not with the tool!

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 8 May 2014 11:02:40 -0400

> 'Approve this submission'.  I think that's pretty clear.

I did not see that.  I just forwarded you the email i received.
That button seems to be gone now, but there is a nice history
recording at:
 http://datatracker.ietf.org/submit/status/59775/

The two times i hit that button are recorded as
"Sent full access URL to: ..."
So i thought that went to the authors as an approval; however, it seems someone
else in the last history entry approved it (wasnt me!)

> chances should be smaller for this kind of misunderstanding, I hope.

thanks.

> just above the approval section.  I wonder if that is sufficient?

In a scenario i described it would have been a good idea to provide immediate
feedback top the authors.

> explaining the situation, so that they can cancel the submission themselves?

That would be nice (and less work). Providing a text box to enter feedback
is needed.

cheers,
jamal

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 08 May 2014 20:01:09 +0200

Hi Jamal,

Inline:

> else in the last history entry approved it (wasnt me!)

Right.  The person who force posted this draft was a secretariat member.
I'm going to check further with the secretariat.

> That would be nice (and less work). Providing a text box to enter feedback

Ok.  Will think some about this.

Best regards,

	Henrik

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 May 2014 13:14:37 -0500

This was definitely a usability issue when I was dhc chair.   What Jamal is describing is a problem I also had—I in fact accidentally approved several initial submissions when I didn't intend to, because the link looked like a link rather than an action, and I wanted to go to the page where the reject button was. :}

---

From: Loa Andersson <[email-masked]>
Date: Fri, 09 May 2014 06:23:07 +0200

All,

There seems to be a rather strong consensus that the reject-button is
needed.

So far my "reject-button" has been to send a mail to authors and
secretariat that the draft should not be posted unless a number of
changes have made. Used a couple of times.

/Loa

--

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 09 May 2014 02:33:26 -0400

I think there is a stronger consensus that every button or action 
requires 'two clicks' to fully engage.   This would be true for any action.

tim

On 5/9/14, 12:23 AM, Loa Andersson wrote:
>> This was definitely a usability issue when I was dhc chair.   What
>> Jamal is describing is a problem I also had—I in fact accidentally
>> approved several initial submissions when I didn't intend to, because
>> the link looked like a link rather than an action, and I wanted to go
>> to the page where the reject button was. :}
>>
>

---

From: Stig Venaas <[email-masked]>
Date: Tue, 13 May 2014 15:35:45 -0700

For pim it seems we have the opposite problem. The draft
draft-ietf-pim-join-attributes-for-lisp-00.txt
is posted, but for some reason it's marked as related
document rather than WG document at http://tools.ietf.org/wg/pim/

What to do? I thought it would be listed as a WG document just
based on the draft-ietf-pim prefix.

Stig

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 13 May 2014 23:45:09 +0100

Seems OK in the datatracker, but I have just fixed up the replace-by info which somehow the datatracker didn't have

A

> From: Stig Venaas [mailto:[email-masked]]
> Sent: 13 May 2014 23:36
> To: [email-masked]; 'wgchairs'

---

From: Christian Hopps <[email-masked]>
Date: Sat, 17 May 2014 04:47:18 -0400

Clicking a link in an email granting immediate approval always struck me as violating the "least surprise" UI design rule. 

Chris.

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 17 May 2014 17:22:26 +0200

On 2014-05-17 10:47 Christian Hopps said the following:
> Clicking a link in an email granting immediate approval always struck
> me as violating the "least surprise" UI design rule.

Agreed.  See below.

>> approved several initial submissions when I didn't intend to,
>> because the link looked like a link rather than an action, and I
>> wanted to go to the page where the reject button was. :}

This may have been the case with the pre-approval page, but the link
sent out in the email has always pointed to the draft status page, where
approval is given by clicking the "Approve this submission" button.  I've
just walked through every revision of the approval request email template
back to the first commit of it in 2011-03-03, and the link points to the
status page all the way, not to any direct approval action.

Best regards,

	Henrik

---

From: Loa Andersson <[email-masked]>
Date: Sun, 18 May 2014 06:36:31 +0200

Henrik,

> status page all the way, not to any direct approval action.

I don't dispute this, but the point I heard repeated over again here is
that a possibility to NAK a request, rather than leave not responded to.

What I don't really understand from your mail is

- are you against adding that button on principle; or
- is it just that the backlog for more urgent updates to the system is
   too log to actually do this now

/Loa

--

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 18 May 2014 07:59:29 +0200

> that a possibility to NAK a request, rather than leave not responded to.

Yes, I got that.

> - are you against adding that button on principle; or

No.

>    too log to actually do this now

Yes.

For those who consider this urgent:

 1. Make sure this is in the issue tracker as a feature request, so that
    it can be picked up during a code sprint by a sprint participant.

 2. Consider coming to a code sprint yourself, in order to get started,
    and then address this feature on the sprint, or in between sprints.

Contributions to the datatracker is merged in all the time; we've done
8 releases after the London code-sprint release (that's nearly one per
week, see https://datatracker.ietf.org/release/), so it's not like you'll
have to wait a long time to get your stuff merged and released, even if
you contribute between sprints.

Best regards,

	Henrik