Subject: Technical Advisor

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 20 May 2014 14:19:54 +0200

Hi all

looking at the recent submission of draft-secretaries-good-practices I
have been wondering what the technical advisors assigned to different
working groups are actually supposed to be doing.

What is your experience?

Ciao
Hannes

---

From: Eliot Lear <[email-masked]>
Date: Tue, 20 May 2014 14:22:20 +0200

I don't know if he is formally a technical advisor, but I would imagine
many people appreciate EKR participating in httpbis in as much as the WG
has a number of interactions with TLS.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 May 2014 12:31:05 +0000

Experiences depend upon the WG and the advisor. When the advising is requested by the WG and fills in a necessary complementary expertise - this can be a very useful function. I had positive experiences with advisors from the security area but also cases where advisors became non-responsive and were hard to replace (because the function was 'officially filled-in). I have been also on the advising side, working as 'MIB advisor' for a number of WGs and I can say that the position requires a far-from-zero effort as the advisor needs to understand at least to some extent the area he is advising in, as he sometime needs to coach at a very basic level the recipients of the advising. 

Directorates in many cases can provide similar 'service' if they exist, but a permanent TA to the WG is preferable in some cases as a longer term relation builds trust and better mutual (technical) understanding. 

My 2 agorot. 

Dan

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Hannes
> Tschofenig
> Sent: Tuesday, May 20, 2014 3:20 PM
> To: 'WG Chairs'
> Subject: Technical Advisor
> 
> Hi all
> 
> looking at the recent submission of draft-secretaries-good-practices I have
> been wondering what the technical advisors assigned to different working
> groups are actually supposed to be doing.
> 
> What is your experience?
> 
> Ciao
> Hannes

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 20 May 2014 09:24:35 -0400

> Directorates in many cases can provide similar 'service' if they exist, but a permanent TA to the WG is preferable in some cases as a longer term relation builds trust and better mutual (technical)…

I can agree with these ideas, but I really wonder why do we need formalities regarding those.  I hate to add more process, roles, etc... into our current labyrinth.

Marc.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 May 2014 13:28:45 +0000

Bonjour Marc,

By formalities you mean the few minutes spend with putting a name on the WG page? I believe that they are well spent for at least two reasons - the WG participants have a place where the name and mail address of the advisor is easy to be retrieved from, and the fact that the name shows up on that WG page can be a motivation for some individuals to contribute, or obtain the approval and necessary time to do the job from their employers. 

Regards,

Dan

> From: Marc Blanchet [mailto:[email-masked]]
> Sent: Tuesday, May 20, 2014 4:25 PM
> To: Romascanu, Dan (Dan)
> Cc: Hannes Tschofenig; WG Chairs
> Subject: Re: Technical Advisor
> 
> 
> > Experiences depend upon the WG and the advisor. When the advising is
> requested by the WG and fills in a necessary complementary expertise - this
> can be a very useful function. I had positive experiences with advisors from
> the security area but also cases where advisors became non-responsive and
> were hard to replace (because the function was 'officially filled-in). I have
> been also on the advising side, working as 'MIB advisor' for a number of WGs
> and I can say that the position requires a far-from-zero effort as the advisor
> needs to understand at least to some extent the area he is advising in, as he
> sometime needs to coach at a very basic level the recipients of the advising.
> >
> > Directorates in many cases can provide similar 'service' if they exist, but a
> permanent TA to the WG is preferable in some cases as a longer term
> relation builds trust and better mutual (technical) understanding.
> 
> I can agree with these ideas, but I really wonder why do we need formalities
> regarding those.  I hate to add more process, roles, etc... into our current
> labyrinth.
> 
> Marc.
> 
> >
> > My 2 agorot.
> >
> > Dan
> >
> >
> >> looking at the recent submission of draft-secretaries-good-practices
> >> I have been wondering what the technical advisors assigned to
> >> different working groups are actually supposed to be doing.
> >>
> >> What is your experience?
> >>
> >> Ciao
> >> Hannes

---

From: Michael Richardson <[email-masked]>
Date: Tue, 20 May 2014 09:34:48 -0400

Romascanu, Dan (Dan) <[email-masked]> wrote:
    > By formalities you mean the few minutes spend with putting a name on
    > the WG page? I believe that they are well spent for at least two
    > reasons - the WG participants have a place where the name and mail
    > address of the advisor is easy to be retrieved from, and the fact that
    > the name shows up on that WG page can be a motivation for some
    > individuals to contribute, or obtain the approval and necessary time to
    > do the job from their employers.

It's not the few minutes inserting the name, it's the process/anxiety/etc. of
removing the name that is the challenge.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 May 2014 13:36:04 +0000

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
> Richardson
> Sent: Tuesday, May 20, 2014 4:35 PM
> To: Romascanu, Dan (Dan)
> Cc: Marc Blanchet; WG Chairs

Why is this process more complicated, and why is anxiety involved? 

Dan

---

From: Thomas Narten <[email-masked]>
Date: Tue, 20 May 2014 09:47:47 -0400

> > It's not the few minutes inserting the name, it's the
> > process/anxiety/etc. of removing the name that is the challenge.

> Why is this process more complicated, and why is anxiety involved? 

Because in at least some (if not many) cases a TA is added to the WG
charter by the IESG essentially as a condition for chartering? I.e.,
they can be a way of placating a particular AD that has particular
concerns about a WG?

And hence, changing/removing a TA from a charter goes back to the IESG
and presumably revisits an earlier (possibly painful) discussion?

Thomas

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 20 May 2014 15:51:02 +0200

> Why is this process more complicated, and why is anxiety involved? 

Because we are dealing with people and not just with strings that are
replaced on an HTML page.

Looking through the security area working groups I noticed that only 2
groups have tech advisors, namely OAuth and TLS.

In the transport area there is only one group that has a tech advisor,
namely nfs4.

Haven't looked at the other areas. Might not be that common as I thought.

Ciao
Hannes

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 May 2014 13:53:00 +0000

> From: Thomas Narten [mailto:[email-masked]]
> Sent: Tuesday, May 20, 2014 4:48 PM
> To: Romascanu, Dan (Dan)
> Cc: Michael Richardson; WG Chairs
> Because in at least some (if not many) cases a TA is added to the WG charter
> by the IESG essentially as a condition for chartering? I.e., they can be a way
> of placating a particular AD that has particular concerns about a WG?
> 

It is this kind of instances that should be avoided. 

> And hence, changing/removing a TA from a charter goes back to the IESG and
> presumably revisits an earlier (possibly painful) discussion?
> 

I do not believe that the process (as I know it from the time I was an AD) is or needs to be that heavy. Even WG chairs are nominated 'at the discretion' of the AD, the decision to nominate or to de-nominate needs not go to the whole IESG. Actually I believe that could be part of the WG chair empowering, if it's not already - of course consultation with the ADs is highly recommended. 

Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 May 2014 13:57:47 +0000

> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Tuesday, May 20, 2014 4:51 PM
> To: Romascanu, Dan (Dan); Michael Richardson
> Cc: WG Chairs

Of course. I never lost this aspect from my mind. I believe that these people perform a useful function in many cases and I am sharing my experience about how to encourage them to sign up for the job. 
 
> Looking through the security area working groups I noticed that only 2 groups
> have tech advisors, namely OAuth and TLS.
> 

The security area is actually more a provider of advice than a recipient.

Regards,

Dan

---

From: Michael Richardson <[email-masked]>
Date: Tue, 20 May 2014 10:03:13 -0400

> Why is this process more complicated, and why is anxiety involved?

The typical reason for removing a security advisor is because they are
performing poorly.  So it involves a certain amount of discussion, dealing
with complaints, figuring out which parts to ignore and which parts to act
on.

---

From: Thomas Narten <[email-masked]>
Date: Tue, 20 May 2014 10:08:12 -0400

> It is this kind of instances that should be avoided.

Indeed, but we all know that it's sometimes easier to give in and move
on rather than fight for what is right. Pick your battles.

> > And hence, changing/removing a TA from a charter goes back to the
> > IESG and presumably revisits an earlier (possibly painful)
> > discussion?
> > 
> 
> I do not believe that the process (as I know it from the time I was an
> AD) is or needs to be that heavy.

I agree. It's not the *process* that is the issue, but it can be the
discussion itself. It may not seem this way to the IESG, but the
feeling at the WG level is quite often "oh no, we have to ask the
IESG, that is hard/risky/complicated/something". And this view is not
always helped by ADs who feed this narrative by not seeming very
willing to bring things up at the IESG on behalf of the WG because
they are worried (and/or lack confidence) about how the discussion
will play out.

And the reality is that it is hard to predict how discussions will
play out. I've been surprised at times at what comes up as an issue
during IESG discussions. I've seen plenty of things get raised as
issues that I thought were out of place and not germane. But
obviously, some ADs thought otherwise.

Thomas

---

From: Robert Sparks <[email-masked]>
Date: Tue, 20 May 2014 09:13:40 -0500

> Haven't looked at the other areas. Might not be that common as I thought.
To save others from digging through charter pages:
This is the full set of technical advisors for active working groups. 
These people are all doing good things and I thank them for their efforts.

Allison Mankin       httpbis    (app)
Sean Turner          websec     (app)
Ralph Droms          6lo        (int)
Dan Romascanu        ancp       (int)
Acee Lindem          homenet    (int)
Jianping Wu          savi       (int)
Xing Li              softwire   (int)
Martin Stiemerling   sunset4    (int)
Fred Baker           sunset4    (int)
Stewart Bryant       sunset4    (int)
Bill C. Fenner       grow       (ops)
Vijay Gill           grow       (ops)
Scott O. Bradner     mboned     (ops)
Stephan Wenger       codec      (rai)
Martin Stiemerling   dart       (rai)
Peter Saint-Andre    siprec     (rai)
David Ward           bfd        (rtg)
Dave Katz            bfd        (rtg)
Joel M. Halpern      forces     (rtg)
Jürgen Schönwälder   i2rs       (rtg)
Randall Atkinson     idr        (rtg)
Sharon Chisholm      idr        (rtg)
David Ward           isis       (rtg)
Tim Polk             karp       (rtg)
Alex D. Zinin        l2vpn      (rtg)
Ron Bonica           nvo3       (rtg)
Brian Haberman       pim        (rtg)
David L. Black       pwe3       (rtg)
Rene Struik          roll       (rtg)
Steven M. Bellovin   sidr       (rtg)
Peter Saint-Andre    oauth      (sec)
Allison J. Mankin    tls        (sec)
Leif Johansson       nfsv4      (tsv)

---

From: Thomas Narten <[email-masked]>
Date: Tue, 20 May 2014 10:32:02 -0400

> This is the full set of technical advisors for active working
> groups. These people are all doing good things and I thank them for
> their efforts.

Not to take away from those who are putting in time and effort, I do
recognize some names on this list that haven't been seen in the IETF
in years. So some cleanup is probably called for... and surely in some
of these cases the need for a TA has long been OBE...

Thomas

---

From: "Giles Heron (giheron)" <[email-masked]>
Date: Tue, 20 May 2014 14:34:14 +0000

right.

for example Alex Zinin is down as our TA for L2VPN.  I've not spoken to him in (quite literally) years.  And I don't think I've ever asked him for any tech advice on L2VPN.

Giles

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 May 2014 14:42:08 +0000

> From: WGChairs [mailto:[email-masked]] On Behalf Of Thomas
> Narten
> Sent: Tuesday, May 20, 2014 5:32 PM
> To: Robert Sparks
> Cc: [email-masked]
> recognize some names on this list that haven't been seen in the IETF in years.
> So some cleanup is probably called for... and surely in some of these cases
> the need for a TA has long been OBE...
> 
> Thomas

Yes. (including my mentioning as a TA for ANCP)

Many details in many charters are OBE. 

Regards,

Dan