Subject: English skills for IETF participants

From: Brian E Carpenter <[email-masked]>
Date: Fri, 08 Aug 2014 15:55:10 +1200

Hi,

These are some collected thoughts following the WG Chairs lunch session
at IETF 90 and related emails. They have no particular authority, but
it does seem that some follow-up is needed. Discussion is invited here;
I expect the EDU team will stay involved too.

1. There are issues in both spoken and written English and they concern
both native English speakers and participants from other languages and
cultures.

2. The range of issues includes:
- Drafts with incorrect English;
- Drafts with correct English that is subtle, obscure or complicated, and
  therefore hard to understand;
- Speech or email using slang, jokes or cultural references;
- Similar problems with slides;
- Speakers with poor English, strong accents (native or foreign), speaking
  too fast or bad microphone technique.

3. Language editing sessions (run by RFC Editor team) can help but are resource-
intensive with much verbal feedback. Suggestions include:
– Separate drafts into categories (protocol specs require different language
  than deployment considerations or implementation guidance);
– Offer general tips (resources for writing clear English);
– Provide guidance on how to prepare for these sessions.
Also it is necessary to clarify responsibility: authors ask
"What do I need to do?" but reviewers ask "Where do you need help?".

4. WG Chairs and document shepherds have a responsibility to flag
language issues in drafts and resolve them early. Leaving it until Last Call
or IESG is really too late.

5. Shepherd has a responsibility to help when editors and authors try to
find a technically correct and grammatically accurate phrase.

6. Possible actions:
- Run more joint editing sessions (involve document shepherds, not ADs);
- Make use of RFC Production Center (RPC) staff at IETF meetings;
- Have RPC provide an on-line "writing lab" for authors with specific
  phrasing questions; and/or set up a mailing list for English language
  questions;
- Encourage early reviews and editing (this has proved difficult so far);
- Peer to peer mode (A non-native English co-author could ask for help on
  language from a reviewer. WG chairs or shepherd could help to find such
  reviewers.);
- Therefore, assign shepherds or even co-editors early;
- Market "style sheet that describes common grammar mistakes and offers
  tips on common mistakes" (Hmm, RFC Editor: I can't seem to find this
  on your web site, so it's hard to market...);
- FAQ on use of English on the WG Chairs wiki (is that the same thing?);
- Tools (equivalent to the MS Word grammar checker);
- WG chairs pay attention to microphone technique, rapid speech, too
  much slang, etc.;
- WG chairs should review slides in advance;
- Choose speaker for a presentation carefully;
- Choose note-takers carefully;
- Encourage questions by jabber or email if questioner has poor spoken English;
- Add relevant material to the Tao of the IETF;
- Contract with companies doing EFL review;
- Encourage non-English discussion lists for preparatory work;

Regards
    Brian

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 8 Aug 2014 14:18:57 +0000

Just to build on item 2, 2nd sub-bullet, because I do not think what I said in the meeting comes across.

One of the aims of the English we use is that it needs to be readily translatable into other languages, without a change of meaning. So it is not just a matter of usage that may not be understandable.

Regards

Keith 

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf 
> Of Brian E Carpenter
> Sent: 08 August 2014 04:55
> To: Working Group Chairs
> Cc: Heather Flanagan (RFC Series Editor); EDU Team
> Subject: English skills for IETF participants
> 
> Hi,
> 
> These are some collected thoughts following the WG Chairs 
> lunch session at IETF 90 and related emails. They have no 
> particular authority, but it does seem that some follow-up is 
> needed. Discussion is invited here; I expect the EDU team 
> will stay involved too.
> 
> 1. There are issues in both spoken and written English and 
> they concern both native English speakers and participants 
> from other languages and cultures.
> 
> 3. Language editing sessions (run by RFC Editor team) can 
> help but are resource- intensive with much verbal feedback. 
> Suggestions include:
> - Separate drafts into categories (protocol specs require 
> different language
> - Offer general tips (resources for writing clear English); - 
> Provide guidance on how to prepare for these sessions.
> 4. WG Chairs and document shepherds have a responsibility to 
> flag language issues in drafts and resolve them early. 
> Leaving it until Last Call or IESG is really too late.
> 
> 5. Shepherd has a responsibility to help when editors and 
> authors try to find a technically correct and grammatically 
> accurate phrase.
> 
> 6. Possible actions:

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Aug 2014 16:00:19 -0400

DRAGE, Keith (Keith) <[email-masked]> wrote:
    > One of the aims of the English we use is that it needs to be readily
    > translatable into other languages, without a change of meaning. So it
    > is not just a matter of usage that may not be understandable.

There was this thing that floated around Ottawa called "Nortel English" (and
probably "BNR English"), that apparently had the property that it was easily
translatable.  I don't think that they got very far with the machine part though.

I've BCC'ed two ex-Nortel types who might know where that document went.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Aug 2014 16:30:34 -0400

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tom Taylor <[email-masked]>
Date: Fri, 08 Aug 2014 18:51:26 -0400

> I've BCC'ed two ex-Nortel types who might know where that document went.

I have an old BNR style manual kicking around home. When I get out of 
hospital I can see if it would be helpful.

Tom Taylor

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 27 Aug 2014 11:31:36 +1200

Following up...

I have now posted the RFC Editor's tips document that was
mentioned in Toronto to the EDU wiki:
http://wiki.tools.ietf.org/group/edu/attachment/wiki/IETF90/RFC-writing-tips.pdf?format=raw

However, perhaps there is an active WG Chair who would like to
open a new page on the WG Chair's wiki for this whole topic?
I don't have editing rights on that wiki.

   Brian

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Fri, 29 Aug 2014 08:19:58 -0700

For folks with continued interest in this topic, you might enjoy this
white paper:

EDANZ WHITE PAPER: Innovating the Authorship Experience -
<http://www.edanzediting.com/sites/all/files/Edanz-white-paper_0.pdf>

"We examine the difficulties ESL (English as a second language) authors
face when trying to publish their results in peer-reviewed journals. Our
findings are largely based on data from surveys conducted on DXY and
ScienceNet.cn, the two leading portals for China’s research community.
The survey results confirm there are major barriers for ESL authors,
supporting our insights from 18 years of first-hand experience working
with these communities."

It's not 100% applicable to RFCs, but there is some interesting material
we might consider.

- -Heather