Subject: RE: Reply to LC comments on draft-secretaries-good-practices-06

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 1 Dec 2014 13:13:29 -0000

Hi Martin,

Thanks for the detailed email and the update. I think you've done a good job of
addressing the many points that were raised.

I've waited a while to see whether anyone wanted to comment on your changes, for
example to say that they don't address their concerns. But no email on the
subject.

I will put the document in front of the IESG on the 18 December telechat. That
gives you all a little longer to express any further concerns.

Thanks,
Adrian

> -----Original Message-----
> From: iesg [mailto:[email-masked]] On Behalf Of Martin Vigoureux
> Sent: 12 November 2014 07:29
> To: [email-masked]
> Cc: IETF WG Chairs
> Subject: Reply to LC comments on draft-secretaries-good-practices-06
> 
> All,
> 
> thank you for your reviews and comments on
> draft-secretaries-good-practices-06.
> Sorry for the delayed response.
> 
> Summarizing the comments:
> 
> * We noticed some opposition to moving this document as a BCP updating
> RFC 2418.
> We have decided no to progress it as such. We have thus removed the
> normative section (Section 2.), changed the intended status to
> Informational, removed the update to RFC 2418 in the header and
> Abstract, and have moved RFC 2418 as an Informative Reference.
> 
> * We understood some clarifications were needed to more precisely
> position the content of this document with regards to WG chairs
> responsibilities.
> * We also understood that some clarifications were needed with regards
> to the relevancy of WG Secretaries, as well a who has responsibility
> over their appointment and the delegation.
> There were bits and pieces of text covering some of these points. Text
> was also missing. We have regrouped all the relevant text elements under
> a new section (Applicability Statement) with the objective of clarifying
> the blurry points.
> 
> * In response to specific comments we have also clarified the elements
> pertaining to access to tools.
> 
> * Finally, we have taken into account a good number of rewording
> suggestions.
> 
> I am ready to go through each comment that was made, if desired.
> 
> We have published a new version of the draft capturing all that.
> http://tools.ietf.org/html/draft-secretaries-good-practices-07
> 
> Thank you
> 
> -m

---

From: Ralph Droms <[email-masked]>
Date: Wed, 3 Dec 2014 08:06:39 -0800

Robert Sparks wrote a gen-art review of this document: http://www.ietf.org/mail-archive/web/ietf/current/msg88387.html

I don't see that Robert's suggestion has been followed:

> Also, as best I can tell, there's been ONE post in response
> to this IETF LC on ietf general, and a lot of discussion in
> other places (78 messages so far on wgchairs - see:
> 
> <https://mailarchive.ietf.org/arch/search/?email_list=wgchairs&q=draft-secretaries-good-practices> ). It might be good for the
> shepherd to bring a summary of those discussions to the IETF list,
> and perhaps steer the remaining conversation that direction?

The summary below does not take into account the suggestion that the contents of draft-secretaries-good-practices be published on the WG chairs' wiki page rather than in an RFC.  Was that alternative considered?

- Ralph

On Nov 11, 2014, at 11:29 PM 11/11/14, Martin Vigoureux <[email-masked]> wrote:

> All,
> 
> thank you for your reviews and comments on draft-secretaries-good-practices-06.
> * We noticed some opposition to moving this document as a BCP updating RFC 2418.
> We have decided no to progress it as such. We have thus removed the normative section (Section 2.), changed the intended status to Informational, removed the update to RFC 2418 in the header and Abstract, and have moved RFC 2418 as an Informative Reference.
> 
> * We understood some clarifications were needed to more precisely position the content of this document with regards to WG chairs responsibilities.
> * We also understood that some clarifications were needed with regards to the relevancy of WG Secretaries, as well a who has responsibility over their appointment and the delegation.
> There were bits and pieces of text covering some of these points. Text was also missing. We have regrouped all the relevant text elements under a new section (Applicability Statement) with the objective of clarifying the blurry points.
> 
> * In response to specific comments we have also clarified the elements pertaining to access to tools.
> 
> * Finally, we have taken into account a good number of rewording suggestions.
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Dec 2014 17:23:40 -0000

Hi ralph,

Thanks for your contribution.

Do you think it would address this comment if the end of Section 1 (the
introduction) included a paragraph such as...

   It is expected that upon publication, the content of this document
   will be transferred to the Working Groups Chairs' wiki, or this
   document be referenced there.

Thanks,
Adrian

> From: WGChairs [mailto:[email-masked]] On Behalf Of Ralph Droms
> Sent: 03 December 2014 16:07
> To: [email-masked]
> Cc: IETF WG Chairs; ietf
> Subject: Re: Reply to LC comments on draft-secretaries-good-practices-06
> 
> Robert Sparks wrote a gen-art review of this document:
> http://www.ietf.org/mail-archive/web/ietf/current/msg88387.html
> 
> > <https://mailarchive.ietf.org/arch/search/?email_list=wgchairs&q=draft-
> secretaries-good-practices> ). It might be good for the
> The summary below does not take into account the suggestion that the contents
> of draft-secretaries-good-practices be published on the WG chairs' wiki page
> rather than in an RFC.  Was that alternative considered?
> 
> - Ralph
> 
> On Nov 11, 2014, at 11:29 PM 11/11/14, Martin Vigoureux
> <[email-masked]> wrote:
> 
> > All,
> >
> normative section (Section 2.), changed the intended status to Informational,
> removed the update to RFC 2418 in the header and Abstract, and have moved
> RFC 2418 as an Informative Reference.
> >
> > * We understood some clarifications were needed to more precisely position
> the content of this document with regards to WG chairs responsibilities.
> > * We also understood that some clarifications were needed with regards to
the
> relevancy of WG Secretaries, as well a who has responsibility over their
> appointment and the delegation.
> > There were bits and pieces of text covering some of these points. Text was
also
> missing. We have regrouped all the relevant text elements under a new section
> (Applicability Statement) with the objective of clarifying the blurry points.
> >
suggestions.

---

From: Ralph Droms <[email-masked]>
Date: Wed, 3 Dec 2014 10:55:32 -0800

>   document be referenced there.

Thanks for pointing me at that text, which I missed when I read rev 7 (and which was not called out in the summary along with the announcement of the publication of rev 7).

I intended to suggest that the material be incorporated directly into the WG chairs' wiki, without publishing this document.  Considering that intent, the paragraph does not address my comment.

To be clear ... I suggest that the very useful contents of this document be directly integrated into the WG chairs' wiki.  The document has done its job as a formal basis for discussion and does not need to be published as an RFC.  

Further, as RFC 2418 could be read as highly restrictive of a secretary's role, it might be appropriate to publish a one-sentence RFC updating RFC 2418 to allow for the chairs to delegate other responsibilities beyond "the Secretary's job is to record WG decisions" however they want.  I would also be perfectly fine if that expansion was simply noted in the wiki or simply not mentioned at all. 

- Ralph