Subject: WG Interim Meeting Blue Sheets

From: Amy Vezza <[email-masked]>
Date: Mon, 26 Jan 2015 16:46:42 -0500

To the Working Group Chairs,

The datatracker release today (v5.10.1) includes an update to the meeting materials manager so that WG Chairs and WG Secretaries can now upload blue sheets for interim meetings, the same way you upload meeting presentations, agenda, and minutes.  The blue sheets will be included in Interim Meeting Proceedings going forward.

For face to face interim meetings, please remember the Working Group Chairs' Page (http://www.ietf.org/wg/chairs-page.html) has a downloadable PDF for the blue sheets under "Meeting Tools."

You may also continue to send blue sheets to the Secretariat for posting if you wish to (at [email-masked]).

Best regards,

Amy Vezza
IETF Secretariat

---

From: "Bradner, Scott" <[email-masked]>
Date: Mon, 26 Jan 2015 21:48:57 +0000

any possibility to also cover IETF-reated non-WG meetings (e.g. BAR BOFs)

Scott

> On Jan 26, 2015, at 4:46 PM, Amy Vezza <[email-masked]> wrote:
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 26 Jan 2015 17:22:35 -0500

> any possibility to also cover IETF-reated non-WG meetings (e.g. BAR BOFs)

eek. That would just confuse the (non)status of Bar BoFs even further --
not a good thing IMO...

Lou

---

From: Sandra Murphy <[email-masked]>
Date: Mon, 26 Jan 2015 17:36:31 -0500

You imply that virtual interim meetings are also supposed to provide something like an attendance record.  

If so, what is the desired method of attendance record?  ("Everyone, call out (spell out) your name and affiliation" or "Everyone please email you name and affiliation" or "Everyone please record your name on the interim meeting wiki" or something else - do you care?) 

I've done the "call out your name" before, and wondered at the time if that met expectations or usual practice.

--Sandy

---

From: Loa Andersson <[email-masked]>
Date: Tue, 27 Jan 2015 12:54:38 +0800

Folks,

> eek. That would just confuse the (non)status of Bar BoFs even further --

I think we have three (at least) types of non-WG meetings

- meeting with minutes, listing the participants (the blue sheets
   should be a problem)
- meetings that in itself does not list participants, blue sheets
   could/should be used
- BAR BOFs - there should formal requirements on this type of meeting,
   if we have gone to far down that road we  will see "speakeasy BOFs"
   within one or two meetings

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Melinda Shore <[email-masked]>
Date: Mon, 26 Jan 2015 20:10:36 -0900

> any possibility to also cover IETF-reated non-WG meetings (e.g. BAR BOFs)

Wow.  I think that's a TERRIBLE idea.  I have tended to find
"bar bofs"/"side meetings"/etc. that are basically faux bofs
to be unproductive - that structure tends to lend itself to
presentation rather than discussion, and to a premature push to
develop charters and try for working group formation.  I'd hate to see
that sort of thing validated by the organization, and attendance records
that are stored on the IETF website will tend to do lend itself to
that.

How do you see them being used?

Melinda

---

From: joel jaeggli <[email-masked]>
Date: Mon, 26 Jan 2015 21:17:06 -0800

> that are stored on the IETF website will tend to do lend itself to

I have a more basic concern with this suggestion. Informal activities
should not be in scope for the note-well. you should feel free to engage
in converstations with your coworkers collaborators, conspirators or
arch-enemies without the ietf process intruding.

digital bluesheets should hopefully facilitate IETF actvities where we
believe we do need such record keeping.

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 27 Jan 2015 12:10:41 +0000

> eek. That would just confuse the (non)status of Bar BoFs even further --
+1

Where would draw the line?

Stewart

---

From: Benoit Claise <[email-masked]>
Date: Tue, 27 Jan 2015 13:16:17 +0100

>> eek. That would just confuse the (non)status of Bar BoFs even further --
Yep, for the SUPA bar BoF, I had to actually remind people that this was 
a bar BoF, as opposed to an approved BoF.

Regards, Benoit

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 27 Jan 2015 15:33:31 +0100

> Where would draw the line?

actually what is wrong if we can later see participant details, so we can review how much interest there was
and which kind of people were interested and involved?

makes it easier to contact people

---

From: Benson Schliesser <[email-masked]>
Date: Tue, 27 Jan 2015 10:14:18 -0500

I have the same question. One method that I've used in the past is to 
simply take a screenshot of the WebEx participants. But of course, that 
only captures the participants at that particular point in time, missing 
those that come late / go early / etc. It also means that I'm just 
getting names without affiliations etc.

It seems too burdensome to go through a roll call. That approach 
wouldn't scale well for virtual interim meetings above a handful of 
people, and would waste a lot of people's time.

I've considered using a registration tool such as Eventbrite for virtual 
interim meetings. But that would capture all the people who intend to 
join, and not necessarily the subset of people that actually do join the 
meeting.

What would be ideal is to get a list of attendees from some "gateway" 
system that people have to pass through on their way into the meeting. 
For example, it could be as simple as requiring people to fill in their 
name and affiliation in WebEx and having that list available for the 
chairs to download. If this is possible in WebEx today, I hope somebody 
can explain how to use it... Otherwise, perhaps it's something worth 
coding up as an IETF tool..?

What do other chairs do?

Cheers,
-Benson

> Sandra Murphy <mailto:[email-masked]>
> January 26, 2015 at 5:36 PM
> If so, what is the desired method of attendance record? ("Everyone, 
> call out (spell out) your name and affiliation" or "Everyone please 
> email you name and affiliation" or "Everyone please record your name 
> on the interim meeting wiki" or something else - do you care?)
>

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 27 Jan 2015 07:17:59 -0800

> and which kind of people were interested and involved?

The thing that is wrong with collecting what looks like a blue sheet is that there will then be an expectation that this "meeting" falls under the IETF "note well" rules.

> makes it easier to contact people

Indeed. And, if you want that, call it an IETF BoF (even if it was not earlier blessed by an AD), and say "we're under the IETF 'note well' rules, and we're passing around a blue sheet". It is useful info if, when someone says that, some people get up and leave.

Let's keep the separation clean. Otherwise, the ability to have useful informal hallway conversations will go to hell. 

--Paul Hoffman

---

From: Lou Berger <[email-masked]>
Date: Tue, 27 Jan 2015 10:36:21 -0500

On 1/27/2015 10:14 AM, Benson Schliesser wrote:
> Otherwise, perhaps it's something worth coding up as an IETF tool..?
>
> What do other chairs do?

In our recenter interim, we published an etherpad link (from the tools
page), and asked that everyone ensure that their name was listed. 
Pretty close to 'blue sheet signing' -- someone (perhaps Adrian) helped
get it started by copying over names from WebEx.

The only change I'd suggest here is to have the etherpad created at the
same time the interim is created.  I believe we just used the etherpad
automatically setup for the next meeting -- and this worked fine.

Lou

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 10:41:18 -0500

Amy:

For virtual interims, is the recording of attendees in the minutes
sufficient for IETF? 

Sue 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Amy Vezza
Sent: Monday, January 26, 2015 4:47 PM
To: [email-masked]
Subject: WG Interim Meeting Blue Sheets

The datatracker release today (v5.10.1) includes an update to the meeting
materials manager so that WG Chairs and WG Secretaries can now upload blue
sheets for interim meetings, the same way you upload meeting presentations,
agenda, and minutes.  The blue sheets will be included in Interim Meeting
Proceedings going forward.

For face to face interim meetings, please remember the Working Group Chairs'
Page (http://www.ietf.org/wg/chairs-page.html) has a downloadable PDF for
the blue sheets under "Meeting Tools."

You may also continue to send blue sheets to the Secretariat for posting if
you wish to (at [email-masked]).

Best regards,

Amy Vezza
IETF Secretariat

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 10:45:40 -0500

Benson:

For virtual interims, we encourage people to give their names in the
participants list in web.

As the meeting starts, the note taker just records the list of participants
in the notes.   We use an etherpad for the notes so that people can see who
is listed, and encourage people in the chat room to add their name.   

During discussions, I have been switching the screen view to the etherpad
notes so that people can see what we are recording from the discussion.  

It's informal, but I hope it has been working well. 

Sue 

From: WGChairs [mailto:[email-masked]] On Behalf Of Benson
Schliesser
Sent: Tuesday, January 27, 2015 10:14 AM
To: Sandra Murphy
Cc: [email-masked]
Subject: Re: WG Interim Meeting Blue Sheets

I have the same question. One method that I've used in the past is to simply
take a screenshot of the WebEx participants. But of course, that only
captures the participants at that particular point in time, missing those
that come late / go early / etc. It also means that I'm just getting names
without affiliations etc.

It seems too burdensome to go through a roll call. That approach wouldn't
scale well for virtual interim meetings above a handful of people, and would
waste a lot of people's time.

I've considered using a registration tool such as Eventbrite for virtual
interim meetings. But that would capture all the people who intend to join,
and not necessarily the subset of people that actually do join the meeting.

What would be ideal is to get a list of attendees from some "gateway" system
that people have to pass through on their way into the meeting. For example,
it could be as simple as requiring people to fill in their name and
affiliation in WebEx and having that list available for the chairs to
download. If this is possible in WebEx today, I hope somebody can explain
how to use it... Otherwise, perhaps it's something worth coding up as an
IETF tool..?

What do other chairs do?

Cheers,
-Benson

 <mailto:[email-masked]> Sandra Murphy

You imply that virtual interim meetings are also supposed to provide
something like an attendance record. 

If so, what is the desired method of attendance record? ("Everyone, call out
(spell out) your name and affiliation" or "Everyone please email you name
and affiliation" or "Everyone please record your name on the interim meeting
wiki" or something else - do you care?) 

I've done the "call out your name" before, and wondered at the time if that
met expectations or usual practice.

--Sandy

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 10:47:49 -0500

Lou:

+1 on your method - This was used for IDR, TRILL, and I2RS interims. 

If you know a way of getting an automatic etherpad set-up for the meeting,
please send a note on how you did it.  

Sue Hares 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Tuesday, January 27, 2015 10:36 AM
To: Benson Schliesser; Sandra Murphy
Cc: [email-masked]
Subject: Re: WG Interim Meeting Blue Sheets

In our recenter interim, we published an etherpad link (from the tools
page), and asked that everyone ensure that their name was listed. 
Pretty close to 'blue sheet signing' -- someone (perhaps Adrian) helped get
it started by copying over names from WebEx.

The only change I'd suggest here is to have the etherpad created at the same
time the interim is created.  I believe we just used the etherpad
automatically setup for the next meeting -- and this worked fine.

Lou

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 27 Jan 2015 16:02:29 +0000

> makes it easier to contact people
Bert,

There must be a line somewhere between a WG meeting and a sentence muttered
whilst at adjacent sinks in the washroom, where the details need to be 
recorded.
At the moment it is at a formal BOF. If we move this line we need to be 
very
careful of the consequences, else we end up introducing a Benedictine 
culture
into the IETF.

Stewart

---

From: Lou Berger <[email-masked]>
Date: Tue, 27 Jan 2015 11:08:13 -0500

> please send a note on how you did it.  
I just hacked the url, i.e., went to the etherpad listed under
http://tools.ietf.org/wg/<WG>/minutes and changed a 91 to 92 (and WG as
teas is new) the end result was:
http://etherpad.tools.ietf.org:9000/p/notes-ietf-92-teas?useMonospaceFont=true

What did you do for your interims?

Lou

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 12:03:17 -0500

http://etherpad.tools.ietf.org:9000/idr-interim-january-26 

However this did not get me into datatracker list of notes?    Did your
mechanism allow it to come up on the data tracker page?   

Sue 

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, January 27, 2015 11:08 AM
To: Susan Hares; 'Benson Schliesser'; 'Sandra Murphy'
Cc: [email-masked]
Subject: Re: WG Interim Meeting Blue Sheets

On 1/27/2015 10:47 AM, Susan Hares wrote:
> If you know a way of getting an automatic etherpad set-up for the 
> meeting, please send a note on how you did it.
I just hacked the url, i.e., went to the etherpad listed under
http://tools.ietf.org/wg/<WG>/minutes and changed a 91 to 92 (and WG as teas
is new) the end result was:
http://etherpad.tools.ietf.org:9000/p/notes-ietf-92-teas?useMonospaceFont=tr
ue

Lou

> Pretty close to 'blue sheet signing' -- someone (perhaps Adrian) 
> helped get it started by copying over names from WebEx.
>
> The only change I'd suggest here is to have the etherpad created at 
> the same time the interim is created.  I believe we just used the 
> etherpad automatically setup for the next meeting -- and this worked fine.
>
> Lou
>
>
>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 27 Jan 2015 17:17:13 +0000

Screenshot of the WebEx is the most effective way. I use this approach all the time when hosting meetings. When new people join the session, I do another screenshot.

I think IETF should also change its' manual bluesheet method to an online sign-in with password given at each session.

Linda

From: WGChairs [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Tuesday, January 27, 2015 9:14 AM
To: Sandra Murphy
Cc: [email-masked]
Subject: Re: WG Interim Meeting Blue Sheets

I have the same question. One method that I've used in the past is to simply take a screenshot of the WebEx participants. But of course, that only captures the participants at that particular point in time, missing those that come late / go early / etc. It also means that I'm just getting names without affiliations etc.

It seems too burdensome to go through a roll call. That approach wouldn't scale well for virtual interim meetings above a handful of people, and would waste a lot of people's time.

I've considered using a registration tool such as Eventbrite for virtual interim meetings. But that would capture all the people who intend to join, and not necessarily the subset of people that actually do join the meeting.

What would be ideal is to get a list of attendees from some "gateway" system that people have to pass through on their way into the meeting. For example, it could be as simple as requiring people to fill in their name and affiliation in WebEx and having that list available for the chairs to download. If this is possible in WebEx today, I hope somebody can explain how to use it... Otherwise, perhaps it's something worth coding up as an IETF tool..?

What do other chairs do?

Cheers,
-Benson

Sandra Murphy<mailto:[email-masked]>
January 26, 2015 at 5:36 PM
You imply that virtual interim meetings are also supposed to provide something like an attendance record.

--Sandy

---

From: Yoav Nir <[email-masked]>
Date: Tue, 27 Jan 2015 21:12:42 +0200

> On Jan 27, 2015, at 7:17 PM, Linda Dunbar <[email-masked]> wrote:
> 

So what do you do when they use a screen name like “thedude1974” ?

> I think IETF should also change its’ manual bluesheet method to an online sign-in with password given at each session.
>  
>  
> Linda

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 27 Jan 2015 14:25:30 -0500

> So what do you do when they use a screen name like “thedude1974” ?

What do you do when the interim is not being held over WebEx?

--Sandy

---

From: Yoav Nir <[email-masked]>
Date: Tue, 27 Jan 2015 21:39:50 +0200

> On Jan 27, 2015, at 9:25 PM, Sandra Murphy <[email-masked]> wrote:
> 
> 

Pretty much any technology lets people choose their names, even face-to-face meetings. I noticed that I could specify whatever I want to be printed on the name tag, and people have used this “feature” before to get name tags with interesting messages. 

But chat rooms tend to have a lot of people using aliases that mean nothing to anyone in the room except them, whereas the blue sheets usually have proper names on them. Looking at the jabber log for my working group’s last meeting, I see we had “stpeter”, “jimsch1”, “sfctd”, and “g m”. I happen to know who three of those are, but that’s because it’s a small group. A virtual interim is likely to bring in people who normally don’t attend, and a screenshot full of screen names is not very helpful.

Yoav

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 14:58:19 -0500

Sandy:

For in person interims, there are blue sheets that can be downloaded and
printed off for the interim.  Most chairs holding in-person interims create
PDFs from the blue sheets and then send the blue sheets to the secretariat.
You could also upload the interim sheets as a slide presentation (there is
no blue sheets place in the interim manager - but I'm sure the tools team
could fix that problem). 

As a chair, I understand Yoav Nir's comments. I try to get people to go from
names I do not recognize to giving me specific names. I allow 15 minutes
before the session to greet newcomers, and gather names.   Your scribe can
also do this by sending chats to people who are online.  If the person just
dials in, you need to ask who it is. 

Sue 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Sandra Murphy
Sent: Tuesday, January 27, 2015 2:26 PM
To: Yoav Nir
Cc: [email-masked]; Sandra Murphy
Subject: Re: WG Interim Meeting Blue Sheets

On Jan 27, 2015, at 2:12 PM, Yoav Nir <[email-masked]> wrote:

>> Screenshot of the WebEx is the most effective way. I use this approach
all the time when hosting meetings. When new people join the session, I do
another screenshot.
> 
> So what do you do when they use a screen name like "thedude1974" ?

--Sandy

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 15:00:43 -0500

Yoav:

Did my answer to Sandy cover “thedude1974” question.   As a chair, I ask the person.  If they decline to answer, it is fine to monitor the meeting without adding comments. If they comment in the meeting, I will stop the meeting and ask them for their name. 

This is pretty much like WG group meetings.  You can monitor the meeting all you want – but if you participate (make a comment), you must give your name. 

Sue 

From: WGChairs [mailto:[email-masked]] On Behalf Of Yoav Nir
Sent: Tuesday, January 27, 2015 2:13 PM
To: Linda Dunbar
Cc: [email-masked]; Sandra Murphy
Subject: Re: WG Interim Meeting Blue Sheets

 

Linda

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 15:07:24 -0500

Scott made an important point in a private discussion.  

His suggestion about the "blue sheets" for pre-BOFs was so that interested
people can contact other people interested in the work.   As the organizer
of pre-BOF materials, it would be helpful to have a small place on the
pre-BOF web-site to point to this information.   A pre-BOF wiki could make
this low-maintenance for the IESG secretariat. 

My current way of doing this is to try to post to the Pre-BOF mail list a
web-site for the pre-BOF information.  

I welcome any thought or guidance on this effort. 

Sue 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, January 27, 2015 12:03 PM
To: 'Lou Berger'; 'Benson Schliesser'; 'Sandra Murphy'
Cc: [email-masked]
Subject: RE: WG Interim Meeting Blue Sheets

Sue 

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, January 27, 2015 11:08 AM
To: Susan Hares; 'Benson Schliesser'; 'Sandra Murphy'
Cc: [email-masked]
Subject: Re: WG Interim Meeting Blue Sheets

Lou

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 27 Jan 2015 15:40:00 -0500

> On Jan 27, 2015:10:14 AM, at 10:14 AM, Benson Schliesser <[email-masked]> wrote:
> 

	Some non-antiquated approach other than manually writing down and collecting names/emails on a piece of paper, needs to be taken.  We should also have some way of better verification of who actually signed/attended given that we use this for Note Well compliance.  If someone say puts down “Mickey Mouse” as their name, that doesn’t really capture their attendance.  I like the Eventbrite approach Benson suggested but it has to work both for the in-person meetings as well as virtual ones.  

	—Tom

> 
> Cheers,
> -Benson
> 
> 
>> 	Sandra Murphy <mailto:[email-masked]>	January 26, 2015 at 5:36 PM

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 27 Jan 2015 16:16:03 -0500

Eventbrite approach is fine with me.   Getting a copy of participants has
not been too burdensome for the IDR, I2RS or TRILL virtual interim so far.  

Sue  

From: WGChairs [mailto:[email-masked]] On Behalf Of Thomas D.
Nadeau
Sent: Tuesday, January 27, 2015 3:40 PM
To: Benson Schliesser
Cc: [email-masked]; Sandra Murphy
Subject: Re: WG Interim Meeting Blue Sheets

On Jan 27, 2015:10:14 AM, at 10:14 AM, Benson Schliesser
<[email-masked]> wrote:

What do other chairs do?

            Some non-antiquated approach other than manually writing down
and collecting names/emails on a piece of paper, needs to be taken.  We
should also have some way of better verification of who actually
signed/attended given that we use this for Note Well compliance.  If someone
say puts down "Mickey Mouse" as their name, that doesn't really capture
their attendance.  I like the Eventbrite approach Benson suggested but it
has to work both for the in-person meetings as well as virtual ones.  

            -Tom

Cheers,
-Benson

--Sandy

---

From: Lou Berger <[email-masked]>
Date: Tue, 27 Jan 2015 16:28:04 -0500

On 1/27/2015 3:40 PM, Thomas D. Nadeau wrote:
> I like the Eventbrite approach Benson suggested but it has to work
> both for the in-person meetings as well as virtual ones.  
>
Do you mean you want to enforce blue sheet signing in person?  We don't
even do that at regular meetings.  (We only enforce identification on
comments.)

Lou

---

From: Yoav Nir <[email-masked]>
Date: Tue, 27 Jan 2015 23:33:59 +0200

> On Jan 27, 2015, at 10:00 PM, Susan Hares <[email-masked]> wrote:
> 
> Yoav:
>  

Sure. The only virtual interim meeting I ever hosted was small enough that we all knew each other, so making the list was fairly easy. So I have never had this issue.

Yoav

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 27 Jan 2015 16:57:47 -0500

I've often wondered what the point is of the sheets then.  If you don't identify yourself positively, who can say you were really there especially if you lurk from the back of the room?

	--Tom

> On Jan 27, 2015:4:28 PM, at 4:28 PM, Lou Berger <[email-masked]> wrote:
> 
>

---

From: Martin Vigoureux <[email-masked]>
Date: Tue, 27 Jan 2015 23:35:33 +0100

at least they give an estimation of the number of people in the room, 
which is useful for room planning/allocation to WG sessions.
-m

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 27 Jan 2015 17:50:17 -0500

That assumes that people don't make up more than one name.

	--Tom

> On Jan 27, 2015:5:35 PM, at 5:35 PM, Martin Vigoureux <[email-masked]> wrote:
> 
> at least they give an estimation of the number of people in the room, which is useful for room planning/allocation to WG sessions.
> -m
>

---

From: Martin Vigoureux <[email-masked]>
Date: Tue, 27 Jan 2015 23:54:06 +0100

no, because rooms are not dimensioned to the exact number given by the 
blue sheets

---

From: Loa Andersson <[email-masked]>
Date: Wed, 28 Jan 2015 06:55:42 +0800

Tom,

> 	That assumes that people don't make up more than one name.

Do we have any evidence that this is a problem?

/Loa

--

---

From: Lou Berger <[email-masked]>
Date: Tue, 27 Jan 2015 17:58:57 -0500

There are times when it can have legal benefits, for example demonstrating 
you present  for a discussion.  (Of course the opposite can occur too.)

Lou

On January 27, 2015 4:58:14 PM "Thomas D. Nadeau" <[email-masked]> 
wrote:

>
> 	I've often wondered what the point is of the sheets then.  If you don't 
> identify yourself positively, who can say you were really there especially 
> if you lurk from the back of the room?
>
> 	--Tom
>
> 	
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 27 Jan 2015 18:02:50 -0500

No. I am just asking the question as to whether these things are really effective. Sure they've been used for a Millenia, but that doesn't mean they're useful or achieving the goals they were set out to accomplish in the modern context. 

	--Tom

> On Jan 27, 2015:5:55 PM, at 5:55 PM, Loa Andersson <[email-masked]> wrote:
> 
> Tom,
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 27 Jan 2015 18:04:05 -0500

That was my point about Note Well evidence.  If you appear on a sheet, then the assertion is that you were a) at that meeting and b) agreed to Note Well conditions.   I am saying that this is not a fool-proof (or convenient in the best case) approach for a number of reasons.

	--Tom

> On Jan 27, 2015:5:58 PM, at 5:58 PM, Lou Berger <[email-masked]> wrote:
> 
> There are times when it can have legal benefits, for example demonstrating you present  for a discussion.  (Of course the opposite can occur too.)
> 
> Lou
> 
> 
> 
> 
> On January 27, 2015 4:58:14 PM "Thomas D. Nadeau" <[email-masked]> wrote:
> 
>>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 28 Jan 2015 08:55:57 +0000

On 27/01/2015 20:40, Thomas D. Nadeau wrote:
>
> Some non-antiquated approach other than manually writing down and 
> collecting names/emails on a piece of paper, needs to be taken.  We 
> signed/attended given that we use this for Note Well compliance.  If 
> someone say puts down “Mickey Mouse” as their name, that doesn’t 
> really capture their attendance.  I like the Eventbrite approach 
> Benson suggested but it has to work both for the in-person meetings as 
> well as virtual ones.
>
> —Tom
>
+1

For F2F meetings I don't see what is wrong with a bar code
reader and for that matter I would like to see one by the
microphone so that we can stop the shouts of "name" by
the poor scribe who then has to figure out how to spell that name.
It would also help the remote participants by getting them a
correctly spelled name as the person speaks.

Stewart

FWIW I would be just fine with RFID, but I understand that
others have a reluctance to go that way.

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 28 Jan 2015 09:39:04 +0000

> 	I've often wondered what the point is of the sheets then.  If you don't identify yourself positively, who can say you were really there especially if you lurk from the back of the room?
They are there for IPR reasons.

If person A fails to identify themselves correctly, then claim 
undeclared IPR,
but are later found to have concealed their identity, the courts presumably
would take an unfavorable view on their behavior.

Stewart

---

From: Yoav Nir <[email-masked]>
Date: Wed, 28 Jan 2015 11:51:43 +0200

> On Jan 28, 2015, at 11:39 AM, Stewart Bryant <[email-masked]> wrote:
> 
> If person A fails to identify themselves correctly, then claim undeclared IPR,

Only if we catch them. Which, I guess is the point of trying to get them to identify themselves in the first place.

Yoav

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Jan 2015 02:34:37 -0800

> arch-enemies without the ietf process intruding.

Where exactly is the line for the note-well today ?  I would have exected
that a BAR-BOF at the IETF would by default be inclued in note well.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 28 Jan 2015 10:51:09 +0000

I was under the impression that would be up to the bar bof itself to decide.

It may get somewhat stronger if it is something sanctioned by IETF itself, e.g. by the provision of meeting facilities.

Regards

Keith 

> From: WGChairs [mailto:[email-masked]] On Behalf 
> Of Toerless Eckert
> Sent: 28 January 2015 10:35
> To: joel jaeggli
> Cc: [email-masked]
> > should not be in scope for the note-well. you should feel free to 
> > engage in converstations with your coworkers collaborators, 
> > conspirators or arch-enemies without the ietf process intruding.
> 
> Where exactly is the line for the note-well today ?  I would 
> have exected that a BAR-BOF at the IETF would by default be 
> inclued in note well. 
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Wed, 28 Jan 2015 18:53:49 +0800

Toerless,

> that a BAR-BOF at the IETF would by default be inclued in note well.

I would say that anything that in a wide meaning is organized by the
IETF is within the Note Well.

Anything that is not organized by the IETF is not.

/Loa

--

---

From: Melinda Shore <[email-masked]>
Date: Wed, 28 Jan 2015 05:28:58 -0900

> that a BAR-BOF at the IETF would by default be inclued in note well. 

My feeling is that bar bofs should have no standing as an IETF activity,
and that "Note well" would not apply.  The institutionalization of the
bar bof is, I think, one of the things that's contributed to
organizational sludge and the fact that we're talking about blue sheets
at them should probably give us pause to think about that.  A bunch
of people getting together informally to chew the fat about a networking
problem really doesn't need any sort of IETF sanction, even if it takes
place during an IETF meeting.

Melinda

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 28 Jan 2015 09:51:41 -0500

I agree with Melinda's sentiment, but I suspect that many if not
most modern "bar BoFs" aren't actually taking place in the bar, halls, etc.
I think that it's reasonable to draw the line at whether or not the IETF
allocates resources (i.e. a room) for the meeting, rather than what the
contributors choose to name the event.
-B

---

From: Thomas D. Nadeau <[email-masked]>
Date: Wed, 28 Jan 2015 11:04:51 -0500

> On Jan 28, 2015:9:28 AM, at 9:28 AM, Melinda Shore <[email-masked]> wrote:
> 

	While I will be the first to agree with you, this is unfortunately not how the lawyers think. I've been told on a recent thread when we wanted to start using GitHub for Yang model development that even casual meetings with "IETF participants" whether official or not, discussing anything pertaining to the IETF" falls under Note Well and its IPR disclosure rules. If you read this part you will understand what I mean:

http://www.ietf.org/about/note-well.html

Statements made outside of an IETF session, mailing list or other function, that are clearly not intended to be input to an IETF activity, group or function, are not IETF Contributions in the context of this notice.  Please consult RFC 5378and RFC 3979 for details.

	I think the interpretation is that since a Bar BoF is considered to be "(eventually) intended as input to an IETF activity" Bar BoFs and similar related conversations are considered to apply.  So this is the guidance I give to people now both here, and in Yang modeling discussions.

	--Tom

---

From: Melinda Shore <[email-masked]>
Date: Wed, 28 Jan 2015 07:07:00 -0900

On 1/28/15 5:51 AM, Benson Schliesser wrote:
> most modern "bar BoFs" aren't actually taking place in the bar, halls,
> etc. I think that it's reasonable to draw the line at whether or not the
> IETF allocates resources (i.e. a room) for the meeting, rather than what
> the contributors choose to name the event. 

Yes, exactly, although I didn't want to go down that rathole (yet).
There are process costs associated with institutionalizing what used
to be very informal, ad hoc discussions.  I understand that providing
guidance to new efforts earlier can help keep them from wandering
too far into the weeds and bringing truly dreadful proposals for
chartering, but I don't think it's clear that it's been beneficial
and that it's helped reduce effort required to create new working
groups or new deliverables.

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Wed, 28 Jan 2015 07:11:41 -0900

On 1/28/15 7:04 AM, Thomas D. Nadeau wrote:
> While I will be the first to agree with you, this is unfortunately
> not how the lawyers think. I've been told on a recent thread when we
> wanted to start using GitHub for Yang model development that even
> casual meetings with "IETF participants" whether official or not,
> discussing anything pertaining to the IETF" falls under Note Well and
> its IPR disclosure rules. 

I think this interpretation can potentially lead to ridiculous
results, where private discussions could fall under Note Well
and would then need blue sheets.

Melinda

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Jan 2015 11:20:37 -0500

> and would then need blue sheets.

The issue here is that if we set up a place where YANG data models are worked on that eventually get published by the IETF, at what point do we say that the work being done at that place is covered by the Note Well?   If the answer is "not until the data model appears on an IETF mailing list or is discussed in an IETF meeting," then there is a huge gap where people can contribute to the data model without being covered by the Note Well.   At that point, I would argue that the data model is no longer a candidate for standardization in the IETF, unless everyone who contributed prior to that point can be identified somehow and asked to agree to the Note Well.

So while I sympathize with the fear of ridiculous results, we also need to make sure that actual work that's going to be published by the IETF was done under the Note Well rules, or else we have to accept that the IETF may standardize something that is covered by IPR that is known to someone who produced the standard, but who is in no way obligated to disclose that knowledge until the time comes to cash in.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 28 Jan 2015 11:26:36 -0500

Trust me, I was astonished by this assertion too. My first thought was, "How is that enforced?"  Further, as you say, it adds to the "sludge" around here that is slowing things down without very much measurable benefit. I've attached one of the notes from the thread I am referring at the bottom to that might clarify my statement. Specifically the part that begins with, "...But if those friends are folks you only know through the IETF..."

	The bottom line here is that perhaps someone needs to revisit all of this within the current context of the universe in an effort to still meet the spirit of Note Well/etc... but without unnecessary burdens?

	--Tom

> On Jan 28, 2015:11:11 AM, at 11:11 AM, Melinda Shore <[email-masked]> wrote:
> 

> Begin forwarded message:
> 
> Date: July 17, 2014 at 3:27:45 PM EDT
> From: Pete Resnick <[email-masked]>
> To: "Thomas D. Nadeau" <[email-masked]>
> Cc: Barry Leiba <[email-masked]>, IETF Trustees <[email-masked]>, Crabbe Edward <[email-masked]>, "[email-masked]" <[email-masked]>, IESG <[email-masked]>, <[email-masked]>, "[email-masked]" <[email-masked]>, Scott Bradner <[email-masked]>
> Subject: Re: [Trustees] "IETF Contribution" and github
> Resent-To: [email-masked], [email-masked],
> Resent-From: [email-masked]
> 
> On 7/17/14 11:10 AM, Thomas D. Nadeau wrote:
>> I am saying that in one large set of cases, there is no such thing going on here. These are individuals working on files outside of the IETF process.  There is no record of this on any IETF mailing list, i-d repository entry or otherwise. They are just files being worked on outside with the possible intent of being brought in someday.
>>   
> 
> Nope. If you edit and submit that file to github *with the intent that your edits are going to be part of that I-D*, whether or not it has hit the I-D repository, you have made an IETF contribution. You can try to argue later about your intent if you want to claim that the IETF does not have rights to the text you submitted, but if the text already has the IETF boilerplate on it you're going to have a hard time doing that. And if you hold patents on the technology about which you're writing and don't disclose that fact to the IETF, and then later those patents come into dispute, I doubt your attorney is going to be very excited about you trying to claim that it wasn't your intent to make them part of an I-D and therefore you had no duty to disclose.
> 
> Of course you and some friends can get together and write some text (without IETF boilerplate) and put it on github with no obvious indication that your intent is eventually to make it part of an I-D or RFC. But if those friends are folks you only know through the IETF, and the text looks a heck of a lot like something you're going to be putting into an I-D, you're skating on thin ice. Note the text in BCP 78:
> 
>      Statements made outside of an IETF session, mailing list, or other
>      function, that are clearly not intended to be input to an IETF
>      activity, group, or function are not IETF Contributions in the
>      context of this document.
> 
> If I create some text in github and I intend for it to be part of an I-D, I better give you fair warning (either through some copyright text in the file itself, or through some "Note Well" text somewhere in the repo) that lets you know that if you edit the file, you're contributing. If I give you that fair warning, you either play by the rules or you're violating *my* (and the IETF's) copyright.
> 
> Let's remember that our "rules" have two functions: The first is obviously, "Do the right thing for the IETF". With regard to copyright, that means we don't want you contributing something and then coming back later and saying that the IETF has no rights to publish it.  With regard to patents, that means we want you to disclose patents you hold that cover the technology in the contribution so we know about them and can decide what, if anything, to do about them. Along those lines, all that's important for our rules is that the IETF doesn't mistake something for a contribution when it's not, and neither do you. All that requires is that we make those "fair notices". If a particular github repo is intended to be used for the IETF, we should label it as such.
> 
> But there's a second function of our rules, and it's most important in patents: If our rules say you have to make disclosures for your contributions, *you* want to make sure that you make those disclosures or you risk losing the ability to assert your patents, because courts have found that if you violate the rules of an SDO, you're out of luck. The IETF doesn't care one way or the other about that; that's an argument in court between you and the other side (and the judge) about what was and was not a contribution. If *I* were making contributions to a github repo that even smelled like it might be an IETF contribution and I had patents I wanted to assert, *I* would assume that it was a contribution and act accordingly.
> 
>> 	Now I might agree with you in the case of the experiment that Benoit and I setup for 3 specific modules. We set that up in our roles as AD and co-chair, and so you are probably right here.  But what if we didn't explicitly state that anywhere?
>>   
> 
> Depends on what copyright statement is on top of the document, and what announcement text you put in the repo, and what the intent of the players is.
> 
>> Again, the point is that the rules/procedures being discussed here need to be adapted for the modern agile software development process.  People are working on code, and not just documents that are run through the IETF processes. We need to embrace and accommodate that or people are just going to go elsewhere.
> 
> The rules really do already cover this case.
> 
> pr
> 
> -- 
> Pete Resnick<http://www.qualcomm.com/~presnick/>
> Qualcomm Technologies, Inc. - +1 (858)651-4478
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Jan 2015 11:29:15 -0500

> 	The bottom line here is that perhaps someone needs to revisit all of this within the current context of the universe in an effort to still meet the spirit of Note Well/etc... but without unnecessa…

In what sense is agreeing to the Note Well a "burden"?

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 28 Jan 2015 11:33:44 -0500

> On Jan 28, 2015:3:55 AM, at 3:55 AM, Stewart Bryant <[email-masked]> wrote:
> 

	I thought ‘RFID’ as soon as I read your first sentence. Brilliant, simple and doable.

	—Tom

---

From: Melinda Shore <[email-masked]>
Date: Wed, 28 Jan 2015 07:35:25 -0900

> In what sense is agreeing to the Note Well a "burden"?

In the sense that it carries with it process requirements,
like blue sheets.

Melinda

---

From: joel jaeggli <[email-masked]>
Date: Wed, 28 Jan 2015 08:36:31 -0800

> that a BAR-BOF at the IETF would by default be inclued in note well. 

IMHO  a BAR-BOF that adopts the trappings of an IETF activity for the
purpose of throwing on some mantle of legitimacy with respect the ietf
process is cargo-culting.

There are multiple reasons why you might want to keep track of the
participants in an informal meeting such as gauging interest or forming
a mailing list, by all means do so.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 28 Jan 2015 11:38:30 -0500

Its not Note Well, but how we document said agreement.

	--Tom

> On Jan 28, 2015:11:29 AM, at 11:29 AM, Ted Lemon <[email-masked]> wrote:
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Jan 2015 12:06:20 -0500

> In the sense that it carries with it process requirements,

Git has commit logs, which would serve the same purpose if handled correctly.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Jan 2015 12:07:30 -0500

> 	Its not Note Well, but how we document said agreement.

That would imply all the burden of the Note Well, without the language the IETF's crack legal team came up with.   I don't see the point.

---

From: joel jaeggli <[email-masked]>
Date: Wed, 28 Jan 2015 10:30:51 -0800

> Only if we catch them. Which, I guess is the point of trying to get them to identify themselves in the first place.

If you set out to insert a submarine, at some point it has to surface.
bad actors will eventually found out, if they have contributions
attempts to subvert the process of staying aboveboard along the way are
not looked on favorably by the courts.

The easiest way to play is to not be a bad actor.

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 28 Jan 2015 13:53:04 -0500

joel jaeggli wrote:
>>> On Jan 28, 2015, at 11:39 AM, Stewart Bryant<[email-masked]>  wrote:
>>>

Granted. But the easiest way to prove somebody is/was a bad actor is to have good records. I.e that they were in attendance. I can't think of any benefit to anybody (except potential bad actors) in avoiding good record-keeping. Assuming it's easy to implement, that is.

In some cases it's easier to implement mandatory blue sheets, rather than optional blue sheets. E.g. such as virtual interims. If that would be easier on the chairs and better for the record-keeping, why wouldn't we just do it? Am I missing something?

As for verifying that names are real, this is admittedly a larger problem.

Cheers,
-Benson

---

From: joel jaeggli <[email-masked]>
Date: Wed, 28 Jan 2015 11:11:57 -0800

On 1/28/15 10:53 AM, Benson Schliesser wrote:
>>> Only if we catch them. Which, I guess is the point of trying to get
>>> them to identify themselves in the first place.
>>
> Granted. But the easiest way to prove somebody is/was a bad actor is to
> have good records. I.e that they were in attendance. I can't think of
> any benefit to anybody (except potential bad actors) in avoiding good
> record-keeping. Assuming it's easy to implement, that is.
> 
> In some cases it's easier to implement mandatory blue sheets, rather
> than optional blue sheets. E.g. such as virtual interims. If that would
> be easier on the chairs and better for the record-keeping, why wouldn't
> we just do it? Am I missing something?

I don't think virtual interims are controversial. they're ietf meetings
full stop.

bar bofs, random meetings between co-conspirators and so on are not ietf
meetings.

pre-draft contributions by unknown  parties seems like a bit of a red
herring,  as an author I want all the contributions to my document to be
attributed. accordingly I either gatekeep that process myself or use a
process which insures that they can be. If it works for the linux kernel
it'll work for my crappy internet draft. As an author I have to state in
good faith what my knowledge on IPR with respect to the document is if I
cannot then I have a bit of a problem.

> As for verifying that names are real, this is admittedly a larger problem.

the ietf process is for the benefit of the good actors, not the bad
ones. Like the subjects of Hammurabi I have no tool that can assure that
bad actors don't misrepresent themselves short of the threat of future
coercive action, public vilification, and so on.

---

From: Melinda Shore <[email-masked]>
Date: Wed, 28 Jan 2015 10:53:27 -0900

> bar bofs, random meetings between co-conspirators and so on are not ietf

Yes, exactly.  But there's a problem that Benson raised earlier, and
that's that some of these "bar bofs" are getting IETF meeting space
and setting themselves up as a faux IETF session, with slides,
auditorium seating, and so on.  There's not that much that the IESG
can do about the format but the fact that there's some filtering of
what will and will not get IETF meeting room space is potentially
problematic, as far as the "note well" situation and IPR problem
and whatnot go.

Melinda

---

From: joel jaeggli <[email-masked]>
Date: Wed, 28 Jan 2015 12:05:46 -0800

> problematic, as far as the "note well" situation and IPR problem

Literally anyone who wants to can book a meeting room in the fairmont
during the IETF and do whatever is allowed within the bounds of their
contract with the hotel in it.

for my sake I hope they have an open bar.

joel

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 28 Jan 2015 21:08:36 +0100

For what it's worth ...

> problematic, as far as the "note well" situation and IPR problem

Speaking as one AD, and as a recovering IAB member ...

The process the IETF uses to charter new work is one of the few
opportunities the IESG has to steer at a level less granular than
individual documents, and it's one of the places the IAB is explicitly
pointed in carrying out their chartered responsibility for architectural
oversight.

I can't speak for the IAB, but I can say that from my perspective, Bar BOFs
that are indistinguishable from BOFs don't help the IESG steer.

Spencer

---

From: Melinda Shore <[email-masked]>
Date: Wed, 28 Jan 2015 11:35:14 -0900

On 1/28/15 11:08 AM, Spencer Dawkins at IETF wrote:
> I can't speak for the IAB, but I can say that from my perspective, Bar
> BOFs that are indistinguishable from BOFs don't help the IESG steer.

I believe the core problem is this:
https://www.ietf.org/meeting/amreq.html

As long as IESG members are filtering those requests on merit, and
providing IETF space for some technical (fsvo "technical" in many
cases) discussions not associated with a specific working group
deliverable, there's going to be some confusion.

It's time to start a movement: let's move bar BOFs back to the bars.

Melinda

---

From: Lou Berger <[email-masked]>
Date: Wed, 28 Jan 2015 15:37:34 -0500

On 1/28/2015 3:08 PM, Spencer Dawkins at IETF wrote:
> ... Bar BOFs that are indistinguishable from BOFs don't help the IESG
> steer.

and are a bad idea.

BTW  can we start pointing folks requesting 'bar bofs' to RFC6771?

Lou

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 29 Jan 2015 09:48:56 -0500

+1

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 29 Jan 2015 10:05:08 -0500

> contract with the hotel in it.
 Yes, but they can't (legally) call it an IETF meeting unless the IETF
gives permission. That permission typically comes when IETF coordinates the
meeting. Even in absence of coordination, I'd argue it should apply when
IETF allocates resources for it. Thus my view that Note Well applies in
these cases, along with blue sheets.

Cheers,
-Benson