Subject: Re: Area Merging: A Transport Perspective

From: Tim Chown <[email-masked]>
Date: Fri, 2 Jan 2015 11:54:26 +0000

> On 29 Dec 2014, at 09:07, [email-masked] wrote:
> 
> As David's Co-Chair in TSV WG, I agree with most of what has been said
> about transport work by Brian and David.
> 
> At one time the role of transport may have been largely about using
> existing transports, that's not the case right now. There's quite a bit of
> work on new transport protocol mechanisms now in progress, and the level
> of new work does not look like reducing in the near future. While some of
> the TSV work could move elsewhere (if expertise is greater), I can't see a
> general amalgamating this with upper layer work would help.

It’s certainly an interesting discussion.

I think from the WG chair’s point of view, what we’d like to see is required actions on outputs from the WG being taken by ADs within a reasonable timeframe. I don’t personally mind too much how the ADs arrange this, but it does seem fairly clear when speaking to the ADs that I interact with that they are rather heavily loaded, or overloaded. The question is how to resolve this, to help the ADs help us.

We either have to reduce the amount of material we’re producing, which might mean a higher hurdle to jump to get new work chartered to WGs or adopted by existing WGs, or beef up the AD level support that we have.

One option is to add more ADs for specific Areas which are growing or highly active, whether as full ADs or interim assistant ADs. This seems a natural thing to do, though it would increase the size of the IESG if additional full ADs were appointed.

Like Gorry and others, I’m less sure that effectively merging Area coverage is a good thing to do, for reasons already stated.

Another option is to make wider or bigger use of directorates, which do seem to operate in different ways. The Operations Area directorate has a nicely managed document review system for example, although the availability of reviewers will vary over time. 

One thing to always consider is around that topic of availability. There’s only so many people who are able to take up AD positions, due to their day job, and thinking creatively about how to allow more people to help with the load part time may well allow appropriately skilled and knowledgeable people to ease the AD load, either through having formal assist ADs who might be ‘expected’ to put in a day a week, or more people working on reviews etc on directorates.

A final question might be how/when the AD workload situation should be reviewed on an ongoing basis.

Tim

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 2 Jan 2015 08:39:28 -0600

Hi, Tim,

On Jan 2, 2015 5:56 AM, "Tim Chown" <[email-masked]> wrote:
> I think from the WG chair’s point of view, what we’d like to see is
required actions on outputs from the WG being taken by ADs within a
reasonable timeframe. I don’t personally mind too much how the ADs arrange
this, but it does seem fairly clear when speaking to the ADs that I
interact with that they are rather heavily loaded, or overloaded. The
question is how to resolve this, to help the ADs help us.
>
> We either have to reduce the amount of material we’re producing, which
might mean a higher hurdle to jump to get new work chartered to WGs or
adopted by existing WGs, or beef up the AD level support that we have.
>
> One option is to add more ADs for specific Areas which are growing or
highly active, whether as full ADs or interim assistant ADs. This seems a
natural thing to do, though it would increase the size of the IESG if
additional full ADs were appointed.
>
> Like Gorry and others, I’m less sure that effectively merging Area
coverage is a good thing to do, for reasons already stated.
>
> Another option is to make wider or bigger use of directorates, which do
seem to operate in different ways. The Operations Area directorate has a
nicely managed document review system for example, although the
availability of reviewers will vary over time.
>
> One thing to always consider is around that topic of availability.
There’s only so many people who are able to take up AD positions, due to
their day job, and thinking creatively about how to allow more people to
help with the load part time may well allow appropriately skilled and
knowledgeable people to ease the AD load, either through having formal
assist ADs who might be ‘expected’ to put in a day a week, or more people
working on reviews etc on directorates.
> A final question might be how/when the AD workload situation should be
reviewed on an ongoing basis.

This note is a good summary of the issues as I understand them.

Thanks for sending it.

Spencer