Subject: Fwd: Re: Strong objection to draft-ietf-WG-*.all noise levels

From: Robert Sparks <[email-masked]>
Date: Mon, 09 Feb 2015 16:26:39 -0600

Forwarding in case anyone here is not watching [email-masked].

RjS

-------- Forwarded Message --------
Subject: 	Re: Strong objection to draft-ietf-WG-*.all noise levels
Date: 	Mon, 09 Feb 2015 16:25:12 -0600
From: 	Robert Sparks <[email-masked]>
To: 	[email-masked]

One detail that's a consequence of what's below that I wanted to highlight:

If a group is getting copied on the state change notices for a document
right now, it's because the group is listed in the "Send notices to"
(aka Notify) field in the datatracker. If a chair wants to alter that
for a document (or all documents for a group), they can do so by editing
the notify field (or asking their AD to do so). In any case, I suggest
coordinating that with the appropriate AD given what's in the links I
sent below.

RjS

On 2/9/15 2:11 PM, Robert Sparks wrote:
> Hi Brian:
>
> There are a couple of moving targets in what you're objecting to that
> I think we need to be careful to tease apart.
>
> Here's a bit of detail to help with that (I hope):
>
> 1) the .all alias includes any address that is covered by any other
> generated alias (currently that's .authors, .chairs, .ad, and .notify)
>
> 2) the .notify alias is populated directly from the Notify field for a
> draft in the tracker. You can see what that's currently set to for a
> draft by looking at the "Send notifications to" line on the document's
> main page.
>
> 3) The IESG directed that when a working group draft begins IESG
> processing, the working group be added to the notify field by default.
> See
> http://www.ietf.org/mail-archive/web/wgchairs/current/msg12989.html
> and
> http://www.ietf.org/mail-archive/web/wgchairs/current/msg12992.html
>
> So, I _think_ the conversation you need to be having to address your
> objection is with the IESG on the decision to add the group to the
> default notification list.
>
> That said, there are some things we're doing to the aliases to make
> where things are coming from easier to figure out. None of what's
> below will change whether a working group gets the state-change
> notifications, but it may help explain other aspects of what you've
> been recently seeing.
>
> 4) We're working on providing pages that show the expansions of the
> aliases at ietf.org similar to the pages that are at tools.ietf.org.
> This isn't happening immediately because the mail processing systems
> are different, and there are some extra gears that we're having to
> incorporate.
>
> 5) The most recent datatracker releases have made incremental changes
> to the way the aliases are used. In particular, mail sent through the
> aliases should end up with fully expanded To header fields at this
> point. We are also working on adding the fields (already present when
> using @tools.ietf.org aliases) that make it easy to see exactly what
> alias got invoked.
>
> 6) From the links above, you'll see that part of the  original
> implementation was to add .all to the Notify field (in addition to the
> working group). That led to some trouble since .all contains .notify -
> there's an include loop, and some of the dynamics of integrating with
> the mail handling at @ietf.org vs @tools.ietf.org led to not catching
> that loop in the right place (this was affecting a few drafts last
> week). This has been addressed, both by more careful loop protection,
> and by changing what gets put in Notify to not use .all directly.
>
> Again, those last 3 items are just part of the context - they don't
> affect the primary concern you're raising. That lives solidly with
> spirit of the decision at item 3) above.
>
> RjS
>
> On 2/9/15 1:00 PM, Brian E Carpenter wrote:
>> Hi,
>>
>> I see that the tracker has started using email aliases of the
>> form [email-masked] to report on state changes,
>> and that these aliases now apparently include the WG as well
>> as the interested parties.
>>
>> This is highly obnoxious. One problem is that for most recipients
>> the messages are pure noise (and any follow-up messages whose CC
>> list isn't manually pruned are additional noise). Another problem
>> is that they are in effect BCC'ed to the WG, so existing filters
>> don't catch these messages. A consequent problem of that is that
>> many people are likely to do what I'm about to do: figure out how
>> to spam filter all this noise, thereby risking to miss any such messages
>> that actually matter.
>>
>> Please please please remove the WG lists from these aliases.
>> If something really needs to be brought to the WG's attention,
>> there are people who know they should do that.
>>
>> Regards
>>     Brian Carpenter
>>
>>
>

---

From: Pete Resnick <[email-masked]>
Date: Mon, 9 Feb 2015 16:56:19 -0600

> Forwarding in case anyone here is not watching [email-masked].

And my reply:

-------- Original Message --------
Subject: 	Re: Strong objection to draft-ietf-WG-*.all noise levels
Resent-From: 	<[email-masked]>
Date: 	Mon, 9 Feb 2015 16:49:48 -0600
From: 	Pete Resnick <[email-masked]>
To: 	Robert Sparks <[email-masked]>
CC: 	[email-masked]

On 2/9/15 2:11 PM, Robert Sparks wrote:
>  I _think_ the conversation you need to be having to address your

That's fair. Speaking as one of the folks involved in the change:

The IESG, in part at the behest of the community, wanted to (by default)
make sure that IESG ballots were copied to the WG mailing list instead
of being a private conversation between the authors, the chairs, and the
IESG, invisible to anyone else in the community. Seeing the ballots can
always be turned off on a case-by-case basis, but it seemed better to
have that as default instead of having to remember to turn it on on a
case-by-case basis.

Now, the mechanism used to accomplish that (adding the WG to the .notify
alias, which in turn adds it to the .all alias) sends *all*
notifications regarding a document to the WG by default. Perhaps we want
to change that.

Are there particular notifications that you *don't* want copied to the
WG? Or maybe more to the point, are there notifications that you *do*
want copied to the WG?

We'll work with the tools folks to make the right thing happen.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Mary Barnes <[email-masked]>
Date: Mon, 9 Feb 2015 17:05:33 -0600

I personally did not find the change useful in the first place.  As others
have noted on the IETF discussion thread, to some of us it only makes sense
to send things to the WG if there is a real need.  I would rather the
default go back to what it was rather than have chairs have to go change it
for all documents. But, I guess it's YMMV. However, ISTM that a number of
WG participants are bothered by it.

It was never clear to me that it provided any benefit to anyone except in
cases where perhaps WG chairs and ADs weren't going back to WGs for
substantial issues that ought to have been run by the WG.  But, I think the
assumption that  this tool change actually helped address that problem was
misplaced as I think people are probably not even reading those emails and
ADs, chairs and authors may now be less conscientious about spelling out
significant changes because they're assuming people ought to have seen
them.   The ballots are public information and anyone can read those at
anytime and if things are done properly, there should be enough detail in
those as to issues and resolution.

Regards,
Mary.

On Mon, Feb 9, 2015 at 4:56 PM, Pete Resnick <[email-masked]>
wrote:

> -------- Original Message --------  Subject: Re: Strong objection to
> draft-ietf-WG-*.all noise levels  Resent-From: <[email-masked]>
> <[email-masked]>  Date: Mon, 9 Feb 2015 16:49:48 -0600  From: Pete
> Resnick <[email-masked]> <[email-masked]>  To: Robert
> Sparks <[email-masked]> <[email-masked]>  CC: [email-masked]
>
> Pete Resnick<http://www.qualcomm.com/~presnick/> <http://www.qualcomm.com/~presnick/>

---

From: Pete Resnick <[email-masked]>
Date: Mon, 9 Feb 2015 17:14:48 -0600

Speaking only for myself:

Mary, this is one where we're going to have to agree to disagree. Yes, 
ballots are public. The entire discussion that occurs in email after the 
ballot is not, and that is simply not acceptable to me, and I'd venture 
to a bunch of other IETFers. I think it goes directly in the face of the 
openness and consensus that we purport to use, and it invites (and 
actually has produced) backroom deals that fly in the face of WG 
consensus. We should not need to trust chairs, authors, and ADs to 
identify those issues that the WG should care about. The WG should be 
able to see for themselves. We have talked about other mechanisms, where 
those messages could be copied to a separate archive, and I'd be OK with 
that, but I think copying the WG on discussions the authors and chairs 
are having with the IESG is absolutely the right thing to do.

All that said, I don't think we should re-hash that entire discussion. 
The question on the table is about other notifications, and which of 
those the WG wants to (and should) see.

pr

On 2/9/15 5:05 PM, Mary Barnes wrote:
> I personally did not find the change useful in the first place.  As 
> others have noted on the IETF discussion thread, to some of us it only 
> makes sense to send things to the WG if there is a real need.  I would 
> rather the default go back to what it was rather than have chairs have 
> to go change it for all documents. But, I guess it's YMMV. However, 
> ISTM that a number of WG participants are bothered by it.
>
> It was never clear to me that it provided any benefit to anyone except 
> in cases where perhaps WG chairs and ADs weren't going back to WGs for 
> substantial issues that ought to have been run by the WG.  But, I 
> think the assumption that  this tool change actually helped address 
> that problem was misplaced as I think people are probably not even 
> reading those emails and ADs, chairs and authors may now be less 
> conscientious about spelling out significant changes because they're 
> assuming people ought to have seen them.   The ballots are public 
> information and anyone can read those at anytime and if things are 
> done properly, there should be enough detail in those as to issues and 
> resolution.
>
> Regards,
> Mary.
>
> On Mon, Feb 9, 2015 at 4:56 PM, Pete Resnick 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>>     Forwarding in case anyone here is not watching [email-masked]
>>     <mailto:[email-masked]>.
>
>     And my reply:
>
>
>     <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     CC: 	[email-masked] <mailto:[email-masked]>
>
>
>
>     Pete Resnick<http://www.qualcomm.com/~presnick/>  <http://www.qualcomm.com/%7Epresnick/>
>     Qualcomm Technologies, Inc. -+1 (858)651-4478  <tel:%2B1%20%28858%29651-4478>
>
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 09 Feb 2015 23:18:58 +0000

Hiya,

On 09/02/15 23:14, Pete Resnick wrote:
> to a bunch of other IETFers.

Have to say I agree with Pete on discuss resolution emails - those can
be fairly wide ranging discussions that WG's should see in many cases.
(Or maybe that's just the security ones:-)

As I recall it when the IESG discussed this, there was a good bit of
support for doing it, but if we can do this better, then yes we should
improve it. I agree the notification stuff isn't useful so if we could
reduce the mail to the wg to that sent by humans would that be ok?

S.

---

From: "Black, David" <[email-masked]>
Date: Mon, 9 Feb 2015 23:29:19 +0000

And the proximate problem is a tools problem where the WG list is getting BCC'd instead of explicitly addressed.  That sends mail to spam traps, including in the IETF's own mailman system (requiring an explicit destination address is a recommended mailman setting).  Right now, the tools need to explicitly address the WG lists and stop using BCC, ASAP, please ... it's really annoying when email from a WG chair to his/her own list gets held for moderation.

Thanks,
--David

From: WGChairs [mailto:[email-masked]] On Behalf Of Pete Resnick
Sent: Monday, February 09, 2015 6:15 PM
To: Mary Barnes
Cc: <[email-masked]>; Robert Sparks
Subject: Re: Fwd: Re: Strong objection to draft-ietf-WG-*.all noise levels

Mary, this is one where we're going to have to agree to disagree. Yes, ballots are public. The entire discussion that occurs in email after the ballot is not, and that is simply not acceptable to me, and I'd venture to a bunch of other IETFers. I think it goes directly in the face of the openness and consensus that we purport to use, and it invites (and actually has produced) backroom deals that fly in the face of WG consensus. We should not need to trust chairs, authors, and ADs to identify those issues that the WG should care about. The WG should be able to see for themselves. We have talked about other mechanisms, where those messages could be copied to a separate archive, and I'd be OK with that, but I think copying the WG on discussions the authors and chairs are having with the IESG is absolutely the right thing to do.

All that said, I don't think we should re-hash that entire discussion. The question on the table is about other notifications, and which of those the WG wants to (and should) see.

pr

On 2/9/15 5:05 PM, Mary Barnes wrote:
I personally did not find the change useful in the first place.  As others have noted on the IETF discussion thread, to some of us it only makes sense to send things to the WG if there is a real need.  I would rather the default go back to what it was rather than have chairs have to go change it for all documents. But, I guess it's YMMV. However, ISTM that a number of WG participants are bothered by it.

It was never clear to me that it provided any benefit to anyone except in cases where perhaps WG chairs and ADs weren't going back to WGs for substantial issues that ought to have been run by the WG.  But, I think the assumption that  this tool change actually helped address that problem was misplaced as I think people are probably not even reading those emails and ADs, chairs and authors may now be less conscientious about spelling out significant changes because they're assuming people ought to have seen them.   The ballots are public information and anyone can read those at anytime and if things are done properly, there should be enough detail in those as to issues and resolution.

Regards,
Mary.

On Mon, Feb 9, 2015 at 4:56 PM, Pete Resnick <[email-masked]<mailto:[email-masked]>> wrote:
On 2/9/15 4:26 PM, Robert Sparks wrote:
Forwarding in case anyone here is not watching [email-masked]<mailto:[email-masked]>.

And my reply:

-------- Original Message --------
Subject:

Re: Strong objection to draft-ietf-WG-*.all noise levels

Resent-From:

<[email-masked]><mailto:[email-masked]>

Date:

Mon, 9 Feb 2015 16:49:48 -0600

From:

Pete Resnick <[email-masked]><mailto:[email-masked]>

To:

Robert Sparks <[email-masked]><mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>

case-by-case basis.

to change that.

want copied to the WG?

pr

--

Pete Resnick<http://www.qualcomm.com/~presnick/><http://www.qualcomm.com/%7Epresnick/>

Qualcomm Technologies, Inc. - +1 (858)651-4478<tel:%2B1%20%28858%29651-4478>

--

Pete Resnick <http://www.qualcomm.com/~presnick/><http://www.qualcomm.com/~presnick/>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 9 Feb 2015 17:34:17 -0600

> reduce the mail to the wg to that sent by humans would that be ok?

[MB] That might help.  We probably should ask that question on
IETF-discussion since that's where this thread started.   As Pete said we
discussed this a tiny bit before the change was made on this mailing list,
but I don't think it ever went to IETF discussion list, did it?  It does
seem that Suzanne's reflection has happened (and clearly I am now
officially an IETF curmudgeon):
https://www.ietf.org/mail-archive/web/wgchairs/current/msg13008.html
[/MB]