Subject: tools email addresses broken?

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 27 Feb 2015 13:14:31 -0500 (EST)

Hi all,

I think that all of my messages to draft- and -chairs aliases
@tools.ietf.org over the past week have been silently not delivered to the
expected (expanded) recipients.

Is anyone else seeing this?  (Has anyone seen successful delivery to such
aliases in the past week?)

Thanks,

Ben

---

From: Yoav Nir <[email-masked]>
Date: Fri, 27 Feb 2015 20:23:07 +0200

Yes, we’ve had this issue with messages from IANA about draft-irtf-cfrg-chacha20-poly1305 not being delivered.

> On Feb 27, 2015, at 8:14 PM, Benjamin Kaduk <[email-masked]> wrote:
> 
> Hi all,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Feb 2015 19:41:29 +0100

Hi Benjamin,

> aliases in the past week?)

As recently as yesterday, I ran tests on a couple of specific draft-* and
*-chairs aliases, and they worked.  If you have specific examples, I can check
the logs on tools.ietf.org and ietf.org to see if there has been failures.

I expect there to be changes in the details of alias expansion, since
the draft-* aliases are now expanded on @ietf.org.  Addresses @tools.ietf.org
now just forwards to ietf.org for expansion.

*-chairs addresses are still being expanded on tools.ietf.org (and also
on ietf.org, if you use a [email-masked] address.

I'm happy to look into any and all cases of non-delivery you may have, but
I need specifics in order to check the logfiles.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Feb 2015 19:42:48 +0100

Hi Yoav,

> Yes, we’ve had this issue with messages from IANA about draft-irtf-cfrg-chacha20-poly1305 not being delivered.

Did the message go to [email-masked]
or to [email-masked]?

Best regards,

	Henrik

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 27 Feb 2015 13:45:30 -0500 (EST)

Hi Henrik,

> now just forwards to ietf.org for expansion.

Thank you for the updates about these changes.

> I need specifics in order to check the logfiles.

I will send a few examples that I believe are non-delivery to you,
unicast.

Thanks again,

Ben

---

From: Yoav Nir <[email-masked]>
Date: Fri, 27 Feb 2015 20:46:33 +0200

It was sent to the @tools.ietf.org alias.

> On Feb 27, 2015, at 8:42 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Yoav,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Feb 2015 19:48:54 +0100

Thanks, Yoav.

I'll report back to you with details from the logs off-list.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Feb 2015 20:15:47 +0100

Hi,

I've traced all the emails to [email-masked]
yesterday through the tools.ietf.org server and mail.ietf.org on to delivery
to the recipients' MTAs.

However, I think I need to mention that the extra Resent-To: header
fields which I had the tools.ietf.org mail server insert, in order to make
filtering easier, are _not_ currently being inserted by the alias expansion
on mail.ietf.org.  I've been working with the secretariat to put this back
in place, but at the moment they are missing.

This could of course be causing mis-filing for those who are relying on
that header field being present :-(

Regards,

	Henrik

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 27 Feb 2015 14:26:03 -0500

In case it may be of use to others --

I find that I can't get email through to @tools.ietf.org aliases any more; however, @ietf.org works for me. Henrik, you may recall that when you looked into my problem earlier, you had this to say:

> I've checked the mail server logs. What seems to be happening is
> this:
>  
> The tools server uses greylisting as one of several measures against
> spam. This means that messages which have an intermediate spam score
> (not low enough to go through immediately, and not high enough to be
> blocked immediately) are delayed -- the sending mail server is told to
> try again in a while. John's recent messages have fallen in this
> intermediate range. However, for these messages I see that the
> repeated delivery requests (for the same message ID) occur from new IP
> addresses every time, which means that they will never be registered
> as repeat requests, and will be told to come back later again and
> again ...
>  
> I'm not sure if this is a bug in the greylist handling in my server,
> or a bug in how the sending mail server handles repeat delivery
> requests, but always re-trying from new IP addresses definitely
> strikes me as unusual...
>  
> The reason why John's messages get a too high spam score to go through
> immediately seem to a large extent to be that the sending mail servers
> are sending from IP addresses that don't match the addresses that
> their HELO names resolve to.

It may be that others who outsource their mail to the same provider my employer uses, are encountering the same thing. FWIW I tried getting the problem resolved through my IT organization but as usual, F. Kafka is in charge there and satisfaction was not easily received, so since I have a good workaround (use the @ietf.org aliases) I just gave up.

By the way, I have no idea why the pathology described in the quotation above would occur for email directed to @tools.ietf.org aliases, but not when targeted to @ietf.org, but again, since I have a workaround in hand I'm not motivated to spend more time investigating.

--John

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Feb 2015 20:34:41 +0100

Hi John,

As to this particular point:

On 2015-02-27 20:26, John G. Scudder wrote:
> By the way, I have no idea why the pathology described in the
> quotation above would occur for email directed to @tools.ietf.org
> aliases, but not when targeted to @ietf.org, but again, since I have
> a workaround in hand I'm not motivated to spend more time
> investigating.

I believe that mail.ietf.org isn't using greylisting, but relies on a
spam filtering in combination with postconfirm.

Best regards,

	Henrik