Subject: Upcoming change to the Notify field for some documents

From: Robert Sparks <[email-masked]>
Date: Wed, 15 Apr 2015 13:39:52 -0500

Working group chairs and IESG members -

The next release of the datatracker will contain the first steps towards 
changing how a working group list gets copied when an AD enters a ballot 
position.
Once that release is in place, I will be running a script that will 
scrub working group lists out of the Notify fields where they occur (276 
documents at the moment).
This is part of addressing the issue that several of you are 
experiencing with mail sent to the .all alias for a document going into 
moderation at your group's list because of an implicit destination.

That script will email the WG personnel (chairs, shepherds, ads) to let 
them know what got changed.
Below, you'll find an example of what will be sent to the personnel for 
one of the groups with the largest count of affected documents.
Please read the text of the example - it explains the history leading up 
to this change in a little more detail.

If you do not want the documents for your working group to be changed, 
reply to me ASAP (and be sure to copy your AD),
and I will exclude your group from what the script will work on.

If all goes well with the upcoming release, I expect to run this script 
late in the day tomorrow.

RjS

---------------------
EXAMPLE MESSAGE FOLLOWS
(this is only an example - these changes have not yet been made to the 
production database)
---------------------
To: <[email-masked]>, <[email-masked]>, <[email-masked]>, 
<[email-masked]>
Subject: Removed the working group list address from the Notify field of 
22 mpls drafts

The Notify field for the documents listed at the end of this message 
were changed by removing the mpls mailing list address [email-masked]'.

For most documents, this address was introduced to the Notify field 
between November 2014 and March 2015 as part of the default value 
assigned when the document entered IESG processing. This was a first try 
at ensuring the working group sees ballot positions as the ADs enter 
them. However, it had several unintended consequences. In particular, 
since the contents of the Notify field are expanded into each document's 
.all alias, messages sent by individuals to the .all alias often ended 
in the list's moderation queue for having an implicit destination.

Instead, the datatracker has been modified to send ballot positions to 
the working group list explicitly, under the balloting AD's control, and 
we are scrubbing the list addresses from the Notify fields.

If you had included the working group list address in the Notify field 
for some reason other than it showing up by default during the above 
period, please use the datatracker to put it back into the field (or ask 
the secretariat to do so for you), and accept our apologies for the 
inconvenience.

The affected documents for mpls appear below:
     https://datatracker.ietf.org/doc/draft-ietf-mpls-ldp-ipv6/
https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-reply-mode-simple/
     https://datatracker.ietf.org/doc/draft-ietf-mpls-seamless-mpls/
https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf/
     https://datatracker.ietf.org/doc/draft-kompella-mpls-rsvp-ecmp/
     https://datatracker.ietf.org/doc/draft-ietf-mpls-seamless-mcast/
     https://datatracker.ietf.org/doc/draft-ietf-mpls-tp-oam-id-mib/
https://datatracker.ietf.org/doc/draft-cheng-mpls-tp-shared-ring-protection/
     https://datatracker.ietf.org/doc/rfc7510/
https://datatracker.ietf.org/doc/draft-ravisingh-mpls-el-for-seamless-mpls/
     https://datatracker.ietf.org/doc/draft-ietf-mpls-proxy-lsp-ping/
https://datatracker.ietf.org/doc/draft-ietf-mpls-mldp-node-protection/
https://datatracker.ietf.org/doc/draft-mirsky-mpls-residence-time/
     https://datatracker.ietf.org/doc/draft-kompella-mpls-larp/
https://datatracker.ietf.org/doc/draft-esale-mpls-app-aware-tldp/
https://datatracker.ietf.org/doc/draft-ietf-mpls-spring-entropy-label/
     https://datatracker.ietf.org/doc/draft-bonica-mpls-self-ping/
https://datatracker.ietf.org/doc/draft-decraene-mpls-lsp-ping-registry/
     https://datatracker.ietf.org/doc/draft-ietf-mpls-oam-ipv6-rao/
     https://datatracker.ietf.org/doc/draft-kompella-mpls-rmr/
https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-registry/
https://datatracker.ietf.org/doc/draft-ietf-mpls-entropy-lsp-ping/

---

From: Robert Sparks <[email-masked]>
Date: Thu, 16 Apr 2015 14:50:54 -0500

This script has been run.

If you didn't receive email, your group had no documents that were changed.

280 documents were touched.
This part of the output from the script shows which groups were affected:

Letting the group personnel know we changed their documents...
Telling idr we changed 15 documents
Telling cfrg we changed 7 documents
Telling dtnrg we changed 1 documents
Telling nmrg we changed 4 documents
Telling netconf we changed 1 documents
Telling v6ops we changed 2 documents
Telling grow we changed 2 documents
Telling opsec we changed 1 documents
Telling ippm we changed 2 documents
Telling radext we changed 8 documents
Telling isis we changed 3 documents
Telling rtgwg we changed 1 documents
Telling bfd we changed 2 documents
Telling kitten we changed 1 documents
Telling ecrit we changed 1 documents
Telling manet we changed 4 documents
Telling trill we changed 12 documents
Telling mpls we changed 22 documents
Telling nfsv4 we changed 2 documents
Telling sidr we changed 1 documents
Telling dime we changed 4 documents
Telling ngtrans we changed 1 documents
Telling ospf we changed 2 documents
Telling opsawg we changed 9 documents
Telling httpbis we changed 1 documents
Telling 6man we changed 2 documents
Telling roll we changed 2 documents
Telling drinks we changed 2 documents
Telling ipsecme we changed 1 documents
Telling multimob we changed 1 documents
Telling oauth we changed 5 documents
Telling lisp we changed 6 documents
Telling mif we changed 2 documents
Telling netext we changed 3 documents
Telling xmpp we changed 3 documents
Telling smime we changed 1 documents
Telling conex we changed 3 documents
Telling siprec we changed 1 documents
Telling core we changed 1 documents
Telling pals we changed 2 documents
Telling precis we changed 3 documents
Telling pcp we changed 1 documents
Telling eman we changed 4 documents
Telling appsawg we changed 5 documents
Telling dane we changed 1 documents
Telling avtcore we changed 1 documents
Telling payload we changed 1 documents
Telling xrblock we changed 1 documents
Telling paws we changed 1 documents
Telling rtcweb we changed 6 documents
Telling httpauth we changed 3 documents
Telling jose we changed 1 documents
Telling mile we changed 1 documents
Telling bfcpbis we changed 1 documents
Telling weirds we changed 6 documents
Telling tls we changed 5 documents
Telling nvo3 we changed 4 documents
Telling scim we changed 3 documents
Telling dmm we changed 4 documents
Telling icnrg we changed 3 documents
Telling straw we changed 1 documents
Telling i2rs we changed 11 documents
Telling lmap we changed 3 documents
Telling json we changed 2 documents
Telling nwcrg we changed 1 documents
Telling jcardcal we changed 1 documents
Telling stox we changed 2 documents
Telling dmarc we changed 1 documents
Telling aqm we changed 1 documents
Telling dnssd we changed 1 documents
Telling sieve we changed 2 documents
Telling 6tisch we changed 1 documents
Telling sfc we changed 2 documents
Telling eppext we changed 1 documents
Telling uta we changed 4 documents
Telling tram we changed 1 documents
Telling ianaplan we changed 1 documents
Telling calext we changed 2 documents
Telling dprive we changed 1 documents
Telling bess we changed 11 documents
Telling dnsop we changed 4 documents
Telling nfvrg we changed 2 documents
Telling gaia we changed 1 documents
Telling bmwg we changed 2 documents
Telling tsvwg we changed 4 documents
Telling teas we changed 1 documents
Telling tokbind we changed 2 documents
Telling dhc we changed 8 documents
Telling forces we changed 2 documents
Telling ccamp we changed 4 documents
Telling simple we changed 1 documents

On 4/15/15 1:39 PM, Robert Sparks wrote:
> The next release of the datatracker will contain the first steps 
> towards changing how a working group list gets copied when an AD 
> enters a ballot position.
> scrub working group lists out of the Notify fields where they occur 
> (276 documents at the moment).
> experiencing with mail sent to the .all alias for a document going 
> into moderation at your group's list because of an implicit destination.
>
> That script will email the WG personnel (chairs, shepherds, ads) to 
> let them know what got changed.
> Below, you'll find an example of what will be sent to the personnel 
> for one of the groups with the largest count of affected documents.
> Please read the text of the example - it explains the history leading 
> up to this change in a little more detail.
>
> If all goes well with the upcoming release, I expect to run this 
> script late in the day tomorrow.
>
> RjS
>
> ---------------------
> EXAMPLE MESSAGE FOLLOWS
> Subject: Removed the working group list address from the Notify field 
> of 22 mpls drafts
>
> assigned when the document entered IESG processing. This was a first 
> try at ensuring the working group sees ballot positions as the ADs 
> enter them. However, it had several unintended consequences. In 
> particular, since the contents of the Notify field are expanded into 
> each document's .all alias, messages sent by individuals to the .all 
> alias often ended in the list's moderation queue for having an 
> implicit destination.
>
> the working group list explicitly, under the balloting AD's control, 
> and we are scrubbing the list addresses from the Notify fields.
>
> period, please use the datatracker to put it back into the field (or 
> ask the secretariat to do so for you), and accept our apologies for 
> the inconvenience.
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 16 Apr 2015 22:18:07 +0000

So I am a bit lost.

Do I need to do anything to ensure that the WG gets such things as notification of publication requests, and IESG review ballot positions?

Keith 

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf 
> Of Robert Sparks
> Sent: 16 April 2015 20:51
> To: [email-masked]
> Subject: Re: Upcoming change to the Notify field for some documents
> 
> > reply to me ASAP (and be sure to copy your AD), and I will exclude 
> > your group from what the script will work on.
> >

---

From: Robert Sparks <[email-masked]>
Date: Thu, 16 Apr 2015 17:26:56 -0500

Nothing new.

For things other than ballot positions, the mail to the list will be 
what you were seeing before last November.

You should now be getting ballot positions mailed directly to the list 
from the tracker unless the AD placing the position unchecks a box on 
the ballot form.

We have a separate effort underway to go through all the places the 
tracker sends email and make sure that the destinations are still the 
best ones (they're not).
Check out the spreadsheet at 
https://mailarchive.ietf.org/arch/msg/tools-discuss/n9l2T0z2rmm3k3HtxaI1pbf1TSg 
if you have time to help.

RjS