Subject: Auto-subscribe IESG to WG lists?

From: Warren Kumari <[email-masked]>
Date: Tue, 9 Jun 2015 13:49:14 -0400

Hi all,

I realize this this should be a minor annoyance, but it irks me...

I just got a bunch of :

    List:    [email-masked]
    From:    [email-masked]
    Subject: Barry Leiba's Yes on
draft-ietf-dprive-problem-statement-05: (with COMMENT)
    Reason:  Post by non-member to a members-only list

    List:    [email-masked]
    From:    [email-masked]
    Subject: Joel Jaeggli's No Objection on
draft-ietf-dprive-problem-statement-05: (with COMMENT)
    Reason:  Post by non-member to a members-only list

So, I went along and approved them (and added them so they can post in
the future). I realize this should't really bother me, but it seems
like IESG folk often need to post to WG lists -- if it were easy to
implement, what do folk think about having ADs automatically have
posting privileges to all WG lists?

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Robert Sparks <[email-masked]>
Date: Tue, 09 Jun 2015 13:11:38 -0500

We have a better solution that I've been testing for awhile. I think 
it's ready for people to try to start using, and you'd make a great 
initial tester for us, Warren.

There is a mailman list that is now being maintained (updated nightly) 
to make this kind of whitelisting easier.
It consists of the full set of addresses that are subscribed to or have 
been whitelisted for any other mailman list at ietf.org.
It's name is "global-whitelist".

Mailman supports the notion of whitelisting the subscribers of some 
other list using '@listname' in the whitelist addresses.

You can add '@global-whitelist' to the 'accept_these_nonmembers' field 
on the 'Privacy options' page of your list's configuration, and then 
anyone who
is subscribed to any ietf list will be be able to post to your list.

If anyone else would like to try it out, please let me know you've done so.

(btw - the global-whitelist list is configured to never carry any list 
traffic - it's archive will always be empty - attempts to send to it are 
automatically dropped.)

RjS

---

From: Aaron Falk <[email-masked]>
Date: Tue, 9 Jun 2015 15:13:54 -0400

I have added it to the TAPS and HOPS lists.  Will let you know if chaos
ensues.

--aaron

On Tue, Jun 9, 2015 at 2:11 PM, Robert Sparks <[email-masked]> wrote:

> We have a better solution that I've been testing for awhile. I think it's
> ready for people to try to start using, and you'd make a great initial
> tester for us, Warren.
>
> There is a mailman list that is now being maintained (updated nightly) to
> make this kind of whitelisting easier.
> Mailman supports the notion of whitelisting the subscribers of some other
> list using '@listname' in the whitelist addresses.
>
> You can add '@global-whitelist' to the 'accept_these_nonmembers' field on
> the 'Privacy options' page of your list's configuration, and then anyone who

---

From: Warren Kumari <[email-masked]>
Date: Tue, 9 Jun 2015 15:24:04 -0400

> ready for people to try to start using, and you'd make a great initial

Done - added this to DPRIVE (dns-privacy@), DANE and OpsAWG.

> It consists of the full set of addresses that are subscribed to or have been
> whitelisted for any other mailman list at ietf.org.

This is cool. I've often sat there wondering if I should just change
the default on "Action to take for postings from non-members for which
no explicit action is defined." to me "Accept", but I know the moment
I do someone will email an infect PDF or similar ot the list. Or an ad
for Viagra. Or some ranty discussion about languages...

W

---

From: Ignacio Goyret <[email-masked]>
Date: Tue, 09 Jun 2015 12:31:53 -0700

Added to the l2tpext list.
-Ignacio

At 11:11 6/9/2015, Robert Sparks wrote:
>We have a better solution that I've been testing for awhile. I think it's ready for people to try to start using, and you'd make a great initial tester for us, Warren.
>
>There is a mailman list that is now being maintained (updated nightly) to make this kind of whitelisting easier.
>It consists of the full set of addresses that are subscribed to or have been whitelisted for any other mailman list at ietf.org.
>Mailman supports the notion of whitelisting the subscribers of some other list using '@listname' in the whitelist addresses.
>
>You can add '@global-whitelist' to the 'accept_these_nonmembers' field on the 'Privacy options' page of your list's configuration, and then anyone who
>(btw - the global-whitelist list is configured to never carry any list traffic - it's archive will always be empty - attempts to send to it are automatically dropped.)
>
>RjS
>
>

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Tue, 09 Jun 2015 14:37:25 -0500

I've added @global-whitelist to sipcore and gen-art lists.

Thanks!

Jean

On 6/9/15 1:11 PM, Robert Sparks wrote:
> It consists of the full set of addresses that are subscribed to or 
> have been whitelisted for any other mailman list at ietf.org.
> traffic - it's archive will always be empty - attempts to send to it 
> are automatically dropped.)
>
> RjS
>
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 09 Jun 2015 16:17:59 -0400

> list using '@listname' in the whitelist addresses.

WOOHOO!

    > on the
    > 'Privacy options' page of your list's configuration, and then anyone who

Just to be clear, it's in the "Sender Filters" part of the privacy options.

I'm so happy to have this, it will make life much easier.

***
Let's make it the default for all new lists.
***

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 10 Jun 2015 11:22:33 +0200

Added for the PALS WG list.

Cheers,
Andy

---

From: Eliot Lear <[email-masked]>
Date: Wed, 10 Jun 2015 11:26:48 +0200

> Added for the PALS WG list.
Can this simply be done for all mailing lists?

Eliot

---

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Jun 2015 07:39:36 -0500

It can be done. It is straightforward, but not necessarily simple.

I'd like to get some time with it from chairs that are opting-in and 
watching the results carefully before we perturb everyone though.

RjS

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 10 Jun 2015 09:07:43 -0400

+1, let’s see how the experiment goes...

From: WGChairs [mailto:[email-masked]] On Behalf Of Robert Sparks
Sent: Wednesday, June 10, 2015 8:40 AM
To: Eliot Lear; Andrew G. Malis
Cc: Working Group Chairs
Subject: Re: Auto-subscribe IESG to WG lists?

I'd like to get some time with it from chairs that are opting-in and watching the results carefully before we perturb everyone though.

---

From: Tim Chown <[email-masked]>
Date: Wed, 10 Jun 2015 14:53:14 +0100

> On 9 Jun 2015, at 21:17, Michael Richardson <[email-masked]> wrote:
> 
> 

Hmm, I already have a bunch of - apparently - AD emails on the accept list for dnssd, and I don’t think Ralph added that.  Is someone working behind the scenes? :)

I have also added @global-whitelist though.

Tim

---

From: Ted Hardie <[email-masked]>
Date: Wed, 10 Jun 2015 07:54:07 -0700

>  It can be done. It is straightforward, but not necessarily simple.
​Thanks for the slow and steady approach on this. My concern is that any
account correctly subscribed to any IETF mailman list is auto-approved with
this list, if I understood correctly.  We've seen subscription then spam
before on these lists, and this would make it easy.    That may not be a
concern, since the spammers would have to work out the special treatment,
but I'd like us to get something under our belt to see.

Ted

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 11 Jun 2015 08:58:41 -0400

+1 – I want to see how the experiment goes. 

Sue 

From: WGChairs [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: Wednesday, June 10, 2015 9:08 AM
To: Robert Sparks
Cc: Working Group Chairs
Subject: RE: Auto-subscribe IESG to WG lists?

---

From: <[email-masked]>
Date: Sat, 13 Jun 2015 17:06:54 +0000

Thank you for that! :)
Done for Dime and Radext

Lionel

-----Message d'origine-----
De : WGChairs [mailto:[email-masked]] De la part de Tim Chown
Envoyé : mercredi 10 juin 2015 15:53
À : Michael Richardson
Cc : [email-masked]; Robert Sparks
Objet : Re: Auto-subscribe IESG to WG lists?

>> You can add '@global-whitelist' to the 'accept_these_nonmembers' 
>> field on the 'Privacy options' page of your list's configuration, and 
>> then anyone who is subscribed to any ietf list will be be able to 
>> post to your list.
> 

Tim

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.