Subject: Re: FCFS policy unclear for "vanity" code points

From: Jeffrey Haas <[email-masked]>
Date: Wed, 1 Jul 2015 10:55:45 -0400

On Tue, Jun 30, 2015 at 05:39:31PM -0400, John Scudder wrote:
> > NEW:
> >   For numbers, the exact
> >   value is generally assigned by IANA using the next in-sequence unallocated
> >   value, other values might be assigned at the discretion of <who exactly?> if an
> >   extenuating circumstance exists
> 
> Andy proposed the admirably minimal s/generally// solution instead. I
> don't think it fully solves the problem we had though, which was that the
> code point requester had no guidance to indicate to them it was not ok to
> cherry-pick a code point, and IANA felt they needed to ask the chairs for
> guidance. Andy's proposal does provide (probably) sufficient document
> cover to allow IANA to assign whatever code point they want, but because
> we are all nice people (aren't we?) the practical difference in this case
> would be nil, I bet. What is different in the text I suggested is it makes
> explicit the expectation you're generally going to get the next
> in-sequence value, absent a good reason to do otherwise.

I'm going to offer an example of something that makes the non-general
next-in-sequence problematic.  Presume you have 2 documents in-flight that
will need a code point from the same registry.  Presume the authors know
this and are trying to coordinate and thus each offers a preferred code
point.

IANA does seem to try to take preference into consideration.  My concern is
trying to be too proscriptive is that it comoplicates the process.

What I think we really want is language that expresses our desire for
compact assignments but doesn't prohibit us from leaving holes when
appropriate.

-- Jeff

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 1 Jul 2015 13:21:07 -0400

> this and are trying to coordinate and thus each offers a preferred code

I think this is a more abstract instance of the example Warren offered, although I will also point out that with FCFS the authors really shouldn't need to do this very often because they should be able to receive their code point early in the document cycle. This is more likely a problematic case for other allocation policies such as Standards Action, but we're not talking about those here.

> compact assignments but doesn't prohibit us from leaving holes when

Here is my original proposed text, modified with Andy's recent suggestion. I think it does exactly what you describe. Do you agree?

OLD:
  For numbers, the exact
  value is generally assigned by IANA

NEW:
  For numbers, the exact
  value is generally assigned by IANA using the next in-sequence unallocated
  value, other values might be assigned if an extenuating circumstance exists

The change is that "at the discretion of <who exactly?>" is removed, implicitly leaving it to the discretion of IANA, just as you describe above.

Thanks,

--John

---

From: Warren Kumari <[email-masked]>
Date: Wed, 1 Jul 2015 13:53:50 -0400

> The change is that "at the discretion of <who exactly?>" is removed, implicitly leaving it to the discretion of IANA, just as you describe above.

I must admit that I'm still slightly confused what problem you are
trying to solve. Is the practice of people asking for vanity
codepoints problematic enough that the people who have to deal with
them (IANA) feel this needs fixing? Other than the one instance you
mention have people seen enough issues that this requires fixing?
Sure, the "dirty trick" of someone asking for 0x1234 just to screw
with someone who is squatting on it is icky, but does this happen in
the real world? If so, there are 2 issues:
1: the person squatting was, um, squatting and
2: we should make it clear that this is uncool, and makes your future
life in the IETF less productive.

I guess I don't really care, but this all feels like fixing something
that isn't significantly broken....

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 1 Jul 2015 15:26:30 -0400

> The change is that "at the discretion of <who exactly?>" is removed, implicitly leaving it to the discretion of IANA, just as you describe above.

Looks good to me.

-- Jeff

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 1 Jul 2015 15:39:11 -0400

On Jul 1, 2015, at 1:53 PM, Warren Kumari <[email-masked]> wrote:
> trying to solve. 
...
> that isn't significantly broken....

I think Eliot already asked this and I already answered:

On Jun 30, 2015, at 5:39 PM, John Scudder <[email-masked]> wrote:
> Eliot asked "But seriously folks, is this a problem that requires a real change of policy?"
> 
> No, I don't think there's a fire. But I also don't think I'm proposing a change of policy. I think I'm proposing a clarification by taking something we "all knew" and making it explicit, that is, you get the next in-sequence value unless you make a case for getting something else (as Warren described, for example). Let me turn the question around: 5226bis has not yet been finalized. The effort to make the change is low (see, I can say that because I'm not the author). What is gained by leaving the policy ambiguous? What is lost by making it clear?

but while I'm quoting myself, I'll also quote myself from a reply to a unicast message:

> You're right that [IANA has] demonstrated they can and will do the right thing regardless of whether we make the suggested change or not.
> 
> I don't feel strongly enough to insist on the change. Leaving it as it stands would be acceptable to me -- I think the change would be an improvement (else I wouldn't have suggested it) but at this point I have invested about as much time in defending it as I think it's worth. But in what way does the suggested change constrain IANA? Not at all, AFAICT. It just makes their existing practice a little more visible.
> 
> At this point I am going with "whatever".

I believe my $0.02 has been fully spent.

--John

---

From: Lou Berger <[email-masked]>
Date: Wed, 01 Jul 2015 15:58:26 -0400

I'm sure I'll jump out of the discussion as fast as John, but...
On 7/1/2015 3:39 PM, John G. Scudder wrote:
> But in what way does the suggested change constrain IANA? Not at all, AFAICT. It just makes their existing practice a little more visible.

An alternative is to have all multiple and non-sequential assignments go
through a designated expert -- yes this is a policy change, or even just
a new policy.

Lou

---

From: Warren Kumari <[email-masked]>
Date: Wed, 1 Jul 2015 16:14:57 -0400

>> No, I don't think there's a fire. But I also don't think I'm proposing a change of policy. I think I'm proposing a clarification by taking something we "all knew" and making it explicit, that is,…

Apologies, you are right -- I'd forgotten that exchange.

Yup, the change does seem useful, and, if the editors are willing,
seems like a worthy addition / clarification.

I'm not quite sure what got into me earlier -- I think I was just in a
bad mood and looking for a fight...

https://www.youtube.com/watch?v=uLlv_aZjHXc

W