Subject: GitHub Contributors Guide

From: Justin Richer <[email-masked]>
Date: Wed, 2 Sep 2015 15:07:12 -0400

I was just pointed to this article from GitHub about setting up a contributors guide for a repository:

https://help.github.com/articles/setting-guidelines-for-repository-contributors/ <https://help.github.com/articles/setting-guidelines-for-repository-contributors/>

Essentially this creates a link to an in-repository document on the page every time someone creates a new issue or pull request. I’ve already added the IETF Note Well to the contribution document for the COSE repository:

https://github.com/cose-wg/cose-issues/blob/master/CONTRIBUTING.md <https://github.com/cose-wg/cose-issues/blob/master/CONTRIBUTING.md>

https://github.com/cose-wg/cose-issues/issues/new <https://github.com/cose-wg/cose-issues/issues/new>

Those of you using GitHub to track code, specs, or issues for your groups will probably want to enable this feature. Feel free to steal the markdown-formatted Note Well from us if you like. :)

 — Justin

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 2 Sep 2015 19:10:37 +0000

If you haven’t already looked at Martin’s templates, you should.  I used it for ACME (https://github.com/ietf-wg-acme), found a few bugs which he fixed; no doubt more remain: https://github.com/martinthomson/i-d-template

--
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz