Subject: Latest RFC2119 boiler plate

From: "Susan Hares" <[email-masked]>
Date: Tue, 1 Sep 2015 12:47:41 -0400

Hi all:

Can anyone tell me where the latest RFC2119 boilerplate is?  

Thank you, 

Sue

---

From: joel jaeggli <[email-masked]>
Date: Tue, 1 Sep 2015 10:08:50 -0700

> Can anyone tell me where the latest RFC2119 boilerplate is? 

the xml template I employ uses

      <section title="Requirements Language">
        <t>The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL
NOT",
        "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
        document are to be interpreted as described in <xref
        target="RFC2119">RFC 2119</xref>.</t>
      </section>

http://tools.ietf.org/tools/templates/draft-davies-template-bare.txt

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 01 Sep 2015 19:47:45 +0200

I see the below often, but it happens to be wrong (errata 499,
https://www.rfc-editor.org/errata_search.php?rfc=2119).
AFAIK, this errata *is* the source document for the currently accepted
boilerplate.

Grüße, Carsten

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 1 Sep 2015 18:57:24 +0100

Although it continues to be the case that the RFC Editor does not use the text updated by the Errata report.

7322 might have been hoped to be helpful. It says...

> 4.8.2.  Requirements Language Section
>
>   Some documents use certain capitalized words ("MUST", "SHOULD", etc.)
>   to specify precise requirement levels for technical features.
>   RFC 2119 [BCP14] defines a default interpretation of these
>   capitalized words in IETF documents.  If this interpretation is used,
>   RFC 2119 must be cited (as specified in RFC 2119) and included as a
>   normative reference.

...w/o reference to the Errata Report that might (or might not) be assumed to be part of RFC 2119.

Thus, Heather is copied on this.

Cheers,
Adrian

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Carsten
> Bormann
> Sent: 01 September 2015 18:48
> To: joel jaeggli
> Cc: [email-masked]; Susan Hares
> Subject: Re: Latest RFC2119 boiler plate
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 1 Sep 2015 18:09:22 +0000

> On Sep 1, 2015, at 10:08 AM, joel jaeggli <[email-masked]> wrote:
> 

RFC 2119?

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 1 Sep 2015 14:09:43 -0400

Adrian, Carsten, and all:

Thank you for the details.  

Perhaps Heather or Russ could update the Internet draft guidelines with the pointer to the right boiler plate.  It would help me and my WGs. 

Sue Hares

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, September 01, 2015 1:57 PM
To: 'Carsten Bormann'
Cc: [email-masked]; Heather Flanagan (RFC Series Editor)
Subject: RE: Latest RFC2119 boiler plate

Cheers,
Adrian

> >         <t>The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", 
> > "SHALL NOT",
> >         "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" 
> > in
> this