Subject: Agenda development support

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 3 Nov 2015 00:13:47 +0000

I have developed a tool for my own amusement, and wonder whether others would find it useful. If appropriate I can get it filed on the tools page or somehow supported in the data tracker. It is based on Henrik's data tracker API, which is to say "not screen scraping". It's in perl.

Here's the problem I'm trying to solve. I can look at https://datatracker.ietf.org/wg/v6ops/documents/, and figure out anything I need to know about my working group's drafts. The information is all there. However, it is somewhat inaccessible, in the sense that it is cluttered with information that, while relevant, isn't particularly useful in agenda analysis, and the sort capability (that used to be there?) isn't there (any more).

What I'm trying to figure out, when planning an agenda, is:
  - what working group drafts have been updated since the last meeting
    (which I will then do a mail search to determine the latest status of)
  - what individual submissions to the working group have come in
    (which I will then do a mail search for supporting commentary regarding).

I may also have other drafts I am specifically interested in; this time, we had an invited talk on a technology that Facebook is experimenting with, that is actually in discussion in nvo3 (draft-herbert-nvo3-ila).

So therefore, I enter something like
ietf-agenda-analysis.pl --date 2015-07-22 v6ops draft-herbert-nvo3-ila-01.txt
or
ietf-agenda-analysis.pl --date 2015-07-22 v6ops draft-herbert-nvo3-ila

and get back the following (today). My question is whether other chairs would find this kind of capability useful, and whether I should bring it up with the tools team. If it's useful to you, you're welcome to my script regardless, on an open source basis.

RFC Editor: EDIT
	2015-10-26	draft-ietf-v6ops-siit-dc
	2015-10-26	draft-ietf-v6ops-siit-dc-2xlat
	2015-10-26	draft-ietf-v6ops-siit-eam
	2015-10-19	draft-ietf-v6ops-pmtud-ecmp-problem

WG: In WG Last Call
	2015-11-01	draft-ietf-v6ops-ipv6-ehs-in-real-world

WG: Parked WG Document
	2015-10-14	draft-ietf-v6ops-mobile-device-profile

WG: Submitted to IESG for Publication
	2015-10-30	draft-ietf-v6ops-reducing-ra-energy-consumption

WG: Unupdated WG Document
	2015-07-06	draft-ietf-v6ops-dhcpv6-slaac-problem
	2015-05-03	draft-ietf-v6ops-ula-usage-recommendations

WG: Updated WG Document
	2015-11-01	draft-ietf-v6ops-host-addr-availability
	2015-11-01	draft-ietf-v6ops-unique-ipv6-prefix-per-host
	2015-10-19	draft-ietf-v6ops-design-choices

Individual Submission: Unupdated
	2015-07-06	draft-akira-v6ops-mape-experience
	2015-07-06	draft-xcf-v6ops-chinatelecom-deployment
	2015-07-05	draft-hui-v6ops-ipv6trans-select-nfv
	2015-07-05	draft-xli-v6ops-cernet-deployment
	2015-07-05	draft-yang-v6ops-ipv6tran-select
	2015-06-26	draft-vyncke-v6ops-ipv6-only-thin-clients
	2015-06-25	draft-sun-v6ops-xlat-multi

Individual Submission: Updated
	2015-10-19	draft-jjmb-v6ops-unique-ipv6-prefix-per-host
	2015-10-19	draft-xu-v6ops-dslite-redundancy
	2015-10-15	draft-gont-v6ops-ipv6-ehs-packet-drops
	2015-10-12	draft-herbert-nvo3-ila
	2015-10-10	draft-bao-v6ops-rfc6145bis
	2015-09-21	draft-ybai-v6ops-ipv6-for-openstack

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 3 Nov 2015 13:30:38 +0900

Fred,

That is very cool, thanks for sharing! By all means, this would be great to
run from a clickable form on either the tools page or perhaps on
http://www.ietf.org/wg/chairs-page.html .

Cheers,
Andy

On Tue, Nov 3, 2015 at 9:13 AM, Fred Baker (fred) <[email-masked]> wrote:

> I have developed a tool for my own amusement, and wonder whether others
> would find it useful. If appropriate I can get it filed on the tools page
> or somehow supported in the data tracker. It is based on Henrik's data
> tracker API, which is to say "not screen scraping". It's in perl.
>
> Here's the problem I'm trying to solve. I can look at
> https://datatracker.ietf.org/wg/v6ops/documents/, and figure out anything
> I need to know about my working group's drafts. The information is all
> there. However, it is somewhat inaccessible, in the sense that it is
> cluttered with information that, while relevant, isn't particularly useful
> in agenda analysis, and the sort capability (that used to be there?) isn't
> there (any more).
>
> I may also have other drafts I am specifically interested in; this time,
> we had an invited talk on a technology that Facebook is experimenting with,
> that is actually in discussion in nvo3 (draft-herbert-nvo3-ila).
>
> and get back the following (today). My question is whether other chairs
> would find this kind of capability useful, and whether I should bring it up
> with the tools team. If it's useful to you, you're welcome to my script
> regardless, on an open source basis.
>
> RFC Editor: EDIT

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 3 Nov 2015 04:52:48 +0000

> On Nov 3, 2015, at 1:30 PM, Andrew G. Malis <[email-masked]> wrote:
> 
> Fred,
> 
> That is very cool, thanks for sharing! By all means, this would be great to run from a clickable form on either the tools page or perhaps on http://www.ietf.org/wg/chairs-page.html <http://www.ietf.org/wg/chairs-page.html> .

That would be a great step from the tools team. :-)

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 3 Nov 2015 05:23:56 +0000

+1

From: WGChairs <[email-masked]<mailto:[email-masked]>> on behalf of "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 2, 2015 at 11:30 PM
To: Fred Baker <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Agenda development support

Fred,

That is very cool, thanks for sharing! By all means, this would be great to run from a clickable form on either the tools page or perhaps on http://www.ietf.org/wg/chairs-page.html .

Cheers,
Andy

On Tue, Nov 3, 2015 at 9:13 AM, Fred Baker (fred) <[email-masked]<mailto:[email-masked]>> wrote:
I have developed a tool for my own amusement, and wonder whether others would find it useful. If appropriate I can get it filed on the tools page or somehow supported in the data tracker. It is based on Henrik's data tracker API, which is to say "not screen scraping". It's in perl.
…

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 3 Nov 2015 06:56:37 +0000

That would be fantastic…

Thanks for sharing, Fred!

Fred,

Cheers,
Andy

---

From: Warren Kumari <[email-masked]>
Date: Wed, 4 Nov 2015 10:40:41 +0900

On Tuesday, November 3, 2015, Pascal Thubert (pthubert) <[email-masked]>
wrote:

> That would be fantastic
Yes, very...

W

> *From: *WGChairs <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> on behalf of
> "Andrew G. Malis" <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> *Date: *Monday, November 2, 2015 at 11:30 PM
> *To: *Fred Baker <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> *Cc: *"[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>" <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> *Subject: *Re: Agenda development support
>
>
>
> Fred,
>
>
>
> That is very cool, thanks for sharing! By all means, this would be great
> to run from a clickable form on either the tools page or perhaps on
> On Tue, Nov 3, 2015 at 9:13 AM, Fred Baker (fred) <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Martin Vigoureux <[email-masked]>
Date: Wed, 4 Nov 2015 02:51:49 +0100

Very useful indeed. Thank you Fred

Le 04/11/2015 02:40, Warren Kumari a écrit :
>
>
> On Tuesday, November 3, 2015, Pascal Thubert (pthubert)
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     That would be fantastic
>
>
> Yes, very...
>
> W
>
>
>     Thanks for sharing, Fred!____
>
>     __ __
>
>     <javascript:_e(%7B%7D,'cvml',[email-masked]');>> on
>     behalf of "Andrew G. Malis" <[email-masked]
>     <javascript:_e(%7B%7D,'cvml',[email-masked]');>"
>     <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>     *Subject: *Re: Agenda development support____
>
>     __ __
>
>     Fred, ____
>
>     __ __
>
>     That is very cool, thanks for sharing! By all means, this would be
>     great to run from a clickable form on either the tools page or
>     perhaps on http://www.ietf.org/wg/chairs-page.html .____
>
>     __ __
>
>     Cheers,____
>
>     Andy____
>
>     __ __
>
>     <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:____
>
>         I have developed a tool for my own amusement, and wonder whether
>         others would find it useful. If appropriate I can get it filed
>         on the tools page or somehow supported in the data tracker. It
>         is based on Henrik's data tracker API, which is to say "not
>         screen scraping". It's in perl.
>         …____
>
>
>
> --
> I don't think the execution is relevant when it was obviously a bad idea
> in the first place.

---

From: Christian Hopps <[email-masked]>
Date: Thu, 12 Nov 2015 15:21:23 -0500

Talk about ships in the night! I wrote something to do something very similar I believe during this IETF.

https://github.com/choppsv1/wgstatus <https://github.com/choppsv1/wgstatus>

Chris.

> On Nov 2, 2015, at 7:13 PM, Fred Baker (fred) <[email-masked]> wrote:
> 
> <ietf-agenda-analysis.pl>

---

From: "Adam W. Montville" <[email-masked]>
Date: Sat, 14 Nov 2015 09:15:50 -0600

Hi Chris,

I’m having some issues running wgstatus.  I was able to get the tool at least running under python3, but I’m not really a python guy so my environment might be jacked in some way.  What I did was:

1. Update pip3
2. Install requirements (pip3 install -r requirements.txt)
3. Attempt to run “python3 wgstatus/main.py” with arguments

That runs, but even when I provide the “last-meeting” switch, the tool is telling me that I need to supply the last meeting.

Any thoughts on how to properly install your tool?

Kind regards,

Adam

> On Nov 12, 2015, at 2:21 PM, Christian Hopps <[email-masked]> wrote:
> 
>> On Nov 2, 2015, at 7:13 PM, Fred Baker (fred) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Here's the problem I'm trying to solve. I can look at https://datatracker.ietf.org/wg/v6ops/documents/ <https://datatracker.ietf.org/wg/v6ops/documents/>, and figure out anything I need to know about my working group's drafts. The information is all there. However, it is somewhat inaccessible, in the sense that it is cluttered with information that, while relevant, isn't particularly useful in agenda analysis, and the sort capability (that used to be there?) isn't there (any more).
>>

---

From: Christian Hopps <[email-masked]>
Date: Sun, 15 Nov 2015 01:17:17 -0500

Hi Adam,

Sorry I had some old code left around for direct invocation. I've fixed that so everything should work now that way.

Note: if you want to install locally you can cd to the git clone and enter: "pip install -e ."

I've also uploaded to pypi so you can also install directly with "pip install wgstatus".

Thanks,
Chris.

> On Nov 14, 2015, at 10:15 AM, Adam W. Montville <[email-masked]> wrote:
> 
> Hi Chris,
> 
>> On Nov 12, 2015, at 2:21 PM, Christian Hopps <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: "Adam W. Montville" <[email-masked]>
Date: Sun, 15 Nov 2015 09:01:45 -0600

Perfect, thanks!

> On Nov 15, 2015, at 12:17 AM, Christian Hopps <[email-masked]> wrote:
> 
> Hi Adam,
> 
>> On Nov 14, 2015, at 10:15 AM, Adam W. Montville <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Chris,
>>