Subject: Changes in using the global whitelist on IETF lists

From: IETF Chair <[email-masked]>
Date: Wed, 3 Feb 2016 07:45:42 +0200

For the last few months, several working group lists have been utilizing a global-whitelist containing the full set of addresses that are subscribed to or have been whitelisted for any mailman list at ietf.org. This is working well, and we will be configuring all new mailing lists to use this global-whitelist by default. We also plan to adjust the configuration of existing lists to use the global-whitelist later this month.

If you are an administrator of a mailman list at ietf.org and you do not wish your list's configuration to be altered to use the global-whitelist, please send a note to [email-masked] before February 19, 2015 asking that your list configuration remain unchanged.

Jari Arkko, IETF Chair

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 3 Feb 2016 08:37:08 +0000

Will this also affect irtf.org lists? (I hope it does.)

---

From: Jari Arkko <[email-masked]>
Date: Wed, 3 Feb 2016 12:30:31 +0200

Maybe we can make it so, if not already. Robert?

Jari

---

From: Robert Sparks <[email-masked]>
Date: Wed, 3 Feb 2016 08:38:05 -0600

> Maybe we can make it so, if not already. Robert?
I don't think it will right away, but it shouldn't be too hard to extend 
the mechanism to cover the @irtf.org lists as well. I'll look into it.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 3 Feb 2016 09:23:43 -0600

On 2/3/16 8:38 AM, Robert Sparks wrote:
> I don't think it will right away, but it shouldn't be too hard to 
> extend the mechanism to cover the @irtf.org lists as well. I'll look 
> into it.
It looks like it _will_ work right away with no additional work.
I'll let you know if that turns out to not be the case.
>>>> For the last few months, several working group lists have been 
>>>> utilizing a global-whitelist containing the full set of addresses 
>>>> that are subscribed to or have been whitelisted for any mailman 
>>>> list at ietf.org. This is working well, and we will be configuring 
>>>> all new mailing lists to use this global-whitelist by default. We 
>>>> also plan to adjust the configuration of existing lists to use the 
>>>> global-whitelist later this month.
>>>>
>>>> If you are an administrator of a mailman list at ietf.org and you 
>>>> do not wish your list's configuration to be altered to use the 
>>>> global-whitelist, please send a note to [email-masked] before 
>>>> February 19, 2015 asking that your list configuration remain 
>>>> unchanged.
>>>>
>>>> Jari Arkko, IETF Chair
>>>>
>

---

From: Jonathan Lennox <[email-masked]>
Date: Wed, 17 Feb 2016 18:55:16 +0000

On Feb 3, 2016, at 12:45 AM, IETF Chair <[email-masked]<mailto:[email-masked]>> wrote:

For the last few months, several working group lists have been utilizing a global-whitelist containing the full set of addresses that are subscribed to or have been whitelisted for any mailman list at ietf.org<http://ietf.org>. This is working well, and we will be configuring all new mailing lists to use this global-whitelist by default. We also plan to adjust the configuration of existing lists to use the global-whitelist later this month.

If you are an administrator of a mailman list at ietf.org<http://ietf.org> and you do not wish your list's configuration to be altered to use the global-whitelist, please send a note to [email-masked]<mailto:[email-masked]> before February 19, 2015 asking that your list configuration remain unchanged.

Has this not yet been implemented (since it’s not yet February 19th), or is [email-masked]<mailto:[email-masked]> not included in the global whitelist? I just had to manually approve a “milestones changed” e-mail from the datatracker.

---

From: Robert Sparks <[email-masked]>
Date: Thu, 18 Feb 2016 09:40:14 -0600

On 2/17/16 12:55 PM, Jonathan Lennox wrote:
>> that are subscribed to or have been whitelisted for any mailman list 
>> at ietf.org <http://ietf.org>. This is working well, and we will be 
>> configuring all new mailing lists to use this global-whitelist by 
>> default. We also plan to adjust the configuration of existing lists 
>> to use the global-whitelist later this month.
>>
>> If you are an administrator of a mailman list at ietf.org 
>> <http://ietf.org> and you do not wish your list's configuration to be 
>> altered to use the global-whitelist, please send a note to 
>> [email-masked] <mailto:[email-masked]> before February 
>> 19, 2015 asking that your list configuration remain unchanged.
>
> Has this not yet been implemented (since it’s not yet February 19th),
No, it hasn't been implemented yet.
> or is [email-masked] 
> <mailto:[email-masked]> not included in the global 
> whitelist?
That address is in the global whitelist.
> I just had to manually approve a “milestones changed” e-mail from the 
> datatracker.
You (and any list maintainer) can set up use of the global whitelist 
immediately if you want to.
Just go put @global-whitelist in your lists' accept_these_nonmembers 
configuration field on the Privacy options page.

I expect it will be several days after the 19th before the remaining 
lists are touched. I'll send a note when that happens.