Subject: RE: New datatracker release: v6.15.0

From: <[email-masked]>
Date: Wed, 2 Mar 2016 11:29:24 +0000

Hi Henrik,

>   - Documents can now be associated with meeting sessions from the  document
>     information page by group chairs, secretariat, etc., through an edit button
>     by the 'On Agenda' entry in the Stream info section

Looks nice, thanks.

For WG chairs, this seems limited to WG document. Is this correct? Is there a way to associate individual draft to a WG meeting? Also a WG document may be presented in another WG.

Thanks,
-- Bruno

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Henrik
> Levkowetz
> Sent: Monday, February 29, 2016 6:01 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: New datatracker release: v6.15.0
> 
> 
> Hi,
> 
> This is an automatic notification about a new datatracker release,
> v6.15.0, generated when running the mkrelease script.
> 
> Release notes:
> 
> ietfdb (6.15.0) ietf; urgency=medium
> 
>   **Session docs, WG List Archive Tab, RFC Note enhancements**
> 
>   This release provides a number of nice enhancements:
> 
>   - Documents can now be associated with meeting sessions from the
> document
>     information page by group chairs, secretariat, etc., through an edit button
>     by the 'On Agenda' entry in the Stream info section.
> 
>   - The group pages now provide links to both the new Mailarchive and the
> old
>     MHonArc list archives (if both exist).
> 
>   - The ability to add RFC Editor notes which will be called out on the IESG
>     agenda which was introduced in release 6.14.0 has now been made
> available
>     to the IAB, IRTF and Independent streams.
> 
>   Detailed changelog information:
> 
>   * Merged in [10861] from [email-masked]:
>     Data cleanup: place old groups in better states and better areas.  Remove
>     a few groups that appear to have never existed (as groups).
> 
>   * Merged in [10857] from [email-masked]:
>     Preserve the assumptions in the secr/proceedings code by isolating it
> from
>     drafts now appearing in sessionpresentations.
> 
>   * Merged in [10856] from [email-masked]:
>     - Show all sessions associated with a document.
>     - Remove the day/seq urls from the materials tree.
>     - Allow sessionpresentation.rev to be None, meaning 'current version'.
>     - Streamlined workflows to focus on current versions of a draft as a
> default.
>     - Allow adding and editing sessionpresentations when looking at a specific
>       document.
>     - Allow adding drafts when looking at a specific session.
>     - Add the meeting tab to 'team' groups.
>     - Refactored several utility classes and expanded on factories.
> 
>     Fixes #1908 and #1910.
> 
>   * Since the list-archive tab on group pages can sometimes be a tab and
>     sometimes a link out, positioning it between the always-tab and always
>     link-out entries seems reasonable.
> 
>   * Column text on the archives tab could overlap for some screen sizes.
>     Tweaked the use of bootstrap cell width styles.
> 
>   * Merged in [10848] from [email-masked]:
>     Correct typo in template. Fixes #1914.
> 
>   * Restricted django-bootstrap3 to versions which work with django 1.7.
> 
>   * Merged in [10718] from [email-masked]:
>     Set daemon = True on the thread in the SMTP test server running while
>     running tests. This fixes the annoying problem of the python process
>     staying alive after certain bugs in the test invocation or after a
>     plain Ctrl + c.
> 
>   * Merged in [10840] from [email-masked]:
>     Fill in the list archive tab, showing both mailarchive and mhonarc links
>     when they exists. Preserve the immediate link-to-archive behavior for the
>     group pages for lists that are not in mailarchive/mhonarc. Provides a url
>     at the datatracker for the mailman listinfo pages to use that will show
>     both types of archive.
> 
>   * Tweaked the output of the check_referential_integrity script to specify
>     the through table name for m2m relationships.
> 
>   * Merged in [10834] from [email-masked]:
>     Allow IAB, IRTF, and Independent streams to use new capability for RFC
>     Editor Notes.  Do not display of document shepherd and shepherd writeup
>     for non-IETF stream documents.  Do not display IESG information for IAB
>     stream documents.
> 
>   * Merged in [10828] from [email-masked]:
>     IRTF RGs do not have a review period, the email is generated as a
> courtesy
>     to the IAB and IESG.
> 
>  -- Henrik Levkowetz <[email-masked]>  28 Feb 2016 12:05:39 -0800
> 
> The new version is available for installation through SVN checkout, with
>   'svn checkout https://svn.tools.ietf.org/svn/tools/ietfdb/tags/6.15.0'
> 
> For development, check out the new development version instead:
>   'svn checkout
> https://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/6.15.1.dev0'
> 
> Regards,
> 
> 	Henrik
> 	(via the mkrelease script)

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Vigoureux <[email-masked]>
Date: Wed, 2 Mar 2016 13:56:10 +0100

That's awesome! Thanks a lot for this.

Just a question, will an history be kept over time?
We, as bess chairs, are regularly asking ourselves "at which ietf 
meeting(s) has this draft already been presented?" when creating the 
agenda for the upcoming one.

I agree with Bruno that it would be ideal to also have this 
functionality available for non wg drafts.

In any case, many thanks.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 02 Mar 2016 21:38:44 +0100

Hi Bruno,

On 2016-03-02 12:29, [email-masked] wrote:
> For WG chairs, this seems limited to WG document. Is this correct? Is
> there a way to associate individual draft to a WG meeting? Also a WG
> document may be presented in another WG.

Currently, yes.  That doesn't mean that's the optimal solution, and
feedback about how people can and want to use this will definitely
affect how we tweak things.

Robert, who coded this up, may have additional thoughts.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 02 Mar 2016 21:39:15 +0100

Hi Martin,

> agenda for the upcoming one.

Yes, this information is captured both on records associated with the
meetings, and will stay around.  We could also think about listing
this information in the document history directly, although that's not
in place at the moment, from what I recall.

Robert, who's put in this functionality, may have additional thoughts.

Best regards,

	Henrik

---

From: Robert Sparks <[email-masked]>
Date: Wed, 2 Mar 2016 14:48:15 -0600

Actually, you can add any draft to your session, not just those from 
your working group.

Use the sandbox to play around.
Go to https://sandbox.ietf.org - login as yourself - everyone's password 
there is "password".

Go to <http://sandbox.ietf.org/meeting/95/session/spring/>
(you can get there using the "materials" link on the row for IETF95 at 
<https://sandbox.ietf.org/wg/spring/meetings/>

You'll see (if you look before the database on the sandbox is refereshed 
tomorrow) that I've already added 
draft-sparks-genarea-mailarch-improvements to your session.

Hit the [Link additional drafts to session] button. Use the box to 
search for whatever drafts you want to add.

I see an enhancement - we should show the [Edit] button for the "On 
Agenda" row on any document when you are someone that might be able to 
put that document on an agenda. I'll make that change and it will be 
available in an upcoming release.

RjS

---

From: Robert Sparks <[email-masked]>
Date: Wed, 2 Mar 2016 14:57:52 -0600

Yes - it's there - but we need to make it easier to get to, especially 
if you're not logged in.

See 
http://sandbox.ietf.org/doc/draft-sparks-genarea-mailarch-improvements/meetings

for the results of the tinkering I mentioned to Bruno. (if you don't see 
this until tomorrow it may be gone).

To get an idea of how this might look after a few meetings have gone by, 
look at this on the production system:
<https://datatracker.ietf.org/doc/slides-edu-newcomers-training/meetings>

RjS

---

From: Martin Vigoureux <[email-masked]>
Date: Wed, 2 Mar 2016 23:56:19 +0100

That's excellent, thank you very much Robert

Le 02/03/2016 21:57, EXT Robert Sparks a écrit :
>>>> For WG chairs, this seems limited to WG document. Is this correct?
>>>> Is there a way to associate individual draft to a WG meeting? Also a
>>>> WG document may be presented in another WG.
>>>>
>>>> Thanks,
>>>> -- Bruno
>>>>
>>>>
>>>>> https://svn.tools.ietf.org/svn/tools/ietfdb/tags/6.15.0'
>>>>>
>>>> Ce message et ses pieces jointes peuvent contenir des informations
>>>> confidentielles ou privilegiees et ne doivent donc
>>>> pas etre diffuses, exploites ou copies sans autorisation. Si vous
>>>> avez recu ce message par erreur, veuillez le signaler
>>>> a l'expediteur et le detruire ainsi que les pieces jointes. Les
>>>> messages electroniques etant susceptibles d'alteration,
>>>> This message and its attachments may contain confidential or
>>>> privileged information that may be protected by law;
>>>> If you have received this email in error, please notify the sender
>>>> and delete this message and its attachments.
>>>> As emails may be altered, Orange is not liable for messages that
>>>> have been modified, changed or falsified.
>>>> Thank you.
>>>>
>>>>
>>>>
>>>
>
>

---

From: <[email-masked]>
Date: Thu, 3 Mar 2016 08:22:57 +0000

Hi Robert,

> From: WGChairs [mailto:[email-masked]] On Behalf Of Robert Sparks
> 

Works fine. Thanks for the tip.

> available in an upcoming release.

That was my original point.

Thanks for the work.
Just like Martin, I find this a very useful feature.

-- Bruno

> ______________________________________________________________
> ___________________________________________________________
> >>
> >> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler
> >> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> >> This message and its attachments may contain confidential or privileged
> information that may be protected by law;