Subject: Drafts on the Meeting Materials page

From: Yoav Nir <[email-masked]>
Date: Mon, 4 Apr 2016 19:15:01 -0300

Hi

This might be a stupid question.  The Meeting Materials page ( https://datatracker.ietf.org/meeting/95/materials.html ) has a column for “Drafts”. For most working group sessions this is blank, but a few have a list of drafts.

How do you do that?  I don’t see it in the Meeting Materials Manager.

Thanks

Yoav

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 4 Apr 2016 19:20:46 -0300

Hi Yoav,

> On 4 Apr 2016, at 19:15, Yoav Nir <[email-masked]> wrote:
> 
> Hi
> 

Isn't this a new datatracker feature for adding drafts to meeting agendas?

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 4 Apr 2016 18:18:55 -0400 (EDT)

> Isn't this a new datatracker feature for adding drafts to meeting agendas?

I don't remember if it's new, but go to the document datatracker page,
then edit the "on agenda" field.

-Ben

---

From: Yoav Nir <[email-masked]>
Date: Mon, 4 Apr 2016 19:19:36 -0300

> On 4 Apr 2016, at 7:20 PM, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi Yoav,
> 

IDK. I especially don’t know why most groups (including mine) have none while a few others have a bunch of drafts there.

And it’s not just the draft-ietf-wgname- drafts in there. There are some others.

Yoav

---

From: Martin Vigoureux <[email-masked]>
Date: Tue, 5 Apr 2016 00:21:39 +0200

Yoav

go to your WG page on the tracker. click on the Meeting "tab" and then 
click on material link. then click on link additional drafts to session.
You need to do that for non-wg documents.
for wg document you can directly do that on the page of each draft in 
the tracker ("on the agenda" button)

-m

---

From: Yoav Nir <[email-masked]>
Date: Mon, 4 Apr 2016 19:22:00 -0300

> On 4 Apr 2016, at 7:18 PM, Benjamin Kaduk <[email-masked]> wrote:
> 

WooHoo!  Works!  

Thanks

Yoav

---

From: Tim Chown <[email-masked]>
Date: Mon, 4 Apr 2016 23:26:21 +0100

I asked this of the tools team earlier, here’s the answer…. so ping Robert if you have questions.

On 4 Apr 2016, at 14:22, Robert Sparks <[email-masked]> wrote:

Hi Tim -

Glen noted a secretariat ticket from you about associating drafts with sessions.
This is a new feature (and we improved somethings at the codesprint, which will show up in a release later this week).

You have two primary paths for managing these things for your sessions.
The first is on the document page - when logged in as a chair, look for the "On Agenda" row in the stream section of the metadata on the main page.
The second is on the group page - there's a "meetings" tab there (which was added a few months ago). If you follow the Materials link for the session you're chairing, there will be a page showing what the current materials are, and two buttons - one to get to the older slide uploading tool, and a new one for managing drafts.

If that doesn't get you unstuck, please find me and I'll help.

RjS

> On 4 Apr 2016, at 23:15, Yoav Nir <[email-masked]> wrote:
> 
> Hi
>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 4 Apr 2016 19:28:42 -0300

That worked as well. 

Thanks

Yoav

> On 4 Apr 2016, at 7:21 PM, Martin Vigoureux <[email-masked]> wrote:
> 
> Yoav
> 
> go to your WG page on the tracker. click on the Meeting "tab" and then click on material link. then click on link additional drafts to session.
> for wg document you can directly do that on the page of each draft in the tracker ("on the agenda" button)
> 
> -m
>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 4 Apr 2016 19:32:30 -0300

> On 4 Apr 2016, at 7:26 PM, Tim Chown <[email-masked]> wrote:
> 

So I managed it with a little help from my friends. I have to say that this required quite a bit more clicks than I think was needed, especially for the documents that are adopted drafts of the working group.  

Ideally, I would get a list of all active “draft-ietf-wgname-“ and “draft-somebody-wgname-“ that allows me to check all that apply (as in all drafts that we are going to discuss at the session)

Anyway, thanks for all the help.

Yoav

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 4 Apr 2016 22:35:45 +0000

Perhaps somthing to add to http://www.ietf.org/wg/meeting-materials.html.

I had noticed these drafts added for some wgs and finally figured out how to add them myself a few weeks ago, but will I remember for Berlin?

- Bernie (from iPhone)

> On Apr 4, 2016, at 7:26 PM, Tim Chown <[email-masked]> wrote:
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 4 Apr 2016 22:36:03 +0000

> Ideally, I would get a list of all active “draft-ietf-wgname-“ and “draft-
> somebody-wgname-“ that allows me to check all that apply (as in all drafts
> that we are going to discuss at the session)

Yes, but I would keep an option to search for an arbitrary string as well, because I-Ds do not necessarily need to include wg name in their id-name to be on the agenda. Actually I just now tried to add an ippm i-d to the lmap wg agenda, as the two wgs work together on some stull and I could not do it - probably a bug. 

Regards,

Dan

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Yoav Nir
> Sent: Tuesday, April 05, 2016 1:32 AM
> To: Tim Chown
> Cc: Working Group Chairs
> Subject: Re: Drafts on the Meeting Materials page
> 
> 
> > This is a new feature (and we improved somethings at the codesprint,
> which will show up in a release later this week).
> >
> > The first is on the document page - when logged in as a chair, look for the
> "On Agenda" row in the stream section of the metadata on the main page.
> > The second is on the group page - there's a "meetings" tab there (which
> was added a few months ago). If you follow the Materials link for the session
> you're chairing, there will be a page showing what the current materials are,
> and two buttons - one to get to the older slide uploading tool, and a new one
> for managing drafts.
> >
> So I managed it with a little help from my friends. I have to say that this
> required quite a bit more clicks than I think was needed, especially for the
> documents that are adopted drafts of the working group.
> 
> Ideally, I would get a list of all active “draft-ietf-wgname-“ and “draft-
> somebody-wgname-“ that allows me to check all that apply (as in all drafts
> that we are going to discuss at the session)
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 04 Apr 2016 19:39:36 -0300

Works for me.

A lot of busywork though; when all the draft links already are on the
agenda page, I'd rather pull them from there...

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Tue, 5 Apr 2016 07:53:55 -0300

> Yes, but I would keep an option to search for an arbitrary string as well, because I-Ds do not necessarily need to include wg name in their id-name to be on the agenda. Actually I just now tried to…
Which was addressed at the codesprint, and will be released in the next 
couple of days.
The workaround is to use the meeting view instead of the document view.
If you go to https://datatracker.ietf.org/meeting/95/session/lmap/ and 
use the [Link additional drafts to session] button, you should be able 
to do what you are wanting to do.

---

From: Adam Roach <[email-masked]>
Date: Tue, 5 Apr 2016 15:56:08 -0300

> agenda page, I'd rather pull them from there...

Having spent many years trying to manually scrape draft names out of 
chair-entered agendas, I can comfortably state that this isn't very 
satisfactory. While some chairs are meticulous in ensuring that they 
cite the right draft, and double-check that the names actually match 
what is in the i-d repository, it would appear that others simply smack 
their hands wildly against the keyboard until what is on the screen 
looks roughly like a draft name.

/a