Subject: RE: "Updates: RFC xxx" - what does it actually mean ? - what about erratas?

From: Christer Holmberg <[email-masked]>
Date: Wed, 31 Aug 2016 08:01:12 +0000

Hi,

Related to Flemming's question, what about erratas? Do they automatically update the associated RFCs, or does one have to explicitly "endorse" the errata?

Regards,

Christer

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Flemming Andreasen
Sent: 29 August 2016 22:22
To: [email-masked]
Subject: "Updates: RFC xxx" - what does it actually mean ?

Greetings

Let's say I have "RFC X", and I then publish "RFC Y", which includes
"Updates: RFC X" on its title page.

1) In order for me to be compliant with RFC X, MUST I now also be compliant with RFC Y ?

2) If yes, what if RFC Y introduced a non-backwards compatible change to RFC X ?

3) Is the answer to 1) documented somewhere ?

Thanks

-- Flemming

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 31 Aug 2016 14:18:19 +0000

There is a vetting process on any erratum that is filed. IMO: An erratum has no weight until verified. But once verified, anyone who ignores verified / endorsed errata when developing a protocol does so at their peril. So yes, I consider verified errata as updates to the RFCs.

	Tony Hansen

On 8/31/16, 4:01 AM, "WGChairs on behalf of Christer Holmberg" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 31 Aug 2016 14:27:19 +0000

Hi,

>There is a vetting process on any erratum that is filed. IMO: An erratum has no weight >until verified.

Correct. I should have made that clear.

>But once verified, anyone who ignores verified / endorsed errata when developing a >protocol does so at their peril. So yes, I consider verified errata as updates to the RFCs.

And by "updates" you mean...? :)

Regards,

Christer