Subject: amount of time for WG meetings, starting times, unstructured time, etc for Seoul

From: Jari Arkko <[email-masked]>
Date: Sun, 11 Sep 2016 09:57:45 +0300

At IETF-96, we had a discussion about both the chosen starting time but also other issues in the way that we set up the schedule, and provide time for either WG or other discussions.

This email provides some information about the options the IESG has in setting the schedule and related tradeoffs.

In general, barring any specific venue limitations, the IESG can independently adjust a number of different variables in the schedule, while assuming the same overall meeting week length. We can adjust the length of the day and overall number of hours in the schedule.  The IESG sets only the formal meeting schedules, so the tradeoff here is what fraction of the days are spent in formal meetings vs. unscheduled time that might be used for design team meetings and other more unstructured collaboration.

We can also adjust the specific timing, subject to local food availability and other conditions. And we can adjust the parallelism, i.e., number of tracks. This will impact conflicts but also our capacity to host meetings that the WGs have requested. Finally, we can adjust the number of plenaries, with the recent trend being holding exactly one plenary during the week.

Overall, our perception at the IESG is the following:

o  The start time provokes some opinions. For IETF-97 we plan to set this so that lunch and dinner times in the local situation are convenient. It might be useful to poll the community about this as well, but we'd like to suggest that it may be more important to focus on the bigger issues such as unstructured/structured time. At this time, what we know is that we will have plenty of restaurants around us, that there may be some lines at 11:30, some restaurants close at 21:30 while others stay open 24 hours. We are still deciding what to do about the start time, though one possibility is to start at 9:30. A lot depends also on how many sessions WGs request, or how many official total meeting hours we want to have.

o  Knowing the ending time on Friday is important for your flight arrangements. We do plan to start early on Friday, have three hours of sessions and one small room changeover break. As a result Friday schedule will end at 12:20.

o  We believe the community has told us to not increase the plenary time. The existing plenary time should be used primarily for technical topic (when available) or community discussion. There will be some amount of program in all of our plenaries, but the substantial reports have largely been moved to online consumption.

o  We also believe the community has told that arranging more unstructured time for work to happen would be useful. Is this a correct conclusion? The exact forms of how we might go about this are subject to furher discussion, see below. One of the big question marks here is the effect of any unstructured time to remote or English-as-foreign-language participants.

o  We have also heard repeated calls for stricter time allocation control by the IESG, in that only some working groups or maybe no working groups should be allowed extensive use of meeting hours (2x3hrs etc). We're not quite sure where the community is on this though, and it is also important that we get to do work when we do meet face to face. Our current belief is that it is better to deal with this question as part of the overall time allocation question, i.e., how much time gets allocated. The IESG is in charge of ensuring that within the time reserved for WGs, the allocation is fair in the sense of giving the time where it is needed and demonstrably useful. Including, for instance, the WG's track record from the time since the previous IETF meeting.

With regards to the possible increase of unstructured time in the meetings, we would like to do some experimentation, as we do not yet have experience of how time might get used.

The possible experiments that we've identified are:

1. The total number of hours available for WG meetings during the week. We could either keep this capped at what we had in Berlin. Alternatively, we can reduce the overall number of hours so that we can have, for instance, more design team meetings. We can start later or finish earlier one day, as an example.

2. Encouraging working groups try unstructured meeting time in one of their slots. This time could be used for free-form discussion in the whole group, an “unconference" style idea session in the different corners of the room, or a hacking session devoted to the WG's technology. All up to the WG chairs to decide. See my other mail.

Note: Seoul we will have tighter than usual space constraint. We can unfortunately not devote additional rooms, so anything we do needs to run under the usual room allocations. However, we will have more space in Chicago, so some bigger experiments or changes could be considered there.

We would like to solicit some feedback:

Q1. Please confirm that the community wishes that we arrange more unstructured time for work to happen.

Q2. Would you like to either keep the amount of meeting time from Berlin, or reduce it so that an additional hour(s) can be used for design team meetings and other unofficial interaction?

Q3. Any other feedback? Other suggestions?

The IESG is looking to make a decision of the IETF-97 schedule by September 30, so input before that is most useful,

Jari (for the IESG)

---

From: Paul Wouters <[email-masked]>
Date: Sun, 11 Sep 2016 14:48:03 -0400 (EDT)

> Q1. Please confirm that the community wishes that we arrange more unstructured time for work to happen.

I think that would be very good.

> Q3. Any other feedback? Other suggestions?

Personally, I really don't find the bits & bytes vendor talks very
interesting.

My suggestion would be to change the B&B into something more like the
Hackathon. Schedule a 4+ hour session, say Wednesday 2pm-10pm where
people can go "hang out" at their working group table in a hackathon
session, where they can either chat informally, brainstorm or write
code. And like the hackathon, bring some snacks/drinks in so people
don't feel like they need to leave for dinner.

That slot can then also be used for people to schedule meetings in
that won't conflict with regular sessions.

Paul

---

From: Tim Chown <[email-masked]>
Date: Mon, 12 Sep 2016 09:41:53 +0000

Hi,

> On 11 Sep 2016, at 19:48, Paul Wouters <[email-masked]> wrote:
> 

It sounds like a good idea, though I’m not aware of immediate need in the WG that I co-chair.

>> Q2. Would you like to either keep the amount of meeting time from Berlin, or reduce it so that an additional hour(s) can be used for design team meetings and other unofficial interaction?

I think there’s quite a bit of design team and other interaction happening over breakfast and lunch, or in slots where people have no WG they are interested in attending. I’m not sure we need more time for that.  It is an argument for a 9.30am or 10am start I suppose, to allow early morning meetings more time. 

> that won't conflict with regular sessions.

This is an interesting idea. The problem with the (otherwise very excellent) hackathon is that it’s held over the weekend before IETF, so if you do both, you’re away from home for a long time. It would be nice if there were some hackathon-style timing during the regular meeting, and something complementary to B&B might be worth exploring. I think 2pm-10pm would be longer than required though, and perhaps put too much pressure on the regular schedule.

Tim

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 12 Sep 2016 08:03:42 -0400

In the last two IETFs, I found the later start very conducive for morning
meetings. But the start, lunch, and end times should be optimized for local
customs. That worked well in BA, somewhat less so in Berlin. I don’t know
Seoul well enough to make a recommendation.

Cheers,
Andy

On Mon, Sep 12, 2016 at 5:41 AM, Tim Chown <[email-masked]> wrote:

> >> With regards to the possible increase of unstructured time in the
> meetings, we would like to do some experimentation, as we do not yet have
> experience of how time might get used.
> >
> >> Q2. Would you like to either keep the amount of meeting time from
> Berlin, or reduce it so that an additional hour(s) can be used for design
> team meetings and other unofficial interaction?
>
> I think there’s quite a bit of design team and other interaction happening
> over breakfast and lunch, or in slots where people have no WG they are
> interested in attending. I’m not sure we need more time for that.  It is an
> argument for a 9.30am or 10am start I suppose, to allow early morning
> meetings more time.
>
> This is an interesting idea. The problem with the (otherwise very
> excellent) hackathon is that it’s held over the weekend before IETF, so if
> you do both, you’re away from home for a long time. It would be nice if
> there were some hackathon-style timing during the regular meeting, and
> something complementary to B&B might be worth exploring. I think 2pm-10pm
> would be longer than required though, and perhaps put too much pressure on
> the regular schedule.
>
> Tim
>
>
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 12 Sep 2016 08:55:55 -0400

> unstructured time for work to happen.

Yes.  But, let me put it differently:  we need time for WG chairs and design
teams to do the structuring, not necessarily more "free" time.  I.e. this
isn't about lack of structure, but delegation of structure.

    > Berlin, or reduce it so that an additional hour(s) can be used for
    > design team meetings and other unofficial interaction?

As someone who is not a natural early riser (but having kids made me adapt),
I did not find I used the extra hour in the morning well.  What did I do with
it?  Stayed up later.

    > The IESG is looking to make a decision of the IETF-97 schedule by
    > September 30, so input before that is most useful,

You said that we don't have much space in Seoul.  We had a lot of extra space
in Berlin.  Is it that we don't have many medium sized rooms, or that we have
no small rooms for the ad-hoc self-scheduling?

I think that some WGs would benefit greatly from splitting into 3-4
<20-person rooms during their slot.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Warren Kumari <[email-masked]>
Date: Mon, 12 Sep 2016 08:57:46 -0400

> o  The start time provokes some opinions. For IETF-97 we plan to set this so that lunch and dinner times in the local situation are convenient. It might be useful to poll the community about this a…

I have found the later time to be very helpful - I can organize more
useful morning meetings (people are more awake / less rushed), I get
get my day organized, and I sleep better too (not worrying if my alarm
will go off or not!). Oh, there is also now usually a NOC planning
meeting / debrief each morning, and so I can participate in that
too...

> 2. Encouraging working groups try unstructured meeting time in one of their slots. This time could be used for free-form discussion in the whole group, an “unconference" style idea session in the d…

DPRIVE is wrapping up our "Phase 1" work, and is now moving onto the
(trickier) recursive to authoritative server part -- we are planning
on using much of our time for a BoF-style / less structured meeting to
figure out if this Phase 2 stuff is even doable.

> Q1. Please confirm that the community wishes that we arrange more unstructured time for work to happen.

I think so.

> Q2. Would you like to either keep the amount of meeting time from Berlin, or reduce it so that an additional hour(s) can be used for design team meetings and other unofficial interaction?

I'd like the meeting time to be reduced so we have more design team
time -- but don't you dare take it from any of my working groups!  I'm
concerned that "not in my back yard" answer may be common - we'd all
like more unofficial / additional time, but we also all (obviously)
believe that our own WGs are important, and so we don't want to give
up our own time.

> Q3. Any other feedback? Other suggestions?

I'm expecting pitchforks and flaming torches for this, but might it be
time to reconsider / discuss adding a full day? (Not for Seoul,
obviously, but for in the (far) future...)

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 12 Sep 2016 15:06:23 +0200

What Tim said.
(And what Michael said: Give chairs a way to structure any additional
time as is needed in *their* particular WG.)

Grüße, Carsten

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 12 Sep 2016 15:11:49 +0000

During IETF 96, I find it is very productive to have multiple informal sessions prior to the WG formal session with each session focusing on specific subjects to get key contributors to converge their differences. So that the WG session can run very smoothly and on time.

I find having formal IETF session starting at 10am is essential to enable us to set up those informal discussion sessions in the morning,  as everyone is very busy in the evening and it is very difficult to get a time slot in the evening for everyone to join.

Here is my answers to the survey:

[Linda] that is definitely very good. Suggest to have more rooms available for people to sign in their desired slots for their informal discussions.

[Linda] having formal sessions starting at 10am is important for people to have informal sessions.

Q3. Any other feedback? Other suggestions?
[Linda] IAB should also have office hours during the week. longer break time is also very useful.

Linda Dunbar

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Jari Arkko
Sent: Sunday, September 11, 2016 1:58 AM
To: WG Chairs
Subject: amount of time for WG meetings, starting times, unstructured time, etc for Seoul

2. Encouraging working groups try unstructured meeting time in one of their slots. This time could be used for free-form discussion in the whole group, an "unconference" style idea session in the different corners of the room, or a hacking session devoted to the WG's technology. All up to the WG chairs to decide. See my other mail.

Jari (for the IESG)

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 12 Sep 2016 21:44:36 +0000

>This is an interesting idea. The problem with the (otherwise very excellent) hackathon is that it’s held over the weekend before IETF, so if you do both, you’re away from home for a long time. It wo…

I am very open to experimenting with the hackathon format. There are obviously tradeoffs with any approach. We tried an experiment at IETF 96 in which we designated space in the IETF lounge for continuation of the hackathon and running code in general. The space did get used for various coding activities as well what I would describe as a rolling BOF/office hours.

One of the key outputs of each hackathon is input back into the working group sessions. Having an opportunity to iterate on this during the course of the week of the IETF meeting is even better. It would be interesting to more officially divide the traditional week day schedule into time for meeting and time for coding. This could be done in place of or in addition to the hackathon the weekend before. However, we need to make sure to not start too early or run too late as that would cut into the critical unstructured time, not to mention sleep.

Cheers,
Charles

---

From: Loa Andersson <[email-masked]>
Date: Tue, 13 Sep 2016 11:29:17 +0200

Jari, et.al,

On 2016-09-11 08:57, Jari Arkko wrote:

<snip>
> Q1. Please confirm that the community wishes that we arrange more unstructured time for work to happen.

I think it is a good thing if we can find time for "unstructured"
meetings.

Though I'm concerned about transparency and decision making. IETF
meetings are supposed to be open for all and decision being based on
discussion on the list. I have not seen this addressed anywhere.
> Q2. Would you like to either keep the amount of meeting time from Berlin, or reduce it so that an additional hour(s) can be used for design team meetings and other unofficial interaction?

I think that the morning hours opened up by starting at 10 am Mon-Thu
i a good starting point and when we have expereiences we can tweak
the scheduling.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Sep 2016 14:57:32 +0300

> don't feel like they need to leave for dinner.

This is a very interesting suggestion, thank you.

Charles… we should talk about this. I’m not sure we can do this yet in Seoul given the space constraints, unless we come up with some clever way of doing this. But lets talk.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Sep 2016 14:57:35 +0300

> isn't about lack of structure, but delegation of structure.

Yes, that’s the right way to put it. Thanks.

Jari

---

From: Michael Richardson <[email-masked]>
Date: Thu, 15 Sep 2016 08:42:53 -0400

> This is a very interesting suggestion, thank you.

It could still include the vendor exhibits.
Particularly if the vendors were prepared to rewire/reconfigure their demo
equipment...
        as in: "hmm, that's a good question. I don't know if we can do that.
               Would you like to find out?"

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 15 Sep 2016 11:54:18 -0400

>                Would you like to find out?"

Yes, but I'm with Mr. Wouters - I'd like another time to hack. 
Especially since the weekend before the IETF is now becoming the goto 
time for other events, it makes choosing hard.

tim

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 15 Sep 2016 16:58:23 +0000

Should we plan a side meeting in Seoul one evening to discuss the Hackathon, review past and current format, and bounce ideas around how to improve things going forward and/or is there time in the WG chairs lunch agenda for this?

Cheers,
Charles

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 15 Sep 2016 17:01:24 +0000

>Charles… we should talk about this. I’m not sure we can do this yet in Seoul given the space constraints, unless we come up with some clever way of doing this. But lets talk.

In Seoul, we are planning to have the space in the IETF lounge again, and we also have a table or two at B&B for the hackathon. This generally involves demos that showcase work from a few projects at the hackathon. We could try to get addition space and promote it as more of a working/coding opportunity.

Cheers,
Charles