Subject: Managing meeting materials for IETF97

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Oct 2016 09:23:00 -0700

Chairs and Secretaries -

The way you will upload slides, agendas, and minutes has changed since 
the last IETF meeting.

The easiest way to get to the place you'll manage materials is through 
your group's meeting tab.

You'll also see an "Edit" button for the groups you can manage materials 
for when looking at the meeting materials page.

We are more explicitly representing all the materials as documents - 
they have versions, and their own document page (this has been true for 
some time, but not obvious, and the way slides are versioned has changed 
to match the way documents are versioned).

One major new bit of functionality : If your group has more than one 
session at this IETF, you have the option of providing a separate agenda 
for each session (you can also provide a single agenda that covers all 
the sessions as we've done in the past). You can associate slides with 
the session they will be covered in.

We also will be building the proceedings in realtime as materials become 
available. See

https://datatracker.ietf.org/meeting/proceedings

This page will change as materials are added until we get to the 
materials deadline after the meeting. Then it will be finalized and will 
become static.

Please keep an eye on that page, especially right after the meeting and 
your materials are all in and help ensure it is showing what you want 
shown for your group.

If you have questions please let me know (consider asking on this list, 
as some other chairs and secretaries may have the same question.

If you find errors, please report them using the bug link at the bottom 
of each datatracker page.

RjS

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 25 Oct 2016 12:43:32 -0400

On Tue, Oct 25, 2016 at 12:23 PM, Robert Sparks <[email-masked]> wrote:
>
> Chairs and Secretaries -
>
> The way you will upload slides, agendas, and minutes has changed since the last IETF meeting.

This announcement seems a bit late. I've been beating my head against
a wall for a couple of days now trying to upload some agendas and have
sent a query to ietf-action about this which has not yet been
responded to. The change seems a bit incomplete and if you try to
follow a memory of the old path, things just look broken. In
particular, since "Materials" seems like the best left side link on
the datatracker main page, when you click there, you get to
https://datatracker.ietf.org/secr/proceedings/
where it says "The list(s) above includes those meetings which you can
upload materials for. Click on the meeting number or interim meeting
date to continue." This certainly gives you the impression that you
should be able to click on "97" and get to a place where (probably
after a choice of WG) you can upload. Please improve this statement -
it seems like an excellent place to add a link to where you can
actually upload materials.

> The easiest way to get to the place you'll manage materials is through your group's meeting tab.

There is no "meeting" tab. There is a "Meetings" tab. I suggest being
precise if you are giving directions for a radically different
procedure than what people are used to.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> You'll also see an "Edit" button for the groups you can manage materials for when looking at the meeting materials page.
>
> We are more explicitly representing all the materials as documents - they have versions, and their own document page (this has been true for some time, but not obvious, and the way slides are versioned has changed to match the way documents are versioned).
>
> One major new bit of functionality : If your group has more than one session at this IETF, you have the option of providing a separate agenda for each session (you can also provide a single agenda that covers all the sessions as we've done in the past). You can associate slides with the session they will be covered in.
>
> We also will be building the proceedings in realtime as materials become available. See
>
> This page will change as materials are added until we get to the materials deadline after the meeting. Then it will be finalized and will become static.
>
> Please keep an eye on that page, especially right after the meeting and your materials are all in and help ensure it is showing what you want shown for your group.
>
> If you have questions please let me know (consider asking on this list, as some other chairs and secretaries may have the same question.
>
> If you find errors, please report them using the bug link at the bottom of each datatracker page.
>
> RjS
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 25 Oct 2016 12:02:18 -0500

Robert,

There doesn’t seem to be any mechanism for WGs that aren’t meeting at IETF
97 (e.g. pals) to upload materials, such as the usual chair WG status
slides that would have otherwise been presented at the meeting, and a
placeholder for meeting minutes. We had that ability at IETF 96, and took
advantage of it to have materials in the proceedings (see
https://www.ietf.org/proceedings/96/pals.html ).

Thanks,
Andy

On Tue, Oct 25, 2016 at 11:23 AM, Robert Sparks <[email-masked]>
wrote:

> We are more explicitly representing all the materials as documents - they
> have versions, and their own document page (this has been true for some
> time, but not obvious, and the way slides are versioned has changed to
> match the way documents are versioned).
>
> for each session (you can also provide a single agenda that covers all the
> sessions as we've done in the past). You can associate slides with the
> session they will be covered in.
>
> This page will change as materials are added until we get to the materials
> deadline after the meeting. Then it will be finalized and will become
> static.
>
> your materials are all in and help ensure it is showing what you want shown
> for your group.
>
> If you have questions please let me know (consider asking on this list, as
> some other chairs and secretaries may have the same question.
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Oct 2016 10:16:28 -0700

Hi Andy -

See if this link works for you:

https://datatracker.ietf.org/meeting/97/session/pals

It _should_ do what you want. I'll work on making it more obvious how to 
get to.

RjS

On 10/25/16 10:02 AM, Andrew G. Malis wrote:
> Robert,
>
> There doesn’t seem to be any mechanism for WGs that aren’t meeting at 
> IETF 97 (e.g. pals) to upload materials, such as the usual chair WG 
> status slides that would have otherwise been presented at the meeting, 
> and a placeholder for meeting minutes. We had that ability at IETF 96, 
> and took advantage of it to have materials in the proceedings (see 
> On Tue, Oct 25, 2016 at 11:23 AM, Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Chairs and Secretaries -
>
>     You'll also see an "Edit" button for the groups you can manage
>     materials for when looking at the meeting materials page.
>
>     We are more explicitly representing all the materials as documents
>     - they have versions, and their own document page (this has been
>     true for some time, but not obvious, and the way slides are
>     versioned has changed to match the way documents are versioned).
>
>     One major new bit of functionality : If your group has more than
>     one session at this IETF, you have the option of providing a
>     separate agenda for each session (you can also provide a single
>     agenda that covers all the sessions as we've done in the past).
>     You can associate slides with the session they will be covered in.
>
>     <https://datatracker.ietf.org/meeting/proceedings>
>
>     materials deadline after the meeting. Then it will be finalized
>     and will become static.
>
>     Please keep an eye on that page, especially right after the
>     meeting and your materials are all in and help ensure it is
>     showing what you want shown for your group.
>
>     If you have questions please let me know (consider asking on this
>     list, as some other chairs and secretaries may have the same question.
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 25 Oct 2016 13:20:06 -0400

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Robert
> Sparks
...
> your group's meeting tab.
Thanks Robert, I just tried this out with a draft agenda.
wfm,
Al

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Oct 2016 10:34:45 -0700

Hi Donald -

Sorry you were having trouble.

A couple of questions inline.

> https://datatracker.ietf.org/secr/proceedings/
I don't, and I'm wondering if there's more than one "materials" link and 
I'm blind to one of them.
When I click on the Materials link in the Meeting section on the left 
navigation bar, it takes me to
https://datatracker.ietf.org/meeting/97/materials
Nothing in the main meeting flow (unless you're logged in as the 
secretariat) should be taking you to the /secr/proceedings page at this 
point.
Where is the link you're clicking that's taking you to that page?

> date to continue."

> This certainly gives you the impression that you

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 25 Oct 2016 13:59:20 -0500

Robert,

That’s much better!  And yes, please make it obvious to find.

Thanks,
Andy

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 25 Oct 2016 15:14:05 -0400

> On Oct 25, 2016, at 12:23 PM, Robert Sparks <[email-masked]> wrote:
> 
> Chairs and Secretaries -
> 

I presume you mean the Meetings tab on the datatracker.ietf.org/wg/<yourwghere> page?

Interestingly, if I go to https://www.ietf.org/meeting/97/ and click on the  Meeting Materials  (the way I’ve always managed materials in the past), I get to a page

https://datatracker.ietf.org/meeting/96/materials.html
IETF 96 Preliminary & Interim Materials

which would have been a bit disconcerting if I had not already read this message.

The Meetings tab on the datatracker sidr page gets me to https://datatracker.ietf.org/wg/sidr/meetings/ which shows the IETF 97 session - with Materials way over on the right, which gets me to a very very different materials management site than I previously used.  (I look forward to finding the way to do replacements and reordering, features that were added to the old system along the way.)

From https://www.ietf.org/meeting/97/, if I click on Meeting Materials Manager, I get to the WG Chair Dashboard I am used to, but from there clicking on 97 gets me to the https://datatracker.ietf.org/meeting/97/materials - IETF 97 meeting materials page - i.e., the proceedings site, not a submission site.

There’s another path that gets to the Dashboard.  If I start at the www.ietf.org home page, click on Meetings in the left side bar, I get to https://www.ietf.org/meeting/, and if I click there on How To Submit Meeting Materials,  I get to https://www.ietf.org/wg/meeting-materials.html and if I click on The IETF Meeting Materials Management Tool (twice) I get to the Dashboard.

If the Dashboard is not going to be used anymore, should/could the links that get you there get changed to protect the clueless?

I like the double agendas for double sessions feature.  That has always been less than optimal before.  Dual sessions sometimes mean some presentations get moved between sessions.  So chairs will be responsible for saying “Look in Wed session materials for these slides, I’ll switch them so they're under the right session in the materials. “  Hm.  “… as soon as my laptop is no longer the presentation laptop”.  Hm.  I suppose Meetecho will have to deal with last minute schedule adjustments like that as well.  Hm.  maybe better to have all slides under both and adjust the proceedings accordingly later.

—Sandy

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 25 Oct 2016 16:09:07 -0400

Hi,

By the way, the WG Chair Wiki home page links to a Meeting Materials
page which seems out of date and in turn references and give
instructions for "The IETF Meeting Materials Management Tool" which
instructions no longer work.

See below.

On Tue, Oct 25, 2016 at 1:34 PM, Robert Sparks <[email-masked]> wrote:
> I don't, and I'm wondering if there's more than one "materials" link and I'm
> blind to one of them.

Sorry, you seem to be correct. I was trying lots of paths yesterday,
none of which worked, and apparently misremembered how I got there. It
was by going to the Meeting Materials Manager URL,
https://datatracker.ietf.org/cgi-bin/wg/wg_proceedings.cgi
I have saved in my bookmarks in one browser but not another browser.
Perhaps there are others who bookmarked by Meeting Materials Manager
so perhaps they should get a useful error if they go there.

> Where is the link you're clicking that's taking you to that page?

See above.

See also further below.

>> procedure than what people are used to.

Where exactly should this Edit button be? When I'm on the
https://datatracker.ietf.org/meeting/97/materials web page using
Chrome on a Macintosh logged in as shown by my identity in white
letters on a dark background at the top, I do not see any Edit button
for any of the groups for which I should be able to
upload/update/delete materials. In fact, the only occurrences of the
string "Edit" on that web page as I see it are in the "Edit profile"
item near the top left and in the "RFC Editor" item at the bottom.

Thanks,
Donald

>>> time, but not obvious, and the way slides are versioned has changed to match
>>> the way documents are versioned).
>>>
>>> session at this IETF, you have the option of providing a separate agenda for
>>> each session (you can also provide a single agenda that covers all the

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Oct 2016 13:24:38 -0700

(trimming to answer one question).
> item near the top left and in the "RFC Editor" item at the bottom.
It will be next to or under your the name of the group (depending on how 
wide a screen the device you are using is).
See 
<https://www.dropbox.com/s/zeo7ffjab6c90in/Screenshot%202016-10-25%2013.22.05.png?dl=0> 
for an example.
RjS

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 25 Oct 2016 15:34:45 -0500

Robert

Ummmm … https://datatracker.ietf.org/meeting/97/materials has a working
“Edit” button for EVERY WG for me, not just the ones I should be able to
edit. All of a sudden, I’m the proceedings superuser!

BTW, the pals WG doesn’t show up at all on this page, presumably because
it’s not meeting at IETF 97. I think it should show up, anyway.

Thanks,
Andy

On Tue, Oct 25, 2016 at 3:24 PM, Robert Sparks <[email-masked]> wrote:

> See <https://www.dropbox.com/s/zeo7ffjab6c90in/Screenshot%202016
> -10-25%2013.22.05.png?dl=0> for an example.
>
>>
>> RjS
>
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Oct 2016 13:38:37 -0700

On 10/25/16 1:34 PM, Andrew G. Malis wrote:
> Robert
>
> Ummmm … https://datatracker.ietf.org/meeting/97/materials has a 
> working “Edit” button for EVERY WG for me, not just the ones I should 
> be able to edit. All of a sudden, I’m the proceedings superuser!
Interesting... I'll dig into it.
>
> BTW, the pals WG doesn’t show up at all on this page, presumably 
> because it’s not meeting at IETF 97. I think it should show up, anyway.
Yes - I'll need to make something like a "will not meet" section to that 
page.
>
> Thanks,
> Andy
>
>
> On Tue, Oct 25, 2016 at 3:24 PM, Robert Sparks <[email-masked] 
>         <https://datatracker.ietf.org/meeting/97/materials> web page using
>     It will be next to or under your the name of the group (depending
>     on how wide a screen the device you are using is).
>     See
>     <https://www.dropbox.com/s/zeo7ffjab6c90in/Screenshot%202016-10-25%2013.22.05.png?dl=0
>     <https://www.dropbox.com/s/zeo7ffjab6c90in/Screenshot%202016-10-25%2013.22.05.png?dl=0>>
>     for an example.
>
>
>     RjS
>
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 25 Oct 2016 14:04:57 -0700

> On Oct 25, 2016, at 1:34 PM, Andrew G. Malis <[email-masked]> wrote:
> 
> Robert
> 
> Ummmm … https://datatracker.ietf.org/meeting/97/materials has a working “Edit” button for EVERY WG for me, not just the ones I should be able to edit. All of a sudden, I’m the proceedings superuser!

Have fun.  I only get my w.g. :-)

Bob

> 
> BTW, the pals WG doesn’t show up at all on this page, presumably because it’s not meeting at IETF 97. I think it should show up, anyway.
> 
> Thanks,
> Andy
> 
> 
> It will be next to or under your the name of the group (depending on how wide a screen the device you are using is).
> See <https://www.dropbox.com/s/zeo7ffjab6c90in/Screenshot%202016-10-25%2013.22.05.png?dl=0> for an example.
> 
> RjS
> 
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 25 Oct 2016 14:07:40 -0700

Robert,

On the IETF97 Materials page, I see some w.g.’s with a link to an agenda.  Unfortunately, they all go to a "404: Page Not Found”.

Bob

> On Oct 25, 2016, at 1:38 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> Yes - I'll need to make something like a "will not meet" section to that page.
>> 
>> Thanks,
>> Andy
>> 
>>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Oct 2016 14:15:34 -0700

Thanks Bob -

It looks like the page is building the URLs incorrectly (tests should 
have caught this, but we're in a transition period with where we're 
pointing for the bits on disk and that made building the tests hard).

Links like

https://www.ietf.org/proceedings/97/agenda/agenda-97-regext

should have been

https://www.ietf.org/proceedings/97/agenda/agenda-97-regext-00

We'll get it fixed quickly.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 25 Oct 2016 14:39:24 -0700

> On Oct 25, 2016, at 2:15 PM, Robert Sparks <[email-masked]> wrote:
> 
> Thanks Bob -
> 
> It looks like the page is building the URLs incorrectly (tests should have caught this, but we're in a transition period with where we're pointing for the bits on disk and that made building the tests hard).
> 
> Links like
> 

No doubt.

Thanks,
Bob

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Oct 2016 23:41:57 +0200

> We'll get it fixed quickly.

This should be fixed now.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Oct 2016 23:50:23 +0200

> instructions no longer work.

I've edited the wiki page to point at the new meeting materials page.

Best regards,

	Henrik

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 26 Oct 2016 11:59:43 -0400

The materials page "Edit" buttons continue to be erratic, presumably
because the code continues to be buggy. Although earlier I was seeing
no Edit buttons, last night (eastern US time) I was seeing the correct
number of Edit buttons and I did upload one agenda. Just now I went to
the Materials page again and all items show an Edit button for me (see
attached). This made it easy to upload the remaining items that I want
to upload now but is obviously wrong. All I had to do was open another
tab in my browser window and go to the Materials page again and this
time I see the right number of Edit buttons... (As before, using
Chrome on a Macintosh)

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Tue, Oct 25, 2016 at 5:15 PM, Robert Sparks <[email-masked]> wrote:
> Thanks Bob -
>
> It looks like the page is building the URLs incorrectly (tests should have
> caught this, but we're in a transition period with where we're pointing for
> the bits on disk and that made building the tests hard).
>
> Links like
>
>> On the IETF97 Materials page, I see some w.g.’s with a link to an agenda.
>> Unfortunately, they all go to a "404: Page Not Found”.
>>
>> Bob
>>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 26 Oct 2016 09:02:50 -0700

There was a caching issue on the page that was corrected in the last hour.

That bit of instability should be gone now.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 26 Oct 2016 18:12:08 +0200

Hi Donald,

As far as I can tell, this was a page caching problem.  I believe I've
fixed it (as of 15:43 UTC today), so you should find the behaviour more
consistent now.  Sorry for the bother :-(, and thanks for the reports :-)

Best regards,

	Henrik

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 26 Oct 2016 11:30:56 -0500

Hi, Robert,

> session they will be covered in.

One MINOR new bit of functionality: it's never been easier for this AD to
spot which of my groups have/have not posted agendas before a meeting.
Thanks for that part, too!

And the TSV chairs shouldn't panic, because the ADs haven't posted an
agenda for TSVAREA yet either, but agendas are due by 10-31.

And way to go, Brian and Bill in IPPM. Now the rest of us can catch up :p
...

Spencer