Subject: IETF list archive

From: Aaron Falk <[email-masked]>
Date: Thu, 17 Nov 2016 10:39:35 +0900

I am frequently despondent about the signal-to-noise on the IETF mail list but still feel compelled to check in periodically.  We now have two archives for browsing the list archives and both have some significant shortcomings.  The Mhonarc view does a decent job of showing threads but doesn’t do line wraps <https://www.ietf.org/mail-archive/web/ietf/current/msg99875.html> frequently making it impossible to read the messages.  The Mailarchive does a lousy job <https://mailarchive.ietf.org/arch/search/?email_list=ietf&gbt=1&index=ny3Pdf8YYcrH_Jnjpwdyu3KOW5E> of threading.  Can we (should we) do better?

—aaron

---

From: Russ Housley <[email-masked]>
Date: Wed, 16 Nov 2016 20:47:59 -0500

Aaron:

Please see RFC 7842.  The changes described there are under development now.

Russ

On Nov 16, 2016, at 8:39 PM, Aaron Falk <[email-masked]> wrote:

> I am frequently despondent about the signal-to-noise on the IETF mail list but still feel compelled to check in periodically.  We now have two archives for browsing the list archives and both have some significant shortcomings.  The Mhonarc view does a decent job of showing threads but doesn’t do line wraps frequently making it impossible to read the messages.  The Mailarchive does a lousy job of threading.  Can we (should we) do better?
> 
> —aaron

---

From: Aaron Falk <[email-masked]>
Date: Thu, 17 Nov 2016 10:49:36 +0900

Excellent.  Thanks!

> On Nov 17, 2016, at 10:47 AM, Russ Housley <[email-masked]> wrote:
> 
> Aaron:
> 
> On Nov 16, 2016, at 8:39 PM, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: Aaron Falk <[email-masked]>
Date: Thu, 17 Nov 2016 11:27:52 +0900

Thanks for the clue.  Chrome has a similar thing that always wraps: "<pre> Line Wrapper": https://chrome.google.com/webstore/detail/%3Cpre%3E-line-wrapper/nhljfekjbhmbibnfeehbgfeccakopaod?utm_source=gmail <https://chrome.google.com/webstore/detail/%3Cpre%3E-line-wrapper/nhljfekjbhmbibnfeehbgfeccakopaod?utm_source=gmail>

—aaron

> On Nov 17, 2016, at 11:13 AM, Black, David <[email-masked]> wrote:
> 
> For anyone using Firefox, this plugin fixes the line wrap problem: https://addons.mozilla.org/en-US/firefox/addon/toggle-word-wrap/ <https://addons.mozilla.org/en-US/firefox/addon/toggle-word-wrap/>
>  
> The plugin adds a “Word Wrap within <PRE>”  item to the browser’s View menu with a Ctrl-Shift-Q quick key.
> I just checked this plugin on the Mhonarc message linked below - the plugin works.
>  
> Thanks, --David
>  
> From: WGChairs [mailto:[email-masked]] On Behalf Of Aaron Falk
> Sent: Wednesday, November 16, 2016 8:50 PM
> To: Russ Housley
> Cc: IETF WG Chairs; [email-masked]
> Subject: Re: [irsg] IETF list archive
>  
> Excellent.  Thanks!
>  
> On Nov 17, 2016, at 10:47 AM, Russ Housley <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Aaron:
>

---

From: "Black, David" <[email-masked]>
Date: Thu, 17 Nov 2016 02:13:36 +0000

For anyone using Firefox, this plugin fixes the line wrap problem: https://addons.mozilla.org/en-US/firefox/addon/toggle-word-wrap/

The plugin adds a "Word Wrap within <PRE>"  item to the browser's View menu with a Ctrl-Shift-Q quick key.
I just checked this plugin on the Mhonarc message linked below - the plugin works.

Thanks, --David

Excellent.  Thanks!

On Nov 17, 2016, at 10:47 AM, Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:

Aaron:

Russ

On Nov 16, 2016, at 8:39 PM, Aaron Falk <[email-masked]<mailto:[email-masked]>> wrote:

I am frequently despondent about the signal-to-noise on the IETF mail list but still feel compelled to check in periodically.  We now have two archives for browsing the list archives and both have some significant shortcomings.  The Mhonarc view does a decent job of showing threads but doesn't do line wraps<https://www.ietf.org/mail-archive/web/ietf/current/msg99875.html> frequently making it impossible to read the messages.  The Mailarchive does a lousy job<https://mailarchive.ietf.org/arch/search/?email_list=ietf&gbt=1&index=ny3Pdf8YYcrH_Jnjpwdyu3KOW5E> of threading.  Can we (should we) do better?

-aaron

---

From: joel jaeggli <[email-masked]>
Date: Thu, 17 Nov 2016 13:52:20 +0900

On 11/17/16 10:39 AM, Aaron Falk wrote:
> I am frequently despondent about the signal-to-noise on the IETF mail
> list but still feel compelled to check in periodically.  We now have two
> archives for browsing the list archives and both have some significant
> shortcomings.

we have three really because you can anonymously subscribe to them via imap

https://trac.tools.ietf.org/group/tools/trac/wiki/Imap

at which point you can ingest them into the mail spindling platform of
your choice.

>  The Mhonarc view does a decent job of showing threads
> but doesn’t do line wraps
> <https://www.ietf.org/mail-archive/web/ietf/current/msg99875.html> frequently
> making it impossible to read the messages.  The Mailarchive does a lousy
> job
> <https://mailarchive.ietf.org/arch/search/?email_list=ietf&gbt=1&index=ny3Pdf8YYcrH_Jnjpwdyu3KOW5E> of
> threading.  Can we (should we) do better?
> 
> —aaron

---

From: Aaron Falk <[email-masked]>
Date: Thu, 17 Nov 2016 17:19:31 +0900

On Nov 17, 2016, at 1:52 PM, joel jaeggli <[email-masked]> wrote:
> https://trac.tools.ietf.org/group/tools/trac/wiki/Imap <https://trac.tools.ietf.org/group/tools/trac/wiki/Imap>
> 

Sounds appealing however I’m unable to get either an authenticated or anonymous account setup on Mail.app on OS X 10.11.6.  Anyone with success who can offer a clue would be appreciated…

—aaron