Subject: agendas/meeting materials

From: "John G. Scudder" <[email-masked]>
Date: Fri, 4 Nov 2016 13:27:03 -0400

Hi Everybody,

At earlier meetings, working group agendas had a stable name, and updating my working group's agenda would overwrite the old version. This doesn't seem to be the case any more, my first revision was published as -00 and my current revision is -01.

While access to the revision history is nice for transparency, I think it's a significantly bad thing if there is no URL that means "just give me the current agenda". We have this for Internet drafts, if I leave the -XX off, I get whatever the latest revision is. Trying to do the same with my agenda, though, it just doesn't resolve.  As far as I can tell, there is no way to publish a URL that takes you straight to the head version of my agenda, only to a particular revision.

While I'm asking for things, the behavior for referencing an Internet draft without a version number is not quite the desirable one for agendas and other meeting materials, in my opinion. When I leave the version number off an Internet draft, I get redirected to the latest revision, so if I reload that page, I'm anchored to that revision, even if the draft has subsequently been updated. For agendas, I think it would be desirable for a reload to cause the current revision to be loaded.

I'm not sure when the change was made, or why, or if it was announced, but I hope we can fix it.

Thanks,

--John

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 4 Nov 2016 13:42:31 -0400

> On Nov 4, 2016, at 1:27 PM, John G. Scudder <[email-masked]> wrote:

While I can't comment on the whole system, I often do something like the following:

https://tools.ietf.org/html/draft-ietf-idr-error-handling <https://tools.ietf.org/html/draft-ietf-idr-error-handling> - takes you to the latest

https://tools.ietf.org/html/draft-ietf-idr-error-handling-15 <https://tools.ietf.org/html/draft-ietf-idr-error-handling-15> takes you to a specific version.

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 4 Nov 2016 14:04:36 -0400

> https://tools.ietf.org/html/draft-ietf-idr-error-handling <https://tools.ietf.org/html/draft-ietf-idr-error-handling> - takes you to the latest

Yes exactly, but that serves up

https://tools.ietf.org/html/draft-ietf-idr-error-handling-19

So reloads end up just giving me -19 again, even if the draft is subsequently updated to -20. This may be desirable for Internet drafts, but I argue it isn't for meeting materials and in particular agendas.

--John

---

From: Pat Thaler <[email-masked]>
Date: Fri, 4 Nov 2016 11:17:12 -0700

At least in the case of internet drafts, it serves it up with a list of
revisions so you can check that and click on that for the latest draft.

For agendas, there isn't a list of revisions at the top to clue you in that
you might be looking at an out of date version.

On Fri, Nov 4, 2016 at 11:04 AM, John G. Scudder <[email-masked]> wrote:

> https://tools.ietf.org/html/draft-ietf-idr-error-handling - takes you to
> the latest
>
>
> So reloads end up just giving me -19 again, even if the draft is
> subsequently updated to -20. This may be desirable for Internet drafts, but
> I argue it isn't for meeting materials and in particular agendas.
>
> --John
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 4 Nov 2016 13:30:00 -0500

On 11/4/16 1:04 PM, John G. Scudder wrote:
> On Nov 4, 2016, at 1:42 PM, Jeffrey Haas <[email-masked] 
> <mailto:[email-masked]>> wrote:
>>
>> https://tools.ietf.org/html/draft-ietf-idr-error-handling - takes you 
>> to the latest
>
The datatracker on the other hand will serve the current version if you 
leave off the version string, but does not do a redirect

https://datatracker.ietf.org/doc/draft-ietf-idr-error-handling

will always give you the most recent version of the draft.
If you need a specific version, you can get it with

https://datatracker.ietf.org/doc/draft-ietf-idr-error-handling/19

> subsequently updated to -20. This may be desirable for Internet 
> drafts, but I argue it isn't for meeting materials and in particular 
> agendas.
>
> --John

---

From: Robert Sparks <[email-masked]>
Date: Fri, 4 Nov 2016 13:34:35 -0500

> While access to the revision history is nice for transparency, I think it's a significantly bad thing if there is no URL that means "just give me the current agenda". We have this for Internet draf…
I think perhaps you are looking for
https://datatracker.ietf.org/doc/agenda-97-idr/
or maybe
https://datatracker.ietf.org/meeting/97/agenda/idr/

Both links will give you the current version.
> While I'm asking for things, the behavior for referencing an Internet draft without a version number is not quite the desirable one for agendas and other meeting materials, in my opinion. When I le…
I responded to this in a later message on the thread. You are describing 
behavior at tools.ietf.org.
The datatracker's use of the URLs will mesh better with your 
reload-this-page use case.

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 4 Nov 2016 16:05:52 -0400

Thanks, Robert.

In tracking where my confusion came from, I think it's because I generally grab the agenda URL I'm presented with as soon as I finish uploading the agenda using the Meeting Materials Manager, and forward that to the WG. Looking back through the WG archives, historically that has been the www.ietf.org agenda. It appears the www.ietf.org version of the agenda used to have the most-recent-revision semantics I described previously, and that apparently are still present in the datatracker version. For example, 

https://www.ietf.org/proceedings/96/agenda/agenda-96-idr

resolves just fine, and has no associated version number, but if I try that with IETF 97 there is a version number:

https://www.ietf.org/proceedings/97/agenda/agenda-97-idr-01.txt

So the semantic change I described did occur (AFAICT). Now that I know about the workaround, I can use it, thanks. I do have to say I've always found the overlapping-but-not-quite-semantically-the-same functionalities of datatracker, tools, and www.ietf.org to be kind of painful exactly for this kind of reason. I've no doubt there are reasons for all of it, some of them even good. And I'm not volunteering to fix it, so now is probably a good time for me to STFU. Which I will do after two more paragraphs.

I still think the addition of the version number in the www.ietf.org variant is likely to cause (hopefully only small) problems, because people with a workflow similar to mine may expect that if they hit "reload" on an already-displayed agenda, they will automatically see the latest thing. But I see the agenda that presents when following www.ietf.org -> IETF 97 Agenda -> Inter-Domain Routing is indeed the (versionless) datatracker agenda so maybe this will not be much of a problem.

(For anyone who cares, the flow I followed to get the versioned agenda was datatracker.ietf.org -> Materials -> idr Agenda. Which gives me the www.ietf.org proceedings one. So if I start from www.ietf.org I end up on datatracker and get what I want, and if I start from datatracker I end up on www.ietf.org and get what I don't want. I'm going to go drink now, thank you.)

Thanks again,

--John

> On Nov 4, 2016, at 2:34 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> I responded to this in a later message on the thread. You are describing behavior at tools.ietf.org.
> The datatracker's use of the URLs will mesh better with your reload-this-page use case.
>>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 4 Nov 2016 15:38:43 -0500

On 11/4/16 3:05 PM, John G. Scudder wrote:
> So the semantic change I described did occur (AFAICT).
Yes - what you were seeing at www was some leakage of the artifacts on 
the filesystem - as part of evolving the proceedings, we needed to 
change the way the filesystem is structured. As part of supporting 
having different agendas for different sessions of the same working 
group at a meeting, we had to change the way the files are named. It was 
also useful to normalize the treatment of Document objects in the 
datatracker so that the code handling agendas (and minutes) was not so 
incredibly different from the code handling drafts, conflict-reviews, 
status-changes, and the other document types.
>   Now that I know about the workaround, I can use it, thanks. I do have to say I've always found the overlapping-but-not-quite-semantically-the-same functionalities of datatracker, tools, and www.ietf.org to be kind of painful exactly for this kind of reason. I've no doubt there are reasons for all of it, some of them even good. And I'm not volunteering to fix it, so now is probably a good time for me to STFU. Which I will do after two more paragraphs.
We're putting a lot of pressure on making the datatracker be the one 
place to do these things. The very useful aspects at tools.ietf.org are 
being reflected in the datatracker as much as we can.
> (For anyone who cares, the flow I followed to get the versioned agenda was datatracker.ietf.org -> Materials -> idr Agenda. Which gives me the www.ietf.org proceedings one. So if I start from www.ietf.org I end up on datatracker and get what I want, and if I start from datatracker I end up on www.ietf.org and get what I don't want.
Thanks for sharing the flow - I'll see if I can follow it and make it 
less likely that you end up in the "don't want" place.
>   I'm going to go drink now, thank you.)
>
> Thanks again,
>
> --John
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 7 Nov 2016 07:59:23 -0600

Speaking only for me ...

On Fri, Nov 4, 2016 at 3:38 PM, Robert Sparks <[email-masked]> wrote:

>> In tracking where my confusion came from, I think it's because I
>> generally grab the agenda URL I'm presented with as soon as I finish
>> uploading the agenda using the Meeting Materials Manager, and forward that
>> to the WG. Looking back through the WG archives, historically that has been
>> the www.ietf.org agenda. It appears the www.ietf.org version of the
>> agenda used to have the most-recent-revision semantics I described
>> previously, and that apparently are still present in the datatracker
>> version. For example,
>>
>> resolves just fine, and has no associated version number, but if I try
>> that with IETF 97 there is a version number:
>>
> Yes - what you were seeing at www was some leakage of the artifacts on the
> filesystem - as part of evolving the proceedings, we needed to change the
> way the filesystem is structured. As part of supporting having different
> agendas for different sessions of the same working group at a meeting, we
> had to change the way the files are named. It was also useful to normalize
> the treatment of Document objects in the datatracker so that the code
> handling agendas (and minutes) was not so incredibly different from the
> code handling drafts, conflict-reviews, status-changes, and the other
> document types.
>
>>   Now that I know about the workaround, I can use it, thanks. I do have
>> to say I've always found the overlapping-but-not-quite-semantically-the-same
>> functionalities of datatracker, tools, and www.ietf.org to be kind of
>> painful exactly for this kind of reason. I've no doubt there are reasons
>> for all of it, some of them even good. And I'm not volunteering to fix it,
>> so now is probably a good time for me to STFU. Which I will do after two
>> more paragraphs.
>>
> We're putting a lot of pressure on making the datatracker be the one place
> to do these things. The very useful aspects at tools.ietf.org are being
> reflected in the datatracker as much as we can.

I can tell.

I've used the tools version of anything by default when it was available
for years, and I seem to be right at the tipping point of using the
datatracker version by default instead, starting in this IETF meeting
cycle.

YMMV, of course.

Thanks to everyone who has helped us figure out what the IETF is doing, for
years!

Spencer

>
>
>> I still think the addition of the version number in the www.ietf.org
>> variant is likely to cause (hopefully only small) problems, because people
>> with a workflow similar to mine may expect that if they hit "reload" on an
>> already-displayed agenda, they will automatically see the latest thing. But
>> I see the agenda that presents when following www.ietf.org -> IETF 97
>> Agenda -> Inter-Domain Routing is indeed the (versionless) datatracker
>> agenda so maybe this will not be much of a problem.
>>
>> (For anyone who cares, the flow I followed to get the versioned agenda
>> was datatracker.ietf.org -> Materials -> idr Agenda. Which gives me the
>> www.ietf.org proceedings one. So if I start from www.ietf.org I end up
>> on datatracker and get what I want, and if I start from datatracker I end
>> up on www.ietf.org and get what I don't want.
>>
> Thanks for sharing the flow - I'll see if I can follow it and make it less
> likely that you end up in the "don't want" place.
>
>>>> At earlier meetings, working group agendas had a stable name, and
>>>> updating my working group's agenda would overwrite the old version. This
>>>> doesn't seem to be the case any more, my first revision was published as
>>>> -00 and my current revision is -01.
>>>>
>>>> While access to the revision history is nice for transparency, I think
>>>> it's a significantly bad thing if there is no URL that means "just give me
>>>> the current agenda". We have this for Internet drafts, if I leave the -XX
>>>> off, I get whatever the latest revision is. Trying to do the same with my
>>>> agenda, though, it just doesn't resolve.  As far as I can tell, there is no
>>>> way to publish a URL that takes you straight to the head version of my
>>>> agenda, only to a particular revision.
>>>>
>>>> While I'm asking for things, the behavior for referencing an Internet
>>>> draft without a version number is not quite the desirable one for agendas
>>>> and other meeting materials, in my opinion. When I leave the version number
>>>> off an Internet draft, I get redirected to the latest revision, so if I
>>>> reload that page, I'm anchored to that revision, even if the draft has
>>>> subsequently been updated. For agendas, I think it would be desirable for a
>>>> reload to cause the current revision to be loaded.
>>>>