Subject: WG Wiki Move

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 04 Nov 2016 15:28:14 +0100

Hi,

As part of the work of moving tools identified as Mission Critical Tools
from the tools servers to the secretariat-managed servers, we are now
ready to move the WG wikis/issue trackers.  The move is planned for this
weekend, and will be limited to Saturday November 5th if everything goes
smoothly.

If you have a WG Trac instance on https://trac.tools.ietf.org/wg/$WG/trac/,
the new location will be https://trac.ietf.org/trac/$WG/.  Redirects will
be in place on tools, so links will continue to work.

As part of the move, there will also be an upgrade of the Trac version used,
and the tools styling with the left-hand tools menubar will be removed;
so please don't be surprised if your wiki and issue tracker doesn't look
exactly the way you're used to, next week.  All the content will have been
moved over.

If you notice any issues as a direct consequence of this move, please report
them to [email-masked], with Cc: [email-masked], [email-masked],
[email-masked].

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 05 Nov 2016 22:25:49 +0100

Hi,

The move of all WG wikis from trac.tools.ietf.org to trac.ietf.org should
now be complete.  If you see issues with the WG wiki and issue trackers
after the move, please don't hesitate to report to [email-masked],
with Cc: [email-masked], [email-masked], [email-masked].

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Sun, 6 Nov 2016 10:09:04 +0000

> be in place on tools, so links will continue to work.

There doesn't seem to be a redirect for the IRTF wiki (https://trac.tools.ietf.org/group/irtf/trac/wiki), and I can't construct the new location from the pattern substitution rule you gave above.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 06 Nov 2016 12:53:06 +0100

Hi Lars,

> There doesn't seem to be a redirect for the IRTF wiki (https://trac.tools.ietf.org/group/irtf/trac/wiki), and I can't construct the new location from the pattern substitution rule you gave above.

After moving all the wg trac instances, I put the copies on 
trac.tools.ietf.org 'in the attic'.  It looks as if that cleanup action
covered a bit more than I intended.

I had intended (and still intend) to move the groups under
trac.ietf.org/group/ later today, and put in redirects.  As of right now,
they are still available at the old location (now that I've pulled them
back from the attic).

Sorry for the interruption :-(

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 06 Nov 2016 21:07:54 +0100

In addition to the WG wikis, the following wikis have now also been moved:

 irtf iesg iab wgchairs edu rsoc app gen int ops rai rtg sec tsv

A few old ad-hoc wikis such as diversity-dt, dhcpv6bis, ppm-legacy-review
and proto has _not_ been moved -- they don't have matching groups in the
datatracker, which excludes them from automatic maintenance based on the
role information in the datatracker.

If you are aware of a wiki which should have been moved, but hasn't, please
let me know.  And if there are any issues related to the move, the same goes.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 7 Nov 2016 08:02:52 +0000

> irtf iesg iab wgchairs edu rsoc app gen int ops rai rtg sec tsv

On https://trac.ietf.org/trac/irtf/wiki, the bottom link is [source:/www IRTF web site source code].

Issue #1, that doesn't get rendered as a link anymore; was "source" provided by a plugin?

Issue #2, when I click "Browse Source", our subversion repo is gone?

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 07 Nov 2016 12:26:59 +0100

Hi Lars,

> Issue #2, when I click "Browse Source", our subversion repo is gone?

Transfer of the repositories was part of the scripted move, but there were
a number of special cases, and I may have missed something.  The IRTF
has been transferred now, and synced with Trac.  This seems to have fixed
both issue #1 and issue #2 above.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 7 Nov 2016 14:14:18 +0000

Thanks!

On 2016-11-07, at 12:26, Henrik Levkowetz <[email-masked]> wrote:
> _______________________________________________
> BOFChairs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bofchairs

---

From: Qin Wu <[email-masked]>
Date: Thu, 10 Nov 2016 06:46:26 +0000

Diff tools seems broken, when clicking diff1 and diff2 that is embedded at the top of I-D, it complains that no file can be retrieved and therefore I can not get diff comparing result as before.

-Qin
-----邮件原件-----
发件人: WGChairs [mailto:[email-masked]] 代表 Henrik Levkowetz
发送时间: 2016年11月6日 5:26
收件人: WG Chairs
抄送: Matt Larson; Glen Barney; Robert J Sparks
主题: Re: WG Wiki Move

Hi,

The move of all WG wikis from trac.tools.ietf.org to trac.ietf.org should now be complete.  If you see issues with the WG wiki and issue trackers after the move, please don't hesitate to report to [email-masked], with Cc: [email-masked], [email-masked], [email-masked].

Best regards,

	Henrik

On 2016-11-04 15:28, Henrik Levkowetz wrote:
> Hi,
> 
> As part of the work of moving tools identified as Mission Critical 
> Tools from the tools servers to the secretariat-managed servers, we 
> are now ready to move the WG wikis/issue trackers.  The move is 
> planned for this weekend, and will be limited to Saturday November 5th 
> if everything goes smoothly.
> 
> If you have a WG Trac instance on 
> https://trac.tools.ietf.org/wg/$WG/trac/,
> the new location will be https://trac.ietf.org/trac/$WG/.  Redirects 
> will be in place on tools, so links will continue to work.
> 
> As part of the move, there will also be an upgrade of the Trac version 
> used, and the tools styling with the left-hand tools menubar will be 
> removed; so please don't be surprised if your wiki and issue tracker 
> doesn't look exactly the way you're used to, next week.  All the 
> content will have been moved over.
> 
> If you notice any issues as a direct consequence of this move, please 
> report them to [email-masked], with Cc: [email-masked], 
> [email-masked], [email-masked].
> 
> 
> Best regards,
> 
> 	Henrik
> 
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 10 Nov 2016 08:19:05 +0100

Hi Qin,

This was unrelated to the wiki move.  New SSL certs on the http server,
and a slight misguided apache reconfig.

Should be fixed now.

Best regards,

	Henrik

---

From: Qin Wu <[email-masked]>
Date: Thu, 10 Nov 2016 07:21:26 +0000

Thanks. It works now.

-Qin
-----邮件原件-----
发件人: Henrik Levkowetz [mailto:[email-masked]] 
发送时间: 2016年11月10日 15:19
收件人: Qin Wu; WG Chairs
抄送: Matt Larson; Glen Barney; Robert J Sparks
主题: Re: WG Wiki Move

Hi Qin,

This was unrelated to the wiki move.  New SSL certs on the http server, and a slight misguided apache reconfig.

Should be fixed now.

Best regards,

	Henrik

On 2016-11-10 07:46, Qin Wu wrote:
>> planned for this weekend, and will be limited to Saturday November 
>> 5th if everything goes smoothly.
>> 
>> As part of the move, there will also be an upgrade of the Trac 
>> version used, and the tools styling with the left-hand tools menubar 
>> will be removed; so please don't be surprised if your wiki and issue 
>> tracker doesn't look exactly the way you're used to, next week.  All 
>> the content will have been moved over.
>>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 10 Nov 2016 08:57:03 -0600

Is anyone else getting

Error

TracError: MissingSectionHeaderError: File contains no section headers.
file: /a/www/trac-setup/conf/trac.ini, line: 1
'\xef\xbb\xbf# -*- coding: utf-8 -*-\n'

from, for instance, https://trac.ietf.org/trac/iesg/?

Curiously,

Spencer

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 10 Nov 2016 14:58:36 +0000

Yes - https://trac.ietf.org/trac/sfc/ gives the same error.

Jim

From: WGChairs <[email-masked]<mailto:[email-masked]>> on behalf of Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 10, 2016 at 9:57 AM
To: Qin Wu <[email-masked]<mailto:[email-masked]>>
Cc: Matt Larson <[email-masked]<mailto:[email-masked]>>, WG Chairs <[email-masked]<mailto:[email-masked]>>, Robert J Sparks <[email-masked]<mailto:[email-masked]>>, Henrik Levkowetz <[email-masked]<mailto:[email-masked]>>, Glen Barney <[email-masked]<mailto:[email-masked]>>
Subject: Re: [irsg] WG Wiki Move

Is anyone else getting

Error

Curiously,

Spencer

---

From: Matt Larson <[email-masked]>
Date: Thu, 10 Nov 2016 10:17:01 -0500

Greetings all!

There was an encoding issue with the config file.  It has been fixed now, and the Trac instances are loading without the error.

Matt

> On Nov 10, 2016, at 9:57 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Is anyone else getting 
> Error
> 
> from, for instance, https://trac.ietf.org/trac/iesg/ <https://trac.ietf.org/trac/iesg/>?
> 
> Curiously,
> 
> Spencer

-------------------------------------------
Matthew Larson, Software Engineer
Association Management Solutions
Forum Management, Meeting and Event Planning
5177 Brandin Court
Fremont, CA  94538

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 10 Nov 2016 22:46:57 +0100

Hi Spencer,

This was a UTF-8 BOM which had sneaked into a config file, and a config
module which doesn't understand them.  Removed, which should fix this.

Sorry for the bother!

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 11 Nov 2016 03:40:44 +0100

Hi,

Some additional information, which was too obvious to me, knowing how
things are arranged, but isn't at all obvious when looking from the
outside:

With the move of the wikis from tools.ietf.org to ietf.org, the login
you need to use in order to edit the wikis also changes from the tools
login to the login administered by the datatracker.  Please use your
datatracker username and password in order to log in to edit the wikis
in their new location.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 12 Nov 2016 10:55:22 +0900

I’m not sure that this applies to the SVN (which was moved as well).
Despite the usual dance about the Starfield certificate root (which does not appear to be accepted by some versions of openssl); this worked without a hitch for me.

Is there a reason the tools WG pages no longer link to the SVN?
Its URL is now completely unfindable, as far as I can tell.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 12 Nov 2016 03:03:24 +0100

> Is there a reason the tools WG pages no longer link to the SVN?

Only that I haven't gotten around to making it do so, I guess :-)

> Its URL is now completely unfindable, as far as I can tell.

Mmm, right.  I'll see what I can do.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 12 Nov 2016 11:21:58 +0900

> Mmm, right.  I'll see what I can do.

For now, I’ve added the SVN link to the wiki at:

https://trac.ietf.org/trac/core/

Grüße, Carsten

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sat, 12 Nov 2016 11:47:13 +0900

Henrik,

> module which doesn't understand them.  Removed, which should fix this.

I could walk across the room and thank you for this, but since I complained
publicly, I should thank you publicly.

Thanks!

Spencer