Subject: I am concerned about the "mentoring" person

From: "Salz, Rich" <[email-masked]>
Date: Mon, 28 Nov 2016 21:05:32 +0000

Having seen the person in charge of IETF mentoring at the last couple of IETFs, and having been involved in some off-list discussions with her (and others), I am fairly concerned that she is a poor choice and should be replaced, or at a minimum, augmented with another person.

Overall, my concern is that the person leading the "outreach" effort is not really someone who has (a) been involved with the IETF for very long; and (b) doesn't really "get it."  I am all in favor of outreach and diversity (I've made a number of public statements, and a presentation, about this). But I think it has to come from the inside-out, and cannot be imposed on the outside-in.

When I mistakenly sent out the empty email during the last IETF, several people came up to me and were quite strong in their agreement.  It is hard to have this conversation, particularly on a large public mailing list, without it degenerating into character attacks. But I will point out a couple of public examples that show the current person is a bad fit.

During the TLS WG meeting, she suggested we slow down in order to give others time to catch up; she continues to remain blithely unaware of the history of the group.  After an interesting discussion with some Financial Industry people, she chided us for not listening to them even though we bent over backwards to do so, and even offer technical solutions to the issue(s?) they raised. I would be interested in hearing if other WG's had similar experience.  Replies to me will be summarized and, if requested, anonymized, for the list.  Some may find her linked-in profile interesting to read.

I am not sure what the next steps are, or should be.

Thanks.

                /r$

--
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 28 Nov 2016 16:13:57 -0500

It sounds like there were definite problems in the interaction with your 
working groups.

In my experience, she and the program have been doing a very good job. 
She has worked hard to learn the IETF processes, and also works hard to 
make sure newcomers are exposed to it.

I think the fact that she has not been around as long as many of us is a 
positive.  I know it is hard for me to see many of the real problems we 
as a community face bringing newcomers into the work.

I am not sure how to improve the specific mistakes you have noted.

Yours,
Joel

On 11/28/16 4:05 PM, Salz, Rich wrote:
> Having seen the person in charge of IETF mentoring at the last couple of
> IETFs, and having been involved in some off-list discussions with her
> (and others), I am fairly concerned that she is a poor choice and should
> be replaced, or at a minimum, augmented with another person.
>
>
>
> Overall, my concern is that the person leading the “outreach” effort is
> not really someone who has (a) been involved with the IETF for very
> long; and (b) doesn’t really “get it.”  I am all in favor of outreach
> and diversity (I’ve made a number of public statements, and a
> presentation, about this). But I think it has to come from the
> inside-out, and cannot be imposed on the outside-in.
>
>
>
> When I mistakenly sent out the empty email during the last IETF, several
> people came up to me and were quite strong in their agreement.  It is
> hard to have this conversation, particularly on a large public mailing
> list, without it degenerating into character attacks. But I will point
> out a couple of public examples that show the current person is a bad fit.
>
>
>
> During the TLS WG meeting, she suggested we slow down in order to give
> others time to catch up; she continues to remain blithely unaware of the
> history of the group.  After an interesting discussion with some
> Financial Industry people, she chided us for not listening to them even
> though we bent over backwards to do so, and even offer technical
> solutions to the issue(s?) they raised. I would be interested in hearing
> if other WG’s had similar experience.  Replies to me will be summarized
> and, if requested, anonymized, for the list.  Some may find her
> linked-in profile interesting to read.
>
>
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 28 Nov 2016 22:20:30 +0100

Hi Rich,

I have been involved in the programme for several years and I have a 
very positive impression about Nalini (assuming we are talking about her).

IMHO she is doing a good job (I have not attended the TLS WG, so i 
cannot comment on the issue you are referring to).

Hope this helps.
Regards, marcelo

El 28/11/16 a las 22:05, Salz, Rich escribió:
>
> Having seen the person in charge of IETF mentoring at the last couple 
> of IETFs, and having been involved in some off-list discussions with 
> her (and others), I am fairly concerned that she is a poor choice and 
> should be replaced, or at a minimum, augmented with another person.
>
> Overall, my concern is that the person leading the “outreach” effort 
> is not really someone who has (a) been involved with the IETF for very 
> When I mistakenly sent out the empty email during the last IETF, 
> several people came up to me and were quite strong in their 
> agreement.  It is hard to have this conversation, particularly on a 
> large public mailing list, without it degenerating into character 
> attacks. But I will point out a couple of public examples that show 
> the current person is a bad fit.
>
> others time to catch up; she continues to remain blithely unaware of 
> the history of the group.  After an interesting discussion with some 
> Financial Industry people, she chided us for not listening to them 
> even though we bent over backwards to do so, and even offer technical 
> solutions to the issue(s?) they raised. I would be interested in 
> hearing if other WG’s had similar experience. Replies to me will be 
> summarized and, if requested, anonymized, for the list.  Some may find 
> her linked-in profile interesting to read.
>

---

From: Margaret Cullen <[email-masked]>
Date: Mon, 28 Nov 2016 16:30:24 -0500

Nalini has actually been involved in the IETF for many years now, and I think she does a good job of lining up mentors/mentees and planning the mentoring events.  She does not position herself as a top expert in any technology area or in the IETF process, and therefore she does not do the mentoring herself.  She is very good, though, at organizing these sorts of activities and recruiting more experienced IETFers as mentors. 

There are some presenters (and I know that I myself am sometimes guilty of this) who present their material so quickly that it is difficult for anyone who is not deeply entrenched in the work AND fully fluent in English to follow.  There are also WGs who conduct their efforts in ways that make it harder for new people to engage and contribute to the work.  Both of these things are bad for the IETF, as they reduce the quality and applicability of our work.  Over time, they reduce the relevance and breadth of the IETF as a whole.

Knowing some of the people involved in the TLS work, I would not be surprised to hear that there is some room for improvement in one or both of these areas within the TLS WG.  If I were you, I would consider contacting Nalini off-line, asking her what she meant, and seeing if there are ways you could make the group more accessible to new people, without incurring more cost than the benefits would be worth.

Is the history of the TLS group (whatever would be pertinent to the issues you outlined) documented somewhere that it would be reasonable to ask newcomers to read before the attempt to engage in the group?  It has been my experience that _every_ IETF WG has to simultaneously deal with newcomers who are unaware of the history while trying to advance the work from its current state, and that this burden gets larger and larger as groups age.

Margaret

> On Nov 28, 2016, at 4:05 PM, Salz, Rich <[email-masked]> wrote:
> 
> Overall, my concern is that the person leading the “outreach” effort is not really someone who has (a) been involved with the IETF for very long; and (b) doesn’t really “get it.”  I am all in favor of outreach and diversity (I’ve made a number of public statements, and a presentation, about this). But I think it has to come from the inside-out, and cannot be imposed on the outside-in.
>  
> During the TLS WG meeting, she suggested we slow down in order to give others time to catch up; she continues to remain blithely unaware of the history of the group.  After an interesting discussion with some Financial Industry people, she chided us for not listening to them even though we bent over backwards to do so, and even offer technical solutions to the issue(s?) they raised. I would be interested in hearing if other WG’s had similar experience.  Replies to me will be summarized and, if requested, anonymized, for the list.  Some may find her linked-in profile interesting to read.
>  
> IM: [email-masked] <mailto:[email-masked]> Twitter: RichSalz

---

From: Melinda Shore <[email-masked]>
Date: Mon, 28 Nov 2016 12:50:15 -0900

On 11/28/16 12:30 PM, Margaret Cullen wrote:
> Knowing some of the people involved in the TLS work, I would not be
> surprised to hear that there is some room for improvement in one or both
> of these areas within the TLS WG.  

Yeah, but she really went quite deeply into the weeds
and tried to drag others in with her.  She's done that
in a few working groups but I wouldn't say that she's
substantially worse on that account than any number of
other high-volume participants (including some working
group chairs!).

I think this discussion is tending in an unfortunate
direction and might be worth dragging back around to
the subject header - is something going wrong in the
mentoring area that requires intervention?

Melinda

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 28 Nov 2016 16:59:52 -0500

> On Nov 28, 2016, at 4:50 PM, Melinda Shore <[email-masked]> wrote:
> 

IMO:
Acting as a mentor a few times, including the speed mentoring events, I've had generally positive interactions with people and the program.  Nalini is energetic and obviously cares quite a bit about "how do we involve new people".  This is a good thing.

I have no experience with any of the types of disruptions mentioned elsewhere in the thread.  I would suggest thinking about this in two buckets:
1. You can't apply the brakes in an active working group (beyond duties the chair should attend to like making sure the presentations are coherent) to help new people.
2. Someone who cares deeply about helping new people will be highly sensitive to things that are obstacles to those people.  Finding a way to help with perceived deficiencies either in WG procedure or providing additional tutorial/mentor work is helpful. However, see 1.

-- Jeff

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 28 Nov 2016 17:13:30 -0500

Hi,

Just an observation from the cheap seats, since I don't have to cope
with any of this just now.  But …

> 2. Someone who cares deeply about helping new people will be highly sensitive to things that are obstacles to those people.  Finding a way to help with perceived deficiencies either in WG procedure…

I'd like to add

3.  WGs ought to be sensitive to the possibility that a new community
has become aware of WG efforts, and may therefore be joining a
conversation late.  Allowances cannot be made for this as an absolute
rule, because it would present an obvious process attack for every
contentious issue; but WG chairs are encouraged to be sensitive to
those issues when new participants who have a genuinely new
perspective join the WG efforts.

Note that in the above I am quite carefully not suggesting anything
about the newness of the participants in this case or the newness of
the perspective they brought to the issue.  But I think it is
important to skirt quite carefully the issue of who is being
represented and instead to concentrate on the questions of whether a
point of view or functional desire has in fact been exposed and
discussed adequately.  We allow IETF "insiders" to show up late with a
substantive technical objection.  We shouldn't prevent "outsiders"
from doing that either, and if we are devoted to the best standards we
should make that as painless as possible.  But only if the swamp in
question has not been well-explored and declared a wildlife preserve.
:)

A

PS:  I think framing this in terms of "person" is maybe not the most
helpful way to proceed.

-- 
Andrew Sullivan
[email-masked]

---

From: Yoav Nir <[email-masked]>
Date: Tue, 29 Nov 2016 00:22:24 +0200

> mentoring area that requires intervention?

I don’t believe it requires intervention, but the concern is that she might have led the financial industry people astray. 

Those people are both newcomers (I think this is the second IETF meeting for both of them) and they have come to the TLS working group requesting changes in TLS 1.3 rather late in the game (TLS 1.3 is now in WGLC). This is literally years after the feature that they wanted was cut from TLS 1.3 following an extensive discussion, which apparently they were oblivious to.

In fairness, as they demonstrated at the meeting, the changes in TLS 1.3 move their cheese. A lot. If they ever deploy TLS 1.3 in their network, it will have a cost in both effort and money. They did their best to get the group to revert some changes, and the group rejected them.

The usual recommendation for newcomers is to follow the WG for a while until the get a “feel” and then start contributing. This request couldn’t wait and I can see how Nalini’s enthusiasm may have led them and her to believe that they ever had a chance. (a few of us told them in Berlin that they didn’t) Still, in their shoes, I might have tried to convince the group. Either way, this seems to me to be at worst a single instance of bad judgement; not anything that requires any intervention by this forum or by the IESG.

Yoav

---

From: "Black, David" <[email-masked]>
Date: Mon, 28 Nov 2016 22:40:08 +0000

> Acting as a mentor a few times, including the speed mentoring events, I've had generally positive interactions with people and the program.
> Nalini is energetic and obviously cares quite a bit about "how do we involve new people".  This is a good thing.

General +1 on newcomers speed mentoring - I went to this for my first time in Seoul, and thought it was effective and productive.

Thanks, --David

From: WGChairs [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Monday, November 28, 2016 5:00 PM
To: WG Chairs
Subject: Re: I am concerned about the "mentoring" person

On Nov 28, 2016, at 4:50 PM, Melinda Shore <[email-masked]<mailto:[email-masked]>> wrote:

IMO:

-- Jeff

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 28 Nov 2016 23:12:53 +0000

Hi Rich,

> cannot comment on the issue you are referring to).

Similar to Marcelo, I do have a positive impression regarding her work on the 
mentoring program. I will take a look at the meetecho recording of the TLS 
session a bit later tonight.

Thanks
Suresh

---

From: Suzanne Woolf <[email-masked]>
Date: Mon, 28 Nov 2016 18:34:32 -0500

> On Nov 28, 2016, at 5:13 PM, Andrew Sullivan <[email-masked]> wrote:
> 
> Hi,
> 

+1 to this. It’s an ever-present concern with DNSOP, for instance— the chairs try hard to encourage contributors who are not DNS specialists to ask for review there, and to encourage our regular contributors to provide substantive review in terms that are comprehensible to non-specialists. This can be a major challenge. (People talk about “the DNS mafia” and “the DNS ivory tower” less than they used to, at least to me— but still more than I’d like.) 

At the same time, it’s quite difficult for the chairs and the WG to assimilate input that’s offered late *and* initially in the f2f meeting *and* without taking clear account of context. If that’s what happened in TLS, I completely understand the concern that people are being taught that’s the most productive way to engage.

I have very limited experience with the mentoring program, but maybe this suggests the scope of it should focus more on getting people involved with the rest of the process cycle, i.e. mailing list participation and draft reviews. Is it too focused on participation in f2f meetings?

best,
Suzanne

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 29 Nov 2016 00:38:10 +0000

On 28/11/16 23:34, Suzanne Woolf wrote:
> I have very limited experience with the mentoring program, but maybe
> this suggests the scope of it should focus more on getting people
> involved with the rest of the process cycle, i.e. mailing list
> participation and draft reviews. Is it too focused on participation
> in f2f meetings?

So maybe it'd be more productive to generalise this thread
away from the personal to discuss what we'd most like new
participants to learn early in their IETF experience, as
well as what we, as "insiders," ought do better when dealing
with folks getting involved in the IETF. We might then be
in a better position to evaluate ways in which we can maybe
improve the current mentoring programme.

For example, one lesson I think we can learn from the
recent TLS situation is we need to emphasise the IETF's
critical need for openness and that sources for requirements
be publicly identified and that significant arguments need
to be held in public. There were specific failings in those
respects in that case that could have been avoided partly
with better mentoring of new folks. (In case someone is
curious, I think those issues have now been remedied without
lasting bad effects on the TLS WG, other than consuming the
cycles of a few folks' and a bit of list histrionics. [1]
Hopefully the repetition involved in all that is now a thing
of the past, but we'll see I guess, and I at least am quite
happy to endlessly repeat the "no" that is both justified
and required by the WG consensus:-)

Directing new folks first to the mailing list (and archive)
is maybe something that we haven't emphasised often enough
in recent times, perhaps because of putting too much focus
on those new participants who make it to f2f meetings and
who become new attendees. I think that might be one thing
that can be improved in mentoring. (As Yoav said, the specific
TLS issue in the above had seen a significant debate a few
years back, so was very clearly a very well documented WG
consensus that didn't really need re-hashing with more
freshly typed words.)

Suzanne and Andrew have additionally identified aspects of
our dealing with newcomers where we as experienced IETFers
can better consider the needs of new folks. In contrast, I
think the TLS case is an example of when we ought emphasise
things to newcomers that might not be so obvious to them,
nor to some of us apparently.

But there are clearly two "directions" in this game, so
what other aspects of good/effective IETF participation ought
we consider in either direction?

Cheers,
S.

[1] https://www.ietf.org/mail-archive/web/tls/current/msg21275.html

---

From: Eliot Lear <[email-masked]>
Date: Tue, 29 Nov 2016 08:39:08 +0100

Hi Yoav,

> Those people are both newcomers (I think this is the second IETF meeting for both of them) and they have come to the TLS working group requesting changes in TLS 1.3 rather late in the game (TLS 1.3…

While I agree that it would be inappropriate for a WG to slow down
simply to allow new entrants to come up to speed, asking for changes in
WGLC is using the process as it was intended.  You as chair have many
means to address both of these matters (and I note you are not seeking
any assistance or action in this case).  However, your advice to
encourage newcomers to follow a WG for a while before engaging would put
these people in this case in the near impossible position of
contributing AFTER WG last call.  AFTER last call *is* late in the game,
but even that happens, and chairs have in the past allowed some
forbearance.  A good example is draft-ietf-netmod-acl-model, just this
past week.[*]  To a certain point, such allowances encourage the
openness that Andrew and Suzanne wrote about, not to mention they often
head off debates during IETF last call, and perhaps appeals).  More
importantly sometimes new angles on old issues improve the result. 

Issues have been revisited in working groups, sometimes due to
operational experience and sometimes precisely because new entrants have
become aware of work.  I have also observed ADs and other veterans
packing a room to reverse decisions on closed issues; not that I'm a
fan, but it happens. If we tolerate veterans behaving as such, surely we
should allow new entrants the same latitude.  And of course, if enough
people agree with the those who showed up in TLS, especially if they are
supporting their arguments well, I'd hope you would slow down and
reconsider an issue.

I find this instant discussion more concerning, because it encourages an
insular orthodoxy.   The IETF is not exactly growing by leaps and
bounds, and perhaps this is one reason.  Discouraging contributions at
ANY stage encourages those people to go elsewhere to get their needs
met, and results in a perfect standard in some people's eyes that may
have limited applicability.

Eliot
[*] No, I'm not complaining about how the chairs handled the matter, but
it did happen.

---

From: Melinda Shore <[email-masked]>
Date: Mon, 28 Nov 2016 22:59:13 -0900

On 11/28/16 10:39 PM, Eliot Lear wrote:
> simply to allow new entrants to come up to speed, asking for changes
> in WGLC is using the process as it was intended. 

This is probably one of those cases where generalities
are going to lead in the wrong direction.  Indeed, a
major problem was that these folks were asking the
working group to compromise the security of the
protocol (tons of backstory on why they were making
that request), and they had waited until working group
last call to do it.  I'm not that sympathetic to the
whole "newcomers should be supported" framing of
this *particular* case, because I don't think that's
actually what happened (newcomers having insufficient
knowledge of how to participate, the working group
being opaque to newer participants, or any of that).

FWIW I was initially interested in their problem but
once it became clear what was going on I stepped back.

Melinda

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 29 Nov 2016 09:19:05 +0100

Is it allowed (process-wise) to provide controversial feedback (maybe
even in ignorance of what has been done in the WG before) --> sure.

Is it helpful for the others who have been working in the group for a
while already --> probably not.

In the context of the TLS working group it is fair to say that this
group has not been working in secret nor has it hiding the intention or
the scope of the work. The level of outreach it has done is unheard-of
and there has been more input than in any other group I have been
involved in.

There is no doubt that the speed of working is fast and the turn-over
cycles for new document versions (especially using Github) is insane.
Ekr, as the document editor, has done an unbelievable job in getting
things moving forward. The chairs and the ADs have been supportive
wherever they could have been. There were several interim meetings and
even an academic workshop. Needless to say that the topic itself is not
an easy one and certainly not a good way to start learning about
Internet security protocols and crypto.

Is there anything we can learn from this? Standardization is a tough job
even if you do it already for a long time. In my view, the TLS working
group with their work on version 1.3 is a model of how we should do work
in the future in the IETF. When I explain the IETF to other SDOs then I
use this work as an example. There is no other SDO that could have done
work like this.

The chairs are most likely burned out already after such an intense and
focused standardization effort and I could imagine that the excitement
for researchers sending links to blog posts with their "review" can be
annoying at this stage (just to pick an other recent event). I recommend
to keep pushing for a few more months and then we are done with this
episode.

I think it is not premature to say that we should celebrate and
congratulate the chairs for their good work on TLS 1.3.

Ciao
Hannes

---

From: Eliot Lear <[email-masked]>
Date: Tue, 29 Nov 2016 09:23:39 +0100

Melinda,

> being opaque to newer participants, or any of that).

I don't think you can frame this discussion around what result you would
like.

Eliot

---

From: Yoav Nir <[email-masked]>
Date: Tue, 29 Nov 2016 12:53:20 +0200

> On 29 Nov 2016, at 9:39, Eliot Lear <[email-masked]> wrote:
> 
> Hi Yoav,
> 
> any assistance or action in this case).

You mean, Sean and Joe.

>  However, your advice to encourage newcomers to follow a WG for a while before engaging

Not my advice. It’s even in RFC 4144, and it’s what we tell any newcomer to any new place. I did say that their particular request could not wait like that.

> would put
> forbearance.

Sure. My telling them that they didn’t stand a chance was not because they were late in the game — changes happen even based on comments received in IETF LC and IESG review — but was my own opinion about how the WG would react to their request (which was totally validated)

>  A good example is draft-ietf-netmod-acl-model, just this

Theirs was definitely a new angle. From the start, those involved in the TLS 1.3 effort were browser “vendors” and security geeks. The outreach that Hannes mentions was to academics, so more security geeks. Until now, we had no input from anyone running a datacenter. To me that is the equivalent of groups in the routing or Internet area getting no input from operators. 

Given that, I think Sean and Joe were very justified in giving them a platform to present their case. I just think the group’s decision was a foregone conclusion because arguments for compromised security are rarely well-received, especially when solutions to their problems are technically possible, even if they don’t currently exist.  As I said, we moved a lot of cheese.

> supporting their arguments well, I'd hope you would slow down and

We did. They supported their argument well, but there are arguments for the other side. The WG preferred one set of arguments to the other. Some people may perceive that as security purists who don’t care about real world operational issues. If the WG chose to accept their request we could be accused of (1) making TLS 1.3 even more complicated, and (2) not caring about security, or even (2.1) helping to enable pervasive monitoring, with at least as much justification.

> have limited applicability.

If a year or so from now these people still feel that they have to remain with TLS 1.2 because the cost of using TLS 1.3 is too great, I think that’s a failure for all of us.

Yoav

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 29 Nov 2016 10:55:08 +0000

> congratulate the chairs for their good work on TLS 1.3.

I fully agree with the sentiment - the chairs (Joe
and Sean) and many important participants, including
a bunch of new participants, have really done
excellent work. However, we need to keep the bubbly
on ice for now and get the thing over the line. (And
then celebrate it:-)

S.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 29 Nov 2016 13:57:40 +0200

A couple of points. FYI I’m following this discussion and feel that the education and mentoring team issues are my responsibility, so very happy get people’s reactions. I will take any actions or feedback-passing as needed, though I’m not yet in a state where I have conclusions. Also FYI I wasn’t at the TLS session, but had already earlier reviewed the recordings, and have been aware of the discussion topic also earlier.

A couple of early opinions on the substance of this discussion. First off, if we take the TLS case as an example, I think I’m seeing a mix of issues including the type of mentoring we do, persons, and newcomers but also WG process and how we discuss with people be it newcomers or otherwise. And perhaps more importantly, how we deal with legitimate conflicts in our goals. I want this, you want something else, the rough consensus process gets to a conclusion, but we need to get through the process with us still being friends and find ways to deal with our own needs as Internet tech evolves. I actually think this case is more about the legitimate conflict and pain of Internet evolution than newcomers. The TLS WG is doing a very important thing in the Internet, and as far as I am concerned, doing it the right way. Thank you for your efforts! But you should not be surprised that in this change there will be industries who will feel pain, that practices that used to suffice may change, or that people will have differing opinions the direction. Take it in and keep making the right decisions. As you are.

I’m a +1 on what Andrew and Suzanne said. It should be a usual matter that as standards process cranks forward, new parties learn about the effort and will provide more feedback. Lets just deal with that, in our usual rough consensus manner.

There are some learnings however. First, setting expectations. It is a big world. Just because we try to give people a fair hearing doesn’t mean that all their concerns and interests will be accommodated. Or if you are bringing in a new idea, just because you can publish a draft or even get a slot at a meeting doesn’t at all mean that the rest of the world is willing to work with you on your new thing. Sorry. Some of this level setting should be made *very* clear particularly in the newcomer context, and I fear people are trying to be too nice at times to tell this particular truth…

Secondly, I think we still need to do even better in listening to new input and new points of view. It isn’t easy for us to get e.g., the late input that Andrew described, but we do need to do that, we in fact need to be pulling it in, with the realistic expectations of course. But while it isn’t easy for us, put yourselves in the shoes of the other guys, it really isn’t easy from the other side either. And I do think we’re not doing well enough here yet. Each of us can look in the mirror and think about how well we are doing. I want take another example here to illustrate, having seen feedback from outside a WG rejected even when it comes from persons who are implementors of the tech in question and well known protocol engineers. Fortunately this is rare, and also less common in the IETF than in some other technical collaborations that I know of, but I wanted to make the point that there’s certainly room for improvement. Another area of improvement is doing more of the pulling. Most of us have plenty to improve on that front.

Jari

---

From: Adam Roach <[email-masked]>
Date: Tue, 29 Nov 2016 07:03:00 -0600

> I don't think you can frame this discussion around what result you would

I agree with Melinda's point: the TLS situation isn't a good example for 
the point you're trying to make. It's not so much a matter of what 
result "she would like" as much as not allowing special interests to 
weaken the overall security model of the Internet (late, early, or 
otherwise in the process). This isn't some ambiguous "reasonable people 
can disagree" kind of situation: we have clear guidance in the form of 
RFCs 1984, 2804, and 7258 that flatly disallow the IETF to consider the 
requests that were being made.

/a

---

From: Eliot Lear <[email-masked]>
Date: Tue, 29 Nov 2016 15:03:28 +0100

Adam,

You're missing my point.  It's fine to argue that the proposed changes
are inappropriate, and I'm not objecting to the outcome.  I raised a
concern because someone argued their proposed changes weren't timely. 
But don't bring the house down on someone because they've made a proposal.

Eliot

On 11/29/16 2:03 PM, Adam Roach wrote:
>
> I agree with Melinda's point: the TLS situation isn't a good example
> for the point you're trying to make. It's not so much a matter of what
> otherwise in the process). This isn't some ambiguous "reasonable
> people can disagree" kind of situation: we have clear guidance in the
> form of RFCs 1984, 2804, and 7258 that flatly disallow the IETF to
> consider the requests that were being made.
>
> /a
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 29 Nov 2016 18:29:57 +0200

> On 29 Nov 2016, at 16:03, Eliot Lear <[email-masked]> wrote:
> 
> Adam,
> 

To clarify, I did not argue that. I brought up that this was late in the game to explain the urgency (from their perspective) that led Nalini to make her appeal at the mic, and that led them to appeal to SAAG which has no standing about this anyway.

> But don't bring the house down on someone because they've made a proposal.

The mailing list discussion had some of that. The discussion at the F2F meeting did not.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 29 Nov 2016 08:31:34 -0800

> On Nov 28, 2016, at 11:39 PM, Eliot Lear <[email-masked]> wrote:
> 
> Hi Yoav,
> 

I agree.

While I don’t participate directly in TLS, I am familiar with the work on TLS 1.3 and agree there has been a good effort to widen the “tent” so to speak.  However, one of the reasons for w.g. last call is to get additional feedback, so it is part of our process.  Just like what will happen in the next step after the w.g. sends it to the IESG, there will be an IETF last call.  We wouldn’t do that if we didn’t want additional feedback.  It better to get that feedback at w.g. last call, then during IETF last call.

Bob

---

From: Kyle Rose <[email-masked]>
Date: Tue, 29 Nov 2016 11:51:25 -0500

> The mailing list discussion had some of that. The discussion at the F2F

I think this is worth highlighting. Given the acrimony on the list when
this was initially raised, the discussion at the TLS session was remarkably
polite, even friendly. I think everyone put their knives away when the case
was presented in person. The technical arguments still won out, but the
tone was a lot better.

Kyle