Subject: FW: ID Tracker State Update Notice: <draft-ietf-curdle-cms-chacha20-poly1305-04.txt>

From: "Salz, Rich" <[email-masked]>
Date: Fri, 16 Dec 2016 15:43:23 +0000

Is it just me, or would others find "Changed state from ... to ..." easier to follow?

--  
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz

-----Original Message-----
From: IETF Secretariat [mailto:[email-masked]] 
Sent: Friday, December 16, 2016 10:38 AM
To: [email-masked]; [email-masked]; [email-masked]; Daniel Migault; [email-masked]
Subject: ID Tracker State Update Notice: <draft-ietf-curdle-cms-chacha20-poly1305-04.txt>

IESG state changed to IESG Evaluation from Waiting for Writeup ID Tracker URL: https://datatracker.ietf.org/doc/draft-ietf-curdle-cms-chacha20-poly1305/

---

From: Paul Wouters <[email-masked]>
Date: Fri, 16 Dec 2016 10:52:35 -0500 (EST)

> Is it just me, or would others find "Changed state from ... to ..." easier to follow?

I've said the same in the past. It's just inhuman and error prone for
the reader. Even if it is easier for whatever code that spits it out.

Paul

---

From: Robert Sparks <[email-masked]>
Date: Fri, 16 Dec 2016 09:54:25 -0600

A positional change like that will introduce errors in people who have 
been conditioned to the current form.

How about

New state: IESG Evaluation

Previous state: Waiting for Writeup ID

instead?

---

From: Warren Kumari <[email-masked]>
Date: Fri, 16 Dec 2016 16:12:49 +0000

The either of the outcomes proposed above would have done worked for me :-)

W
(Yes, I find the current wording tricky - "this to that" would presumably
not take long for people to learn, but Roberts solution works too....)
On Fri, Dec 16, 2016 at 11:00 AM Robert Sparks <[email-masked]> wrote:

> > To: [email-masked];
> [email-masked]; [email-masked]; Daniel Migault;
> [email-masked]
> > Subject: ID Tracker State Update Notice:
> <draft-ietf-curdle-cms-chacha20-poly1305-04.txt>
> >
> > IESG state changed to IESG Evaluation from Waiting for Writeup ID
> Tracker URL:
> https://datatracker.ietf.org/doc/draft-ietf-curdle-cms-chacha20-poly1305/
> >
>
>

---

From: Bob Hinden <[email-masked]>
Date: Fri, 16 Dec 2016 08:23:24 -0800

Robert,

> On Dec 16, 2016, at 7:54 AM, Robert Sparks <[email-masked]> wrote:
> 
> A positional change like that will introduce errors in people who have been conditioned to the current form.
> 
> How about
> 

Yes, that’s better.  Though, I would reverse the order, that is:

Thanks,
Bob

---

From: Robert Sparks <[email-masked]>
Date: Fri, 16 Dec 2016 10:26:43 -0600

The important thing the message is conveying is the new state. The old 
state is background information.

I will take a stab at formatting the message with better visual cues.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 16 Dec 2016 16:29:12 +0000

> From: WGChairs [mailto:[email-masked]] On Behalf Of Robert
> Sparks
...
> state is background information.
[ACM]
 
+1, that's why I kept it on top in my example, too.

Al

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 16 Dec 2016 16:00:34 +0000

> From: WGChairs [mailto:[email-masked]] On Behalf Of Salz,
> Rich
> Sent: Friday, December 16, 2016 10:43 AM
> To: [email-masked]
> Subject: FW: ID Tracker State Update Notice: <draft-ietf-curdle-cms-
> chacha20-poly1305-04.txt>
> 
[ACM] 
Hi Rich,
I've sometimes thought the same as you (and Paul)
but I also think it's a matter of emphasis.
IMO, it would help to have a line break before
the from state (which is usually less important).
An example that also breaks for the URL below:

IESG state changed to IESG Evaluation 
from Waiting for Writeup 
ID Tracker URL: https://datatracker.ietf.org/doc/draft-ietf-curdle-cms-
chacha20-poly1305/

Al

> Tracker URL: https://datatracker.ietf.org/doc/draft-ietf-curdle-cms-
> chacha20-poly1305/

---

From: Barry Leiba <[email-masked]>
Date: Thu, 29 Dec 2016 18:14:04 -0500

I'm late to this, but let me add to what Robert said:

> The important thing the message is conveying is the new state. The old state
> is background information.

Absolutely correct, and that's why news media, such as the New York
Times, also use the "changed to ... from ..." order.  You might think
you prefer the opposite order, but they have studied this, and have
concluded that "changed to ... from ..." is actually better for
comprehension.

Barry

---

From: Paul Wouters <[email-masked]>
Date: Thu, 29 Dec 2016 18:27:35 -0500

Sent from my iPhone

> On Dec 29, 2016, at 18:14, Barry Leiba <[email-masked]> wrote:
> 

This is a little odd. Some people say they keep misreading the information  and then you tell them they only think presenting it differently would cause less misreading. 

Let's take a step back. The current phrasing is misleading for some and results in errors. What can we do to make it better for everyone[*], taking into account we are not constrained like a newspaper.

Paul
[*] with the exception of Yoda