Subject: Re: I am concerned about the "mentoring" person

From: S Moonesamy <[email-masked]>
Date: Thu, 01 Dec 2016 12:15:03 -0800

Hi Rich,
At 13:05 28-11-2016, Salz, Rich wrote:
>Having seen the person in charge of IETF mentoring at the last 
>couple of IETFs, and having been involved in some off-list 
>discussions with her (and others), I am fairly concerned that she is 
>a poor choice and should be replaced, or at a minimum, augmented 
>with another person.
>
>Overall, my concern is that the person leading the "outreach" effort 
>is not really someone who has (a) been involved with the IETF for 
>very long; and (b) doesn't really "get it."  I am all in favor of 
>outreach and diversity (I've made a number of public statements, and 
>a presentation, about this). But I think it has to come from the 
>inside-out, and cannot be imposed on the outside-in.
>
>When I mistakenly sent out the empty email during the last IETF, 
>several people came up to me and were quite strong in their 
>agreement.  It is hard to have this conversation, particularly on a 
>large public mailing list, without it degenerating into character 
>attacks. But I will point out a couple of public examples that show 
>the current person is a bad fit.
>
>During the TLS WG meeting, she suggested we slow down in order to 
>give others time to catch up; she continues to remain blithely 
>unaware of the history of the group.  After an

The issue seems to be about one or more participants in a Working 
Group not being aware of what has been discussed previously.  It is 
usually suggested to read the mailing list archives.  That is not 
very helpful as the participant who has not closely followed the 
discussion over the years won't be able to figure out where to start 
or what to look for.  This is where the person doing mentoring could 
help as he/she would be familiar with the issues in that Area/Working Group.

I read the URL provided by Stephen to understand the related 
concern.  It seems to be about process.  It illustrates issue of how 
difficult it may be for someone new to a working group to figure out 
what to look for when nobody provides a hint.

Regards,
S. Moonesamy

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 2 Dec 2016 10:41:01 +1100

> On 2 Dec. 2016, at 7:15 am, S Moonesamy <[email-masked]> wrote:
> 
> Hi Rich,
>> Having seen the person in charge of IETF mentoring at the last couple of IETFs, and having been involved in some off-list discussions with her (and others), I am fairly concerned that she is a poor choice and should be replaced, or at a minimum, augmented with another person.
>> 
>> Overall, my concern is that the person leading the "outreach" effort is not really someone who has (a) been involved with the IETF for very long; and (b) doesn't really "get it."  I am all in favor of outreach and diversity (I've made a number of public statements, and a presentation, about this). But I think it has to come from the inside-out, and cannot be imposed on the outside-in.
>> 
>> When I mistakenly sent out the empty email during the last IETF, several people came up to me and were quite strong in their agreement.  It is hard to have this conversation, particularly on a large public mailing list, without it degenerating into character attacks. But I will point out a couple of public examples that show the current person is a bad fit.
>> 
>> During the TLS WG meeting, she suggested we slow down in order to give others time to catch up; she continues to remain blithely unaware of the history of the group.  After an
> 
> The issue seems to be about one or more participants in a Working Group not being aware of what has been discussed previously.  It is usually suggested to read the mailing list archives.  That is not very helpful as the participant who has not closely followed the discussion over the years won't be able to figure out where to start or what to look for.  This is where the person doing mentoring could help as he/she would be familiar with the issues in that Area/Working Group.
> 
> I read the URL provided by Stephen to understand the related concern.  It seems to be about process.  It illustrates issue of how difficult it may be for someone new to a working group to figure out what to look for when nobody provides a hint.

On a bit of a tangent --

IME, this is one of the advantages of a well-maintained issue list. If major areas of discussion and the resulting consensus are captured in it, you can give people a URL for the issue, rather than saying "dig through the archives." It's true that for the complete picture, they'll also need to go to the mailing list, but often the issue is enough to give them an idea, and when it's not, they at least know when the discussions took place, and (when some conversation takes place on the issue), who's involved.

Cheers,

--
Mark Nottingham   https://www.mnot.net/