Subject: New datatracker release: v6.40.0

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 14 Dec 2016 23:54:08 +0100

Hi,

This is an automatic notification about a new datatracker release, 
v6.40.0, generated when running the mkrelease script.

Release notes:

ietfdb (6.40.0) ietf; urgency=medium

  **Django 1.8**

  This release upgrades the datatracker to use version 1.8 of the Django
  framework.  Django 1.8 introduces security enhancements, type checking of
  foreign-key and many-to-many-key arguments when doing database queries, and
  a number of other features [a].  The type checking in particular brought to
  light a number of places where we provided the wrong argument types (or
  multiple inconsistent argument types) to queries.  These have all been
  fixed.  The full set of changes are shown in changeset [12507].

  [a] https://docs.djangoproject.com/en/1.8/releases/1.8/

 -- Henrik Levkowetz <[email-masked]>  13 Dec 2016 06:00:44 +0000

The new version is available for installation through SVN checkout, with
  'svn checkout https://svn.tools.ietf.org/svn/tools/ietfdb/tags/6.40.0'

For development, copy the new development version instead:
  'svn copy https://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/6.40.1.dev0' <YOURBRANCH>

Regards,

	Henrik
	(via the mkrelease script)

---

From: Matt Larson <[email-masked]>
Date: Thu, 15 Dec 2016 14:21:45 -0500

Greetings all!

Datatracker 6.40.0 and 6.40.1.dev0 have been deployed to their respective servers.

Matt

> On Dec 14, 2016, at 5:54 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints

-------------------------------------------
Matthew Larson, Software Engineer
Association Management Solutions
Forum Management, Meeting and Event Planning
5177 Brandin Court
Fremont, CA  94538

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 15 Dec 2016 21:10:31 +0100

Thank you, Matt!

	Henrik