Subject: delivery issue with mailer?

From: Kent Watsen <[email-masked]>
Date: Fri, 17 Mar 2017 19:08:01 +0000

A WG contributor replied to an email of mine yesterday.  I received it
right away, but a couple folks on the list I spoke to said that they
had not received it (yet), and I don't see it in the mail archives[1][2].

Attached is a copy of the email I received.  Looking at the headers (see
below), it's clear that the email was also sent to "[email-masked]":

  From: David Bannister <[email-masked]>
  Date: Thu, 16 Mar 2017 14:23:47 -0400
  Subject: Re: [netmod] Fwd: New Version Notification for draft-ietf-netmod-acl-model-10.txt
  To: Kent Watsen <[email-masked]>
  CC: Dean Bogdanovic <[email-masked]>, NetMod WG <[email-masked]>

I've noticed a couple other delivery timeliness in that last couple days.
Is anything going on with the mailer?

Thanks,
Kent

Note: below are links to my email to David.  David's response should
be "Next in thread", but it's not listed (yet):

[1] https://www.ietf.org/mail-archive/web/netmod/current/msg17845.html
[2] https://mailarchive.ietf.org/arch/search/?email_list=netmod&q=Fwd%3A+New+Version+Notification+for+draft-ietf-netmod-acl&gbt=1

Subject: Re: [netmod] Fwd: New Version Notification for draft-ietf-netmod-acl-model-10.txt
From: David Bannister <[email-masked]>
To: Kent Watsen <[email-masked]>
Cc: Dean Bogdanovic <[email-masked]>, NetMod WG <[email-masked]>
Date: Thu, 16 Mar 2017 14:23:47 -0400

There were no changes to the model so my concerns remain the same.  Augmentation is not a scalable solution when dealing with a mutli-vendor or in some instances a multi-business-unit environment.  The 'newco' example in the draft illustrates  this problem.  The IETF produces a 'standard' for an ACL draft which is so sparse in nature that it must be augmented by each vendor.  In the best case this gives me a unique model per vendor because we know the vendors are not going to get together to define  the missing pieces.  The vendors will use a variety of mechanisms to complete the model from using a script to build their models from source code, handling the missing pieces as arbitrary code (anyxml), or everything as a string.  Then there is the worse  case where a vendor has no internal standardization (you know who you are) and their own product lines will not align into a common model.  The object here, for me, is to get to a single model for all vendors barring a unique feature th
 at belongs to one vendor  in which case augmentation is acceptable.  

Could you add to this in the future and rev up the RFC?  Sure.  However, I am not sure what value that brings to the community.  In its current form I would not ask any of my vendors to implement this draft.  Instead I would push them towards the OpenConfig  ACL model.  

On Tue, Mar 14, 2017 at 9:12 PM, Kent Watsen <[email-masked]> wrote:
Hi David,

Can you please confirm that the additional examples address your concern?  And, if not, please

explain if there is any reason why what you're looking for couldn't be added or augmented in

in the future.

Thanks,

Kent // shepherd

On 3/13/17, 5:57 AM, "netmod on behalf of Dean Bogdanovic" <[email-masked] on behalf of [email-masked]> wrote:

Here is the new version of the ACL draft. Since December and some additional comments about the ACL model, I spoke with many operators and how they use ACLs. I have also received lot of detailed ACL configurations. In most cases, the model  is easily adapted to the current use cases in operations. But to answer the comments, the authors have added a detailed example in the addendum section how the model can be extended and how this model can be used. 

Cheers,

Dean

Begin forwarded message:

From: [email-masked]

Subject: New Version Notification for draft-ietf-netmod-acl-model-10.txt

Date: March 13, 2017 at 10:52:38 AM GMT+1

To: <[email-masked]>, "Kiran Koushik" <[email-masked]>,  "Lisa Huang" <[email-masked]>, "Dean Bogdanovic" <[email-masked]>, "Dana Blair" <[email-masked]>,  "Kiran Agrahara Sreenivasa" <[email-masked]>

A new version of I-D, draft-ietf-netmod-acl-model-10.txt
has been successfully submitted by Dean Bogdanovic and posted to the
IETF repository.

Name: draft-ietf-netmod-acl-model
Revision: 10
Title: Network Access Control List (ACL) YANG Data Model
Document date: 2017-03-13
Group: netmod
Pages: 32
URL:            https://www.ietf.org/internet-drafts/draft-ietf-netmod-acl-model-10.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-netmod-acl-model/
Htmlized:       https://tools.ietf.org/html/draft-ietf-netmod-acl-model-10
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-acl-model-10

Abstract:
  This document describes a data model of Access Control List (ACL)
  basic building blocks.

  Editorial Note (To be removed by RFC Editor)

  This draft contains many placeholder values that need to be replaced
  with finalized values at the time of publication.  This note
  summarizes all of the substitutions that are needed.  Please note
  that no other RFC Editor instructions are specified anywhere else in
  this document.

  Artwork in this document contains shorthand references to drafts in
  progress.  Please apply the following replacements

  o  "XXXX" --> the assigned RFC value for this draft.

  o  Revision date in model (Oct 12, 2016) needs to get updated with
     the date the draft gets approved.  The date also needs to get
     reflected on the line with <CODE BEGINS>.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 17 Mar 2017 15:23:42 -0400

Kent,

> below), it's clear that the email was also sent to "[email-masked]":
[...]
> [1] https://www.ietf.org/mail-archive/web/netmod/current/msg17845.html

I'll make an observation based on my own setup on my personal server.

I'm using a smtp technique called "greylisting" to cut down on the spam.
It basically operates by returning a temporary delivery error on the
message while tracking where the message came from.

In postgrey, that tracking is on a tuple of sender:receiver:client_ip & 255.255.255.0

I was having regular failures sending from my Juniper account or a few other
of my local user accounts when Microsoft mail services were involved.  A
small amount of troubleshooting showed that MS is sending from a set of
servers spread around a /13 network - considerably bigger than the /24 mask
here.

I had to whitelist Microsoft's network to bypass my own issues.

I have no idea if the IETF mail infra does something similar, but it might
be a possibility.

-- Jeff

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 18 Mar 2017 00:07:45 +0100

Hi Kent,

I checked the server logs, and found this log line, which might explain
the issue:

  2017-03-16T11:23:54.195042-07:00 ietfa postconfirmd[29390]: Requesting confirmation: <[email-masked]> to [email-masked]

This seems to have been the first message from David to an IETF list,
something that triggers a confirmation request to the sender.

Could you ask David to look for and reply to the posting confirmation
request he should have received from <[email-masked]>, if he has
not already done so?

Best regards,

	Henrik

---

From: Kent Watsen <[email-masked]>
Date: Sat, 18 Mar 2017 09:52:45 +0000

Hi Henrik,

David's been on this list for awhile.  Just the same, I forwarded to him your message and asked if he changed email addresses recently.  He wrote back this:

"should have been sent as dpb@ as this the default for gmail.  I replied to the list email verification, let's see what that does."

That was sent last night -9:30 EST and, as of now (-6:00), no new emails have been sent to the netmod list.  

I don't know what he means by 

Thanks,
Kent

Thanks,
Kent
> On Mar 17, 2017, at 7:07 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Kent,
>

---

From: Kent Watsen <[email-masked]>
Date: Sat, 18 Mar 2017 10:04:59 +0000

Sorry, my mobile decided to send that last email before I finished it.

I was trying to say, I don't know what David meant by "I replied to the list email verification".   

It might mean that he received a special message from the mailer (though i'm unsure what that could've been, especially since i didn't receive any message as list admin), or it might be saying that he was going to send another email to the list as a test (though no such email has been received yet, perhaps for the same reason). 

PS: adding David to the CC, even though he won't be able to post to the wgchairs list. 

Thanks,
Kent

> On Mar 18, 2017, at 5:52 AM, Kent Watsen <[email-masked]> wrote:
> 
> Hi Henrik,
>