Subject: requirements for IETF laptops to run displays at WG meetings

From: Alia Atlas <[email-masked]>
Date: Fri, 2 Jun 2017 16:55:26 -0400

Would you find it helpful to have an IETF laptop set up in each WG session
from which the WG meeting could be run - as far as projecting goes?   What
concerns would you have about such
a setup?

The IESG has brainstormed a bit on the requirements for such laptops.  Here
is the current list:

1) Ability to show PDF and PPT formats in presentation style
2) Ability to access web browser to reach meeting materials page & agenda
page & download rapidly.
3) Ability to take a USB flash drive to load the presentation materials.
4) Antivirus protection since random USB flash drives will be connected.
5) Support for all standard video outputs we would expect to encounter at
IETF meeting locations.

An issue definitely will be that WG Chairs won't have access to the
presentation laptops to download the relevant presentations until 10
minutes before the meeting.  This may encourage WG Chairs to bring flash drives
with the presentations.  Given the frequent lack of timeliness of
presentations for the WG, this is not something that could be done by the
Secretariat ahead of time.

Please do brainstorm and discuss here.  I would like to get requirements
well understood so that we can ask the Secretariat to investigate the
logistical and financial implications.  I will collect the feedback,
summarize it here, and pass it on to the Secretariat.  It is not clear if
there will be time to do have these available at IETF 99 in Prague - but
the sooner we conclude this conversation, the more feasible that is.

Regards,
Alia

---

From: Aaron Falk <[email-masked]>
Date: Fri, 02 Jun 2017 21:04:19 +0000

Seems like a reasonable proposal, albeit not a life-changer.  If the
browser had a bookmark for the meeting materials page, it would make it
easy to grab the current uploaded presentations.  Seems like most folks
have become pretty disciplined at uploading presentations before the
meeting for non-english and remote participants.

--aaron

On Fri, Jun 2, 2017 at 4:55 PM Alia Atlas <[email-masked]> wrote:

> The IESG has brainstormed a bit on the requirements for such laptops.
> Here is the current list:
>

---

From: Joe Clarke <[email-masked]>
Date: Fri, 2 Jun 2017 17:16:55 -0400

On 6/2/17 16:55, Alia Atlas wrote:
> Would you find it helpful to have an IETF laptop set up in each WG
> session from which the WG meeting could be run - as far as projecting
> goes?   What concerns would you have about such
> a setup?
> 
> 2) Ability to access web browser to reach meeting materials page &
> agenda page & download rapidly.  
> 5) Support for all standard video outputs we would expect to encounter
> at IETF meeting locations.
> 
> minutes before the meeting.  This may encourage WG Chairs to bring flash
> drives with the presentations.  Given the frequent lack of timeliness of
> presentations for the WG, this is not something that could be done by
> the Secretariat ahead of time.

We do pre-provisioned speaker laptops at our user conferences, and in
general this works out well.  Content is typically accessible remotely
from the laptop.  For the IETF, any content uploaded to the agenda/WG
site ahead of time would be accessible.  Having the browsers
pre-provisioned with the links for sessions happening in the given room
would make that even easier.

Chairs/presenters needing to provide late content could bring USB drives.

In terms of downsides, the laptops we have received in the past for
conferences have not always be patched correctly and some have come with
malware and viruses pre-loaded.  I'm not sure what your plan for
ownership and operation are, but do not under-estimate the operational
burden if you choose to have them as part of the NOC/AV kit.

Joe

---

From: Brian Rosen <[email-masked]>
Date: Fri, 2 Jun 2017 17:33:41 -0400

What is the problem this is trying to solve?

I haven’t noticed an issue with using chair laptops.  We know what the requirements are.  If we started having several video options that weren’t the standard analog monitor or HDMI, then maybe it will be a problem we don’t have yet.

There is sometimes a struggle when a presenter wants to use their system.

Brian

> On Jun 2, 2017, at 4:55 PM, Alia Atlas <[email-masked]> wrote:
> 
> Would you find it helpful to have an IETF laptop set up in each WG session from which the WG meeting could be run - as far as projecting goes?   What concerns would you have about such
> a setup?
> 
> The IESG has brainstormed a bit on the requirements for such laptops.  Here is the current list:
> 
> 2) Ability to access web browser to reach meeting materials page & agenda page & download rapidly.  
> 5) Support for all standard video outputs we would expect to encounter at IETF meeting locations.
> 
> An issue definitely will be that WG Chairs won't have access to the presentation laptops to download the relevant presentations until 10 minutes before the meeting.  This may encourage WG Chairs to bring flash drives with the presentations.  Given the frequent lack of timeliness of presentations for the WG, this is not something that could be done by the Secretariat ahead of time.
> 
> Please do brainstorm and discuss here.  I would like to get requirements well understood so that we can ask the Secretariat to investigate the logistical and financial implications.  I will collect the feedback, summarize it here, and pass it on to the Secretariat.  It is not clear if there will be time to do have these available at IETF 99 in Prague - but the sooner we conclude this conversation, the more feasible that is.
> 
> Regards,
> Alia

---

From: Bob Hinden <[email-masked]>
Date: Fri, 2 Jun 2017 14:44:37 -0700

> On Jun 2, 2017, at 2:33 PM, Brian Rosen <[email-masked]> wrote:
> 

+1

I also feel like I have to ask, how is this going to be paid for?  Higher registration fees?

> There is sometimes a struggle when a presenter wants to use their system.

For the w.g. I co-chair, we require the presenters to send us their presentation in PDF a day before and then project from one of our laptops.  We occasionally get a new version the day of the session, but it hasn’t been a big problem.  Sessions are lot smoother without the plugging in a new laptop for every talk.

Bob

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 2 Jun 2017 21:48:04 +0000

Hi Alia,

If we go this way, I’d like to see:

  6) Two-button Mouse supplied with Laptop
  (could be cheap & wired, makes for a more standard interface,
   there’s a lot of variability in rubber pointers and scratch pads).

If this adds too much cost, I guess we could use our own Mice
if necessary (and then we’ll certainly see chairs moving from
room to room looking for the USB wireless interface they left behind),
so allowing personal USB Mice and USB remote control clicker would be
the alternate requirement.

The other requirement would be to optionally substitute a chair laptop
when the chairs find their own equipment more convenient.

Even if a supplied-laptop is temporary, it will enable an AV
transition to HDMI interface (I understand the it’s not yet possible
to do this and retain AV compatibility for all chairs).
That’s a good thing.

my 2 cents,
Al

From: WGChairs [mailto:[email-masked]] On Behalf Of Aaron Falk
Sent: Friday, June 02, 2017 5:04 PM
To: Alia Atlas; [email-masked]
Subject: Re: requirements for IETF laptops to run displays at WG meetings

Seems like a reasonable proposal, albeit not a life-changer.  If the browser had a bookmark for the meeting materials page, it would make it easy to grab the current uploaded presentations.  Seems like most folks have become pretty disciplined at uploading presentations before the meeting for non-english and remote participants.

--aaron

On Fri, Jun 2, 2017 at 4:55 PM Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:
Would you find it helpful to have an IETF laptop set up in each WG session from which the WG meeting could be run - as far as projecting goes?   What concerns would you have about such
a setup?

Regards,
Alia

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 2 Jun 2017 17:51:29 -0400

Brian and Alia,

Actually, I think this is a good thing, especially if it becomes more
difficult to travel internationally with one’s own laptop as the US Gov’t
has been threatening.

Also, I’ve seen a lot of WG meetings start late because the chairs are
having some sort of incompatibility between their own laptop and the
projector. Using a pre-set-up laptop to project PDF directly in a browser
using the meeting materials page makes a lot of sense. It also makes it
easy to enforce the rule that if your material wasn’t received early enough
to be on the meeting material page, then it doesn’t get projected.

If all you’re doing is projecting PDF directly from the meetings material
page, all you’ll need is inexpensive Linux laptops with Chrome or Firefox
installed. Something with an HDMI interface would be more future-proof than
using VGA. Using Linux also protects from the menagerie of Windows viruses.

Cheers,
Andy

On Fri, Jun 2, 2017 at 5:33 PM, Brian Rosen <[email-masked]> wrote:

> I haven’t noticed an issue with using chair laptops.  We know what the
> requirements are.  If we started having several video options that weren’t
> the standard analog monitor or HDMI, then maybe it will be a problem we
> don’t have yet.
>

---

From: joel jaeggli <[email-masked]>
Date: Fri, 2 Jun 2017 14:55:14 -0700

> 1) Ability to show PDF and PPT formats in presentation style
while that would seem to cover the vast bulk of the marials presented,
> agenda page & download rapidly. 

I think there's a tendency here towards a level of formalism that i
don't particularly find healthy which this bullet I think endeavors to
caputre,. e.g. this is a working group meeting, not a presentation track
at a conference, so the emphasis on presentation as the communication
methodology takes us away from what we are doing which is running a
working group. much of the alternative supporting materials for a
working group session, be it the draft itself, the issue tracker, the
etherpad and so on are in fact view-able through a browser.that said
you're still working on someone elses laptop potentially on a different
operating system then normal with all the attendant learning curve.
> 3) Ability to take a USB flash drive to load the presentation materials.
I think we've long since passed the point where handing around media is
acceptable or safe. I wouldn't attach someone elses usb stick to my
laptop, and I daresay connecting it to shared device and then back to an
unshared one sounds like like a bad idea. 
> 4) Antivirus protection since random USB flash drives will be connected.
is a mild prophylactic and not a cure.
> at IETF meeting locations.
Actually kind of irrelevant since it's vertically integrated. e.g. the
secretariat + contractors is responsible for the end-to-end laptop to
projector so they really only need  the one the decide to support.one.
> minutes before the meeting.  This may encourage WG Chairs to bring
> flash drives with the presentations.  Given the frequent lack of
> timeliness of presentations for the WG, this is not something that
> could be done by the Secretariat ahead of time.
>
> Please do brainstorm and discuss here.  I would like to get
> requirements well understood so that we can ask the Secretariat to
> investigate the logistical and financial implications.  I will collect
> the feedback, summarize it here, and pass it on to the Secretariat. 
> It is not clear if there will be time to do have these available at
> IETF 99 in Prague - but the sooner we conclude this conversation, the
> more feasible that is.
>
> Regards,
> Alia

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 2 Jun 2017 18:07:40 -0400

As a WG Chair, I pack for every situation. Adapters, clicky pointy things, mice, first aid kits when the consensus gets "rougher". 

From my high tech gadget

> On Jun 2, 2017, at 17:55, joel jaeggli <[email-masked]> wrote:
>

---

From: Pat Thaler <[email-masked]>
Date: Fri, 2 Jun 2017 16:07:59 -0700

It is nice to have a third laptop to project so that both chairs can have
their laptops available, e.g.: for Etherpad, jabber, datatracker. On the
occasions when only one of the two co-chairs is at the meeting, this
probably is more important as you don't have one chair to monitor other
things while the other projects.

On the other hand, with the decreasing size of laptop like capabilities, my
co-chair has been bringing a second small one to use for projecting. That
avoids any issues with user unfamiliarity, worrying about USB sticks
transporting malware and getting presentations onto a machine in the
minutes before starting the meeting. Now that my door stop has been
replaced by something more compact, I'd consider bringing a second small
computer myself is he wasn't.

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 2 Jun 2017 19:14:50 -0400

As a chair, I always have a laptop at the meeting, anyway.  I review presentations with people ahead of time, so I have their presentations.  Therefore, I am not sure this would help me very much.  

I would prefer to see the money used to upgrade the projectors to have higher resolution and more modern connectors.

Margaret

Sent from my iPhone

---

From: Michael Richardson <[email-masked]>
Date: Fri, 02 Jun 2017 19:39:03 -0400

> 3) Ability to take a USB flash drive to load the presentation

This would seem to encourage late submission of materials.
Despite the success of meetecho to project the "latest", it still
has impacts on remote attendees, but also upon ability of download
materials ahead of time, perhaps to decide whether or not to even attend
*that* session or not.

So, I'd rather not do that.

    > 4) Antivirus protection since random USB flash drives will be

This seems to imply use of a vulnerable operating system(s)!
So, perhaps this "protection" could be in the form of electrical tape over
the ports, with late submissions simply disallowed.

    > could be done by the Secretariat ahead of time.

Don't we have a WG that deals with networked file systems?
Didn't we insist that they put real security into v4 of that protocol?
Couldn't a read-only contents of all the uploaded materials just be available
that way?

Seriously.  People did this kind of thing 30 years ago.

joel jaeggli <[email-masked]> wrote:
    joel> I think there's a tendency here towards a level of formalism that i
    joel> don't particularly find healthy which this bullet I think endeavors to
    joel> caputre,. e.g. this is a working group meeting, not a presentation
    joel> track at a conference, so the emphasis on presentation as the
    joel> communication
    joel> methodology takes us away from what we are doing which is running a
    joel> working group. much of the alternative supporting materials for a
    joel> working group session, be it the draft itself, the issue tracker, the
    joel> etherpad and so on are in fact view-able through a browser.

What he said.
I can't see a reason to have anything more than a chromebook or equivalent here.

    joel> that said
    joel> you're still working on someone elses laptop potentially on a
    joel> different operating system then normal with all the attendant
    joel> learning curve.

I suspect we can overcome this.
Chairs could also delegate operating this laptop!

    joel> Actually kind of irrelevant since it's vertically integrated. e.g. the
    joel> secretariat + contractors is responsible for the end-to-end laptop to
    joel> projector so they really only need  the one the decide to support.one.

Agreed.  Some projectors apparently come with browsers now..

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Christian Hopps <[email-masked]>
Date: Fri, 02 Jun 2017 21:17:03 -0400

> Bob Hinden <[email-masked]> writes:

+1

Also are there other ways to spend that money that would yield more bang
for the buck (including but not limited to not spending it and reducing
registration fees)?

Thanks,
Chris.

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 3 Jun 2017 11:51:38 +1000

FWIW -

I like the idea of a dedicated presentation machine; we tried this at our last Interim (QUIC in Tokyo), and it made it much easier on me as a chair. In particular, not being worried about flashing my private e-mail / calendar / chat etc. on screen is a relief :) 

I suspect there's more value in longer meetings; it's usually manageable for an hour or two.

I'm trying something new for our Interim next week. The old MacBook Air that I used in Tokyo has a dead battery, and while I could just plug it in, I don't fancy explaining a non-functional laptop to airport security in the current climate. So, I got a NUC for this purpose. In some ways, this is better than a laptop -- it's got more USB ports (for mics, cameras, usb sticks, speakers), is very portable, and we can just use Remote Desktop to control it, so no need for a keyboard / mouse.

Will report back as to how it goes.

> On 3 Jun 2017, at 6:55 am, Alia Atlas <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 3 Jun 2017 06:49:15 +0000

Hi,

Assuming there is a problem to solve to begin with, I don't think a laptop is needed. Some alternatives:

1)	Use a powerful enough raspberry Pi (or something similar) device. You don't really need a keyboard or screen. Connect a mouse that can be used to download the presentation (e.g., via a web interface) and control the presentation.
2)	Use a projector with built-in software for handing presentations - no need for ANY computer as far as presenting is concerned. Whether such projectors can hook up to a web interface, or whether you have to physically provide the presentations (e.g., using an USB stick) I don't know.

Regards,

Christer

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Mark Nottingham
Sent: 03 June 2017 03:52
To: Alia Atlas <[email-masked]>
Cc: [email-masked]
Subject: Re: requirements for IETF laptops to run displays at WG meetings

FWIW -

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 3 Jun 2017 16:53:51 +1000

I chose a nuc because I need to run webex with multiple mics and a hd camera. For simpler situations, a pi might work. 

Sent from my iPhone

> On 3 Jun 2017, at 4:49 pm, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: Gorry Fairhurst <[email-masked]>
Date: Sat, 03 Jun 2017 08:29:50 +0100

On 03/06/2017, 02:17, Christian Hopps wrote:
>>>> On Jun 2, 2017, at 4:55 PM, Alia Atlas<[email-masked]>  wrote:
>>>>
>> Bob Hinden<[email-masked]>  writes:
>>> On Jun 2, 2017, at 2:33 PM, Brian Rosen<[email-masked]>  wrote:
>>>
+1 I don't see a problem. I dislike the idea of ONLY being allowed to 
use a presentation machine - this is a WG update, not a presentation 
slot. I like the flexibility of being able to let people use what they 
(or the chairs) find most helpful and familiar (providing they upload 
draft slides ahead of their talk).

If governments prevent me carrying a laptop to the IETF, then the 
current meeting would becomes unworkable ... that's something we could 
have a contingency plan for.

Gorry

---

From: "Mehmet Ersue" <[email-masked]>
Date: Sat, 3 Jun 2017 14:13:23 +0200

Although many chairs are well-organized, I can imagine there will sufficient
amount of people who appreciate having a standard solution for connecting to
the beamer, etc. and having their own laptop free for jabber.
Also there is a tendency for new notebooks to support HDMI where the beamer
common standard is still VGA.

To make it simple and secure I would disallow using USB sticks. Instead the
meeting materials can be synchronized continuously with the presenter
laptop. This shouldn't be a big task to make available on all such laptops. 
I think we all agree that the slides should be made available to the
community on the meeting material page as early as possible.

Cheers,
Mehmet

> From: WGChairs [mailto:[email-masked]] On Behalf Of Gorry
> Fairhurst
> Sent: Saturday, June 3, 2017 9:30 AM
> To: [email-masked]
goes?
> What concerns would you have about such
> >>>> a setup?
> >>>>
> > Also are there other ways to spend that money that would yield more
> > bang for the buck (including but not limited to not spending it and
> > reducing registration fees)?
> >
> > Thanks,
> > Chris.
> use a presentation machine - this is a WG update, not a presentation slot.
I
> like the flexibility of being able to let people use what they (or the
chairs)
> find most helpful and familiar (providing they upload draft slides ahead
of
> their talk).
> 
> If governments prevent me carrying a laptop to the IETF, then the current
> meeting would becomes unworkable ... that's something we could have a
> contingency plan for.
> 
> Gorry

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 3 Jun 2017 12:42:56 +0000

Unsure whether there is a problem to be solved (barring laptop ban in planes).

I would prefer to have a mirrored screen in front of the speaker (in Chicago it was really not easy to face the WG members while seeing the slide: I had to use my iPad to remotely follow my own slides !)

Please add (been burned at some places):

-          Clicker to advance slides

-          QWERTY keyboard

-          English version of the OS

-éric

From: WGChairs <[email-masked]> on behalf of Alia Atlas <[email-masked]>
Date: Friday 2 June 2017 at 22:55
To: "[email-masked]" <[email-masked]>
Subject: requirements for IETF laptops to run displays at WG meetings

Regards,
Alia

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 3 Jun 2017 15:05:24 +0200

On Jun 3, 2017, at 14:13, Mehmet Ersue <[email-masked]> wrote:
> the
> laptop

Right, we could do a lot more here.

E.g., there might be a simple rsync command to get the current state of the meeting materials for a WG onto the projecting laptop (whether that is IETF provided or not), instead of having to fiddle with Web pages for download (or, heaven forbid, projecting from the Web pages).

Slot leaders might be able to push their slides on their own, so we don’t have to have the WG chair (and their unreliable mail server) as a middleperson.  (Yes, the WG chair might still have a gating function, but this doesn’t have to involve pulling slides out of a mail folder and then uploading them again, all on an overloaded meeting WiFi.)

Oh, and I wouldn’t mind having more options for projecting than dead(*) VGA: e.g., HDMI, also keeping around MDP and USB-C connectors.

I also wouldn’t mind all IETF projectors to be 16:9 (some are, but others still are 4:3, which leads to surprises and bad resolution when projecting).  (The resolution itself is not a problem due to the size of the meeting rooms, unless some EDID failure makes the laptops choose 800x600.)

Grüße, Carsten

(*) VGA would turn 30 this year, hadn’t the industry laid it to rest between 2013 and 2015.  It really feels a lot like IPv4 now :-)

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sat, 3 Jun 2017 13:51:59 +0000

> From: WGChairs [mailto:[email-masked]] On Behalf Of Gorry
...
> have a contingency plan for.
[ACM] 
Return of the Terminal Room ;-)

---

From: Justin Richer <[email-masked]>
Date: Sat, 3 Jun 2017 12:36:23 -0400

I agree that VGA is exactly as dead as IPV4. Which is to say, we're 
probably going to still be using it for quite some time...

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 3 Jun 2017 11:57:31 -0600

Other conferences I go to have a dropbox folder which is mounted on all the presentation computer and that the panel moderators can upload presentation to. It works really well. For reason I can't put my finger on, it is much faster / easier than uploading a preso to  ietf materials page then download on another computer. 

For IETF I would we could consider a single dropbox folder that has subfolders for each WG and that any chair had write access to and everyone has read access. 

> On Jun 2, 2017, at 2:55 PM, Alia Atlas <[email-masked]> wrote:
>

---

From: Yoav Nir <[email-masked]>
Date: Sat, 3 Jun 2017 21:45:12 +0300

+1

I like the idea of having the files on the computer rather than available through web access as it encourages chairs to use a proper PDF viewer rather than a browser.  Browsers are really terrible for showing PDF files.

What’s more, the public can be given view-only access to this Dropbox folder, so anyone can add it to their dropbox and have the latest materials right on their device.

I don’t know if we want to give edit access to all chairs as that includes delete access and s**t happens, but it could be automatically fed from the same repository as the meeting materials page.

Yoav

> On 3 Jun 2017, at 20:57, Cullen Jennings <[email-masked]> wrote:
> 
>

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 4 Jun 2017 17:38:07 +1000

Fine, minus using Dropbox; I won't run their software on my machines.

> On 4 Jun 2017, at 3:57 am, Cullen Jennings <[email-masked]> wrote:
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 4 Jun 2017 09:40:04 +0200

On Jun 4, 2017, at 09:38, Mark Nottingham <[email-masked]> wrote:
> 
> Fine, minus using Dropbox;

+1

Grüße, Carsten

---

From: Yoav Nir <[email-masked]>
Date: Sun, 4 Jun 2017 11:14:53 +0300

So don't install their software on your machine. It's fine that it's
installed on the presentation machine and you can use their web interface.

Shouldn't prevent others from using their app.

On Sun, Jun 4, 2017 at 10:38 AM, Mark Nottingham <[email-masked]> wrote:

> > Other conferences I go to have a dropbox folder which is mounted on all
> the presentation computer and that the panel moderators can upload
> presentation to. It works really well. For reason I can't put my finger on,
> it is much faster / easier than uploading a preso to  ietf materials page
> then download on another computer.
> >
> > For IETF I would we could consider a single dropbox folder that has
> subfolders for each WG and that any chair had write access to and everyone
> has read access.
> >
> >
> investigate the logistical and financial implications.  I will collect the
> feedback, summarize it here, and pass it on to the Secretariat.  It is not
> clear if there will be time to do have these available at IETF 99 in Prague
> - but the sooner we conclude this conversation, the more feasible that is.
> >>
> >> Regards,
> >> Alia
> >
>
> --

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Mon, 5 Jun 2017 12:51:04 +0000

I am a strong believer that the meeting materials should be on the meeting materials site before the WG begins, therefore to me, if 3) and 4) are to support someone turning up after the meeting has started with their presentation, then these are not important requirements. If they are to support a chair at a meeting without a laptop, then 3) and 4) could be an entirely separate machine in the terminal room, rather than one used for presentations in the meeting room.

If this is not done, then remote participants lose one of their means of following the meeting. People attending the meeting face to face also use the meeting materials for making their own personal notes as the meeting proceeds.

The only exception I would make to the above meeting materials rule is where the chair needs to support hums by typing the question and presenting it, rather than just doing it verbally.

Regards

Keith

From: WGChairs [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: 02 June 2017 21:55
To: [email-masked]
Subject: requirements for IETF laptops to run displays at WG meetings

Regards,
Alia

---

From: Michael Richardson <[email-masked]>
Date: Mon, 05 Jun 2017 09:47:47 -0400

Drage, Keith (Nokia - GB) <[email-masked]> wrote:
    > I am a strong believer that the meeting materials should be on the
    > meeting materials site before the WG begins, therefore to me, if 3)

+10.

    > The only exception I would make to the above meeting materials rule is
    > where the chair needs to support hums by typing the question and
    > presenting it, rather than just doing it verbally.

I think that even a chromebook/equivalent can support typing a question
into a blank page.   Some chairs might even know the question ahead of
time, and upload it as a material.

---

From: Tim Chown <[email-masked]>
Date: Mon, 5 Jun 2017 14:42:23 +0000

> On 5 Jun 2017, at 14:47, Michael Richardson <[email-masked]> wrote:
> 

For me, something that can just run Meetecho would be fine, and allow slides to be projected (from the materials area).

So we can clearly see the slides, and any (jabber) questions / discussion.

I can then use my own laptop to take notes and refer to emails or other material relevant to the WG session separate from the presentation device.

Tim

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 5 Jun 2017 15:04:59 +0000

＋１，　

Linda

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Friday, June 02, 2017 4:45 PM
To: Brian Rosen <[email-masked]>
Cc: [email-masked]
Subject: Re: requirements for IETF laptops to run displays at WG meetings

+1

Bob

---

From: Leonard Giuliano <[email-masked]>
Date: Mon, 5 Jun 2017 12:45:55 -0700

+1 Having a PC dedicated to presenting and not having to burn up a chair 
PC (and worry about having the right adapters and compat with the 
projector) would be very helpful.

On Fri, 2 Jun 2017, Andrew G. Malis wrote:

| Brian and Alia,
| Actually, I think this is a good thing, especially if it becomes more difficult to travel internationally with one’s own laptop as the US Gov’t has been threatening. 
| 
| Also, I’ve seen a lot of WG meetings start late because the chairs are having some sort of incompatibility between their own laptop and the projector. Using a pre-set-up laptop to project PDF directly in
| a browser using the meeting materials page makes a lot of sense. It also makes it easy to enforce the rule that if your material wasn’t received early enough to be on the meeting material page, then it
| doesn’t get projected. 
| 
| If all you’re doing is projecting PDF directly from the meetings material page, all you’ll need is inexpensive Linux laptops with Chrome or Firefox installed. Something with an HDMI interface would be
| more future-proof than using VGA. Using Linux also protects from the menagerie of Windows viruses.
| 
| Cheers,
| Andy
| 
| 
| On Fri, Jun 2, 2017 at 5:33 PM, Brian Rosen <[email-masked]> wrote:
|       What is the problem this is trying to solve?
| I haven’t noticed an issue with using chair laptops.  We know what the requirements are.  If we started having several video options that weren’t the standard analog monitor or HDMI, then maybe it
| will be a problem we don’t have yet.
| 
| There is sometimes a struggle when a presenter wants to use their system.
| 
| Brian
| 
|       On Jun 2, 2017, at 4:55 PM, Alia Atlas <[email-masked]> wrote:
| 
| Would you find it helpful to have an IETF laptop set up in each WG session from which the WG meeting could be run - as far as projecting goes?   What concerns would you have about such
| a setup?
| 
| The IESG has brainstormed a bit on the requirements for such laptops.  Here is the current list:
| 
| 1) Ability to show PDF and PPT formats in presentation style
| 2) Ability to access web browser to reach meeting materials page & agenda page & download rapidly.  
| 3) Ability to take a USB flash drive to load the presentation materials.  
| 4) Antivirus protection since random USB flash drives will be connected.
| 5) Support for all standard video outputs we would expect to encounter at IETF meeting locations.
| 
| An issue definitely will be that WG Chairs won't have access to the presentation laptops to download the relevant presentations until 10 minutes before the meeting.  This may encourage WG
| Chairs to bring flash drives with the presentations.  Given the frequent lack of timeliness of presentations for the WG, this is not something that could be done by the Secretariat ahead of
| time.
| 
| Please do brainstorm and discuss here.  I would like to get requirements well understood so that we can ask the Secretariat to investigate the logistical and financial implications.  I will
| collect the feedback, summarize it here, and pass it on to the Secretariat.  It is not clear if there will be time to do have these available at IETF 99 in Prague - but the sooner we conclude
| this conversation, the more feasible that is.
| 
| Regards,
| Alia
| 
| 
| 
| 
|

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 5 Jun 2017 15:09:57 -0700

Hi,

The idea of having a dedicated laptop in the WG meeting is great, however
if the cost is high enough to maintain/administer such that it affects the
membership fees or other useful benefits then it's not probably needed.

In our working group, we co-chairs preload all the presentations to the
materials page, but most of the time it is easier to present from the
chairs' laptops due to last minute changes and in some cases network
connectivity/reliability issues in the room.

Most of the time, the problems are with display adapters as Carsten and
many others mentioned in the list. So, it will be really helpful if the
chairs station is supplied with multi-type display adapter connectivity to
the projector, for example - HDMI, USB-C regular and mini adapters along
with regular VGA and MAC adapters.

Also, specifying  a  IETF meeting standard display size for the projector
(as mentioned below) would be also quite helpful for the slide
presenters/contributors.

-Samita

On Sat, Jun 3, 2017 at 6:05 AM, Carsten Bormann <[email-masked]> wrote:

> E.g., there might be a simple rsync command to get the current state of
> the meeting materials for a WG onto the projecting laptop (whether that is
> IETF provided or not), instead of having to fiddle with Web pages for
> download (or, heaven forbid, projecting from the Web pages).
>
> Slot leaders might be able to push their slides on their own, so we don’t
> have to have the WG chair (and their unreliable mail server) as a
> middleperson.  (Yes, the WG chair might still have a gating function, but
> this doesn’t have to involve pulling slides out of a mail folder and then
> uploading them again, all on an overloaded meeting WiFi.)
>
> Oh, and I wouldn’t mind having more options for projecting than dead(*)
> VGA: e.g., HDMI, also keeping around MDP and USB-C connectors.
>
> I also wouldn’t mind all IETF projectors to be 16:9 (some are, but others
> still are 4:3, which leads to surprises and bad resolution when
> projecting).  (The resolution itself is not a problem due to the size of
> the meeting rooms, unless some EDID failure makes the laptops choose
> 800x600.)
>
> Grüße, Carsten
>
> (*) VGA would turn 30 this year, hadn’t the industry laid it to rest
> between 2013 and 2015.  It really feels a lot like IPv4 now :-)
>
>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 7 Jun 2017 02:32:54 +0200

Interesting discussion

a) Its definitely beneficial for chairs not to have to present from their own PC.

b) Its unclear to me if you needed to afford actual notebooks. How about nuc size PC ?
would fit better on the table if chairs are present and have their own notebooks.
Less per-room-expense.  Would require more upfront tooling, like a web-page to remotely
control it. Could be vnc or the like for all i care. And making the GUI not the local
display/keyboard would equally allow easier remote chairs or presenters to operate it.
Heck, with a NUC style PC you should also always have the ability to present two
separate screens - such as one for etherpad/jabber/notes and one for the presentation.
That would actually allow to slowly morph WG maeetings back to the "working" group meeting.

c) Wrt to PPT: I have to admit i am not quite on top of the current tool-chain.
Do i remember it correctly that the ssytem today only uploads PDF files to the
meeting material ? So even if i as a wg chair upload a PPT(x), if i try to
download later on for presentation during the session, i will get PDF ?

Eg: If the toolchain with the "meeting room pc" would allow to actually see
slides presented from the actual PPT that would help a lot, because the
conversion PPT->PDF often has issues. Especially when you do invest into the
effort of making nice animated slides or the like (yeah yea, standard disclaimer,
IETF is working, not marketing, and you should not use any animations etc. ppp.
but PPT->PDF is still error-prone).

And yes, i am totally torn about PPT. Many presenters rightfully would not like to
share PPT but only PDF. So a toolchain that keeps the PPT locked down to
just the presentation PC might be necessary/appropriate.

(but maybe the least important aspect of the discussion)

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 7 Jun 2017 02:42:52 +0200

To reverse the concern you raise:

Even if this thread started by Alia i think asking whether such a PC
should be introduced to help chairs avoid to have to present from their own
PC, it is IMHO even more interesting to figure out how such a PC in
the meeting room could help to make the collaborative/work part of the meeting
work better - and always see that it makes local and remote participation
equally better.

-- 
---
[email-masked]

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 6 Jun 2017 20:12:59 -0600

> On Jun 4, 2017, at 1:38 AM, Mark Nottingham <[email-masked]> wrote:
> 

I don't use their apps but I do use their website to upload and download files. Would you do that? I think that is all that is needed for the non presentation computers. 

(and I have no love for dropbox if there is something better, it is just well known)

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 7 Jun 2017 10:09:48 +0200

> On 7 Jun 2017, at 4:12 am, Cullen Jennings <[email-masked]> wrote:
> 
> 

I'd be grumpy about it, but yes.

OTOH I'm not sure why something like WebDAV or just a "normal" file share on the machine wouldn't work.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 7 Jun 2017 06:15:28 -0600

> On Jun 7, 2017, at 2:09 AM, Mark Nottingham <[email-masked]> wrote:
> 
> 
> -

Got a suggestion on a public free  webdav service IETFers can grab an account on and easily upload files? I'm pretty negative on us standing up our own service because doing a good job of long term support is expensive.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 7 Jun 2017 14:16:17 +0200

I meant on the box in the room itself.

Not *everything* has to be in the cloud...

> On 7 Jun 2017, at 2:15 pm, Cullen Jennings <[email-masked]> wrote:
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 7 Jun 2017 14:38:46 -0400

> Got a suggestion on a public free  webdav service IETFers can grab an account on and easily upload files? I'm pretty negative on us standing up our own service because doing a good job of long term…

Why doesn't the existing meeting materials page serve this purpose?

	Thanks,
	Paul

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Jun 2017 20:48:32 +0200

> Why doesn't the existing meeting materials page serve this purpose?

Can’t show visual aids (“slide decks”) from there.

Grüße, Carsten

---

From: Alia Atlas <[email-masked]>
Date: Wed, 7 Jun 2017 16:04:01 -0400

Thank you very much for the interested discussion and perspectives.
Let me make an effort to summarize what I am hearing and respond a bit.

In general, I've heard several folks saying it would be useful & solving
display problems
or having their laptops available for use during the WG session would be
useful.  The
concerns seem to be primarily around cost.

I'd like to let the discussion run for another week - until June 14.  Then
I'll summarize any
changes in requirements and bring them back to the Secretariat & IESG.

I have a set of what I believe to be the updated requirements at the end of
this email.

1) What problem are we solving?
     a) The short form is to help make it easier to run a meeting and avoid
delays due to logistics.
     My understanding is a combination of 2 aspects.   First, many modern
laptops don't support
     VGA; getting a laptop connected up to the projector with the needed
tech can be annoying and
     requires folks to remember and bring different connectors.  This would
allow consistency for display,
     avoid that hassle, and potentially allow migration to HDMI.   Second,
this would allow both WG
     Chairs to be able to take notes, follow jabber, look up related
materials, respond to very timely emails, etc.

2) Cost - how much are we talking?  What is the opportunity cost of
spending on laptops vs. other
     options (improved projectors, etc.)
     a) I haven't done the research on cost; that'll be up to the
Secretariat - but since we usually have around,
     say, 8 parallel sessions and since the requirements are minimal, I'd
be surprised if this was more than $3k
     (just my personal high WAG).  The cost of equipment has just come
down.   As a one-time cost, I don't see
     this impacting the meeting fee significantly or having the ability to
do so.

3) OS & options
   a)  I hear a concern against Windows because of the virus vector.  I see
discussion on more experimental
    possibilities that would be likely to be more fragile.  I believe we
are looking for an extremely robust
    solution that will not require significant support.   If you have a
specific solution in mind that falls into that
    category, feel free to unicast me with details and reasoning and I can
pass it on.

4) Ability to load presentations via USB - not needed/actively opposed due
to security risks.
   a) Fascinatingly, I don't see folks concerned about having a fall-back
way of getting materials on the laptops
   beyond via web browser or the equivalent of a shared network drive.
Instead, I see a strong pushback
   against supporting USB flash drives and a preference for shared network
drive.  The fallback is to another
   laptop.

5) Fall-back to WG Chair's laptop critical. The desired fallback is to pull
the display cable to another laptop.

6) Cost of patching/maintenance may be higher than expected.   Consider
this in evaluation.

7)  Provide meeting materials via a network-synced drive.
       a) There seems to be a good amount of enthusiasm for this and
thoughts that it could also be useful
            for WG participants.    There's already a way to download a
tarball of the meeting materials from
            the agenda page.  If this is on the provided laptop, the
technology used seems to me to be primarily
            a convenience question for the Tools Team & Secretariat; the
requirement of access via a web-interface
            (for WG participants) may be met by the Meeting Materials
data-tracker tool.  The goal would be to
            have the WG session materials automatically sync'd on the
laptops (and to encourage presentations
            of PDFs to not be in the browser).

8) Mirrored screen in front of presenter?
      a)  I think this has more implications for the room setup.  We'd need
a place to put the laptop.
      This seems like something that could be experimented with, but the
laptop availability could facilitate.
      I do have concerns that this will drive WG sessions to feel even more
like presentation-fests.

Updated & summarized Requirements:

1) Applications  & formats to access & display
     a)  PDF  -  display shouldn't be just browser based.
     b) PPT  -  mild preference for display to allow animations to work.
     c) Etherpad
     d) issues tracker
     e) basic text editor  - for on-the-fly questions
     f) Meeting Materials data-tracker
     g) Agenda data-tracker

2)  Access of up-to-date Meeting Materials
    a) Good network speed to access meeting materials datatracker.
    b) Support for unpacking meeting materials tarball from datatracker
agenda
    c) Automatically network-synchronized files from Meeting Materials onto
laptop.
        This would also allow meeting to go forward in the event of network
problems.

3) Physical details, accessories, and language
     a) Provide 2-button mouse.
     b) QWERTY keyboard  & English version of OS
     c) Provide clicker (as currently done)
     d) Multi-type display adapters (for example, HDMI, USB-C regular and
mini adapters,
         VGA and MAC adapters) for to ensure fallback to personal laptops
is possible.
     e) Support for all standard video outputs we would expect to encounter
at IETF meeting locations.
     f) Reduce risk from USB flash drives (either use of or viruses from)
     g) Preference against Windows due to virus concerns.

4) Minimal maintenance costs - well considered/understood before purchase.
(Joe Calrke has
     experience with issues from running user conferences.)

Thank you,
Alia

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 7 Jun 2017 23:14:55 +0200

Its not only this sticky ANIMA head, but i do actually believe that the
most important way for low opex and reliability is some shrink-wrapped, close
to zero touch client setup. Eg: RPI/NUC wit a standard IETF-presentation flash, boot,
displays IP address, initial config "you're for rom XYZ" via web etc. pp. 

Not sure if it could go any simpler than this. DOes anyone have experience with
Miracast ? If there wouldn't have to be PCs in the meeting rooms but just
wireless display adapter, this sounds logically a lot less complex. Of course
the wifi network would become even more crucial. Maybe we're still
(after almost 2 decades of 802.11 ?) not ready for that, but if that wifi
reliability/performance was the gating factor not to go that way, that would really
suck rocks.

Cheers
    toerless

-- 
---
[email-masked]

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Thu, 8 Jun 2017 13:26:01 +0000

Just a thought that has occurred to me that we ought to get all such lists of requirements reviewed by experts from the disability community – e.g. any speaker screen should probably have sufficient angle of view to be visible from a seated or wheelchair speaker as well as a standing speaker.

I am not sure there would be much else for this issue but it should be a general review principle.

Keith

From: WGChairs [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: 07 June 2017 21:04
To: [email-masked]
Subject: Re: [irsg] requirements for IETF laptops to run displays at WG meetings

In general, I've heard several folks saying it would be useful & solving display problems
or having their laptops available for use during the WG session would be useful.  The
concerns seem to be primarily around cost.

I'd like to let the discussion run for another week - until June 14.  Then I'll summarize any
changes in requirements and bring them back to the Secretariat & IESG.

I have a set of what I believe to be the updated requirements at the end of this email.

1) What problem are we solving?
     a) The short form is to help make it easier to run a meeting and avoid delays due to logistics.
     My understanding is a combination of 2 aspects.   First, many modern laptops don't support
     VGA; getting a laptop connected up to the projector with the needed tech can be annoying and
     requires folks to remember and bring different connectors.  This would allow consistency for display,
     avoid that hassle, and potentially allow migration to HDMI.   Second, this would allow both WG
     Chairs to be able to take notes, follow jabber, look up related materials, respond to very timely emails, etc.

2) Cost - how much are we talking?  What is the opportunity cost of spending on laptops vs. other
     options (improved projectors, etc.)
     a) I haven't done the research on cost; that'll be up to the Secretariat - but since we usually have around,
     say, 8 parallel sessions and since the requirements are minimal, I'd be surprised if this was more than $3k
     (just my personal high WAG).  The cost of equipment has just come down.   As a one-time cost, I don't see
     this impacting the meeting fee significantly or having the ability to do so.

3) OS & options
   a)  I hear a concern against Windows because of the virus vector.  I see discussion on more experimental
    possibilities that would be likely to be more fragile.  I believe we are looking for an extremely robust
    solution that will not require significant support.   If you have a specific solution in mind that falls into that
    category, feel free to unicast me with details and reasoning and I can pass it on.

4) Ability to load presentations via USB - not needed/actively opposed due to security risks.
   a) Fascinatingly, I don't see folks concerned about having a fall-back way of getting materials on the laptops
   beyond via web browser or the equivalent of a shared network drive.   Instead, I see a strong pushback
   against supporting USB flash drives and a preference for shared network drive.  The fallback is to another
   laptop.

5) Fall-back to WG Chair's laptop critical. The desired fallback is to pull the display cable to another laptop.

6) Cost of patching/maintenance may be higher than expected.   Consider this in evaluation.

7)  Provide meeting materials via a network-synced drive.
       a) There seems to be a good amount of enthusiasm for this and thoughts that it could also be useful
            for WG participants.    There's already a way to download a tarball of the meeting materials from
            the agenda page.  If this is on the provided laptop, the technology used seems to me to be primarily
            a convenience question for the Tools Team & Secretariat; the requirement of access via a web-interface
            (for WG participants) may be met by the Meeting Materials data-tracker tool.  The goal would be to
            have the WG session materials automatically sync'd on the laptops (and to encourage presentations
            of PDFs to not be in the browser).

8) Mirrored screen in front of presenter?
      a)  I think this has more implications for the room setup.  We'd need a place to put the laptop.
      This seems like something that could be experimented with, but the laptop availability could facilitate.
      I do have concerns that this will drive WG sessions to feel even more like presentation-fests.

2)  Access of up-to-date Meeting Materials
    a) Good network speed to access meeting materials datatracker.
    b) Support for unpacking meeting materials tarball from datatracker agenda
    c) Automatically network-synchronized files from Meeting Materials onto laptop.
        This would also allow meeting to go forward in the event of network problems.

3) Physical details, accessories, and language
     a) Provide 2-button mouse.
     b) QWERTY keyboard  & English version of OS
     c) Provide clicker (as currently done)
     d) Multi-type display adapters (for example, HDMI, USB-C regular and mini adapters,
         VGA and MAC adapters) for to ensure fallback to personal laptops is possible.
     e) Support for all standard video outputs we would expect to encounter at IETF meeting locations.
     f) Reduce risk from USB flash drives (either use of or viruses from)
     g) Preference against Windows due to virus concerns.

4) Minimal maintenance costs - well considered/understood before purchase. (Joe Calrke has
     experience with issues from running user conferences.)

Thank you,
Alia

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Jun 2017 14:10:26 +0000

>Just a thought that has occurred to me that we ought to get all such lists of requirements reviewed by experts from the disability community

Oh wow, yes!

---

From: Alia Atlas <[email-masked]>
Date: Wed, 14 Jun 2017 17:02:13 -0400

[bcc: iesg for conclusion of thread]

It has now been another week with very limited comments, so I am concluding
that we have nailed down the requirements from the WG Chairs perspective.
I have not heard more concerns as to whether this is solving a problem.

I did get feedback pointing out that the costs aren't likely to be
one-time, but should consider replacement & such.  Luckily, the IETF
Secretariat has IT expertise & I am sure will look at this as part of the
feasibility.

I also heard support for considering accessibility in the requirements.
The example was for the experiment of having the presenter able to see the
presentation on a provided laptop - but the general principle applies.
There was also a request for a 2 button mouse with scroll-wheel.    I've
updated the requirements below.

Regards,
Alia

On Wed, Jun 7, 2017 at 4:04 PM, Alia Atlas <[email-masked]> wrote:

> 5) Fall-back to WG Chair's laptop critical. The desired fallback is to
> pull the display cable to another laptop.
>
2-button with scroll-wheel

>      g) Preference against Windows due to virus concerns.
Consider accessibility