Subject: updated agenda - WG Chairs Forum (Wed, 19 July 2017, 12:00 CEST)

From: Karen ODonoghue <[email-masked]>
Date: Wed, 19 Jul 2017 10:09:08 +0200

Folks,

Below is the updated agenda for the WG Chairs Forum today. All are 
welcome. If you did not pre-register, please don't pick up a lunch until 
all those who registered get theirs.

Thanks,
Karen

WG Chairs Forum
Wednesday, 19 July 12:00 - 13:30 CEST (10:00 - 11:30 UTC)
Congress Hall III
==============

- An Update on the RFC Format Project (Heather Flanagan)
- IETF Comms update (Greg Wood)
- WG Chairs Forum agenda and topics
- Open Forum

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 20 Jul 2017 14:31:31 +0200

Hi all,

Please find below the minutes of this week's WG chairs lunch session.
Let me know if anything is missing. We will also post them on the wg
chairs wiki.

Thanks for all the great input!

Kind regards,
Mirjam Kühne
==============

WG Chairs Forum
IETF 99, 19 July 2017

Agenda:
1. An Update on the RFC Format Project (Heather Flanagan)
2. IETF Comms update (Greg Wood)
3. WG Chairs Forum agenda and topics
4. Open Forum

1. An Update on the RFC Format Project (Heather Flanagan)

(see slides)

Pretty much everybody in the room knew that Heather is changing the RFC
format.

Q & A

David Black thanked Heather for all her hard work and asked if anyone is
thinking about tracking the state of the upstream tools during the
migration from v2 and v3. Which of the community tools are where in the
process?

Heather reported that Carsten Bormann has offered to help with that.

Niels ten Oever said he is happy to help test kramdown.

Henrik Levkowetz pointed people to the issue tracker on the tools
section on the IETF web site for bug reports about xml2rfc.

A participant asked when documents SVG can be published in documents.
Heather said this would be possible next year.

2. IETF Comms update (Greg Wood)

Greg presented a short recap of where we are today on:
https://beta.ietf.org :

There is a project plan. Russ Housley is now the project manager.
There are three possible audiences for the site: experienced IETF
participants, new IETF participants and people who might never actually
attend an IETF meeting.
In the meantime there were also some changes made to the datatracker.
Russ now sent a mail to the IETF discussion list announcing the beta
site. Feedback is coming in.
There will still be time for testing and providing feedback.
Plan is to move to production in the next few months.
There is a mail address you can send feedback to: [email-masked]
There is also an issue tracker for more details (see Russ Housley’s mail
to the list).

Q & A

Tim Chown said that we have to realise that www.ietf.org will be the
place that people go to that are not regular IETF participants. More
experienced IETF participants will mostly work on the datatracker and
the tools page. He said this is ok, but we will have to get used to.

Greg added that when he was asking people, most IETF participants use
the main IETF site to register for the meetings and they also use the
links on the left hand site.

Bob Hinden thanked Greg for doing this and said it’s a vert thankless
job (people will always criticise you, whatever you do). He added that
hates that picture on the front page, because it doesn’t at all
represent how we do work at the IETF.

Allison Mankin also thanked Greg for this work and applauded him for
being very communicative and clear about the entire process. She
mentioned that she has been involved in the development of a number of
corporate web sites and always found eyeball testing is essential.

Greg said that this is definitely part of the plan and added that Alissa
Cooper is interested in that as well.

3. WG Chairs Forum agenda and topics (Karen O’Donoghue)

Karen reported that we used to do WG chairs tutorials and then moved to
this more open forum. She said she would like to find out if this is a
useful format and how we can better solicit feedback for future topics.
Karen asked a number of questions:

How many people have been to the WG chairs wiki? Many hands went up.

How many people think these WG chair forums should continue? Many hands
went up

How many people are here just for the free lunch? No hands went up

She then opened up the floor for suggestions for future topics.

Barry Leiba said he liked it when we had one or two topics that filled
the time rather than these short 10 minute updates. He offered to think
about some topics. He really liked those topical meetings.

Robert Sparks agreed with Barry, but added that if we continue this more
open format, it might be an idea to have this meeting in the lounge with
smaller tables and break-out sessions so that people can discuss in
smaller group.

How many people would like to have tutorials instead?
Only a few hands went up. But people said it depends on the topic.

Spencer Dawkins said that we don’t have to make this decision for all
future IETF meetings. He liked the idea of the WG Chairs lunch to be a
discussion forum, and not classroom style only.

Barry added that because we pick a topic for a day, doesn’t mean it has
to be a lecture. And that’s how we did that in the past. He said he also
likes Robert’s idea, but it might be difficult logistically.

Robert wondered if there are topics or tutorials that are not tools related?

Barry suggested a topic: a quick intro from a few chairs about what they
found particularly effective in running  WG session. Then a discussion
about what problems chairs encountered and how they handled them. A WG
Chairs management session.

Robert suggested to do a training on how to do a break-out style session.

One of the relative new WG chairs said that understanding what it means
being a chair is very important and relevant, but that might be
different for more experienced chairs.

Barry asked the room how many have tried running a WG session as a
break-out session.
Only a couple of hands went up. But might be worth a try.

A participant suggested to ask the IESG what would help them with
document reviews. What could WG chairs do to help with that process?

Ari Keranen reported that they had break-out sessions and made very good
experience with it. It needs enough space and also good note takers.

Natasha Rooney said she would like to experiment with different formats.

Mirjam Kuhne asked if it would be useful to do a “How to be a WG chair”
tutorial again?

Some people said yes, this would indeed be useful from time to time.

Rick Taylor agreed and added that this of course doesn’t have to be at
every IETF. But it would definitely be useful for new chairs.

Dave Morton also liked the idea. He reminded people that in the past
when we organised this we would open it up to prospective WG chairs
(together with some existing chairs).

Brian Roosen commented on the idea of break-out sessions. He said a good
format for the WG chairs lunch could be a session on possible formats
and ideas on how to run a meeting.

Niels said that the hackathon is coinciding with the Sunday tutorials
and the newcomers events. And many of the hackathon participants are
newcomers. Maybe we could consider doing some tutorials during the week?

Robert said the hackathon is getting as important if not more than the
work done at the WG meetings. Maybe we need to start thinking about
having fewer WG sessions and instead focus more on hackathon work? He
also suggested to organise a session for WG chairs on how to handle
difficult situations in a WG session.

Rick Taylor agreed with those who said they liked the current format of
the WG chairs lunch. He added that especially this particular session
worked really well, starting with a small number of updates and then a
good open mic discussion. This seems to be working pretty well, let’s
not just through it out for the sake of it.

Ben Campbell said that the IESG is currently discussing how to find more
time for the hackathon. Regarding Sunday tutorials for WG chairs, it
would be good to announce them early on so people can plan ahead.

Ari agreed with the idea of combining break-out and presentation style
in WG meetings. He also liked the topic on how to handle difficult
situations. Regarding time allocations he added that the weekend before
the IETF is getting very crowded. Maybe we need to work on some
guidelines on how to make the week work better?

Spencer seconded the idea of having the WG chairs lunch as a break-out
session.

Charles (?) said that when they first started the hackathon, it was an
experiment and now it is indeed growing, it takes more time, it costs
more. He started working with the secretariat on how all these issues
can be addressed, for instance planning to experiment with more informal
side room hackathons.

Barry asked the room how many people know that when you request a WG
session, they can request a U-shaped layout?
Many hands went up.

Niels asked for advice from other WG chairs on scheduling conflicts and
how to deal with them. What, where and how should we be using the
rescheduling feature?

At the end Karen described the types of tutorials we usually organise
(newcomers, area overviews, procedural tutorials, technical tutorials)
and asked to submit topics.

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 20 Jul 2017 23:21:42 -0400

Miriam: 

Thanks for the notes.  I think the split between www.ietf.org and datatracker.ietf.org - is a good one.  www.ietf.org looks like something managers can look at.  Datatracker.ietf.org - will be where I go for my daily work.      Maybe we could even get this down to an alias of 1 letter.  d.ietf.org.    

Tell Greg - Awesome work!

Sue Hares

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Mirjam Kuehne
Sent: Thursday, July 20, 2017 8:32 AM
To: [email-masked]
Subject: IETF 99 WG Chairs Forum Minutes

Hi all,

Please find below the minutes of this week's WG chairs lunch session.
Let me know if anything is missing. We will also post them on the wg chairs wiki.

Kind regards,
Mirjam Kühne
==============

WG Chairs Forum
IETF 99, 19 July 2017

Agenda:
1. An Update on the RFC Format Project (Heather Flanagan) 2. IETF Comms update (Greg Wood) 3. WG Chairs Forum agenda and topics 4. Open Forum

(see slides)

Pretty much everybody in the room knew that Heather is changing the RFC format.

Q & A

David Black thanked Heather for all her hard work and asked if anyone is thinking about tracking the state of the upstream tools during the migration from v2 and v3. Which of the community tools are where in the process?

Henrik Levkowetz pointed people to the issue tracker on the tools section on the IETF web site for bug reports about xml2rfc.

There is a project plan. Russ Housley is now the project manager.
There are three possible audiences for the site: experienced IETF participants, new IETF participants and people who might never actually attend an IETF meeting.
In the meantime there were also some changes made to the datatracker.
Russ now sent a mail to the IETF discussion list announcing the beta site. Feedback is coming in.
There will still be time for testing and providing feedback.
Plan is to move to production in the next few months.
There is a mail address you can send feedback to: [email-masked] There is also an issue tracker for more details (see Russ Housley’s mail to the list).

Q & A

Tim Chown said that we have to realise that www.ietf.org will be the place that people go to that are not regular IETF participants. More experienced IETF participants will mostly work on the datatracker and the tools page. He said this is ok, but we will have to get used to.

Greg added that when he was asking people, most IETF participants use the main IETF site to register for the meetings and they also use the links on the left hand site.

Bob Hinden thanked Greg for doing this and said it’s a vert thankless job (people will always criticise you, whatever you do). He added that hates that picture on the front page, because it doesn’t at all represent how we do work at the IETF.

Allison Mankin also thanked Greg for this work and applauded him for being very communicative and clear about the entire process. She mentioned that she has been involved in the development of a number of corporate web sites and always found eyeball testing is essential.

Greg said that this is definitely part of the plan and added that Alissa Cooper is interested in that as well.

Karen reported that we used to do WG chairs tutorials and then moved to this more open forum. She said she would like to find out if this is a useful format and how we can better solicit feedback for future topics.
Karen asked a number of questions:

How many people think these WG chair forums should continue? Many hands went up

Barry Leiba said he liked it when we had one or two topics that filled the time rather than these short 10 minute updates. He offered to think about some topics. He really liked those topical meetings.

Robert Sparks agreed with Barry, but added that if we continue this more open format, it might be an idea to have this meeting in the lounge with smaller tables and break-out sessions so that people can discuss in smaller group.

Spencer Dawkins said that we don’t have to make this decision for all future IETF meetings. He liked the idea of the WG Chairs lunch to be a discussion forum, and not classroom style only.

Barry added that because we pick a topic for a day, doesn’t mean it has to be a lecture. And that’s how we did that in the past. He said he also likes Robert’s idea, but it might be difficult logistically.

Barry suggested a topic: a quick intro from a few chairs about what they found particularly effective in running  WG session. Then a discussion about what problems chairs encountered and how they handled them. A WG Chairs management session.

One of the relative new WG chairs said that understanding what it means being a chair is very important and relevant, but that might be different for more experienced chairs.

Barry asked the room how many have tried running a WG session as a break-out session.
Only a couple of hands went up. But might be worth a try.

A participant suggested to ask the IESG what would help them with document reviews. What could WG chairs do to help with that process?

Ari Keranen reported that they had break-out sessions and made very good experience with it. It needs enough space and also good note takers.

Rick Taylor agreed and added that this of course doesn’t have to be at every IETF. But it would definitely be useful for new chairs.

Dave Morton also liked the idea. He reminded people that in the past when we organised this we would open it up to prospective WG chairs (together with some existing chairs).

Brian Roosen commented on the idea of break-out sessions. He said a good format for the WG chairs lunch could be a session on possible formats and ideas on how to run a meeting.

Niels said that the hackathon is coinciding with the Sunday tutorials and the newcomers events. And many of the hackathon participants are newcomers. Maybe we could consider doing some tutorials during the week?

Robert said the hackathon is getting as important if not more than the work done at the WG meetings. Maybe we need to start thinking about having fewer WG sessions and instead focus more on hackathon work? He also suggested to organise a session for WG chairs on how to handle difficult situations in a WG session.

Rick Taylor agreed with those who said they liked the current format of the WG chairs lunch. He added that especially this particular session worked really well, starting with a small number of updates and then a good open mic discussion. This seems to be working pretty well, let’s not just through it out for the sake of it.

Ben Campbell said that the IESG is currently discussing how to find more time for the hackathon. Regarding Sunday tutorials for WG chairs, it would be good to announce them early on so people can plan ahead.

Ari agreed with the idea of combining break-out and presentation style in WG meetings. He also liked the topic on how to handle difficult situations. Regarding time allocations he added that the weekend before the IETF is getting very crowded. Maybe we need to work on some guidelines on how to make the week work better?

Spencer seconded the idea of having the WG chairs lunch as a break-out session.

Charles (?) said that when they first started the hackathon, it was an experiment and now it is indeed growing, it takes more time, it costs more. He started working with the secretariat on how all these issues can be addressed, for instance planning to experiment with more informal side room hackathons.

Barry asked the room how many people know that when you request a WG session, they can request a U-shaped layout?
Many hands went up.

Niels asked for advice from other WG chairs on scheduling conflicts and how to deal with them. What, where and how should we be using the rescheduling feature?

At the end Karen described the types of tutorials we usually organise (newcomers, area overviews, procedural tutorials, technical tutorials) and asked to submit topics.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 21 Jul 2017 07:03:20 +0200

On Jul 21, 2017, at 05:21, Susan Hares <[email-masked]> wrote:
> 
> alias of 1 letter.  d.ietf.org.    

+1!!!11one

Grüße, Carsten

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 21 Jul 2017 10:37:42 +0200

d.ietf.org - +100!

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 23 Jul 2017 11:04:12 +0000

Hi Mirjam,
thanks for preparing these detailed minutes!

...
> (together with some existing chairs).

I must have mumbled at the microphone, sorry.
My first name is Al.  :-)

I remember that David Black came to the mic after me
and gave a big +1 to my comment, so perhaps we became
one person in your notes...

thanks again,
Al