Subject: Re: [irsg] Stop trying to fix what is broke in a different way than you think

From: Jana Iyengar <[email-masked]>
Date: Tue, 1 Aug 2017 18:47:58 +0000

Completely agree with ekr. My first thought was also that they're
differently useful, and that we need more time in QUIC wg meetings for
discussion.

I don't think restructuring meeting time is necessary or useful as a global
exercise -- IMO that's really best left to the wg chairs and the group
itself.

Alternatively, perhaps not all wgs/rgs need to meet during IETF week.

Separately, I do think that there should be serious thought and
consideration given to chartering of new wgs or rgs, and perhaps more
aggressive closing. I'm getting increasingly bothered as I keep finding
more and more conflict during IETF week. Fewer wgs means more gaps during
the day, which allows for hallway conversations, which are incredibly
important during IETF week.

- jana

On Mon, Jul 31, 2017 at 7:02 PM, Eric Rescorla <[email-masked]> wrote:

>
>
> On Mon, Jul 31, 2017 at 11:54 AM, Stephen Farrell <
> [email-masked]> wrote:
>>
>> I really find it hard to believe that the formal sessions
>> we have now are the best option for all of the the week.
>> Given that we had a couple of hundred people spending the
>> w/e in Prague hacking, doing the tools codesprint, the ANRW
>> workshop and various other weekend activities, it seems
>> obvious to me that there is a demand, and now a significant
>> demand, for more than just our current set of formal WG
>> sessions.
>>
>> If, OTOH, the people who were there at the weekend in
>> Prague said they find the Mon-Fri sessions *more* useful,
>> then that'd shut me up, but I don't think I've heard
>> that.
>>
>
> They're differently useful. To take a concrete example, we spent two days
> hacking on TLS and QUIC stacks and then ~6 hours in QUIC-related WG
> meetings. I don't believe it would have been useful to sacrifice any of
> that WG meeting time for more hacking time (though given the ratios the
> opposite might have been true).
>
> FWIW, I do sometimes have the sense that some formal session or other is
> not a good use of time, but I don't think that's primarily a question of
> the form of the session (presentations or whatever) being useless but
> rather the content being not really that relevant or important. But the
> solution to that problem is to shut down WGs and documents that are
> irrelevant, not to push back on people doing presentations.
>
> -Ekr
>
>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Aug 2017 19:13:08 +0000

> I don't think restructuring meeting time is necessary or useful as a global exercise -- IMO that's really best left to the wg chairs and the group itself.

Totally agree!  Informing chairs of options, and perhaps make sure that nobody feels like a second-class citizen for using different meeting approaches, seems like the most effective use of time.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Aug 2017 21:19:48 +0200

> Totally agree!  Informing chairs of options, and perhaps make sure that nobody feels like a second-class citizen for using different meeting approaches, seems like the most effective use of time.

+1

Grüße, Carsten

---

From: Yoav Nir <[email-masked]>
Date: Tue, 1 Aug 2017 22:36:34 +0300

> On 1 Aug 2017, at 22:13, Salz, Rich <[email-masked]> wrote:
> 

+1

There’s really very few rules on how meeting time is spent: You have to show the Note Well, you have to fill in the blue sheets, you have to prepare minutes. Everything else is up to the chairs.

Oh, and you have to make all discussion be into the microphones and allow remote participants to participate meaningfully. These points severely limit what you can do. That moderate  question-and-answer-and-opinion session that we tend to have works pretty well with remote participants. Some of the proposed alternatives don’t do that very well.

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 1 Aug 2017 17:27:46 -0500

I am reading the responses to my question with interest, but am not 
replying to every one of them :-)

But, since Stephen conjured me up ...

On 07/31/2017 01:54 PM, Stephen Farrell wrote:
>
> On 31/07/17 19:03, Toerless Eckert wrote:
>> I was bringing up the experiment to skip slides
> I hope that we're not interpreting Spencer's ask to be
> solely about slideware.
It wasn't intended to be.

And, as a couple of people have observed, working groups are different, 
so I'm curious about what chairs aren't doing, that they'd like to do 
differently, and whether there are any other chairs who'd like to try 
the same thing, so that it's worth a conversation here, and not in your 
working group.
> IMO, making better use of a week when loads of us are in
> one place is entirely feasible, and experiments to see
> what works well would be good. (And there's really no need
> for strawman suggestions that one size fits all won't cut
> it: I don't hear anyone sensible suggesting that.)
>
I'd find it harder to believe that that's the best option for 100+ 
different working groups to spend all of the week, and that it will be, 
for all time.

And if it's not, when should that start changing for some working 
groups, and in which direction(s)?

I'll go back to listening now, and thanks for the thoughts expressed so far.

Spencer
> S.

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 4 Aug 2017 21:25:14 +0000

Not everyone writes code. Not everyone writes specs. What I think could work well is to have a block of time (e.g. 4 hours) and a place established each day for those interested in working on code to meet and work together. A given working group may decide to make use of this space every day, one day, or not at all. Regular working group meetings could be going on in parallel in other rooms/space and be attended by those not involved in the coding session. A working group could list one or more coding sessions as conflicts to try to help with time management of their working group member. 

Cheers,
Charles

-----Original Message-----
From: WGChairs <[email-masked]> on behalf of Michael Richardson <[email-masked]>
Date: Monday, July 31, 2017 at 11:00 AM
To: Warren Kumari <[email-masked]>
Cc: IETF chairs <[email-masked]>, Spencer Dawkins at IETF <[email-masked]>
Subject: Re: Brilliant Plan? More hackathon, less PowerPoint-athon? (was: [irsg] IETF 99 WG Chairs Forum Minutes)

    Warren Kumari <[email-masked]> wrote:
        >> Fred Baker <[email-masked]> wrote:
        >> > I'm pretty much in the same boat. I have an email out to my co-chairs
        >> > and they may disagree with me. But where we stand right now, v6ops is
        >> > on operational working group and by charter doesn't develop code or
        >> > specifications for code. I don't know what we would hack in a
        >> > hackathon.
    
        > We also seem to be working from the assumption that everyone who
        > participates also writes code; this is an incorrect assumption. There
        > are a number of people who are not software engineers, but rather
        > network engineers - while their input might be useful to people
        > hacking code, it may not be the best use of their time...
    
    It may not be the best of us time, but having someone to configures
    equipment sitting with someone who writes code to configure equipment
    can be very productive.
    
    It can lead to clarifications about why certain parameters exist, or
    cause certain options to just *go away*, because they are never useful.
    (I point to a decade or more of configuring explicit broadcast addresses in
    Linux distros.  No idea why it was ever there. Sure, as an override, but
    you almost never need to do that, and if you do, you are already a guru)
    
    But, again, Spencer didn't ask you why it wouldn't work for you.
    
    --
    Michael Richardson <[email-masked]>, Sandelman Software Works
     -= IPv6 IoT consulting =-