Subject: Testing one of DMARC workarounds: rewriting p=reject addresses to forwarding addresses

From: Alexey Melnikov <[email-masked]>
Date: Mon, 12 Feb 2018 18:44:22 +0000

Hi,
Many of you have seen the long discussion thread about DMARC and how it affects use of mailing lists.

Tools team is ready to test one of the proposed workarounds to see if it is effective against DMARC problems and measure how it affects different groups of participants. I’ve asked the admins of a few IETF mailing lists if we could use their lists to test the workaround.

The next steps are going to be:

1) Tools team will decide what kind of feedback we are expecting to collect from deploying the workaround. This should happen this week.

2) Deploy the workaround on several mailing lists for some specified period of time (e.g. 2-3 weeks) and inform the community which lists are being used for testing. Testing is going to start later this week, most likely on Wednesday, February 14th.

3) Make sure that some emails are posted to mailing lists under test from email addresses in p=reject domains.

4) Collect and analyze feedback received. In the meantime configuration of the test mailing lists will be rolled back to the current setting (i.e. not to contain any DMARC workaround).

5) Once the feeback is analyzed, IESG together with the Tools Team will announce whether the workaround is what will be deployed permanently.

Below are technical details on how the email address rewriting workaround is going to work:

Emails from domains that don't have p=reject DMARC setting are not going to be affected in any way.

For emails from p=reject domains:

 - From header field of such emails will be rewritten to be under @dmarc.ietf.org domain (which will have p=none policy). For example, "[email-masked]" email address would become "[email-masked]". The original From header field will be preserved in the X-Original-From header field, which can be used for automatic message processing by Sieve and Mail User Agents.

Note that the mapping is reversible, so it would be possible to send replies or new messages to an original sender by sending them to the corresponding mapped @dmarc.ietf.org email address.

Best Regards,
Alexey

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 12 Feb 2018 15:01:47 -0500

Alexey,

Nice solution! I’m looking forward to the experiment, and happy to
volunteer my list.

Cheers,
Andy

On Mon, Feb 12, 2018 at 1:44 PM, Alexey Melnikov <[email-masked]>
wrote:

> Tools team is ready to test one of the proposed workarounds to see if it
> is effective against DMARC problems and measure how it affects different
> groups of participants. I’ve asked the admins of a few IETF mailing lists
> if we could use their lists to test the workaround.
>
>
> 1) Tools team will decide what kind of feedback we are expecting to
> collect from deploying the workaround. This should happen this week.
>
> 2) Deploy the workaround on several mailing lists for some specified
> period of time (e.g. 2-3 weeks) and inform the community which lists are
> being used for testing. Testing is going to start later this week, most
> likely on Wednesday, February 14th.
>
> 4) Collect and analyze feedback received. In the meantime configuration of
> the test mailing lists will be rolled back to the current setting (i.e. not
> to contain any DMARC workaround).
>
> 5) Once the feeback is analyzed, IESG together with the Tools Team will
> announce whether the workaround is what will be deployed permanently.
>
>
>  - From header field of such emails will be rewritten to be under @
> dmarc.ietf.org domain (which will have p=none policy). For example, "
> [email-masked]" email address would become "
> [email-masked]". The original From header field will
> be preserved in the X-Original-From header field, which can be used for
> automatic message processing by Sieve and Mail User Agents.
>
> Note that the mapping is reversible, so it would be possible to send
> replies or new messages to an original sender by sending them to the
> corresponding mapped @dmarc.ietf.org email address.
>
> Best Regards,
> Alexey
>
>