Subject: is mailing list subscription important?

From: "Marc Blanchet" <[email-masked]>
Date: Thu, 29 Mar 2018 22:09:31 -0400

Hello,
  I have my own answer of the question, but just wanted to confirm.

Over the last few weeks, I’ve been changing my mail client config to 
use the anonymous IMAP access to IETF mailing list and at the same time 
unsubscribing to all mailing lists I was subscribed to. I love that new 
config and don’t want to come back. With the (very useful) provision 
that I can even send mail to any ietf mailing list (given I’m 
subscribed to one), I’m effectively not subscribed to any IETF wg 
mailing lists. So I’m assuming that my unsubscription does not have 
any impact on the process in general (e.g. I as a wg chair never checked 
the mailing list subscribers). Therefore, my conclusion is that 
(public/wg) mailing list subscription is not important/relevant/… for 
any IETF related work. Am I wrong?

Marc.

PS. info on this config: 
https://trac.tools.ietf.org/group/tools/trac/wiki/Imap  (for sending 
mail while not subscribed, see last paragraph).

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 29 Mar 2018 22:24:00 -0400

> On Mar 29, 2018, at 10:09 PM, Marc Blanchet <[email-masked]> wrote:
> 
> Hello,
> Over the last few weeks, I’ve been changing my mail client config to use the anonymous IMAP access to IETF mailing list and at the same time unsubscribing to all mailing lists I was subscribed to.

I wasn't aware this was an option. :-)

For the mail lists that I regularly participate on, a local cache is useful since I've been known to search, greg or run stats on list mail from years of content.  And I also like my mail client's ability to thread in personal responses along with archived list stuff.

But for stuff that I'm not super active on, anonymous imap as "Usenet" type feed is perfectly fine.  And it'd save me from the occasions where I've found it useful to just grab list mbox files and then load them locally for similar indexing.

-- Jeff

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Mar 2018 09:04:19 -0500

Marc -

I don't believe there is any part of the process that requires you to be 
subscribed to any mailing list to participate. I know I haven't seen 
anything in the tooling except one thing.

We make a global-whitelist that chairs can configure their lists to use. 
It's formed by combining active addresses from the datatracker and any 
subscribed addresses to the full set of mailing lists (including 
global-whitelist, so in your particular case, you will still remain in 
the global-whitelist) and anyone explicitly whitelisted on any list. 
Someone who has never subscribed to any ietf list or created a 
datatracker account will end up in the "hold for moderation" queue of 
most WG lists. If it's a legitimate poster, the list moderator will 
probably whitelist them, resulting in their addition to the 
global-whitelist.

RjS

On 3/29/18 9:09 PM, Marc Blanchet wrote:
> use the anonymous IMAP access to IETF mailing list and at the same 
> time unsubscribing to all mailing lists I was subscribed to. I love 
> that new config and don’t want to come back. With the (very useful) 
> provision that I can even send mail to any ietf mailing list (given 
> I’m subscribed to one), I’m effectively not subscribed to any IETF wg 
> any impact on the process in general (e.g. I as a wg chair never 
> checked the mailing list subscribers). Therefore, my conclusion is 
> that (public/wg) mailing list subscription is not important/relevant/… 
> for any IETF related work. Am I wrong?
>
> Marc.
>
> PS. info on this config:

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Mar 2018 16:15:32 +0200

The anonymous imap sounds cool, will try to set it up for
all those rarely used WG list i am caching now to save space.

Not a big fan of the current expectations that WG chairs
should complain about clueless posters sending email without
being subscribed. Would rather like the error message sent
back to posters to be updated to ask them to subscribe themselves
before posting.

Toerless

On Fri, Mar 30, 2018 at 09:04:19AM -0500, Robert Sparks wrote:
> Marc -
> 
> I don't believe there is any part of the process that requires you
> to be subscribed to any mailing list to participate. I know I
> haven't seen anything in the tooling except one thing.
> 
> We make a global-whitelist that chairs can configure their lists to
> use. It's formed by combining active addresses from the datatracker
> and any subscribed addresses to the full set of mailing lists
> (including global-whitelist, so in your particular case, you will
> still remain in the global-whitelist) and anyone explicitly
> whitelisted on any list. Someone who has never subscribed to any
> ietf list or created a datatracker account will end up in the "hold
> for moderation" queue of most WG lists. If it's a legitimate poster,
> the list moderator will probably whitelist them, resulting in their
> addition to the global-whitelist.
> 
> RjS
> 
> 
> >Over the last few weeks, I???ve been changing my mail client
> >config to use the anonymous IMAP access to IETF mailing list and
> >at the same time unsubscribing to all mailing lists I was
> >subscribed to. I love that new config and don???t want to come
> >back. With the (very useful) provision that I can even send mail
> >to any ietf mailing list (given I???m subscribed to one), I???m
> >effectively not subscribed to any IETF wg mailing lists. So I???m
> >assuming that my unsubscription does not have any impact on the
> >process in general (e.g. I as a wg chair never checked the mailing
> >list subscribers). Therefore, my conclusion is that (public/wg)
> >mailing list subscription is not important/relevant/??? for any
> >IETF related work. Am I wrong?
> >
> >Marc.
> >
> >PS. info on this config:
> >https://trac.tools.ietf.org/group/tools/trac/wiki/Imap  (for
> >sending mail while not subscribed, see last paragraph).
> >

-- 
---
[email-masked]

---

From: Suzanne Woolf <[email-masked]>
Date: Fri, 30 Mar 2018 10:46:52 -0400

Hi Marc,

I guess to me there are two purposes to subscriptions to publicly archived IETF mailing lists.

One is your convenience as an IETF participant trying to find the documents, keep up with WG business, and be part of the discussion. It sounds like the mechanism you described works fine for that.

The other purpose is to support transparency in IETF processes, so your participation is visible to others, i.e. a message with your name on it appears on the (publicly archived) list when you have something to say. It sounds like it works for that too. 

As a WG chair I’ve never assumed people who are subscribed to the list but don’t participate in the discussion are “part of the WG” for “NOTE WELL” purposes— they’re not making contributions.

So if you’re missing something in this analysis, so am I. :-)

Suzanne

> Over the last few weeks, I’ve been changing my mail client config to use the anonymous IMAP access to IETF mailing list and at the same time unsubscribing to all mailing lists I was subscribed to. I love that new config and don’t want to come back. With the (very useful) provision that I can even send mail to any ietf mailing list (given I’m subscribed to one), I’m effectively not subscribed to any IETF wg mailing lists. So I’m assuming that my unsubscription does not have any impact on the process in general (e.g. I as a wg chair never checked the mailing list subscribers). Therefore, my conclusion is that (public/wg) mailing list subscription is not important/relevant/… for any IETF related work. Am I wrong?
> 
> Marc.
> 
> PS. info on this config: https://trac.tools.ietf.org/group/tools/trac/wiki/Imap  (for sending mail while not subscribed, see last paragraph).
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Mar 2018 17:11:40 +0200

On Fri, Mar 30, 2018 at 10:46:52AM -0400, Suzanne Woolf wrote:
> As a WG chair I???ve never assumed people who are subscribed to the list but don???t participate in the discussion are ???part of the WG??? for ???NOTE WELL??? purposes??? they???re not making contributions.

I don't think its only about "contributions".

You are supposed to let IETF know of IPR that may
be levied against IETF work.

Now you have the case where you do not want to release your IPR,
for example the IETF work in question was started by a competitor
who wants to (ab?)use the IETF to make you declare (if not even release)
your IPR.

So, then you're in a bind. Supposedly in the past people
in this position explicitly avoided attending/signing-blue-sheet-for
the WG in question.

Same thing i guess could be argued about having your email
subscribed to the WG mailing list.

Of course, this all would be difficult to argue in a court of
law, but if your name is on an actual patent and your name
shows up on blue-sheet/camera/mailing-list and you didn't
make a statement about IPR, then you become an obvious attack vector.

Toerless

> So if you???re missing something in this analysis, so am I. :-)
> 
> 
> Suzanne
> 
> 
> > Over the last few weeks, I???ve been changing my mail client config to use the anonymous IMAP access to IETF mailing list and at the same time unsubscribing to all mailing lists I was subscribed to. I love that new config and don???t want to come back. With the (very useful) provision that I can even send mail to any ietf mailing list (given I???m subscribed to one), I???m effectively not subscribed to any IETF wg mailing lists. So I???m assuming that my unsubscription does not have any impact on the process in general (e.g. I as a wg chair never checked the mailing list subscribers). Therefore, my conclusion is that (public/wg) mailing list subscription is not important/relevant/??? for any IETF related work. Am I wrong?
> > 
> > Marc.
> > 

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Fri, 30 Mar 2018 15:08:57 -0400

Jeffrey Haas <[email-masked]> wrote:
    > For the mail lists that I regularly participate on, a local cache is
    > useful since I've been known to search, greg or run stats on list mail
    > from years of content.  And I also like my mail client's ability to
    > thread in personal responses along with archived list stuff.

It's all IMAP.

The only difference between pulling emails from your personal email "ISP",
and the IETF server is the lack of Received: headers.  If your software
can create a local cache, then it's all the same.

(Okay, so I use fetchmail->MH for my personal email, which I can run grep
on, vs letting Thunderbird do it all itself for my IETF IMAP connection,
but I could use fetchmail instead)

I haven't tried to see what Thunderbird would do with my personal
responses against an archive, but I suspect that quite a few programs
would still do that threading.

    > But for stuff that I'm not super active on, anonymous imap as "Usenet"
    > type feed is perfectly fine.  And it'd save me from the occasions where
    > I've found it useful to just grab list mbox files and then load them
    > locally for similar indexing.

I tend to use the mhonarc archives to find the thread I missed (or deleted
From my inbox without thinking), then find the thread using IMAP/Thunderbird
and then reply.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Fri, 30 Mar 2018 15:12:01 -0400

Robert Sparks <[email-masked]> wrote:
    > subscribed to any mailing list to participate. I know I haven't seen anything
    > in the tooling except one thing.

    > We make a global-whitelist that chairs can configure their lists to use. It's
    > formed by combining active addresses from the datatracker and any

So, a person who was actively submitting drafts from a logged in account
could read an all IETF lists from IMAP, and never subscribe to any specific list?

What else constitutes "active addresses" on the datatracker?
Is a login sufficient?  Or do they have to do something?

The global-whitelist seems to be working very well, in that, I now rarely
get moderated, and I rarely see requests to moderate.  I wonder if there are
any stats on how well it's working...

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Mar 2018 14:16:57 -0500

> could read an all IETF lists from IMAP, and never subscribe to any specific list?
Yes
> Is a login sufficient?  Or do they have to do something?
Your login will be an email address. When you create it it's usually 
active. When you look at the
Account Info page after you login (it's in the menu with your login 
name), you'll see a list of addresses the tracker knows belong to you. 
The active ones are marked active.
For me, for example:
Email addresses
Primary 	Active 	Address
		[email-masked]
		[email-masked]
		[email-masked]
		[email-masked]
		[email-masked]
		[email-masked]
		[email-masked]
		[email-masked]

> any stats on how well it's working...
I haven't figured out a way to collect stats. Only anecdotes like yours.