Subject: Re: [Tools-discuss] format of AD ballot emails

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 5 Apr 2018 15:53:29 +0200

Hi Michael,

Makes sense to me.  Cc:ing wgchairs in case there are additional comments.

	Henrik

On 2018-04-04 22:52, Michael Richardson wrote:
> 
> Right now we see subjects like:
> 
> Subject: [6tisch] Ben Campbell's No Objection on
>                   draft-ietf-6tisch-6top-protocol-11: (with COMMENT)
> 
> I wonder if it might be worth changing this to:
> 
> Subject: [6tisch] 6top-protocol-11: No Objection (COMMENT) from Ben Campbell.
> 
> (i.e. with draft- always removed, with ietf- removed if it exists,
> and with the WG removed if it follows.  So things like AD sponsored
> submissions might say, "richardson-foo-bar-fun-03)
> 
> my goal here is just to group ballot positions together by draft name in MUA
> folders and in archives.  The AD commenting is not as important as that there
> is something being said about a particular document.
> 
> My appologies for asking what might be a bike-shed colour suggestion.
> 
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works
>  -= IPv6 IoT consulting =-
> 
> 
> 
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: <[email-masked]>
Date: Thu, 5 Apr 2018 14:21:14 +0000

Hi,

Starting with the name of the draft would make sense to me as this would follow the hierarchy [WG] draft: action 

IMO I'd rather use the full name of the draft for consistency with existing searching habits, consistency when the name of the draft may not align with the name of the WG (e.g. LSR WG is now working on draft-ietf-isis and draft-ietf-ospf documents).

If the above change is applied, we might consider it for all generated emails. e.g.

OLD:  Rtgdir last call review of draft-ietf-teas-actn-framework-11
NEW: draft-ietf-teas-actn-framework-11: Rtgdir last call review

OLD:  [spring] I-D Action: draft-ietf-spring-segment-routing-ldp-interop-01.txt
NEW: [spring] draft-ietf-spring-segment-routing-ldp-interop-01.txt: I-D Action

OLD: New Version Notification for draft-ietf-spring-segment-routing-mpls-12.txt
NEW: draft-ietf-spring-segment-routing-mpls-12.txt: New Version Notification

OLD:  Protocol Action: 'Segment Routing Architecture' to Proposed Standard (draft-ietf-spring-segment-routing-15.txt)
NEW: draft-ietf-spring-segment-routing-15.txt: Protocol Action 'Segment Routing Architecture' to Proposed Standard

And so on...

--Bruno

 > -----Original Message-----
 > From: WGChairs [mailto:[email-masked]] On Behalf Of Henrik Levkowetz
 > Sent: Thursday, April 05, 2018 3:53 PM
 > To: Michael Richardson; [email-masked]; WG Chairs
 > Subject: Re: [Tools-discuss] format of AD ballot emails
 > 
 > Hi Michael,
 > 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 05 Apr 2018 15:27:12 +0100

Hi,

My personal opinion: I don't mind reordering, but I would rather not strip the draft prefix name, because searching for a draft is so much easier in my email early in the morning, if I don't need to remember to strip the prefix.

So I prefer:

  Subject: [6tisch] draft-ietf-6tisch-6top-protocol-11: No Objection (COMMENT) from Ben Campbell.

Best Regards,
Alexey

On Thu, Apr 5, 2018, at 2:53 PM, Henrik Levkowetz wrote:
> Email had 1 attachment:
> + signature.asc
>   1k (application/pgp-signature)

---

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Apr 2018 11:13:55 -0400

Alexey Melnikov <[email-masked]> wrote:
    > My personal opinion: I don't mind reordering, but I would rather not
    > strip the draft prefix name, because searching for a draft is so much
    > easier in my email early in the morning, if I don't need to remember to
    > strip the prefix.

The full draft name would still be in the body.
but, I can live with not stripping.
I was simply trying to optimize for subject line width.

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 5 Apr 2018 14:46:18 -0500

> I was simply trying to optimize for subject line width.

I understand the desire to reduce the subject line width, and so am
only mildly negative about removing "draft-".  I feel more strongly
that the "ietf-" and WG should be retained, as that is helpful for
scoping the document, for those of us receiving the mail not through
a WG list (e.g., via iesg@).

-Ben

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 6 Apr 2018 08:25:18 +1200

>   Subject: [6tisch] draft-ietf-6tisch-6top-protocol-11: No Objection (COMMENT) from Ben Campbell.

+1, especially since not all WG lists insert [WGname]

otoh my sorting and filtering doesn't care where the draft name appears in the subject, so
from my point of view the change has no real value.

    Brian

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 5 Apr 2018 19:20:14 -0500

Since a new AD who is almost certainly tuning his mail filter rules like a
madman surfaced ... (hi, Benjamin!),

> a WG list (e.g., via iesg@).

I often wish that IESG ballots used a different mailing list for IESG
members than the usual IESG mailing list, which collects mail on almost
every topic that has ever interested an IETF participant. I've beaten my
own mail filter rules into submission so that I can isolate balloting
e-mail, and I hardly ever miss anything, but being able to say "if it's on
THIS mailing list, put it HERE" would be super helpful.

(And now that I've typed that, I note that subscriptions to an IESG-ballot
mailing list could be a lot more widely available than the IESG mailing
list, which collects a lot of stuff that's not intended for public viewing,
and ISTM there's no obvious reason the archives wouldn't be world-viewable)

But Your Mileage May Vary, of course.

Spencer, who is waiting to order a saddle for this unicorn until he
actually needs one ...