Subject: Laptops for WG Chairs

From: Alexa Morris <[email-masked]>
Date: Tue, 29 May 2018 13:03:46 -0700

Working Group Chairs,

Last year, after a vigorous discussion about the topic (see https://mailarchive.ietf.org/arch/msg/wgchairs/lZBBtoXJenpgmfJabhgB3S_46WA), the IESG asked the Secretariat to look into providing laptops for WG Chairs. This effort stalled several times, but we have finally completed that research.

Starting at IETF 102, we will provide a Samsung Chromebook 3 in each working group session. The Chromebooks have 4GB RAM, 2 USB ports, a HDMI port and a 16x9 aspect ratio. Each laptop will also have an external mouse for those who prefer that to a trackpad. Wireless presenter remotes will continue to be available, and the Chrombooks will be locked to the chair’s table to prevent theft. 

No solution is perfect but we are confident that this will prove to be a workable option for most while meeting the budgetary constraints of the IETF. We have verified that attendees can present material in PDF, Powerpoint online and, of course, Google Slides. In addition, the Secretariat will provide written instructions on how to load and present material. 

Finally, please note that the Chromebooks are provided as a convenience and use of them is entirely voluntary. 

Alexa

---

From: Kent Watsen <[email-masked]>
Date: Tue, 29 May 2018 21:23:44 +0000

This is great, thank you!

Will the Chromebooks have networking configured, or is load-from-USB expected?

Assuming networking is configured, could the "written instructions" include how to use a preloaded script to auto-sync/download the WG's current set of meeting materials from datatracker?  Lou Berger has such a script if interested.  Perhaps, in the course of time, even this step could be automated, so everything was ready when the chairs got to the table.  Of course, reliance on the network working could, ironically enough, be a precarious dependency.  Perhaps a background task could do the syncing periodically, so the dependency would only truly exist for very last-minute tweaks?  

Kent

===== original message =====

Working Group Chairs,

Last year, after a vigorous discussion about the topic (see https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_wgchairs_lZBBtoXJenpgmfJabhgB3S-5F46WA&d=DwIFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=oxh1joiral3lBoBEvCSFOZy8J5KH5XXqutXeYPtWI50&s=4abZW-mAKQ1O02gUepfnGgJh_9ud12l3N6UumxsFsQE&e=), the IESG asked the Secretariat to look into providing laptops for WG Chairs. This effort stalled several times, but we have finally completed that research.

Alexa

---

From: Alexa Morris <[email-masked]>
Date: Tue, 29 May 2018 15:05:14 -0700

Hi Kent,

> On May 29, 2018, at 2:23 PM, Kent Watsen <[email-masked]> wrote:
> 
‘
Yes, the Chromebooks will have access to the IETF network.

> Assuming networking is configured, could the "written instructions" include how to use a preloaded script to auto-sync/download the WG's current set of meeting materials from datatracker?  Lou Berg…

Interesting idea. We will look into it.

Thanks,
Alexa

---

From: Lou Berger <[email-masked]>
Date: Tue, 29 May 2018 18:25:45 -0400

> Interesting idea. We will look into it.
I think what would be best is if there was rsync available for the 
meeting materials pages and rsync was run periodically.  Baring that, 
I'm happy to work with whoever to make my crude/old/screen scraping  
scripts work for the next meeting...

Alexa, have whoever makes to work with contact me off list...

Lou

PS Having these laptops will be a *huge* help -- thank you!

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 29 May 2018 23:16:40 -0400

On Tue, May 29, 2018 at 6:25 PM Lou Berger <[email-masked]> wrote:

> >> Assuming networking is configured, could the "written instructions"
> include how to use a preloaded script to auto-sync/download the WG's
> current set of meeting materials from datatracker?  Lou Berger has such a
> script if interested.  Perhaps, in the course of time, even this step could
> be automated, so everything was ready when the chairs got to the table.  Of
> course, reliance on the network working could, ironically enough, be a
> precarious dependency.  Perhaps a background task could do the syncing
> periodically, so the dependency would only truly exist for very last-minute
> tweaks?

I'm very much expecting rsync is a non-starter on a chromebook... also,
your presentation providing people will need to provide PDF format for
upload to the meeting materials site. From there a chair could simply
click/display-full-screen/exit wash/rinse/repeat

> >> Last year, after a vigorous discussion about the topic (see
> https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_wgchairs_lZBBtoXJenpgmfJabhgB3S-5F46WA&d=DwIFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=oxh1joiral3lBoBEvCSFOZy8J5KH5XXqutXeYPtWI50&s=4abZW-mAKQ1O02gUepfnGgJh_9ud12l3N6UumxsFsQE&e=),
> the IESG asked the Secretariat to look into providing laptops for WG
> Chairs. This effort stalled several times, but we have finally completed
> that research.
> >>
> >> Starting at IETF 102, we will provide a Samsung Chromebook 3 in each
> working group session. The Chromebooks have 4GB RAM, 2 USB ports, a HDMI
> port and a 16x9 aspect ratio. Each laptop will also have an external mouse
> for those who prefer that to a trackpad. Wireless presenter remotes will
> continue to be available, and the Chrombooks will be locked to the chair’s
> table to prevent theft.
> >>
> >> No solution is perfect but we are confident that this will prove to be
> a workable option for most while meeting the budgetary constraints of the
> IETF. We have verified that attendees can present material in PDF,
> Powerpoint online and, of course, Google Slides. In addition, the
> Secretariat will provide written instructions on how to load and present
> material.
> >>

---

From: Fred Baker <[email-masked]>
Date: Wed, 30 May 2018 05:24:02 +0200

Hmm. I don't mind uploading PDF. However, if someone sends me ppt/pptx, I will generally upload and use that on the assumption that they are using ppt features like builds, which pdf doesn't have. If I'm limited to pdf, I'll wind up looking through the ppt/pptx to see if they are depending on something I would need to be aware of. Some people send me both, and I upload both.

> On May 30, 2018, at 5:16 AM, Christopher Morrow <[email-masked]> wrote:
> 
> 
> 
> I'm very much expecting rsync is a non-starter on a chromebook... also, your presentation providing people will need to provide PDF format for upload to the meeting materials site. From there a chair could simply click/display-full-screen/exit wash/rinse/repeat
>  
>

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 29 May 2018 23:25:07 -0400

> click/display-full-screen/exit wash/rinse/repeat

Sorry, didn't mean to come off as a downer... I do like the idea of the
chromebooks a bunch :)
I think aside from the  above things: "do I login as me?" and "is this
safe?" and "what if I don't have a google account, then what?"

"guest login enabled" [0] is probably something to look into for the
chromebooks to avoid that whole discussion though :)

-chris
0: https://support.google.com/chromebook/answer/1057090?hl=en

>> >> Finally, please note that the Chromebooks are provided as a
>> convenience and use of them is entirely voluntary.
>> >>
>> >> Alexa
>> >>
>> >>
>> >
>>
>>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 30 May 2018 09:29:06 +0100

I think the chromebooks are a good idea.

On 30/05/18 04:25, Christopher Morrow wrote:
> I don't have a google account

The above however applies to me, so if such an a/c
were needed I'd not benefit from the new h/w which
would be a pity (for me:-).

So hopefully no such a/c is required. If some login
is needed the same approach as is taken for 802.1X
could work (i.e. "well-known" username/password).

Cheers,
S.

---

From: Ted Hardie <[email-masked]>
Date: Wed, 30 May 2018 10:40:49 +0200

Howdy,

On Wed, May 30, 2018 at 10:29 AM, Stephen Farrell <[email-masked]
> wrote:

> Chromebooks allow you to browse as a guest, so you could visit sites
(including the proceedings site) from there. So you can get some benefits
from it in that mode.

Using it with a shared account would be contrary to the account design (see
https://support.google.com/a/answer/33330?hl=en).

Ted

---

From: Lou Berger <[email-masked]>
Date: Wed, 30 May 2018 05:44:49 -0400

Fwiw - Data tracker automatically generates pdf from uploaded ppt/pptx...

----------
On May 29, 2018 11:24:36 PM Fred Baker <[email-masked]> wrote:

> Hmm. I don't mind uploading PDF. However, if someone sends me ppt/pptx, I 
> will generally upload and use that on the assumption that they are using 
> ppt features like builds, which pdf doesn't have. If I'm limited to pdf, 
> I'll wind up looking through the ppt/pptx to see if they are depending on 
> something I would need to be aware of. Some people send me both, and I 
> upload both.
>
>> >> No solution is perfect but we are confident that this will prove to be a 
>> workable option for most while meeting the budgetary constraints of the

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 30 May 2018 08:51:52 -0400

> Fwiw - Data tracker automatically generates pdf from uploaded ppt/pptx...
sure, somewhat delayed (I don't care to make this part faster) and ...
potentially with the transitions squashed or other oddball artifacts.
When asking for presentations I NORMALLY say:
  "send only pdf, if you send ppt/pptx/etc I'll convert to pdf with all of
the failure on you..."

-chris

---

From: Lou Berger <[email-masked]>
Date: Wed, 30 May 2018 09:36:05 -0400

On 5/30/2018 8:51 AM, Christopher Morrow wrote:
>
>
> On Wed, May 30, 2018 at 5:44 AM Lou Berger <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>   "send only pdf, if you send ppt/pptx/etc I'll convert to pdf with 
> all of the failure on you..."
>

funny, I have done the opposite in the past - i.e., I had a preference 
for pptx as it generally renders and operates better. With the 
chromebooks it sounds like ppt maps to office online or libreoffice, 
which I have no experience with so have no idea if it is usable.

Lou

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 30 May 2018 11:22:47 -0400

> for pptx as it generally renders and operates better. With the

ha :) "not everyone has the ability to view ppt/pptx"

> which I have no experience with so have no idea if it is usable.
there's no libreoffice on chromeos, there's "upload to google docs" or
"upload to office360" (and then display).
Imagine chromeos is just a chromebrowser on a laptop.

-chris