Subject: outline for GitHub creation scripts

From: "Salz, Rich" <[email-masked]>
Date: Wed, 18 Jul 2018 18:19:36 +0000

Martin talked about use of GitHub, and I kinda got suckered into writing some bootstrap scripts by asking if he had any.  So here’s my initial thoughts.  Comments and feedback encouraged.  Particularly, what did I miss?

                mk-ietf-wg
                                -wg WGNAME
                                -chair GH_ID (can be repeated, must be at least once)
                                -ad GH_ID (can be repeated, must be at least once)
Creates a GitHub organization, ietf-wg-$WGNAME
Populates organization meta-data (URL, mailing list, description, IETF logo, what else?)
Creates an “owners” team of the chairs and AD’s

                mk-ietf-repo
                                -wg WGNAME
                                -doc DOCNAME (removes /draft-/ /ietf-/ /$WGNAME-/ prefixes; any others?)
                                -editor GH_ID (can be repeated, must be at least once)
Creates a repository draft-$WGNAME-$DOCNAME within the ietf-wg-$WGNAME organization.
Creates the common issues “editorial” and “design” (any others, like “parked”?)
Creates a $DOCNAME team within the organization that has the editors and owners as members of that repo
Adds Martin’s I-D tools as a submodule, runs the initial script to populate contributing, etc.
Edits the Makefile as needed, to populate all $WGNAME related URL’s

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 18 Jul 2018 18:46:07 +0000

Thanks for doing this?

Adding to this, you may wish to consider:
1 – Creation of a Note Well in the root of the repo (like https://github.com/IASA2/Background-Note-Well)
2 – Creating folders /Drafts and /Meetings where WG I-Ds and meeting materials can go, respectively.

Longer-term, it’d be nice to have a simple & automated way to generate IETF-compatible XML from a GH markdown file (which is more difficult that in needs to be today). That XML can then be used in XML2RFC to generate new Internet Drafts.

JL

From: WGChairs <[email-masked]> on behalf of "Salz, Rich" <rsalz=[email-masked]>
Date: Wednesday, July 18, 2018 at 2:20 PM
To: 'WG Chairs' <[email-masked]>
Subject: outline for GitHub creation scripts

                mk-ietf-wg
                                -wg WGNAME

                mk-ietf-repo
                                -wg WGNAME

---

From: Martin Thomson <[email-masked]>
Date: Thu, 19 Jul 2018 10:17:13 -0400

> 1 – Creation of a Note Well in the root of the repo (like https://github.com/IASA2/Background-Note-Well)

My tools already do this.

> 2 – Creating folders /Drafts and /Meetings where WG I-Ds and meeting materials can go, respectively.

The established convention here is a repo called `wg-materials`.

> Longer-term, it’d be nice to have a simple & automated way to generate IETF-compatible XML from a GH markdown file (which is more difficult that in needs to be today). That XML can then be used in…

As mentioned, this process exists.

---

From: Jane Coffin <[email-masked]>
Date: Thu, 19 Jul 2018 14:18:43 +0000

All -

I was not able to attend the lunch, yesterday.
Was the session recorded?

Jane

Internet Society | www.internetsociety.org

Skype:  janercoffin

Mobile/WhatsApp:  +1.202.247.8429

On 7/19/18, 10:17 AM, "irsg on behalf of Martin Thomson" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Martin Thomson <[email-masked]>
Date: Thu, 19 Jul 2018 10:22:41 -0400

Hey Rich,

> Martin talked about use of GitHub, and I kinda got suckered into writing some bootstrap scripts by asking if he had any.  So here’s my initial thoughts.  Comments and feedback encouraged.  Particul…

If someone would be willing to do this, that would be a great help.
I'm willing to help, but note that the creation process is already
fairly straightforward, and rare, so the value here is in creating
consistency.  A standardized tool is good for that, but it could
become overbearing.

>                                 -ad GH_ID (can be repeated, must be at least once)

With datatracker integration, the latter two options could be omitted.
If the datatracker were to maintain information about github
identities, that would be useful.  You will need to identify yourself
and provide credentials for this.  There's probably something that can
be done with oauth, but I've tried to keep the tools simple thus far.

Note that even if you automate parts of this setup, people need to
accept things like invitations manually.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 19 Jul 2018 15:24:56 +0000

fairly straightforward

Creating a WG yes.  The main reason is for consistency in names, i.e., discovery.
 
>    With datatracker integration, the latter two options could be omitted.

Well, and an API to get the data.  Screen-scraping is so last generation. (

Yes.  But once you joined an org, you can set the default to be 'auto-join' when a new repo (i.e., document) gets created.