Subject: suggested features for materials upload

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 19 Jul 2018 14:28:17 +0000

Hello,

Would like to have our feedback on a possible feature for the meeting page of the datatracker.

When preparing WG/RG sessions, we often chase presenters for their slides and upload them on the datatracker. This is ok but sometimes burdensome and time-consuming.

What about allowing the presenters to directly upload their slides on the meeting page, and we (chairs) receive a notification of the upload, we can then check and validate (or send back to presenters if further work is needed).

This would ease the process while maintaining quality and validation on the WG/RG chairs.

Thanks, Laurent.

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 19 Jul 2018 10:30:50 -0400

Love it.  Yes, please!

Also, it would be helpful to automate the association of presentations 
to agenda topics.

--aaron

On 19 Jul 2018, at 10:28, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) 
wrote:

> When preparing WG/RG sessions, we often chase presenters for their 
> slides and upload them on the datatracker. This is ok but sometimes 
> burdensome and time-consuming.
>
> What about allowing the presenters to directly upload their slides on 
> the meeting page, and we (chairs) receive a notification of the 
> upload, we can then check and validate (or send back to presenters if 
> further work is needed).
>

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 19 Jul 2018 10:32:57 -0400

While I like this suggestion, I fear it will make the presenters delay even
more "I now have until the meeting to upload"

Also, the WG chairs for DNSOP like to look over the slides to make sure
someone is not submitting an overly large talk for the time limit allowed.

I am not against the idea, we need someway to enforce more responsibility.

Tim

(also, I tend to update the chairs slides up until the meeting)

On Thu, Jul 19, 2018 at 10:28 AM, Ciavaglia, Laurent (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> When preparing WG/RG sessions, we often chase presenters for their slides
> and upload them on the datatracker. This is ok but sometimes burdensome and
> time-consuming.
>
>
>
> What about allowing the presenters to directly upload their slides on the
> meeting page, and we (chairs) receive a notification of the upload, we can
> then check and validate (or send back to presenters if further work is
> needed).
>
>
>

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 19 Jul 2018 10:34:55 -0400

I would hope the use of this feature would be optional.

--aaron

On 19 Jul 2018, at 10:32, Tim Wicinski wrote:

>> Would like to have our feedback on a possible feature for the meeting 
>> page
>> of the datatracker.
>>
>>
>>
>> slides
>> the
>> This would ease the process while maintaining quality and validation 
>> on
>> the WG/RG chairs.
>>
>>
>>
>> Thanks, Laurent.
>>

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 19 Jul 2018 14:38:09 +0000

We could imagine setting a deadline e.g. using this method upload is possible up to 24hrs before the meeting.
The feature would not change the ability of chairs to look/control the slides: chairs receive a notification and validate or not the upload.
Yes, this could remain optional.

-Laurent.

From: Aaron Falk [mailto:[email-masked]]
Sent: Thursday, July 19, 2018 4:35 PM
To: Tim Wicinski <[email-masked]>
Cc: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]
Subject: Re: suggested features for materials upload

--aaron

While I like this suggestion, I fear it will make the presenters delay even more "I now have until the meeting to upload"

Also, the WG chairs for DNSOP like to look over the slides to make sure someone is not submitting an overly large talk for the time limit allowed.

Tim

On Thu, Jul 19, 2018 at 10:28 AM, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Thanks, Laurent.

---

From: Fred Baker <[email-masked]>
Date: Thu, 19 Jul 2018 10:38:19 -0400

Sounds good to me. I have two questions/concerns:

(1) we still have to get authors/editors to actually DO it, which is the hard/time-consuming part. The actual upload is trivial - and the chair still has to arrange them in the appropriate order.
(2) this sounds like it gives others the ability to upload their stuff even though it is NOT on the agenda. I have some authors/editors that can get pushy at times, and this could be perceived as giving them leverage, or the appearance in the proceedings of having presented their topic when they didn't. I think I would want some way (similar to what we do with permitting working group drafts) to permit slides from topics on the agenda.

> On Jul 19, 2018, at 10:30 AM, Aaron Falk <[email-masked]> wrote:
> 
> Love it. Yes, please!
> 
> Also, it would be helpful to automate the association of presentations to agenda topics.
> 
> --aaron
> 
> On 19 Jul 2018, at 10:28, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) wrote:
> 
> Hello,
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 19 Jul 2018 10:48:41 -0400

> On Jul 19, 2018, at 10:38 AM, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]> wrote:
> 

I think that's a requirement. With the Chromebooks, we wind up displaying from the meeting materials page, and the chairs don't need surprises. Also, remote attendees may download a tar image in advance.

> The feature would not change the ability of chairs to look/control the slides: chairs receive a notification and validate or not the upload.

I'd suggest doing that similar to the way we authorize working group drafts - there is some web page on which the chair presents the name of a draft to pre-permit slides from. And I would suggest that the page allow the chair to override the 24 hour limitation, or allow the chair to do what is necessary regardless of the window. Context of that request - I have a talk I'm adding to v6ops' meeting tomorrow for which a draft was uploaded today (and the authors are looking for operational review in a 6man topic) and will have slides later in the day. It's essentially a lightning talk. I'd want to be able to somehow allow someone to slide in under the wire.

> On Thu, Jul 19, 2018 at 10:28 AM, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]> wrote:
> Hello,
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Jul 2018 11:03:16 -0400

What I think would help, even more than this (or perhaps in conjunction) is
an agenda building tool so that we have consistency between WG agendas, and
much more useful agendas. Right now, most agendas are just uploaded text
files, without live links. I would love a web form that I could enter for
each agenda item:
- Item number
- draft name
- presenter name
- time allowed

and have the tool build the agenda complete with hyperlinks to the drafts
and, once uploaded, the corresponding slides, and the starting clock time
for each item.

And once it’s been built, I can use the tool to update the item number on a
topic, and the agenda will do a live update to shift everything around.

Cheers,
Andy

On Thu, Jul 19, 2018 at 10:38 AM, Fred Baker <[email-masked]>
wrote:

> (1) we still have to get authors/editors to actually DO it, which is the
> hard/time-consuming part. The actual upload is trivial - and the chair
> still has to arrange them in the appropriate order.
> (2) this sounds like it gives others the ability to upload their stuff
> even though it is NOT on the agenda. I have some authors/editors that can
> get pushy at times, and this could be perceived as giving them leverage, or
> the appearance in the proceedings of having presented their topic when they
> didn't. I think I would want some way (similar to what we do with
> permitting working group drafts) to permit slides from topics on the agenda.
>
> page of the datatracker.
> the meeting page, and we (chairs) receive a notification of the upload, we
> can then check and validate (or send back to presenters if further work is
> needed).
> >

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 19 Jul 2018 15:05:47 +0000

Agreed.
I see this as a two-path workflow that merge at the end: one path is the presenters upload, the other one is the wg chairs (as currently implemented). The merge is where the wg chairs validate.
So in worst case we have the same flexibility as today (last minute upload for the wg chairs).

-Laurent.

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Thursday, July 19, 2018 4:49 PM
> To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> <[email-masked]>
> Cc: Aaron Falk <[email-masked]>; Tim Wicinski
> <[email-masked]>; [email-masked]
> > On Jul 19, 2018, at 10:38 AM, Ciavaglia, Laurent (Nokia - FR/Paris-
> Saclay) <[email-masked]> wrote:
> >
> I think that's a requirement. With the Chromebooks, we wind up
> displaying from the meeting materials page, and the chairs don't need
> surprises. Also, remote attendees may download a tar image in advance.
> 
> > The feature would not change the ability of chairs to look/control the
> slides: chairs receive a notification and validate or not the upload.
> 
> I'd suggest doing that similar to the way we authorize working group
> drafts - there is some web page on which the chair presents the name of
> a draft to pre-permit slides from. And I would suggest that the page
> allow the chair to override the 24 hour limitation, or allow the chair
> to do what is necessary regardless of the window. Context of that
> request - I have a talk I'm adding to v6ops' meeting tomorrow for which
> a draft was uploaded today (and the authors are looking for operational
> review in a 6man topic) and will have slides later in the day. It's
> essentially a lightning talk. I'd want to be able to somehow allow
> someone to slide in under the wire.
> 
> > Cc: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> <[email-masked]>; [email-masked]
> > While I like this suggestion, I fear it will make the presenters delay
> even more "I now have until the meeting to upload"
> >
> > Also, the WG chairs for DNSOP like to look over the slides to make
> sure someone is not submitting an overly large talk for the time limit
> allowed.
> >
> the meeting page, and we (chairs) receive a notification of the upload,
> we can then check and validate (or send back to presenters if further
> work is needed).
> >
> on the WG/RG chairs.

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 19 Jul 2018 11:07:26 -0400

In DNSOP we use Google Sheets to build a list of drafts with times and a
countdown clock.

It's been very helpful to know we're going off the rails.

But into the tracker would be great but maybe a longer term ask.

Tim

On Thu, Jul 19, 2018 at 11:03 AM, Andrew G. Malis <[email-masked]> wrote:

> What I think would help, even more than this (or perhaps in conjunction)
> is an agenda building tool so that we have consistency between WG agendas,
> and much more useful agendas. Right now, most agendas are just uploaded
> text files, without live links. I would love a web form that I could enter
> for each agenda item:
> - Item number
> - draft name
> - presenter name
> - time allowed
>
> And once it’s been built, I can use the tool to update the item number on
> a topic, and the agenda will do a live update to shift everything around.
>
> Cheers,
> Andy
>
>

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 19 Jul 2018 11:08:45 -0400

I realize I have a PDF of what we use which does the timing, the countdown,
the "Have Slides" etc.

On Thu, Jul 19, 2018 at 11:05 AM, Ciavaglia, Laurent (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Agreed.
> I see this as a two-path workflow that merge at the end: one path is the
> presenters upload, the other one is the wg chairs (as currently
> implemented). The merge is where the wg chairs validate.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 19 Jul 2018 17:38:46 +0200

I would like to see the following agenda editing workflow:

Agenda item object creation/edit (including file upload):

Object Item:
  "Agenda item Title",
  Agenda-item number (num{.alpha}) (may be empty on creation)
  Agenda item description (free text)
  Submitter (datatracker account, or verified uploader email)
  Presenter (free form string)
  associated draft(s) (list from datatracker),
  Submitter statement rfc6702 4.1 IPR [Yes/No/Unknown]
  optional: Upload-document
     "Document Title",
     Type [presentation, reference-material]
     versions (eg: allow upload of both PDF/PPTX versions together).
     comments (e.g., prior version had foobar problem, IPR comments, etc.pp)

Creation of these objects usable by anyone, including WG chairs.

Non-WG chair uploaders can see/modify/delete their own uploads.

WG-chairs see all items equally, three types: pending (uploaded,
not processed by wg-chair), on-agenda and parked.

WG-chair operations:
  - modify any fields, add/modify field "slot length"
  - action (comment)
    - reject-delete, reject-park
    - accept-insert/replace
      -> puts into agenda agenda item slot num{.alpha},
         inserting (shifting existing agenda items) or
	 replace existing agenda item.
  - action optionally creates notification email to submitter and
    author of associated draft(s)

Parked list is across IETF meetings.

Agenda on datatracker is automatically created/updated from this information
showing all information.

This looks like a lot of work for WG chairs, but effectively,
this is what we typically try to write manually now into an HTML
agenda anyhow, and then every time my co-chair and i edit that
html file the different html editors we use mess it up, or have
to recalculate the overall agenda length (that we try to put on every
slot).

So, IMHO this type of agenda item editor would help a lot to simplify
WG chairs life while simultaneously create a more consistent
meeting agenda experience for all participants.

And of course this is primarily an agenda editor and workflow tool.
Presentation material is a completely optional part of each agenda item,
tracking submitter/presenter/draft(s)/description etc. alone would make this
IMHO beneficial even if we wanted meetings to be without any presentations
attached to them.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Thu, 19 Jul 2018 11:43:55 -0400

This is all great brainstorming - please keep bringing out more 
suggestions like this.

I've heard requests like this (to help automate build session agendas) 
before.

RjS

---

From: Jane Coffin <[email-masked]>
Date: Thu, 19 Jul 2018 21:46:20 +0000

+1

Internet Society | www.internetsociety.org

Skype:  janercoffin

Mobile/WhatsApp:  +1.202.247.8429

From: irsg <[email-masked]> on behalf of "Andrew G. Malis" <[email-masked]>
Date: Thursday, July 19, 2018 at 11:04 AM
To: Fred Baker <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: [irsg] suggested features for materials upload

What I think would help, even more than this (or perhaps in conjunction) is an agenda building tool so that we have consistency between WG agendas, and much more useful agendas. Right now, most agendas are just uploaded text files, without live links. I would love a web form that I could enter for each agenda item: 

- Item number

- draft name

- presenter name

- time allowed

and have the tool build the agenda complete with hyperlinks to the drafts and, once uploaded, the corresponding slides, and the starting clock time for each item.

And once it’s been built, I can use the tool to update the item number on a topic, and the agenda will do a live update to shift everything around.

Cheers,

Andy

On Thu, Jul 19, 2018 at 10:38 AM, Fred Baker <[email-masked]> wrote:

---

From: Jen Linkova <[email-masked]>
Date: Fri, 20 Jul 2018 14:44:32 +1000

> (2) this sounds like it gives others the ability to upload their stuff even though it is NOT on the agenda. I have some authors/editors that can get pushy at times, and this could be perceived as g…

At RIPE, WG Chairs do not need to upload slides for presenters. How it works:
- Chairs create agenda
- when you upload a presentation, you select the slot/agenda item from
a dropdown menu. AFAIR you need to create an account to edit/remove
the existing presentation but I can not recall any cases of the system
being abused.

The obvious benefit is that the presenters can upload their slides
just before the session. Well, I understand that it could be
considered as a drawback, not a benefit ;). The obligatory warning 'if
your slides are not in the system in time you'll have to do the power
point karaoke' usually works  - at the end of the day it's in the
presenter's best interest to get the slides uploaded.

So I fully support the idea of allowing presenters to upload slides.

-- 
SY, Jen Linkova aka Furry

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 20 Jul 2018 09:48:50 -0500

(top posting)

I'm encouraged by the discussion in this thread. I did have one data point
about chairs reviewing slides before the session.

Robert Sparks was my AD when we had a presenter with something like 35
slides for a 10 minute slot, and my co-chair and I hadn't noticed that. But
Robert did.

No matter who uploads slides, it's useful for chairs who might be thinking
about everything else, to think about number of slides vs. number of
minutes!

Spencer

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 20 Jul 2018 10:58:43 -0400

*ding* *ding* *ding* Give that nice man a (DNS) cookie!

This is our big problem in DNSOP - we have to sit down with some presenters
and say "no no no no, you can not do 35 slides in 15 minutes".

Tim

---

From: G Fairhurst <[email-masked]>
Date: Fri, 20 Jul 2018 14:34:14 -0400

On 20/07/2018, 00:44, Jen Linkova wrote:
> On Fri, Jul 20, 2018 at 12:38 AM, Fred Baker<[email-masked]>  wrote:
If I was at a workshop, I'd agree. In standards meeting where most of 
the talks are editors representing WG consensus and issues, I don't 
agree. If people don't submit their slides in time for remote 
participants to download and view, I think we have a problem.

It's also quite nice to also have time for the Chairs to read and 
understand which questions are being asked/need to be asked.

Gorry
>>> On Jul 19, 2018, at 10:30 AM, Aaron Falk<[email-masked]>  wrote:
>>>
>>> Love it. Yes, please!
>>>

---

From: Avri <[email-masked]>
Date: Fri, 20 Jul 2018 11:06:53 -0400

Hi,  

But more complicated than just counting slides, some people include lots of background slides just in case they are asked a question. And it is hard to time slides. There are those that are wordy, and those that are symbolic pictures. So a slide can vary from .5 - 10 minutes. Or more. Or less.

Btw from a historical perspective: when did we become a slide bound organization? Now if I don't have slides, I feel somehow remiss.

Avri

 
 
>  
> On Jul 20, 2018 at 10:58,  <Tim Wicinski (mailto:[email-masked])>  wrote:
>  
>  
>  
> This is our big problem in DNSOP - we have to sit down with some presenters and say "no no no no, you can not do 35 slides in 15 minutes".     
>  
>
>  
> Tim
>  
>
>    
>
>  
> On Fri, Jul 20, 2018 at 10:48 AM, Spencer Dawkins at IETF  <[email-masked] (mailto:[email-masked])>  wrote:
>  
> >  
> > (top posting)    
> >
> >  
> > I'm encouraged by the discussion in this thread. I did have one data point about chairs reviewing slides before the session.
> >  
> >
> >  
> > Robert Sparks was my AD when we had a presenter with something like 35 slides for a 10 minute slot, and my co-chair and I hadn't noticed that. But Robert did.
> >  
> >
> >  
> > No matter who uploads slides, it's useful for chairs who might be thinking about everything else, to think about number of slides vs. number of minutes!
> >    
> >
> >  
> > Spencer
> >  
> >  
>  
>  
>

---

From: Jen Linkova <[email-masked]>
Date: Sat, 21 Jul 2018 07:59:28 +1000

On Sat, Jul 21, 2018 at 4:34 AM, G Fairhurst <[email-masked]> wrote:
> If I was at a workshop, I'd agree. In standards meeting where most of the
> talks are editors representing WG consensus and issues, I don't agree. If
> people don't submit their slides in time for remote participants to download
> and view, I think we have a problem.

I'm not sure how much time remote participants need to download/view
comparing to onsite ones but I think we
are talking about *two* different scenarios here.
- the presenter provides slides on time (before the deadline specified
by the chairs). In this case allowing presenters to upload:
a) eliminates an additional hop/delay in the process (so slides can
actually get uploaded earlier - which would be even more convenient
for remote
participants;
b) allows the presenter to upload the updated version of the slides if
some last minute changes were made.

- the presenter does not provide slides before the deadline, slides
sent  *before* the session starts but too late for the chairs to
notice. In this case, unless the chairs are *very* strict and enforce
the policy 'no slides before the deadline - no talk', the usual
scenario is 'the chairs and the presenter spend 5 minutes trying to
find out how to present the slides, running around with USB sticks,
re-plugging cables etc, wasting time.
I have not been in that situation as a chair myself but it happened to
me twice as a presenter and in both cases being able to upload would
have saved us a bit of time.

Maybe if the chairs have the policy of 'no slides on time - no slot'
then this feature could be enabled on per-WG basis?

> It's also quite nice to also have time for the Chairs to read and understand
> which questions are being asked/need to be asked.

If I understand correctly, the main concern is that people would abuse
the system and would not provide slides until 5 mins before their
talk?

It looks to me like two features would be useful:

- Slides could only be uploaded for the pre-defined agenda items;
- WG chairs should be able to disable upload (so after the deadline
passed slides can not be uploaded; also if the chairs do not want to
use the feature at all, they might keep the upload feature completely
disabled)

---

From: "Aaron Falk" <[email-masked]>
Date: Sun, 22 Jul 2018 08:49:28 -0400

> use the feature at all, they might keep the upload feature completely

+1 for both of these!

---

From: Robert Sparks <[email-masked]>
Date: Sun, 22 Jul 2018 22:04:24 -0500

So far, I suggest allowing anyone logged into upload, but requiring a 
chair or delegate to approve before they show for anyone else is the 
best path. Thoughts? (If/when we pursue this, it'll be the IESG that 
sets this policy, so giving them some good discussion to base a policy 
on would be a good thing.)

RjS

---

From: Tim Wicinski <[email-masked]>
Date: Tue, 24 Jul 2018 12:11:54 -0400

I approve of this - it makes it easier on your side also then knowing all
the folks presenting per WG.

On Sun, Jul 22, 2018 at 11:04 PM, Robert Sparks <[email-masked]>
wrote:

> chair or delegate to approve before they show for anyone else is the best
> path. Thoughts? (If/when we pursue this, it'll be the IESG that sets this
> policy, so giving them some good discussion to base a policy on would be a
> good thing.)
>
> RjS
>

---

From: Christopher Wood <[email-masked]>
Date: Tue, 24 Jul 2018 19:50:32 -0700

> use the feature at all, they might keep the upload feature completely

+1 as well.

Best,
Chris