Subject: I liked the Chromebook

From: "Salz, Rich" <[email-masked]>
Date: Wed, 25 Jul 2018 15:39:15 +0000

It takes some getting used to, and we’ll probably want to revise the instructions for Bangkok, but they worked well for me.

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 25 Jul 2018 10:45:41 -0500

> It takes some getting used to, and we’ll probably want to revise the instructions for Bangkok, but they worked well for me.

Agreed; it was extremely helpful for me -- a big "thank you!" to the
Secretariat for making it happen!

-Ben

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 25 Jul 2018 17:57:20 +0200

In ANIMA, we had the problem that pptx would not show up fullscreen,
(when going fullscreen, the page would be very small)
and had to change over to another notebook. We tried to fiddle
the problem with zoom in keyboard shortcuts but to no avail.
And the clicker also didn't work then when using PPTX.

I tried to repeat the experience afterwards with Steffanie,
but then it worked fine (size and clicker). I hate glitches.

Other thn that, it would be a great improbement, indeed.
Next time i'll try to reboot the chromebook. Seems to be reasonably
fast. *sigh*

On Wed, Jul 25, 2018 at 10:45:41AM -0500, Benjamin Kaduk wrote:
> > It takes some getting used to, and we???ll probably want to revise the instructions for Bangkok, but they worked well for me.
> 

-- 
---
[email-masked]

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 25 Jul 2018 15:57:27 +0000

+1.

Linda Dunbar

From: WGChairs [mailto:[email-masked]] On Behalf Of Salz, Rich
Sent: Wednesday, July 25, 2018 10:39 AM
To: 'WG Chairs' <[email-masked]>
Subject: I liked the Chromebook

---

From: Paul Wouters <[email-masked]>
Date: Wed, 25 Jul 2018 13:11:25 -0400 (EDT)

> It takes some getting used to, and we’ll probably want to revise the instructions for Bangkok, but they worked well for me.

I liked the fact that I didn't have to worry if meetecho would work on
my machine and what stuff I would need to install to make it work.

The integration with my own laptop showing things and meetecho was
great!

Paul

---

From: Kyle Rose <[email-masked]>
Date: Wed, 25 Jul 2018 13:18:44 -0400

Agreed. With the exception of some confusion about how to get the slides to
page properly, the audience experience was consistently better than that of
prior meetings.

On Wed, Jul 25, 2018, 11:39 AM Salz, Rich <rsalz=[email-masked]>
wrote:

> It takes some getting used to, and we’ll probably want to revise the
> instructions for Bangkok, but they worked well for me.
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Jul 2018 10:54:34 -0700

+1. We've been using a separate machine in QUIC interims for a while, and it's REALLY nice to not worry about personal data showing up on the big screen. Now I get those benefits in the big IETF meetings without lugging around a NUC :)

Well done, secretariat!

> On 25 Jul 2018, at 8:39 am, Salz, Rich <rsalz=[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: David Schinazi <[email-masked]>
Date: Wed, 25 Jul 2018 13:26:35 -0700

+1, loved the Chromebook. Thanks!

David

> On Jul 25, 2018, at 10:54, Mark Nottingham <[email-masked]> wrote:
>

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 25 Jul 2018 13:53:45 -0700

+1, worked great!
The only problem was - remote wouldn't work with power point

Cheers,
Jeff

On 7/25/18, 13:27, "WGChairs on behalf of David Schinazi" <[email-masked] on behalf of [email-masked]> wrote:

    David

---

From: Fred Baker <[email-masked]>
Date: Wed, 25 Jul 2018 17:34:53 -0400

Well, PowerPoint didn’t really work. One had to save the files as Google Slides; the remote worked with the slides.

Sent using a machine that autocorrects in interesting ways...

> On Jul 25, 2018, at 4:53 PM, Jeff Tantsura <[email-masked]> wrote:
> 
> +1, worked great!

---

From: "Black, David" <[email-masked]>
Date: Wed, 25 Jul 2018 21:55:12 +0000

Hmm - I thought I saw PPT slides work on the Chromebook via a browser plugin when accessing the PPT directly from the datatracker.

Overall, +1 on the Chromebook working well - a little bit of time up front to get every slide deck into its own tab paid off during the session.

Thanks, --David

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Fred
> Baker
> Sent: Wednesday, July 25, 2018 5:35 PM
> To: Jeff Tantsura
> Cc: WG Chairs; Mark Nottingham; Salz, Rich
> Subject: Re: I liked the Chromebook
> 
> Well, PowerPoint didn’t really work. One had to save the files as Google
> Slides; the remote worked with the slides.
> 
> > On 7/25/18, 13:27, "WGChairs on behalf of David Schinazi" <wgchairs-
> [email-masked] on behalf of [email-masked]> wrote:
> >
> >> +1. We've been using a separate machine in QUIC interims for a while,
> and it's REALLY nice to not worry about personal data showing up on the big
> screen. Now I get those benefits in the big IETF meetings without lugging
> around a NUC :)
> >>
> >> Well done, secretariat!
> >>
> >>
> >>
> >>> On 25 Jul 2018, at 8:39 am, Salz, Rich
> <rsalz=[email-masked]> wrote:
> >>>

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jul 2018 18:49:56 -0400

> Hmm - I thought I saw PPT slides work on the Chromebook via a browser plugin when accessing the PPT directly from the datatracker.
you may have seen me using office365 to present PPTX -- it worked really 
well (via tinyurl to temp public opendrive).  PDF displayed better using 
datatracker/chrome directly but paging was still a bit off.

> Overall, +1 on the Chromebook working well - a little bit of time up front to get every slide deck into its own tab paid off during the session.
+ (a big) 1

Lou

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 26 Jul 2018 12:52:04 -0400

+1 a  big thanks to the Secretariat for making this happen.  

In IDR we were able to use the chromebooks for most presentations.  
We switched to another laptop for powerpoint with actions. 

Sue Hares

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Benjamin Kaduk
Sent: Wednesday, July 25, 2018 11:46 AM
To: 'WG Chairs'
Subject: Re: I liked the Chromebook

> It takes some getting used to, and we’ll probably want to revise the instructions for Bangkok, but they worked well for me.

Agreed; it was extremely helpful for me -- a big "thank you!" to the Secretariat for making it happen!

-Ben

---

From: Sean Turner <[email-masked]>
Date: Thu, 26 Jul 2018 13:09:54 -0400

I originally was against the chromebooks.  But, it worked and I ended up being a fan after I got schooled on which buttons to use to make it go fullscreen.

> On Jul 25, 2018, at 11:39, Salz, Rich <rsalz=[email-masked]> wrote:
>

---

From: Tim Hollebeek <[email-masked]>
Date: Thu, 26 Jul 2018 20:52:46 +0000

Agree... it's a good idea and a good start.  Better instructions would have been
very helpful, but nothing is perfect on the first try.

-Tim

> From: WGChairs <[email-masked]> On Behalf Of Benjamin Kaduk

---

From: Leif Johansson <[email-masked]>
Date: Sat, 28 Jul 2018 22:33:03 +0200

> instructions for Bangkok, but they worked well for me.

+1

just out of curiosity - did you experience any issues related to the
passwords? - They were sorta low on entropy...

	Cheers Leif

---

From: Christian Hopps <[email-masked]>
Date: Sun, 29 Jul 2018 01:20:07 -0400

We also had issues with PPT in LSR (e.g., the remote didn't work), but the chromebook was very nice to have.

Could we just standardize on PDF only, and avoid the PPT issues for the next go-around?

I think the meeting materials upload thing can/does/used to convert to PDF automatically, so if the default was to also download in that format (instead of PPT) then the PPT issue would go away.

Thanks,
Chris.

> On Jul 26, 2018, at 12:52 PM, Susan Hares <[email-masked]> wrote:
>

---

From: Adam Roach <[email-masked]>
Date: Sun, 29 Jul 2018 01:32:37 -0500

> I think the meeting materials upload thing can/does/used to convert to PDF automatically, so if the default was to also download in that format (instead of PPT) then the PPT issue would go away.

As far as I know, the conversion from PPT to PDF was always done in a 
manual or semi-manual fashion by the secretariat. For the WGs I chaired, 
I would always convert to PDF before uploading to the datatracker, to 
save them the time. (I would also combine them into one long deck -- not 
to upload, but for my own use so that I could drive a meeting without 
having to take the time to switch decks between topics. Doing this 
required conversion to PDF as a first step.)

I believe that the issue that prevents automated server-side automation 
is that nothing aside from actual name-brand Powerpoint software can 
reliably create a PDF from a PPT file without running a fairly high risk 
of botching the formatting.

/a

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 29 Jul 2018 09:20:22 +0200

On Jul 29, 2018, at 08:32, Adam Roach <[email-masked]> wrote:
> 
> 
> I believe that the issue that prevents automated server-side automation is that nothing aside from actual name-brand Powerpoint software can reliably create a PDF from a PPT file without running a fairly high risk of botching the formatting.

This is not a matter of branding.  There are multiple versions even of the branded software and the renderings are going to be different.  There are also differences caused by the environment, e.g., fonts available.  It is best to get the rendering done on the machine of the author.

(I learned the hard way that, on a Mac, for a Windows Powerpoint deck often the rendering by Keynote is closer to the author’s intent than the one by Powerpoint for Mac.)

Grüße, Carsten

---

From: "John G. Scudder" <[email-masked]>
Date: Sun, 29 Jul 2018 12:00:22 +0300

> Could we just standardize on PDF only, and avoid the PPT issues for the next go-around?

If you mean “we” the IETF, there’s already social pressure to provide PPT and not PDF, in that your PDF gets converted to PPT anyway so if you want control over how it looks, you’d better PDF it yourself.

If you mean “we” the individual WGs, that’s up to you (or your chairs) of course. We already do this in IDR and have for years, with the proviso that presenters MAY request in advance to present using native PPT if they require PPT-only features like builds and animations. (This has been requested once that I recall, though some presenters who don’t read the instructions carefully in advance have been surprised.) Because I think it’s not reasonable to forbid builds and animations, I’m not likely to want to change to a hard-and-fast “PPT or the highway” rule.

On the other hand, in a presentation I helped give (Ross’s presentation in RTG Area and Ops Area), despite having flagged the builds to the chairs ahead of time they didn’t work, so caveat presentor. In RTG the entire deck failed rather spectacularly, actually. (All formatting lost.) I’m not sure why but it left a bad taste in my mouth about the whole Chromebook thing from the presenter’s point of view.

Others have mentioned preloading all the presentations into tabs before starting the meeting. In IDR we went one further and did what we always do — I concatenated all the presentations into one big PDF and then preloaded that. One tab, no worries about losing track of which tab you’re supposed to present next. The morbidly curious can find the PDFs (two, for two sessions) in IDR’s meeting materials. I was blaming the fact I included both 4:3 and 16:9 slides in the same concatenated deck for the weird (non) horizontal centering and paging issues, but since so many people have complained about that I suppose it’s due to some other reason. Other than that (which I thought was a pretty big minus but I expect it’ll be addressed in the future) I give the experiment a thumbs-up.

—John

---

From: Lou Berger <[email-masked]>
Date: Sun, 29 Jul 2018 08:37:54 -0400

----------
On July 29, 2018 2:33:25 AM Adam Roach <[email-masked]> wrote:
....
> manual or semi-manual fashion by the secretariat.

The conversion has been automated for a while now. Henrik can provide 
details if anyone cares. The tooling also allows upload either PPT or PDF, 
but it assumes that if you upload both that they are different versions and 
it makes only the most recent upload available.

Personally, I'd prefer that it allow upload of both formats for a single 
version to so that a well formatted PDF is available, and PPT is available 
for presentation -- I generally find PPT works better during the session, 
even with the Chromebook (rendered via 365)...

Lou

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 29 Jul 2018 11:44:24 -0500

On Sun, Jul 29, 2018 at 08:37:54AM -0400, Lou Berger wrote:
> .....

I did end up finding the datatracker-converted PDF version of some slide
decks that had been uploaded as .pptx, but it was not as straightforward as
I had remembered.  That is, from the HTML agenda page, the "show meeting
materials" popup for any given session only had links to the "primary"
version (and did not show a file type suffix); I had to datatracker
"session" page (e.g.,
https://datatracker.ietf.org/meeting/102/session/secevent to get a link to
the "doc" page for the slides (e.g.,
https://datatracker.ietf.org/doc/slides-102-secevent-push-based-delivery/)
which has both pptx and pdf links.  Am I misremembering that it used to be
easier to get to the converted PDF?

-Ben

---

From: Fred Baker <[email-masked]>
Date: Sun, 29 Jul 2018 14:46:48 -0700

This makes a lot of sense to me, if I first change all instances of "ppt" to "pdf" and all instances of "pdf" to "ppt". I get some flies as PPT and could instantly change them to PDF. I also get files for which that contravenes the intent of the author. The downside of Google's approach to ppt ("run it on your own machine") is that the chair ends up juggling machines or (in Google Slides) contravening the intent of the speaker. I have to ask - why do we allow slides at all, even using pdf? We do so to help speakers make their points plainly - if I can "go to next slide" rather than quickly drawing on a white board supplied for the purpose, the talk goes more quickly and is probably more understandable to the audience. And it can be kept for posterity, displayed remotely, yada yada yada.

I, personally, use builds in ppt, as I find them useful in expressing meaning - "there's this, and this, and this, as a process in the overall intent of the slide". If I were going to mandate conversion of ppt to pdf, I would want Powerpoint's "print to pdf" capability to create a slide for each "wait until click", so that most of the effect of a build is reflected in PDF slides. That doesn't happen - converting a deck with builds to ppt pretty much means recreating the deck. The IETF has historically reacted badly to Word as a "proprietary file format" in Internet Drafts (largely because each successive release makes the previous one unreadable by "modern" software to force users to pay to upgrade); I'm pretty sure that the reason Powerpoint is accepted *at*all* in IETF circles (even Word-as-Internet-Draft-creation has to be ASCII before it is posted) is because people find it useful.

If people find it useful, I think we should think pretty hard before sweeping it away.

> On Jul 29, 2018, at 2:00 AM, John G. Scudder <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 30 Jul 2018 01:15:49 +0200

On Jul 29, 2018, at 23:46, Fred Baker <[email-masked]> wrote:
> 
> That doesn't happen - converting a deck with builds to ppt pretty much means recreating the deck.

Do you mean “to PDF”?

Doing a rendering to PDF with a page per build is easy with Keynote; I don’t know the various Powerpoints enough to know which of them can do that and how, but I would expect they can.

(Another reason why the *author* should always do the rendering to PDF.)

Of course, that doesn’t help with cute animations…
You can always switch to Prezi if the objective is to nauseate the WG.

(Most of my students have long switched to presenting aided by tools such as reveal.js, hackmd etc., following the trend that all content created by humans needs to be entered in markdown.  But that doesn’t help with diagrams…  Ditaa [1[ notwithstanding :-))

Grüße, Carsten

[1] http://ditaa.sourceforge.net

---

From: "John G. Scudder" <[email-masked]>
Date: Mon, 30 Jul 2018 08:28:29 +0300

On Jul 30, 2018, at 12:46 AM, Fred Baker <[email-masked]> wrote:
> 
> This makes a lot of sense to me, if I first change all instances of "ppt" to "pdf" and all instances of "pdf" to "ppt".

Oops. Yes, that was my intent, thanks. 

—John