Subject: IETF Tools working group page

From: Joel Halpern Direct <[email-masked]>
Date: Wed, 24 Oct 2018 11:02:35 -0400

I just had a problem with a working group member / author 
misunderstanding the tools page.

The problem is that the "Working Group Documents:" active drafts section 
includes any drafts for which the working group has issued a call for 
adoption.  Those are not (yet) working group documents.

In the particular case, I believe I have solved the problem by changing 
the document state to a different state, which should remove it from 
that list.  Still, it caused a lot of confusion.

As I related point, I could not find a good state to change it to.
Let's pretend that we had agreed that the authors were going to revise 
it and then we were going to issue a new call for adoption (that is not 
quite the case here, but good enough).  What state should I have changed 
it to?

Thank you,
Joel

---

From: Jane Coffin <[email-masked]>
Date: Wed, 24 Oct 2018 15:10:30 +0000

Forgive the possibly naïve question, but can we change the state to "active" and add a date?
Dates usually focus people.

Internet Society | www.internetsociety.org

Skype:  janercoffin

Mobile/WhatsApp:  +1.202.247.8429

On 10/24/18, 11:02 AM, "irsg on behalf of Joel Halpern Direct" <[email-masked] on behalf of [email-masked]> wrote:

    

    Thank you,
    Joel

---

From: Joel Halpern Direct <[email-masked]>
Date: Wed, 24 Oct 2018 11:12:54 -0400

The issue is that the particular document is no an Active Working Group 
draft (which is the section name).  It is an active individual draft 
intended for the working group.  It failed WG adoption.  The author was 
reading the page as telling him that it was an Active Working Group 
document.

Yours,
Joel

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 24 Oct 2018 11:22:03 -0400

Joel,

I assume you're referring to draft-sarikaya-sfc-hostid-serviceheader. I
think the problem may be that the WG state includes "Held by WG". Try
turning that off and see if it moves back down to the "Related I-Ds"
section.

Cheers,
Andy

On Wed, Oct 24, 2018 at 11:13 AM Joel Halpern Direct <
[email-masked]> wrote:

> > On 10/24/18, 11:02 AM, "irsg on behalf of Joel Halpern Direct" <
> [email-masked] on behalf of [email-masked]> wrote:
> >

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 24 Oct 2018 11:31:14 -0400

(I replied to Andy, and then realized others might care).
this is indeed sfc document draft-sarikaya...
The problem noticed when the document was a candidate for WG adoption. 
The same problem of mis-=description can be seen with draft-wang on that 
page, as that document is just completing its WG Adoption poll.

I have changed draft-sarikaya to "Held".  I don;'t know if the fact that 
the document is still appearing on the active list is because of delay 
in how the tooling page gets populated, or if tooling things Held is an 
active state?

Yours,
Joel

On 10/24/18 11:22 AM, Andrew G. Malis wrote:
> On Wed, Oct 24, 2018 at 11:13 AM Joel Halpern Direct 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     <http://www.internetsociety.org>
>      >
>      > Skype:  janercoffin
>      >
>      > On 10/24/18, 11:02 AM, "irsg on behalf of Joel Halpern Direct"
>     <[email-masked] <mailto:[email-masked]> on behalf of
>     [email-masked] <mailto:[email-masked]>> wrote:
>      >

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 24 Oct 2018 12:20:50 -0400

Joel,

I agree, this certainly does look like a bug. Report it to ietf-action.

Cheers,
Andy

---

From: Jane Coffin <[email-masked]>
Date: Wed, 24 Oct 2018 16:47:08 +0000

Okay.  Got you

Skype:  janercoffin

On 10/24/18, 11:12 AM, "Joel Halpern Direct" <[email-masked]> wrote:

    Yours,
    Joel

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 24 Oct 2018 19:38:50 +0200

Hi,

1) Since this is an issue with a page on tools.ietf.org, you're
   more likely to get a fix by reporting it to Henrik, a.k.a.
   [email-masked] ,:-)

2) Tracing back the chain of relevant information leads to the file
   https://www.ietf.org/id/1id-index.txt, which lists drafts in the
   states Candidate for WG Adoption and Call for WG Adoption Issued
   under the WG rather than as 'Individual'.  That's probably not
   right.

3) That file is generated by datatracker code hourly, so ultimately
   the fix needed is in the datatracker code.

4) I have a fix ready, which will be part of the next datatracker release.

5) When the fix is in place, drafts in state 'Hold' will still show up
   under the wg.  I thought we'd added a way to remove the 'Candidate'
   state, but will have to go and look at the code for that.  

Best regards,

	Henrik

---

From: "Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 24 Oct 2018 18:54:02 +0000

it's not a bug, but definitely something we might want to find a 
solution to.
Putting the doc in Candidate for WG adoption or any stage after that, 
puts the doc in the IETF Stream (rather than "none" before that). It 
results in this document showing up in the Active Documents of a WG.
This is not an issue, but when indeed the doc is not adopted then we end 
up in an odd situation.
This could be resolved by asking the Secretariat (I think) to take the 
doc out of the IETF Stream. I have checked and it seems I can't as AD.
But maybe this is something the chairs could be allowed to do.

-m

Le 2018-10-24 à 18:20, Andrew G. Malis a écrit :
> On Wed, Oct 24, 2018 at 11:31 AM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      > I assume you're referring
>     to draft-sarikaya-sfc-hostid-serviceheader. I
>      > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >      > Forgive the possibly naïve question, but can we change the
>     state
>      >     to "active" and add a date?
>      >      > Dates usually focus people.
>      >      >
>      >      >
>      >      > Internet Society | www.internetsociety.org
>      >      >
>      >      > Skype:  janercoffin
>      >      >
>      >      > Mobile/WhatsApp:  +1.202.247.8429
>      >      >
>      >      > On 10/24/18, 11:02 AM, "irsg on behalf of Joel Halpern
>     Direct"
>      >     <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>> on
>     behalf of
>      > [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >      >
>      >      >      I just had a problem with a working group member / author
>      >      >      misunderstanding the tools page.
>      >      >
>      >      >      The problem is that the "Working Group Documents:" active
>      >     drafts section
>      >      >      includes any drafts for which the working group has
>     issued a
>      >     call for
>      >      >      adoption.  Those are not (yet) working group documents.
>      >      >
>      >      >      In the particular case, I believe I have solved the
>     problem
>      >     by changing
>      >      >      the document state to a different state, which should
>     remove
>      >     it from
>      >      >      that list.  Still, it caused a lot of confusion.
>      >      >
>      >      >      As I related point, I could not find a good state to
>     change
>      >     it to.
>      >      >      Let's pretend that we had agreed that the authors
>     were going
>      >     to revise
>      >      >      it and then we were going to issue a new call for
>     adoption
>      >     (that is not
>      >      >      quite the case here, but good enough).  What state
>     should I
>      >     have changed
>      >      >      it to?
>      >      >
>      >      >      Thank you,
>      >      >      Joel
>      >      >
>      >      >
>      >      >
>      >
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 24 Oct 2018 15:01:50 -0400

Actually Martin, I think it is a bug.
Issuing the call for adoption does not make the document an active 
working group document.  Successfully completing the call for adoption does.
Thus, the tools page for the working group is confusing.

And this was brought up because I had a long discussion with a WG 
participant who was confused by the apparent state of his document.

Whether the bug is marking it to the IETF stream, or some other aspect 
of the datatracker, I leave in Henrik's skilled hands.

Yours,
Joel

---

From: "Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 24 Oct 2018 19:09:35 +0000

whether we call it a bug or something different is not so important.
But I think we are in-line regarding the behaviour, a Document should 
only enter the IETF stream once it's been adopted by a WG.
And I think the reason it appears in the Active list is because it is in 
the IETF stream.

-m

Le 2018-10-24 à 21:01, Joel M. Halpern a écrit :
>>>       > Joel,
>>>       > I assume you're referring
>>>       > think the problem may be that the WG state includes "Held by 
>>> WG".
>>>      Try
>>>       > turning that off and see if it moves back down to the 
>>> "Related I-Ds"
>>>       > section.
>>>       >
>>>       > Cheers,
>>>       > Andy
>>>       >
>>>       >
>>>       > On Wed, Oct 24, 2018 at 11:13 AM Joel Halpern Direct
>>>       > <[email-masked] <mailto:[email-masked]>
>>>       >     The issue is that the particular document is no an Active
>>>      Working Group
>>>       >     draft (which is the section name).  It is an active
>>>      individual draft
>>>       >     intended for the working group.  It failed WG adoption.  The
>>>      author was
>>>       >     reading the page as telling him that it was an Active 
>>> Working
>>>      Group
>>>       >     document.
>>>       >
>>>       >     Yours,
>>>       >     Joel
>>>       >
>>>       >     On 10/24/18 11:10 AM, Jane Coffin wrote:
>>>       >      > Forgive the possibly naïve question, but can we change 
>>> the
>>>      state
>>>       >     to "active" and add a date?
>>>       >      > Dates usually focus people.
>>>       >      >
>>>       >      >
>>>       >      > Internet Society | www.internetsociety.org
>>>       >     <http://www.internetsociety.org>
>>>       >      >
>>>       >      > Skype:  janercoffin
>>>       >      >
>>>       >      > Mobile/WhatsApp:  +1.202.247.8429
>>>       >      >
>>>       >      > On 10/24/18, 11:02 AM, "irsg on behalf of Joel Halpern
>>>      Direct"
>>>       >     <[email-masked] <mailto:[email-masked]>
>>>       > [email-masked] <mailto:[email-masked]>
>>>       >      >
>>>       >      >      I just had a problem with a working group member 
>>> / author
>>>       >      >      misunderstanding the tools page.
>>>       >      >
>>>       >      >      The problem is that the "Working Group 
>>> Documents:" active
>>>       >     drafts section
>>>       >      >      includes any drafts for which the working group has
>>>      issued a
>>>       >     call for
>>>       >      >      adoption.  Those are not (yet) working group 
>>> documents.
>>>       >      >
>>>       >      >      In the particular case, I believe I have solved the
>>>      problem
>>>       >     by changing
>>>       >      >      the document state to a different state, which 
>>> should
>>>      remove
>>>       >     it from
>>>       >      >      that list.  Still, it caused a lot of confusion.
>>>       >      >
>>>       >      >      As I related point, I could not find a good state to
>>>      change
>>>       >     it to.
>>>       >      >      Let's pretend that we had agreed that the authors
>>>      were going
>>>       >     to revise
>>>       >      >      it and then we were going to issue a new call for
>>>      adoption
>>>       >     (that is not
>>>       >      >      quite the case here, but good enough).  What state
>>>      should I
>>>       >     have changed
>>>       >      >      it to?
>>>       >      >
>>>       >      >      Thank you,
>>>       >      >      Joel
>>>       >      >
>>>       >      >
>>>       >      >
>>>       >
>>>
>