Subject: Archival integrity of virtual interim recordings?

From: John Scudder <[email-masked]>
Date: Mon, 29 Oct 2018 15:48:29 +0000

Hi All,

For in-person meetings the proceedings include audio recordings hosted on IETF infrastructure (well, at least they're behind an ietf.org URL). My assumption is that these are considered archival, they won't be subject to being arbitrarily moved, deleted, etc.

Is there any equivalent for virtual interims? WebEx makes it easy to record, and to share the recordings, but I have no idea what -- if any -- archival integrity the recordings have. I can grab my own local copy but that's not very consoling. I didn't find this mentioned in the published info on use of WebEx for virtual interims, nor do the past interim meeting materials have anything linked.

Thanks,

--John

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 29 Oct 2018 17:26:34 +0100

AFAIK all the archived videos are kept on youtube and meetecho
'just" orchestrates recording and uploading and redirecting.

I have already voiced concerns about the insufficiency of youtube as
an archival carrier for the whole community, for example because its
a single huge bucket that may not even want to comply with local
regulations around the planet, so IETF participants in china can not access it.

In the absence of better places/more automated tooling my recommendation
would be to have the WG-chairs to download the webex recordings, upload
to youtube.com and youku.com, and put those URLs on the WG wiki. 

Cheers
    Toerless

---

From: Russ Housley <[email-masked]>
Date: Mon, 29 Oct 2018 12:54:12 -0400

Toerless:

My understanding is that the Secretariat archives the files, but the youtube infrastructure is used for public playback.

Russ

> On Oct 29, 2018, at 12:26 PM, Toerless Eckert <[email-masked]> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 29 Oct 2018 18:16:40 +0100

Russ:

Thanks for the insight, that's great. My recommendation
for upload to more diverse public playback location is unaffected
by this, but it adds the point that WG chairs should also forward
webex recording files to the secretariat for the internal archive.

Request should actually just be webex recording URL, but
secretariat would need to also download it, because that URL will
not persist arbitrarily long.

Maybe a standard filename format for interrims like we seem to
have for meeting recordins would help so that if someone ever
wants to retrieve a file of an interrim from the secretariat 
(or look for one on some public location), it would be unambiguous.

Cheers
     Toerless

-- 
---
[email-masked]

---

From: John Scudder <[email-masked]>
Date: Mon, 29 Oct 2018 20:19:47 +0000

Thanks for the replies. I just dropped a note to the Secretariat with a summary of the thread and asked if they can help.

--John

> On Oct 29, 2018, at 1:16 PM, Toerless Eckert <[email-masked]> wrote:
> 
> Russ:
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 29 Oct 2018 16:55:43 -0400

FYI - when this was set up there was an agreement that the secretariat 
would maintain archival versions of the (audio and video) recordings.  
There was some confusion as to if these archival versions would be 
directly available to the community or not.  I believe they are *not* 
available at this time.  Alexa can confirm.

Lou

---

From: Alexa Morris <[email-masked]>
Date: Mon, 29 Oct 2018 15:06:19 -0700

The archival audio files are available at https://ietf.org/audio/ <https://ietf.org/audio/>. However the archival video files are not publicly available. AFAIR, the Tools Team determined that, while while it was imperative that the IETF archive all Meetecho meeting recordings for safe keeping, YouTube would be the most effective way to make the video recordings available to the world.

Alexa

> On Oct 29, 2018, at 1:55 PM, Lou Berger <[email-masked]> wrote:
> 
> FYI - when this was set up there was an agreement that the secretariat would maintain archival versions of the (audio and video) recordings.  There was some confusion as to if these archival versions would be directly available to the community or not.  I believe they are *not* available at this time.  Alexa can confirm.
> 
> Lou
> 
>

---

From: John Scudder <[email-masked]>
Date: Mon, 29 Oct 2018 22:15:58 +0000

To be clear, are you referring to archival audio files of interims conducted over WebEx? If so, it's not immediately obvious where those are on https://ietf.org/audio/<https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.org_audio_&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=HDsdO-hpjQg63Kr-W_xQnlRx0kwiFgYIdxBnSKThRgw&e=>.

I ask because that was the original topic of this thread. Of course it immediately meandered into adjacent topics, as these things do.

Thanks!

--John

P.S.: Also, I take it that on the subject of recordings of the main meetings, the video files ARE archived although the archived versions aren't publicly available.

On Oct 29, 2018, at 6:06 PM, Alexa Morris <[email-masked]<mailto:[email-masked]>> wrote:

The archival audio files are available at https://ietf.org/audio/<https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.org_audio_&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=HDsdO-hpjQg63Kr-W_xQnlRx0kwiFgYIdxBnSKThRgw&e=>. However the archival video files are not publicly available. AFAIR, the Tools Team determined that, while while it was imperative that the IETF archive all Meetecho meeting recordings for safe keeping, YouTube would be the most effective way to make the video recordings available to the world.

Alexa

On Oct 29, 2018, at 1:55 PM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:

Lou

--John

On Oct 29, 2018, at 1:16 PM, Toerless Eckert <[email-masked]<mailto:[email-masked]>> wrote:

Russ:

Cheers
    Toerless

Russ

On Oct 29, 2018, at 12:26 PM, Toerless Eckert <[email-masked]<mailto:[email-masked]>> wrote:

In the absence of better places/more automated tooling my recommendation
would be to have the WG-chairs to download the webex recordings, upload
to youtube.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__youtube.com&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=PprJyGmU3jgtuoywqmRgFvQ-blGTbDnXj5eTiycs7EA&e=> and youku.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__youku.com&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=wXDmCMgkKuPP6MtdtOpW9-Q4R1aVTaZYMiQ0BBmlHiQ&e=>, and put those URLs on the WG wiki.

Cheers
  Toerless

For in-person meetings the proceedings include audio recordings hosted on IETF infrastructure (well, at least they're behind an ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__ietf.org&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=qCyHtgjauGdL878gcrEmhRC1fYMb3TglbxBFC34FMr8&e=> URL). My assumption is that these are considered archival, they won't be subject to being arbitrarily moved, deleted, etc.

Thanks,

--John
--
---
[email-masked]<mailto:[email-masked]>

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 29 Oct 2018 23:17:30 +0100

Alexa: in case you hadn't seen my prior email: Given how youtube is
filtered in parts of the world, uploading to multiple public
streaming pages may be useful. I at least had to help
colleagues/partners in china to view youtube clips by
downloading and re-uploading to another site.

And according to youtube policies such downloading is not permitted,
so officially all uploads would have to come from another primary
source like the IETF archive you have internally.

No idea what the best side would be to reach the chinese IETF
community, but definitely the one with the biggest challenge.
http://www.youku.com/ ?

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 30 Oct 2018 08:49:54 -0400

Do we need to be concerned about this portion of John’s message?

> On Oct 29, 2018, at 12:54 PM, Russ Housley <[email-masked]> wrote:
> 
>>> nor do the past interim meeting materials have anything linked.

I’m talking of long past virtual meetings carried by webex, before meetecho.

—Sandy

---

From: Alexa Morris <[email-masked]>
Date: Tue, 30 Oct 2018 13:24:34 -0700

John,

Apologies, just catching up on the full thread now. Inline: 

> On Oct 29, 2018, at 3:15 PM, John Scudder <[email-masked]> wrote:
> 
> To be clear, are you referring to archival audio files of interims conducted over WebEx? If so, it's not immediately obvious where those are on https://ietf.org/audio/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.org_audio_&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=HDsdO-hpjQg63Kr-W_xQnlRx0kwiFgYIdxBnSKThRgw&e=>. 

We do not currently keep official archives of the interim meetings, though we could certainly download and store the .arf files on a hard drive. 

Unfortunately, AFAIK, making them publily available is trickier. Unless they are converted individually to mp4, all WebEx meeting recordings require the WebEX player. Unfortunately, converting the files to mp4 is a manual process and it requires a Windows-based application. Maybe there is a way to simply this, and we can certainly explore it if desired. 

> P.S.: Also, I take it that on the subject of recordings of the main meetings, the video files ARE archived although the archived versions aren't publicly available.

Yes, that is the case. 

-Alexa

> 
>> On Oct 29, 2018, at 6:06 PM, Alexa Morris <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> The archival audio files are available at https://ietf.org/audio/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.org_audio_&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=HDsdO-hpjQg63Kr-W_xQnlRx0kwiFgYIdxBnSKThRgw&e=>. However the archival video files are not publicly available. AFAIR, the Tools Team determined that, while while it was imperative that the IETF archive all Meetecho meeting recordings for safe keeping, YouTube would be the most effective way to make the video recordings available to the world.
>> 
>> Alexa
>> 
>>> On Oct 29, 2018, at 1:55 PM, Lou Berger <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>>> On Oct 29, 2018, at 1:16 PM, Toerless Eckert <[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> Russ:
>>>>> 
>>>>>>> On Oct 29, 2018, at 12:26 PM, Toerless Eckert <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>>> 
>>>>>>> to youtube.com <https://urldefense.proofpoint.com/v2/url?u=http-3A__youtube...com&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=PprJyGmU3jgtuoywqmRgFvQ-blGTbDnXj5eTiycs7EA&e=> and youku.com <https://urldefense.proofpoint.com/v2/url?u=http-3A__youku.com&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=wXDmCMgkKuPP6MtdtOpW9-Q4R1aVTaZYMiQ0BBmlHiQ&e=>, and put those URLs on the WG wiki.
>>>>>>> 
>>>>>>> Cheers
>>>>>>>   Toerless
>>>>>>> 
>>>>>>>> For in-person meetings the proceedings include audio recordings hosted on IETF infrastructure (well, at least they're behind an ietf.org <https://urldefense.proofpoint.com/v2/url?u=http-3A__ietf.org&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=fGM-oNYRJVFZi09wgzcept5zq3MsZYVurxmCT7SOE7U&s=qCyHtgjauGdL878gcrEmhRC1fYMb3TglbxBFC34FMr8&e=> URL). My assumption is that these are considered archival, they won't be subject to being arbitrarily moved, deleted, etc.
>>>>>>>> 
>>>>> [email-masked] <mailto:[email-masked]>
>>>> 
>>> 
>> 
>

---

From: Alexa Morris <[email-masked]>
Date: Tue, 30 Oct 2018 13:26:57 -0700

Toerless,

Thanks for this. I will bring it up with the Tools Team for further discussion. 

Alexa

> On Oct 29, 2018, at 3:17 PM, Toerless Eckert <[email-masked]> wrote:
> 
> http://www.youku.com/ <http://www.youku.com/> ?
> 
> Cheers
>    Toerless
> 
>> The archival audio files are available at https://ietf.org/audio/ <https://ietf.org/audio/> <https://ietf.org/audio/ <https://ietf.org/audio/>>. However the archival video files are not publicly available. AFAIR, the Tools Team determined that, while while it was imperative that the IETF archive all Meetecho meeting recordings for safe keeping, YouTube would be the most effective way to make the video recordings available to the world.
>> 
>> Alexa
>>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 30 Oct 2018 21:35:38 +0100

Thanks Alexa

Maybe to rephrase, because i think i was too much proposing one solution
and not staing the core issue as broadly as possible::

Even before thinking about how the IETF itself could make its video content
available on more download platforms itself, there should be solution
how other people could legally download IETF content to upload it on
other platforms, and that download part is not permitted by youtube,
making it a problematic primary platform.

This is all assuming that we as the IETF would be happy if IETF media
content was made available by others as much as possible and do not put
restrictions ourselves on doing so.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 30 Oct 2018 18:11:45 -0400

Do you believe that the webex recording of all past meetings are still available?

—Sandy

> On Oct 30, 2018, at 4:24 PM, Alexa Morris <[email-masked]> wrote:
>

---

From: John Scudder <[email-masked]>
Date: Tue, 30 Oct 2018 22:14:28 +0000

Thanks, Alexa.

On Oct 30, 2018, at 4:24 PM, Alexa Morris <[email-masked]<mailto:[email-masked]>> wrote:

That seems like a good minimum step to protect against losing the history, although as you point out the .arf format itself could be problematic in the long (and maybe not-even-that-long) run.

It seems to me that insofar as

- Virtual meetings are IETF meetings, and
- The IETF wants to preserve IETF meeting recordings for posterity, and disseminate them for transparency,

that this would be worth doing. Of course, I understand that everything takes time and resources. :-/

--John