Subject: WG Milestones and Dates

From: Adam Roach <[email-masked]>
Date: Thu, 25 Oct 2018 19:27:28 -0500

Chairs --

I've asked the EDU folks for some time during the Working Group Chair 
Lunch in Bangkok to have a conversation around the utility of having 
dates associated with the milestones that appear in working group charters.

In the spirit of having discussions on the list, I wanted to solicit 
people's thoughts on the issue ahead of time. Some questions to prompt 
discussion, and associated thoughts (some mine, some received from other 
people) to go with those questions:

  * What value do the dates serve?
      o Other SDOs may look towards the dates as estimates about when to
        expect output
      o For those documents of interest to governmental agencies (of
        various countries), they may serve the same purpose
      o In some working groups, they are used by area directors to
        actively manage work and to drive progress. There are some
        success stories in using the dates in this way.
  * What harm comes from out-of-date and/or inaccurate milestones?
      o In the cases cited above regarding external entities,
        out-of-date and inaccurate milestones may cause issues for those
        parties and/or reflect poorly on the IETF as an organization.
  * What steps could we take to improve milestone accuracy?
      o One option could be more aggressively using milestones as a
        driving function, to prompt author action, WGLCs, and interim
        meetings.
      o Another option might be frequent review of milestones by chairs
        and ADs, and revising dates when they appear to be at-risk.
  * What drawbacks might arise from removing dates entirely?
      o To the extent that the current use of dates provides pressure
        for working groups to complete tasks within a reasonable
        timeframe, removing them will remove that pressure, potentially
        leading to a slower pace of work.
      o For considerations regarding external parties, we need to
        consider whether having no dates on milestones looks better or
        worse than having inaccurate dates on milestones.
  * Would replacing dates with a simple priority order be an improvement?
      o In theory, this could be done on a WG-by-WG basis.

I mean this to be a pretty open-ended exploration of the topic, so feel 
free to throw in your own questions and thoughts.

Thanks! I look forward to seeing y'all in Bangkok.

/a

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Oct 2018 03:18:25 +0000

One option is coarser granularity, like half-year.

From: Adam Roach <[email-masked]>
Date: Thursday, October 25, 2018 at 8:27 PM
To: 'WG Chairs' <[email-masked]>
Subject: WG Milestones and Dates

Chairs --

I've asked the EDU folks for some time during the Working Group Chair Lunch in Bangkok to have a conversation around the utility of having dates associated with the milestones that appear in working group charters.

In the spirit of having discussions on the list, I wanted to solicit people's thoughts on the issue ahead of time. Some questions to prompt discussion, and associated thoughts (some mine, some received from other people) to go with those questions:

  *   What value do the dates serve?
     *   Other SDOs may look towards the dates as estimates about when to expect output
     *   For those documents of interest to governmental agencies (of various countries), they may serve the same purpose
     *   In some working groups, they are used by area directors to actively manage work and to drive progress. There are some success stories in using the dates in this way.
  *   What harm comes from out-of-date and/or inaccurate milestones?
     *   In the cases cited above regarding external entities, out-of-date and inaccurate milestones may cause issues for those parties and/or reflect poorly on the IETF as an organization.
  *   What steps could we take to improve milestone accuracy?
     *   One option could be more aggressively using milestones as a driving function, to prompt author action, WGLCs, and interim meetings.
     *   Another option might be frequent review of milestones by chairs and ADs, and revising dates when they appear to be at-risk.
  *   What drawbacks might arise from removing dates entirely?
     *   To the extent that the current use of dates provides pressure for working groups to complete tasks within a reasonable timeframe, removing them will remove that pressure, potentially leading to a slower pace of work.
     *   For considerations regarding external parties, we need to consider whether having no dates on milestones looks better or worse than having inaccurate dates on milestones.
  *   Would replacing dates with a simple priority order be an improvement?
     *   In theory, this could be done on a WG-by-WG basis.

I mean this to be a pretty open-ended exploration of the topic, so feel free to throw in your own questions and thoughts.

/a

---

From: Melinda Shore <[email-masked]>
Date: Thu, 25 Oct 2018 19:32:59 -0800

> free to throw in your own questions and thoughts.

"I like deadlines.  I love the whooshing sound they make as they
go flying by."

I'm less concerned about reputational damage, per se, and more
concerned about other organizations making plans or commitments
based on milestone dates and then those dates not being met.

I do think that as long as it's possible for people to blow up
a document after it's been through wglc it's going to be extremely
difficult to manage dates for deliverables reliably.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 26 Oct 2018 07:40:31 +0100

A discussion would be good. Possibly an AD could communicate how the current IESG views milestone dates and what they expect from chairs.
 
I always understood the milestones to serve three purposes
 
1. A list of deliverables from the WG (other things may be delivered, but these are the things that the chairs are committed to strive to deliver)
 
2. A tool for the chairs to use to manage the WG (and so how they are used is up to the chair)
 
3. A mechanism for communication between the chairs and the AD (so the AD can see what the plans are)
 
Since the chairs can change the milestone dates at will, they clearly have no binding effect. A long-overdue date means either:
- the chairs want to show that the work has taken longer than planned
or
- the chairs don't care to / don't know how to update the dates.
 
Best,
Adrian
 
"Milestones, not millstones"
 
From: WGChairs [mailto:[email-masked]] On Behalf Of Adam Roach
Sent: 26 October 2018 01:27
To: IETF WG Chairs
Subject: WG Milestones and Dates
 
Chairs --

---

From: Eliot Lear <[email-masked]>
Date: Fri, 26 Oct 2018 10:11:36 +0200

Largely agree with Adrian.  I wonder if milestones need to be augmented
with activity graphs (both emails and draft updates).

Eliot

On 26.10.18 08:40, Adrian Farrel wrote:
>
> A discussion would be good. Possibly an AD could communicate how the
> current IESG views milestone dates and what they expect from chairs.
>
>  
>
> 1. A list of deliverables from the WG (other things may be delivered,
> but these are the things that the chairs are committed to strive to
> deliver)
>
>  
>
> Since the chairs can change the milestone dates at will, they clearly
> have no binding effect. A long-overdue date means either:
>
> *From:*WGChairs [mailto:[email-masked]] *On Behalf Of *Adam
> Roach
> *Sent:* 26 October 2018 01:27
> *To:* IETF WG Chairs
> *Subject:* WG Milestones and Dates
>
>  
>
> Chairs --
>
> discussion, and associated thoughts (some mine, some received from
> other people) to go with those questions:
>
>       o Other SDOs may look towards the dates as estimates about when
>         to expect output
>         out-of-date and inaccurate milestones may cause issues for
>         those parties and/or reflect poorly on the IETF as an
>         organization.
>
>       o Another option might be frequent review of milestones by
>         chairs and ADs, and revising dates when they appear to be at-risk.
>
>         timeframe, removing them will remove that pressure,
>         potentially leading to a slower pace of work.
> I mean this to be a pretty open-ended exploration of the topic, so
> feel free to throw in your own questions and thoughts.
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 26 Oct 2018 10:14:18 +0200

Thanks for your thoughts. I personally don’t attach a lot of weight to, or think much about, the dates. I take my best guess and move on. Reason: I haven’t observed discussions ending or consensus being reached on s specific date, and consider consensus far more important than any burocracy we might add to it.

Sent using a machine that autocorrects in interesting ways...

> On Oct 26, 2018, at 2:27 AM, Adam Roach <[email-masked]> wrote:
> 
> Chairs --
> What value do the dates serve?
> Other SDOs may look towards the dates as estimates about when to expect output
> For those documents of interest to governmental agencies (of various countries), they may serve the same purpose
> In some working groups, they are used by area directors to actively manage work and to drive progress. There are some success stories in using the dates in this way.
> What harm comes from out-of-date and/or inaccurate milestones?
> In the cases cited above regarding external entities, out-of-date and inaccurate milestones may cause issues for those parties and/or reflect poorly on the IETF as an organization.
> What steps could we take to improve milestone accuracy?
> One option could be more aggressively using milestones as a driving function, to prompt author action, WGLCs, and interim meetings.
> Another option might be frequent review of milestones by chairs and ADs, and revising dates when they appear to be at-risk.
> What drawbacks might arise from removing dates entirely?
> To the extent that the current use of dates provides pressure for working groups to complete tasks within a reasonable timeframe, removing them will remove that pressure, potentially leading to a slower pace of work.
> For considerations regarding external parties, we need to consider whether having no dates on milestones looks better or worse than having inaccurate dates on milestones.
> Would replacing dates with a simple priority order be an improvement?
> In theory, this could be done on a WG-by-WG basis.

---

From: Robert Sparks <[email-masked]>
Date: Fri, 26 Oct 2018 09:24:23 -0500

On 10/26/18 3:14 AM, Fred Baker wrote:
> Thanks for your thoughts. I personally don’t attach a lot of weight 
> to, or think much about, the dates. I take my best guess and move on. 
> Reason: I haven’t observed discussions ending or consensus being 
> reached on s specific date, and consider consensus far more important 
> than any burocracy we might add to it.
>
> On Oct 26, 2018, at 2:27 AM, Adam Roach <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Chairs --
>>
>> people's thoughts on the issue ahead of time. Some questions to 
>> prompt discussion, and associated thoughts (some mine, some received 
>> from other people) to go with those questions:
>>
I think for any group that was successfully using the dates as a 
management tool, you wouldn't need to do this. For a group where the 
dates are not helpful, this would be quite useless makework.

>>         potentially leading to a slower pace of work.
Not my experience. Groups and authors are far more motivated to make 
progress by -00 deadlines than they are a milestone date. For many 
groups I've been involved in, the dates have been completely ignored.
>>         consider whether having no dates on milestones looks better
>>         or worse than having inaccurate dates on milestones.
Why did you predicate that with "In theory"?
>>      o

---

From: Michael Richardson <[email-masked]>
Date: Fri, 26 Oct 2018 14:29:43 -0400

> One option is coarser granularity, like half-year.

+1.
or IETFmtg#.
But, we still need ability to give a partial-order milestones.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Adam Roach <[email-masked]>
Date: Fri, 26 Oct 2018 15:19:02 -0500

> Why did you predicate that with "In theory"?

Because we'd need to work through and get consensus on the specifics. 
You're probably thinking of it from a tooling perspective, which would 
be easy. We'd also have to figure out process and policy for the 
question of who owns the decision [1] about which style is used for a WG 
and when it can change. I don't mean to imply it's intractable, but the 
conversation could certainly land in a place where the community didn't 
want to pursue this or couldn't agree on how to implement it, so it's 
also not a foregone conclusion that this group of people could 
unilaterally make it happen.

/a

____
[1] And I mean this term in a way that's consistent with the rest of 
working group handling. For example, even though they're all ultimate a 
reflection of consensus of the relevant communities, charter contents 
are approved by the IESG en bloc; milestones are approved by the 
responsible AD; and milestone dates are approved by the WG chairs. These 
people are functionally the decision owners, even though those decisions 
frequently have more to do with judging consensus than personal judgement.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 29 Oct 2018 10:26:39 -0500

Hi, Michael,

>     > One option is coarser granularity, like half-year.

This seems like an obvious alternative, and to be blunt, when I was
chairing working groups, that's what I was lining milestone dates up on
anyway (so, "March 2019" on my charter would translate into IETF 104 pretty
directly), but I haven't seen it made in previous iterations of discussions
about this topic.

Thanks for making it.

Spencer