Subject: Archiving the expired work (was Re: IETF103 Plenary discussion on WG meeting conduct)

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 10 Jan 2019 17:53:06 +0000

Toerless,

There is indeed no rsync'able archive of all expired drafts which makes search a little more complex.

AFAIK, rsync is only available for active draft and of course for RFC

-éric

On 10/01/2019, 16:46, "Toerless Eckert" <[email-masked]> wrote:

    I think its a common issue that newcomers to WGs with an otherwise
    long term membership always have a hard time to catch up with the
    context and avoid the problem Stewart is referring to.
    
    One of standard problems for newcomers to catch up is IMHO that the
    IETF is very lame to capture the conclusions for old work that did
    not proceed to RFC. I have at times tried to dig down on stuff i had
    interest in and would have really liked to see if authors/WG-chairs
    would send off expiring work into the eternal draft archive with one
    final update including such a status summary. So one know whether
    the idea just didn't see enough interest in a group, was debunked,
    etc. pp. I know this is somewhat hard, but IMHO worthwhile.
    
    Cheers
        Toerless
    
    On Thu, Jan 10, 2019 at 12:21:57PM +0000, Acee Lindem (acee) wrote:
    > +1 with Stewart. At least in the Routing Area WGs in which I participate, I believe we go out our way to give new work fair consideration.
    > Thanks,
    > Acee
    > 
    > From: WGChairs <[email-masked]> on behalf of Stewart Bryant <[email-masked]>
    > Date: Thursday, January 10, 2019 at 7:15 AM
    > To: Kent Watsen <[email-masked]>, "Eric Vyncke (evyncke)" <[email-masked]>, Mary Barnes <[email-masked]>, Deborah Brungard <[email-masked]>
    > Cc: "[email-masked]" <[email-masked]>
    > Subject: Re: IETF103 Plenary discussion on WG meeting conduct
    > 
    > 
    > Our culture is an asset, so we need to change it carefully and wisely, being wary of the inevitable unintended consequences of change.
    > 
    > I was in the plenary and could not figure out what actually happened, other that it appeared that someone was trying to re-introduce an old, previously discredited idea which was rebuffed.
    > 
    > If someone is re-inventing/introducing old work (which is I think that this was about) then it is as well for us all to remember that all work needs to live in its own time, but that the onus is on the *proposer* to understand the history of the concept and pre-empt historical concerns up front.
    > 
    > Whatever happens here we also need to remember that one case makes very poor law.
    > 
    > - Stewart
    > On 09/01/2019 19:37, Kent Watsen wrote:
    > I disagree that that this can???t be changed and, to the extent we agree that there is a problem, we should try.
    > 
    > Actually, if each of us to agree to put a single (IETF-provided?) slide in our meeting kickoff decks on e.g., courtesy, and spend 1-minute on it (i.e., ???the chairs have been asked to relay this message...???), it would hammer the point home by the end of the week.   This may be preceded by an email from IETF Chair, but I wouldn???t view that as a substitute for an in-room slide.  I would do this for one meeting only or, at least, until needed again.
    > 
    > It???s nice/good to have the bullet in the Note Well (and the aforementioned slide could refer to it) but, honestly, I???ve never noticed it before.  The Note Well slide???s font is too small to read in the meeting, and the chairs just say ???note well the Note Well??? and/or something to the effect that anything said is considered a contribution.  Yes, I know, as a Chair putting together the slides, I have a rather readable version in-front of me every four months, but after years of small-font and pithy-intros, I became desensitized to it long ago and now it somewhat just glosses over my eyes.
    > 
    > Kent
    > 
    > 
    > On 1/8/19, 8:31 AM, "WGChairs on behalf of Eric Vyncke (evyncke)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:
    > 
    > Mary
    > 
    > Very sensible email about the situation and the causes.
    > 
    > And, I am sure that we agree that we could aim for a better: leadership should example
    > 
    > -éric
    > 
    > From: WGChairs <[email-masked]><mailto:[email-masked]> on behalf of Mary Barnes <[email-masked]><mailto:[email-masked]>
    > Date: Monday, 7 January 2019 at 23:05
    > To: "BRUNGARD, DEBORAH A" <[email-masked]><mailto:[email-masked]>
    > Cc: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
    > Subject: Re: IETF103 Plenary discussion on WG meeting conduct
    > 
    > I had a hard time taking away too much from that despite the level of detail since there wasn't a clear example of the infarction in my opinion.  Clearly, we know people (including ADs, WG chairs, regular participants and even sometimes new ones) often don't communicate well nor nicely.   I go to the newcomer events and warn anyone that tells me they'll be presenting that they will encounter hostility.  That's not a good thing, but that's our community and culture in my experience and it's quite often reenforced based upon leadership choices.  I've had what I consider some of the rudest interactions with some ADs and everyday you can find examples of email discussions that could have been worded much differently.  And, it's possible that the fact that we only meet 3 times per year (rather than monthly or every 6 weeks) with the majority of interactions happening via email contributes to the situation.  It's very easy to misinterpret things in email and our very, very short sessions don't allow much back and forth for clarifying questions and really effective dialog.
    > 
    > Personally, I don't think given even these factors that a huge cultural shift is possible. And, I also think that we are a tougher crowd than average when it comes to getting folks to interact "nicely".   But, I think leadership can better handle situations as they occur by talking to the perceived offending parties after the meetings OR during a meeting if things are getting too tense.  That has happened and it does work.  I would also suggest that newcomers (or really anyone) be encouraged to bring the situations forward during the week and then maybe someone can set up a few minutes for them to have a side discussion with the person with whom they encountered an apparent issue.  A lot of us are a lot nicer one on one than in the large group interactions.  And, cross talk, even amongst those that know one another well also happens.  In general, many are not very good at listening to understand, but rather listen with the intent to respond (based on sometimes false assumptions).    If things are really bad, then I think that should go through ombuds team.   I don't think we need HR folks in meetings and I really don't think any sort of training would help much (if my mother were still alive, she could recount her many attempts at trying to improve my social graces - she gave up when I was about 10).    One only has to compare our group during refreshment breaks to that of other conferences to see a significant difference when it comes to the most basic practice of etiquette.  We'd need to start with the 101 class from the Emily Post Institute.
    > 
    > Regards,
    > Mary.
    > 
    > 
    > 
    > On Fri, Jan 4, 2019 at 4:42 PM BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>> wrote:
    > Hi,
    > 
    > I am not aware myself though maybe private discussions-
    > 
    > The minutes of the Plenary were just posted, it has a very good transcript of the open mike session-
    > https://datatracker.ietf.org/meeting/103/materials/minutes-103-ietf-201811071730-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_103_materials_minutes-2D103-2Dietf-2D201811071730-2D00&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=GPn3zW7m3vZOi8maKmMLkVWGqpPwUZDPkaSCuvzlHUE&s=_P8BBnWRGktpRThGeyCtEUAT_08Gz1qBK2oDqgVvDdc&e=>
    > 
    > Happy New Year everyone -
    > Deborah
    > 
    > 
    > -----Original Message-----
    > From: S Moonesamy <[email-masked]<mailto:[email-masked]>>
    > Sent: Friday, December 14, 2018 4:58 PM
    > To: BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
    > Subject: Re: IETF103 Plenary discussion on WG meeting conduct
    > 
    > Hi Deborah,
    > At 10:23 AM 13-12-2018, BRUNGARD, DEBORAH A wrote:
    > >At Bangkok's plenary meeting, during the IESG mike session, we had a
    > >couple of people commenting on their experience at working group
    > >meetings. Some people felt that they were treated inappropriately, that
    > >they were personally criticized vs. technically, or were simply told
    > >their idea was discussed before vs. a short summary so as to understand
    > >why it was rejected.
    > 
    > Did anyone talk with the persons to find out what happened?
    > 
    > Regards,
    > S. Moonesamy
    
    -- 
    ---
    [email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 10 Jan 2019 19:31:39 +0100

Huh. How did you transition from my text to rsync
(not that wouldn't be a nice thing) ;-)

I was merely referring to the most easy way we can figure out to attach
some status information to a draft after it has expired. Without any new
tooling for example, a WG chair or author could just upload another
revision with such a new status section, we would just need to come
up with some useful guidance what could/should be in it.

Or else some other place where such a status is created, but i prefer
in the document.

rsync for all old ID's would be nice, yes.

You can at least search them by googling something like
  site:https://tools.ietf.org/id <search terms>

(although i am not 100% sure if google has a full index of docs under
 that directory because i don't know where the index would be, but it
 could be that google simply uses the list of all IDs where the tools/id
 URL is referenced).

Cheers
    Toerless

On Thu, Jan 10, 2019 at 05:53:06PM +0000, Eric Vyncke (evyncke) wrote:
> ???On 10/01/2019, 16:46, "Toerless Eckert" <[email-masked]> wrote:
> 

-- 
---
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Thu, 10 Jan 2019 12:31:55 -0600

The id-archive is available via rsync at rfc.ietf.org::id-archive and 
contains all drafts, expired or not.

(The repository of currently active drafts is at 
rfc.ietf.org::internet-drafts.)

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 10 Jan 2019 19:34:16 +0100

Hah, great!

thanks
    Toerless

-- 
---
[email-masked]

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 10 Jan 2019 17:01:17 -0600

> up with some useful guidance what could/should be in it.

I'd settle for useful guidance for what to CALL that section. If everyone
knows that a draft didn't reach working group consensus, or IETF consensus,
looking for a section called "why this draft is no longer active" would go
a long way toward cluing people in.

Actual contents would be even better, of course ...

Spencer

> >     > +1 with Stewart. At least in the Routing Area WGs in which I
> participate, I believe we go out our way to give new work fair
> consideration.
> >     > Thanks,
> >     > Acee
> >     >
> >     > To: Kent Watsen <[email-masked]>, "Eric Vyncke (evyncke)" <
> [email-masked]>, Mary Barnes <[email-masked]>, Deborah
> Brungard <[email-masked]>
> >     > Our culture is an asset, so we need to change it carefully and
> wisely, being wary of the inevitable unintended consequences of change.
> >     >
> >     > I was in the plenary and could not figure out what actually
> happened, other that it appeared that someone was trying to re-introduce an
> old, previously discredited idea which was rebuffed.
> >     >
> >     > If someone is re-inventing/introducing old work (which is I think
> that this was about) then it is as well for us all to remember that all
> work needs to live in its own time, but that the onus is on the *proposer*
> to understand the history of the concept and pre-empt historical concerns
> up front.
> >     >
> >     > I disagree that that this can???t be changed and, to the extent we
> agree that there is a problem, we should try.
> >     >
> >     > Actually, if each of us to agree to put a single (IETF-provided?)
> slide in our meeting kickoff decks on e.g., courtesy, and spend 1-minute on
> it (i.e., ???the chairs have been asked to relay this message...???), it
> would hammer the point home by the end of the week.   This may be preceded
> by an email from IETF Chair, but I wouldn???t view that as a substitute for
> an in-room slide.  I would do this for one meeting only or, at least, until
> needed again.
> >     >
> >     > It???s nice/good to have the bullet in the Note Well (and the
> aforementioned slide could refer to it) but, honestly, I???ve never noticed
> it before.  The Note Well slide???s font is too small to read in the
> meeting, and the chairs just say ???note well the Note Well??? and/or
> something to the effect that anything said is considered a contribution.
> Yes, I know, as a Chair putting together the slides, I have a rather
> readable version in-front of me every four months, but after years of
> small-font and pithy-intros, I became desensitized to it long ago and now
> it somewhat just glosses over my eyes.
> >     >
> >     > Kent
> >     >
> >     >
> >     > On 1/8/19, 8:31 AM, "WGChairs on behalf of Eric Vyncke (evyncke)" <
> [email-masked]<mailto:[email-masked]> on behalf of
> [email-masked]<mailto:[email-masked]>> wrote:
> >     >
> >     > Mary
> >     >
> >     > From: WGChairs <[email-masked]><mailto:
> [email-masked]> on behalf of Mary Barnes <
> [email-masked]><mailto:[email-masked]>
> >     > Cc: "[email-masked]"<mailto:[email-masked]> <
> [email-masked]><mailto:[email-masked]>
> >     > I had a hard time taking away too much from that despite the level
> of detail since there wasn't a clear example of the infarction in my
> opinion.  Clearly, we know people (including ADs, WG chairs, regular
> participants and even sometimes new ones) often don't communicate well nor
> nicely.   I go to the newcomer events and warn anyone that tells me they'll
> be presenting that they will encounter hostility.  That's not a good thing,
> but that's our community and culture in my experience and it's quite often
> reenforced based upon leadership choices.  I've had what I consider some of
> the rudest interactions with some ADs and everyday you can find examples of
> email discussions that could have been worded much differently.  And, it's
> possible that the fact that we only meet 3 times per year (rather than
> monthly or every 6 weeks) with the majority of interactions happening via
> email contributes to the situation.  It's very easy to misinterpret things
> in email and our very, very short sessions don't allow much back and forth
> for clarifying questions and really effective dialog.
> >     >
> >     > Personally, I don't think given even these factors that a huge
> cultural shift is possible. And, I also think that we are a tougher crowd
> than average when it comes to getting folks to interact "nicely".   But, I
> think leadership can better handle situations as they occur by talking to
> the perceived offending parties after the meetings OR during a meeting if
> things are getting too tense.  That has happened and it does work.  I would
> also suggest that newcomers (or really anyone) be encouraged to bring the
> situations forward during the week and then maybe someone can set up a few
> minutes for them to have a side discussion with the person with whom they
> encountered an apparent issue.  A lot of us are a lot nicer one on one than
> in the large group interactions.  And, cross talk, even amongst those that
> know one another well also happens.  In general, many are not very good at
> listening to understand, but rather listen with the intent to respond
> (based on sometimes false assumptions).    If things are really bad, then I
> think that should go through ombuds team.   I don't think we need HR folks
> in meetings and I really don't think any sort of training would help much
> (if my mother were still alive, she could recount her many attempts at
> trying to improve my social graces - she gave up when I was about 10).
> One only has to compare our group during refreshment breaks to that of
> other conferences to see a significant difference when it comes to the most
> basic practice of etiquette.  We'd need to start with the 101 class from
> the Emily Post Institute.
> >     >
> >     > Regards,
> >     > Mary.
> >     >
> >     >
> >     >
> https://datatracker.ietf.org/meeting/103/materials/minutes-103-ietf-201811071730-00
> <
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_103_materials_minutes-2D103-2Dietf-2D201811071730-2D00&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=GPn3zW7m3vZOi8maKmMLkVWGqpPwUZDPkaSCuvzlHUE&s=_P8BBnWRGktpRThGeyCtEUAT_08Gz1qBK2oDqgVvDdc&e=
> >
> >     >
> >     > To: BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>

---

From: Warren Kumari <[email-masked]>
Date: Thu, 10 Jan 2019 18:52:49 -0500

> a long way toward cluing people in.
I propose we call the section "Why this draft is no longer active". :-)

W

>> >     > I disagree that that this can???t be changed and, to the extent
>> we agree that there is a problem, we should try.
>> >     >
>> >     > On 1/8/19, 8:31 AM, "WGChairs on behalf of Eric Vyncke (evyncke)"
>> <[email-masked]<mailto:[email-masked]> on behalf
>> of [email-masked]<mailto:[email-masked]>> wrote:
>> >     >
>> >     > Mary
>> >     >
>> >     > I had a hard time taking away too much from that despite the
>> level of detail since there wasn't a clear example of the infarction in my
>> >     > On Fri, Jan 4, 2019 at 4:42 PM BRUNGARD, DEBORAH A <
>> [email-masked]<mailto:[email-masked]>> wrote:
>> >     > Hi,
>> >     >

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 11 Jan 2019 00:59:54 +0100

On Jan 11, 2019, at 00:01, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> why this draft is no longer active

The only value of this variable can be “submitter lost interest”, or they would have sent a new version in time.

Now, *why* the submitter lost interest is a different question, and is probably highly subjective.  I know that at least for some of my drafts the answer should be “X was stupid”, where X may be a WG, a WG chair, an AD…  But of course I would never say it that way.  For others, the answer would be “bad idea, I was shown the light”, or “overtaken by events” (such as “somebody else had a better idea”).   Maybe it would be useful for submitters to be able to bury their I-Ds with such a mark, but I’m not sure it would be used much.  (The one mark we do have, “replaced by”, is extremely useful, but still doesn’t say why — “became” vs. “went as one of the parts into” vs. “was superseded/obsoleted by”.)

Grüße, Carsten

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 11 Jan 2019 09:10:48 +0000

FWIW, I also like the idea of encouraging optional publication
of a tombstone version of a draft that sets out the authors'
view as to why this version is seen as the end of the road.

Authors can do that today if they want. WG chairs can encourage
it to be done where they think it'd be useful.

Having a convention for the name of the section would be good
to help find such drafts.

On 10/01/2019 23:59, Carsten Bormann wrote:
> The only value of this variable can be “submitter lost interest”, or
> they would have sent a new version in time.
> 
> Now, *why* the submitter lost interest is a different question, and
> is probably highly subjective.  I know that at least for some of my
> drafts the answer should be “X was stupid”, where X may be a WG, a WG
> chair, an AD…  

True. But people can write anything in any draft but generally
avoid such language. Even if every dead draft ended up with a
tombstone, I'd say there'd be few containing such statements.

> But of course I would never say it that way.  For
> others, the answer would be “bad idea, I was shown the light”, or
> “overtaken by events” (such as “somebody else had a better idea”).
> Maybe it would be useful for submitters to be able to bury their I-Ds
> with such a mark, but I’m not sure it would be used much.  (The one
> mark we do have, “replaced by”, is extremely useful, but still
> doesn’t say why — “became” vs. “went as one of the parts into” vs.
> “was superseded/obsoleted by”.)

I'd suggest we don't try formalise it into the datatracker. As
you say there are too many possible cases. If ADs and WG chairs
encourage such tombstone drafts, and if authors publish some,
then someone could summarise what they say in a few months or a
year or so and we could go from there.

Cheers,
S.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 11 Jan 2019 11:15:57 -0500

Stephen Farrell <[email-masked]> wrote:
    > FWIW, I also like the idea of encouraging optional publication of a
    > tombstone version of a draft that sets out the authors' view as to why
    > this version is seen as the end of the road.

That's an interesting idea, and I think there is merit to discussing it.
Would this be generated by the DT, or would this be something the authors
would explicitely do by uploading a last revision?

    > Authors can do that today if they want. WG chairs can encourage it to
    > be done where they think it'd be useful.

    > Having a convention for the name of the section would be good to help
    > find such drafts.

So, it's a new section in the existing draft, not a replacement of the draft.
I think the DT does not to put the draft into a specific identifiable state,
and we (the IETF/the WG) need to be able to add this new section even though
the authors have lost interest, maybe never to return.

    >> Now, *why* the submitter lost interest is a different question, and is
    >> probably highly subjective.  I know that at least for some of my

    > True. But people can write anything in any draft but generally avoid
    > such language. Even if every dead draft ended up with a tombstone, I'd
    > say there'd be few containing such statements.

    >> But of course I would never say it that way.  For others, the answer
    >> would be “bad idea, I was shown the light”, or “overtaken by events”
    >> (such as “somebody else had a better idea”).  Maybe it would be useful
    >> for submitters to be able to bury their I-Ds with such a mark, but I’m
    >> not sure it would be used much.  (The one mark we do have, “replaced
    >> by”, is extremely useful, but still doesn’t say why — “became”
    >> vs. “went as one of the parts into” vs.  “was superseded/obsoleted
    >> by”.)

    > I'd suggest we don't try formalise it into the datatracker. As you say
    > there are too many possible cases. If ADs and WG chairs encourage such
    > tombstone drafts, and if authors publish some, then someone could
    > summarise what they say in a few months or a year or so and we could go
    > from there.

    > Cheers, S.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 11 Jan 2019 10:23:32 -0600

> the authors have lost interest, maybe never to return.

The WG chairs are supposed to be able to approve posting of new revs of WG
documents (though my experience with this datatracker workflow has been
mixed).  For individual drafts it's less clear that we have a mandate to do
so, anyway.

-Ben

---

From: Michael Richardson <[email-masked]>
Date: Fri, 11 Jan 2019 11:41:23 -0500

Benjamin Kaduk <[email-masked]> wrote:
    >> Stephen Farrell <[email-masked]> wrote: > FWIW, I also like
    >> the idea of encouraging optional publication of a > tombstone version
    >> of a draft that sets out the authors' view as to why > this version is
    >> seen as the end of the road.
    >>
    >> That's an interesting idea, and I think there is merit to discussing
    >> it.  Would this be generated by the DT, or would this be something the
    >> authors would explicitely do by uploading a last revision?
    >>
    >> > Authors can do that today if they want. WG chairs can encourage it
    >> to > be done where they think it'd be useful.
    >>
    >> > Having a convention for the name of the section would be good to
    >> help > find such drafts.

    >> So, it's a new section in the existing draft, not a replacement of the
    >> draft.  I think the DT does not to put the draft into a specific
    >> identifiable state, and we (the IETF/the WG) need to be able to add

argh. "I THINK THE DT DOES NEED TO PUT THE DRAFT INTO A SPECIFIC STATE"

    >> this new section even though the authors have lost interest, maybe
    >> never to return.

    > The WG chairs are supposed to be able to approve posting of new revs of
    > WG documents (though my experience with this datatracker workflow has
    > been mixed).  For individual drafts it's less clear that we have a
    > mandate to do so, anyway.

That's a very good point.
So I was thinking the WG needs to Not-Adopt the draft :-)

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 11 Jan 2019 19:15:37 +0000

Hiya,

On 11/01/2019 16:15, Michael Richardson wrote:
> authors would explicitly do by uploading a last revision?

The latter:

Here's an example of what I mean:

"
2. Why this draft is no longer active

This draft was proposed for adoption by the foo WG, but
after discussion [1] there was no consensus to adopt it
as a WG item. The authors agree that's reasonable, in
particular given the argument at [2]. We don't expect
this idea to be revived in the near future.
"

[1] could be a pointer to the WG archive thread
[2] the mail where someone sensible nicely explains why it's a
    bad plan:-)

I don't think we need or ought to try figure out how to change the
data tracker for this until we have some examples of it being used
usefully.

Cheers,
S.

---

From: Paul Wouters <[email-masked]>
Date: Fri, 11 Jan 2019 14:28:32 -0500 (EST)

> data tracker for this until we have some examples of it being used

This would be great. But I doubt people will end up investing that
much time in a dying draft. And authors could already do that now
without any tooling change by just rev'ing the draft.

Paul

---

From: Fred Baker <[email-masked]>
Date: Fri, 11 Jan 2019 11:49:09 -0800

Responding to several emails.

The proposal of adding it to the actual internet draft text concerns me; I have had drafts, and others have, that expired and were then revived months later - or were replaced by some other draft at some subsequent time. It seems quite sufficient to have the data tracker report that the draft expired without having to actively "declare it dead". The "replaced by" note is a good idea, but for anything else, having the datatracker simply note that it expired seems adequate.

> On Jan 10, 2019, at 3:59 PM, Carsten Bormann <[email-masked]> wrote:
> 

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 11 Jan 2019 20:59:52 +0100

I would also suggest to at least start collecting experience purely by
using existing processes (not inventing new onesand just adding helpful
thet explaining the status of the draft (expired), and then learn from
that experience.

The main question in this context is whether anybody not the "owner" of
the draft should be allowed to add such information (owner = authors or
WG). Today that would already be a process change, so probably try to
avoid this.

Main case i can think of in my WG would for example be a lot of one-off
draft presentations (ndividual of course), where the idea is interesting but the
execution insufficient for adoption, and there is no critical mass of
resources (authors) to solve that issue. IN that case such an "expired" section
could ultimately act as an invitation to consider this probleem and
execute a solution better with or without reuse of that expired text.

Cheers
    Toerless

On Fri, Jan 11, 2019 at 11:49:09AM -0800, Fred Baker wrote:
> > The only value of this variable can be ???submitter lost interest???, or they would have sent a new version in time.
> > 
> > Now, *why* the submitter lost interest is a different question, and is probably highly subjective.  I know that at least for some of my drafts the answer should be ???X was stupid???, where X may be a WG, a WG chair, an AD???  But of course I would never say it that way.  For others, the answer would be ???bad idea, I was shown the light???, or ???overtaken by events??? (such as ???somebody else had a better idea???).   Maybe it would be useful for submitters to be able to bury their I-Ds with such a mark, but I???m not sure it would be used much.  (The one mark we do have, ???replaced by???, is extremely useful, but still doesn???t say why ??? ???became??? vs. ???went as one of the parts into??? vs. ???was superseded/obsoleted by???.)
> > 
> > Grüße, Carsten
> > 
>

---

From: Warren Kumari <[email-masked]>
Date: Fri, 11 Jan 2019 15:15:09 -0500

> data tracker for this until we have some examples of it being used
This sounds perfectly reasonable to me, but I would like there to be a
**convention** for what the section is called -- it would be nice to be
able to find drafts with these sections using e.g grep.
"Why this draft is no longer active" seems like a perfectly fine option for
that...
W

---

From: Robert Sparks <[email-masked]>
Date: Fri, 11 Jan 2019 14:37:30 -0600

I typo'd of course: All the instances of rfc.ietf.org below should say 
rsync.ietf.org.

RjS

On 1/10/19 12:31 PM, Robert Sparks wrote:
>>      > +1 with Stewart. At least in the Routing Area WGs in which I 
>>      > Thanks,
>>      > Acee
>>      >
>>      > From: WGChairs <[email-masked]> on behalf of 
>> Stewart Bryant <[email-masked]>
>>      > Date: Thursday, January 10, 2019 at 7:15 AM
>>      > To: Kent Watsen <[email-masked]>, "Eric Vyncke (evyncke)" 
>> <[email-masked]>, Mary Barnes <[email-masked]>, 
>> Deborah Brungard <[email-masked]>
>>      > Cc: "[email-masked]" <[email-masked]>
>>      > Subject: Re: IETF103 Plenary discussion on WG meeting conduct
>>      >
>>      >
>>      > Our culture is an asset, so we need to change it carefully and 
>>      >
>>      > I was in the plenary and could not figure out what actually 
>> happened, other that it appeared that someone was trying to 
>> re-introduce an old, previously discredited idea which was rebuffed.
>>      >
>>      > If someone is re-inventing/introducing old work (which is I 
>> think that this was about) then it is as well for us all to remember 
>> that all work needs to live in its own time, but that the onus is on 
>> the *proposer* to understand the history of the concept and pre-empt 
>> historical concerns up front.
>>      >
>>      > Whatever happens here we also need to remember that one case 
>> makes very poor law.
>>      >
>>      > - Stewart
>>      > On 09/01/2019 19:37, Kent Watsen wrote:
>>      > I disagree that that this can???t be changed and, to the 
>> extent we agree that there is a problem, we should try.
>>      >
>>      > Actually, if each of us to agree to put a single 
>> (IETF-provided?) slide in our meeting kickoff decks on e.g., 
>> courtesy, and spend 1-minute on it (i.e., ???the chairs have been 
>> asked to relay this message...???), it would hammer the point home by 
>> the end of the week.   This may be preceded by an email from IETF 
>> Chair, but I wouldn???t view that as a substitute for an in-room 
>> slide.  I would do this for one meeting only or, at least, until 
>> needed again.
>>      >
>>      > It???s nice/good to have the bullet in the Note Well (and the 
>> aforementioned slide could refer to it) but, honestly, I???ve never 
>> noticed it before.  The Note Well slide???s font is too small to read 
>> in the meeting, and the chairs just say ???note well the Note Well??? 
>> and/or something to the effect that anything said is considered a 
>> contribution.  Yes, I know, as a Chair putting together the slides, I 
>> have a rather readable version in-front of me every four months, but 
>> after years of small-font and pithy-intros, I became desensitized to 
>> it long ago and now it somewhat just glosses over my eyes.
>>      >
>>      > Kent
>>      >
>>      >
>>      > On 1/8/19, 8:31 AM, "WGChairs on behalf of Eric Vyncke 
>> (evyncke)" 
>> <[email-masked]<mailto:[email-masked]> on 
>> behalf of [email-masked]<mailto:[email-masked]>> wrote:
>>      >
>>      > Mary
>>      >
>>      > Very sensible email about the situation and the causes.
>>      >
>>      > And, I am sure that we agree that we could aim for a better: 
>> leadership should example
>>      >
>>      > -éric
>>      >
>>      > From: WGChairs 
>> <[email-masked]><mailto:[email-masked]> on 
>> behalf of Mary Barnes 
>> <[email-masked]><mailto:[email-masked]>
>>      > Date: Monday, 7 January 2019 at 23:05
>>      > To: "BRUNGARD, DEBORAH A" <[email-masked]><mailto:[email-masked]>
>>      > Cc: "[email-masked]"<mailto:[email-masked]> 
>> <[email-masked]><mailto:[email-masked]>
>>      > Subject: Re: IETF103 Plenary discussion on WG meeting conduct
>>      >
>>      > I had a hard time taking away too much from that despite the 
>> level of detail since there wasn't a clear example of the infarction 
>> in my opinion.  Clearly, we know people (including ADs, WG chairs, 
>> regular participants and even sometimes new ones) often don't 
>> communicate well nor nicely.   I go to the newcomer events and warn 
>> anyone that tells me they'll be presenting that they will encounter 
>> hostility.  That's not a good thing, but that's our community and 
>> culture in my experience and it's quite often reenforced based upon 
>> leadership choices.  I've had what I consider some of the rudest 
>> interactions with some ADs and everyday you can find examples of 
>> email discussions that could have been worded much differently. And, 
>> it's possible that the fact that we only meet 3 times per year 
>> (rather than monthly or every 6 weeks) with the majority of 
>> interactions happening via email contributes to the situation. It's 
>> very easy to misinterpret things in email and our very, very short 
>> sessions don't allow much back and forth for clarifying questions and 
>> really effective dialog.
>>      >
>>      > Personally, I don't think given even these factors that a huge 
>> cultural shift is possible. And, I also think that we are a tougher 
>> crowd than average when it comes to getting folks to interact 
>> "nicely".   But, I think leadership can better handle situations as 
>> they occur by talking to the perceived offending parties after the 
>> meetings OR during a meeting if things are getting too tense.  That 
>> has happened and it does work.  I would also suggest that newcomers 
>> (or really anyone) be encouraged to bring the situations forward 
>> during the week and then maybe someone can set up a few minutes for 
>> them to have a side discussion with the person with whom they 
>> encountered an apparent issue.  A lot of us are a lot nicer one on 
>> one than in the large group interactions.  And, cross talk, even 
>> amongst those that know one another well also happens.  In general, 
>> many are not very good at listening to understand, but rather listen 
>> with the intent to respond (based on sometimes false assumptions).    
>> If things are really bad, then I think that should go through ombuds 
>> team.   I don't think we need HR folks in meetings and I really don't 
>> think any sort of training would help much (if my mother were still 
>> alive, she could recount her many attempts at trying to improve my 
>> social graces - she gave up when I was about 10).    One only has to 
>> compare our group during refreshment breaks to that of other 
>> conferences to see a significant difference when it comes to the most 
>> basic practice of etiquette.  We'd need to start with the 101 class 
>> from the Emily Post Institute.
>>      >
>>      > Regards,
>>      > Mary.
>>      >
>>      >
>>      >
>>      > On Fri, Jan 4, 2019 at 4:42 PM BRUNGARD, DEBORAH A 
>> <[email-masked]<mailto:[email-masked]>> wrote:
>>      > Hi,
>>      >
>>      > I am not aware myself though maybe private discussions-
>>      >
>>      > The minutes of the Plenary were just posted, it has a very 
>> good transcript of the open mike session-
>>      > 
>>      >
>>      > Happy New Year everyone -
>>      > Deborah
>>      >
>>      >
>>      > -----Original Message-----
>>      > From: S Moonesamy 
>> <[email-masked]<mailto:[email-masked]>>
>>      > Sent: Friday, December 14, 2018 4:58 PM
>>      > To: BRUNGARD, DEBORAH A 
>> <[email-masked]<mailto:[email-masked]>>; 
>>      > Subject: Re: IETF103 Plenary discussion on WG meeting conduct
>>      >
>>      > Hi Deborah,
>>      > At 10:23 AM 13-12-2018, BRUNGARD, DEBORAH A wrote:
>>      > >At Bangkok's plenary meeting, during the IESG mike session, 
>> we had a
>>      > >couple of people commenting on their experience at working group
>>      > >meetings. Some people felt that they were treated 
>> inappropriately, that
>>      > >they were personally criticized vs. technically, or were 
>> simply told
>>      > >their idea was discussed before vs. a short summary so as to 
>> understand
>>      > >why it was rejected.
>>      >
>>      > Did anyone talk with the persons to find out what happened?
>>      >
>>      > Regards,
>>      > S. Moonesamy
>>           --
>>      ---
>>      [email-masked]
>>
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 11 Jan 2019 15:40:21 -0600

> data tracker for this until we have some examples of it being used

Who says we have to change the datatracker?  "Edit WG state", "Dead WG
Document", leave a comment in the comment field to show up in the document
history.

-Ben