Subject: Catalogue of "bad behaviour" to use for discussion

From: Barry Leiba <[email-masked]>
Date: Fri, 29 Mar 2019 11:40:37 +0100

I promised at the WG Chairs' Forum on Tuesday of IETF 104 to post this
to the WG Chairs' list, and here it is:

https://trac.ietf.org/trac/iesg/wiki/DraftListOfBadBehaviour

Keep a few things in mind:

1. This is just a starting point for discussion, and maybe something
for chairs to think about as you guide the working groups.

2. This is meant to be neither complete nor even "correct".  Different
situations will work differently, and many of the things that are
mentioned have a lot of grey areas.

3. The IESG is on your side and will help and support you.  We will
also be taking direct action ourselves.  But we really want this to
empower the community as a whole to reject bullying and inappropriate
ways of interaction.

Discussion on this list would be great.  Stories about how we were
able to improve particular situations would be great.  And reaching
out to your working group participants... and calling out, privately
or publicly if you think that's appropriate, people who are bullying,
dismissive, and unwelcoming to newcomers would be really great.

Have at it...

Barry

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 29 Mar 2019 11:47:42 +0100

It’s actually sad that we need this :(

mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

> On Mar 29, 2019, at 11:40 AM, Barry Leiba <[email-masked]> wrote:
>

---

From: tjw ietf <[email-masked]>
Date: Fri, 29 Mar 2019 11:48:48 +0100

Marie

I agree. But thanks Barry for putting this together. 

Tim

From my high tech gadget

> On Mar 29, 2019, at 11:40, Barry Leiba <[email-masked]> wrote:
>

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 29 Mar 2019 11:53:40 +0100

It's touched on tangentially in the list, but FWIW I've always held that attacking a person's arguments / proposals based on where they work amounts to an ad hominem, and therefore is out of bounds. Some people have reacted really negatively to this; they seem to believe that it's OK to smear someone based on their employer.

Worth adding explicitly?

> On 29 Mar 2019, at 11:40 am, Barry Leiba <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 29 Mar 2019 11:17:56 +0000

>   It's touched on tangentially in the list, but FWIW I've always held that attacking a person's arguments / proposals based on where they work amounts to an ad hominem, and therefore is out of boun…
  
It's tough. We talk about individual contributions, but it can be clear when someone is coming just to get "air cover" for something that is in their planned corporate goals and directions, even when the IETF is not interested, and in those cases it can be worthwhile to make that explicit.  "Go away, ITU, we don't want X.400 to replace S/MIME" as a contrived example.* Experienced IETFers are better at "hiding" this than recent newcomers.
	/r$

* (Of course ITU had the last laugh because we're using X.509 all over the place.)

---

From: Dave Lawrence <[email-masked]>
Date: Fri, 29 Mar 2019 07:31:16 -0400

Mark Nottingham writes:
> It's touched on tangentially in the list, but FWIW I've always held
> that attacking a person's arguments / proposals based on where they
> work amounts to an ad hominem, and therefore is out of bounds. [...]
> 
> Worth adding explicitly?

Yes, maybe updating the "It's just <company yy>..." example?

Similarly I'd change this example:

   Bad: "You don't know what you're talking about. That's a really stupid
        idea."

to just:

   Bad: "That's a really stupid idea."

The first sentence is suitably covered before that, I think, but the
second part really isn't.  Apart from effectively being an indirect
attack on the person advancing the idea, it simply isn't constructive.
As the first point says, stick to the argument.

That brings to mind one other issue though ... we do a lot of arguing
about non-technical things too, which can certainly be respectful by
not insulting the intellect behind either side.  A little more
wordsmithing would help.

---

From: Suzanne Woolf <[email-masked]>
Date: Fri, 29 Mar 2019 07:35:57 -0400

> On Mar 29, 2019, at 7:17 AM, Salz, Rich <[email-masked]> wrote:
> 

It’s also the case that a contributor's employment and day-to-day environment can have an enormous and sometimes unstated impact on that contributor's views of what’s important, what’s possible, and what’s worth doing.

However, if it’s not done carefully, pointing that out can look a lot like attacking the speaker or their employer.

There are probably ways to suggest a person is overlooking others’ interests because of priorities derived from their employment, without attacking either them or their employer.

Suzanne

---

From: Dave Lawrence <[email-masked]>
Date: Fri, 29 Mar 2019 07:37:07 -0400

Salz, Rich writes:
> It's tough. We talk about individual contributions, but it can be
> clear when someone is coming just to get "air cover" for something
> that is in their planned corporate goals and directions,

Even when true, however, the argument against it is not simply "it's
because $company wants it".  The proposal is examined on its own merits.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 29 Mar 2019 12:44:33 +0100

Right. The sort of thing I’m talking about is on the lines of “you work for $bigco, therefore you’re evil / participating in bad faith, and we don’t have to listen to you.”

Sent from my iPhone

> On 29 Mar 2019, at 12:35 pm, Suzanne Woolf <[email-masked]> wrote:
> 
> 
>

---

From: Melinda Shore <[email-masked]>
Date: Fri, 29 Mar 2019 12:03:06 +0100

I have to admit that I don't think that attempting to
enumerate unacceptable behaviors is particularly helpful,
except to the extent that it might lead to a more general
discussion of unacceptable *modes* of behavior.  I understand
that it's not intended to be comprehensive, but there are
nearly inevitably questions about things that don't end up
on the list, etc.  Also, note that there's substantial
prior art.

Melinda

-- 
Software longa, hardware brevis

PGP key fingerprint  4F68 2D93 2A17 96F8 20F2
                     34C0 DFB8 9172 9A76 DB8F

---

From: Yoav Nir <[email-masked]>
Date: Fri, 29 Mar 2019 19:44:41 +0100

> On 29 Mar 2019, at 12:35, Suzanne Woolf <[email-masked]> wrote:
> 
> 
> 

I don’t know how you can suggest that “you’re saying this because you work for Google” without it sounding like “you’re saying this because you are a privileged straight white guy”

Both statements may have some truth to them, but they are more inflammatory then helpful. If the technical statement you’re making disregards the needs of, say, a medium-sized data center, it should be called out on those grounds rather than your affiliation or level of privilege.

Yoav

---

From: Joel Jaeggli <[email-masked]>
Date: Fri, 29 Mar 2019 17:13:49 -0700

> On Mar 29, 2019, at 11:44, Yoav Nir <[email-masked]> wrote:
>> 

If one shows up at the IETF with some new elliptic curves  to publish It seems quite reasonable that people might chose to take into account who the stated or unstated employer of the individual is. This applies to quite a few other domains of work which the IETF engages in. Our intellectual property disclosure rules indicate as much and, they in in way rule out the presence of bad actors.

---

From: Yoav Nir <[email-masked]>
Date: Sat, 30 Mar 2019 11:27:17 +0300

> On 30 Mar 2019, at 3:13, Joel Jaeggli <[email-masked]> wrote:
> 
> 
> 
>> On Mar 29, 2019, at 11:44, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>>> 

That may be, and I suspect that it is one of the reasons why we wear our employer’s name on our badges. 

This thread is about how we treat other people.  It is not OK to effectively say, “You don’t really care about privacy because you work for Google” or “I think you’re lying because you work for the NSA”.  Take those things into account, but don’t use them to attack the individual.

Yoav

---

From: Kathleen Moriarty <[email-masked]>
Date: Sat, 30 Mar 2019 16:02:47 -0400

Sent from my mobile device

> On Mar 29, 2019, at 7:03 AM, Melinda Shore <[email-masked]> wrote:
> 

+1
Kathleen

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 30 Mar 2019 20:26:43 -0000

Just so, Melinda.

In composing 7776 Pete and I found ourselves resisting pressure to build a
list of bad behaviours. We were particularly worried that the omission of
something from the list might be construed as condoning the activity. We
also did not want to get into discussion of corner cases, reasonable
excuses, and misunderstandings.

Instead we deliberately did not attempt to precisely define behaviour that
falls under the term "harassment."

The obmudsteam are well versed in what might be reasonably called
unacceptable behaviour. And they understand the varying conditions under
which things happen and can apply judgement accordingly.

Best,
Adrian

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sat, 30 Mar 2019 21:43:30 +0000

Whether we end-up with a Catalogue of bad behavior or not,
I think it's useful to mention that bad behavior may  
be silent/non-verbal. Barry captured this under the heading
"Sarcasm and condescending tone/body language".

Actions near the front of the Mic-line in response to
something another contributor says are visible to
almost everyone in the room (and may be captured on video).

I witnessed a couple of actions like this some time back,
and it stuck with me because it was acted-out behind
the person speaking at the Mic - they had no idea what
people were suddenly laughing about, and were helpless
to defend against it.

Al

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Adrian
> Farrel
> Sent: Saturday, March 30, 2019 4:27 PM
> To: 'Melinda Shore' <[email-masked]>
> Cc: [email-masked]
> Subject: RE: [irsg] Catalogue of "bad behaviour" to use for discussion
> 
> Just so, Melinda.
> 
> > On Mar 29, 2019, at 7:03 AM, Melinda Shore
> <[email-masked]>
> wrote:
> >

---

From: G Fairhurst <[email-masked]>
Date: Sun, 31 Mar 2019 10:32:53 +0200

My thoughts are that trying to enumerate iyems of "bad behaviour" may 
actually not be productive, because the way behaviour is perceived often 
depends on the context of the observer  - I sometimes appreciate even 
the nuances between UK and North American can be very different - and we 
have such a wide variety of people attending with very different levels 
of appreciation of the "characters" found in such meetings - making 
everyone the same isn't good either.

Perhaps having good examples of where a change in practice can improve 
things could be more worthwhile?

Two things I try to do are:
* Listen to my open working group meetings and compare with my 
recollection - did someone try to say something that wasn't "heard" by 
the group? - did we use the time wisely to introduce discussion? How did 
we come across as Chairs?
* Sometimes watch the video of a meeting to look for how the group(s) 
are working - this can really help one become more aware of the way 
we/others are perceived...

Gorry

On 30/03/2019, 22:43, MORTON, ALFRED C (AL) wrote:
>> To: 'Melinda Shore'<[email-masked]>
>> Cc: [email-masked]