Subject: RE: [yang-doctors] Need YANG Doctor reviewing the YANG module of draft-ietf-i2nsf-sdn-ipsec-flow-protection which I2NSF is about to call WGLC

From: "Mehmet Ersue" <[email-masked]>
Date: Sat, 6 Apr 2019 12:53:19 +0200

Dear Linda,

following our process I would like to ask you to request a YANG Doctors
review on the datatracker page of your draft at:

https://datatracker.ietf.org/doc/draft-ietf-i2nsf-sdn-ipsec-flow-protection/

This will trigger a regular review by the YANG Doctors.

Note: You will not see the "Request review" button if you are not logged in
into the datatracker.

To point the reviewer to important issues you can enter on this page also
the "Requester's comments and instructions".

Please see following pages for further information on YANG Doctors and its
process:

https://datatracker.ietf.org/group/yangdoctors/about/

https://trac.ietf.org/trac/ops/wiki/yang-doctors-review

Many Thanks,

Mehmet

YANG Doctors Secretary

From: yang-doctors <[email-masked]> On Behalf Of Linda Dunbar
Sent: Friday, April 5, 2019 6:51 PM
To: [email-masked]
Cc: [email-masked]
Subject: [yang-doctors] Need YANG Doctor reviewing the YANG module of
draft-ietf-i2nsf-sdn-ipsec-flow-protection which I2NSF is about to call WGLC

Dear YANG Doctor:

We need your help in reviewing the YANG model in
draft-ietf-i2nsf-sdn-ipsec-flow-protection which I2NSF WG is about to call
WGLC. 

In particular, we need your advice on the following issue:

draft-ietf-i2nsf-sdn-ipsec-flow-protection-04 imports from
draft-ietf-netconf-crypto-types, which appears to be a generic list of
algorithms. 

The problem is that the list in draft-ietf-netconf-crypto-types could
contain algorithms that are not suitable for IPsec (such as secp192r1 for
key agreement), and right now it seems to lack some older algorithms that
have fallen out of fashion (3DES) but is still needed in IPsec.  

Questions to the YANG Doctor:

1.	 Is it better to list the IPsec specific algorithms in
draft-ietf-i2nsf-sdn-ipsec-flow-protection (which is a subset of
draft-ietf-netconf-crypto-types? Or to import all crypto algorithms many of
which are not relevant to IPsec? What is the common practice? 
2.	If we do import from draft-ietf-netconf-crypto-types, does it mean
draft-ietf-i2nsf-sdn-ipsec-flow-protection cannot be published until
draft-ietf-netconf-crypto-types is published?

Thank you very much, 

Linda & Yoav

---

From: Yoav Nir <[email-masked]>
Date: Sat, 6 Apr 2019 18:21:02 +0300

Thanks,  I’ve just requested it.

> On 6 Apr 2019, at 13:53, Mehmet Ersue <[email-masked]> wrote:
> 
> Dear Linda,
>  
> following our process I would like to ask you to request a YANG Doctors review on the datatracker page of your draft at:
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-sdn-ipsec-flow-protection/ <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-sdn-ipsec-flow-protection/>
> Note: You will not see the “Request review” button if you are not logged in into the datatracker.
>  
> To point the reviewer to important issues you can enter on this page also the “Requester's comments and instructions”.
>  
> Please see following pages for further information on YANG Doctors and its process:
> https://datatracker.ietf.org/group/yangdoctors/about/ <https://datatracker.ietf.org/group/yangdoctors/about/>
> https://trac.ietf.org/trac/ops/wiki/yang-doctors-review <https://trac.ietf.org/trac/ops/wiki/yang-doctors-review>
>  
> Many Thanks,
> Mehmet
> YANG Doctors Secretary
>  
> From: yang-doctors <[email-masked] <mailto:[email-masked]>> On Behalf Of Linda Dunbar
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> Subject: [yang-doctors] Need YANG Doctor reviewing the YANG module of draft-ietf-i2nsf-sdn-ipsec-flow-protection which I2NSF is about to call WGLC
>  
> Dear YANG Doctor:
>  
> We need your help in reviewing the YANG model in draft-ietf-i2nsf-sdn-ipsec-flow-protection which I2NSF WG is about to call WGLC. 
>  
> draft-ietf-i2nsf-sdn-ipsec-flow-protection-04 imports from draft-ietf-netconf-crypto-types, which appears to be a generic list of algorithms. 
> The problem is that the list in draft-ietf-netconf-crypto-types could contain algorithms that are not suitable for IPsec (such as secp192r1 for key agreement), and right now it seems to lack some older algorithms that have fallen out of fashion (3DES) but is still needed in IPsec.  
>  
>  
>  Is it better to list the IPsec specific algorithms in draft-ietf-i2nsf-sdn-ipsec-flow-protection (which is a subset of draft-ietf-netconf-crypto-types? Or to import all crypto algorithms many of which are not relevant to IPsec? What is the common practice? 
> If we do import from draft-ietf-netconf-crypto-types, does it mean draft-ietf-i2nsf-sdn-ipsec-flow-protection cannot be published until draft-ietf-netconf-crypto-types is published?
>  
>  
> Thank you very much, 
>  
> Linda & Yoav
>