Subject: WG meeting structure

From: "Pete Resnick" <[email-masked]>
Date: Tue, 14 May 2019 18:14:25 -0500

In part inspired by Dave Taht's thread on the IETF list; in part 
something I've been thinking about for some time.

Some of us chairs would like more discussing and less presenting in WG 
sessions. Even for the largest of WG sessions, I tend to see one or two 
dozen people coming to the mic and discussing, and the rest just 
visiting, so this is not an inconceivable idea for most WGs. Getting 
this accomplished is in part having the chairs structure the agenda 
somewhat differently, and we should really start discussing ways to 
accomplish that. But a practical tool to promote discussion is changing 
the room layout. The secretariat has already said that they're willing 
to set up something like this if there are enough takers, and I know a 
few chairs (including myself) who really want this, but I'd like to know 
if we've got enough critical mass to try this out, at least for one or 
two rooms:

The idea is to set up the room like this (check out this ASCII art!):

              +------+
              |screen|
              +------+
   X  X  X  O +-+  +-+ O  X  X  X
   X  X  X  O | |  | | O  X  X  X
   X  X  X  O |T|  |T| O  X  X  X
   X  X  X  O |a|  |a| O  X  X  X
   X  X  X  O |b|  |b| O  X  X  X
   X  X  X  O |l|  |l| O  X  X  X
   X  X  X  O |e|  |e| O  X  X  X
   X  X  X  O | |  | | O  X  X  X
   X  X  X  O | |__| | O  X  X  X
            O +______+ O
    M        O  O  O  O        M
       X  X  X  X  X  X  X  X
       X  X  X  X  X  X  X  X
       X  X  X  X  X  X  X  X
       X  X  X  X  X  X  X  X

Basically, the idea is to have U-shaped table setup, with the screen up 
at the open end. You'd get people at the table all the way around (the 
Os) who plan to participate in the discussion. (I've also seen this done 
with nested tables for more folks in the discussion.) Rows behind (in 3 
directions; the Xs) are for folks who plan to mostly just listen; those 
could fill the rest of the room and could probably scale to 100 or more 
seats depending on the size of the room. There would be a few wireless 
mics to pass around the tables, with perhaps a fixed mic at the bottom 
of the U for the WG chairs, and a couple of floor mics (the Ms) for 
folks who aren't around the table who happen to have comments.

How many of you be willing to run a WG session this way if the setup was 
offered?

pr
-- 
Pete Resnick http://www.episteme.net/
All connections to the world are tenuous at best

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 14 May 2019 19:36:45 -0400

Given the other disucssions about the importance of remote 
participation, it would seem we would either need a lot of microphones, 
or very different (and I suspect expensive) microphone technology so 
that the folks at those tables could simultaneously
1) engage in effective conversation
2) be heard remotely

Yours,
Joel

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 15 May 2019 00:49:07 +0100

Hi Pete,

> something I've been thinking about for some time.

Wasn't exactly this done for QUIC or maybe HTTPBIS a few times
a couple of years ago? (With spill over to other WGs in the
relevant room on that day.) I forget if that was considered
a success or not.

S.

---

From: Fred Baker <[email-masked]>
Date: Tue, 14 May 2019 16:53:35 -0700

Am I willing? Yes. Do I think it's a wonderful idea? I don't. Why? Because I already have little trouble getting people to come to the microphone when they care about something, and I already instruct speakers to leave at least half of their slot for discussion. The one thing I would request is that breakout rooms not have large visual blockages in them that prevent people from coming to the microphone, or interacting with the speaker.

I would suggest that chairs be given the option of choosing such a room layout, and that at least one room be configured as you suggest for those chairs that request it.

> On May 14, 2019, at 4:14 PM, Pete Resnick <[email-masked]> wrote:
> 
> In part inspired by Dave Taht's thread on the IETF list; in part something I've been thinking about for some time.
> 
> Some of us chairs would like more discussing and less presenting in WG sessions. Even for the largest of WG sessions, I tend to see one or two dozen people coming to the mic and discussing, and the rest just visiting, so this is not an inconceivable idea for most WGs. Getting this accomplished is in part having the chairs structure the agenda somewhat differently, and we should really start discussing ways to accomplish that. But a practical tool to promote discussion is changing the room layout. The secretariat has already said that they're willing to set up something like this if there are enough takers, and I know a few chairs (including myself) who really want this, but I'd like to know if we've got enough critical mass to try this out, at least for one or two rooms:
> 
> Basically, the idea is to have U-shaped table setup, with the screen up at the open end. You'd get people at the table all the way around (the Os) who plan to participate in the discussion. (I've also seen this done with nested tables for more folks in the discussion.) Rows behind (in 3 directions; the Xs) are for folks who plan to mostly just listen; those could fill the rest of the room and could probably scale to 100 or more seats depending on the size of the room. There would be a few wireless mics to pass around the tables, with perhaps a fixed mic at the bottom of the U for the WG chairs, and a couple of floor mics (the Ms) for folks who aren't around the table who happen to have comments.
> 
> How many of you be willing to run a WG session this way if the setup was offered?
> 
> pr
> --

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 14 May 2019 19:16:35 -0500

Replying to Joel, Stephen, and Fred in one message to reduce traffic:

On 14 May 2019, at 18:36, Joel M. Halpern wrote:

> participation, it would seem we would either need a lot of 
> microphones, or very different (and I suspect expensive) microphone 
> technology so that the folks at those tables could simultaneously

I think for 2 dozen people, 3 or 4 mics to be passed around the table 
should be fine, plus the two fixed floor mics. And so long as the 
screen/camera is up front, I don't think engagement changes much from 
the current state for remote folks.

> relevant room on that day.) I forget if that was considered

Yes, I should have given proper credit for that too: Mark N and I have 
chatted about that experience, which he reported as quite positive.

On 14 May 2019, at 18:53, Fred Baker wrote:

> Am I willing? Yes. Do I think it's a wonderful idea? I don't. Why? 
> Because I already have little trouble getting people to come to the 
> microphone when they care about something, and I already instruct 
> speakers to leave at least half of their slot for discussion.

I find this one interesting: I always find that interacting in the U 
shape is much easier than from a floor mic, depending on the size of the 
room, especially when multiple people are in on the discussion. If you 
have someone leading the discussion (or presenting), you can always put 
them at the top-center of the U for that part of the discussion. But 
either way, I'm not clear how having the people up at the table would 
make it harder to get them to participate than getting them to walk up 
to the mic in a lecture-style room.

> The one thing I would request is that breakout rooms not have large
> visual blockages in them that prevent people from coming to the 
> microphone,
> or interacting with the speaker.

Do you think this somehow makes that worse?

> I would suggest that chairs be given the option of choosing such a 
> room layout, and that at least one room be configured as you suggest 
> for those chairs that request it.

Absolutely. But we do need to get enough folks to say they'd be willing 
(or want) to try in order to get the secretariat to set it up.

pr

---

From: Michael Richardson <[email-masked]>
Date: Tue, 14 May 2019 20:46:00 -0400

> How many of you be willing to run a WG session this way if the setup was

Yes. Yes. Yes. YES!!!

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Tue, 14 May 2019 20:49:24 -0400

Fred Baker <[email-masked]> wrote:
    > speakers to leave at least half of their slot for discussion. The one
    > thing I would request is that breakout rooms not have large visual
    > blockages in them that prevent people from coming to the microphone, or
    > interacting with the speaker.

As complementary suggestion for both "regular" rooms and the X seating in
Pete's U-shape...  Can we have enough space between rows, and enough space
between chairs so that people can get through.  Generally, if we have a room
that seats 300, it will be "full" with 100 people because so many chairs are
effectively blocked.

So let's just put fewer chairs in the room, and have a stacks of extra chairs
in the corner and/or in the hallway.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 14 May 2019 18:00:18 -0700

Pete,

> …..

I think the problem is who gets to sit at the table.  It’s not always the same people who want to speak on a specific agenda item.   So I don’t think this will work at all for a w.g. meeting like 6man with over a hundred people in the room and a range of topics.  It might possibly for a smaller w.g.  I think it will also discourage people in the “X” seats from speaking.

As others have said, this is also going to be a big problem for remote participation.   Need a lot of microphones, a new who get to speak next protocol, and probably waste a lot of time passing the microphones around.

Bob

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 15 May 2019 03:11:05 +0200

On Wed, May 15, 2019, at 03:00, Bob Hinden wrote:
> I think the problem is who gets to sit at the table.  It’s not always 
> the same people who want to speak on a specific agenda item.   So I 
> don’t think this will work at all for a w.g. meeting like 6man with 
> over a hundred people in the room and a range of topics.  It might 
> possibly for a smaller w.g.  I think it will also discourage people in 
> the “X” seats from speaking.
> 
> As others have said, this is also going to be a big problem for remote 
> participation.   Need a lot of microphones, a new who get to speak next 
> protocol, and probably waste a lot of time passing the microphones 
> around.

It might pay to retrieve the feedback that was provided on the experiment.  The IESG did collect feedback.  My sense was that this was widely consider to have not worked, mostly for the reasons that Bob describes.  This layout worked (and works) really well for interim meetings where there are fewer attendees, but it didn't work for the larger meetings.

---

From: Kyle Rose <[email-masked]>
Date: Tue, 14 May 2019 21:11:22 -0400

On Tue, May 14, 2019 at 9:00 PM Bob Hinden <[email-masked]> wrote:

> I think the problem is who gets to sit at the table.  It’s not always the
> same people who want to speak on a specific agenda item.   So I don’t think
> this will work at all for a w.g. meeting like 6man with over a hundred
> people in the room and a range of topics.  It might possibly for a smaller
> w.g.  I think it will also discourage people in the “X” seats from speaking.
>

I think this can be dealt with by the WG chairs. In some WGs, there will be
a core group of people who need to be at the table for the entire
discussion, while in others it will change entirely from topic to topic.
Asking people who are not involved in a particular discussion to move to
the audience seems reasonable.

Need a lot of microphones, a new who get to speak next protocol, and
> probably waste a lot of time passing the microphones around.
>

Technical issues aside (more mics?), WG chairs already have pretty wide
latitude to run the meetings in the way they feel is most appropriate. This
includes how to recognize speakers. It seems some experiments are in order.
FWIW, I attended the QUIC session in Berlin (?) where this U shape was
employed, and I thought it worked quite well.

Kyle

---

From: Aaron Falk <[email-masked]>
Date: Tue, 14 May 2019 22:00:48 -0400

> employed, and I thought it worked quite well.

 My recollection is that the experiments with the U-shaped table were
considered a success for the people who were there and a failure for any
remote participants because they had a difficult time hearing and
participating in the conversation. Comments from remote folks who tried
would be helpful.

—aaron
-- 
-- aaron Sent from Gmail Mobile

---

From: Kyle Rose <[email-masked]>
Date: Tue, 14 May 2019 22:07:35 -0400

On Tue, May 14, 2019 at 10:01 PM Aaron Falk <[email-masked]> wrote:

> participating in the conversation.
>

If true, this is definitely a problem, but it also feels like one that can
be solved with better equipment.

A related consideration might be providing a virtual place at the table for
remote participants who are critical participants in a particular
discussion, which might mean augmenting meetecho with the ability for
chair-selected remotes to speak without the chair pressing the big red
button.

Kyle

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 15 May 2019 04:28:45 +0200

A)

Given how i am a big fan of not regressing on support for remote
participation: If you do expect to enable discussion between
people sitting on the tables, then at least every second needs to have
a microphone in front of them. These additional microphones 
may already be a significant org issue. Also its unclear to me how
well a single camera could capture the front-row discussion
participants. I fear it is easy to regress on our remote
participation quality. But of course, there may be WGs where there
are no remote participants.

B)

A cheaper alternative approach could be a row of "panel chairs"
in front of the screen (beside the speaker cage). In such a constrained
setup, one could still quickly enough pass around a single mike and
the existing cameras would likely easily be able to program additional
pan/tilt positions to capture the panel seats. We're already using
this setup in non-WG meetings anyhow.

C)

IMHO, the primary case where i think a room setup issue
exists is when the room is too tighly packed that there is not enough
sparse space around the audience microphones for active participants
to dynamically readjust themselves around them. SO may just make
sure rooms have enough spare space and for the big ones that will be
stuff, maybe start setting up the chairs around the mike sparsely, e.g.:
don't populate a few chairs every second like this:

		Screen
                Speaker

    XXXXXXXXXXXXX   XXXXXXXXXXXXX   
    XXXXXXXXXXXXX   XXXXXXXXXXXXX   
    XXXXXXXXXXXXX M XXXXXXXXXXXXX   
    XXXXXXXXP           PXXXXXXXX   
    XXXXXXXXPPPPP   PPPPPXXXXXXXX   
    XXXXXXXXP           PXXXXXXXX   
    XXXXXXXXPPPPP   PPPPPXXXXXXXX   
    XXXXXXXXXXXXX   XXXXXXXXXXXXX   
    XXXXXXXXXXXXX   XXXXXXXXXXXXX   
    XXXXXXXXXXXXX   XXXXXXXXXXXXX   

M(icrophone).
P chairs would be reserved to be used when participating in discussion.

This would allow to overcome the problem that today everyboy who thinks
she may want to go to the mike occupies the first chair in every row and
creates head of row congestion.

Again:  Not necessary to bother IMHO when rooms are not full.

Cheers
    Toerless

On Tue, May 14, 2019 at 06:14:25PM -0500, Pete Resnick wrote:
> dozen people coming to the mic and discussing, and the rest just visiting,
> so this is not an inconceivable idea for most WGs. Getting this accomplished
> is in part having the chairs structure the agenda somewhat differently, and
> we should really start discussing ways to accomplish that. But a practical
> tool to promote discussion is changing the room layout. The secretariat has
> already said that they're willing to set up something like this if there are
> enough takers, and I know a few chairs (including myself) who really want
> this, but I'd like to know if we've got enough critical mass to try this
> out, at least for one or two rooms:
> 
> Basically, the idea is to have U-shaped table setup, with the screen up at
> the open end. You'd get people at the table all the way around (the Os) who
> plan to participate in the discussion. (I've also seen this done with nested
> tables for more folks in the discussion.) Rows behind (in 3 directions; the
> Xs) are for folks who plan to mostly just listen; those could fill the rest
> of the room and could probably scale to 100 or more seats depending on the
> size of the room. There would be a few wireless mics to pass around the
> tables, with perhaps a fixed mic at the bottom of the U for the WG chairs,
> and a couple of floor mics (the Ms) for folks who aren't around the table
> who happen to have comments.
> 

-- 
---
[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Tue, 14 May 2019 22:09:46 -0700

> On May 14, 2019, at 5:16 PM, Pete Resnick <[email-masked]> wrote:
> 
>> Am I willing? Yes. Do I think it's a wonderful idea? I don't. Why? Because I already have little trouble getting people to come to the microphone when they care about something, and I already instruct speakers to leave at least half of their slot for discussion.
> 
> I find this one interesting: I always find that interacting in the U shape is much easier than from a floor mic, depending on the size of the room, especially when multiple people are in on the discussion. If you have someone leading the discussion (or presenting), you can always put them at the top-center of the U for that part of the discussion. But either way, I'm not clear how having the people up at the table would make it harder to get them to participate than getting them to walk up to the mic in a lecture-style room.

I didn't say it would make it harder. I said it was a solution to a problem that I don't know that I have in my working group. We also have tables in the front of the lecture-style room, and people tend to sit where they have easy access to a microphone. So if we're solving problems, I don't see this as a solution to a problem I have.

>> visual blockages in them that prevent people from coming to the microphone,

I think we had rather a problem with that in Prague. If we're solving problems, that's a problem we did have.

---

From: Fred Baker <[email-masked]>
Date: Tue, 14 May 2019 22:12:24 -0700

> On May 14, 2019, at 6:11 PM, Kyle Rose <[email-masked]> wrote:
> 
> I think this can be dealt with by the WG chairs. In some WGs, there will be a core group of people who need to be at the table for the entire discussion,

And we generally have a few tables toward the front, with the express understanding that people sitting there have read the drafts in prep for the meeting. That tends to be the "core" group for at least some discussions.

---

From: "Valery Smyslov" <[email-masked]>
Date: Wed, 15 May 2019 09:59:02 +0300

Hi Pete,

what I've been always liking in IETF room setup is that the floor mics
make discussion self-organized - those who want to discuss form a line
and speak one past one, making easy for listeners to identify who is
speaking and to follow the discussion. Yes, it makes the discussion 
slower than it could be if people can speak from their seats.

But the problem, as I see it, with your suggested setup is that 
if there are more than a few folks willing to speak (each with
his/her own mic), then there is usually a need for some moderator,
who will give them a right to speak. Otherwise we'll hear either noise 
or mostly only most active (or quick) speakers. The WG chairs can be 
moderators, but any moderation is somewhat subjective and you
need to indicate a willingness to speak to moderators (e.g. sitting
for a long time with hand raised). 

And I participated remotely in a QUICK session with such room setup 
(that was a few meeting ago). From my recollection I had somewhat 
bad experience from it, because I had hard time trying to identify who was 
speaking (folks often forgot to introduce themselves and jabber scribe
didn't help much since he/she probably had the same problem)
and as far as I remember sometimes it happened that speakers talked simultaneously,
making impossible to understand them for remote participants.

So, I believe this setup is suited for small groups with 3-5 active speakers.

Regards,
Valery Smyslov.

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 15 May 2019 08:08:20 +0100

On 15/05/2019, 03:07, Kyle Rose wrote:
> On Tue, May 14, 2019 at 10:01 PM Aaron Falk <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>         Technical issues aside (more mics?), WG chairs already have
>         pretty wide latitude to run the meetings in the way they feel
>         is most appropriate. This includes how to recognize speakers.
>         It seems some experiments are in order. FWIW, I attended the
>         QUIC session in Berlin (?) where this U shape was employed,
>         and I thought it worked quite well.
>
>
>      My recollection is that the experiments with the U-shaped table
>     were considered a success for the people who were there and a
>     failure for any remote participants because they had a difficult
>     time hearing and participating in the conversation.
>
>
> If true, this is definitely a problem, but it also feels like one that 
> can be solved with better equipment.
>
> A related consideration might be providing a virtual place at the 
> table for remote participants who are critical participants in a 
> particular discussion, which might mean augmenting meetecho with the 
> ability for chair-selected remotes to speak without the chair pressing 
> the big red button.
>
> Kyle
As I recall, this worked nicely for a smaller setting with a U-table and 
one or two rows seats where more people were included.

For me, it served very badly when the a U-table was setup and then there 
were banks of chairs postioned to observe it. A part of the issue was 
that it encouraged people at the table to have an Interim-style 
discussion - engagement was faster with each other. These people 
benefited from cues in body language, eye contact, etc.

Others became passive observers. Many people had their back to me and 
spoke to others without me knowing who they were or who they were 
talking to; I couldn't see who was speaking and it could be hard to see 
a presenter's face as they presented. I even saw a case where the person 
leading/chairing was seated with their back to many of the people in the 
room. To me it was like being a remote observer at an Interim.

I'm unsure how more technology would help here.

Gorry

---

From: Ole Troan <[email-masked]>
Date: Wed, 15 May 2019 09:16:36 +0200

The current microphone line isn't as much a discussion as it is a serialized set of independent one way comments.
Allowing for a 1:1 exchange between the presenter/author and the commentor.

I like Pete's proposal.
I would run it so that who had the "hot seats" were reshuffled per presentation/topic.
It might require more preparation ahead of time. A clearer definition of open issues to discuss, and perhaps some prepping of individuals to encourage them to take the  seats for particular topics.

I think it would foster a much more healthy active participation, and also be a good block for documents that have few supporters apart from the authors, but also few opponents.

Ole

> On 15 May 2019, at 08:59, Valery Smyslov <[email-masked]> wrote:
> 
> Hi Pete,
>

---

From: Lars Eggert <[email-masked]>
Date: Wed, 15 May 2019 10:57:17 +0300

Hi,

On 2019-5-15, at 10:08, Gorry Fairhurst <[email-masked]> wrote:
> For me, it served very badly when the a U-table was setup and then there were banks of chairs postioned to observe it. A part of the issue was that it encouraged people at the table to have an Interim-style discussion - engagement was faster with each other. These people benefited from cues in body language, eye contact, etc.

that was exactly the intent. QUIC never made much progress on any open issues during the IETF meetings, because the serialized "discussion" enforced by the mic lines is simply very inefficient at that. So we tried to replicate a discussion style like we have during interims, where we make much more rapid progress.

> Others became passive observers. Many people had their back to me and spoke to others without me knowing who they were or who they were talking to; I couldn't see who was speaking and it could be hard to see a presenter's face as they presented. I even saw a case where the person leading/chairing was seated with their back to many of the people in the room. To me it was like being a remote observer at an Interim.

In that particular room, the seats for the chairs where badly placed, but that is easily corrected.

I guess it all boils down to what a WG meeting at an IETF is for: is it for making rapid progress on open technical issues? Or is it for presentations to a broader audience with limited Q&A? The answer is obviously going to be different for different WGs, and even for different topics within a WG.

For QUIC, since we haven't had the chance for another experimental room setup in a while, we are actively scheduling things so that presentation-style topics are mostly presented with more limited discussion at IETFs, and (most) other things only at interims.

Lars

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 15 May 2019 08:13:58 +0000

Hello,

I like Pete's proposal.
I've experienced session with u-shape room several years ago (IETF88 I think) for the NMRG (I know RG are different from WG) and it worked quite well for the 20-30 participants that were present. Remote participation was not supported though.

One suggestion to try to satisfy the various needs/constraints could be that WG meet at least twice (one in a U-shape, and one in a lecture-style room) during the IETF week, and adapt their agenda to fit the type of discussion/interaction/presentation that needs to happen. Session for the u-shape room would be more to address open issues, discuss on technical topics. Lecture-style could be more for summary/status presentations and WG status, etc.
Sessions for WG could also be defaulted to shorter slots i.e. 1hr.

--Laurent.

> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Lars Eggert
> Sent: Wednesday, May 15, 2019 09:57
> To: Gorry Fairhust <[email-masked]>
> Cc: WG Chairs <[email-masked]>; Pete Resnick <[email-masked]>
> Subject: Re: WG meeting structure
> 
> Hi,
> 
> were banks of chairs postioned to observe it. A part of the issue was that
> it encouraged people at the table to have an Interim-style discussion -
> engagement was faster with each other. These people benefited from cues in
> body language, eye contact, etc.
> 
> that was exactly the intent. QUIC never made much progress on any open
> issues during the IETF meetings, because the serialized "discussion"
> enforced by the mic lines is simply very inefficient at that. So we tried
> to replicate a discussion style like we have during interims, where we
> make much more rapid progress.
> 
> spoke to others without me knowing who they were or who they were talking
> to; I couldn't see who was speaking and it could be hard to see a
> presenter's face as they presented. I even saw a case where the person
> I guess it all boils down to what a WG meeting at an IETF is for: is it
> for making rapid progress on open technical issues? Or is it for
> presentations to a broader audience with limited Q&A? The answer is
> obviously going to be different for different WGs, and even for different
> topics within a WG.
> 
> For QUIC, since we haven't had the chance for another experimental room
> setup in a while, we are actively scheduling things so that presentation-
> style topics are mostly presented with more limited discussion at IETFs,
> and (most) other things only at interims.
> 
> Lars

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 15 May 2019 08:20:10 +0000

From a mic tech standpoint -- this is how we set up QUIC interims (although it's just concentric U-shapes); we use a MXL AC-404 and remote participants regularly report that the sound is very good. It seems to be able to cover a roughly 15 meter squared room; for larger, I suspect we'd need to use more than one.

http://www.mxlmics.com/microphones/web-conferencing/AC-404/

> On 14 May 2019, at 11:36 pm, Joel M. Halpern <[email-masked]> wrote:
> 
> Given the other disucssions about the importance of remote participation, it would seem we would either need a lot of microphones, or very different (and I suspect expensive) microphone technology so that the folks at those tables could simultaneously

--
Mark Nottingham   https://www.mnot.net/

---

From: Russ Housley <[email-masked]>
Date: Wed, 15 May 2019 06:25:24 -0400

Pete:

This was offered as an alternate setup a few meetings ago, and as WG chair, it did not work well.  No matter where I sat, many people were behind me, so I could not tell when people wanted to speak.  Also, the back row filled before the seats at the table.

Russ

> On May 14, 2019, at 7:14 PM, Pete Resnick <[email-masked]> wrote:
>

---

From: Ole Troan <[email-masked]>
Date: Wed, 15 May 2019 13:12:49 +0200

> This was offered as an alternate setup a few meetings ago, and as WG chair, it did not work well.  No matter where I sat, many people were behind me, so I could not tell when people wanted to speak…

My suggestions was that the people at the table would switch per presentation. So you only had people at the table that was prepared and have a stake and interest in the document. I think you could combine active discussion with a microphone queue (local/remote) too.
And if there was no-one walking to the table for a given document, then well, then that's a glaring show of consensus to drop.

Ole

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 15 May 2019 12:19:56 +0000

> It might pay to retrieve the feedback that was provided on the experiment.
> The IESG did collect feedback.  My sense was that this was widely consider to
> have not worked, mostly for the reasons that Bob describes.  This layout
> worked (and works) really well for interim meetings where there are fewer
> attendees, but it didn't work for the larger meetings.

As someone who made the horrible mistake of volunteering to jabber scribe at one of these sessions, I'll just say that mistake will never happen again. The sound was coming from loudspeakers and many of the people at the tables had their backs to me so I couldn't tell who was talking. And if they were talking to the person next to them or near them, they didn't even talk in to the microphone sometimes. 

Engaged discussion to resolve open technical issues is hard to do in rooms with 100+ people. Interim meetings, "unstructured time" meetings (using WebEx and an iPad-as-speakerphone for remote participants), working on topics that "the masses" don't care about, etc. are often the best way to get such engaged discussion.

Or advertise the session will be that way and strongly encourage "observers" and others who don't plan to directly participate to just stay away. Put it in a small room that can only accommodate up to 25 people and tell everyone who just wants to watch to go elsewhere and use Meetecho to watch.
Barbara

---

From: Mary Barnes <[email-masked]>
Date: Wed, 15 May 2019 07:37:39 -0500

I agree with Bob - I don't see this working for any large WG with diverse
topics (e.g., DISPATCH).  Maybe smaller WGs, but I don't think the
logistics are manageable given the places we meet.

Other standard's meetings I attend that have 30-40 participants have the
U-shaped setup with some folks sitting behind all around.  Audio is
*always* a problem and you waste time having to restate things and it's a
terrible experience as a remote participant.  You really need a purpose
built meeting room for that to work well, or you need a lot more A/V
support for addition of the extra microphones.   And, the acoustics of many
of these meeting rooms only make it worse.  We sometimes have problems even
with in-room audio with our current very simple setup.

Regards,
Mary.

On Tue, May 14, 2019 at 8:00 PM Bob Hinden <[email-masked]> wrote:

> at the open end. You'd get people at the table all the way around (the Os)
> who plan to participate in the discussion. (I've also seen this done with
> nested tables for more folks in the discussion.) Rows behind (in 3
> seats depending on the size of the room. There would be a few wireless mics
> to pass around the tables, with perhaps a fixed mic at the bottom of the U
> for the WG chairs, and a couple of floor mics (the Ms) for folks who aren't
> around the table who happen to have comments.
>
> protocol, and probably waste a lot of time passing the microphones around.
>
> Bob
>
>
>
>
>
> >

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 10:02:22 -0400

STARK, BARBARA H <[email-masked]> wrote:
    > Engaged discussion to resolve open technical issues is hard to do in
    > rooms with 100+ people. Interim meetings, "unstructured time" meetings
    > (using WebEx and an iPad-as-speakerphone for remote participants),
    > working on topics that "the masses" don't care about, etc. are often
    > the best way to get such engaged discussion.

Doctor, Doctor, it's hurts when I try to resolve technical issues in a room
with 100+ people....

So, why do we keep trying to do this? It doesn't work any better with the
speakers at the front.  That is, we don't resolve issues any faster.
(Sure, the audio might be better)

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 15 May 2019 10:07:56 -0400

I also agree with Bob. A setup like this is great for an interim meeting,
or perhaps for a small focused WG (it would have been great back when I
chaired FRNETMIB back in the 90s, we had around 10 or so people at a
meeting and we tended to move the chairs to sit in a circle).  But even
with a small focused group, this would be very difficult for remote
participants to have an equivalent place at the table.

Cheers,
Andy

On Wed, May 15, 2019 at 8:38 AM Mary Barnes <[email-masked]>
wrote:

> logistics are manageable given the places we meet..
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 15 May 2019 10:14:03 -0400

Michael,

We keep doing this because you can't turn people away, and tourists can
have a legitimate reason to be in the room and have useful things to say,
even if they're not a primary contributor.

If a WG finds that it can't make technical progress during an IETF week,
then call interim meetings, either virtual or in-person. One WG I
participate in had a three-day in-person interim meeting and we made a huge
amount of progress.

Cheers,
Andy

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 15 May 2019 14:14:37 +0000

> From: Michael Richardson
> Doctor, Doctor, it's hurts when I try to resolve technical issues in a room with
> 100+ people....
> 

Maybe the experiment should be to have a small room with a table/U where only active list-participants are allowed. Stream the Meetecho from this to a large room, which now becomes a remote site. There can be a mic in the large room for people who want to talk to the small room. And a moderator/jabber scribe in the large room (who don't need to be a chair or active participant) to manage the large room mic and identify who is at the mic.

If the small room is small enough, it might be possible to use a single non-directional mic for the whole room. And have a single camera to get everyone in the room (I've seen this done with a camera from above or from in front -- depending on layout). 

The acoustics of a small room will be much better than a table in a big room.

Just a thought.
Barbara

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 15 May 2019 14:54:26 +0000

+1.
Some “tourists” to WG are probably the ones who will use the protocols being discussed, e.g. network operators who don’t have time to participate in detailed discussions.

Linda

From: WGChairs [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Wednesday, May 15, 2019 9:14 AM
To: Michael Richardson <[email-masked]>
Cc: [email-masked]
Subject: Re: WG meeting structure

Michael,

We keep doing this because you can't turn people away, and tourists can have a legitimate reason to be in the room and have useful things to say, even if they're not a primary contributor.

If a WG finds that it can't make technical progress during an IETF week, then call interim meetings, either virtual or in-person. One WG I participate in had a three-day in-person interim meeting and we made a huge amount of progress.

Cheers,
Andy

On Wed, May 15, 2019 at 10:02 AM Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Black, David" <[email-masked]>
Date: Wed, 15 May 2019 14:56:38 +0000

> (Sure, the audio might be better)

Because sometimes it works, believe it or not ;-).   I've seen technical issues resolved relatively quickly via microphone discussion among the key people.  IMHO, that's usually worth a try, but if it doesn't converge, there are alternatives.

An approach that I like is that if discussion at the microphones is going nowhere slowly, figure out who the key participants are and charter a design team with a near-term deadline to come back with a preferred outcome or a set of thought-out alternatives that are conducive to hums in a room with 100+ people ... getting to an agreement to disagree is much easier in a small design team than in a room with 100+ people.

On the original topic, the U-shaped structure is interesting, but a WG chairs table may still be needed on one side of the screen so that the WG chairs have a complete view of the action without their backs turned to anyone.   I also want to reinforce that use of that structure needs to be at the discretion of WG chairs.  Thinking about the WGs that I have chaired and currently chair, there have been WG meetings for which the U-shaped structure would work well and WG meetings for which it would have been disastrous.

Thanks, --David

> From: WGChairs <[email-masked]> On Behalf Of Michael
> Richardson
> Sent: Wednesday, May 15, 2019 10:02 AM
> To: [email-masked]'

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 15 May 2019 06:55:34 +0000

Hi,

> relevant room on that day.) I forget if that was considered

yes, this is pretty much exactly what the "experimental room setup" is that you can ask for when requesting a slot. (QUIC is always asking for it, but we've only had it at one or two meetings, IIRC.) I think it worked well for us, and I think most of the core contributors would agree, but several other not-quite-core contributors felt it was worse for them than the normal layout.

Lars

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 13:05:24 -0400

Andrew G. Malis <[email-masked]> wrote:
    > I also agree with Bob. A setup like this is great for an interim meeting, or
    > perhaps for a small focused WG (it would have been great back when I chaired
    > FRNETMIB back in the 90s, we had around 10 or so people at a meeting and we
    > tended to move the chairs to sit in a circle). But even with a small focused
    > group, this would be very difficult for remote participants to have an
    > equivalent place at the table.

Is the remote participant issue that the U encourages multiple simultaenous
conversations without MIC?

or is it something else?

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 13:13:54 -0400

Andrew G. Malis <[email-masked]> wrote:
    > We keep doing this because you can't turn people away, and tourists can have
    > a legitimate reason to be in the room and have useful things to say, even if
    > they're not a primary contributor.

understood.... and I've been that tourist as well as benefitted from review
From people who were not primary contributors.

    > If a WG finds that it can't make technical progress during an IETF week, then
    > call interim meetings, either virtual or in-person. One WG I participate in
    > had a three-day in-person interim meeting and we made a huge amount of
    > progress.

Three questions:
1) did that WG have a significantly shorter, or no WG session at IETF?
2) was there a registration fee, and was remote attendance possible for this
   three-day interim meeting?
3) a three-day in-person interim is a pretty big commitment, did you get any
   tourists?

Okay, these questions may be leading and/or rhetorical :-)

My contention is that if the IETF-week meeting is not useful due to
accomodating tourists, and we have to do something elsewhere, then that
really means that we are paying for rooms for presentations for tourists^Wadhoc-cross-area-review.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 15 May 2019 13:16:22 -0400

Michael,

I think it would be difficult to impossible for a remote participant to be
able to keep up with open conversation around a table and be able to get a
word in edgewise without extremely strict conversational control from the
chair, to make sure that people spoke one at a time, into a microphone,
with the camera correctly pointed, and that the remote queue was expeditely
serviced.

Cheers,
Andy

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 13:18:19 -0400

Black, David <[email-masked]> wrote:
    > An approach that I like is that if discussion at the microphones is
    > going nowhere slowly, figure out who the key participants are and
    > charter a design team with a near-term deadline to come back with a
    > preferred outcome or a set of thought-out alternatives that are
    > conducive to hums in a room with 100+ people ... getting to an
    > agreement to disagree is much easier in a small design team than in a
    > room with 100+ people.

Yes, this is a good plan.

This is why I would like every WG to have 1HR session with as few conflicts
as possible, early in the week, and a second session later on in the week,
after sufficient unstructured time to have hashed out a solution.

Okay, so not every problem can be solved with five people, two couches and
seven beers, but I'll bet that a good problem statement can be articulated in
such a period of time, such that if you really need the formalism of a
chartered design-team, then you at least have the text by the end of the week.

    > On the original topic, the U-shaped structure is interesting, but a WG
    > chairs table may still be needed on one side of the screen so that the
    > WG chairs have a complete view of the action without their backs turned
    > to anyone.   I also want to reinforce that use of that structure needs
    > to be at the discretion of WG chairs.  Thinking about the WGs that I
    > have chaired and currently chair, there have been WG meetings for which
    > the U-shaped structure would work well and WG meetings for which it
    > would have been disastrous.

Care you provide some details?

I have a hypothesis that the WGs in which it would not work are dysfunctional
for a multitude of reasons.

All the WG sessions are on youtube... I spend many days after each meeting
watching the meetings I missed.  Can you handle 1.5 speed? 1.75? 2x? :-)

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 13:20:59 -0400

> Maybe the experiment should be to have a small room with a table/U
    > where only active list-participants are allowed. Stream the Meetecho
    > from this to a large room, which now becomes a remote site. There can
    > be a mic in the large room for people who want to talk to the small
    > room. And a moderator/jabber scribe in the large room (who don't need
    > to be a chair or active participant) to manage the large room mic and
    > identify who is at the mic.

Brilliant!

This also simplies room allocation, since all the "big" rooms can be setup in
presentation-style, and the small room can be opted in by
FirstComeFirstServed of WG chairs....

(This Thread has been giving me flashbacks of the "VPN BOF" sometime around
1999, where 1500 tourists tried to get into a 400 person room...)

---

From: "Black, David" <[email-masked]>
Date: Wed, 15 May 2019 17:34:20 +0000

> for a multitude of reasons.

Sure:

Area-wide catch-all WG spanning a bunch of topics, e.g., TSVWG - the U-shape will tend to result in many of those seated at the U being disengaged on topics in which they are not involved.   Mic lines result in self-selection of interested participants for each topic, which works well as the WG moves from topic to topic.

Very active WG for which the "working set" of seriously involved participants exceeds the seated capacity of the U-shape.

Beyond that, I have a general concern that the U-shape accompanied by expectations that seats at the U are for active participants may implicitly tend to discourage newcomers and tourists ... who may have crucial insights that everyone else in the WG has missed ...

Thanks, --David

> From: Michael Richardson <[email-masked]>
> Sent: Wednesday, May 15, 2019 1:18 PM
> To: Black, David
> Cc: [email-masked]'

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 15 May 2019 13:38:19 -0400

Michael,

In this particular case (SFC), there was no registration fee (we had a host
who donated a conference room and coffee), we didn't have remote
participation, we had the same meetings at the IETF as always, and as
always the resulting documents were reviewed by the WG as a whole.

Another "interim" that proved useful was at IETF 101, in place of a regular
meeting earlier in the week, the DETNET WG spent Friday together from 09:30
to 14:30, using a regular IETF meeting room.

DETNET has also had several virtual interims.

So there are lots of ways to use interim meetings to get work done in
addition to the meeting during IETF week.

Cheers,
Andy

---

From: "Pete Resnick" <[email-masked]>
Date: Wed, 15 May 2019 13:09:20 -0500

> identify who is at the mic.

I'm fine with this idea. I would be OK with some "cheap seats" in the 
small room if people wanted to sit in, as it will give us some 
additional data to the experiment.

I think as Michael has mentioned, quite a bit of the discussion has lost 
track of why we might want to do this: We want discussion, not "a 
serialized set of independent one way comments". (Thanks Ole.) Too 
often, that's what mic queues turn into, and that makes it harder for 
the chair to  figure out what the consensus is. People facing each other 
helps in a way that even tables all facing front do not. (See 
contortions in the current setup.) Having the chair face the remote 
screen to see who wants to participate helps. (Again, see contortions.)

The problem that remote (and some local observer) participants had with 
QUIC appears to be a chair issue: You still have to do discussion 
management, and in this setup the chair should call out the name of the 
person to ask them to speak, or even say, "John, Mary: Please go ahead 
and discuss between the two of you" and interrupt and say, "Joe, did you 
want to jump in?" Sure, that's not quite as free-flow as a free-for-all 
discussion, but it is much better than the current state. I also think 
that passing around a handheld mic would add a bit to the discussion 
management, instead of doing fixed "collect all sounds" mics. I've 
moderated sessions like this, and it does take attention and a piece of 
paper listing topics and names of people wishing to speak on those 
topics. No, you can't catch up on your email while chairing such a 
session. ;-)

My quick look over the list was a half a dozen folks thinking this is 
worth doing, a dozen seeing problems, and a couple simply neutrally 
commenting. Sounds like (given the small sample size) enough folks for 
an experiment, at least with their own WGs.

Speaking of experiments: For those of you with large rooms of folks (and 
do look at the numbers in the agenda request sent out yesterday; they're 
smaller than you think), it would be worth actually counting up how many 
people participated in your sessions (including presenters), how much 
time each of them spent speaking, and how quickly issues resolved. I 
suspect (with my data being a huge number of anecdotes) that you're 
being less productive in these sessions than you think you are.

pr

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 14:17:58 -0400

Andrew G. Malis <[email-masked]> wrote:
    > chair, to make sure that people spoke one at a time, into a microphone, with
    > the camera correctly pointed, and that the remote queue was expeditely
    > serviced.

It seems like we have a transport problem :-)

The issue is that with people closer together, the RTT between people is
shorter, and the chair does not get a chance to do congestion control, and so
goodput gets too high?

In order to accomodate large RTT remote participants, we need to slow down
the DC-speed traffic in the room?

But, I note that in the current presentation-style setup, we often do not
service the remote queue fast enough already.  Maybe the U-shape room simply
makes this obviously a problem.  Maybe we need to accomodate remote
participation in a more asynchronous nature, rather than in the CB-radio
way that we currently attempt to do it.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 14:29:32 -0400

Pete Resnick <[email-masked]> wrote:
    > what the consensus is. People facing each other helps in a way that even
    > tables all facing front do not. (See contortions in the current setup.)
    > Having the chair face the remote screen to see who wants to participate
    > helps. (Again, see contortions.)

    > The problem that remote (and some local observer) participants had with QUIC
    > appears to be a chair issue: You still have to do discussion
    > management, and

As someone who has done remote attendance, and is presently catching up on
IETF104 sessions where I had conflicts via youtube, I want to ask:

   Is our desire to support remote attendance causing us to render the
   meeting week un-productive?  If the answer to that lack of productivity
   is (in-person) interim meetings that don't have remote attendance, then
   did we really gain?

Note that watching the "dead" feed on youtube doesn't keep me from
interacting.  I hit pause, write an email, and then resume.

If I'm more courteous, I avoid hitting send until I finish watching, because
maybe my question gets answered :-)

This is actually potentially way better, because I'm taking the conversation
back to the list (where it belongs)

---

From: Mary Barnes <[email-masked]>
Date: Wed, 15 May 2019 14:10:35 -0500

I think you hit the nail on the head with the point about some things being
chair issues.  I would posit that the majority of this is chair issues.
IMHO, chairs should facilitate the discussion, which is easier with the U
shape.   For example, chairs are facing the group and rather than looking
at their email during the session or being heads-down in their laptop in
general, chairs should be watching the group.  The chairs know who the key
people are and there's nothing wrong with them specifically asking person X
to share their view if they're not in the queue.  We do that with ADs quite
frequently.  For example, the chairs can interrupt the queue and ask the
group if anyone else, who might not even be in the queue, has thoughts on
the specific point being discussed.

We also have the fact that a lot of participants are of the ilk that they
talk *at* people and really don't necessarily listen to what others have to
say - i.e., their top priority is to get their point across and not to try
to understand others' points (in many situations in my experience).   It's
not unusual that I'll say something and then someone else says the same
thing without acknowledging that the point has also been made.   If they
were more active listeners, while others are speaking, then the discussion
could be more interactive. But, I think many stand in line formulating what
they plan to say and lose track of what others in the queue are saying.
Obviously, facing one another is more conducive to active listening since
the majority of communication is non-verbal.  One thought I have to
facilitate the issue during the large sessions is to display the speaker on
the screen.  This allows people other than the chairs or those closer to
the front that can turn around to see the speaker.   And, maybe this is
something that chairs already have control over with the Meetecho screen
for remote participants?

I think the suggestion to have more interims is a good one.  The only
challenge there is time zone bias.  For example, even if you do a Doodle
poll, the majority might be one timezone which disadvantages those in a
completely different timezone (e.g., North America vs Asia).   One group I
worked in had the requirement that we rotate through time zones - we picked
a time for each major region.    The downside of course is that if there's
no one in the timezone you're accommodating, then it's really, really
annoying.

Certainly, there are ways to improve meetings. I do think it starts with
the chairs, then participants and then meeting room setup (and don't forget
potential impacts of the HVAC system and staff working behind the meeting
rooms that can have a significant impact on audio quality).    In my
experience, you need a chair that has a lot of experience chairing meetings
with the U-shape setup to be effective for both in room participants and
remote -i.e., zero tolerance for cross talk.  I will also add that some
folks have more difficulty following discussions when there are side
discussions (which are more common with U-shape, in particular, when you're
trying to ensure that everyone has access to a microphone.  So, you'd also
need participants to mute the nearby microphones when they are not
speaking.  And, actually studies show that women have this problem much
more frequently than men -  there is research showing that the auditory
processing in the brain of men and women is different.   So, that might
well be why I have difficulty with this style of meeting that isn't
extremely well managed. I've been on conference calls where there's a lot
of folks in the room and I seem to be the only one that can't follow the
discussion due to cross talk and poor moderation of the discussion, which
is why I wondered and did some research about this potential difference.
So, given that we have so few women, even if we experiment, there will
likely be a bias in the conclusions.

Regards,
Mary.

---

From: Mary Barnes <[email-masked]>
Date: Wed, 15 May 2019 14:17:39 -0500

I'll also add that I think our community likely has more folks with
auditory processing disorders than the general population - likely
undiagnosed because we have a lot of smart people in our demographic.    I
had a long discussion on this topic on a flight with an audiologist.  I
think this is why we have a lot of cross talk in meetings - i.e., people
saying the same thing but thinking that they aren't agreeing.

On Wed, May 15, 2019 at 2:10 PM Mary Barnes <[email-masked]>
wrote:

> I think you hit the nail on the head with the point about some things
> being chair issues.  I would posit that the majority of this is chair
> issues.  IMHO, chairs should facilitate the discussion, which is easier
> with the U shape.   For example, chairs are facing the group and rather
> than looking at their email during the session or being heads-down in their
> laptop in general, chairs should be watching the group.  The chairs know
> who the key people are and there's nothing wrong with them specifically
> asking person X to share their view if they're not in the queue.  We do
> that with ADs quite frequently.  For example, the chairs can interrupt the
> queue and ask the group if anyone else, who might not even be in the queue,
> has thoughts on the specific point being discussed.
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 15:50:31 -0400

Mary Barnes <[email-masked]> wrote:
    > challenge there is time zone bias. For example, even if you do a Doodle poll,
    > the majority might be one timezone which disadvantages those in a completely
    > different timezone (e.g., North America vs Asia). One group I worked in had
    > the requirement that we rotate through time zones - we picked a time for each
    > major region. The downside of course is that if there's no one in the
    > timezone you're accommodating, then it's really, really annoying.

It would be interesting to have a survey of IETF contributors to understand
what time is best for them.  Despite time-zone issues there are some other
issues with AV online meetings:
  1) some have no microphones/headphones at work
  2) some have microphones at work, but no quiet space
  3) some have too many state firewalls to permit them to work at home,
     in the evening.
  4) differences in work week days

I wonder if we could add this to the next meeting survey?

    > Certainly, there are ways to improve meetings. I do think it starts with the
    > chairs, then participants and then meeting room setup (and don't forget
    > rooms that can have a significant impact on audio quality). In my experience,
    > you need a chair that has a lot of experience chairing meetings with the
    > U-shape setup to be effective for both in room participants and remote -i.e.,
    > zero tolerance for cross talk. I will also add that some folks have more
    > difficulty following discussions when there are side discussions (which are
    > more common with U-shape, in particular, when you're trying to ensure that
    > everyone has access to a microphone. So, you'd also need participants to mute
    > the nearby microphones when they are not speaking. And, actually studies show
    > that women have this problem much more frequently than men - there is
    > research showing that the auditory processing in the brain of men and women
    > is different. So, that might well be why I have difficulty with this style of
    > meeting that isn't extremely well managed. I've been on conference calls
    > where there's a lot of folks in the room and I seem to be the only one that
    > can't follow the discussion due to cross talk and poor moderation of the
    > discussion, which is why I wondered and did some research about this
    > potential difference. So, given that we have so few women, even if we
    > experiment, there will likely be a bias in the conclusions.

So the prediction is that if we try this with people who haven't done it
before, then it will fail.  But how can we get trained better if we don't try
it?  Can we go learn how to do this elsewhere?  (where?)

---

From: Dave Lawrence <[email-masked]>
Date: Thu, 16 May 2019 13:18:58 -0400

Fred Baker writes:
> And we generally have a few tables toward the front, with the
> express understanding that people sitting there have read the drafts
> in prep for the meeting. That tends to be the "core" group for at
> least some discussions. 

Kind of annoying though when you're one of those participants though
and have to keep squeezing out from the middle to get to the mic line.
I imagine this could be fairly easily remedied though by remove a row
or two of gallery seating to allow the tables to be a little more
spaced.

---

From: Fred Baker <[email-masked]>
Date: Thu, 16 May 2019 19:04:14 -0700

Sent from my iPad

> On May 16, 2019, at 10:18 AM, Dave Lawrence <[email-masked]> wrote:
> 
> Fred Baker writes:

That, of course, depends on room size, and that actual number of people that show up. IPv6 Operations seems to randomly vary between 75 and 200, which is in part why I’m unconvinced about a layout that works well for 20 people. Every meeting doesn’t need to be organized for 200, and it’s true that in every meeting of 200 there is a meeting of 20 struggling to be had - a different 20 on each draft. But that doesn’t mean that every meeting is or should be organized for 20 people.

I also have questions about Meetecho, which would really like whoever is currently speaking to stand in a small square at exactly one of the three microphones. If we really want that form of A/V (and it looks like I’ll be dependent on it in July), I think we’re going to have to seriously rethink it. Zoom, perhaps, or something like it, using every laptop as a camera, microphone, and display for its owner, might be a solution, if it runs on IPv6.

In Prague, besides having a giant box or something occupying the center, and obscuring my view, of a good part of the room, I’m not at all sure there was “extra” floor space for aisles and space between rows in any of the breakout rooms on the first two floors (Kaplan I-Iii, or the ones in the “business” area). We had about 70 people, I think, and that worked because some were willing to stand against the back wall.

In Bangkok, I sat in on hrpc, which had 20-30 people arranged as Pete suggests and didn’t have Meetecho; we still needed to pass a mike around the room simply for people to be able to hear each other. It did allow people to get a lot of opinions voiced. As someone else noted, I wouldn’t have wanted to be the jabber scribe, although jabber might have been a useful solution to “the mike’s at the other end of the room and I want to talk”.

---

From: Loa Andersson <[email-masked]>
Date: Fri, 17 May 2019 20:37:49 +0800

All,

I agree with most of what what Fred says, drawing on experience from
other wg's.

I'm a bit nervous when this type discussions pops up. As long they are
discussions on "good ideas we tried, and the results we had", I think it
is fine.

When they slide away to instruct wg chairs what they should do, I'm
very concerned.

I'm convinced that when it comes to IETF wg's we don't have and will
never have a seating arrangement that fit all wg's, nor fit a single
working group for all of its life time.

If there are experiments necessary, let the wg chairs do the experiments
and the evaluation of the experiments.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 17 May 2019 09:14:44 -0500

> and the evaluation of the experiments.

There's a bit of a threshold problem, in that the logistics of the chair
setup means we need some critical mass of WGs to agree to run the same
experiment in the same meeting cycle in order for any of them to happen.
But that shouldn't have to take much else away from the WG chairs' control
over how to run the WG.

-Ben

---

From: Loa Andersson <[email-masked]>
Date: Fri, 17 May 2019 23:15:18 +0800

Ben,

> But that shouldn't have to take much else away from the WG chairs' control

So you are saying that if I would like to run the table setup for a MPLS
meeting as a U, V or A shape, you are saying that you would stop me just
because there are no other groups that are doing the same thing?

/Loa

--

---

From: Fred Baker <[email-masked]>
Date: Fri, 17 May 2019 08:27:42 -0700

inline

> On May 17, 2019, at 8:15 AM, Loa Andersson <[email-masked]> wrote:
> 
> Ben,
> 
> 

I believe that he was saying the hotel will charge something for the service, the service will take some time to perform, and the secretariat will need to understand what you want well enough in advance of the meeting that they can arrange a room in your favorite way and then schedule a number of working/research groups into it for the day. If they arranged it for you alone, they would probably need the time allotted to the slots before and after to rearrange it again.

So, by all means, arrange the room as you want to. And help them by getting a few other groups to be willing to be scheduled into the room that day.

--------------------------------------------------------------------------------
Victorious warriors win first and then go to war,
Defeated warriors go to war first and then seek to win.
     Sun Tzu

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 17 May 2019 10:50:12 -0500

> I believe that he was saying the hotel will charge something for the service, the service will take some time to perform, and the secretariat will need to understand what you want well enough in ad…

Exactly so, and better said than I would, from this phone keyboard.

Thanks,

Ben

---

From: Loa Andersson <[email-masked]>
Date: Sat, 18 May 2019 11:19:35 +0800

Fred and Ben,

Inline plz.

> So, by all means, arrange the room as you want to. And help them by getting a few other groups to be willing to be scheduled into the room that day.

OK - we have done that before - I think in Minneapolis  and some other
place -  for the MPLS working group.

Back then we had no tables in the front. We wanted that and talked to
the secretariat, they fixed that without any fuzz.

WE had a 2.5 hour morning slot and the hotel staff put i back without
tables after lunch. Did not affect anyone else, and we had our tables.
At that time we did not even call it an experiment. If there are reasons
it can't be done, so be it.

I still say let the wg chairs handle this.

/Loa

--

---

From: Wes Hardaker <[email-masked]>
Date: Sat, 18 May 2019 07:27:12 -0700

Lars Eggert <[email-masked]> writes:

> enforced by the mic lines is simply very inefficient at that. 

TLDR; In the end, I think a setup like that would work for a small WG
with a need for real brainstorming, but has
fairness/management/exclusionary issues with larger groups.

Jumping in here randomly, but the above at least works for some of my
context:

1) Some other standards organizations have rooms set up this way, as
people mentioned.  Typically these work well when the conversations to
be had are functionally "closed" but "open to observers", similar to
(large) board meetings and things.  It definitely impacts the
desire/ability to have other people in the room participate, and if
you're looking for a diversity of opinions this will hamper that.

2) Queue management becomes a different problem, which is harder for the
chair.  People raise hands to get put into a "I want to talk on the
subject queue", and when that list becomes long it's a real pain.  We
tend to have long lines at mics at the IETF, so the chairs may have
their work cut out for them.  If you don't do queues and do free-form
discussion, then mic monopolization becomes a serious problem, or some
people with valid inputs simply never get to express their thoughts
because its hard to be heard in a group of shouting people.  I'm
constantly concerned that without management, we only hear from
extroverts.  IE, "fair" becomes a real issue if it's not a small group.

3) Serialization itself isn't an issue *if* people are responding to
previous people's comments in an orderly fashion (more in a sec).  I
have seen many productive mic lines where 2-3 people resolve an issue
all standing at the mic, with a longer line behind them.  Which brings
me to:

4) One counter idea is to have rooms with two microphones (like many
have now, but run into issues with #2 above), but mandate that we use
them in the way we have in the past at plenaries: one mic is for
introducing new ideas, and the second is for responding to that
comment/issue.  Then you resolve some of the issues with not being able
to rapidly close sub-ideas with "discussion" style conversations that at
least still promotes fairness (smaller queues on a single topic).

-- 
Wes Hardaker
USC/ISI

---

From: Michael Richardson <[email-masked]>
Date: Sat, 18 May 2019 18:43:23 -0400

> extroverts.  IE, "fair" becomes a real issue if it's not a small group.

It does require active management, and this requires some training and
experience.
There was a very good ksk-rollover side-meeting with two or three mics in
Bangkok with Paul Hoffmann doing excellent queue management.

Getting input from introverts requires the chair to actively ask them.
I regularly wonder if having a "+1" button in front of everyone would help.

    > all standing at the mic, with a longer line behind them.  Which brings

Yes... the chair has to be willing to allow and encourage this.
It helps if people not at the front of the line have some way to say, "I have
a comment on the current topic", and for people who have multiple comments to
be able to make their first comment, and then do cooperative multi-tasking,
rather than having their do pre-emptive multitasking on them.

    > least still promotes fairness (smaller queues on a single topic).

I didn't remember that we do sometimes (always?) do this at plenaries.
I think that it is a really good idea.  To make it work best, people have to
be able to reach the mic lines better, which goes to my request to put just
fewer chairs in the room, spread them out way better.

{why do we accumulate people in the CC who are on the list?  Removing people
From the CC who are on the list might be an enhancement we could do to mailman}

---

From: Fred Baker <[email-masked]>
Date: Sat, 18 May 2019 23:04:56 -0700

Change of subject line.

> On May 18, 2019, at 3:43 PM, Michael Richardson <[email-masked]> wrote:
> 

I would personally favor doing so. In short, I presume that the sender of the message a given message is in reply to will be on the "to" line, and the working group on the CC line along with a random set of other email addresses, any of which can be edited out if they are also members o the mailing list. There are two issue that I see:

1) you really want to be sure that any email address removed is on the email list, so that a person is not prevented from receiving the email. If there is another email address is that *not* on the email list, it needs to not be edited away. The objective here is to shorten the CC line, not to exclude people that are presumably interested in the conversation.

2) I'll use this email as an example and discuss a probable issue. It is going to three destinations: [email-masked], [email-masked], and [email-masked]. The third will presumably be edited as suggested, because it's going through mailman; the other two will not, because they are not. BTW, if I had one or more BCC'd addresses, they would also not pass through mailman. If I have that right (I think I do, but I guarantee that there is some email program that will surprise me), the majority of the folks on the list will see the first (the "to") address and third address (the working group), but not Wes's address, but you will see Wes's email address (and Wes will see yours) in addition to the working group address. When you reply, it will get edited, but the messages you and I see will not because we will send them to each other directly. So the behavior of the system will be correct in the sense that each addressed party will receive the email, but it may not be intuitive.

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 19 May 2019 13:31:00 +0200

I do right now think there would be downsides for my WG with this
setup, but i would like to encourage my WG to evaluate and chime in (i
know MichaelR seems to like it), and i would certainly try to go to
WG meetings where this is being attempted at 105 to gain actual
experience.

Please send a reminder to this list which WGs will use this 
if the experiment is happening.

Cheers
    Toerless

-- 
---
[email-masked]