Subject: Submitting Agendas as Markdown

From: Tom Pusateri <[email-masked]>
Date: Thu, 11 Jul 2019 17:51:25 -0400

Dear WG chairs,
         In case you didn’t know, you can make your Agendas automatically format from Markdown to nice looking HTML in the IETFers iPad/iPhone app.

 I’m not sure if Markdown is a format choice for uploading in the Datatracker, but if not, you can upload it as TXT but make sure the first character is ‘#’ and it will attempt to convert from Markdown to HTML.

 If you already submit your Agendas as HTML, then you can skip this.

 Here is the link to the source for the DPRIVE Agenda in Markdown as an example (Thanks! Tim/Brian):

 https://datatracker.ietf.org/meeting/105/materials/agenda-105-dprive-00.txt

 It’s very easy to use and the agendas are pretty readable.

 Thanks,
 Tom

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Jul 2019 00:45:02 +0200

It's funny how 25 minutes became 5 minutes...

Sent from mobile

> On 11. Jul 2019, at 23:51, Tom Pusateri <[email-masked]> wrote:
> 
> Dear WG chairs,

---

From: Brian Haberman <[email-masked]>
Date: Fri, 12 Jul 2019 10:45:17 -0400

> It's funny how 25 minutes became 5 minutes...

Not really. We changed the length of the timeslot between version -00
and the current version.

Brian

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Jul 2019 17:01:10 +0200

> Not really. We changed the length of the timeslot between version -00

Right.  Tom explained that he had sent a version-specific link to the -00, which I viewed in parallel to the current data from the app.

And here’s my ceterum censeo, why it’s worth writing this message: 
*Never* send version-specific agenda links.  To anyone.

DON’T say:  https://datatracker.ietf.org/meeting/105/materials/agenda-105-t2trg-00
ALWAYS say: https://datatracker.ietf.org/meeting/105/materials/agenda-105-t2trg

Thank you for your attention to this public service message.

(And maybe at some point datatracker can be coaxed into revealing the version-specific links only if explicitly requested, signed with blood or so.)

Grüße, Carsten

---

From: Dave Lawrence <[email-masked]>
Date: Fri, 12 Jul 2019 11:48:34 -0400

Carsten Bormann writes:
> Right.  Tom explained that he had sent a version-specific link

Ooooh weird, I thought you were commenting on a markdown formatting
issue that had happened somehow, especially given that it was you,
Carsten.  I'd noticed that the "-25 minutes" was written differently
in the base Markdown text than other lines like "- 15 minutes", and
thought maybe you were subtly pointing out the processing problem.

I should have remembered that subtle isn't really something we do
here. :)

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Jul 2019 18:15:00 +0200

> thought maybe you were subtly pointing out the processing problem.

That was indeed what I thought I was commenting on.
But then Tom pointed out that I just was misled by a version-specific agenda link.
Again.  Like the usual 2-4 times for each IETF.  🔨💉✂️🔌📸🐲👻☠️👽🤦‍♂️.

> I should have remembered that subtle isn't really something we do

We sometimes try to…

Grüße, Carsten

---

From: Jim Fenton <[email-masked]>
Date: Fri, 12 Jul 2019 15:38:38 -0700

>  I’m not sure if Markdown is a format choice for uploading in the Datatracker, but if not, you can upload it as TXT but make sure the first character is ‘#’ and it will attempt to convert from Mark…

I tried this, and it looked like Datatracker inserted 3 spaces at the
beginning of the file (before that initial '#') and shows just the
Markdown source.

>  https://datatracker.ietf.org/meeting/105/materials/agenda-105-dprive-00.txt

Looks like it did the same for your sample as well. They look nice in
the IETFers app, but is there a way to make it look good on Datatracker
as well?

-Jim

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Jul 2019 00:45:32 +0200

> beginning of the file (before that initial '#') and shows just the

I don’t see three spaces on the dprive example.  Do you have a BOM problem?

> the IETFers app, but is there a way to make it look good on Datatracker

No, Datatracker does not know about markdown.

Grüße, Carsten

---

From: Sean Turner <[email-masked]>
Date: Mon, 15 Jul 2019 09:50:12 -0400

> On Jul 12, 2019, at 18:45, Carsten Bormann <[email-masked]> wrote:
> 

There are a couple of tickets about this:
https://trac.tools.ietf.org/tools/ietfdb/ticket/1926
https://trac.tools.ietf.org/tools/ietfdb/ticket/2704

spt