Subject: discourage pptx uploads for presentations?

From: Kent Watsen <[email-masked]>
Date: Sat, 27 Jul 2019 21:54:31 +0000

I gave two presentations last week.   For both, I authored the slides using Keynote on a Mac.  For one, the Keynote-exported PDF [1] was uploaded to Materials Manager and, for the other, the Keynote-exported PPTX [2] was uploaded.  

The PDF rendered flawlessly, but the PPTX was garbled rather badly.  This experience makes me wonder why we don't request all slides to be uploaded in PDF format?   AFAIK, PDF has always rendered flawlessly across platforms.

By having the source software do the PDF export, 1) the conversion has the best chance of being accurate, 2) the author has a chance to review the PDF for artifacts before uploading, and 3) IETF can stop supporting PDF convertors (though I don't know if this is a problem of any sort at this time).

PS: yes, I should've known better, but I've been successfully sharing Keynote-export PPTXs with many for awhile now, so I thought the Keynote's PPTX export was stable.  That said, I don't think I've ever shared a Keynote-exported PPTX with anyone running on a Chromebook before.   For all I know, Chromebooks may garble PPTXs produced by PowerPoint as well.

Thoughts?

Kent

[1] https://datatracker.ietf.org/meeting/105/materials/slides-105-netconf-client-server-suite-of-drafts-00 <https://datatracker.ietf.org/meeting/105/materials/slides-105-netconf-client-server-suite-of-drafts-00>
[2] https://datatracker.ietf.org/meeting/105/materials/slides-105-tcpm-yang-groupings-for-tcp-clients-and-tcp-servers-00 <https://datatracker.ietf.org/meeting/105/materials/slides-105-tcpm-yang-groupings-for-tcp-clients-and-tcp-servers-00>

---

From: "John G. Scudder" <[email-masked]>
Date: Sat, 27 Jul 2019 18:14:26 -0400

We normally PDF all the slides we receive, regardless of source format, and display PDF. It works well. We warn authors we will do this, invite them to send in PDF they’ve reviewed themselves for accuracy, and ask them to tell us if they need to use a different format for reasons. 

This last session we accidentally allowed a PPTX to sneak in. It was a minor disaster, because the Chromebook PPTX viewer is apparently, um, not perfect. I believe the deck was saved by Genuine Microsoft PowerPoint, Accept No Substitute, not exported from a different format, and it rendered fine when I checked it on my own laptop, so the finger can be definitively pointed at the Chromebook.

There are occasions where displaying the native format makes sense, notably for animations and builds, which can be quite helpful in explaining packet or event flows. Builds can sometimes be exported to PDF by generating one page per build stage, although I couldn’t figure out how to get PowerPoint to do it this time (maybe the feature died at some point, or maybe only Keynote can do it?). Animations can’t be PDF’d, though. Although we discourage them I’m not prepared to outright refuse their use, since as I said they can actually be useful, but given our experience with the Chromebook PPTX viewer I think I’d ask the presenter to project from their own laptop.

—John

> On Jul 27, 2019, at 5:54 PM, Kent Watsen <[email-masked]> wrote:
> 
> [1] https://datatracker.ietf.org/meeting/105/materials/slides-105-netconf-client-server-suite-of-drafts-00
> [2] https://datatracker.ietf.org/meeting/105/materials/slides-105-tcpm-yang-groupings-for-tcp-clients-and-tcp-servers-00
>

---

From: Kent Watsen <[email-masked]>
Date: Sat, 27 Jul 2019 22:32:37 +0000

> On Jul 27, 2019, at 6:14 PM, John G. Scudder <[email-masked]> wrote:
> 

Good practice but, in this case, I used Datatracker's new presenter self-upload feature...

> There are occasions where displaying the native format makes sense, notably for animations and builds, which can be quite helpful in explaining packet or event flows. Builds can sometimes be export…

Fair, and note the title says "discourage" (not refuse).  Perhaps, if an author attempts to upload a PPTX, a click-thru warning such as the following could be flash?

"PPTX uploads are generally discouraged due to rendering issues on the Chromebooks used by the IETF.   Only for slides containing animations is a PPTX understood to be necessary, in which case authors are strongly encouraged to verify that their slides render correctly on a Chromebook prior to their presentation."

Kent

---

From: "John G. Scudder" <[email-masked]>
Date: Sat, 27 Jul 2019 18:52:10 -0400

> Good practice but, in this case, I used Datatracker's new presenter self-upload feature...

That was how it snuck through for us too. 

—John

---

From: Fred Baker <[email-masked]>
Date: Sat, 27 Jul 2019 16:17:05 -0700

From my perspective, people that send me pots as a presentation format have a reason. The Chromebook presentation machines only use PDF, and the archive is invariably PDF. So Monday, I used the Chromebook and my laptop as presentation machines - PDF on the Chromebook and PPT(X) on my laptop.

I wouldn’t cry if PPTX went away, but to your point, why did you convert one file to PDF and the other to PPTX? I would expect you had a reason, or you would have converted both the same way. So I’m guessing that PPTX was in some way better for one presentation but not the other.

Sent using a machine that autocorrects in interesting ways...

> On Jul 27, 2019, at 2:54 PM, Kent Watsen <[email-masked]> wrote:
> 
>

---

From: Kent Watsen <[email-masked]>
Date: Sun, 28 Jul 2019 00:10:48 +0000

> On Jul 27, 2019, at 7:17 PM, Fred Baker <[email-masked]> wrote:
> 

That sounds painful.  Knowing what I know now, when given a PPTX, I'll ask the presenter to send again the PDF,  unless they need the animations.  That said, I hope to see the self-upload form modified to provide a click-thru warning such as described before.

> I wouldn’t cry if PPTX went away, but to your point, why did you convert one file to PDF and the other to PPTX? I would expect you had a reason, or you would have converted both the same way. So I’…

It was mostly an accident.  To clarify, for both presentations I had exported both PPTX and PDF files.

For one WG, I sent both files to the WG chair as, to be honest, I've never been sure which is preferred format (read: guidance missing) but, thankfully, the chair selected the PDF.  

For the other WG, I thought I'd be clever and use the new Datatracker-upload feature.  I thought I'd get to upload both file, like the draft-submission form (though nowadays I only every upload the XML).  I first selected the PPTX file and then, without giving an option to upload another file, I was on a page that made it seem that the self-upload process was done.  Perhaps I should've used the self-upload form again, but I didn't know what backend confusion that might create, so I decided to play it "safe" and leave it alone (after all, PPTX-export had been working fine for me for a while now).

Hope that helps.

Kent

---

From: Sarah Banks <[email-masked]>
Date: Sat, 27 Jul 2019 21:57:15 -0300

Participants of different levels come into different working groups; PPT is a default for many of us whose company’s pay our way to the IETF, and I’d be hard pressed to ask a user to convert their presentations to make life easier for me as a chair. They shouldn’t have to know, or frankly, care, what a chrome book will or won’t do. If a user sends me particularly crazy ppt then I might have a discussion with them; or convert it myself, and drop a note about the lost animations, but I think we have enough to deal with in a week than to be worried about ppt or pdf.

OTOH, since the IETF doesn’t have a “rule” about PPT/PDF, what and how you chair your WG is your business. I’d still urge you to consider the above, tho.

</2 cents>
Sarah

> On Jul 27, 2019, at 9:10 PM, Kent Watsen <[email-masked]> wrote:
> 
> 
>

---

From: Tommy Pauly <[email-masked]>
Date: Sat, 27 Jul 2019 21:29:54 -0400

Just as another data point, I regularly do request PDFs specifically. While I don't expect presenters to be aware of Chromebook constraints, compatibility with presenter machines and readability for others in the community is a clear benefit, and I've never had a complaint about converting to PDF.

As someone who makes slides in Keynote, and doesn't have Powerpoint, I often find that some Powerpoint formats (especially older ones) render poorly in translation, so any PDF I generate on their behalf is not perfect.

When people need to look at slides from Datatracker in a browser or in the various mobile apps that scrape Datatracker, PDFs are also more convenient and consistent (no out-of app or browser downloads required). That's a benefit for the entire working group, not just the chairs.

Best,
Tommy

> On Jul 27, 2019, at 8:57 PM, Sarah Banks <[email-masked]> wrote:
> 
> On Jul 27, 2019, at 9:10 PM, Kent Watsen <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> 
>> 
>>> On Jul 27, 2019, at 7:17 PM, Fred Baker <[email-masked] <mailto:[email-masked]>> wrote:
>>>

---

From: Stewart Bryant <[email-masked]>
Date: Sun, 28 Jul 2019 09:39:36 +0100

I am not sure if the issue is with the conversion to pdf, or the pdf display devices, or the difference between international paper sizes, or something else, but it is both annoying and distracting that when the presenter presses next (or previous) the display does not correctly align with the intended slide.

Stewart

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 28 Jul 2019 10:52:53 +0200

The problem is with the PDF viewer on Chromebook, which defaults to continuous scroll mode.  The chair has to explicitly press the button for page mode (“full-screen mode”, but that term conflicts with the browser’s full screen mode, which you want to have as well but is unrelated otherwise) in order to make page-wise movement possible.  It is easy to forget this when you already have to juggle with loading and displaying multiple slide decks from a (this week) partially broken datatracker interface.

In groups I help run, we construct a consolidated slide deck with all slides in it, so we don’t have to waste time juggling slide decks.  That has disadvantages, too, but helps a lot in WGs with a dozen or more of agenda items.  Now if the datatracker interface would make it easier to point to the *current* slide deck (as opposed to a specific version), we could easily reload that deck in the middle of the session if updates have come in…  Currently we have to manually change the URL to get a current version, and then page through a couple hundred slides (because this wasn’t a simple reload).  Still faster to do this occasionally for an update than doing the Chromebook dance for each deck…

Grüße, Carsten

> On Jul 28, 2019, at 10:39, Stewart Bryant <[email-masked]> wrote:
> 
>

---

From: Lou Berger <[email-masked]>
Date: Sun, 28 Jul 2019 10:25:36 -0400

I find either format is workable, although I think the PDF converted from 
pptx using the open source tools to be less than satisfactory. As chair, I 
also generally use 365 to display PPTXs so that the clicker works. In the 
one session where we didn't, it was a little annoying to have to advance 
slides for the presenter.

PDF does have the slight advantage of advancing just fine from the IETF 
site when you put it in the presenter mode...

At this point I'm slightly more inclined to focus on the tooling then 
forcing presenters to change their behavior...

Lou

----------
On July 27, 2019 5:55:21 PM Kent Watsen <[email-masked]> wrote:

> I gave two presentations last week.   For both, I authored the slides using 
> Keynote on a Mac.  For one, the Keynote-exported PDF [1] was uploaded to 
> Materials Manager and, for the other, the Keynote-exported PPTX [2] was 
> uploaded.
>
> The PDF rendered flawlessly, but the PPTX was garbled rather badly.  This 
> experience makes me wonder why we don't request all slides to be uploaded 
> in PDF format?   AFAIK, PDF has always rendered flawlessly across platforms.
>
> By having the source software do the PDF export, 1) the conversion has the 
> best chance of being accurate, 2) the author has a chance to review the PDF 
> for artifacts before uploading, and 3) IETF can stop supporting PDF 
> convertors (though I don't know if this is a problem of any sort at this time).
>
> PS: yes, I should've known better, but I've been successfully sharing 
> Keynote-export PPTXs with many for awhile now, so I thought the Keynote's 
> PPTX export was stable.  That said, I don't think I've ever shared a 
> Keynote-exported PPTX with anyone running on a Chromebook before.   For all 
> I know, Chromebooks may garble PPTXs produced by PowerPoint as well.
>
> Thoughts?
>
> Kent
>
> [1] 
> https://datatracker.ietf.org/meeting/105/materials/slides-105-netconf-client-server-suite-of-drafts-00 
> <https://datatracker.ietf.org/meeting/105/materials/slides-105-netconf-client-server-suite-of-drafts-00>
> [2] 
> https://datatracker.ietf.org/meeting/105/materials/slides-105-tcpm-yang-groupings-for-tcp-clients-and-tcp-servers-00 
> <https://datatracker.ietf.org/meeting/105/materials/slides-105-tcpm-yang-groupings-for-tcp-clients-and-tcp-servers-00>
>

---

From: Mary Barnes <[email-masked]>
Date: Sun, 28 Jul 2019 14:09:22 -0500

The problem I dealt with long ago that forced me to stop using Keynote and
buy Office for my Mac is that there are incompatibilities when trying to
import a Keynote saved as powerpoint.  Or even worse if someone is merging
your slides into their slide deck.   It's unfortunate and maybe it's gotten
better since I abandoned Keynote about 8 years ago.

As a chair, I'll take either.

Mary.

On Sun, Jul 28, 2019 at 9:25 AM Lou Berger <[email-masked]> wrote:

> ------------------------------
>
>> I gave two presentations last week.   For both, I authored the slides
>> using Keynote on a Mac.  For one, the Keynote-exported PDF [1] was uploaded
>> to Materials Manager and, for the other, the Keynote-exported PPTX [2] was
>> uploaded.
>>
>> By having the source software do the PDF export, 1) the conversion has
>> the best chance of being accurate, 2) the author has a chance to review the
>> PDF for artifacts before uploading, and 3) IETF can stop supporting PDF

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 28 Jul 2019 16:56:20 -0400

The problem is compounded of: 
-presenting from Chromebook
-pptx
Using any other platform presenting pptx works just fine.
Since Chromebooks are there to stay, it would be logical to change the 2nd element - namely presentation format.
It takes exactly 1 more click to save pptx as a pdf (save as->pdf), it could take 10 minutes to split animation across different slides (tooling is not going to help with that).
My vote is to stick to pdf.

Cheers,
Jeff

> On Jul 28, 2019, at 15:09, Mary Barnes <[email-masked]> wrote:
> 
> The problem I dealt with long ago that forced me to stop using Keynote and buy Office for my Mac is that there are incompatibilities when trying to import a Keynote saved as powerpoint.  Or even worse if someone is merging your slides into their slide deck.   It's unfortunate and maybe it's gotten better since I abandoned Keynote about 8 years ago.  
> 
>> I find either format is workable, although I think the PDF converted from pptx using the open source tools to be less than satisfactory. As chair, I also generally use 365 to display PPTXs so that the clicker works. In the one session where we didn't, it was a little annoying to have to advance slides for the presenter. 
>> 
>> PDF does have the slight advantage of advancing just fine from the IETF site when you put it in the presenter mode...
>> 
>> At this point I'm slightly more inclined to focus on the tooling then forcing presenters to change their behavior...
>> 
>> Lou
>>

---

From: Jim Schaad <[email-masked]>
Date: Sun, 28 Jul 2019 14:04:56 -0700

I find it interesting that I may appear to be In the minority that my pptx presentations contain a great deal more information than what the resulting pdf file will ever result in.  Given that I write my presentations much earlier than the previous day and I do not write presentations that are just read off the screen, I will generally using the notes area for providing myself a much greater degree of information about what I am going to present.  This allows me to do a better job of refreshing what I am going to talk about just before the talk and, if the chairs desire, allows them to get a much better idea of what I plan to say for each of the slides.

In the past I have occasionally given the hint to a chair that when the conversion is done that a version w/o the comments should be used for the presentation but a version with the comments should be posted for inclusion in the proceedings.

Jim

From: WGChairs <[email-masked]> On Behalf Of Mary Barnes
Sent: Sunday, July 28, 2019 12:09 PM
To: Lou Berger <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: discourage pptx uploads for presentations?

Mary. 

On Sun, Jul 28, 2019 at 9:25 AM Lou Berger <[email-masked] <mailto:[email-masked]> > wrote:

Lou

  _____  

On July 27, 2019 5:55:21 PM Kent Watsen <[email-masked] <mailto:[email-masked]> > wrote:

Thoughts?

Kent

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 28 Jul 2019 23:06:04 +0200

On Jul 28, 2019, at 21:09, Mary Barnes <[email-masked]> wrote:
> 
> maybe it's gotten better since I abandoned Keynote about 8 years ago.  

It has.  A couple of years later Apple did a rewrite of Keynote, and Keynote became a very capable powerpoint presenter.  At the same time, Microsoft started shipping a very buggy version of powerpoint, which usually crashed in the middle of a non-trivial presentation (we saw some of these crashes at IETF plenaries…).  So for a while, you definitely wanted to use Keynote for showing powerpoint on a Mac.  Microsoft has then improved the situation, and Apple has had its share of new Keynote bugs (some of which were about embedded PDFs(*)), so the situation maybe was a bit equalized for while.  Keynote has since been fixed, and is again my powerpoint presenter of choice.

So the situation is somewhat fluid.  It is a nice demonstration why single-source, proprietary formats can be problematic.  I haven’t seen a PDF viewer crash in all that time (well, Adobe Reader apparently does, but nobody in their right mind would use that instead of Preview, Skim, or any other of the stellar PDF viewers for macOS).

Of course, people who teach a lot tend to also use more efficient slide generation tools (e.g., markdown-based such as reveal.js or Deckset), and these tend to interface in PDF, which is another reason that I think PDF should remain our primary slide submission format for the foreseeable future.

Grüße, Carsten

(*) Apparently, for a while Apple completely lost control over their PDF renderer OS component, messed up the API and was unable to fix the bugs they introduced.  Well, that is another story…

---

From: Job Snijders <[email-masked]>
Date: Sun, 28 Jul 2019 22:06:17 +0000

Dear all,

I’d recommend we set up the tooling to encourage people to use PDF files as
it is the preferred format. The problem is not just Chromebook, but also
that PowerPoint files don’t always open well in LibreOffice and other
non-Microsoft implementations.

I think a warning in the upload tool would be the right way to nudge people
towards PDF, but if for whatever reason they can’t upload a PDF right now
at least something will be uploaded.

Kind regards,

Job

On Sun, 28 Jul 2019 at 20:56, Jeff Tantsura <[email-masked]> wrote:

> It takes exactly 1 more click to save pptx as a pdf (save as->pdf), it
> could take 10 minutes to split animation across different slides (tooling
> is not going to help with that).
>>> The PDF rendered flawlessly, but the PPTX was garbled rather badly.
>>> This experience makes me wonder why we don't request all slides to be
>>> uploaded in PDF format?   AFAIK, PDF has always rendered flawlessly across
>>> platforms.
>>>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 29 Jul 2019 07:58:47 +0200

On Jul 28, 2019, at 23:04, Jim Schaad <[email-masked]> wrote:
> notes area

Good point.

A professional presentation setup has a separate screen for the speaker that shows current slide, next slide/build, presentation notes, ancillary information such as time now, time started, time left, etc.

I’m assuming this is not attainable in the IETF setting as it would require multiple video outputs from the Chromebook.  The handling with standard applications would also become more complicated (e.g., I don’t think that the in-browser PDF viewer supports a presentation mode).

With that, the remaining value of speaker notes is indeed in rehearsal and communication outside the presentation context; I typically get the latter from a cover letter, and I can rehearse from my slide sources.

Grüße, Carsten

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 29 Jul 2019 13:23:29 +0300

> Using any other platform presenting pptx works just fine.

Not true.

I am using linux on my laptop, and MOST of the pptx files do NOT
render correctly on the libreoffice. The text is there, but formatting
is wrong. I think this happens for example when slide has so many
items that font size is automatically reduced. Same thing happens when
you use libreoffice and save it to pptx.

> It takes exactly 1 more click to save pptx as a pdf (save as->pdf), it could
> take 10 minutes to split animation across different slides (tooling is not
> going to help with that).

Lately in my WGs I have never accepted anything else than PDFs. If I
get pptx, I ask them to resend it in pdf. None of the prensentations
in my WG have been left out because authors were unable to provide PDF
slides :-)

And it does help to say that unless you do provide PDF slides on
time, your item will go away from the agenda...
-- 
[email-masked]

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 29 Jul 2019 08:25:40 -0400

On Sun, Jul 28, 2019 at 6:06 PM Job Snijders <[email-masked]> wrote:
>
> Dear all,
>
> I’d recommend we set up the tooling to encourage people to use PDF files as it is the preferred format. The problem is not just Chromebook, but also that PowerPoint files don’t always open well in LibreOffice and other non-Microsoft implementations.

yes, this.

I don't have anything as a compute device that will open a PPT* file
properly, so the guidance I've given folk who are to be presenting in
grow/sidr/sidrops/iepg is:
  "Send a pdf, if you send ppt I'll convert it and I'm certain you
will be less happy with the result"

Example conversion:
  http://www.iepg.org/2019-07-21-ietf105/notapt.pdf

I don't think it's hard to provide pdf, it's certainly not hard to
present that, and the format is relatively immutable once sent to the
chairs/tooling.
(plus there are readers for pdf on all platforms (save symbianOS?) so
it's relatively assured that what is presented in the room is what the
presenter wanted AND what will be available long term in the archives)
-chris

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 29 Jul 2019 07:26:17 -0700

On Sun, Jul 28, 2019, at 3:06 PM, Job Snijders wrote:
> Dear all,
> 
> I’d recommend we set up the tooling to encourage people to use PDF 
> files as it is the preferred format. The problem is not just 
> Chromebook, but also that PowerPoint files don’t always open well in 
> LibreOffice and other non-Microsoft implementations.

+1

In my (limited) experience, PDFs seem easier to read by WG participants and simple to produce by authors. I've started rejecting PowerPoint slides from presenters simply because I don't have the tooling necessary to create PDF versions myself. (I don't want to produce incorrect slides.)

Best,
Chris

> 
> I think a warning in the upload tool would be the right way to nudge 
> people towards PDF, but if for whatever reason they can’t upload a PDF 
> right now at least something will be uploaded.
> 
> Kind regards,
> 
> Job
> 
> >> On Sun, Jul 28, 2019 at 9:25 AM Lou Berger <lberger@labn..net <mailto:[email-masked]>> wrote:
> >>> On July 27, 2019 5:55:21 PM Kent Watsen <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 29 Jul 2019 11:28:57 -0400

>> LibreOffice and other non-Microsoft implementations.

I'm going to dissent here:

I can support "discourage pptx *only* uploads for presentations". I 
would be ok with requiring pdf but also allowing pptx.

Perhaps I am just not sufficiently skilled with using pdfs for 
presentations, but I find it much more convenient to present pptx (using 
Powerpoint). So if I have both a pptx form of the presentation and 
Powerpoint available I will use that in preference to the pdf form.

I still find the state of pdf tooling to be frustrating. I used to be an 
Acrobat user, and it was very capable (excessively so), but when the 
Adobe tools went to subscription-only I stopped having it. I currently 
use Preview, but it can be frustrating at times. And the Chromebooks 
have something else. If you don't use a Chromebook (or Chrome) 
frequently in presentation mode then it is one more thing to fumble 
through. AFAIK it doesn't have the nice presentation mode that 
Powerpoint has.

	Thanks,
	Paul

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 29 Jul 2019 13:15:07 -0400

> through. AFAIK it doesn't have the nice presentation mode that

1) make pretty presentation in $(TOOL)
2) print to pdf
3) profit

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 29 Jul 2019 13:15:54 -0500

> would be ok with requiring pdf but also allowing pptx.

On this point: am I misremembering that the datatracker used to have a
background job to convert pptx uploads to pdf, giving the option to
download either version?  If I look at (to pick an example that I have
handy) https://datatracker.ietf.org/doc/slides-105-dots-dots-telemetry/
there is only a pptx version available, even now.

Perhaps the new self-upload feature skips the conversion step?

-Ben

P.S. The only way I've found to get to that page just by following links
involves the "edit materials" button only available to chairs/ADs; I kind
of thought there used to be another way to get to it as well.

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 29 Jul 2019 20:21:59 +0200

+1 

Another reason to make sure we maintain the ability to upload pptx
is that when there are multiple co-authors, the pptx is also 
a good option of last resort to have an editable version of the work.
Given how most of presentations are not well organized on github
this is IMHO quite important.

Cheers
    Toerless

On Mon, Jul 29, 2019 at 11:28:57AM -0400, Paul Kyzivat wrote:
> > > I???d recommend we set up the tooling to encourage people to use PDF
> > > Chromebook, but also that PowerPoint files don???t always open well in
> I can support "discourage pptx *only* uploads for presentations". I would be
> ok with requiring pdf but also allowing pptx.
> 
> Acrobat user, and it was very capable (excessively so), but when the Adobe
> tools went to subscription-only I stopped having it. I currently use
> Preview, but it can be frustrating at times. And the Chromebooks have
> something else. If you don't use a Chromebook (or Chrome) frequently in
> presentation mode then it is one more thing to fumble through. AFAIK it
> doesn't have the nice presentation mode that Powerpoint has.
> 
> 	Thanks,
> 	Paul

---

From: Robert Sparks <[email-masked]>
Date: Mon, 29 Jul 2019 15:01:48 -0500

> Perhaps the new self-upload feature skips the conversion step?
Yes, it does. That will get fixed for IETF 106, and we're looking at 
converting what was uploaded for 105 so the pdfs will be available in 
the proceedings.
> of thought there used to be another way to get to it as well.
I'll follow up with you in real-time on this one.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 29 Jul 2019 16:11:22 -0400

Kent Watsen <[email-masked]> wrote:
    > "PPTX uploads are generally discouraged due to rendering issues on the
    > Chromebooks used by the IETF.  Only for slides containing animations is
    > a PPTX understood to be necessary, in which case authors are strongly
    > encouraged to verify that their slides render correctly on a Chromebook
    > prior to their presentation."

The PPTX issues are, as far as I understand, due to font sizes/shapes not
actually being correctly saved in the PPTX.  It sure seems intentional.

As for animations, this exists for LibreOffice:
   https://github.com/monperrus/ExpandAnimations

   ExpandAnimations is a LibreOffice/OpenOffice.org extension to expand
   animations before exporting to PDF. The extension adds a menu entry
   "Tools>>Add-ons>>Expand animations" in Impress. The generated PDF file is
   in the same folder as the source document.

I am told that this is built-in to Keynote, but that's heresay.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Mon, 29 Jul 2019 16:19:31 -0400

> this is IMHO quite important.

If you are in the habit of editing your slides with a presentation
program like MS PowerPoint, Keynote, or LibreOffice Impress, and you
want to upload an editable version that will also be guaranteed to be
presentable, I recommend using LibreOffice's "Hybrid PDF" option from
its "Export as PDF" functionality.

The generated PDF is portable, all fonts included and visible for
rendering on any sensible platform.

And the same file also contains the ODF presentation document itself,
embedded in such a way that a reasonable ODF presentation tool can
extract it and work with it if editing, presenter-view, or other
presentation-program features are needed.

        --dkg

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 30 Jul 2019 11:54:58 -0400

Jim:

John Scudder and I will work with both ppt and pdf in WG.    Since the IETF chrombooks do not do well with anything other than “pdf”, we recommend pdf.  Some speakers really want ppt which must be projected on a laptop besides the chrombooks.  

The materials site always has always pdf – since it can be viewed by all OSes. 

This time our challenge this time came when I automatically accepted a ppt from the datatracker without checking the ppt to pdf translation.    The text came out fine.  The embedded pictures and text did not.    

Sue 

From: WGChairs [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Sunday, July 28, 2019 5:05 PM
To: 'Lou Berger'
Cc: 'Working Group Chairs'
Subject: RE: discourage pptx uploads for presentations?

Jim

Mary. 

Lou

  _____  

On July 27, 2019 5:55:21 PM Kent Watsen < <mailto:[email-masked]> [email-masked]> wrote:

Thoughts?

Kent

---

From: Jim Schaad <[email-masked]>
Date: Tue, 30 Jul 2019 11:59:58 -0700

Sue,

I understand what the problem is.  What I am saying is that if one does the conversion to pdf, even if it is the chair and not an automatic tool, the pdf to be displayed on the screen and the pdf to go into the proceedings may not always be the same depending on how one uses the ppt file format.  Personally I have never done automation because  I don’t want to force going to ppt for a presentation and I think it does not look good when done in pdf.

Tooling should probably make sure that both formats can be updated, potentially require a pdf file to be uploaded, but even then there is no guarantee that the presenter will have checked that things look correct in pdf files.  I have seen presentations from individuals where the pdf that they gave to the chair did not look good.  

Jim

From: Susan Hares <[email-masked]> 
Sent: Tuesday, July 30, 2019 8:55 AM
To: 'Jim Schaad' <[email-masked]>; 'Lou Berger' <[email-masked]>
Cc: 'Working Group Chairs' <[email-masked]>
Subject: RE: discourage pptx uploads for presentations?

Jim:

Sue 

Jim

From: WGChairs <[email-masked] <mailto:[email-masked]> > On Behalf Of Mary Barnes
Sent: Sunday, July 28, 2019 12:09 PM
To: Lou Berger <[email-masked] <mailto:[email-masked]> >
Cc: Working Group Chairs <[email-masked] <mailto:[email-masked]> >
Subject: Re: discourage pptx uploads for presentations?

Mary. 

Lou

  _____  

Thoughts?

Kent

---

From: Brian Rosen <[email-masked]>
Date: Tue, 30 Jul 2019 15:05:42 -0400

I note that on the instructions for chairs in the rooms, there is a set of instructions for importing a pptx into google slides, which at least for the presentations in our meeting, imported flawlessly and displayed just fine on the Chromebook. 

Brian

> On Jul 30, 2019, at 2:59 PM, Jim Schaad <[email-masked]> wrote:
> 
> Sue,
>  
> From: WGChairs [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Jim Schaad
> From: WGChairs <[email-masked] <mailto:[email-masked]>> On Behalf Of Mary Barnes
> To: Lou Berger <[email-masked] <mailto:[email-masked]>>
> Cc: Working Group Chairs <[email-masked] <mailto:[email-masked]>>
> On Sun, Jul 28, 2019 at 9:25 AM Lou Berger <[email-masked] <mailto:[email-masked]>> wrote:

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 30 Jul 2019 22:26:17 +0200

It is a good thing to force contributors to convert themselves to
PDF so they can check the result. It is even better if the tool also
asks for the editable source format (pptx or whatever). Same thing really
as for IETF drafts. Especially pictures from presentations could in the
future become a more relevant reuseable piece for RFCs too (oh well..
;-)

On Tue, Jul 30, 2019 at 11:59:58AM -0700, Jim Schaad wrote:
> Sue,
> 
>  
> 
> I understand what the problem is.  What I am saying is that if one does the conversion to pdf, even if it is the chair and not an automatic tool, the pdf to be displayed on the screen and the pdf to go into the proceedings may not always be the same depending on how one uses the ppt file format.  Personally I have never done automation because  I don???t want to force going to ppt for a presentation and I think it does not look good when done in pdf.
> 
>  
> 
> John Scudder and I will work with both ppt and pdf in WG.    Since the IETF chrombooks do not do well with anything other than ???pdf???, we recommend pdf.  Some speakers really want ppt which must be projected on a laptop besides the chrombooks.  
> 
>  
> 
> The materials site always has always pdf ??? since it can be viewed by all OSes. 
> 
>  
> 

-- 
---
[email-masked]

---

From: Job Snijders <[email-masked]>
Date: Mon, 29 Jul 2019 20:25:38 +0000

> presentation-program features are needed.

Thank you for this hint!

Kind regards,

Job