Subject: Re: Remote participation ( was Leading a moving target)

From: Meetecho IETF support <[email-masked]>
Date: Thu, 1 Aug 2019 11:20:27 +0200

Il 31/07/19 20:42, Michael Richardson ha scritto:
> 
> I don't care that much about video quality (unless I have to lip-read..)
> 
> I care about audio quality, and echo cancellation.

Software echo cancellation is provided by WebRTC browsers and is 
continuously improving. It does help a lot, even though the result may 
not be perfect in very big rooms where there's a lot of reverberation. 
Of course I assume you're talking about echo remote participants may 
hear, as I'm not aware of any echo audible in the meeting room.

> It might be nice to have an option to mute speaker's headphones while they
> are speaking, as often the echo is via the "analog hole" in the meeting room
> itself. [%]

I think this is called half-duplex, and is far from optimal when you 
need real interaction (e.g., Q&A, comments). What we try to do when 
there are remote presentations is to bring down the capture level of the 
laptop which sends audio from the room to Meetecho (we can control that 
from the NOC). This really helps the software echo canceler to be more 
effective and makes the echo barely audible, if any.

A.

> 
> This really matters for non-native English speakers, as we need all the
> fidelity there is in.
> 
> 
> [%]-the solution of course is to remove the acoustic transmission media
>      in the meeting rooms, and do all the meetings in vacuum.
>      This also solves much of the temperature issues in the room.
> 
> Meetecho IETF support <[email-masked]> wrote:
>      > Yeah that was the plan already.
> 
>      > Il 31/07/19 16:04, Andrew G. Malis ha scritto:
>      >> Thanks, I can see that. For the next IETF, could you experiment with
>      >> raising the cap just enough to improve the quality a bit?
>      >>
>      >> Cheers, Andy
>      >>
>      >>
>      >> On Wed, Jul 31, 2019 at 9:56 AM Meetecho IETF support
>      >> <[email-masked] <mailto:[email-masked]>> wrote:
>      >>
>      >> Hi Andy,
>      >>
>      >> as you figured it's not a matter of IETF network bandwidth. It's a
>      >> matter of receiver-side bandwidth. The video sent by a remote
>      >> participant is received by all other participants connected via
>      >> Meetecho. Such participants are already receiving the videos we send
>      >> from the physical room, namely the slides and camera feeds. If we
>      >> don't set a cap, a remote presenter with plenty of bandwidth may send,
>      >> e.g., 2Mbps and overload the others.
>      >>
>      >> The Meetecho team
>      >>
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 1 Aug 2019 11:27:38 +0200

Most of the presentation audio I witnessed at ietf105 was too hot, which also contributes to echo. 

Sent from mobile, sorry for terse

> On 1. Aug 2019, at 11:20, Meetecho IETF support <[email-masked]> wrote:
> 
> Software echo cancellation is provided by WebRTC browsers and is continuously improving. It does help a lot, even though the result may not be perfect in very big rooms where there's a lot of reverberation. Of course I assume you're talking about echo remote participants may hear, as I'm not aware of any echo audible in the meeting room.
> 
> I think this is called half-duplex, and is far from optimal when you need real interaction (e.g., Q&A, comments). What we try to do when there are remote presentations is to bring down the capture level of the laptop which sends audio from the room to Meetecho (we can control that from the NOC). This really helps the software echo canceler to be more effective and makes the echo barely audible, if any.
> 
> A.
>

---

From: Meetecho IETF support <[email-masked]>
Date: Thu, 1 Aug 2019 11:32:56 +0200

Il 31/07/19 23:08, Carsten Bormann ha scritto:
> On Jul 31, 2019, at 20:42, Michael Richardson <[email-masked]> wrote:
>>
> The echo they hear themselves is one point.
> There are also often problems with audio codecs that throttle down when there is other audio incoming.
> 
> We had several presentations with “underwater” audio this week, again; I don’t know whether that effect is related to this issue.  It would be good if there were a way to require a minimum audio quality (G.722 level, at least, well, Apollo 11 would already be great).

WebRTC uses the Opus codec [RFC6716]. As such, there isn't any quality 
issue depending on codec itself. "Underwater" audio may depend on either 
a bad microphone or bad network conditions at the sender side. In this 
latter case, disabling video usually helps. This is why we ask you 
chairs to inform us of remote presentations in proper advance, so that 
we can get in touch with speakers and ask (then remind, then remind 
again...) them to go through our self-test application and send us the 
report it generates. This allows us to spot potential issues, be it a 
bad mike or anything else. Unfortunately it happens that remote 
presentations are arranged through the virtual queue without noticing us 
at all, or that we get _very_ late requests...

A.

> +1000.
> Grüße, Carsten

---

From: Meetecho IETF support <[email-masked]>
Date: Thu, 1 Aug 2019 11:42:10 +0200

Il 31/07/19 23:39, Toerless Eckert ha scritto:
> The main issue is that troubleshooting always takes time and
> ideally someone with more expertise involved. SO you can not and do not
> want to do it in any actual meeting.
> 
> Yada yada: offering some dry run/testing opportunity options would be
> very helpful for remote participants to figure out what the best is they
> can get.

This had been existing for a long time, actually. For example, this is a 
replica of what is made available at IETF meetings:

	https://p0.conf.meetecho.com

If there has been a remote presentation in a WG you chair you should be 
aware of this, as we always copy the chairs to the emails we send 
presenters with instructions and guidelines. If this is not the case, 
please let us know.

A.

> 
> On Wed, Jul 31, 2019 at 11:08:30PM +0200, Carsten Bormann wrote:
>> We had several presentations with ???underwater??? audio this week, again; I don???t know whether that effect is related to this issue.  It would be good if there were a way to require a minimum audio quality (G.722 level, at least, well, Apollo 11 would already be great).
>>

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 1 Aug 2019 14:27:01 +0000

On Aug 1, 2019, at 5:32 AM, Meetecho IETF support <[email-masked]> wrote:
> WebRTC uses the Opus codec [RFC6716]. As such, there isn't any quality issue depending on codec itself. "Underwater" audio may depend on either a bad microphone or bad network conditions at the sender side. In this latter case, disabling video usually helps. This is why we ask you chairs to inform us of remote presentations in proper advance, so that we can get in touch with speakers and ask (then remind, then remind again...) them to go through our self-test application and send us the report it generates. This allows us to spot potential issues, be it a bad mike or anything else. Unfortunately it happens that remote presentations are arranged through the virtual queue without noticing us at all, or that we get _very_ late requests…

I’d like to “+1” the mention here of advance arrangements for speakers. The Meetecho team is very supportive in advance for testing and troubleshooting. I have a fairly small sample set generally in the smaller rooms, but inevitably, the presentations I request in advance (with speakers who actually do the advance testing) go better than the last minute ones… or even worse… the ones that are sometimes via the virtual queue. I am also notoriously bad at requesting speakers in advance… 

Karen

---

From: Michael Richardson <[email-masked]>
Date: Thu, 01 Aug 2019 12:33:05 -0400

> not be perfect in very big rooms where there's a lot of
    > reverberation. Of course I assume you're talking about echo remote
    > participants may hear, as I'm not aware of any echo audible in the
    > meeting room.

yes, often delays of 2-3s are experienced by the speaker, who basically can't
speak, because they hear their own voice.
I appreciate that echo cancellation is getting better, but it's still not
perfect, and when it fails, it's a serious distraction.

    > need real interaction (e.g., Q&A, comments). What we try to do when

I wouldn't have thought to call it half-duplex, but you are right, that's
what it is.  If it's under control of the speaker, call it "lecture mode"
maybe, then it interacts far less with the real interaction.
I found the gamer conferencing, "push to speak" interaction very good when we did
a few virtual IPsec meetings years (15?) ago using teamspeak.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 5 Aug 2019 20:08:05 +0200

> I don't care that much about video quality (unless I have to lip-read..)

You may start to bother about it, once you're fine with audio quality ;-)

> are speaking, as often the echo is via the "analog hole" in the meeting room

Good point.

https://www.ebay.com/itm/Black-U94-PTT-Cable-Military-Adapter-Z113-for-Mobile-Phone-3-5mm-Plug/292414210249?epid=5013354972&hash=item44153ec0c9:g:EC4AAOSw86JaYFHq

I just ordered one to see if it works as i hope, but at least
on airplane PTT, it does mute the speaker when you press PTT.

Cheers
    Toerless

-- 
---
[email-masked]