Subject: Pre-BoF documents and mailing lists

From: "Salz, Rich" <[email-masked]>
Date: Tue, 6 Aug 2019 16:13:09 +0000

The IETF has a non-WG mailing list, WPACK, to discuss web packaging.  There is some chatter going on about a document to serve as input to the WG-forming BoF that seems likely to happen, probably in Singapore.  That document is at https://docs.google.com/document/d/1OUZcl6yQSJ5eZxMrbo6O2tVRW_U_bv0PZUxAVtR1GYA/edit?ts=5d48cada&pli=1

Jeffrey Yasskin started an initial problem statement and scope for the WG, and hopes to create a charter, email message at https://mailarchive.ietf.org/arch/msg/wpack/ctrnRXXda2X6z0Z6creNcTQX9AM

I posted some feedback on the list.  It appears that most work is being done directly on the Google doc as comments/suggestions, etc.  Not on the mailing list.  The document says the “Note well” applies.  Does the IETF practice of use the mailing list also apply? I looked through IETF list archives and couldn’t find the responsible AD to ask them.

---

From: Melinda Shore <[email-masked]>
Date: Tue, 6 Aug 2019 08:59:58 -0800

On 8/6/19 12:13 PM, Salz, Rich wrote:
> I posted some feedback on the list.  It appears that most work is being
> done directly on the Google doc as comments/suggestions, etc.  Not on
> the mailing list.  The document says the “Note well” applies.  Does the
> IETF practice of use the mailing list also apply? I looked through IETF
> list archives and couldn’t find the responsible AD to ask them.

Arguably this might be something like a design team, and ultimately
if they do ask to be chartered they'll need to go through that process.
So while I don't love this I think it's legit.

Melinda

-- 
Software longa, hardware brevis

PGP key fingerprint  4F68 2D93 2A17 96F8 20F2
                     34C0 DFB8 9172 9A76 DB8F

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 6 Aug 2019 13:22:51 -0400

I am glad to hear that they are explicitly indicating the applicability 
of "Note Well".

Formally, as I understand it a pre-BoF activity can be organized and 
undertaken any way the participants want.  It is usually a good idea to 
use the email list, as that will reach more interested people, thus 
building the support that is needed.  Also, ADs often look for email 
discussion and activity as an indicator of community interest before 
sponsoring a BoF.

So as I understand the rules, no the folks do not have to use the email 
list.  Doing so would still seem a very good idea.

Yours,
Joel

On 8/6/2019 12:13 PM, Salz, Rich wrote:
> The IETF has a non-WG mailing list, WPACK, to discuss web packaging.  
> There is some chatter going on about a document to serve as input to the 
> WG-forming BoF that seems likely to happen, probably in Singapore. That 
> document is at 
> https://docs.google.com/document/d/1OUZcl6yQSJ5eZxMrbo6O2tVRW_U_bv0PZUxAVtR1GYA/edit?ts=5d48cada&pli=1
> 
> Jeffrey Yasskin started an initial problem statement and scope for the 
> WG, and hopes to create a charter, email message at 
> https://mailarchive.ietf.org/arch/msg/wpack/ctrnRXXda2X6z0Z6creNcTQX9AM
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 6 Aug 2019 11:08:39 -0700

On Aug 6, 2019, at 10:22 AM, Joel M. Halpern <[email-masked]> wrote:
> So as I understand the rules, no the folks do not have to use the email list.  Doing so would still seem a very good idea.

I would agree. I'll also note, though, that people seem to be using GitHub as a means of discussing documents, and that without the use of the list. My principal comment isn't that it's "wrong" or "untraditional"; it's that it means that there is no one place people can refer to that contains all of the discussions, or all of any particular one. To me, that's troublesome; I might review thoughts in one context, add a thought, and be told "yeah, but that's all wrong; this discussion is happening somewhere else." That's my biggest concern with the GitHub model. 

As a working group chair, I review threads related to a document before sending it to my AD, and in the process of deciding whether it belongs on my agenda. Now I have no way to know whether I have reviewed all of the threads, or whether I have - or lack - consensus around a topic. When talking with newcomers about a working group, I point them to that list of threads (https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-name%22") and ask them to be familiar with them. What ONE place do I point them to?

From my perspective, I would like to have ONE repository with all of the discussions.  The mailing list has historically provided that, and if we have a new one to recommend, so be it. But an open-ended and unspecified set makes that job pretty hard.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 6 Aug 2019 18:20:13 +0000

>    I would agree. I'll also note, though, that people seem to be using GitHub as a means of discussing documents, and that without the use of the list.

I don't want the thread to migrate, but I will point out that GitHub doesn't make commentary "vanish" when something is resolved, and that discussion of that topic is happening over on the IETF list.

---

From: Fred Baker <[email-masked]>
Date: Tue, 6 Aug 2019 11:29:46 -0700

> On Aug 6, 2019, at 11:20 AM, Salz, Rich <[email-masked]> wrote:
> 

True, but (and respecting your desire for the topic to not wander - I actually think it's the same topic or at least related) if I'm following the IETF list, I have no clue that there might be a related topic somewhere in GitHub (where in GitHub, specifically? Is that one place?), or in some random Google Doc, or that there was one in the past that I should read through.

There are at least two conversations, which might have disjoint sets of participants, unaware of each other, looking at the same or different data, and arriving at potentially diametrically opposed viewpoints, each of which is held in consensus among some set of people.

What I think I would want is one set of threads that is "master", and to which other threads are mirrored if necessary. I want to be able to follow or investigate a topic without having to become a forensic pathologist or archeologist.

I'm also related to RSSAC. We use Google Docs extensively in RSSAC. The difference is that our different conversational threads are explicitly different - the conversation about a given document *all* happens in that document, and if there is a related email exchange, it refers to the document.

---

From: Jim Fenton <[email-masked]>
Date: Wed, 7 Aug 2019 10:36:55 -0700

On 8/6/19 11:29 AM, Fred Baker wrote:
> True, but (and respecting your desire for the topic to not wander - I
> actually think it's the same topic or at least related) if I'm
> following the IETF list, I have no clue that there might be a related
> topic somewhere in GitHub (where in GitHub, specifically? Is that one
> place?), or in some random Google Doc, or that there was one in the
> past that I should read through. 

A number of years ago, the DKIM WG used an instance of rt (rt.psg.com)
to track issues on documents. rt.psg.com isn't around any more. I think
we did a fairly good job of keeping the discussion on the mailing list,
but we have lost some of the record, and everything wasn't on the
mailing list.

I'm not sure if this is an argument for or against the current and
anticipated use of GitHub as an issue tracker, but it seems like
relevant history.

-Jim

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 14:03:19 -0400

> anticipated use of GitHub as an issue tracker, but it seems like

Another argument (AFAIC) for keeping WG decisions and issue tracking on
IETF-maintained lists or servers, or at the very least mirroring any
off-list discussion, issue tracking, or document updates on the WG list as
well.

More seriously, github.com is a DDOS and other bad actor magnet, and also
subject to (perhaps ruinous, at the whim of the courts) lawsuits or
(perhaps ruinous, at the whim of Congress) legislation. And even if
Microsoft is the current owner and has deep pockets, there's no guarantee
that will continue, or that they will continue to operate it with a light
touch.

Cheers,
Andy

---

From: Ted Hardie <[email-masked]>
Date: Mon, 12 Aug 2019 11:55:45 -0700

On Tue, Aug 6, 2019 at 11:20 AM Salz, Rich <[email-masked]> wrote:

> >    I would agree. I'll also note, though, that people seem to be using
> GitHub as a means of discussing documents, and that without the use of the
> list.
>
> I don't want the thread to migrate, but I will point out that GitHub
> doesn't make commentary "vanish" when something is resolved, and that
> discussion of that topic is happening over on the IETF list.
>
>
Google docs has both a version history and a comment history.  The comment
history is seen by clicking the icon that looks like a speech bubble, next
to the share button.  The version history is seen by using the File menu's
"Version history" selector.   You can delete the full set of comments on
making a copy, but that changes the URL of the doc.

regards,

Ted