Subject: Re: Minutes being messed with?

From: Bob Hinden <[email-masked]>
Date: Tue, 6 Aug 2019 08:33:16 -0700

In 6man, as I suspect in most other w.g.’s, the minute takers use Etherpad to take the raw minutes.   It's a problem, if others can rewrite it during or after the fact.

For the purpose of producing w.g. minutes, it would be nice to be able to lock its write access to the minute takers.   We usually know who they are in advance.

Is this possible in Etherpad?   That is, limit write access while allowing everyone else to have read access.

I note that Etherpad has the ability to show users, this is helpful, but since there is no login, doesn’t solve the problem.

Suggestions?

Bob

p.s. I note the parallels here with the issues we see on the Internet.  A tools that works great for a set of users who are aligned, but then it breaks when you get other users who have other intents.  Sigh...

> On Jul 31, 2019, at 1:45 AM, [email-masked] wrote:
> 
> Hi,
> 
> I agree with Patrick on this. I'm among those people who are reluctant
> to create accounts on websites, especially if:
> - creating the account is more effort/out-of-context action than the
> info I was about to share/get (our case here),
> - the 1st benefit is mainly to the system and barely to me (our case
> here too).
> If I didn't already have a datatracker account, I wouldn't mind using an
> anonymous "edit" button but I would certainly not create an account just
> to update my speaker name in Etherpad...
> 
> Julien
> 
> 
> On 29/07/2019 17:59, Patrick McManus wrote:
>> please don't add a datatracker login to the etherpad requirements - it
>> is already hard enough to find people to take minutes.
>> 
>> however an anonymous "click to edit" button would do fine and likely
>> prevent this from accidentally happening without breaking the no-doubt
>> useful translation feature being used.
>> 
>> On Mon, Jul 29, 2019 at 11:54 AM Henrik Levkowetz
>> <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>>    On 2019-07-29 17:30, Jim Fenton wrote:
>>> On 7/29/19 1:06 AM, Van De Velde, Gunter (Nokia - BE/Antwerp) wrote:
>>>> Yep, they were swapped, while I was typing.. it confused the
>>    heck out of me .
>>> 
>>> If this is disrupting things, and it sounds like it is, perhaps
>>    Etherpad
>>> should require a Datatracker login in order to edit. That would
>>    at least
>>> provide some accountability, and we would know who we need to
>>    "coach".
>> 
>>    Yes, this has been my conclusion from the thread so far.
>> 
>>            Henrik
>> 
>>> I missed the ADD BOF, so I tried looked at Etherpad afterwards
>>    and it
>>> was a bunch of Cyrillic text. Glad to know about the history slider!
>>> 
>>> -Jim
>>> 
>>> 
>>> 
>> 
> 
> 
> _________________________________________________________________________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Aug 2019 18:06:40 +0200

> For the purpose of producing w.g. minutes, it would be nice to be able to lock its write access to the minute takers.   We usually know who they are in advance.

It is probably more than enough to limit write access to people with datatracker accounts.

This is a little like wikipedia, where everyone can make a change, but destructive changes are quickly backed out.  Freezing isn’t really necessary, as you can always rewind to the end of the meeting (but then, people do correct mistakes afterwards).

(I repeat my suggestion to have a look at hackmd/codimd as an Etherpad replacement.  It sure works for our students.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 6 Aug 2019 18:13:36 +0200

Hi Carsten,

> (I repeat my suggestion to have a look at hackmd/codimd as an Etherpad replacement.  It sure works for our students.)

I've noted this, but you should know that the etherpad is now being
maintained by the Secretariat, so this is not something I can go and
just fix (the way I could in the past).  Glen has his first vacation
week in about 42 weeks right now, but if you'll mention this to him
next week, it would be good.

Best regards,

	Henrik

---

From: Bob Hinden <[email-masked]>
Date: Wed, 7 Aug 2019 08:58:51 -0700

> On Aug 6, 2019, at 9:06 AM, Carsten Bormann <[email-masked]> wrote:
> 

I support that.   We can then see if that solves the problem.

Bob

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 7 Aug 2019 16:21:46 +0000

>    I support that.   We can then see if that solves the problem.
 
It looks like a simple matter of programming :)  Etherpad already supports a read-only access, and an oauth plugin, and there's a ticket to add it to datatracker, https://trac.tools.ietf.org/tools/ietfdb/ticket/2749 if anyone has that mythical "copious free time."

---

From: Jim Fenton <[email-masked]>
Date: Wed, 7 Aug 2019 09:31:46 -0700

> It looks like a simple matter of programming :)  Etherpad already supports a read-only access, and an oauth plugin, and there's a ticket to add it to datatracker, https://trac.tools.ietf.org/tools/…
Someone had expressed concern that requiring a datatracker login would
make it harder to recruit notetakers. I had expected that most attendees
who are likely notetakers already have datatracker accounts.

Does anyone know if that concern is warranted?

-Jim

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 7 Aug 2019 17:23:14 +0000

> Does anyone know if that concern is warranted?

I've taken notes together with a person who has no datatracker account (that I know of) and (to my knowledge) has never physically attended IETF or submitted an ID. They were on Meetecho. They helped several times (multiple IETF meetings) for this specific WG. I don't think they do other WGs. It's a very small WG, with about 20 people in the room and a similar number on Meetecho. It was a big help -- especially when I got up to present.
I often experience people filling in names and correcting spelling or better expressing things that were said while I'm taking minutes. This is really helpful.

I tend to take minutes for 3 or 4 different WGs every IETF (including Bob's 6man WG, FWIW). Always on etherpad, if possible. Because of my good experience with random people helping on minutes, I'd prefer not to limit to datatracker accounts. It would be nice if people on etherpad were encouraged to put their name in etherpad (maybe encouraged by chairs at start of meeting, when mentioning notetaking). That way I might also have the ability to glare at somebody if they were doing something that interfered with notetaking. I've never had issues with people doing malicious or hard-to-recover-from bad things while I'm taking minutes. I have sometimes made etherpad notes to unknown etherpad people to suggest they do something differently or don't do something (and then delete the note after they ack). I'd like the option of using glares directed at known people, too.
Barbara

---

From: Sandra Murphy <[email-masked]>
Date: Wed, 7 Aug 2019 13:36:07 -0400

> On Aug 7, 2019, at 12:31 PM, Jim Fenton <[email-masked]> wrote:
> 

I had a similar thought about barriers.  How many ietf attendees have datatracker accounts?  (could be that only the number of datatracker accounts is known.)  what is the process for getting an account?  (if it is automated and responds quickly, the barrier is small).

but - why does the minute taker having a datatracker account make anyone feel better?  I’ve lost track - what problem does having a datatracker account solve?

---

From: Jim Fenton <[email-masked]>
Date: Wed, 7 Aug 2019 10:43:13 -0700

On 8/7/19 10:36 AM, Sandra Murphy wrote:
> I had a similar thought about barriers. How many ietf attendees have
> datatracker accounts? (could be that only the number of datatracker
> accounts is known.) what is the process for getting an account? (if it
> is automated and responds quickly, the barrier is small). 

I can't remember quite what is involved, but you can go to
datatracker.ietf.org/accounts/create and try it out :)

> but - why does the minute taker having a datatracker account make anyone feel better?  I’ve lost track - what problem does having a datatracker account solve?

We had a situation where some of the WG notes were overwritten,
apparently by translations into other languages. This raised the
awareness that it would be possible for a malicious user to interfere
with notetaking in this way, particularly if it is done during the
meeting (making it harder to revert the changes). Requiring a
datatracker login would add accountability.

-Jim

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 13:44:05 -0400

Sandy,

but - why does the minute taker having a datatracker account make anyone
feel better?  I’ve lost track - what problem does having a datatracker
account solve?

If someone (for example) accidentally replaces the Etherpad minutes with a
foreign language translation, there would be traceability as to who did it,
so we can ask them nicely to not do that again. Or it could be prevented in
the first place if it was a non-IETFer without a datatracker account that
accidentally destructively did the translation.

Cheers,
Andy

On Wed, Aug 7, 2019 at 1:36 PM Sandra Murphy <[email-masked]> wrote:

> >> It looks like a simple matter of programming :)  Etherpad already
> supports a read-only access, and an oauth plugin, and there's a ticket to
> add it to datatracker,
> https://trac.tools.ietf.org/tools/ietfdb/ticket/2749 if anyone has that
> mythical "copious free time."
> >>
> >>
> accounts is known.)  what is the process for getting an account?  (if it is
> automated and responds quickly, the barrier is small).
>
> but - why does the minute taker having a datatracker account make anyone
> feel better?  I’ve lost track - what problem does having a datatracker
> account solve?
>
> >
> > -Jim
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 14:44:33 -0400

Linda,

If you click the clock icon in the upper right, you get a time slider that
allows you to go back change by change all the way to the blank page at at
the start if you like, or anywhere in-between. So yes, the page can be
recovered. It would still be nice to not have to, though.

Cheers,
Andy

On Wed, Aug 7, 2019 at 1:50 PM Linda Dunbar <[email-masked]>
wrote:

> What can be done if someone accidentally highlight the entire content of
> Etherpad and clicked CUT (instead of COPY) when they want to copy the
> content to their Note on their local device?  Instead of click the Back
> Button on the Etherpad, they click the Back Button on the website, then
> everything is lost. Is there anyway to retrieve the content?
>
>
>
> Linda
>
>
>
> *From:* WGChairs <[email-masked]> *On Behalf Of *Andrew G.
> Malis
> *Sent:* Wednesday, August 07, 2019 12:44 PM
> *To:* Sandra Murphy <[email-masked]>
> *Cc:* IETF WG Chairs <[email-masked]>
> *Subject:* Re: [irsg] Minutes being messed with?
>
>
>
> Sandy,
>
>
>
> https://trac.tools.ietf.org/tools/ietfdb/ticket/2749
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.tools.ietf.org%2Ftools%2Fietfdb%2Fticket%2F2749&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cd26f725a4b5a4fe703a108d71b5ee98f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637007966781088570&sdata=m8SmmZYkjss2KeUE%2FCaxA34m2bss4SrE5vnzt3FZeyE%3D&reserved=0>
> if anyone has that mythical "copious free time."
> >>
> >>

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 7 Aug 2019 17:50:10 +0000

What can be done if someone accidentally highlight the entire content of Etherpad and clicked CUT (instead of COPY) when they want to copy the content to their Note on their local device?  Instead of click the Back Button on the Etherpad, they click the Back Button on the website, then everything is lost. Is there anyway to retrieve the content?

Linda

From: WGChairs <[email-masked]> On Behalf Of Andrew G. Malis
Sent: Wednesday, August 07, 2019 12:44 PM
To: Sandra Murphy <[email-masked]>
Cc: IETF WG Chairs <[email-masked]>
Subject: Re: [irsg] Minutes being messed with?

Sandy,

If someone (for example) accidentally replaces the Etherpad minutes with a foreign language translation, there would be traceability as to who did it, so we can ask them nicely to not do that again. Or it could be prevented in the first place if it was a non-IETFer without a datatracker account that accidentally destructively did the translation.

Cheers,
Andy

On Wed, Aug 7, 2019 at 1:36 PM Sandra Murphy <[email-masked]<mailto:[email-masked]>> wrote:

> On Aug 7, 2019, at 12:31 PM, Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:
>
>> It looks like a simple matter of programming :)  Etherpad already supports a read-only access, and an oauth plugin, and there's a ticket to add it to datatracker, https://trac.tools.ietf.org/tools/ietfdb/ticket/2749<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.tools.ietf.org%2Ftools%2Fietfdb%2Fticket%2F2749&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cd26f725a4b5a4fe703a108d71b5ee98f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637007966781088570&sdata=m8SmmZYkjss2KeUE%2FCaxA34m2bss4SrE5vnzt3FZeyE%3D&reserved=0> if anyone has that mythical "copious free time."
>>
>>

---

From: Fred Baker <[email-masked]>
Date: Wed, 7 Aug 2019 12:46:16 -0700

I think the concern is unwarranted. First, those willing to take notes in my WG have the requisite login; second, those who want to take notes are not trying to hide.  

From my perspective, "give me a break". 

> On Aug 7, 2019, at 9:31 AM, Jim Fenton <[email-masked]> wrote:
>

---

From: Fred Baker <[email-masked]>
Date: Wed, 7 Aug 2019 13:00:09 -0700

To be very honest, this email is surprising.

> On Aug 7, 2019, at 10:36 AM, Sandra Murphy <[email-masked]> wrote:
> 

The issue is access to datatracker, whether for minutes or any other purpose. A service without access controls is a service with spam and all that. 20 years ago, I told those that thought that Internet Email distribution of Advertising Services that it was a bad idea. We now have International law regarding them and ISC discussion lists regarding the problems they cause. 

Now, the only thing I have to say is "I told you so" -and implement an ad blocker, purchase access services from some one that claims to block them, and in my own home, block them. 

Imagine, if you will, that in a standards meeting with 100 people present, one records the discussion and 199 record what they wish it was, and we had to accept all of them as faithful recordings of the proceedings, even if they didn't pass the ultra-low bar of identifying themselves.

And now, explain to me, in detail, why asking people to identify themselves when recording the discussions of a standards group is a bad idea?

Good grief.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Aug 2019 22:18:42 +0200

> And now, explain to me, in detail, why asking people to identify themselves when recording the discussions of a standards group is a bad idea?

When we have trouble finding people for some task, we try to reduce the threshold involved in performing that task.  I think the missing data here is how many IETFers actually have a datatracker account (and are using it often enough so they will remember it when they are asked to take notes).  That data would allow us to assess whether asking for a datatracker login would create a counterproductive threshold for many candidate note takers.

Grüße, Carsten

---

From: Sandra Murphy <[email-masked]>
Date: Wed, 7 Aug 2019 17:35:33 -0400

> On Aug 7, 2019, at 1:43 PM, Jim Fenton <[email-masked]> wrote:
> 

have one or two.  wouldn’t be a good test.

> datatracker login would add accountability.

OK, the problem solved is the deliberate attempt to “mess with” the minutes, not the accidental user slip-up.

In that case, I’d say the datatracker account process is too friendly to prevent or add accountability:

Please enter your email address in order to create your datatracker account.

Your email (lowercase)

<click on> Create account

Of course, there could be an involved vetting process behind that "Create account", but I don’t think so.

—Sandy

---

From: Sandra Murphy <[email-masked]>
Date: Wed, 7 Aug 2019 17:40:15 -0400

> On Aug 7, 2019, at 5:35 PM, Sandra Murphy <[email-masked]> wrote:
> 

I forgot to add: and looks too friendly to present a barrier to someone who was willing to take notes but lacked an account.

—Sandy

---

From: Robert Sparks <[email-masked]>
Date: Thu, 8 Aug 2019 09:11:41 -0500

Hi Carsten -

A _very rough_ look into what the datatracker has data for says that 
somewhere around 40% of the folks that registered for IETF105 have 
logged into the datatracker this year.

RjS

---

From: Bob Hinden <[email-masked]>
Date: Thu, 8 Aug 2019 07:32:05 -0700

Barbara,

> On Aug 7, 2019, at 10:23 AM, STARK, BARBARA H <[email-masked]> wrote:
> 
> I tend to take minutes for 3 or 4 different WGs every IETF (including Bob's 6man WG, FWIW). Always on etherpad, if possible. Because of my good experience with random people helping on minutes, I'd prefer not to limit to datatracker accounts. It would be nice if people on etherpad were encouraged to put their name in etherpad (maybe encouraged by chairs at start of meeting, when mentioning notetaking).

Instead of a datatracker login, how about using ones IETF registration info?  I assume everyone at the meeting (local and remote) has that.

Bob

> That way I might also have the ability to glare at somebody if they were doing something that interfered with notetaking. I've never had issues with people doing malicious or hard-to-recover-from bad things while I'm taking minutes. I have sometimes made etherpad notes to unknown etherpad people to suggest they do something differently or don't do something (and then delete the note after they ack). I'd like the option of using glares directed at known people, too.
> Barbara

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 8 Aug 2019 11:12:02 -0400

Bob,

Instead of a datatracker login, how about using ones IETF registration
info?  I assume everyone at the meeting (local and remote) has that.

That's a great suggestion, since that's the same credential that you use
for Meetecho, and you can already invoke Etherpad from Meetecho.

Cheers,
Andy

---

From: Bob Hinden <[email-masked]>
Date: Thu, 8 Aug 2019 09:33:47 -0700

Andy,

> On Aug 8, 2019, at 8:12 AM, Andrew G. Malis <[email-masked]> wrote:
> 
> Bob,
> 
> That's a great suggestion, since that's the same credential that you use for Meetecho, and you can already invoke Etherpad from Meetecho.
> 

Thanks.

Also, to clarify, this would only be for write access.   Read-only shouldn’t need any credentials.   I think this extra step would avoid overwriting by mistake.

Bob

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 8 Aug 2019 18:53:44 +0200

On Aug 8, 2019, at 16:11, Robert Sparks <[email-masked]> wrote:
> 
> Hi Carsten -
> 
> A _very rough_ look into what the datatracker has data for says that somewhere around 40% of the folks that registered for IETF105 have logged into the datatracker this year.

Thank you, Robert.

At first, I thought that number was surprisingly low, but then, I notice that I’m using datatracker all the time but only log in for “leadership” things.  Since about a third of the people at an IETF might be considered “leadership” in some form, the number actually is about right.

So maybe the IETF registration number is better for that.  Also, people have that with them (and can type it from their badge in a pinch).

I’m still not convinced the solution (adding more threshold) is better than the problem (accidentally overwritten notes that can easily be reverted), but at least we now seem to know a good way to improve the situation.

(I personally wouldn’t mind having to make the intention to write explicit.
This would also help with the color to note-taker mapping.)

Grüße, Carsten

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 8 Aug 2019 19:33:51 +0000

> somewhere around 40% of the folks that registered for IETF105 have logged
> into the datatracker this year.
> 
> Thank you, Robert.
> 
> At first, I thought that number was surprisingly low, but then, I notice that
> I’m using datatracker all the time but only log in for “leadership” things.  Since
> about a third of the people at an IETF might be considered “leadership” in
> some form, the number actually is about right.
> 
> So maybe the IETF registration number is better for that.  Also, people have
> that with them (and can type it from their badge in a pinch).
> 
> I’m still not convinced the solution (adding more threshold) is better than the
> problem (accidentally overwritten notes that can easily be reverted), but at
> least we now seem to know a good way to improve the situation.
> 

When I've used Meetecho (to watch and not present, which is what most Meetecho people do), I don't remember ever logging in. Do people have to log in? It's been a while for me. I do see some people registering as remote attendees, but I get the sense there are a whole lot of people on Meetecho who aren't registered. Having to search for my IETF registration number before taking minutes would add some additional setup time for me (I usually do a search in my inbox for something like "IETF registration" and manually scan the 100 or so results for the one from "[email-masked]"). And the device I take minutes on isn't always one with access to my email account -- so I would have to manually type the number found in one device to the Etherpad in the other. I've found connections to Etherpad go up and down a lot, and they go up and down more when I'm going through the corporate VLAN. I hope any logging in mechanism would allow the same person to be logged in multiple times. Sometimes I do have to use the corporate laptop without the VPN (instead of the personal laptop) because it has more robust Wi-Fi.

Honestly, I'd prefer to just experiment with notetaker (me, or any other notetaker in a different WG) asks chair at start of meeting to ask people on Etherpad to put their name in. See how many people do and how many don't. It seems really easy and presents no barrier. I notice part of Etherpad history has the names (or not) of all who typed something. So maybe it would be possible to draw statistics from WGs that participated in this experiment. 

I'd prefer not to over-solve this problem. 
Barbara

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 8 Aug 2019 19:40:25 +0000

[ As the person who started this thread... ]

There is a good chance that the (temporary) damage happened after the meeting. Thus, knowing this in advance, I might export the results at the end of the meeting.

Even if I don't, as long as the history function works, I can alway reverse the damage.

Given that, I don't see any good reason for the proposed premature optimizations.

--Paul Hoffman

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 8 Aug 2019 16:34:06 -0400

Barbara,

When I've used Meetecho (to watch and not present, which is what most
Meetecho people do), I don't remember ever logging in. Do people have to
log in?

You have to log in (using your IETF registration number)  if you wish to be
a remote participant (as opposed to observer). Logging in adds you to the
remote blue sheet and gives you the ability to raise your hand and speak
remotely, and type into Jabber. Otherwise it's just watch only.

If you accept cookies in your browser, you only need to log in the first
time you use it for a particular IETF meeting, and Meetecho remembers you
for subsequent sessions.

Cheers,
Andy

On Thu, Aug 8, 2019 at 3:40 PM Paul Hoffman <[email-masked]> wrote:

> There is a good chance that the (temporary) damage happened after the
> meeting. Thus, knowing this in advance, I might export the results at the
> end of the meeting.
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 9 Aug 2019 08:29:53 +0000

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Paul
> Hoffman
> Sent: Thursday, August 8, 2019 3:40 PM
> To: [email-masked]
> Subject: Re: [Ext] [irsg] Minutes being messed with?
> 
[acm] 
There was an unfortunate Etherpad crash during one set of sessions
some years back - that experience caused me to occasionally scrape the 
screen to a text file while taking minutes, and periodically asking
my minute-takers to scrape as well. 

(Status of the built-in history recall unknown after recovery 
in connection with this one failure instance.)

> Given that, I don't see any good reason for the proposed premature
[acm] 
If the over-writes were accidental, registered participants 
may have performed them, so I tend to agree with Paul and Barbara.

Al

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 9 Aug 2019 11:13:13 +0000

> > meeting. Thus, knowing this in advance, I might export the results at
> > the end of the meeting.
> >
> There was an unfortunate Etherpad crash during one set of sessions some
> years back - that experience caused me to occasionally scrape the screen to a
> text file while taking minutes, and periodically asking my minute-takers to
> scrape as well.
> 
> (Status of the built-in history recall unknown after recovery in connection
> with this one failure instance.)
> 
> >
> If the over-writes were accidental, registered participants may have
> performed them, so I tend to agree with Paul and Barbara.

My personal "best" practices are to click the star on Etherpad at the very end of a session so it marks a specific point in the history, and to immediately copy the contents and email them to the chairs. If I think they need refining or there's a 2nd session still coming (so I don't want to email them to the chairs right away), I'll save a copy to a local text file. Just in case.
Barbara