Subject: Support (as co-author)

From: Benoit Claise <[email-masked]>
Date: Mon, 25 Nov 2019 16:09:44 +0100

Dear all,

Along the years, I witnessed a trend, which intensifies with time: "I 
support the adoption of this draft (as a co-author)."
Well, if someone is a co-author, implicitly this person wants the draft 
to progress. Therefore, such as message carries no weight IMO.
Is it time for the WG chairs to start correcting this behaviour, or at 
least setting the right expectations?

ex: 
https://mailarchive.ietf.org/arch/browse/ippm/?q=Adoption%20Call%20for%20draft-ioamteam-ippm-ioam-direct-export

Regards, Benoit

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 25 Nov 2019 10:27:34 -0500

Benoit,

In some WGs, I have seen the chairs ask for explicit declarations of
support for adoption or last call, including from co-authors. In such a
case, it make sense for a co-author to identify themself as such.

Cheers,
Andy

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 25 Nov 2019 15:38:11 +0000

This has been my experience, too – that chairs were asking authors to explicitly express support.
Barbara

From: WGChairs <[email-masked]> On Behalf Of Andrew G. Malis

Benoit,

In some WGs, I have seen the chairs ask for explicit declarations of support for adoption or last call, including from co-authors. In such a case, it make sense for a co-author to identify themself as such.

Cheers,
Andy

On Mon, Nov 25, 2019 at 10:10 AM Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

ex:
https://mailarchive.ietf.org/arch/browse/ippm/?q=Adoption%20Call%20for%20draft-ioamteam-ippm-ioam-direct-export<https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_browse_ippm_-3Fq-3DAdoption-2520Call-2520for-2520draft-2Dioamteam-2Dippm-2Dioam-2Ddirect-2Dexport&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=z74Kntk3UE7Lz-yMzb_gYdzVfwgbYTHVkF9DWr8oIyY&s=Km3cxFj72cpLtc1NoB4d-WM6ELlMlAm6_b0-J-Ajsc4&e=>

Regards, Benoit

---

From: <[email-masked]>
Date: Mon, 25 Nov 2019 16:52:23 +0100

Hi Benoît,

I agree with you that, in the ideal world, being a co-author implies
being a supporter and that a "support as co-author" doesn't have the
exact same value as a support by someone else. However, as Andy
suggests, an explicit support expressed by a co-author at adoption or WG
LC time may help distinguishing:
- co-authors who just approved the use of their (company) name vs. those
who actually follow (at least) the key steps of the documents;
- co-authors who no longer care about a given work their used to be
interested in (e.g., when reaching WG LC) vs. those who still believe is
needs to progress.
What is more, having co-authors involved in a support thread on mailing
lists is also a way to attract readers and trigger responses from other
WG members.

My 2 cents,

Julien

On 25/11/2019 16:27, Andrew G. Malis wrote:
> support for adoption or last call, including from co-authors. In such
> a case, it make sense for a co-author to identify themself as such.
>
> Cheers,
> Andy
>
>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Fatai Zhang <[email-masked]>
Date: Mon, 25 Nov 2019 16:12:32 +0000

I fully agree with Julien.

At least, a co-author (and a contributor) as a WG member has the right to voice his/her support.

If it does not require the co-authors (and contributors) to respond the WG adoption, there might be quiet on the list (e.g.,no one shows support, but there are many co-authors/co-contributors for a draft), or there would be few members object the adoption, and then it might be difficult for the chairs to judge WG consensus.

________________________________

Thanks
Fatai

发件人： julien.meuric<[email-masked]<mailto:[email-masked]>>
收件人： Benoit Claise<[email-masked]<mailto:[email-masked]>>
抄送： WG Chairs<[email-masked]<mailto:[email-masked]>>
主题： Re: Support (as co-author)
时间： 2019-11-25 23:52:55

Hi Benoît,

My 2 cents,

Julien

---

From: Ron Bonica <[email-masked]>
Date: Mon, 25 Nov 2019 18:03:21 +0000

+1

Juniper Business Use Only

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Benoit Claise
Sent: Monday, November 25, 2019 10:10 AM
To: WG Chairs <[email-masked]>
Subject: Support (as co-author)

Dear all,

Along the years, I witnessed a trend, which intensifies with time: "I support the adoption of this draft (as a co-author)."
Well, if someone is a co-author, implicitly this person wants the draft to progress. Therefore, such as message carries no weight IMO.
Is it time for the WG chairs to start correcting this behaviour, or at least setting the right expectations?

ex: 
https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/browse/ippm/?q=Adoption*20Call*20for*20draft-ioamteam-ippm-ioam-direct-export__;JSUl!8WoA6RjC81c!QBeN6lMyv7px6hR_Xv2f4ZKZFt7oA4txb8fooEa8mK84cDKE3RQtdcDjWzGzOz1S$ 

Regards, Benoit

---

From: Job Snijders <[email-masked]>
Date: Mon, 25 Nov 2019 18:13:59 +0000

On Mon, Nov 25, 2019 at 04:09:44PM +0100, Benoit Claise wrote:
> Well, if someone is a co-author, implicitly this person wants the draft to
> progress. Therefore, such as message carries no weight IMO.
> ex: https://mailarchive.ietf.org/arch/browse/ippm/?q=Adoption%20Call%20for%20draft-ioamteam-ippm-ioam-direct-export

What problem is being solved by "correcting" people? Even if the
interpretation is "well doh, you are a co-author", it still shows the
authors are engaged and willing to push for publication.

If e-mail volume via IETF mailing lists is the issue, there may be other
ways to cut down on noise.

Kind regards,

Job

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 25 Nov 2019 19:43:40 +0100

Hi Benoit,

> On Nov 25, 2019, at 16:09, Benoit Claise <[email-masked]> wrote:
> 

As a co-author of an individual draft, I have more freedom to continue to develop the draft into the right direction.  It is very much an inflection point to move the draft out of author control to WG control.  I believe we do need to know whether the co-authors agree that this point actually has been reached, from their point of view as well.  Now, if a co-author has already asked for WG adoption, this is redundant information, but for other co-authors it may not be.

Grüße, Carsten

---

From: Mary Barnes <[email-masked]>
Date: Mon, 25 Nov 2019 12:52:05 -0600

In general, I would posit it doesn't carry much weight.  But, there are
times when one or more authors update drafts before meetings and all the
authors have not reviewed or may not necessarily agree.   The author that
didn't get to preview prior to the meeting or doesn't necessarily agree may
not have anticipated the document moving to ready to adopt state at that
particular point in time and they may want to have further discussions with
co-authors and make additional changes prior to asking for WG adoption.
 That gives flexibility to the authors to make changes without WG
consensus.  Of course, that takes us to another point that WG documents are
very often updated that don't necessarily reflect WG consensus.    And, the
burden there belongs with the authors and WGs that go along with that
manner of working.  Although, at times that's not a real problem since
there are cases in some WGs where work has a very narrow scope of interest.

In short, I don't see an issue with those emails and it would be a lot more
work for WG chairs to try to police that than just taking the approach of
not giving that as much weight unless of course, it's *only* authors
posting those emails.

Regards,
Mary.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 25 Nov 2019 13:54:46 -0500

I normally make clear to the authors as part of agreeinf to issue a call 
(adoption or WG last call) that I am looking for non-authorial support.
Nonetheless, the authors almost always respond with their support.  So I 
don't count that.

I have occaisonally tried to decide what I should do about drafts that 
have a large number of "authors".  I have not had to deal with it much. 
Most days, when I consider it, I conclude that my ignoring the "authors" 
is a fair trade for them playing games listing them.
It would be harder in the cases I have heard about in some other WGs 
where the work really is a collaboration among a large number of people. 
  At that point, I suspect the calls become more a call for objections / 
concerns.

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 25 Nov 2019 13:56:04 -0500

Yes, but typically not a problem to know if the authors want it to move.
As a chair, i will not start consideration of a WG adoption unless the 
authors ask me to do so.

Yours,
Joel

---

From: Melinda Shore <[email-masked]>
Date: Mon, 25 Nov 2019 11:01:59 -0900

I'm not a fan, although I'd like to think that people are
concerned about ethics and want to make it clear that their
statement of support is informed by their personal interest
in advancing a document.

Still, the world has changed and I've occasionally been
surprised to see my name pop up as co-author on a document,
so I suppose it's interesting when an author doesn't support
adopting/advancing/whatever.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Job Snijders <[email-masked]>
Date: Mon, 25 Nov 2019 18:13:59 +0000

Kind regards,

Job

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 25 Nov 2019 22:15:19 +0000

On 25/11/2019 20:01, Melinda Shore wrote:
> I'm not a fan,

Me neither.

As to expressions of support being useful in case
an author hadn't seen an update - I don't really
find that convincing. If a set of authors can't
get that much in sync, then I bet there are other
problems with the document.

That said, if chairs took such overdeclarations of
support by authors as a strong hint that the WG
draft ought have a different set of authors, then
that'd be good maybe. Perhaps we'd be better off
if some more adopted documents withered on the vine
rather than stumble over the line due to energetic
authors and "support" at adoption time?

If a WG is really motivated to do work then finding
new authors ought be do-able, and we might actually
decrease late-stage workload and get better outcomes,
if at the expense of more delay in WG processing.
(Could be a good experiment for some brave but
foolish WG chairs:-)

Cheers,
S.

---

From: Fred Baker <[email-masked]>
Date: Mon, 25 Nov 2019 22:01:18 -0800

Perhaps; personally, I would do that in private email (“well, we assumed that of you...”).

One thing I find a little frustrating is that we have pretty simple rules in v6ops - we’re looking for a draft to be posted and announced to the list that matches our charter, and then for other people to discuss it in email, with at least some positive commentary. At this past meeting, I had an author tell me that there had been discussion of his draft (which was true, but it was all negative commentary) and therefore he wanted an agenda slot (I replied listing people that commented and what they had said). We ended our meeting a few minutes short, and he walked to the mike announcing that he had his slides with him and wanted to present his draft. I wanted to ask him exactly what part of “no” was confusing to him.

We similarly have one author that we have actually given the floor to and let the working group boo him off the stage. He now periodically comments to the list that the chairs aren’t supportive of his draft.

I think sometimes people are just a little dense.

> On Nov 25, 2019, at 7:10 AM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
>

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 26 Nov 2019 16:54:19 +0900

Agree with Job, I find it positive when co-authors do respond (especially given that some drafts have complete front page taken by co-authors ;-))

Regards,
Jeff

> On Nov 26, 2019, at 03:14, Job Snijders <[email-masked]> wrote:
>

---

From: Tim Chown <[email-masked]>
Date: Tue, 26 Nov 2019 11:34:22 +0000

Hi,

Given the chairs (perhaps via the shepherd) need to get an IPR declaration from all authors, perhaps that is a time to also check their support for the document.  If they don’t support it, doesn’t it make sense for them to withdraw their name?

I had a case - I think for the "Why /64?” RFC - where one author later withdrew their support post-publication, saying they had changed their mind.  Having a confirmationary support ACK alongside the IPR ACK might be useful.

Tim

On 25 Nov 2019, at 15:09, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Regards, Benoit

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 26 Nov 2019 06:58:01 -0800

Thanks for the lively discussion on this topic! I agree in general that this habit is redundant, but not harmful. In general, such indications of support shouldn’t count for measuring WG support. 

I did want to comment on the thread you mention in IPPM, as a co-chair :). That particular draft is one in which I do appreciate the indications of support from authors, due to its rather complex history. In Montreal, we had two separate and overlapping drafts that mainly represented two companies. In order to get past this impasse, we asked the individual authors of each to work together and form a design team to come back with a unified document that reconciled the approaches. This document is that effort. Since the authors initially disagreed, or at least had different perspectives, it is usefully for me to be able to gauge if all of the authors are satisfied with the result. 

Best,
Tommy

---

From: Mary Barnes <[email-masked]>
Date: Tue, 26 Nov 2019 10:22:58 -0600

Exactly and that was a similar situation I was referring to.   And, unlike
what Stephen F said, it wasn't that there were particular problems with the
draft - it's just helpful to ensure that all authors are fine with the
compromise, rather than issues recurring after the doc is adopted.

Personally, I don't think that authors saying they support the draft being
adopted is harmful and in some cases it can be helpful.

Mary.

On Tue, Nov 26, 2019 at 8:58 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> Thanks for the lively discussion on this topic! I agree in general that
> this habit is redundant, but not harmful. In general, such indications of
> support shouldn’t count for measuring WG support.
>
> I did want to comment on the thread you mention in IPPM, as a co-chair :).
> That particular draft is one in which I do appreciate the indications of
> support from authors, due to its rather complex history. In Montreal, we
> had two separate and overlapping drafts that mainly represented two
> companies. In order to get past this impasse, we asked the individual
> authors of each to work together and form a design team to come back with a
> unified document that reconciled the approaches. This document is that
> effort. Since the authors initially disagreed, or at least had different
> perspectives, it is usefully for me to be able to gauge if all of the
> authors are satisfied with the result.
>
> Best,
> Tommy
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 26 Nov 2019 08:31:07 -0800

Hi,

My take on this is that having one’s name as an author is implicitly a sign of support.   No need to state it on the list in an adoption call.   If you don’t support it, you should ask that your name be removed.

Isn’t this the reason we see drafts with long author lists?

Relating to this, I think that someone should only be listed as an author if they have written words in the document.   I dislike the trend to listing names of people as authors who have not contributed to the text.

Bob

> On Nov 25, 2019, at 7:09 AM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
>

---

From: Rodney Van Meter <[email-masked]>
Date: Tue, 26 Nov 2019 20:54:56 +0900

Having worked on research papers with moderately long author lists, people go AWOL at times, and sometimes you have to really prod them to get their okay to submit something to a conference or journal, especially when projects have been long and the amount of day-to-day engagement varies.  Having all the co-authors ACK that they are paying attention and think things should move forward is a good thing.  Doesn’t mean that all of their nits have been answered, but that overall they can live with it.

So I would say it is necessary, but certainly not sufficient.  Other, less invested folks should also express some sort of positive support, as well.

—Rod

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 26 Nov 2019 15:01:21 -0500

I think it is an important question to ask.

Quite a few of my drafts have taken a long time to reach RFC. If I have
written 100% of the original draft and had the original idea, then I expect
my name to be there as a co-author even after I hand it off to other
people. But that isn't a commitment to read every new incremental revision.
That is not how I work.

It is more than fair to ask me if I still support the work as an ongoing
project after a WG has rewritten it.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 29 Nov 2019 07:30:05 +0100

> Relating to this, I think that someone should only be listed as an author if they have written words in the document.   I dislike the trend to listing names of people as authors who have not contri…

Others have already commented about the reality of these things.

The rules need to be made to work with what actually happens, not with what we believe should happen.

https://social-biz.org/2008/05/25/process-confabulation/

(There is a strong tendency towards process confabulation in many discussions about IETF processes; maybe all process geeks who are not familiar with this phenomenon should look it up.)

Grüße, Carsten

---

From: Lou Berger <[email-masked]>
Date: Fri, 29 Nov 2019 15:53:07 +0900

There's a big difference between adoption and last call.  The point of the 
original mail was on the former, on which I'm totaly ambivalent.  On the 
other hand, I agree that authors should be included in wg last calls.

Lou

----------
On November 29, 2019 2:40:17 PM Phillip Hallam-Baker

---

From: Loa Andersson <[email-masked]>
Date: Sat, 30 Nov 2019 13:59:13 +0800

Bod,

very much agree!

small cooment and a piece of one of my favorite rants inline.

On 27/11/2019 00:31, Bob Hinden wrote:
> Hi,
> 
> My take on this is that having one’s name as an author is implicitly a sign of support.

Well - I would say that it very explicit.

> No need to state it on the list in an adoption call.   

I'd say that this is obvious. BTW I'm still waiting for the case where
an author at the WGAP says he no long support the document.

> If you don’t support it, you should ask that your name be removed.

Well - yes, but if you still have contributed text to the document, you
will still have to active for the IPT polls.

> Relating to this, I think that someone should only be listed as an author if they have written words in the document.   I dislike the trend to listing names of people as authors who have not contri…

I think the rules would be

If you are an authors - you thave contributed text or at least ideas
to the document -  you should be listed as an author. Eve it this takes
us 6 or 7 authors.

As it is now it happens that wg chairs are forced to move authors - text
in the document - to become a contributor. having to explain why one
author should be on the front page, while other are stowed away in the
contributor section.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64