Subject: New datatracker release: v6.116.0

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Jan 2020 13:58:50 -0800

Hi,

This is an automatic notification about a new datatracker release, 
v6.116.0, generated when running the mkrelease script.

Release notes:

ietfdb (6.116.0) ietf; urgency=medium

  **Dateless group milestones, improved author stats, and bugfixes**

  * Merged in [17196] from [email-masked]:
    Removed [email-masked] from audio import notification To: list.  

  * Merged in [17195] from [email-masked]:
    Updated admin permissions to grant secretariat access to
    LiaisonStatementGroupContacts.  

  * Merged in [17185] from [email-masked]:
    Added support for dateless milestones. Fixes issue #2799.

  * Specified explicit UTF-8 decoding of submission checker output, in
    order to avoid issues when reporting errors due to UTF-8 content.

  * Merged in [17181] from [email-masked]:
    Fixed a problem with assignments to the same session causing a crash. 

  * Merged in [17179] from [email-masked]:
    Added references and referened-by buttons to each RFC listed on the person
    profile page.  In addition, changed the buttons on the document references
    and document referenced-by pages to match the buttons on the main document
    page (the buttons with the long arrows). Fixes #2854, although it does not
    include the number of references in the button.

  * Merged in [17178] from [email-masked]:
    Turned text names into links on the stats pages. Fixes issue #2854.

  * Refactored some document methods to align better with Django's
    get_absolute_url(), and added Person.get_absolute_uri()

  * Merged in [17177] from [email-masked]:
    Improve can_ballot. Fixes #2856.

  * Limited the permitted versions of mypy and related django-slugs, to avoid
    issues related to using Django-1.11.  We should update to latest versions
    when we've moved to Django 2.2.x

  * Changed ReviewerSettings history change-reason field to be a TextField, in
    order to accomodate longer change descriptions.

  * Merged in [17173] from [email-masked]:
    Worked around a problem with displaying IESG evaluation information for 
    non-approve ballot types. Partially addresses #2851.  

 -- Henrik Levkowetz <[email-masked]>  09 Jan 2020 18:31:03 +0000

The new version is available for installation through SVN checkout, with
  'svn checkout https://svn.tools.ietf.org/svn/tools/ietfdb/tags/6.116.0'

For development, copy the new development version instead:
  'svn copy https://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/6.116.1.dev0' <YOURBRANCH>

Regards,

	Henrik
	(via the mkrelease script)

---

From: Robert Sparks <[email-masked]>
Date: Wed, 15 Jan 2020 16:25:39 -0600

Chairs and ADs:

This release brings the ability to configure a working group to manage 
its milestones as an ordered list without dates.

If you want to switch your group(s) over, see the "Edit milestones" page 
for the group.

If you try it and don't like it, you can switch back to using dates at 
any time.

Let me know if you run into problems or have any questions.

RjS

-------- Forwarded Message --------
Subject: 	New datatracker release: v6.116.0
Date: 	Thu, 09 Jan 2020 13:58:50 -0800
From: 	Henrik Levkowetz <[email-masked]>
To: 	[email-masked], [email-masked], [email-masked]

Hi,

Release notes:

For development, copy the new development version instead:
'svn copy 
https://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/6.116.1.dev0' 
<YOURBRANCH>

Regards,

Henrik

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 16 Jan 2020 09:28:34 +0000

Hi WG Chairs,

Please note that IESG would like to provide some guidance on when it is
suitable to exclude the dates. 

One reasons for this need is that RFC 2418 do have requirements on charter
and milestones:

   Goals and milestones

      The working group charter MUST establish a timetable for specific

      work items.  While this may be renegotiated over time, the list of

      milestones and dates facilitates the Area Director's tracking of

      working group progress and status, and it is indispensable to

      potential participants identifying the critical moments for input.

      Milestones shall consist of deliverables that can be qualified as

      showing specific achievement; e.g., "Internet-Draft finished" is

      fine, but "discuss via email" is not. It is helpful to specify

      milestones for every 3-6 months, so that progress can be gauged

      easily.  This milestone list is expected to be updated

      periodically (see section 5).

So please await guidance. IESG will discuss this in our informal telechat
today. 

Cheers

Magnus Westerlund

TSV AD

From: WGChairs <[email-masked]> On Behalf Of Robert Sparks
Sent: den 15 januari 2020 23:26
To: IETF WG Chairs <[email-masked]>
Subject: Fwd: New datatracker release: v6.116.0

Chairs and ADs:

This release brings the ability to configure a working group to manage its
milestones as an ordered list without dates.

If you want to switch your group(s) over, see the "Edit milestones" page for
the group.

If you try it and don't like it, you can switch back to using dates at any
time.

RjS

-------- Forwarded Message -------- 

Subject: 

New datatracker release: v6.116.0

Date: 

Thu, 09 Jan 2020 13:58:50 -0800

From: 

Henrik Levkowetz  <mailto:[email-masked]> <[email-masked]>

To: 

[email-masked] <mailto:[email-masked]> , [email-masked]
<mailto:[email-masked]> , [email-masked] <mailto:[email-masked]> 

Hi,

This is an automatic notification about a new datatracker release, v6.116.0,
generated when running the mkrelease script.

Release notes:

* Merged in [17196] from [email-masked] <mailto:[email-masked]> :
Removed [email-masked] <mailto:[email-masked]>  from audio import
notification To: list. 
* Merged in [17195] from [email-masked] <mailto:[email-masked]> :
Updated admin permissions to grant secretariat access to
LiaisonStatementGroupContacts. 
* Merged in [17185] from [email-masked] <mailto:[email-masked]>
:
Added support for dateless milestones. Fixes issue #2799.

* Merged in [17181] from [email-masked] <mailto:[email-masked]> :
Fixed a problem with assignments to the same session causing a crash. 
* Merged in [17179] from [email-masked] <mailto:[email-masked]>
:
Added references and referened-by buttons to each RFC listed on the person
profile page. In addition, changed the buttons on the document references
and document referenced-by pages to match the buttons on the main document
page (the buttons with the long arrows). Fixes #2854, although it does not
include the number of references in the button.

* Merged in [17178] from [email-masked] <mailto:[email-masked]>
:
Turned text names into links on the stats pages. Fixes issue #2854.

* Merged in [17177] from [email-masked] <mailto:[email-masked]>
:
Improve can_ballot. Fixes #2856.

* Merged in [17173] from [email-masked] <mailto:[email-masked]>
:
Worked around a problem with displaying IESG evaluation information for
non-approve ballot types. Partially addresses #2851. 
-- Henrik Levkowetz  <mailto:[email-masked]> <[email-masked]> 09
Jan 2020 18:31:03 +0000

For development, copy the new development version instead:
'svn copy https://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/6.116.1.dev0'
<YOURBRANCH>

Regards,

Henrik

---

From: Adam Roach <[email-masked]>
Date: Thu, 23 Jan 2020 10:13:31 -0600

Hi!

Sorry for the confusion around the new datatracker feature that allows 
working groups to remove dates from milestones. The IESG's intention 
here is to run an experiment to evaluate what positive and negative 
impacts may result.

Please note that the decision to remove dates from your milestones needs 
approval by your responsible area director, who will need to make such a 
change in the datatracker. If you're interested in doing so, please 
start a conversation with your area director.

If you have any feedback about this new functionality and its impact -- 
either beneficial or detrimental -- please send comments to the IESG.

Thanks.

/a

On 1/16/20 03:28, Magnus Westerlund wrote:
>
> Hi WG Chairs,
>
> Please note that IESG would like to provide some guidance on when it 
> is suitable to exclude the dates.
>
> One reasons for this need is that RFC 2418 do have requirements on 
> charter and milestones:
>
>    Goals and milestones
>
> So please await guidance. IESG will discuss this in our informal 
> telechat today.
>
> Cheers
>
> Magnus Westerlund
>
> TSV AD
>
> *From:*WGChairs <[email-masked]> *On Behalf Of *Robert Sparks
> *Sent:* den 15 januari 2020 23:26
> *To:* IETF WG Chairs <[email-masked]>
> *Subject:* Fwd: New datatracker release: v6.116.0
>
> Chairs and ADs:
>
> If you want to switch your group(s) over, see the "Edit milestones" 
> page for the group.
>
> *Subject: *
> *Date: *
> *From: *
> Henrik Levkowetz <[email-masked]> <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>
>
>
>
> Hi,
>
> * Merged in [17196] from [email-masked] <mailto:[email-masked]>:
> * Merged in [17195] from [email-masked] <mailto:[email-masked]>:
> * Merged in [17185] from [email-masked] 
> <mailto:[email-masked]>:
> * Merged in [17181] from [email-masked] <mailto:[email-masked]>:
> * Merged in [17179] from [email-masked] 
> <mailto:[email-masked]>:
> * Merged in [17178] from [email-masked] 
> <mailto:[email-masked]>:
> * Merged in [17177] from [email-masked] 
> <mailto:[email-masked]>:
> * Merged in [17173] from [email-masked] 
> <mailto:[email-masked]>:
> Worked around a problem with displaying IESG evaluation information 
> for non-approve ballot types. Partially addresses #2851.
> -- Henrik Levkowetz <[email-masked]> 
> <mailto:[email-masked]> 09 Jan 2020 18:31:03 +0000
>

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 24 Jan 2020 09:11:14 +1100

Has this functionality actually shipped? When I try to add a milestone without a date, clicking "Review changes" brings up a bright red box saying "This field is required." next to the date field.

> On 24 Jan 2020, at 3:13 am, Adam Roach <[email-masked]> wrote:
> 
> Hi!
> 
> Sorry for the confusion around the new datatracker feature that allows working groups to remove dates from milestones. The IESG's intention here is to run an experiment to evaluate what positive and negative impacts may result.
> 
> Please note that the decision to remove dates from your milestones needs approval by your responsible area director, who will need to make such a change in the datatracker. If you're interested in doing so, please start a conversation with your area director.
> 
> If you have any feedback about this new functionality and its impact -- either beneficial or detrimental -- please send comments to the IESG.
> 
> Thanks.
> 
> /a
> 
>> Please note that IESG would like to provide some guidance on when it is suitable to exclude the dates. 
>>  
>> One reasons for this need is that RFC 2418 do have requirements on charter and milestones:
>>  
>>    Goals and milestones
>> So please await guidance. IESG will discuss this in our informal telechat today. 
>>  
>> Cheers
>>  
>> Magnus Westerlund
>> TSV AD
>>  
>>  
>> This release brings the ability to configure a working group to manage its milestones as an ordered list without dates.
>> 
>> If you want to switch your group(s) over, see the "Edit milestones" page for the group.
>> 
>> If you try it and don't like it, you can switch back to using dates at any time.
>> 
>> Henrik Levkowetz <[email-masked]>
>> To: 
>> [email-masked], [email-masked], [email-masked]
>> 
>> 
>> 
>> Hi,
>> 
>> This is an automatic notification about a new datatracker release, v6.116.0, generated when running the mkrelease script.
>> 
>> Release notes:
>> 
>> Worked around a problem with displaying IESG evaluation information for non-approve ballot types. Partially addresses #2851. 

--
Mark Nottingham   https://www.mnot.net/

---

From: Adam Roach <[email-masked]>
Date: Thu, 23 Jan 2020 16:23:01 -0600

It has shipped; but as I indicate below, only Area Directors can flip 
the switch on a working group. (I've already done this for STIR, for 
example.) It should be noted that the current implementation is an 
all-or-nothing setting: working groups either have dates on all of their 
milestones, or on none of them.

/a