Subject: protocol design tenets?

From: Dick Hardt <[email-masked]>
Date: Tue, 18 Feb 2020 12:28:02 -0800

Does anyone have any pointers to protocol design tenets / best practices /
principles?

/Dick
ᐧ

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 18 Feb 2020 12:31:32 -0800

https://tools.ietf.org/html/rfc5218

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 18 Feb 2020 15:33:04 -0500

Getting a bit old but still excellent

https://tools.ietf.org/html/rfc5218 <https://tools.ietf.org/html/rfc5218>

Cheers
Suresh

> On Feb 18, 2020, at 3:28 PM, Dick Hardt <[email-masked]> wrote:
> 
> Does anyone have any pointers to protocol design tenets / best practices / principles?
> 
> 
> 
> /Dick
> ᐧ

---

From: Dick Hardt <[email-masked]>
Date: Tue, 18 Feb 2020 12:47:50 -0800

Thanks!

5218 is interesting, but https://tools.ietf.org/html/rfc1958 was more what
I was looking for, specifically section 3 & 4.

Anything else similar to 1918? Are the design guidelines still applicable?

---

From: Warren Kumari <[email-masked]>
Date: Wed, 19 Feb 2020 07:53:45 +1100

> https://tools.ietf.org/html/rfc5218

Even older, but also excellenter..

https://tools.ietf.org/html/rfc1925

Yes, it is an April 1st, but is one of the truest documents I've ever
read - - esp points #12, #4, #5, and #6

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Erik Kline <[email-masked]>
Date: Tue, 18 Feb 2020 13:17:52 -0800

https://tools.ietf.org/html/rfc3439 perhaps.

On Tue, Feb 18, 2020 at 12:48 PM Dick Hardt <[email-masked]> wrote:

> Thanks!
>
> 5218 is interesting, but https://tools.ietf.org/html/rfc1958 was more
> what I was looking for, specifically section 3 & 4.
>
> On Tue, Feb 18, 2020 at 12:33 PM Suresh Krishnan <
> [email-masked]> wrote:
>

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Feb 2020 21:39:46 +0000

> Does anyone have any pointers to protocol design tenets / best practices /

Don't mimic IKEv1, try be more like wireguard instead:-)

Cheers,
S.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 19 Feb 2020 09:08:21 +0000

There are a few more documents in the IAB stream, e.g.

https://tools.ietf.org/html/rfc6709

https://tools.ietf.org/html/rfc8170

https://tools.ietf.org/html/rfc8546

https://tools.ietf.org/html/rfc8558

And there are also a bunch of docs called “Architectural Considerations for …”. However, not sure what you exactly you are looking for. Hope that’s helpful!

Mirja

From: irsg <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Tuesday, 18. February 2020 at 21:48
To: Suresh Krishnan <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [irsg] protocol design tenets?

Thanks!

5218 is interesting, but https://tools.ietf.org/html/rfc1958 was more what I was looking for, specifically section 3 & 4.

On Tue, Feb 18, 2020 at 12:33 PM Suresh Krishnan <[email-masked]<mailto:[email-masked]>> wrote:
Getting a bit old but still excellent

Cheers
Suresh

On Feb 18, 2020, at 3:28 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

/Dick
[Image removed by sender.]ᐧ

---

From: Dick Hardt <[email-masked]>
Date: Wed, 19 Feb 2020 11:04:58 -0800

Thanks Mirja, 6709 and 8170 are the types of documents I was looking for!

For context, the TxAuth BoF is exploring a successor to
https://tools.ietf.org/html/rfc6749 (OAuth 2.0)

I'm looking for applicable tenets if a WG is formed.

On Wed, Feb 19, 2020 at 1:08 AM Mirja Kuehlewind <
[email-masked]> wrote:

> And there are also a bunch of docs called “Architectural Considerations
> for …”. However, not sure what you exactly you are looking for. Hope that’s
> helpful!
>
>
>
> Mirja
>
>
>
>
>
>
>
> *From: *irsg <[email-masked]> on behalf of Dick Hardt <
> [email-masked]>
> *Date: *Tuesday, 18. February 2020 at 21:48
> *To: *Suresh Krishnan <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [irsg] protocol design tenets?
>
>
>
> Thanks!
>
>
>

---

From: Keith Drage <[email-masked]>
Date: Thu, 20 Feb 2020 13:36:23 +0000

Some additional discussion of compatibility can also be found in ITU-T 
Recommendation Q.1400, which should be available for free download 
although you may need to register first (I'm not saying this is a 
better, or indeed worse, document, but it does give some different 
perspectives). I would emphasise that protocol solutions for 
compatibility / extensibility do need to be designed in from day 1. 
Further, if you intend more than two entities participating in a peer to 
peer protocol, i.e. you have entities acting as some sort of bridge or 
relay, then that requires much deeper thought (in relation as to whether 
information the entity does not understand is passed on to other 
entities or not).

I haven't read all the referenced documents so far in detail, so I may 
have missed this, but assuming I have not, another issue concerns the 
creation of protocol transaction identifiers. Under no circumstances use 
identifiers the protocol is carrying for end to end application purposes 
to be used for making some form of transaction identifier, as at some 
point you will undoubtedly run into some form of privacy considerations. 
Yes you can hash them and work from that, but then you need to 
understand the long term effectiveness of your hashing algorithm.

regards

Keith

On 19/02/2020 19:04, Dick Hardt wrote:
> On Wed, Feb 19, 2020 at 1:08 AM Mirja Kuehlewind 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     And there are also a bunch of docs called “Architectural
>     Considerations for …”. However, not sure what you exactly you are
>     looking for. Hope that’s helpful!
>
>     Mirja
>
>     *From: *irsg <[email-masked]
>     <mailto:[email-masked]>> on behalf of Dick Hardt
>     <[email-masked] <mailto:[email-masked]>>
>     *To: *Suresh Krishnan <[email-masked]
>     <mailto:[email-masked]>>, "[email-masked]
>     <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc: *"[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>     5218 is interesting, but https://tools.ietf.org/html/rfc1958 was
>     more what I was looking for, specifically section 3 & 4.
>
>     On Tue, Feb 18, 2020 at 12:33 PM Suresh Krishnan
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>             On Feb 18, 2020, at 3:28 PM, Dick Hardt
>             <[email-masked] <mailto:[email-masked]>> wrote:
>
>             Image removed by sender.ᐧ
>