Subject: Tools for GitHub backups

From: "Martin Thomson" <[email-masked]>
Date: Fri, 20 Mar 2020 15:51:14 +1100

In case folks here are interested.

The toolchain I maintain (https://github.com/martinthomson/i-d-template) now has a better backup for issues and pull requests.

If you have CI enabled, this creates a snapshot of the issues and pull requests (thanks to Mike Bishop for navigating the API here) and saves a copy alongside the HTML and text versions of the draft.  This archive is a JSON file that is pretty easy to read, even without tools.  Saving to the repo means that anyone who has a copy of the repo will have a copy of this archive.

The archive is only created when changes are made to the repo, though that has been OK in the past, there are plans to run the update on a timer instead.

You can see an example of a *large* database with the QUIC repo.  This takes a fair bit to download - it's a 19M database uncompressed - and it can be a little slow to sort and do other things.  But it should give you an idea of what is possible.  It might not be as fully featured as the real GitHub interface, but I find that it can be useful for some things.

https://quicwg.org/base-drafts/issues.html

Cheers,
Martin

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 20 Mar 2020 14:27:40 +0000

>    The toolchain I maintain (https://github.com/martinthomson/i-d-template) now has a better backup for issues and pull requests.
  
I haven't looked, sorry.  Does it also do labels?  If so, then this seems like it does everything needed to practically backup the state of a WG repository, right?  And the secretariat only needs to clone repo's?

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Mar 2020 15:38:21 +0100

On 2020-03-20, at 05:51, Martin Thomson <[email-masked]> wrote:
> snapshot of the issues

Including the discussion?

Grüße, Carsten

---

From: "Martin Thomson" <[email-masked]>
Date: Sat, 21 Mar 2020 17:12:39 +1100

On Sat, Mar 21, 2020, at 01:27, Salz, Rich wrote:
> I haven't looked, sorry.  Does it also do labels?

Yes, it does labels, including their colour and description.

> Including the discussion?

Yes, the entire discussion, including review comments, is saved for each issue.  I haven't worked out how to render the comments that are attached to code just yet, and I'm not sure if the right data is being saved (position vs. originalPosition is still a bit mysterious), but it is all there.

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 21 Mar 2020 13:48:26 +0000

> It saves this ... it saves that ...

So in order to do a backup if the WG uses your CI tooling to save data in the repo, then anyone can clone the repo and it's all set.  If they don't use this, then the secretariat will need to be an owner to use other tooling to do a backup.