Subject: bluesheets - etherpad

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 25 Mar 2020 14:34:41 +0000

Hijacking this thread so as to keep hints together -

Minutetakers/Chairs - you may want to send the list of names you captured on etherpad to your mailing list so folks can doublecheck.

In RAW yesterday, after about 15 min, etherpad lost a group of names. The chairs think they recovered most names using the timeslider feature. They sent what they had on the mailing list and asked for folks to doublecheck and if not included to send mail to [email-masked]<mailto:[email-masked]>.

Deborah

From: WGChairs <[email-masked]> On Behalf Of STARK, BARBARA H
Sent: Wednesday, March 25, 2020 10:12 AM
To: [email-masked]' <[email-masked]>
Subject: RE: DISPATCH Virtual Meeting

As note-taker in yesterday's ADD WG ...

From: Bron Gondwana
On Wed, Mar 25, 2020, at 02:12, Ben Campbell wrote:

On Mar 24, 2020, at 10:08 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

>We failed to make sure everyone was introduced by their full names when speaking. We have this issue in person too, of course,
>but it seemed easier to forget in the faceless forum but is probably even more important to remember.

While I agree it is good to explicitly introduce the speakers, it was possible to see who was speaking by looking at the WebEx attendee list which shows where the audio comes from.

I imagine that the note takers had enough to keep up with without having to constantly look at the WebEx GUI to see who is talking.

Speaking as a note taker, I didn't find it particularly hard - I have a 2-screen setup though, so I had webex up on one screen with the webex chat window open, and the speaker name appeared at the top of that.  The hard part was people who had their "name" as something other than their actual name (Mark Nottingham as the QUIC working group, and some others who had email address rather than name) - but I could have easily noted what I saw there instead of the actual name and corrected to the name list later if I was struggling.

I also used 2 screens and found it really easy to get the speakers' names from WebEx. Much easier (and with more accurate spelling) than transcribing the spoken form of names. It's really helpful if people make sure to provide WebEx with their full name. And chairs of other WGs should log out of their WG accounts before connecting to an interim meeting for a WG they aren't chairing - to avoid appearing in WebEx as "<WG name> working group".

Where I missed something, others added it quickly too - having collaborative note taking is mostly nice (unless someone else starts taking ALL the notes like someone did in Tx, so I just left them to it).

Things I noticed:
*       Webex losing the slides or losing partial audio is a massive usability failure - if you don't know for sure that everyone is getting the same stream then you have the nightmare situation of "can everyone hear me / see" and needing 150 ACKs.  Ouch..
*       I couldn't see where on Etherpad to coordinate the colours back to the identity of the person typing, which made it hard to contact them outside Etherpad to coordinate who's writing what - instead having to just write notes inline for the other authors!
Since people usually don't bother identifying themselves in Etherpad, it probably wouldn't have made a difference, for you to have known that there is a button on the upper right of the Etherpad screen where you can enter your name (so people can see who that color is). I did think about identifying myself there. But I didn't, because it was mostly just me. I probably should have.
*       There was a lot of interesting stuff happening in the Jabber chat which wasn't seen by those who weren't there.  This makes the Webex-by-itself experience a significantly degraded understanding compared to Jabber.  I feel like there would be some value in someone speaking a summary of what happened in Jabber to the Webex at the end of each presentation.  It wouldn't take that long to get the summary out there - both key points made and a "feel of the room", e.g. in DISPATCH there was a large set of "the problem space should be solved, we don't think CLIENTID is the right solution" responses on Jabber, but those in Webex wouldn't have heard that sentiment so clearly.
I do sometimes put notes about jabber chatter into the minutes, when it seems particularly relevant. Even if it's just something like "<robust jabber conversation on this topic>". But I find it's also true in F2F IETF sessions that being in the jabber room (even when physically present) is an essential part of the experience.
Overall I think this has gone really well given the short notice..  Massive Kudos to both the secretariat and the rest of the IETF team for making it happen so smoothly, and to the chairs who really rose to the occasion and ran smooth remote meetings.

I also thought it went quite well.
I do have a comment for people who intend to speak (especially presenters) -
Consider doing whatever you can to ensure good quality audio is coming from you. For example, try to use wired Ethernet directly to your edge router (I moved my laptop and a monitor into the room where my router is so I could connect with Ethernet even though I wasn't speaking - because I didn't want to lose connectivity or have self-inflicted bad audio while taking minutes), use a headset that you've tested out and know works well, ask other family members to avoid bandwidth-consuming activities, etc.

---

From: Jay Daley <[email-masked]>
Date: Thu, 26 Mar 2020 07:35:33 +1300

Deborah

> On 26/03/2020, at 3:34 AM, BRUNGARD, DEBORAH A <[email-masked]> wrote:
> 
> Hijacking this thread so as to keep hints together –
>  
> Minutetakers/Chairs – you may want to send the list of names you captured on etherpad to your mailing list so folks can doublecheck.
>  
> In RAW yesterday, after about 15 min, etherpad lost a group of names. The chairs think they recovered most names using the timeslider feature. They sent what they had on the mailing list and asked for folks to doublecheck and if not included to send mail to [email-masked] <mailto:[email-masked]>.

Do you know if that was that because someone deleted them, presumably inadvertently, or a technical glitch in Etherpad?

Jay

>  
> Deborah
>  
> From: WGChairs <[email-masked] <mailto:[email-masked]>> On Behalf Of STARK, BARBARA H
> To: [email-masked] <mailto:[email-masked]>' <[email-masked] <mailto:[email-masked]>>
> As note-taker in yesterday’s ADD WG ...
>  
> From: Bron Gondwana
> 
> On Mar 24, 2020, at 10:08 AM, Christer Holmberg <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi,
>  
> I also used 2 screens and found it really easy to get the speakers’ names from WebEx. Much easier (and with more accurate spelling) than transcribing the spoken form of names. It’s really helpful if people make sure to provide WebEx with their full name. And chairs of other WGs should log out of their WG accounts before connecting to an interim meeting for a WG they aren’t chairing – to avoid appearing in WebEx as “<WG name> working group”.
>  
> ·       Webex losing the slides or losing partial audio is a massive usability failure - if you don't know for sure that everyone is getting the same stream then you have the nightmare situation of "can everyone hear me / see" and needing 150 ACKs.  Ouch....
> ·       I couldn't see where on Etherpad to coordinate the colours back to the identity of the person typing, which made it hard to contact them outside Etherpad to coordinate who's writing what - instead having to just write notes inline for the other authors!
> Since people usually don’t bother identifying themselves in Etherpad, it probably wouldn’t have made a difference, for you to have known that there is a button on the upper right of the Etherpad screen where you can enter your name (so people can see who that color is). I did think about identifying myself there. But I didn’t, because it was mostly just me. I probably should have.
> ·       There was a lot of interesting stuff happening in the Jabber chat which wasn't seen by those who weren't there.  This makes the Webex-by-itself experience a significantly degraded understanding compared to Jabber.  I feel like there would be some value in someone speaking a summary of what happened in Jabber to the Webex at the end of each presentation.  It wouldn't take that long to get the summary out there - both key points made and a "feel of the room", e.g. in DISPATCH there was a large set of "the problem space should be solved, we don't think CLIENTID is the right solution" responses on Jabber, but those in Webex wouldn't have heard that sentiment so clearly.
> I do sometimes put notes about jabber chatter into the minutes, when it seems particularly relevant. Even if it’s just something like “<robust jabber conversation on this topic>”. But I find it’s also true in F2F IETF sessions that being in the jabber room (even when physically present) is an essential part of the experience.
> I do have a comment for people who intend to speak (especially presenters) –
> Consider doing whatever you can to ensure good quality audio is coming from you. For example, try to use wired Ethernet directly to your edge router (I moved my laptop and a monitor into the room where my router is so I could connect with Ethernet even though I wasn’t speaking – because I didn’t want to lose connectivity or have self-inflicted bad audio while taking minutes), use a headset that you’ve tested out and know works well, ask other family members to avoid bandwidth-consuming activities, etc.

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 25 Mar 2020 19:43:20 +0000

Hi Jay,

I’m not sure we know – my raw chairs, Rick or Eve, or some of the participants that took note of the gap (several are wg chairs) may be able to say more.

As we know Murphy’s Law may activate at any time, I thought to suggest confirming on the mailing list if the attendee list is complete.

Thanks,
Deborah

From: Jay Daley <[email-masked]>
Sent: Wednesday, March 25, 2020 2:36 PM
To: BRUNGARD, DEBORAH A <[email-masked]>
Cc: [email-masked]
Subject: Re: bluesheets - etherpad

Deborah

On 26/03/2020, at 3:34 AM, BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>> wrote:

Jay

Deborah

From: WGChairs <[email-masked]<mailto:[email-masked]>> On Behalf Of STARK, BARBARA H
Sent: Wednesday, March 25, 2020 10:12 AM
To: [email-masked]<mailto:[email-masked]>' <[email-masked]<mailto:[email-masked]>>
Subject: RE: DISPATCH Virtual Meeting

From: Bron Gondwana

Hi,

Things I noticed:
•       Webex losing the slides or losing partial audio is a massive usability failure - if you don't know for sure that everyone is getting the same stream then you have the nightmare situation of "can everyone hear me / see" and needing 150 ACKs.  Ouch....
•       I couldn't see where on Etherpad to coordinate the colours back to the identity of the person typing, which made it hard to contact them outside Etherpad to coordinate who's writing what - instead having to just write notes inline for the other authors!
Since people usually don’t bother identifying themselves in Etherpad, it probably wouldn’t have made a difference, for you to have known that there is a button on the upper right of the Etherpad screen where you can enter your name (so people can see who that color is). I did think about identifying myself there. But I didn’t, because it was mostly just me. I probably should have.
•       There was a lot of interesting stuff happening in the Jabber chat which wasn't seen by those who weren't there.  This makes the Webex-by-itself experience a significantly degraded understanding compared to Jabber.  I feel like there would be some value in someone speaking a summary of what happened in Jabber to the Webex at the end of each presentation.  It wouldn't take that long to get the summary out there - both key points made and a "feel of the room", e.g. in DISPATCH there was a large set of "the problem space should be solved, we don't think CLIENTID is the right solution" responses on Jabber, but those in Webex wouldn't have heard that sentiment so clearly.
I do sometimes put notes about jabber chatter into the minutes, when it seems particularly relevant. Even if it’s just something like “<robust jabber conversation on this topic>”. But I find it’s also true in F2F IETF sessions that being in the jabber room (even when physically present) is an essential part of the experience.
Overall I think this has gone really well given the short notice..  Massive Kudos to both the secretariat and the rest of the IETF team for making it happen so smoothly, and to the chairs who really rose to the occasion and ran smooth remote meetings.

--
Jay Daley
IETF Executive Director
[email-masked]<mailto:[email-masked]>

---

From: "Schooler, Eve M" <[email-masked]>
Date: Wed, 25 Mar 2020 20:59:22 +0000

We think it was inadvertent. If everyone attaches to the Etherpad to sign the virtual Bluesheet, it means we are likely getting more inexperienced folks using the tool than normal. On the other hand, it probably also means we are getting more people staying and contributing to notes….

Eve

From: WGChairs <[email-masked]> On Behalf Of BRUNGARD, DEBORAH A
Sent: Wednesday, March 25, 2020 12:43 PM
To: Jay Daley <[email-masked]>
Cc: [email-masked]
Subject: RE: bluesheets - etherpad

Hi Jay,

Thanks,
Deborah

From: Jay Daley <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 25, 2020 2:36 PM
To: BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: bluesheets - etherpad

Deborah

Jay

Deborah

From: Bron Gondwana

Hi,

Things I noticed:

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Mar 2020 22:00:59 +0100

Etherpad is a terrible blue sheet.
It is even more terrible with someone trying to type in notes into the same document.

Grüße, Carsten

> On 2020-03-25, at 21:59, Schooler, Eve M <[email-masked]> wrote:
> 
> In RAW yesterday, after about 15 min, etherpad lost a group of names. The chairs think they recovered most names using the timeslider feature. They sent what they had on the mailing list and asked for folks to doublecheck and if not included to send mail to [email-masked].
>  
> On Mar 24, 2020, at 10:08 AM, Christer Holmberg <[email-masked]> wrote:
>  
> Hi,
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 25 Mar 2020 21:01:01 +0000

During regular meetings, WGs I’ve been involved with
using Etherpad “Scrape” the current state and paste in
a text file (like pressing save in other contexts).

stuff happens, copies help,
Al

From: WGChairs [mailto:[email-masked]] On Behalf Of BRUNGARD, DEBORAH A
Sent: Wednesday, March 25, 2020 3:43 PM
To: Jay Daley <[email-masked]>
Cc: [email-masked]
Subject: RE: bluesheets - etherpad

***Security Advisory: This Message Originated Outside of AT&T ***
Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
Hi Jay,

Thanks,
Deborah

Deborah

Jay

Deborah

From: Bron Gondwana

Hi,

Things I noticed:

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Mar 2020 22:37:05 +0100

> a text file (like pressing save in other contexts).

That is useful to keep some value if Etherpad completely crashes (as it has done before).

Here, apparently Etherpad worked as designed, but there was user error, and the timeline feature of Etherpad saved the day.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 25 Mar 2020 22:42:36 +0100

> Etherpad is a terrible blue sheet.

Are you Churchill talking about democracy or do you have a better suggestion ?

> It is even more terrible with someone trying to type in notes into the same document.

Worked pretty fine in our side meeting in the morning...

Yes, there is an ongoing fear of etherpad molestation, i typically
regularily click on the download button to have backups...

Cheers
    Toerless

> > We think it was inadvertent. If everyone attaches to the Etherpad to sign the virtual Bluesheet, it means we are likely getting more inexperienced folks using the tool than normal. On the other hand, it probably also means we are getting more people staying and contributing to notes???.
> >  
> > Eve 
> >  
> > I???m not sure we know ??? my raw chairs, Rick or Eve, or some of the participants that took note of the gap (several are wg chairs) may be able to say more.
> >  
> > As we know Murphy???s Law may activate at any time, I thought to suggest confirming on the mailing list if the attendee list is complete.
> >  
> > Thanks,
> > Deborah
> >  
> > Hijacking this thread so as to keep hints together ???
> >  
> > Minutetakers/Chairs ??? you may want to send the list of names you captured on etherpad to your mailing list so folks can doublecheck.
> >  
> > As note-taker in yesterday???s ADD WG ...
> >  
> > From: Bron Gondwana
> > 
> > I also used 2 screens and found it really easy to get the speakers??? names from WebEx. Much easier (and with more accurate spelling) than transcribing the spoken form of names. It???s really helpful if people make sure to provide WebEx with their full name. And chairs of other WGs should log out of their WG accounts before connecting to an interim meeting for a WG they aren???t chairing ??? to avoid appearing in WebEx as ???<WG name> working group???.
> >  
> > Since people usually don???t bother identifying themselves in Etherpad, it probably wouldn???t have made a difference, for you to have known that there is a button on the upper right of the Etherpad screen where you can enter your name (so people can see who that color is). I did think about identifying myself there. But I didn???t, because it was mostly just me. I probably should have.
> > I do sometimes put notes about jabber chatter into the minutes, when it seems particularly relevant. Even if it???s just something like ???<robust jabber conversation on this topic>???. But I find it???s also true in F2F IETF sessions that being in the jabber room (even when physically present) is an essential part of the experience.
> > I do have a comment for people who intend to speak (especially presenters) ???
> > Consider doing whatever you can to ensure good quality audio is coming from you. For example, try to use wired Ethernet directly to your edge router (I moved my laptop and a monitor into the room where my router is so I could connect with Ethernet even though I wasn???t speaking ??? because I didn???t want to lose connectivity or have self-inflicted bad audio while taking minutes), use a headset that you???ve tested out and know works well, ask other family members to avoid bandwidth-consuming activities, etc.
> >  
> > -- 
> > Jay Daley
> > IETF Executive Director
> > [email-masked]

-- 
---
[email-masked]

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 26 Mar 2020 09:46:53 -0400

> Are you Churchill talking about democracy or do you have a better suggestion ?

Meetecho has a better system.

Why don't we replace Webex with Meetecho for virtual meetings?

	Thanks,
	Paul

---

From: Tim Chown <[email-masked]>
Date: Thu, 26 Mar 2020 13:48:03 +0000

> On 26 Mar 2020, at 13:46, Paul Kyzivat <[email-masked]> wrote:
> 

Sounds good to me.   Free Jabber integration too.

Tim

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 26 Mar 2020 13:54:03 +0000

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf Of Tim Chown
> Sent: Thursday, March 26, 2020 9:48 AM
> To: Paul Kyzivat <[email-masked]>
> Cc: [email-masked]
[acm] Because the team (Italy?) is on extreme lockdown? I think I heard this 
as a factor sometime back...

---

From: Tim Chown <[email-masked]>
Date: Thu, 26 Mar 2020 14:05:25 +0000

> On 26 Mar 2020, at 13:54, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
> as a factor sometime back…

Ah, I hadn’t realised where they were based.  I hope they’re all ok.

Tim

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 26 Mar 2020 10:15:36 -0400

The current Meetecho implementation requires people in the physical meeting
room to push the red button and run the equipment. There would probably be
some amount of development required by the Meetecho team to make it usable
in a totally remote environment. And we do indeed wish them well, being
located in Italy.

Cheers,
Andy

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 26 Mar 2020 10:21:21 -0400

> as a factor sometime back...

That is certainly an issue in the short term. But could still be a 
consideration for the longer term.

I don't have an understanding of whether Meetecho is set up to handle 
increased load. It seems like it was built with IETF f2f meetings as its 
primary use case. I don't know if it is currently set to scale beyond 
that. For our live meetings there is almost always hands-on support for 
each session.

But it certainly seems like something we should be exploring. Its 
features (blue sheets, queuing, jabber support, etc.) are all tuned for 
our meetings.

	Thanks,
	Paul

---

From: Jay Daley <[email-masked]>
Date: Fri, 27 Mar 2020 10:08:11 +1300

Replying to multiple messages

Meetecho assure me that they can support fully virtual meetings and have for some time with this already being the case for virtual EDU sessions.  However that was not widely known until recently and so we were working on imperfect information.

Additionally, Meetecho has always been run on our own meeting infrastructure, which we ship to each venue, and our kit is currently in Vancouver.  The NOC team made a heroic effort to enable us to run Meetecho on a different infrastructure but trying this for the first time at such short notice is a significant risk. 

After IETF 107 we have time to test things and then make a more thought out choice (IESG/LLC decision) on what remote collaboration platform to use for any future virtual meetings.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 27 Mar 2020 00:27:51 +0100

Thanks for the update Jay

Let us (wgchairs) know when meetecho needs guinea pigs..