Subject: A Meeting Bot

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Mar 2020 07:47:38 +1100

If you've participated in the W3C before, you're probably aware of their very useful IRC bot, Zakim. 

Among other things, Zakim manages queues of speakers during meetings, both physical and virtual. Seeing that we're having some trouble doing that in our new all-virtual world, I did a quick port of the more relevant features to an XMPP bot. 

So, meet meetingbot:
  https://github.com/mnot/meetingbot

Basically, you run it from the command line during your meeting, to manage the queue. It also allows you to run a simple hum (currently, participants can only select one option).

There's a test instance up on [email-masked] (it might go up and down, as it's currently running on my laptop; ask there if it doesn't seem to be working). Start by typing 'help'.

Feedback and contributions gladly accepted, the issues list is open.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Adam Roach <[email-masked]>
Date: Wed, 25 Mar 2020 11:56:24 -0500

On 3/24/2020 3:47 PM, Mark Nottingham wrote:
> It also allows you to run a simple hum (currently, participants can only select one option).

The IESG discussed the use of polling techniques, such as the one built 
in to Webex, as a potential replacement for humming to get the sense of 
the room. In-person humming has a lot more nuance for chairs to read 
than simple up/down voting; as a consequence, voting is a poor 
substitute for gauging general direction. As per the chair guide at 
<https://www.ietf.org/how/meetings/107/session-chair-guide/>, we instead 
ask that you rely on normal chairing techniques (e.g., explicitly 
soliciting opposing positions) rather than attempting to use hums or voting.

/a