Subject: Calendars

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 28 Apr 2020 10:52:38 -0400

Hello,

If we wind up with a repeat of how the last IETF was run, would others also
find it helpful to have a collective calendar including meeting invites of
all sessions?  Being able to customize or download all meetings in an area
to block off meetings would be so helpful for me and I am guessing others.
I likely missed a few interims I would have otherwise attended if I could
keep up with increased demands on my time (as many others have experienced).

Would it be possible to have this for interims?

Thank you!

-- 

Best regards,
Kathleen

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 28 Apr 2020 16:56:15 +0200

https://datatracker.ietf.org/meeting/upcoming.ics

> On 28. Apr 2020, at 16:52, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hello,
> 
> If we wind up with a repeat of how the last IETF was run, would others also find it helpful to have a collective calendar including meeting invites of all sessions?  Being able to customize or download all meetings in an area to block off meetings would be so helpful for me and I am guessing others.  I likely missed a few interims I would have otherwise attended if I could keep up with increased demands on my time (as many others have experienced).
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 28 Apr 2020 11:04:28 -0400

There is a major problem with that ics in terms of addressing Kathleen's 
request.
It works great if you load it once.
But it does not add changes to your calendar automatically.
And if you load it a second time, it duplicates all the meetings.

Yours,
Joel

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 28 Apr 2020 17:07:20 +0200

Works for me. I added it to my calendar client as a new “Internet calendar”.

> On 28. Apr 2020, at 17:04, Joel M. Halpern <[email-masked]> wrote:
> 
> There is a major problem with that ics in terms of addressing Kathleen's request.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Apr 2020 17:08:24 +0200

> And if you load it a second time, it duplicates all the meetings.

So best don't load it, subscribe to it instead.

Grüße, Carsten

---

From: Paul Wouters <[email-masked]>
Date: Tue, 28 Apr 2020 11:24:07 -0400 (EDT)

On Tue, 28 Apr 2020, Kathleen Moriarty wrote:

> If we wind up with a repeat of how the last IETF was run, would others also find it helpful to have a collective calendar including meeting invites of all
> sessions?  Being able to customize or download all meetings in an area to block off meetings would be so helpful for me and I am guessing others.  I
> likely missed a few interims I would have otherwise attended if I could keep up with increased demands on my time (as many others have experienced).

Not having a calendar for all meetings, whether online 'phyisical'
meeting or interim meetings, is a big problem for me. Yes, I would
like to have an IETF calendar I could sync to my phone. Possibly
not 1 IETF one, but one per WG.

> Would it be possible to have this for interims?

Especially for these it is important.

Paul

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 28 Apr 2020 15:37:37 +0000

I believe Tom was working on update the phone app to "be better" in this area.

---

From: Jane Coffin <[email-masked]>
Date: Tue, 28 Apr 2020 15:46:44 +0000

Kathleen –

A collective calendar would be very helpful.
Thank you for thinking of this.

Best,
Jane

From: irsg <[email-masked]> on behalf of Kathleen Moriarty <[email-masked]>
Date: Tuesday, April 28, 2020 at 10:55 AM
To: IETF WG Chairs <[email-masked]>
Subject: [irsg] Calendars

Hello,

Thank you!

--

Best regards,
Kathleen

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 28 Apr 2020 10:54:49 -0500

Right. The problem Joel's having is downloading the .ics instead of 
subscribing to the URL in a calendar program. You can also customize the 
.ics using the "Customize the agenda view" section of 
https://datatracker.ietf.org/meeting/agenda/ and then copy the resultant 
URL.

Once you subscribe, you get updates of cancellations and session moves, 
so long as you refresh regularly.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

On 28 Apr 2020, at 10:07, Mirja Kuehlewind wrote:

>>>> On 28. Apr 2020, at 16:52, Kathleen Moriarty 
>>>> <[email-masked]> wrote:
>>>>
>>>> Hello,
>>>>
>>>> If we wind up with a repeat of how the last IETF was run, would 
>>>> others also find it helpful to have a collective calendar including 
>>>> meeting invites of all sessions?  Being able to customize or 
>>>> download all meetings in an area to block off meetings would be so 
>>>> helpful for me and I am guessing others.  I likely missed a few 
>>>> interims I would have otherwise attended if I could keep up with 
>>>> increased demands on my time (as many others have experienced).
>>>>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 28 Apr 2020 11:59:27 -0400

I did the obvious think from the upcoming meetings page.  I clicked on 
the link.  I then told outlook to accept it as a calendar.

I would be happy to subscribe to it instead.  If someone tells me how to 
do so.  I would suggest someone also fix the page to tell people how to 
subscribe to it.
As it stands, clicking on the .ics link does something ineffective.

Yours,
Joel

---

From: Robert Sparks <[email-masked]>
Date: Tue, 28 Apr 2020 11:06:52 -0500

I haven't found anything that we can do at the datatracker to mark the 
link such that a calendar agent would say "oh, maybe the user wants to 
subscribe to this". If someone knows of such a thing, please say so.

The state of calendaring programs is that users have to go do that 
explicitly (and sometimes corporate policy prevents them from doing so).

RjS

On 4/28/20 10:59 AM, Joel M. Halpern wrote:
> I would be happy to subscribe to it instead.  If someone tells me how 
> to do so.  I would suggest someone also fix the page to tell people 
> how to subscribe to it.
>> subscribing to the URL in a calendar program. You can also customize 
>> the .ics using the "Customize the agenda view" section of 
>> https://datatracker.ietf.org/meeting/agenda/ and then copy the 
>> resultant URL.
>>
>> Once you subscribe, you get updates of cancellations and session 
>> moves, so long as you refresh regularly.
>>
>> pr
>

---

From: Lars Eggert <[email-masked]>
Date: Tue, 28 Apr 2020 19:24:48 +0300

> https://datatracker.ietf.org/meeting/upcoming.ics

This works great, but past meetings are removed very aggressively. I don't know if this was a recent change or whether I just never noticed it before, but it's a bit annoying. (I was trying to look back at last weeks meetings to find out when something had been scheduled - and there wasn't anything anymore to look at.)

Could we maybe remove meetings after a year or two instead of in the following week?

Lars

---

From: Michael Richardson <[email-masked]>
Date: Tue, 28 Apr 2020 12:44:48 -0400

> And if you load it a second time, it duplicates all the meetings.

As others have said, you need to subscribed to it, not load it.

The problem with the upcoming.ics is:

1) it includes a bunch of non-interim stuff like the EDU stuff, reception,
   etc.  That's only a problem when we have an actual in-person meeting
   because you wind up with two copies.

2) the meetings disappear from the feed a day or so after they occur.
   Robert has been tweaking this.

The bigger problem is not an IETF/operational problem, but maybe it's a
CalDAV issue.  The issue is that I don't usually want all of the interim
sessions in *my* calendar, I just want the ones that I intend to attend.

My option today is to "copy to Michael Calendar", which has the problem that
it does not get updated.  It has the plus that now I show up as busy during
that period, and this helps me from double-booking.

What we want is to be *invited* to that meetings we care about in a way that
we get updates.  This could be done by clients in some local way.
(I'd also like to be able to subscribe in the same way to the various Holiday
calendars that exist)

Or, the IETF could come up with some system where we ask the DT to invite us.
This would be something new.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 28 Apr 2020 13:01:52 -0400

Having what's in place for in person meetings would be a big improvement
over tracking each individual WG mailing list and manually entering
information, including the webex details.  This may not work for Joel, but
should for many.  I use a Google calendar if I can't use my internal
Outlook one and sometimes change which calendar an entry shows up in using
my phone if needed.

Thank you!
Kathleen

-- 

Best regards,
Kathleen

---

From: Ned Freed <[email-masked]>
Date: Tue, 28 Apr 2020 10:11:20 -0700 (PDT)

How you subscribe depends on your client. For example, in BusyCal there's a
"New Calendar Subscription" menu item that does this. It brings up a menu that
lets you enter the URL along with how often you want it to refresh.

> the link.  I then told outlook to accept it as a calendar.

There are directions explaining how to subscribe to a calendar in outlook.com
here:

 https://support.office.com/en-us/article/Import-or-subscribe-to-a-calendar-in-Outlook-com-cff1429c-5af6-41ec-a5b4-74f2c278e98c

Similar instruction are available for most clients.

> do so.  I would suggest someone also fix the page to tell people how to

It really isn't the job of the IETF to document how to do stuff in the myriad
different calendar programs, especially when it is subject to change. And
Microsoft has a habit of moving their documentation links around, so I cannot
really recommend trying to maintain links to their documentation either.

> As it stands, clicking on the .ics link does something ineffective.

The problem is there are multiple things people want to do with .ics
data. Like it or not, some additional guidance is needed.

All that said, if you expect the resulting subscription to contain up-to-date
URLs you need to join meetings, you may be disappointed. The IETF is still
coming to terms with doing this.

				Ned

---

From: Ned Freed <[email-masked]>
Date: Tue, 28 Apr 2020 10:36:08 -0700 (PDT)

I hadn't noticed this before so I checked. Yep, it's doing that and IMO
it's a bug, not a feature. Please fix.

Given the (tiny) amount of data involved and the need to keep track of historical
stuff, I'd suggest a least three years.

				Ned

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 28 Apr 2020 12:43:12 -0500

> subscribe to this". If someone knows of such a thing, please say so.

There is this <https://en.wikipedia.org/wiki/Webcal> (unfortunately).

Perhaps you could include a webcal: link in addition to the http: link.

pr

---

From: Fred Baker <[email-masked]>
Date: Tue, 28 Apr 2020 16:14:49 -0700

I appreciate and use the “tools-style calendar”, which allows me to identify the meetings I want to be part of and subscribe to a custom calendar containing them.

Sent from my iPad

> On Apr 28, 2020, at 7:55 AM, Kathleen Moriarty <[email-masked]> wrote:
> 
> 
> Hello,
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 28 Apr 2020 16:16:03 -0700

Sent from my iPad

> On Apr 28, 2020, at 8:04 AM, Joel M. Halpern <[email-masked]> wrote:
> 

I don’t have that problem when I subscribe to a calendar. If it changes, the .ics files have sequence numbers, and change accordingly.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Apr 2020 13:10:10 +0000

In other groups I participate in, they provide instructions for how to subscribe to calendars in commonly-used email apps.

This is how those instructions would be expressed in the context of IETF's calendar.ics:

Apple Calendar:
    "File" -> "New Calendar Subscription".
    Paste " https://datatracker.ietf.org/meeting/upcoming.ics" and click "Subscribe".
    Click "OK" in new window that pops up.

Microsoft Outlook Calendar:
    "Open Calendar" -> "From Internet".
    Paste " https://datatracker.ietf.org/meeting/upcoming.ics" and click "Yes". 
    Note: Click left-pointing arrow next to the calendar title for combined view.

Google Calendar:
    Go to Google Calendar.
    Above the list of My Calendars, click the plus sign to the right of "Add a coworker's calendar"
    Click "From URL"
    Paste " https://datatracker.ietf.org/meeting/upcoming.ics" and click "Add Calendar".

Barbara

> -----Original Message-----
> From: Robert Sparks
> 
> I haven't found anything that we can do at the datatracker to mark the link
> such that a calendar agent would say "oh, maybe the user wants to subscribe
> to this". If someone knows of such a thing, please say so.
> 
> The state of calendaring programs is that users have to go do that explicitly
> (and sometimes corporate policy prevents them from doing so).
> 
> RjS
> 
> >> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf
> >> .org_meeting_agenda_&d=DwIDaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=D90goGuJRNOwjZY00Iz5U9WGktnqt_D3jUIT1afnIiE&s=
> xn263DauzdjcKvfM9J85fRkN1jsnQPFBWWSQ2INXQCA&e=  and then copy
> the resultant URL.
> >>