Subject: Necessary webex info for mobile devices

From: Tom Pusateri <[email-masked]>
Date: Thu, 23 Apr 2020 12:40:29 -0400

Working Group chairs,

After experimenting with using Webex on mobile devices to join interim meetings, I want to recommend that Working Group Agenda pages provide separate links for joining the session on a mobile device.

The difference is that the Webex mobile apps (both iOS and Android) require a password while the browser version does not. Please include the 9-digit Meeting Id and the Meeting password in your Remote instructions.

Given the example information for a webex session in the remote instructions:

https://ietf.webex.com/ietf/j.php?MTID=m8d49e59807a47eec1d8cf5fbd4f81fa3

Meeting Id: 616 191 802
Meeting password: 3JNxacS23pS

The browser based URL for joining will not work on a mobile device.

The URL for mobile devices is:

wbx://ietf.webex.com/ietf?MK=616191802&MPW=3JNxacS23pS

MK is the 9 digit meeting Id
MPW is the meeting password

In order to join the webex from a mobile browser or a mobile app agenda page like on the iOS/iPad OS app IETFers, the mobile URL should be placed on the agenda page for now.

In the future, this information may be available through the datatracker and mobile apps can add buttons to join seamlessly.

Thanks for your assistance in supporting mobile,

Tom

---

From: Mallory Knodel <[email-masked]>
Date: Thu, 23 Apr 2020 13:51:57 -0400

Hi all,

I can report that I've used my mobile device to join all remote sessions
and on my iPhone the web/MTID URL would transfer me via Safari browser,
detect that I had the app and then automatically open correctly. I can
imagine that other OS+browser configurations do not work as smoothly.

-Mallory

On Thu, Apr 23, 2020 at 1:03 PM Tom Pusateri <pusateri=
[email-masked]> wrote:

> Working Group chairs,
>
> After experimenting with using Webex on mobile devices to join interim
> meetings, I want to recommend that Working Group Agenda pages provide
> separate links for joining the session on a mobile device.
>
> The difference is that the Webex mobile apps (both iOS and Android)
> require a password while the browser version does not. Please include the
> 9-digit Meeting Id and the Meeting password in your Remote instructions.
>
> In order to join the webex from a mobile browser or a mobile app agenda
> page like on the iOS/iPad OS app IETFers, the mobile URL should be placed
> on the agenda page for now.
>
> In the future, this information may be available through the datatracker
> and mobile apps can add buttons to join seamlessly.
>

-- 
Mallory Knodel
CTO, Center for Democracy and Technology
gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 23 Apr 2020 14:25:04 -0400

Did it prompt you for a password? That is what I faced on an iPad so this alternative URL scheme gets you directly in without prompts. 

Thanks,
Tom

> On Apr 23, 2020, at 1:52 PM, Mallory Knodel <[email-masked]> wrote:
> 
> 
> Hi all,
> 
> I can report that I've used my mobile device to join all remote sessions and on my iPhone the web/MTID URL would transfer me via Safari browser, detect that I had the app and then automatically open correctly. I can imagine that other OS+browser configurations do not work as smoothly.
> 
> -Mallory
> 
>> On Thu, Apr 23, 2020 at 1:03 PM Tom Pusateri <pusateri=[email-masked]> wrote:
>> Working Group chairs,
>>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 23 Apr 2020 18:34:11 +0000

And further:

You can specify a meeting password when you create the meeting. Often that makes life easier as it can be WG name or IETF.

And for those using just a phone to get in, if you don’t get the numeric (phone call) password, you can generate it by mapping the letters to the numbers. Thus, for phones, Meeting password 3JNxacS23pS should be 35692272377.

  *   Bernie

From: WGChairs <[email-masked]> on behalf of Tom Pusateri <pusateri=[email-masked]>
Date: Thursday, April 23, 2020 at 2:25 PM
To: Mallory Knodel <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [irsg] Necessary webex info for mobile devices

Thanks,
Tom

-Mallory

On Thu, Apr 23, 2020 at 1:03 PM Tom Pusateri <pusateri=[email-masked]<mailto:[email-masked]>> wrote:
Working Group chairs,

Meeting Id: 616 191 802

wbx://ietf.webex.com/ietf?MK=616191802&MPW=3JNxacS23pS<http://ietf.webex.com/ietf?MK=616191802&MPW=3JNxacS23pS>

Tom

---

From: Mallory Knodel <[email-masked]>
Date: Thu, 23 Apr 2020 14:49:30 -0400

No it did not. Safari did verify that I wanted it to open the app, and
that's all.

On Thu, Apr 23, 2020 at 2:25 PM Tom Pusateri <[email-masked]> wrote:

> Did it prompt you for a password? That is what I faced on an iPad so this
> alternative URL scheme gets you directly in without prompts.
>
> Thanks,
> Tom
>

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 23 Apr 2020 17:12:20 -0400

I have now seen this as well where the regular URL worked on the iPad without any password. I don't know how the previous webex sessions were created that required passwords. Maybe this is an option when creating the webex session. I do not have access to this so I cannot confirm this.

Regardless, if you use the desktop URL on mobile, the IETFers app will have to go through Safari first to get to the Webex app. If you have a content blocker like Firefox Focus enabled, the webex URL will be blocked by default (this happened to me).

Going directly to the wbx: url scheme avoids this trip through Safari.

Thanks,
Tom

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Apr 2020 02:25:03 +0200

Tom,

Have you tried to just click on the meeting URL on your phone ?

I think it's been maybe two years since i last tried webex on mobile,
but then the URL did work with the webex app installed on the phone.
Aka: Traditionally, the MTID did encode meeting id and password.

I am not aware of another type of single link you could click on
to get into a webex on a phone than those that you can also use
on a PC. The Meeting ID/Password themselves can of course
be manually typed into the webex app anywhere (phone, PC),
but that's not a link. Thats content on a web page.

When the working group chair has set up the interrim "correctly",
it should AFAIK show everything, as it does e.g.: in my ANIMA WG
meetings material page:

https://datatracker.ietf.org/meeting/interim-2020-anima-01/session/anima
Remote instructions:  Access: 614 444 982 Password: AMvJRJwr392 URL: https://ietf.webex.com/ietf/j.php?MTID=m378d8c28c45a9f786868c586138a0450

"correctly" may be difficult though. Webex hates me, so when i
created the interrim, it created a webex on my free Webex account
server even though i was logged in via my ANIMA chair webex acccount,
so i had to manually edit the datatracker webex info as shown above.

It is highly recommended to use the tagged format
as shown above, so that the tooling can automatically extract the
URL from it and create the link to it on the agenda page.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 23 Apr 2020 20:29:58 -0400

Toerless,
	Yes, I have tried many of the IETF webex https MTID links and have been prompted for a password. But sometimes it works without a password. But this also requires going through Safari which introduces another point of failure (content filters, etc). It should be more reliable to use the wbx: links with meeting Id and password specified as MK and MPW.

I also should be able to catch the wbx: url link failure in my app and direct the user to the App Store to install Webex Meeting if they haven’t already.

Thanks,
Tom

> On Apr 23, 2020, at 8:25 PM, Toerless Eckert <[email-masked]> wrote:
> 
> Tom,
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Apr 2020 04:18:17 +0200

So, whats exactly the workflow you would like to do on eg.: android.

I just tested setting up webex meeting, then including into
the invite myg mail address. Then gmail on the phone, touch on
the "Join" button in the mail, and it gets into the installed
webex app on the phone without password and that join button
also was just an MTID URL.

So, maybe if you can reproduce a situation where it does not
work, or if you would like a different workflow than
what i describe.. ? 

Or are you asking for the webex URL to be included into
some specific android/ios app, like the IETF schedules ?
Not useful unless we have such an app for interims, right ?

Not sure i remember MK or MKW URLs. Or what do you mean ?

Cheers
    Toerless

On Thu, Apr 23, 2020 at 08:29:58PM -0400, Tom Pusateri wrote:
> I also should be able to catch the wbx: url link failure in my app and direct the user to the App Store to install Webex Meeting if they haven???t already.
> 
> Thanks,
> Tom
> 
> 

-- 
---
[email-masked]

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 24 Apr 2020 18:03:21 -0400

> On Apr 23, 2020, at 10:18 PM, Toerless Eckert <[email-masked]> wrote:
> 

Initially, when I used the MTID parameter and the https: scheme, I got redirected through Safari and into the iOS Webex app, but I was still prompted for the password. I don’t want to have to enter the password. This doesn’t happen all the time though. I don’t know what causes it.

I have tried to reach out to webex people for help but I haven’t been able to find anyone.

On mobile devices there are two cases:

1. you have the app installed
2. you don’t have the app installed

If you have the app installed, I would like to access directly from IETFers mobile app on iOS/iPad OS without having to go through safari. This means using the wbx: scheme and not the https: scheme. This prevents content blockers from causing trouble in Safari. A similar situation could occur on Android.

If you don’t have the app installed, and I try to open the wbx: scheme from inside the iOS app, I will get an appropriate error and I can open the App Store to the Webex Meeting App for installation.

In the future when the remote instructions come through the datatracker, I can do this automatically in the IETFers app. For now, I’m asking for the wbx: URLs be put in the agendas.

> Not useful unless we have such an app for interims, right ?

The iOS IETFers app works now with interim meetings.

> Not sure i remember MK or MKW URLs. Or what do you mean ?

These are the meeting id and password URL attributes on the wbx: scheme.

Thanks,
Tom

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Apr 2020 19:36:15 +0200

Tom,

I only have android, and don't see an app that displays me the
interims. Is there any ?

I guess that these mobile apps do all need to have some 
screen-scraping of datatracker URLs to work. Every interims
or IETF seession meetings material URL uses the same template
and has a free form "Remote Instructions" line, e.g.:

>> Remote instructions:  Access: 614 444 982 Password: AMvJRJwr392 URL: https://ietf.webex.com/ietf/j.php?MTID=m378d8c28c45a9f786868c586138a0450

I think most WGchairs only enter the webex URL but not the
Access and Password. I was lucky to steal my ANIMA session
setup ideas from OPSAWG which also had access and password included.

Even though i can not find any public webex documentation
for the format of the wbx: scheme (i hate obfuscation),
i would venture to guess that you can construct in the
app of your interest the wbx: URL from the access code,
password and non-MTID part of the URL.

Aka: all that seems to be needed is figure out how to make
WGchairs put not only the URL but also access code and password
into the remote instructions line when they create their
sessions. This is to the best of my knowledge all done
manually right now.

If this would work, maybe we just need a bit of more text
on the datatracker page where chairs enter this information
to guide them how to enter the important tags. That should
be a simple request to Henrik.

Cheers
    Toerless

On Fri, Apr 24, 2020 at 06:03:21PM -0400, Tom Pusateri wrote:
> Initially, when I used the MTID parameter and the https: scheme, I got redirected through Safari and into the iOS Webex app, but I was still prompted for the password. I don???t want to have to enter the password. This doesn???t happen all the time though. I don???t know what causes it.
> 
> I have tried to reach out to webex people for help but I haven???t been able to find anyone.
> 
> 2. you don???t have the app installed
> 
> If you don???t have the app installed, and I try to open the wbx: scheme from inside the iOS app, I will get an appropriate error and I can open the App Store to the Webex Meeting App for installation.
> 
> In the future when the remote instructions come through the datatracker, I can do this automatically in the IETFers app. For now, I???m asking for the wbx: URLs be put in the agendas.
> 

-- 
---
[email-masked]