Subject: change in Etherpad URLs ...?

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 9 Apr 2020 16:19:38 +0000

Hello,

I've noticed an issue with Etherpad URLs

We (NMRG) used to manage a set of pads with URLs in: https://etherpad.tools.ietf.org/p/something

Those URLs were working last time I checked (yesterday), but today it seems only the Etherpad URLs in: https://etherpad.ietf.org/p/something (no '.tools') are resolved.

The issue is that previous Etherpad URLs doesn't resolve anymore to the previous page content but to new, empty pads...

Has some recent changes been made to the Etherpad config?
(I've seen the :9090 thing but this is not impacting here).

My main request would be to be able to recover (even temporarily) the content of previous pads.
I don't mind porting them to the new URLs, but currently the content is (partly) lost; we have back-ups but not of all pads.

Thanks for the help you may provide.

Best regards, Laurent (as NMRG co-chair)

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 9 Apr 2020 18:31:14 +0200

Hi Laurent,

On 2020-04-09 18:19, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) wrote:
> We (NMRG) used to manage a set of pads with URLs in:
> https://etherpad.tools..ietf.org/p/something
> 
> Those URLs were working last time I checked (yesterday), but today it
> seems only the Etherpad URLs in:
> https://etherpad.ietf.org/p/something (no '.tools') are resolved.
> 
> The issue is that previous Etherpad URLs doesn't resolve anymore to
> the previous page content but to new, empty pads...
> 
> Has some recent changes been made to the Etherpad config? (I've seen
> the :9090 thing but this is not impacting here).

Yes.  The old pads at tools.ietf.org should have gone away a long time
ago, being replaced by the new ones at etherpad.ietf.org.  I believe
I transferred content at the time we did the switchover, but not now
when I finally took them down.
> 
> My main request would be to be able to recover (even temporarily) the
> content of previous pads. I don't mind porting them to the new URLs,
> but currently the content is (partly) lost; we have back-ups but not
> of all pads.

Ok, I see.  I'll make them available again for 24 hours.

> Thanks for the help you may provide.

Sorry for the disruption.  I really thought the usage of these had ended
now.

Best regards,

	Henrik

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Sun, 12 Apr 2020 09:16:41 +0000

Hi Henrik,

Please see below in-line.

Best regards, Laurent.

> -----Original Message-----
> From: Henrik Levkowetz <[email-masked]>
> Sent: Thursday, April 9, 2020 18:31
> To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> <[email-masked]>; [email-masked]
> Cc: Jérôme François <[email-masked]>
> Subject: Re: change in Etherpad URLs ...?
> 
> Hi Laurent,
> 

Thakn you very much.
I've now copy-pasted the content to the new pads URLs.
Everything is working fine.

> Sorry for the disruption.  I really thought the usage of these had ended

No worries. 
Since our meeting workflow was operational we haven't changed the pad URL for a while, this is why we haven't seen the need to update.
It's better n ow and thank you very much for you quick response and help.

Everything is in order now.

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 12 Apr 2020 22:27:41 +0200

> Please see below in-line.

Ack; thanks for confirming, Laurent.

I'll take the tools.ietf.org etherpad down again during the coming week.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 13 Apr 2020 11:49:08 +0200

> I'll take the tools.ietf.org etherpad down again during the coming week.

Can we have a redirect?

Grüße, Carsten