Subject: FYI: Meeting Pain Calculator

From: Mark Nottingham <[email-masked]>
Date: Mon, 4 May 2020 16:32:57 +1000

For a little while, the IAB has used a spreadsheet created by Martin Thomson to try to make the pain of our regular calls more equitably spread.

This has proven to be a valuable tool; it lets people see how meeting times affect other participants in a more graphic way, by calculating the 'pain' of different call times. For example, someone pushing back on a particular slot because it's mildly inconvenient to be on a call at 6pm or 7pm is not the same as getting someone up at 4am.

Since we seem to be doing more of this these days, I've created a new, cleaned up version, suitable for copying:
  https://docs.google.com/spreadsheets/d/1E8SnbkXk4K4rZVgMzK3m0UeNgmJdRfMgeBkA5Z6rQ7Q/edit?usp=sharing

Comments / questions / bugs / etc. welcome.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 04 May 2020 12:21:04 +0200

Thanks, nice :-)

Dirk

On 4 May 2020, at 8:32, Mark Nottingham wrote:

> For a little while, the IAB has used a spreadsheet created by Martin 
> Thomson to try to make the pain of our regular calls more equitably 
> spread.
>
> This has proven to be a valuable tool; it lets people see how meeting 
> times affect other participants in a more graphic way, by calculating 
> the 'pain' of different call times. For example, someone pushing back 
> on a particular slot because it's mildly inconvenient to be on a call 
> at 6pm or 7pm is not the same as getting someone up at 4am.
>
> Since we seem to be doing more of this these days, I've created a new, 
> cleaned up version, suitable for copying:

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 4 May 2020 15:29:11 +0000

It looks very impressive, and I am sure that it is useful, but I have no idea how to use it.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 4 May 2020 11:52:13 -0400

Rich,

I figured it out.

Open it up in Google Docs.

Make a personal copy of it, and work with your personal copy (the original
is read-only for good reason).

In the column on the left with the time zones, delete all of the time zones
that aren't pertinent to your meeting. The ones that are left will show
which hours of the day minimize total pain and which maximize total pain.
Smaller numbers are better.

Cheers,
Andy

---

From: Michael Richardson <[email-masked]>
Date: Mon, 04 May 2020 12:11:09 -0400

Andrew G. Malis <[email-masked]> wrote:
    > In the column on the left with the time zones, delete all of the time
    > zones that aren't pertinent to your meeting. The ones that are left
    > will show which hours of the day minimize total pain and which maximize
    > total pain.  Smaller numbers are better.

{yes, make a copy first...}

I thought that I should mark the time zone of each participant, so that
if there are 5 people in Berlin, and two in California, it will estimate the
pain of the Californian's in a weighted fashion.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 4 May 2020 12:21:12 -0400

Michael,

That hadn't occurred to me, but makes sense!

Cheers,
Andy

---

From: Fred Baker <[email-masked]>
Date: Mon, 4 May 2020 11:01:47 -0700

Or, re-create it to reflect the time zones you care about.

The timezones in Mark and Rich's spreadsheets presumably reflect the IAB, I presume. When I'm doing this for the RSSAC (which has members on the US east coast, US west coast, Amsterdam, Stockholm, and Tokyo)  or for ITU FG QIT4N (which has participants in China, US west coast, US east coast, Berlin, and Geneva), I go to the meeting planner at timeanddate.com and enter the relevant cities. What I'm trying to achieve is usually a time during which nobody has to be awake between midnight and 6:00 AM local time. I usually wind up looking in the vicinity of 13:00 or 14:00 UTC. It gets difficult when I need to also include Australia or New Zealand.

> On May 4, 2020, at 8:52 AM, Andrew G. Malis <[email-masked]> wrote:
> 
> Rich,
> 
> I figured it out.
> 
> Make a personal copy of it, and work with your personal copy (the original is read-only for good reason).
> 
> In the column on the left with the time zones, delete all of the time zones that aren't pertinent to your meeting. The ones that are left will show which hours of the day minimize total pain and which maximize total pain. Smaller numbers are better.
> 
> Cheers,
> Andy
> 
> 
> On Mon, May 4, 2020 at 11:29 AM Salz, Rich <rsalz=[email-masked]> wrote:

---

From: Michael Richardson <[email-masked]>
Date: Mon, 04 May 2020 17:17:31 -0400

> The timezones in Mark and Rich's spreadsheets presumably reflect the
    > IAB, I presume. When I'm doing this for the RSSAC (which has members on

They can be edited if you make a copy, and then you can put in your own
selection of time zones.

    > the US east coast, US west coast, Amsterdam, Stockholm, and Tokyo) or
    > for ITU FG QIT4N (which has participants in China, US west coast, US
    > east coast, Berlin, and Geneva), I go to the meeting planner at
    > timeanddate.com and enter the relevant cities. What I'm trying to
    > achieve is usually a time during which nobody has to be awake between

Yes, but as we move toward people in more time zones, that's not always
possible.  The point of this tool isn't, I think, to find a single time that
is best, but rather, to share the pain.

    > midnight and 6:00 AM local time. I usually wind up looking in the
    > vicinity of 13:00 or 14:00 UTC. It gets difficult when I need to also
    > include Australia or New Zealand.

Exactly.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [