Subject: Next iteration (was Experimental deployment of CodiMD)

From: Robert Sparks <[email-masked]>
Date: Wed, 17 Jun 2020 14:43:12 -0500

OAUTH2 integration with the datatracker is working now, and is the only 
way to login to https://codimd.ietf.org.

The site has been stable. I encourage groups to try using this instead 
of etherpad for upcoming interims and for IETF108.

Please let me know if you run into any difficulties.

RjS

---

From: Jim Schaad <[email-masked]>
Date: Wed, 17 Jun 2020 13:10:26 -0700

Does this mean that the current etherpad link has been changed for upcoming meetings. (Could have been in Henrik's mail but I have not got that far.)

> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Robert Sparks
> Sent: Wednesday, June 17, 2020 12:43 PM
> To: [email-masked]
> Subject: Next iteration (was Experimental deployment of CodiMD)
> 
> OAUTH2 integration with the datatracker is working now, and is the only way to
> login to https://codimd.ietf.org.
> 
> The site has been stable. I encourage groups to try using this instead of
> etherpad for upcoming interims and for IETF108.
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jun 2020 22:20:46 +0200

(This is the real-time markdown collaboration tool that is best known under its previous, now commercial name: hackmd.  It doesn’t do rfc-markdown right away, but often the ability to use snippets of markdown as editable material in a meeting is quite useful.  The tool even has a slide show mode!)

Great news!  Thank you.

Those that want to try this in various settings: There is a little pop-down in the right hand side of the tool that starts out with “editable — signed-in people can edit”.  In the long run, that may be the right setting, but until everyone has a datatracker account and gets used to using it, “freely — anyone can edit” may be the right, low-threshold setting during a meeting.

Use

  https://codimd.ietf.org/features?both

to get an overview of what can be in these notes, and maybe

  https://codimd.ietf.org/Cb5Guqn5RcmCptBWH1oLjg

to see some of that in action (upcoming ASDF BOF, maybe), and

  https://www.ietf.org/id/draft-onedm-t2trg-sdf-00.html#section-2.2-3.1.1

for how that later looks in the I-D or RFC...

Grüße, Carsten

> On 2020-06-17, at 21:43, Robert Sparks <[email-masked]> wrote:
> 
> OAUTH2 integration with the datatracker is working now, and is the only way to login to https://codimd.ietf.org.
> 
> The site has been stable. I encourage groups to try using this instead of etherpad for upcoming interims and for IETF108.
>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 17 Jun 2020 15:29:38 -0500

No, not yet, but we're working towards that eventually (assuming nothing 
major is found lacking with codimd).

---

From: Robert Sparks <[email-masked]>
Date: Wed, 17 Jun 2020 15:32:00 -0500

>    https://codimd.ietf.org/Cb5Guqn5RcmCptBWH1oLjg
fwiw, allow freeurl is set, so you can also create notes with readable 
names (like https://codimd.ietf.org/stir).

---

From: Jay Daley <[email-masked]>
Date: Thu, 18 Jun 2020 08:59:03 +1200

Just to note that Etherpad is built into Meetecho and as everyone will be using Meetecho for IETF 108 then that is probably how they will access it.  We will ask Meetecho how easy it is to switch out their Etherpad integration for CodiMD.

> On 18/06/2020, at 8:29 AM, Robert Sparks <[email-masked]> wrote:
> 
> No, not yet, but we're working towards that eventually (assuming nothing major is found lacking with codimd).
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 22 Jun 2020 14:44:48 +0300

Hi Robert,

thank you so much for setting this up, we will give it a try as an
alternative to etherpad during the next CoRE interim tomorrow.

I have been using hackmd for quite some time and I am now trying to set
up an instance internally. I am having few problems that I think are due
to the kubernetes installation, they are related to missing files under
"/config". I wonder if you run into that too.

Thanks!
-- Jaime

On Wed, Apr 22, 2020 at 11:01:51AM -0500, Robert Sparks wrote:
> Chairs -
> 
> I have an experimental deployment of CodiMD available at
> https://codimd.ietf.org (it is currently also available over http, but its
> on my list to change that).
> 
> It is currently configured to be very open, similar to how we have etherpad
> configured. Anonymous edits are allowed and any page can be created by
> making up a path. You can register with the site with a round-trip email
> verification and then your edits will be attributed to you. Later, we can
> look at integrating this with datatracker credentials.
> 
> If you want to try to use it as an alternative to etherpad, you can create a
> page with a name that makes sense and share it with your group.
> 
> For example: https://codimd.ietf.org/stir-interim-2020-04-20 (with content
> pasted anonymously from what we had in the etherpad).
> 
> Note that it allows very rich markup. See the documentation at
> https://hackmd.io/c/codimd-documentation/%2F%40codimd%2Fmarkdown-syntax. An
> example of some non-trivial markup is at https://codimd.ietf.org/stir.
> 
> This is not integrated with the datatracker. Links will not appear on the
> upcoming meetings page to this resource at this time.
> 
> If it gets uptake and we move it out of experimental, we'll start that
> integration.
> 
> Please try it out if you are interested and provide feedback.
> 
> Please also be very careful to copy your notes out immediately at the end of
> your session. This is experimental - I intend to keep it available, but it
> could go away at anytime if we learn that something fundamental needs to
> change.
> 
> RjS
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 22 Jun 2020 08:40:50 -0500

> "/config". I wonder if you run into that too.
No, I was able to deploy to heroku initially using one-click (the bot 
that builds an image directly from a github repository) pointed at 
https://github.com/hackmdio/codimd. All I've needed to do so far is set 
environment variables.

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 22 Jun 2020 17:32:38 +0300

On Mon, Jun 22, 2020 at 08:40:50AM -0500, Robert Sparks wrote:
> No, I was able to deploy to heroku initially using one-click (the bot that
> builds an image directly from a github repository) pointed at

I see, Heroku is indeed an easier way to do this. 
Will keep trying. 

Thanks!