Subject: Webex configuration

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Jun 2020 18:18:02 +0200

Collecting things I always forget when configuring a Webex conference under advanced options:
Can’t find the option right now:
— participants start muted (and no video)
Under scheduling options:
— participants can join 10 min ahead (not 5)
— hosts get a reminder 15 min (not 10 min) ahead
Under Audio connection options:
— no join/leave noise  [at least when you expect more than 10 participants]

What we need to remind people ahead of time:
— In the Webex join form, use your name (in Latin characters), not “bruce” or “E M” or “JB”.

What else?

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Jun 2020 18:36:10 +0200

I still haven't figured out whether i or webex was the cause of
my problems during 107:

-> I think i logged out of webex account, but was still showing up as ANIMA WG chair (account) during plenary.
-> I am sure i was logged in as ANIMA WG chair when i created my ANIMA interrim on datatracker but still the webex invite created was from the non-ietf webex account i hae (wrong server).

Luckily not problems for normal participants, but whenever you do have some form of webex account,
you need to be more careful. Especially now in times of corona, lot more participants of IETF
may use webex also at work. I have seen troubles changing names in webex from login id's
like r02345 to actual names.

Aka: explicit step-by-step what to do if your name does NOT show up correctly ?
(admittedly all the hoops to do that escaped me again as well...)

On Thu, Jun 11, 2020 at 06:18:02PM +0200, Carsten Bormann wrote:
> Can???t find the option right now:
> ??? participants start muted (and no video)
> ??? participants can join 10 min ahead (not 5)
> ??? hosts get a reminder 15 min (not 10 min) ahead
> ??? no join/leave noise  [at least when you expect more than 10 participants]
> 
> ??? In the Webex join form, use your name (in Latin characters), not ???bruce??? or ???E M??? or ???JB???..
> 
> What else?
> 
> Grüße, Carsten

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Jun 2020 18:40:54 +0200

> (admittedly all the hoops to do that escaped me again as well...)

Step 1: Install a browser you have never used before (the “virgin browser”)
Step 2: Still do all your Webex configuration work on the old browser
Step 3: Never log in to Webex on the virgin browser (or install another one if you did)
Step 4: Run all web conferences where you don’t want to be "American Red Cross Northern California Coastal Region” (yes, that happened today in an interim) from the virgin browser.

Grüße, Carsten

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 11 Jun 2020 15:00:12 -0400

Hi!

I had the same problem; I would show up as “Routing Area” on all
ietf.webex.com meetings; other *.webex.com allowed me to use any other name.

I solved the problem by getting a personal Webex account.  I downloaded the
app and now log into all ietf.webex.com from it.

I can be myself again. :-)

Alvaro.

On June 11, 2020 at 12:36:28 PM, Toerless Eckert ([email-masked]) wrote:

-> I think i logged out of webex account, but was still showing up as ANIMA
WG chair (account) during plenary.
-> I am sure i was logged in as ANIMA WG chair when i created my ANIMA
interrim on datatracker but still the webex invite created was from the
non-ietf webex account i hae (wrong server).

Luckily not problems for normal participants, but whenever you do have some
form of webex account,
you need to be more careful. Especially now in times of corona, lot more
participants of IETF
may use webex also at work. I have seen troubles changing names in webex
from login id's
like r02345 to actual names.

Aka: explicit step-by-step what to do if your name does NOT show up
correctly ?
(admittedly all the hoops to do that escaped me again as well...)

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Jun 2020 21:20:31 +0200

Given how you should (IMHO) run again for Routing AD, you should
use a Webex title of "Alvaro - your trusted routing AD"

Sorry, but i could not resist the joke after experiening all
the blunt and neverending election advertisements here in the USA on all
communication channels, and todays NOMCOM reminder. ;-))

Kidding aside: Leaving out the "your trusted", marketing fun,
i think it is actually a good suggestion to recommend to participants to 
include role/affiliation into their webex name. Especially for all
the newcomers to IETF.

I am listening to a Universities industry workshop these days, 
and there the Universities organizer actually did ask all
participants to put their affiliation into the their webex name,
so i can not even claim this to be my idea.

Cheers
    Toerless

On Thu, Jun 11, 2020 at 03:00:12PM -0400, Alvaro Retana wrote:
> Hi!
> 
> I had the same problem; I would show up as ???Routing Area??? on all

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 11 Jun 2020 15:48:09 -0400

> Step 1: Install a browser you have never used before (the “virgin browser”)

You can often use a Firefox _profile_ for this.
Not every browser provides this, or makes it easy to get to.
Also, some uses of "Igcognito" mode can help for this.

I personally find that logging out has worked for me (chrome), but I
understand that it has failed for others.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 11 Jun 2020 14:25:11 -0700

On June 11, 2020 at 3:20:34 PM, Toerless Eckert wrote:

Toerless:

Hi!

...
> include role/affiliation into their webex name. Especially for all

I think that the role, as relevant to the current meeting, may be a
good thing.  People may have different roles in different meetings, so
being able to change it easily from one call to the next would be
important.

Given that we participate as individuals I don't think that
recommending affiliation is appropriate.

My 2c,

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 11 Jun 2020 14:25:11 -0700

Toerless:

Hi!

...

My 2c,

Alvaro.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Jun 2020 23:58:48 +0200

> recommending affiliation is appropriate.

I think we should not conflate individual contribution
maxime with transparency about affiliation, and in doubt just
try to provide as much of the same community experience on-line
as we do in-person:

Since i remember, we have IETF registration / attendence lists
and badges with an affiliation field.

Sure, if you are a privacy advocate or once you know the community,
you would know how an affiliation choice of  "Rubber Ducky Inc."
would be well acceptable.  But the same is also true for the name field.
( What was the name on Warren's last badge ?)

Nevertheless, the mayority of attendees do use their real affiliation
on registration/badge publically, and if they are anywhere like me
(only in this respect!), they also see it as a benefit to know their
peers afiliations. 

Indeed, there is a good percentage of introductions on the microphone
during in-person meetings where affiliations are mentioned and also
a good amount of WG chairs that ask to do that (have no percentages).

Indeed i have heard enough concerns in the past when affiliations
where not transparent, such as contractors working for specific
companies and not disclosing it. 

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Jun 2020 00:57:43 +0200

In an interim today (forget which), a chair said about the blue sheet:
"Use whatever affiliation you think you are representing today”.

Not wanting to assign too much weight to this one-off, I think this is wrong.

(1) We use affiliation to identify people(*).

(2) We don’t represent companies/organizations.

Re what Toerless said:

(3) An affiliation cannot even start to disclose the entire web of contracts that a participant and/or their company operates under.  Asking a Cisco person to identify as “US Navy” because that happens to be the customer in whose interest they are bringing forward a feature sounds wrong.  Doesn’t get better for contractual relationships directly held by an individual.

(This is very different for the disclosure requirements of functionaries.  
I’m talking about participants here, which have absolutely no disclosure requirements beyond self-identification and the rules about patent claims they personally know of.)

Grüße, Carsten

(*) I know, if you use a now rare name like “Toerless”, maybe you don’t even have to give your last name.
Already doesn’t work for “Carsten”, unfortunately.

> On 2020-06-11, at 23:58, Toerless Eckert <[email-masked]> wrote:
>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 12 Jun 2020 13:54:53 -0400

> include role/affiliation into their webex name. Especially for all

It's rather a good idea.

    > so i can not even claim this to be my idea.

I also suggest that there is an important part of the interval [-5,+5]
minutes where one chats with people.  Make sure that you have communicated
with every single person who might be presenting, because that's when you
want find out if their mic works.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Jun 2020 20:45:10 +0200

> want find out if their mic works.

Good point that needs to be added to the Webex FAQ (once we write one up).

It is amazing to see the difference between Webex and a system that was designed by people who actually do have meetings not unlike the ones we have: BigBlueButton (BBB) that is.  It has polls (really useful in a classroom setting), you can upload your slides (so they don’t need to be sent as video) and draw on them in realtime (and, optionally, have participants draw on them as well); when integrated with an LMS (learning management system) you even have automatic identification.

Re the mike challenge: Everybody joining a BBB conference who intends to be able to speak (not a given with BBB - there is a listen-only mode) needs to go through a quick mike/speaker test.  Each time.  And it really only takes two seconds.

The potential to have your system designed by someone who knows what is important in real life (and who actually cares) is one of the really big benefits of the empowerment WebRTC gave us.

But yes, if you need to use a system that doesn’t have this, do chat in the [-4 min, +4 min] interval.  When we did the OneDM spring conference (with several two-to-three hour segments per week), we actually started to make a point out of using that time for informal chatting, as well.
Of course, it helps if the recording hasn’t been started yet :-)

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 12 Jun 2020 23:58:11 +0200

Cc'ing manycouches

On Fri, Jun 12, 2020 at 08:45:10PM +0200, Carsten Bormann wrote:
> It is amazing to see the difference between Webex and a system that was designed by people who actually do have meetings not unlike the ones we have: BigBlueButton (BBB) that is.  It has polls (really useful in a classroom setting), you can upload your slides (so they don???t need to be sent as video) and draw on them in realtime (and, optionally, have participants draw on them as well); when integrated with an LMS (learning management system) you even have automatic identification.

Let me Cc fluffy explicitly, he should know more authoritatively,
 i actually would like to phrase it more as questions:

Webex has polls, can upload slides, allows drawing on realtime... not sure about the other features.
BUT: these features don't seem to work in the RTCweb == browser version.
Michael Richardson i think would step up here and ask not to rely on features
not supported in the RTCweb version (whatever the tool is). And i am on the
fence with that argument.

Carsten: Do you know if these features work in BBB in RTCweb or equally only in native clients ?

I remember Cullen had a bix of an exchange about feature limits in RTCwebs
earlier on the IETF mailing list, so i am wondering and curious whether that
argument applies to these features. I could only imagine that the slides and
drawing could relate to RTCweb limitations. The raising hands sounds like
solely part of the javascript app.

If there are reasonable problems to do advanced features via RTCweb,
whatever the conferencing product is we choose, then i would suggest to reconsider
the "Must rely on lowest-common-RTCweb-denominator".

> Re the mike challenge: Everybody joining a BBB conference who intends to be able to speak (not a given with BBB - there is a listen-only mode) needs to go through a quick mike/speaker test.  Each t…

I don't think these tests find really common problems. Yesterday on a university
zoom meeting one of the speakers was continuously broken up, sounded like
very reliably overloaded upstream link from home. The tests typically are
only level issue based.

> The potential to have your system designed by someone who knows what is important in real life (and who actually cares) is one of the really big benefits of the empowerment WebRTC gave us.

See above Q.

Cheers
    Toerless

> But yes, if you need to use a system that doesn???t have this, do chat in the [-4 min, +4 min] interval.  When we did the OneDM spring conference (with several two-to-three hour segments per week), we actually started to make a point out of using that time for informal chatting, as well.  > Of course, it helps if the recording hasn???t been started yet :-)
> 
> Grüße, Carsten

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Jun 2020 00:15:20 +0200

> BUT: these features don't seem to work in the RTCweb == browser version.

OK, I have no idea — I haven’t used the installed version in ages.
(Just found a Webex invite from 2009, so I must have used it before.)

> Carsten: Do you know if these features work in BBB in RTCweb or equally only in native clients ?

There is no installable client for BBB — this idea was apparently abolished when WebRTC started to work.  Amazingly, this includes mobile!

> If there are reasonable problems to do advanced features via RTCweb,

The point is that very little of these features cannot be done by a normal web app, since about 2005 (easier now with “HTML5” and all that).  Adding in the audio/video is the part where WebRTC comes in.

> the "Must rely on lowest-common-RTCweb-denominator".

That’s not what we do at the university; you won’t get too happy with (Desktop) Safari, for instance.  You do need a modern browser that implements most of WebRTC.  Until a few weeks ago, that meant Chrome/Chromium-based browsers (such as Brave).  Firefox appears to have caught up a bit now, but all the students now “know” that they need Chrome/Chromium.

> very reliably overloaded upstream link from home. The tests typically are

They find the 80 % problem: Mike not plugged in (usually on the software side, not in hardware).

It is really hard to diagnose all the kinds of broken networks that students bring to the table.
And don’t get me started on the audio/webcam hardware that is sold these days...

>>  a system that doesn???t have this, […] if the recording hasn???t been started yet :-)

BTW, your mail reader still wants back to its comfortable 1990s.

Grüße, Carsten