Subject: Uploading minutes

From: Jim Schaad <[email-masked]>
Date: Wed, 29 Jul 2020 07:43:29 -0700

When I go to upload the minutes I see that it says that I can upload in the
format text/markdown.  How do I mark a file as being markdown so that it is
uploaded correctly?   Or are we still in the this cannot be done.  Uploading
the markdown from CodiMD would seem to be the easiest method.

Jim

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Jul 2020 16:45:52 +0200

On 2020-07-29, at 16:43, Jim Schaad <[email-masked]> wrote:
> format text/markdown.  

I still upload after conversion to HTML.

> How do I mark a file as being markdown so that it is
> uploaded correctly?  

Depends on browser, haven’t decoded a general theme here.

> Or are we still in the this cannot be done.  Uploading

(Explicitly.) Yes!

Grüße, Carsten

---

From: Russ Housley <[email-masked]>
Date: Wed, 29 Jul 2020 10:48:52 -0400

It worked for me with filename.md

Russ

> On Jul 29, 2020, at 10:43 AM, Jim Schaad <[email-masked]> wrote:
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 29 Jul 2020 15:09:14 +0000

I tried that but the tracker rejected the .md file.

Depending on the browser and the uploading device the error was a variation of 
Upload Content-Type (application/octet-stream) is different from the observed mime-type (text/plain)
Upload Content-Type (text/x-markdown) is different from the observed mime-type (text/plain)

So is there a trick ?

Pascal

> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Russ Housley
> Sent: mercredi 29 juillet 2020 16:49
> To: Jim Schaad <[email-masked]>
> Cc: IETF WG Chairs <[email-masked]>
> Subject: Re: Uploading minutes
> 
> > When I go to upload the minutes I see that it says that I can upload
> > in the format text/markdown.  How do I mark a file as being markdown so
> that it is

---

From: Jim Schaad <[email-masked]>
Date: Wed, 29 Jul 2020 08:27:55 -0700

What browser are you using?  I get an error "Upload Content-Type
(application/octet-stream) is different from the observed mime-type
(text/plain).

> From: Russ Housley <[email-masked]>
> Sent: Wednesday, July 29, 2020 7:49 AM

---

From: Russ Housley <[email-masked]>
Date: Wed, 29 Jul 2020 11:50:29 -0400

I used Firefox.

Russ

> On Jul 29, 2020, at 11:27 AM, Jim Schaad <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Jul 2020 18:04:15 +0200

> I used Firefox.

Now that is information we can use.

Just in case: On which platform?

Grüße, Carsten

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 29 Jul 2020 16:12:34 +0000

I use Firefox too. On windows I got the above error. So I tried chrome from an iPhone for diversity. What changed is the upload mine type. What did not change is the application analysis that my upload was analyzed as lain text which was a mismatch with the mime. 

I could upload the html from codi but the result is savantly transformed. 

Could it be that our tools are too safe or too intelligent?

Pascal

> Le 29 juil. 2020 à 18:05, Carsten Bormann <[email-masked]> a écrit :
>

---

From: Jim Schaad <[email-masked]>
Date: Wed, 29 Jul 2020 09:21:22 -0700

I already know he is on iOS

> From: Carsten Bormann <[email-masked]>
> Sent: Wednesday, July 29, 2020 9:04 AM
> To: Russ Housley <[email-masked]>
> Cc: Jim Schaad <[email-masked]>; IETF WG Chairs <[email-masked]>
> Subject: Re: [irsg] Uploading minutes
>

---

From: Jim Schaad <[email-masked]>
Date: Wed, 29 Jul 2020 09:48:50 -0700

On my windows machine, I added a key in the registry editor @ HKEY_CLASSES_ROOT\.md  with a value of "Content Type" "text/markdown".  It now lets me upload a .md file for minutes.  It displays the markdown as text when I look at the minutes.  It is not converted to html.  I verified that this was true with the minutes for LAMPS as well.

Jim

---

From: Russ Housley <[email-masked]>
Date: Wed, 29 Jul 2020 13:06:10 -0400

Oh, yes, I see.  The raw markdown was posted.

Russ

> On Jul 29, 2020, at 12:48 PM, Jim Schaad <[email-masked]> wrote:
>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 29 Jul 2020 12:10:26 -0500

> Oh, yes, I see.  The raw markdown was posted.
There is a ticket to recognize when we have markdown and display it as 
html, but this is not yet done.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 29 Jul 2020 19:33:14 +0200

Hi Pascal,

> Upload Content-Type (text/x-markdown) is different from the observed mime-type (text/plain)

In addition to Jim's trick to get the .md file classified as text/markdown,
I've now added 'text/x-markdown' to the recognised upload file mime types
for agendas and minutes.

Best regards,

	Henrik

---

From: Jim Schaad <[email-masked]>
Date: Wed, 29 Jul 2020 10:34:30 -0700

I also tried using the publish feature of CodiMD to produce HTML and then upload the HTML.  However it was "sanitized" by messing with the toc on the upper right corner and the result was not readable.

jim

> Sent: Wednesday, July 29, 2020 10:06 AM
> > On my windows machine, I added a key in the registry editor @
> HKEY_CLASSES_ROOT\.md  with a value of "Content Type" "text/markdown".  It
> now lets me upload a .md file for minutes.  It displays the markdown as text
> when I look at the minutes.  It is not converted to html.  I verified that this was
> true with the minutes for LAMPS as well.
> >
> > Jim
> >
> >

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 29 Jul 2020 19:39:15 +0200

Hi Jim,

> I also tried using the publish feature of CodiMD to produce HTML and then upload the HTML.  However it was "sanitized" by messing with the toc on the upper right corner and the result was not reada…

https://trac.tools.ietf.org/tools/ietfdb/ticket/3046

Best,  Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Jul 2020 23:56:05 +0200

> So is there a trick ?

Wait for the next datatracker version (7.12.0) having been deployed!

Archived-At: <https://mailarchive.ietf.org/arch/msg/codesprints/UHxZx8vDpbaTFKJv9vZRihTGTig>

Grüße, Carsten