Subject: IETF 108 session chair Meetecho testing

From: Greg Wood <[email-masked]>
Date: Fri, 24 Jul 2020 12:04:25 -0400

Hello,

Starting at 1800 UTC today, a Meetecho session will be open for testing by IETF 108 session chairs. It will be available throughout the IETF 108 Online meeting.

To ensure smooth testing for everyone, please reserve a time to test via this CodiMD page:

https://codimd.ietf.org/s/ry4pe__lP

Thanks for everyone’s patience as this was set up.

Sincerely,

-Greg

--

Greg Wood
[email-masked]
+1-703-625-3917

---

From: Michael McBride <[email-masked]>
Date: Fri, 24 Jul 2020 17:17:11 +0000

Thanks so much Greg, this will help a lot. Will this also allow a non-chair participant to test with us? We have a wg member who would like to practice sharing their screen, etc.

mike

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Greg Wood
Sent: Friday, July 24, 2020 9:04 AM
To: Working Group Chairs <[email-masked]>
Subject: IETF 108 session chair Meetecho testing

Hello,

https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcodimd.ietf.org%2Fs%2Fry4pe__lP&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C5d65a522d3ae4240133108d82feb4434%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312034795381572&amp;sdata=WW0Vx3rB6lIYZl79sTOyAoOBH7%2FKOHaE8AomGJ3GRlQ%3D&amp;reserved=0

Sincerely,

-Greg

--

Greg Wood
[email-masked]
+1-703-625-3917

---

From: Greg Wood <[email-masked]>
Date: Fri, 24 Jul 2020 14:15:22 -0400

Yes. Logging in via IETF Datatracker will enable joining the session as a participant.
-Greg

> On Jul 24, 2020, at 1:17 PM, Michael McBride <[email-masked]> wrote:
> 

--

Greg Wood
[email-masked]
+1-703-625-3917

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 24 Jul 2020 11:26:17 -0700

I am in the test session now and having trouble initiating screen sharing.
I logged in via datatracker.  Is there something I'm missing?

On Fri, Jul 24, 2020 at 11:15 AM Greg Wood <[email-masked]> wrote:

> > Thanks so much Greg, this will help a lot. Will this also allow a
> non-chair participant to test with us? We have a wg member who would like
> to practice sharing their screen, etc.
> >
> > mike
> >
> > Starting at 1800 UTC today, a Meetecho session will be open for testing
> by IETF 108 session chairs. It will be available throughout the IETF 108
> Online meeting.
> >
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcodimd..ietf.org%2Fs%2Fry4pe__lP&amp;data=02%7C01%7Cmichael.mcbride%40futurewei..com%7C5d65a522d3ae4240133108d82feb4434%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312034795381572&amp;sdata=WW0Vx3rB6lIYZl79sTOyAoOBH7%2FKOHaE8AomGJ3GRlQ%3D&amp;reserved=0
> >

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 24 Jul 2020 19:24:28 +0000

If you have macOS and not using Safari, you may have to change system settings as per https://www.ietf.org/media/documents/Documentation-Meetecho-IETF.pdf

From: WGChairs <[email-masked]> on behalf of Bernard Aboba <[email-masked]>
Date: Friday, July 24, 2020 at 2:26 PM
To: Greg Wood <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: IETF 108 session chair Meetecho testing

I am in the test session now and having trouble initiating screen sharing.  I logged in via datatracker.  Is there something I'm missing?

On Fri, Jul 24, 2020 at 11:15 AM Greg Wood <[email-masked]<mailto:[email-masked]>> wrote:
Yes. Logging in via IETF Datatracker will enable joining the session as a participant.
-Greg

> On Jul 24, 2020, at 1:17 PM, Michael McBride <[email-masked]<mailto:[email-masked]>> wrote:
>
> From: WGChairs <[email-masked]<mailto:[email-masked]>> On Behalf Of Greg Wood
> To: Working Group Chairs <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>
> +1-703-625-3917
>
>
>
>

--

Greg Wood
[email-masked]<mailto:[email-masked]>
+1-703-625-3917

---

From: Bob Hinden <[email-masked]>
Date: Fri, 24 Jul 2020 13:13:13 -0700

We finished our test session, feel much better using Meetecho to run a w.g. session.   Took a while, learned a few things:

I had to switch from Safari to Crome.   That worked better.  I am running MacOS 10.14.

Need to use a headset, other wise the audio quality is poor, lots of echos.   We are going to advise our w.g. that everyone should use a headset.

I have two screens (laptop and monitor).  I was able to run Meetecho on the monitor and the app to share on the laptop.

Also, joining the jabber room in a jabber app allows one to see the jabber queue and the participant list at the same time.  As a chair, one needs to always see the participant list to manage the queue.

We (chairs) will be presenting all of the slides, this will avoid wasting time having speakers figuring how how to share their slides.

Many thanks to Greg for setting this up.  It was essential to learn how to use it in chair mode!

Bob

> On Jul 24, 2020, at 9:04 AM, Greg Wood <[email-masked]> wrote:
> 
> Hello,
>

---

From: Kent Watsen <[email-masked]>
Date: Fri, 24 Jul 2020 20:56:02 +0000

A couple issues found:

1) On the "Scheduling Chairs Testing Time for MeetEcho” page, two links are dead (i.e. “site cannot be reached”).  These links are in the sentence:  "Before testing, please closely review the Session chair guide <https://https//www.ietf.org/how/meetings/108/session-chair-guide/> and the Meetecho documentation <https://https//www.ietf.org/media/documents/Documentation-Meetecho-IETF.pdf>."

2) We did a hum. There were only two of us (one “chair”, one “participant”).  The “participant” hummed LOUDLY, but the result came back “Niete”.   We assume that this is because there were also 10 Jabber users connected.  We don’t feel that Jabeer users should be counted as they cannot hum.

K.

> On Jul 24, 2020, at 4:13 PM, Bob Hinden <[email-masked]> wrote:
>

---

From: Greg Wood <[email-masked]>
Date: Fri, 24 Jul 2020 17:00:16 -0400

> On Jul 24, 2020, at 4:56 PM, Kent Watsen <[email-masked]> wrote:
> 
> A couple issues found:
> 
> 1) On the "Scheduling Chairs Testing Time for MeetEcho” page, two links are dead (i.e. “site cannot be reached”).  These links are in the sentence:  "Before testing, please closely review the Session chair guide and the Meetecho documentation."
> 

These were broken in the Markdown and are now fixed to point to:

https://www.ietf.org/how/meetings/108/session-chair-guide/

https://www.ietf.org/media/documents/Documentation-Meetecho-IETF.pdf

Apologies for the trouble.

-Greg

<snip>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Jul 2020 23:01:17 +0200

> Need to use a headset, other wise the audio quality is poor, lots of echos.   We are going to advise our w.g. that everyone should use a headset.

(Expect people who have properly configured audio subsystems to disagree.
But those that do, also know, so there maybe is no need to discuss this.)

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 23:08:06 +0200

> 2) We did a hum. There were only two of us (one ???chair???, one ???participant???).  The ???participant??? hummed LOUDLY, but the result came back ???Niete???.   We assume that this is because there were also 10 Jabber users connected.  We don???t feel that Jabeer users should be counted as they cannot hum.

Great catch.

One school of thought says that this is irrelevant, because a set of hums always needs
to be set up such that only the relative difference in the hum level is what counts.

The other school of thought says that the granularity of difference does
of course suffer when you're counting folks who do not/can-not hum.

Seem to me like the rideal solution is that the average is only gcounted fro thos who do
click on a hum level and in addition to that average, the report also says
many hum-votes / no-hum-total / no-hum-jabber-only.

Cheers
    Toerless

> >> Thanks for everyone???s patience as this was set up.
> >> 
> >> Sincerely,
> >> 
> >> -Greg
> >> 
> >> --
> >> 
> >> Greg Wood
> >> [email-masked]
> >> +1-703-625-3917
> >> 
> >> 
> >> 
> >> 
> > 
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 23:09:04 +0200

"Unless you know your heads-free audio performance well, please use a headset when you go to the mike"

seems like a perfect useful recommendation.

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Jul 2020 23:11:55 +0200

On 2020-07-24, at 22:56, Kent Watsen <[email-masked]> wrote:
> 
> 2) We did a hum. There were only two of us (one “chair”, one “participant”).  The “participant” hummed LOUDLY, but the result came back “Niete”.  

It is a virtual hum.  The microphones are not involved.

But more seriously, the guesswork behind these aggregated results makes them nearly useless.  I would appeal any decision based on these hum results that don’t happen to be what I wanted anyway.  I hope most WG chairs will know better.
(I’m sure most chairs will know that they will have no trouble translating
https://tools.ietf.org/html/draft-duke-shmoo-virtual-hum-00#section-3.4
into a hum result given the set of participants a number for which is not provided in the real-time situation of chairing a meeting.  NOT.)

> We assume that this is because there were also 10 Jabber users connected.  We don’t feel that Jabeer users should be counted as they cannot hum.

See https://tools.ietf.org/html/draft-duke-shmoo-virtual-hum-00#section-3.4

S ≤ 2 = Niente.  All worked as designed.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Jul 2020 23:13:11 +0200

On 2020-07-24, at 23:09, Toerless Eckert <[email-masked]> wrote:
> 
> heads-free audio performance

Thinking of previous mic lines, why does this ring so true? :-)

Grüße, Carsten

---

From: Kent Watsen <[email-masked]>
Date: Fri, 24 Jul 2020 21:36:41 +0000

We just did another test.

Three chairs with dual-logins:
    - once as a “chair” (i.e., 50000x)
    - and again via datatracker (i.e., as participants)

We did a hum.

All three ”participants" chose LOUD.

The result came back PIANISSIMO.

Again, there were 10 Jabbers connected at that the time.

I view including the Jabbers in the tally as a bug.

Kent

> On Jul 24, 2020, at 5:13 PM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Bob Hinden <[email-masked]>
Date: Fri, 24 Jul 2020 14:43:15 -0700

Carsten,

> On Jul 24, 2020, at 2:01 PM, Carsten Bormann <[email-masked]> wrote:
> 

I have no similar issues with other applications like Zoom, Webex, Whereby, and Facetime, but did with Meetecho.  I suspect the issue is with Meetecho, not the local audio system.

Bob

---

From: Jay Daley <[email-masked]>
Date: Sat, 25 Jul 2020 09:50:52 +1200

Kent

As you may not have seen the messages from me or Carsten I’ll just repeat this - the total number of participants has no effect on the result if a virtual hum, only the number of people that hum. The behaviour you describe is all to spec. 

Jay

-- 
Jay Daley
IETF Executive Director

(Sent from a mobile device that insists on putting the signature at the top *sigh*)

> On 25/07/2020, at 9:37 AM, Kent Watsen <[email-masked]> wrote:
>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 24 Jul 2020 21:51:34 +0000

2.  **_s_ > 2 and **_s_ <= 10: pianissimo

On 2020-07-24, 5:37 PM, "WGChairs on behalf of Kent Watsen" <[email-masked] on behalf of [email-masked]> wrote:

    We did a hum.

    Kent

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2020 00:03:43 +0200

> On 2020-07-24, at 23:43, Bob Hinden <[email-masked]> wrote:
> 
> Carsten,
> 

Maybe it’s in the name :-)

Echo cancellation happens locally, in the OS or, as a fallback, in the Browser.
Theoretically, Meetecho could be disabling the cancellation.  Hmm.

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Fri, 24 Jul 2020 15:17:01 -0700

Jay,

> On Jul 24, 2020, at 2:50 PM, Jay Daley <[email-masked]> wrote:
> 
> Kent
> 

If I understand what you are saying and how I read the draft (draft-duke-shmoo-virtual-hum-00), this isn’t a useful tool.

For example, there are 50 people in the room, and only 10 hum loudly (there isn’t a no hum button), then the result will indicate that there is support, when there is not because only 10 of 50 actually hummed to express support.   This kind of result is clear in a face to face meeting, but not with this tool.

In this example the algorithm in Section 3.4 will return “piano”.   The algorithm is also easily skewed if it is a big room (~200 people) and 50 people hum loudly.

The chairs will have no idea how many people hummed.   The chairs can't evaluate the level of support for the question being called.

The algorithm needs to take into account the number of people in the room and how many hummed.

Bob

---

From: Michael McBride <[email-masked]>
Date: Fri, 24 Jul 2020 22:23:24 +0000

Is there a way to share all powerpoint windows in order to quickly switch between ppt's? I'm having to quit sharing of one ppt and then start a new share of a new ppt. Doable but it would be nice to just share an app and then switch between ppts without having to quit and reshare.

Thanks,
mike

-----Original Message-----
From: Greg Wood <[email-masked]> 
Sent: Friday, July 24, 2020 11:15 AM
To: Michael McBride <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: IETF 108 session chair Meetecho testing

> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcodimd.ietf.org%2Fs%2Fry4pe__lP&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C9f24a30642b44aa6228308d82ffd89ac%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312113300844524&amp;sdata=jXH7NyrrYRTJHHakpg%2B6%2FaGddgD2VENp3RzqwWcGcDA%3D&amp;reserved=0
> 

--

Greg Wood
[email-masked]
+1-703-625-3917

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 24 Jul 2020 22:49:46 +0000

> From: Michael McBride
> 
> Is there a way to share all powerpoint windows in order to quickly switch
> between ppt's? I'm having to quit sharing of one ppt and then start a new
> share of a new ppt. Doable but it would be nice to just share an app and then
> switch between ppts without having to quit and reshare.

Instead of PPT, save as PDF and have each open in a browser tab, ready to go. Then share the browser and switch between tabs.
Barbara

> > Thanks so much Greg, this will help a lot. Will this also allow a non-chair
> participant to test with us? We have a wg member who would like to practice
> sharing their screen, etc.
> >
> > mike
> >
> > Starting at 1800 UTC today, a Meetecho session will be open for testing by
> IETF 108 session chairs. It will be available throughout the IETF 108 Online
> meeting.
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__nam11.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-
> 252Fcodimd.ietf.org-252Fs-252Fry4pe-5F-5FlP-26amp-3Bdata-3D02-257C01-
> 257Cmichael.mcbride-2540futurewei.com-
> 257C9f24a30642b44aa6228308d82ffd89ac-
> 257C0fee8ff2a3b240189c753a1d5591fedc-257C1-257C0-
> 257C637312113300844524-26amp-3Bsdata-3DjXH7NyrrYRTJHHakpg-252B6-
> 252FaGddgD2VENp3RzqwWcGcDA-253D-26amp-3Breserved-
> 3D0&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=nSCye9gCoUM8fceUWG4xrCTWyuqMlMODZtzCtB04G
> AE&s=qJIDRL55Xud9lbaZ8iCbAvwIhnO5oFr7GUNM1ibS4D4&e=
> >

---

From: Jay Daley <[email-masked]>
Date: Sat, 25 Jul 2020 11:17:40 +1200

Thanks Bob - Can you provide that feedback in manycouches where that spec is being discussed?

> On 25/07/2020, at 10:17 AM, Bob Hinden <[email-masked]> wrote:
> 
> Jay,
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Dave Thaler <[email-masked]>
Date: Fri, 24 Jul 2020 23:42:43 +0000

I read the draft and I disagree with Bob's response (or else I don't understand it).
As the draft notes it is typical to do 2 (or more) hums, e.g., for and against.
Once you do both hums in a room with 50 people, you can tell whether for or against
is louder, or whether they're both roughly the same in terms of loudness.

Dave

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Bob Hinden
Sent: Friday, July 24, 2020 3:17 PM
To: Jay Daley <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: [irsg] IETF 108 session chair Meetecho testing

Jay,

Bob

---

From: Michael McBride <[email-masked]>
Date: Sat, 25 Jul 2020 00:08:44 +0000

Hi Barbara,

> From: Michael McBride
> 
> Is there a way to share all powerpoint windows in order to quickly 
> switch between ppt's? I'm having to quit sharing of one ppt and then 
> start a new share of a new ppt. Doable but it would be nice to just 
> share an app and then switch between ppts without having to quit and reshare.

Barbara

Thanks. It looks like I can only share one browser tab at a time as well, doesn't allow me to just share chrome. I'll test again this weekend.
mike

> > non-chair
> participant to test with us? We have a wg member who would like to 
> practice sharing their screen, etc.
> >
> > mike
> >
> IETF 108 session chairs. It will be available throughout the IETF 108 
> Online meeting.
> >
> > To ensure smooth testing for everyone, please reserve a time to test 
> > via
> this CodiMD page:
> >
> > https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fur
> > ldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-&amp;data=02%7C01%7Cm
> > ichael.mcbride%40futurewei.com%7Ce14d123644374d3231b108d83023e062%7C
> > 0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637312277935527303&amp;sd
> > ata=INWCXFuKzjRaAva4aDcRc1Avz9DTEDAs6x8gbltZrak%3D&amp;reserved=0

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 24 Jul 2020 21:19:59 -0400

I was doing some testing with the meetecho folks (who are amazingly 
helpful) for a different problem.
As part of that, I shared different things.
What I observed was that if meetecho is in chrome then
a) when I want to share chrome things I share individual tabs
b) but if I share edge, it did not know about tabs, and just shared edge.

While I did not try it, I expect that the problem with powerpoint was 
that it was using different windows (nto different tabs) and therefore 
chrome could see them separately.  So it asked you to pick one.

Yours,
Joel

---

From: Bob Hinden <[email-masked]>
Date: Fri, 24 Jul 2020 19:29:41 -0700

Hi Dave,

> On Jul 24, 2020, at 4:42 PM, Dave Thaler <[email-masked]> wrote:
> 

Hums aren’t always used that way, but I still think it is a problem.   If you can’t tell the number of people humming, it’s still the same problem.   A hum where only a small percentage of the people respond for or against is meaningless.  This is obvious in a face to face meeting, but not with this tool.

All it would take to fix this is to show the number of people using the tool (and perhaps adding a silent button).  That would give the chairs enough information to evaluate the hum.

Bob

---

From: Kent Watsen <[email-masked]>
Date: Sat, 25 Jul 2020 03:24:25 +0000

Humming both for/against doesn’t help if large numbers of Jabber users can make both results be Niete.

IMO, only Participant users should be included in the tally, as Chairs, MeetEcho, and Jabber users cannot hum.  [BTW, I disagree with Chairs not being able to hum, as they are participants too when they takeoff their chair hats.]

Bob, the tool currently shows the number of people using the tool, but that number includes those that cannot hum (i.e., Jabbers, MeetEcho staff, and Chairs), and so isn’t the number we need.

The need for an explicit “no-hum” (vs. an implicit "neither loud/soft selected") may be helpful to handle cases where folks walked away from their computers or are otherwise distracted.

K.

> On Jul 24, 2020, at 10:29 PM, Bob Hinden <[email-masked]> wrote:
> 
> Hi Dave,
>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2020 08:57:41 +0200

On 2020-07-25, at 00:23, Michael McBride <[email-masked]> wrote:
> 
> share all powerpoint windows

I’ve been using consolidated decks; no window switching.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2020 09:03:24 +0200

> As the draft notes it is typical to do 2 (or more) hums, e.g., for and against.

That is exactly what is broken.

Hum 1: 26 against, 27 for.  The tool tells me that I have strong support, when in reality it is about equal sides.

Hum 2: 27 against, 58 for.  The tool tells me that support is meh, when in reality it was a two-thirds majority.

Comparing after rounding does not make any sense, especially if the rounding ranges are full octaves.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2020 09:28:39 +0200

This is also a nice example for what not to do when you move physical processes into the digital domain.  Humming is an interesting process, with known advantages and disadvantages.  It is not very precise, but pretty good for what we can do in a room.  Doing a skeuomorphic design in the digital space means we incur the same advantages and disadvantages, when we wouldn’t have to.

The important observation is that we use hums to (not a complete list):
(1) validate (rough) consensus [the opposing party doesn’t hum very loud]
(2) answer design choices that don’t have a well-defined technical answer
(3) evaluate support, energy, benefit.

Each of these use cases requires hums to be used in a specific way.  E.g., (1) relies on spatial perception (if you have a good volume of for-hummers, and can make out the against-hummers in space, you have rough consensus — of course, you still have to check what the arguments against are).

Instead of properly modeling these use cases (e.g., a calendar), we now have a skeuomorphic image (e.g., a digital image of a leather-bound diary), with all its disadvantages plus the ones added by the digital version not being a perfect copy (here: bad rounding).  Instead, we should have used the fact that we now get exact counts, and if we want to hide those exact numbers, hide them in a way that is appropriate for each of the use cases.

Sorry for this impromptu software design lecture.
The whole web conferencing space is amazing in this respect, as it exhibits a regression of at least a quarter century with respect to design for usability.

Grüße, Carsten

> On 2020-07-25, at 09:03, Carsten Bormann <[email-masked]> wrote:
>

---

From: Bob Hinden <[email-masked]>
Date: Sat, 25 Jul 2020 09:34:12 -0700

Kent,

> On Jul 24, 2020, at 8:24 PM, Kent Watsen <[email-masked]> wrote:
> 
> 

I also agree about the Chairs being able to hum, if ADs can hum, why not chairs?

> Bob, the tool currently shows the number of people using the tool, but that number includes those that cannot hum (i.e., Jabbers, MeetEcho staff, and Chairs), and so isn’t the number we need.

I agree.

> The need for an explicit “no-hum” (vs. an implicit "neither loud/soft selected") may be helpful to handle cases where folks walked away from their computers or are otherwise distracted.

I also agree.

Bob

---

From: Michael Richardson <[email-masked]>
Date: Sun, 26 Jul 2020 13:50:43 -0400

Bob Hinden <[email-masked]> wrote:
    Kent> IMO, only Participant users should be included in the tally, as
    Kent> Chairs, MeetEcho, and Jabber users cannot hum.  [BTW, I disagree
    Kent> with Chairs not being able to hum, as they are participants too
    Kent> when they takeoff their chair hats.]

    Bob> I also agree about the Chairs being able to hum, if ADs can hum, why not chairs?

IT IS NOT A VOTE.
You guys keep arguing franchise because you keep thinking it is about voting.
If you want a formal vote, then write a spec for that.
(Or pick a web site)

(Chairs should be listening. Both of them)

Humming is a way to allow shy people who may have objections to object
without being identified.  The existence of any hum against a proposal should
lead to further conversation!

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Sun, 26 Jul 2020 13:58:15 -0400

Carsten Bormann <[email-masked]> wrote:
    > This is also a nice example for what not to do when you move physical
    > processes into the digital domain.  Humming is an interesting process,
    > with known advantages and disadvantages.  It is not very precise, but
    > pretty good for what we can do in a room.  Doing a skeuomorphic design
    > in the digital space means we incur the same advantages and
    > disadvantages, when we wouldn’t have to.

    > (1) validate (rough) consensus [the opposing party doesn’t hum very

Ideally, just a single hum: hum if you object to this proposal (and discuss
                            if not in the rough)

    > (2) answer design choices that don’t have a well-defined technical

1) Hum if you can not live with proposal A.
2) Hum if you can not live with proposal B.
3) Hum if you have no preference.
[note you can hum for all three, but probably 1|2 & ~3. ]

    > (3) evaluate support, energy, benefit.

Hum if you will help with this effort.

In none of these cases does it matter how many people are in the room, or who
could have hummed.

    > The whole web conferencing space is amazing in this respect, as it
    > exhibits a regression of at least a quarter century with respect to
    > design for usability.

I strongly agree.
A major reason is that we have no standards and no interoperability, so
everyone has to build a closed vertical system which attempts to deal with
all users and all levels of sophistication.

We can't take the best-of-breed "Raise Hands" interface (from webex?) and mix
it in with the Zoom Gallery view, but use the Youtube watching mechanism from Jitsi.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Ben Campbell <[email-masked]>
Date: Sun, 26 Jul 2020 14:07:00 -0500

I’m sure I’m being obtuse here—but how do you edit that codimd page? I don’t seem to get an editable view, and was not asked to login.

Ben.

> On Jul 24, 2020, at 11:04 AM, Greg Wood <[email-masked]> wrote:
> 
> Hello,
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 26 Jul 2020 12:14:03 -0700

Append /edit or hit the pencil icon at the top next to the "209 views".

-Ben

---

From: Ben Campbell <[email-masked]>
Date: Sun, 26 Jul 2020 14:18:05 -0500

Ah, thanks! Now I see the tiny little pencil I didn’t notice the first time. I guess all my previous ventures into codimd already had the /edit in the URL :-)

Ben.

> On Jul 26, 2020, at 2:14 PM, Benjamin Kaduk <[email-masked]> wrote:
>

---

From: Bob Hinden <[email-masked]>
Date: Sun, 26 Jul 2020 17:22:31 -0700

Michael,

> On Jul 26, 2020, at 10:50 AM, Michael Richardson <[email-masked]> wrote:
> 
> 

Don’t you think I know what a hum is and that it’s not a vote?

> You guys keep arguing franchise because you keep thinking it is about voting.

No, I am raising this issue because given the current tool I can’t evaluate the results of the hum.

Bob

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 31 Jul 2020 15:39:53 +0200

Well, I just witnessed a BOF where exactly that happened.

We had a couple of hums pro or con, and both turned out forte.
It might have been 14 to 58 or 58 to 14, we’ll never now.
And it *was* a comparative hum (“voting”), whether we like that or not.

(I’m not saying what BOF that was even if you can find out: I *fully* accept the outcome of the BOF, and I’m not blaming anyone for anything except for myself.
So, no, I won’t appeal, contrary what I said below.
I’m just relating what happened, for all the people who said hums are not used in the way I said.)

Hums need work.

Grüße, Carsten

> On 2020-07-24, at 23:11, Carsten Bormann <[email-masked]> wrote:
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 31 Jul 2020 14:43:27 +0100

Have you never been in a meeting where the hum was indecisive? I have. That's why hums are only indicative and that (and other better reasons) are why we go to the list for our decisions.

Ciao,
Adrian

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Carsten Bormann
Sent: 31 July 2020 14:40
To: Working Group Chairs <[email-masked]>
Subject: Re: [irsg] IETF 108 session chair Meetecho testing

Hums need work.

Grüße, Carsten

---

From: Martin Duke <[email-masked]>
Date: Fri, 31 Jul 2020 06:48:42 -0700

>
>
> Hums aren’t always used that way, but I still think it is a problem.   If
> you can’t tell the number of people humming, it’s still the same problem.
>  A hum where only a small percentage of the people respond for or against
> is meaningless.  This is obvious in a face to face meeting, but not with
> this tool.
>
> All it would take to fix this is to show the number of people using the
> tool (and perhaps adding a silent button).  That would give the chairs
> enough information to evaluate the hum.
>
> Bob
>

The hum is a raw measure of sound, not normalized for the number of people
in the room. If a small number of people respond, it will come out as
niente or pianissimo -- which would signal the meaningless that you seek.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 31 Jul 2020 15:49:19 +0200

On 2020-07-31, at 15:43, Adrian Farrel <[email-masked]> wrote:
> 
> Have you never been in a meeting where the hum was indecisive? I have.

Me too.  That is a little more helpful if you *know* the hum was indecisive (and can possibly even make out the general direction of the source of that indecisiveness), than if you are kept in the dark due to double rounding.

> That's why hums are only indicative and that (and other better reasons) are why we go to the list for our decisions.

Sure.  We pretty much decided on a specific way of “go to the list” (a.k.a., “proponents, do more work”), so that is not the part I have a problem with.
 
Grüße, Carsten

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 31 Jul 2020 09:25:39 -0500

On 31 Jul 2020, at 8:49, Carsten Bormann wrote:

> Me too.  That is a little more helpful if you *know* the hum was 
> indecisive (and can possibly even make out the general direction of 
> the source of that indecisiveness), than if you are kept in the dark 
> due to double rounding.

I have loads of problems with the hum tool, but this case is not one of 
them. Whether it was 14 to 58 or 58 to 14 would make absolutely no 
difference to me. It tells me that there was significant support and 
significant objection to both positions, and were going to have to drill 
down and figure out what those are. You were not kept in the dark at all 
in this case.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 31 Jul 2020 09:46:43 -0500

On one point ...

> down and figure out what those are. You were not kept in the dark at all

The problem for me as BOF chair, and I hope for others, was that we went
from "forte do this work in the IETF"/"forte don't", which should have
indicated a lot of support and a lot of concerns/objections, to "the
proponents should go do more work" as a stated path forward - and Martin
would know better, but I don't think "forte do the work" could have just
been the proponents.

I called that out during the meeting ("if you think this work should
happen, don't sit and wait for the proponents to take the next step on
their own and see what happens next"), but it would have been awesome if
we'd had time for "for those who hummed 'don't', what are your objections
and concerns?".

I THINK we can dig that out of the notes + jabber log, but that's someone
digging, and clarity is a win.

Best,

Spencer

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 31 Jul 2020 14:50:57 +0000

I think a show-of-hands tool would be more useful and simpler in the virtual environment. It would be good for questions such as "How many people have read the document?", "How many people think this document is work that the WG should adopt?", or "How many people would be willing to actively review this document?" 

Thanks,
Acee

On 7/31/20, 10:26 AM, "WGChairs on behalf of Pete Resnick" <[email-masked] on behalf of [email-masked]> wrote:

    pr

---

From: Martin Duke <[email-masked]>
Date: Fri, 31 Jul 2020 07:53:20 -0700

Yes, I strongly suspect we will have a show-of-hands tool for 109.

On Fri, Jul 31, 2020 at 7:51 AM Acee Lindem (acee) <acee=
[email-masked]> wrote:

> I think a show-of-hands tool would be more useful and simpler in the
> virtual environment. It would be good for questions such as "How many
> people have read the document?", "How many people think this document is
> work that the WG should adopt?", or "How many people would be willing to
> actively review this document?"
>
> Thanks,
> Acee
>
> On 7/31/20, 10:26 AM, "WGChairs on behalf of Pete Resnick" <
> [email-masked] on behalf of [email-masked]> wrote:
>

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 31 Jul 2020 15:57:51 +0100

I hope so.

When we meet F2F hum is a way of anonymously showing opinion.

Anonymity is easily handled by the application when we meet remotely.

Stewart

> On 31 Jul 2020, at 15:53, Martin Duke <[email-masked]> wrote:
> 
> On Fri, Jul 31, 2020 at 7:51 AM Acee Lindem (acee) <acee=[email-masked] <mailto:[email-masked]>> wrote:
> On 7/31/20, 10:26 AM, "WGChairs on behalf of Pete Resnick" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>     > On 2020-07-31, at 15:43, Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
>     >>
>     Pete Resnick https://www.episteme.net/ <https://www.episteme.net/>

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 31 Jul 2020 09:59:44 -0500

On 31 Jul 2020, at 9:50, Acee Lindem (acee) wrote:

> people have read the document?", "How many people think this document 
> is work that the WG should adopt?", or "How many people would be 
> willing to actively review this document?"

[Starting to drift the thread a bit; sorry for that.]

Show of hands would definitely be good for questions 1 & 3, but why 
would a show of hands ever be done for question 2?

pr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 31 Jul 2020 15:04:25 +0000

On 7/31/20, 11:00 AM, "Pete Resnick" <[email-masked]> wrote:

To get an initial gage on interest. And yes I've seen your presentation on IETF consensus on more than one occasion and this would not be the actual adoption call. No need for a protracted discussion.

Thanks,
Acee

    pr

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 31 Jul 2020 10:17:27 -0500

Just a compulsive need to close the loops:

On 31 Jul 2020, at 9:46, Spencer Dawkins at IETF wrote:

> ...it would have been awesome if

Fully agree.

On 31 Jul 2020, at 10:04, Acee Lindem (acee) wrote:

> And yes I've seen your presentation on IETF consensus on more than one 
> occasion and this would not be the actual adoption call.

Of course this makes me very happy. ;-)

pr

---

From: Fred Baker <[email-masked]>
Date: Fri, 31 Jul 2020 13:23:58 -0700

> On Jul 24, 2020, at 3:23 PM, Michael McBride <[email-masked]> wrote:
> 

If this is powerpoint, as in "from Microsoft" (I don't keep track of the others), Powerpoint allows you to have a number of open windows. You would only be projecting one in any case, but you should be able to close a window, switch to a new one, and project it.

You can do the same with pdf from any of the several things on my Mac that deal with it.

Where I get confused is sequence - if I have two powerpoint files and five pdfs, closing one won't necessarily instantly reveal the next in sequence. That's not a showstopper; it only calls for a little care.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 1 Aug 2020 07:01:03 +0200

> Where I get confused is sequence - if I have two powerpoint files and five pdfs, closing one won't necessarily instantly reveal the next in sequence. That's not a showstopper; it only calls for a l…

Fred,

I think you are thinking about sharing a screen and cycling through windows on that screen.  This is hard to do on a laptop, where usually you have only one screen (unless you are using a solution like Apple’s Sidecar).  So we typically use Chrome’s “Share application window” function.

That works great for windows with tabs, where you cycle through tabs.  E.g., 
putting all decks into a Chrome window.

In contrast, presentation software usually creates a new window for each deck presentation (if you can present to a window at all — a very recent feature in Keynote), so you would have to use Chrome’s clumsy window selection interface each time you choose a presentation.

Consolidated decks (putting all slides into one deck) help with this, but require some planning (and some scrolling around if the sequence of presentations changes).

Grüße, Carsten