Subject: Pointing to github repositories from the datatracker

From: Robert Sparks <[email-masked]>
Date: Thu, 10 Sep 2020 14:22:17 -0500

Chairs -

A few releases ago, we changed the way the datatracker allows you to 
make references to external resources (see the section labelled 
Additional Resources on a document's main page or on a groups /about page).

If you are using github for your working group or a set of drafts, 
please consider pointing to the repository or organization using the 
github_repo and github_org tags respectively. The datatracker will use 
the urls you provide with those tags to backup the repositories.

(You'll see github and gitlab username tags in the hint for the edit 
form - those are not used by the backup mechanism - there is no need to 
enter any such thing for this purpose).

RjS

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 11 Sep 2020 09:35:47 +1000

Thanks Robert, that's helpful.

This makes me wonder about the converse -- turning things *off* in tools that WGs don't use.

For example, if you go to:
  https://datatracker.ietf.org/wg/quic/about/
and follow the 'Tools" link to:
  https://tools.ietf.org/wg/quic/
... there are several tools that the WG doesn't use (e.g., Wiki, Training). Furthermore, following "Wiki" to
  https://trac.ietf.org/trac/quic
leads to "Roadmap", "Browse Source", "View Tickets" that the WG also doesn't use.

Could we get these links (or tools?) able to be turned off by the WG chairs if they're not using them? They confuse newcomers, and generally having multiple sources of 'truth' isn't great. It also might be good to consider moving the creation of these tools to on-demand, rather than on-instantiation. 

Cheers,

> On 11 Sep 2020, at 5:22 am, Robert Sparks <[email-masked]> wrote:
> 
> Chairs -
> 
> A few releases ago, we changed the way the datatracker allows you to make references to external resources (see the section labelled Additional Resources on a document's main page or on a groups /about page).
> 
> If you are using github for your working group or a set of drafts, please consider pointing to the repository or organization using the github_repo and github_org tags respectively. The datatracker will use the urls you provide with those tags to backup the repositories.
> 
> (You'll see github and gitlab username tags in the hint for the edit form - those are not used by the backup mechanism - there is no need to enter any such thing for this purpose).
> 
> RjS
> 
> 

--
Mark Nottingham   https://www.mnot.net/