Subject: IETF 109 Preliminary Agenda

From: IETF Agenda <[email-masked]>
Date: Fri, 16 Oct 2020 15:49:11 -0700

The IETF 109 preliminary agenda has been posted. The final agenda will be published on Friday, October 23, 2020.  

If you would like to request a change to the preliminary agenda, please send a message to [email-masked] and copy all relevant Area Directors.

https://datatracker.ietf.org/meeting/109/agenda.html
https://datatracker.ietf.org/meeting/109/agenda.txt

The preliminary agenda includes all planned WG, RG, and BoF sessions. We are still finalizing details for a few of our usual meeting-adjacent events, so please look out for further details about those. Information about side meeting signups will be available when the final agenda is posted.

Please note the agenda times are listed in ICT (UTC +7). 

Thank you!

IETF Secretariat

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 17 Oct 2020 01:12:44 +0200

While there is a agenda-utc.html, there is no agenda-utc.txt at
https://datatracker.ietf.org/meeting/109/agenda-utc.txt
Can you add that?

Grüße, Carsten

> On 2020-10-17, at 00:49, IETF Agenda <[email-masked]> wrote:
>

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 16 Oct 2020 23:23:06 +0000

No,  I cannot access.

--------------------------------------------------
Sent from WeLink

发件人：Carsten Bormann <[email-masked]>
收件人：IETF Agenda <[email-masked]>
抄 送：Working Group Chairs <[email-masked]>
时 间：2020-10-17 07:13:19
主 题：Re: IETF 109 Preliminary Agenda

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Fri, 16 Oct 2020 20:23:28 -0400

It appears that session are scheduled starting at 05:00 UTC, which would be
12:00(noon) Bangkok time.   It's really as if this meeting was being held in Madrid.

While I fully expected to time-shift by 12 hours (Bangkok+7, EST-5), this
isn't quite that.
I'm not sure I understand how we are respecting 1-1-1-* time zones here.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Martin Duke <[email-masked]>
Date: Fri, 16 Oct 2020 17:32:10 -0700

Each virtual meeting has started at 1300 "local time" each day. We added an
hour to the length of the day for 109, which the IESG chose to add to the
beginning. Thus, 1200 local time.

I agree that it's a relatively late start, but we've been rotating in a way
consistent with 1-1-1.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 17 Oct 2020 02:33:48 +0200

> 12:00(noon) Bangkok time.   It's really as if this meeting was being held in Madrid.

I don’t think you are aware when Spanish people tend to get up :-)

> I'm not sure I understand how we are respecting 1-1-1-* time zones here.

Alissa announced this ~ six weeks ago:
<https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk>

She also mentioned the times expressed in other time zones:

21:00 - 03:00 PST (UTC -8)
00:00 - 06:00 EST (UTC -5)
06:00 - 12:00 CET (UTC +1)
10:30 - 16:00 IST (UTC +5:30)
12:00 - 18:00 ICT  (UTC +7)
13:00 - 19:00 CST (UTC +8)
16:00 - 22:00 AEDT (UTC +11)

I saw surprisingly little discussion at the time.
But yes, the EST dwellers got the short stick this time.
For everybody else, the pain is, er, limited.

Grüße, Carsten

---

From: David Noveck <[email-masked]>
Date: Sat, 17 Oct 2020 07:33:09 -0400

> I don’t think you are aware when Spanish people tend to get up :-)

Fair enough but I don't know when people in Bangkok typically get up and
I'm not sure it is really relevant.  Typically on-site meetings start at
10am local time and go on to 5:30, creating a 7.5-hour window for meeting
sessions.

Given that this is a virtual meeting,  it would make sense to widen those
windows to allow some amelioration of the problems that this creates for
some time zones, in this case, for those in the Americas.  Instead, the
window has been shortened to six hours and I'm not sure why.

> > I'm not sure I understand how we are respecting 1-1-1-* time zones here.

That's the one thing about this that I do understand.  1-1-1-* time zones
are being respected but the inflexibility about the way this is done has
meant that many working groups need to schedule their meetings in November
as post-109 virtual interims.

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 17 Oct 2020 12:36:10 -0700

> window has been shortened to six hours and I'm not sure why.

Could you expound a bit on why you think widening the block of time in
which sessions occur would be helpful?  IIRC we have survey results showing
that in a virtual format even the 7.5-hour window is too long to be
practical, and having a longer window is going to push more of the session
timeslots into times that are quite painful for more participant timezones.
My understanding was that the idea of having a consolidated virtual IETF
was to enable the cross-polination that occurs at in-person IETF meetings
where most participants are attending sessions in most of the timeslots.

Thanks,

Ben

---

From: Michael Richardson <[email-masked]>
Date: Sat, 17 Oct 2020 20:23:14 -0400

please take followups to manycouches@ only.

    > where most participants are attending sessions in most of the timeslots.

First, I would like to know why we can do 9hr long days in person,  while we
can't even manage 7.5 hour virtual days.   I think that this needs to be
unpacked a lot more in the survey.

Second, that doesn't explain why we are starting at the times we starting.
I don't think it helps people in any of the time zones.
(Starting earlier would probably be kinder to Pacific coast types.
We start at 9pm Pacific now, end at 3am.
If we started at "10am" local", then we'd end at 1am, which is just a late
night for them.

I expect to flip my time zone: it's the full 12 hour flip for me.
Starting later doesn't help me much.
{Given my investment of ~36hours to do this, I'd kinda like to maximimze my
investment.}

The current schedule has only 30 minute breaks.
This isn't enough for people where it's "day" to eat and still do any kind of
cross-polination.

For people for whom it's middle of the night, I guess we'll have to bring box
lunches to our desks.

The bigger point is that 30 minutes is not enough to:
 1) finish 3 minutes late
 2) go to the washroom
 3) connect to gather.town to chat with someone
 4) eat/drink while this occurs
 5) arrive 3 minutes early for the next session

I'm glad that there are 7 tracks rather than 8, though.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 18 Oct 2020 03:12:24 +0200

> please take followups to manycouches@ only.

(This doesn’t work, so I won’t try.)

> can't even manage 7.5 hour virtual days.  

It is called Zoom fatigue.  It is very real.

A lot of thinking went into the new schedule, and the 2+0.5+1+0.5+2 structure sounds rather brilliant to me given the IETF108 experience.

> I think that this needs to be

This has not been divulged, but it is just a repeat of IETF 108, with adjustments for the too short slots and too short breaks.

> I don't think it helps people in any of the time zones.

(It sure helps the Europeans.)

> If we started at "10am" local", then we'd end at 1am, which is just a late

Yes.
(BTW, it is 03:00 CEST right now here.  Whether that time is a problem for a participant depends a lot on their personal habits.)

> This isn't enough for people where it's "day" to eat and still do any kind of

I expect to have some kind of screen breakfast/early lunch.

> For people for whom it's middle of the night,

… and for everyone else…

> I guess we'll have to bring box
> lunches to our desks.

Yes.

> 4) eat/drink while this occurs

Eat during session then.  (Don’t forget to mute :-)

> I'm glad that there are 7 tracks rather than 8, though.

(I’m not sure what you are referring to here. 
There are slots with 5, 6, 7, and 8 rooms.)

Grüße, Carsten

---

From: David Noveck <[email-masked]>
Date: Sun, 18 Oct 2020 06:34:23 -0400

On Sat, Oct 17, 2020, 3:36 PM Benjamin Kaduk <[email-masked]> wrote:

> > > > It appears that session are scheduled starting at 05:00 UTC, which
> would
> > > be
> which sessions occur would be helpful?

First of all, given that the current block (midnight to 6AM) was unworkable
for me, I was looking to provide options that would allow us to schedule an
nfsv4wg meeting during IETF.

It never occurred to me that there were people who would attend the entire
12Am-6Am meeting and had no expectation of people attending an expanded
version of that.  It now appears that there are such people but I expect
there will be very few.

IIRC we have survey results showing
> where most participants are attending sessions in most of the timeslots.

If that is the goal, it does not appear to be realizable for those in the
Americas given the current ICT session times, except for a small group
willing to turn their lives upside down to attend the meeting. Although
these times were not chosen to make this difficult, if you were trying to
do exclude us, it would be hard to pick a more forbidding time slot.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 18 Oct 2020 09:16:51 -0400

David,

Speaking as another person in the upcoming midnight-6 AM zone ....

Think about how the folks in Asia feel when we schedule a virtual meeting
for our daylight hours. It's convenient for us, but not for them. We do
1+1+1 for a reason - to spread the pain. It's only fair. And to your other
point, the survey results were very clear that people prefer a shorter day
(6 hours) for the online IETF meetings.

You talked about turning your life upside down to attend the meeting - if
the meeting had actually been in Bangkok, then you would have had two 20+
hour bouts of travel going and coming, and a week away from home. At least
this way, you can still sleep in your own bed. If you don't want to become
nocturnal for the entire week, then pick and choose which sessions are most
important to you and set your alarm.

Cheers,
Andy

On Sun, Oct 18, 2020 at 6:34 AM David Noveck <[email-masked]> wrote:

> First of all, given that the current block (midnight to 6AM) was
> unworkable for me, I was looking to provide options that would allow us to
> schedule an nfsv4wg meeting during IETF.
>

---

From: Lou Berger <[email-masked]>
Date: Sun, 18 Oct 2020 09:48:16 -0400

Andy,

I'm fine for sharing the pain -- but let's not pretend this is fully 
scheduled based on Bangkok time.  I don't object *at all* to holding the 
meeting based on the typical meeting times at the planned location.  If 
we were doing so this for this meeting, we'd be starting 2-3 hours 
earlier -- which would more fairly spread the pain IMO.  (Full 
disclosure, you and I are catching the worst of it this time and 
starting at the normal Bangkok time would have made a material 
difference to me. )  Of course, I do freely admit that I really have 
nothing to complain about given what our Asian colleagues are subjected 
to week in and week out with meeting times generally biased to work for 
NA and EU.  I just hope that future meetings really do start at the 
normal local meeting time -- or, even better, we figure out a less 
apparently random+some-biased way to "share the pain".

There's time enough to consider options before IETF110...

Lou

On 10/18/2020 9:16 AM, Andrew G. Malis wrote:
> Think about how the folks in Asia feel when we schedule a virtual 
> meeting for our daylight hours. It's convenient for us, but not for 
> them. We do 1+1+1 for a reason - to spread the pain. It's only fair. 
> And to your other point, the survey results were very clear that 
> people prefer a shorter day (6 hours) for the online IETF meetings.
>
> You talked about turning your life upside down to attend the meeting - 
> if the meeting had actually been in Bangkok, then you would have had 
> two 20+ hour bouts of travel going and coming, and a week away from 
> home. At least this way, you can still sleep in your own bed. If you 
> don't want to become nocturnal for the entire week, then pick and 
> choose which sessions are most important to you and set your alarm.
>
> Cheers,
> Andy
>
>
> On Sun, Oct 18, 2020 at 6:34 AM David Noveck <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>     On Sat, Oct 17, 2020, 3:36 PM Benjamin Kaduk <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         > On Fri, Oct 16, 2020, 8:34 PM Carsten Bormann <[email-masked]
>         <mailto:[email-masked]>> wrote:
>         >
>         > > On 2020-10-17, at 02:23, Michael Richardson
>         <[email-masked] <mailto:[email-masked]>> wrote:
>         > > >
>         > > > It appears that session are scheduled starting at 05:00
>         UTC, which would
>         > > be
>         > > > 12:00(noon) Bangkok time.   It's really as if this
>         meeting was being
>         > > held in Madrid.
>         > >
>     unworkable for me, I was looking to provide options that would
>     allow us to schedule an nfsv4wg meeting during IETF.
>
>     It never occurred to me that there were people who would attend
>     the entire 12Am-6Am meeting and had no expectation of people
>     attending an expanded version of that.  It now appears that there
>     are such people but I expect there will be very few.
>
>     If that is the goal, it does not appear to be realizable for those
>     in the Americas given the current ICT session times, except for a
>     small group willing to turn their lives upside down to attend the
>     meeting. Although these times were not chosen to make this
>     difficult, if you were trying to do exclude us, it would be hard
>     to pick a more forbidding time slot.
>
>
>         Thanks,
>
>         Ben
>

---

From: Martin Duke <[email-masked]>
Date: Sun, 18 Oct 2020 07:30:02 -0700

All of the virtual meetings have begun at 12:00 or 13:00 "local" time. No
one seriously questioned this choice until it became inconvenient for
Eastern Time.

To start messing with the start time now would erode the principle of 1-1-1.

On Sun, Oct 18, 2020, 06:48 Lou Berger <[email-masked]> wrote:

> meeting based on the typical meeting times at the planned location.  If we
> were doing so this for this meeting, we'd be starting 2-3 hours earlier --
> which would more fairly spread the pain IMO.  (Full disclosure, you and I
> are catching the worst of it this time and starting at the normal Bangkok
> time would have made a material difference to me. )  Of course, I do freely
> admit that I really have nothing to complain about given what our Asian
> colleagues are subjected to week in and week out with meeting times
> generally biased to work for NA and EU.  I just hope that future meetings
> really do start at the normal local meeting time -- or, even better, we
> figure out a less apparently random+some-biased way to "share the pain".
>
>>> > > > 12:00(noon) Bangkok time.   It's really as if this meeting was
>>> being
>>> > > held in Madrid.
>>> > >
>> It never occurred to me that there were people who would attend the
>> entire 12Am-6Am meeting and had no expectation of people attending an
>> expanded version of that.  It now appears that there are such people but I
>> expect there will be very few.
>>

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 18 Oct 2020 10:58:29 -0400

> On Oct 18, 2020, at 10:30 AM, Martin Duke <[email-masked]> wrote:
> 
> All of the virtual meetings have begun at 12:00 or 13:00 "local" time. No one seriously questioned this choice until it became inconvenient for Eastern Time.

Indeed, IETF 109 is starting an hour earlier in the local time zone than IETF 107 and 108 (12:00 rather than 13:00). An even earlier start time would put our European participants, who together with those in Asia had the short end of the stick at IETF 107, into typical sleeping hours.

Alissa

> On Sun, Oct 18, 2020, 06:48 Lou Berger <[email-masked] <mailto:[email-masked]>> wrote:
> Andy,
> 
> I'm fine for sharing the pain -- but let's not pretend this is fully scheduled based on Bangkok time.  I don't object *at all* to holding the meeting based on the typical meeting times at the planned location.  If we were doing so this for this meeting, we'd be starting 2-3 hours earlier -- which would more fairly spread the pain IMO.  (Full disclosure, you and I are catching the worst of it this time and starting at the normal Bangkok time would have made a material difference to me. )  Of course, I do freely admit that I really have nothing to complain about given what our Asian colleagues are subjected to week in and week out with meeting times generally biased to work for NA and EU.  I just hope that future meetings really do start at the normal local meeting time -- or, even better, we figure out a less apparently random+some-biased way to "share the pain".  
> 
>> Think about how the folks in Asia feel when we schedule a virtual meeting for our daylight hours. It's convenient for us, but not for them. We do 1+1+1 for a reason - to spread the pain. It's only fair. And to your other point, the survey results were very clear that people prefer a shorter day (6 hours) for the online IETF meetings.
>> 
>> You talked about turning your life upside down to attend the meeting - if the meeting had actually been in Bangkok, then you would have had two 20+ hour bouts of travel going and coming, and a week away from home. At least this way, you can still sleep in your own bed. If you don't want to become nocturnal for the entire week, then pick and choose which sessions are most important to you and set your alarm.
>> 
>> Cheers,
>> Andy
>> 
>> 
>> On Sun, Oct 18, 2020 at 6:34 AM David Noveck <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> On Sat, Oct 17, 2020, 3:36 PM Benjamin Kaduk <[email-masked] <mailto:[email-masked]>> wrote:
>> > On Fri, Oct 16, 2020, 8:34 PM Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
>> > 
>> > > On 2020-10-17, at 02:23, Michael Richardson <[email-masked] <mailto:[email-masked]>> wrote:
>> > > >
>> First of all, given that the current block (midnight to 6AM) was unworkable for me, I was looking to provide options that would allow us to schedule an nfsv4wg meeting during IETF. 
>> 
>> It never occurred to me that there were people who would attend the entire 12Am-6Am meeting and had no expectation of people attending an expanded version of that.  It now appears that there are such people but I expect there will be very few.
>> 
>> If that is the goal, it does not appear to be realizable for those in the Americas given the current ICT session times, except for a small group willing to turn their lives upside down to attend the meeting. Although these times were not chosen to make this difficult, if you were trying to do exclude us, it would be hard to pick a more forbidding time slot.
>> 
>> 
>> Thanks,
>> 
>> Ben

---

From: Lou Berger <[email-masked]>
Date: Sun, 18 Oct 2020 15:46:40 +0000

----------

> All of the virtual meetings have begun at 12:00 or 13:00 "local" time. No one seriously questioned this choice until it became inconvenient for Eastern Time.

Sorry, I think we've seen grumbling at each meeting. For examples I heard for many in California at the last meeting. It is true that the is the first time I am commenting on it.

> To start messing with the start time now would erode the principle of 1-1-1.

I have no interest in eroding that. but I think we could do something a little more intelligent for virtual ietfs going forward. For example on the virtuals that I scheduled, we call among the contributors and find a time that work best for them. Clearly polling is not a great way to do it for a whole meeting but, for example, we could be scheduling based on a majority of attendees rather than on what might be a hypothetical location in the future.  For example 110 could start based on what is a normal start time for the  weighted average of eu attendees for the last year.  I suspect that this will only make a small difference given the distribution of time zones in each region is only about 3-4 hours, but still seems less arbitrary and more reflective of today's reality to me...

Lou

> On Sun, Oct 18, 2020, 06:48 Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
>
> Andy,
>
> On Sun, Oct 18, 2020 at 6:34 AM David Noveck <[email-masked]<mailto:[email-masked]>> wrote:
>
>
> On Sat, Oct 17, 2020, 3:36 PM Benjamin Kaduk <[email-masked]<mailto:[email-masked]>> wrote:
>> On Fri, Oct 16, 2020, 8:34 PM Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> > On 2020-10-17, at 02:23, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:
>> > >

---

From: David Noveck <[email-masked]>
Date: Sun, 18 Oct 2020 13:52:28 -0400

On Sun, Oct 18, 2020, 9:17 AM Andrew G. Malis <[email-masked]> wrote:

> for our daylight hours.

I would not do that of it were a real issue.  Nfsv4wg has no active members
in Asia.   And no non-member has ever expressed an interest in attending,
regardless of time zone  issues.

It's convenient for us, but not for them.

So, in this case, except for the prospect of cross-polination, about which
I am becoming rather dubious, there is no "them" to be inconvenienced.

We do 1+1+1 for a reason

Understood.

to spread the pain.

There's a difference between spreading unavoidable pain and creating
unnecessary pain.

It's only fair. And to your other point, the survey results were very clear
> that people prefer a shorter day (6 hours) for the online IETF meetings.
>

We've never had an explanation of why those particular six hours were
chosen and I don't think we ever will.

>
> You talked about turning your life upside down to attend the meeting
>

Really, I talked about my unwillingness to do that.

if the meeting had actually been in Bangkok, then you would have had two
> 20+ hour bouts of travel going and coming, and a week away from home.
>

I wouldn't have done that either.  The last time the working group met at
an asian venue was in Beijing.  For a while, these meetings were just
skipped but lately we have used virtual interims and I expect that pattern
to continue.

At least this way, you can still sleep in your own bed.

Since I'm unlikely to do either, it doesn't really matter.

If you don't want to become nocturnal for the entire week, then pick and
choose which sessions are most important to you and set your alarm.

I'll be looking at the schedule and seeing if there is anything
sufficiently interesting to justify the effort and fees.

---

From: Michael Richardson <[email-masked]>
Date: Sun, 18 Oct 2020 17:42:09 -0400

> one seriously questioned this choice until it became inconvenient for

AGAIN, I am not complaining as an Eastern-Time person.
Starting Vancouver later in the day did not particularly help, and I asked
WTF at the time.

Starting Madrid later in the day only really helped EST people, and I asked
about that at the time.

    > To start messing with the start time now would erode the principle of 1-1-1.

Are you saying, "having got it wrong twice, it would unfair if we did it
correctly this time?"

---

From: Michael Richardson <[email-masked]>
Date: Sun, 18 Oct 2020 17:46:38 -0400

Lou Berger <[email-masked]> wrote:
    > I have no interest in eroding that. but I think we could do something a
    > little more intelligent for virtual ietfs going forward. For example on
    > the virtuals that I scheduled, we call among the contributors and find
    > a time that work best for them. Clearly polling is not a great way to
    > do it for a whole meeting but, for example, we could be scheduling
    > based on a majority of attendees rather than on what might be a
    > hypothetical location in the future.  For example 110 could start based
    > on what is a normal start time for the  weighted average of eu
    > attendees for the last year.  I suspect that this will only make a
    > small difference given the distribution of time zones in each region is
    > only about 3-4 hours, but still seems less arbitrary and more
    > reflective of today's reality to me...

Are you saying that the time zone for the meeting would be driven by the who
has registered rather than what locale it was supposed to be in?

Or are you limiting it to EU attendees, since it was to be in Prague?

There are some chicken and egg if we try to do this based upon registration
for the current meeting, but I'm sure we could figure something out.

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 18 Oct 2020 23:54:37 +0200

On 2020-10-18, at 19:52, David Noveck <[email-masked]> wrote:
> 
> So, in this case, except for the prospect of cross-polination, about which I am becoming rather dubious, there is no "them" to be inconvenienced.

Your WG may then be a good candidate for meeting for an interim instead of at the main IETF week.

The IETF week is useful for the serendipity of pulling in people who haven’t seen your work yet (in detail) and, nonetheless, can make useful contributions.
I agree that would be a stretch for NFSv4...

Grüße, Carsten

---

From: Martin Duke <[email-masked]>
Date: Sun, 18 Oct 2020 15:06:01 -0700

> Are you saying, "having got it wrong twice, it would unfair if we did it
12-6 pm is not "wrong". If we had started at 0700 in Vancouver and remained
consistent with that, it wouldn't have been "wrong" either. But starting to
time shift individual meetings because it doesn't work great for certain
people would violate the principle of sharing the pain

I also wouldn't assume that a particular time is ideal for a certain time
zone, either -- mornings, evenings, and the middle of the night will be
attractive to different people based on their constraints. Moving the times
around in a consistent manner avoids continuous inconvenience for anyone.

---

From: Lou Berger <[email-masked]>
Date: Sun, 18 Oct 2020 19:47:36 -0400

> has registered rather than what locale it was supposed to be in?
Close.  I was saying use an average of recent (3-meetings) past attendees.
> Or are you limiting it to EU attendees, since it was to be in Prague?

in trying to preserve 1-1-1, yes, I was saying look on at the average of 
EU attendees for 110.  For 109 - it would have been the Asia attendees...

This was a half thought out example of what *could* be done if we 
consider ourselves as untethered from physical meeting locations. This 
is probably a discussion for the shmoo wg...

Lou

---

From: Dave Lawrence <[email-masked]>
Date: Sun, 18 Oct 2020 21:40:43 -0400

> At least this way, you can still sleep in your own bed.

Not that I expect most folks to do something like this, so just
sharing another data point ...

I'll be sleeping at my office all week.  After the midnight to 6am
meeting, I'll get a solid 8 hours of sleep, head home to refresh and
spend time with the fam, then back to the office at like 21h after the
kids are put to bed.

It's a lot more family time than if I were in Bangkok.

I realize that many others do not necessarily have flexible enough
circumstances to accommodate something like this.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 19 Oct 2020 13:01:23 -0400

> version of that.  It now appears that there are such people but I expect

Yes, there are many people who attend a meeting almost every single session,
and often have conflicts.

Some of them are Area Directors (IESG), and IAB.
But, many of them are just active members.

If your WG does not require or experience interactions with people outside
some specific working set, then I recommend not dealing with this time zone.
Hold a virtual interim meeting.  Hold a series of them.

The CELLAR WG, of which I'm co-chair, has met only once at an IETF meeting,
for instance.
It's a group of ~8 to ~12 people who are very github/ML focused, and who
mostly work on these documents outside of their day$job.

{typing this in an editor that is saving it's files over NFSv4, btw}

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 19 Oct 2020 19:49:38 +0100

This thread (re-)opens the question of the value of a full virtual meeting.

There is unquestionable (to me) value in the plenary session, and a few of
the agenda-slot meetings are widely attended.

But it seems that the main draw of an in-person meeting is the interactions
in the corridors and after people have spoken at agenda sessions. Also the
ad hoc gatherings to advance topics. 
It seems to me that most/all of this was missing at IETF-108 and is likely
to be missing at IETF-109.

So what is left between the packed one-week agenda and a sparse three-month
schedule of "interims".

Maybe the only benefit I can see is that rather than having to be out of bed
every week for a poorly-scheduled interim, I can be out of bed for a whole
week for the IETF week. I am not sure that is an advantage, especially when
weighed against agenda clashes (at IETF-108 I tried listening to multiple
audio streams at once, and it fried my poor brain).

So I'd like to see a renewed discussion of why we are doing this to
ourselves.

(And yes, this discussion should probably be in schmoo)

(And, oh yes, what about the funding model)

Adrian

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Michael Richardson
Sent: 19 October 2020 18:01
To: David Noveck <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: IETF 109 Preliminary Agenda

    > It never occurred to me that there were people who would attend the
entire

--
]               Never tell me the odds!                 | ipv6 mesh networks
[
]   Michael Richardson, Sandelman Software Works        |    IoT architect
[
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails
[

---

From: Jay Daley <[email-masked]>
Date: Tue, 20 Oct 2020 09:19:33 +1300

Adrian

> On 20/10/2020, at 7:49 AM, Adrian Farrel <[email-masked]> wrote:
> 

Just a reminder that we have surveyed the community about this

	https://www.ietf.org/media/documents/survey-planning-possible-online-meetings-responses.pdf

One key question was "If an in-person one-week IETF meeting needs to be cancelled then which of the following options do you prefer?", which elicited the following responses (p20):

- Replace it with a combination of an online meeting with a set agenda and virtual interims				36.15% 	184
- Replace it with an online meeting with a set agenda (format to be decided)						29.47% 	150
- Ask WGs/RGs to schedule virtual interims when and how they want								14.54% 	74
- Ask WGs/RGs to schedule virtual interims following rules about when and how (rules to be decided)	9.82% 	50
- Don't know																			5.11% 	26
- Do nothing and defer until the next in-person meeting											2.95% 	15
- Other (please specify)																	1.96% 	10

It might be argued that an online meeting with just a plenary meets the top two results above, but then a further question asks "If an online IETF meeting is scheduled, then how important is it for each of the following to be included?", which elicited the following responses (p26):

(From L-R: Very important, Important, Neutral, Not important, Not at all important, Score (lower score is more important))

- Sessions for existing working groups 		43.66% 38.05% 12.06% 4.99% 1.25% 		1.82
- Sessions for new working groups			39.02% 39.91% 16.19% 2.66% 2.22% 		1.89
- BOFs 								38.12% 36.32% 21.08% 2.24% 2.24% 		1.94
- Sessions for proposed research groups	19.48% 36.15% 34.27% 6.81% 3.29% 		2.38
- Sessions for existing research groups		19.25% 34.51% 36.38% 7.28% 2.58% 		2.39
- Plenary session 						21.81% 28.19% 31.28% 13.88% 4.85% 	2.52
- Side meetings 						14.99% 29.98% 32.08% 13.11% 9.84% 	2.73
- Newcomers’ events					13.00% 28.25% 34.00% 12.00% 12.75% 	2.83
- Technical tutorials 					11.14% 20.54% 40.35% 17.33% 10.64%	2.96
- HotRFC								9.49% 19.49% 41.79% 15.64% 13.59% 	3.04
- Office hours							5.34% 22.90% 39.95% 20.10% 11.70%		3.10
- Hackathon 							6.73% 20.20% 40.65% 19.70% 12.72% 	3.11
- Codesprint 							3.20% 12.00% 48.27% 20.27% 16.27%		3.34
- Host Speaker Series 					5.85% 15.78% 35.11% 21.12% 22.14%		3.38
- Systers Networking 					4.68% 10.23% 47.95% 15.20% 21.93%		3.39
- Social event 							4.99% 8.48% 23.44% 20.95% 42.14%		3.87

Of course the sessions for existing working groups are the bulk of the sessions.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 20 Oct 2020 01:12:29 +0200

+1

regurgitating my suggestion from 108: Put more time in between the virtual meeting
slots, allowing attendees to engage in this valuable "between sessions" discussions
(hang out after session in meeting, lunch get-together, calorie-free-cookie-break..).

Especially for the Asia time slot of 109, my highly heuristic "quickly browse through
registrartions and stat Amer/Europe/Asia" tells me that Amer may be as much as 50%,
and they are being screwed. Lengthening up the agenda would only help Amer, it
would help the community, and it would just create a bit more hassle for the other
two timezones which are otherwise pretty well served.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 19 Oct 2020 17:17:32 -0700

> regardless of time zone  issues.

It is hard to be certain that all or even most people who would consider
attending would ever "express an interest" in doing so -- there's not a
good way to get any real data.  That said, my opinion informed by
experience is that NFSv4 is a fair bit away from being an "average" IETF
WG in terms of being tied in to the overall participant pool.

> I am becoming rather dubious, there is no "them" to be inconvenienced.

Well, I know one sample does not make a data set, but NFSv4 is regularly on
my list of WG sessions that I want to go to at the in-person meeting but
I'm unlikely to carve time out of my normal schedule to attend a virtual
interim for it.  There are many reasons why I'm interested, but only
loosely interested, in NFSv4 (I like GSS and NFSv4 uses RPCSEC_GSS, I
maintain a different XDR-and-RPC-using network filesystem, ...), and of
course everyone can have their own opinion about whether it is useful to
get comments from me (whether early in the process or late in the process),
but I fall into the "cross-pollination" bucket for this case.

> chosen and I don't think we ever will.

Recall that these six (well, five) hours were first used for Vancouver,
which was converted into a virtual meeting on a very tight schedule.  My
recollection, which I cannot currently substantiate, is that we were quite
set on respecting the "working hours in Vancouver" boundaries, but put some
thought into picking a subset of those working hours that was "least bad"
globally.  At that point it was not clear how quickly (or slowly) things
would return to normal, and so trying to optimize for which five/six hour
slot would be least bad when averaged over 1-1-1 was not anywhere close to
the top of the (frantic) priority list.  It does seem to have
(inadvertently?) set a precedent, though.  Hopefully SHMOO can give some
more input in time for 110 and we can shift things around if needed.

-Ben

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 20 Oct 2020 12:30:30 +0100

> On 19 Oct 2020, at 19:49, Adrian Farrel <[email-masked]> wrote:
> 

Solving that next problem in virtual meeting, i.e. that of casual ad hoc “coffee” meetings is one of the biggest challenges many people face at the moment. It is a problem who’s solution is of long term post-covid benefit to mankind in reducing carbon footprint.

Maybe it needs to be a work item in the Apps Area?

- Stewart

---

From: Tim Chown <[email-masked]>
Date: Tue, 20 Oct 2020 14:20:17 +0100

> On 18 Oct 2020, at 01:23, Michael Richardson <[email-masked]> wrote:
> 

This is a little surprising. I may not be the only person who didn’t plan to attend IETF 109 on the assumption the meetings would start at 2am or 3am UTC.   It would be helpful if for future meetings the planned meeting hours are advertised more clearly well in advance.

Tim

---

From: Robert Sparks <[email-masked]>
Date: Tue, 20 Oct 2020 09:46:22 -0500

Hi Tim -

Advertising, as you suggest, isn't easy. Alissa _did_ send a note to 
IETF announce with the expected hours several weeks ago (as soon as was 
reasonable I think, awaiting the decision to be online). See 
<https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk>.

Where could that have been sent/put that would have been easier for you 
to see?

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 20 Oct 2020 17:48:53 +0200

On Tue, Oct 20, 2020 at 12:30:30PM +0100, Stewart Bryant wrote:
> Solving that next problem in virtual meeting, i.e. that of casual ad hoc ???coffee??? meetings is one of the biggest challenges many people face at the moment. It is a problem who???s solution is of long term post-covid benefit to mankind in reducing carbon footprint.
> 

We have [email-masked].

Cheers
    toerless

-- 
---
[email-masked]

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 20 Oct 2020 13:21:03 -0400

Robert,

I did see that when it was first sent to ietf-announce. However, for future
meetings, it probably wouldn't hurt to also send this sort of info to the
wgchairs list as well, just to make sure that the chairs don't accidentally
miss it.

Cheers,
Andy

On Tue, Oct 20, 2020 at 10:46 AM Robert Sparks <[email-masked]> wrote:

> <
> https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk
> >.
>
> would be
> > This is a little surprising. I may not be the only person who didn’t
> plan to attend IETF 109 on the assumption the meetings would start at 2am
> or 3am UTC.   It would be helpful if for future meetings the planned
> meeting hours are advertised more clearly well in advance.
> >
> > Tim
>
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Cj Aronson <[email-masked]>
Date: Tue, 20 Oct 2020 11:43:32 -0600

How about putting the meeting timezone information on the website?  It
would also be helpful to have the draft agenda before the early bird
expires.

Thanks
-----Cathy

{Ô,Ô}
  (( ))
  ◊  ◊

On Tue, Oct 20, 2020 at 11:21 AM Andrew G. Malis <[email-masked]> wrote:

> Robert,
>
> I did see that when it was first sent to ietf-announce. However, for
> future meetings, it probably wouldn't hurt to also send this sort of info
> to the wgchairs list as well, just to make sure that the chairs don't
> accidentally miss it.
>
> Cheers,
> Andy
>
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 20 Oct 2020 12:16:47 -0700

Tim was talking about the possibility of registration. I understood perhaps on https://www.ietf.org/how/meetings/109/ somehow. It *does* say that "IETF 109 is an online meeting with sessions from 05:00 to 11:00 UTC/ 12:00 to 18:00 ICT each day", so the data is there - but I for one find it a little hard to digest - what is that in my time zone, and how does it relate to bedtime? I'm thinking out loud, and Tim would have to say whether it helped him, but maybe a little bit HTML code that let you select the timezone of interest and did the conversion?

Personally, my thought process was a little different. As a working group chair, I'm either going to be there or make some other arrangements. If I were flying to Thailand, the fact that ICT is UTC+7 and therefore 14 hours ahead of PST (UTC-7) wouldn't make much difference. So I decided to "be there" for some definition of "there", and went from that.

> On Oct 20, 2020, at 7:46 AM, Robert Sparks <[email-masked]> wrote:
> 
> Hi Tim -
> 
> Advertising, as you suggest, isn't easy. Alissa _did_ send a note to IETF announce with the expected hours several weeks ago (as soon as was reasonable I think, awaiting the decision to be online). See <https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk>.
> 
> Where could that have been sent/put that would have been easier for you to see?
> 
> RjS
>