Subject: Workaround for uploading markdown on Windows

From: "Martin Thomson" <[email-masked]>
Date: Fri, 06 Nov 2020 16:35:52 +1100

For anyone who has a markdown agenda or minutes to upload, you might find that datatracker rejects it for not being a supported media type.

For those on Windows, rather than uploading as a .txt file, you can open regedit (I know) and create a key at "HKEY_CLASSES_ROOT\.md".  Then you can add a REG_SZ (that is, a String) value and assign it the value "text/markdown".

As a .reg file:
~~~
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.md]
"Content Type"="text/markdown"
~~~

This worked for me.  Maybe some day Windows will learn about markdown on its own.

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 06 Nov 2020 20:17:31 +0200

I just failed to upload a markdown agenda from Firefox/Mac (some mime type problem I've seen before), but did it successfully on Linux.

Problem is, when I access the agenda link [1] from Firefox, I get a download of the original markdown file. From Chrome, the markdown text is rendered. I would expect that markdown to be rendered as HTML, that's kind of the whole point!

Thanks,
	Yaron

[1] https://www.ietf.org/proceedings/109/agenda/agenda-109-gnap-00

On 11/6/20, 07:36, "WGChairs on behalf of Martin Thomson" <[email-masked] on behalf of [email-masked]> wrote:

    As a .reg file:
    ~~~

    [HKEY_CLASSES_ROOT\.md]