Subject: github org names

From: Michael Richardson <[email-masked]>
Date: Fri, 20 Nov 2020 02:40:32 -0500

Should WGs whose github organization is not "ietf-wg-FOO", plan to rename
their Org?

Github leaves a forwarding note, so that is no loss of connectivity.
Or is this just busy-work?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 20 Nov 2020 18:51:22 +1100

That was discussed during the GIT WG work, and my recollection is that it was explicitly said that was not required.

> On 20 Nov 2020, at 6:40 pm, Michael Richardson <[email-masked]> wrote:
> 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 20 Nov 2020 02:53:16 -0500

I migrated the DNSOP/DPRIVE orgs, but I'm a bit OCD at times.

tim

On Fri, Nov 20, 2020 at 2:51 AM Mark Nottingham <[email-masked]> wrote:

> That was discussed during the GIT WG work, and my recollection is that it
> was explicitly said that was not required.
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Nov 2020 08:58:26 +0100

> Should WGs whose github organization is not "ietf-wg-FOO", plan to rename

No.

> Or is this just busy-work?

Yes.

But maybe you want to claim that name anyway…

https://github.com/ietf-wg-core :-)

Grüße, Carsten

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 20 Nov 2020 08:16:49 +0000

OCD in this field?  Surely you jest!

More seriously, I think it more important to migrate/clone the repo’s then the old org names.  But discovery is a good thing, and wgchairs might want to be part of the groups ietf-xxxxx collection.

From: Tim Wicinski <[email-masked]>
Date: Friday, November 20, 2020 at 2:53 AM
To: Mark Nottingham <[email-masked]>
Cc: Michael Richardson <[email-masked]>, 'WG Chairs' <[email-masked]>
Subject: Re: github org names

tim

On Fri, Nov 20, 2020 at 2:51 AM Mark Nottingham <[email-masked]<mailto:[email-masked]>> wrote:
That was discussed during the GIT WG work, and my recollection is that it was explicitly said that was not required.

> On 20 Nov 2020, at 6:40 pm, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:
>
>
> Michael Richardson <[email-masked]<mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )

--
Mark Nottingham   https://www.mnot.net/<https://urldefense.com/v3/__https:/www.mnot.net/__;!!GjvTz_vk!BeTGoi4goo9N5CevGFfxsyOlG21n7sJWyfa-nXMtRk5jnUo6Rjr-URUlewbZ$>

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 22 Nov 2020 23:26:51 +0000

>    That was discussed during the GIT WG work, and my recollection is that it was explicitly said that was not required.

Yeah, my recollection is that renaming orgs wasn't required.

I recommend people do it so you can be found more easily however :)

---

From: tjw ietf <[email-masked]>
Date: Sun, 22 Nov 2020 18:51:37 -0500

Am I the only person who is worried about Random Evil Doer squatting on names for other purposes?

Tim

Sent from my iPhone

> On Nov 22, 2020, at 18:27, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> 
>>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 23 Nov 2020 07:23:24 +0100

No.

(That was the point of the earlier message where I announced that I’m squatting on ietf-wg-core, because I can(*)…)

Grüße, Carsten

(*) Yes, I am aware that IETF is a registered trademark of the IETF Trust.
So if the IETF cares and, for once, the legal system does its job, any such squatting cannot continue.  Still sounds easier for us to just claim those names now...

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 23 Nov 2020 08:12:22 +0100

How about the opposite ?

Aka: can we allocate names github.com/ietf-wg-FOO and have them point to whereever
FOO currently is (e.g.: github.com/ietf-wg-anima -> github.com/anima-wg for ANIMA WG).

That way we don't need to bother incumbant efforts from the IETF but
make sure that the names that new contributors to a WG will be looking for will also work.

Just no idea about github tooling. Explanations how to do this very much welcome.

Cheers
    Toerless

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 23 Nov 2020 14:21:38 +0000

>    So if the IETF cares and, for once, the legal system does its job, any such squatting cannot continue.  Still sounds easier for us to just claim those names now...

There are probably more important things to worry about. :) I have been discussing with the IETF trust about using logo's on GitHub repo's since July. I think it's on me to update my scripts to leverage the "remote URL" capability in DataTracker.

In the past, I have also found GitHub to be responsive to "please make me the owner" of emails.

The more we follow the documented convention, ietf-wg-XXX, the more we strengthen the argument and the easier we make it for possible contributors to find our work. The downside is that someone may pretend to be an IETF group; even if we can't wrest it away from them, so what?

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 23 Nov 2020 14:23:30 +0000

Simplest thing to do would be to create org, a repository, and put a README there.  That could easily be scripted.  Someone have a list of groups?

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Nov 2020 09:29:44 -0500

> How about the opposite ?

No, that won't really work unless you can convince github.com to help, and
they aren't smart enough, apparently, to enable IPv6 :-(
I believe we should probably consider our own gitlab, but maybe not yet.

    > FOO currently is (e.g.: github.com/ietf-wg-anima -> github.com/anima-wg for ANIMA WG).

I just renamed cellar-wg to ietf-wg-cellar.
None of the https:// links gets a forward, but all of the content is kept,
and all of the git:// access gets a forward function.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 23 Nov 2020 20:12:25 +0100

> and all of the git:// access gets a forward function.

Maybe it works better to create the new org, push all repos over (which do get a redirect then as far as I can tell), and create a tombstone setup at the now empty old org.

(Not that I plan to do this or encourage this at any of the WGs I care about.)

Grüße, Carsten