Subject: Re: [Tools-discuss] XMPP room improvements

From: Michael Richardson <[email-masked]>
Date: Sat, 14 Nov 2020 21:05:24 -0500

Sebastian Kippe <[email-masked]> wrote:
    > 3. Configure room avatars

    > Human brains prefer images to pretty much all other information for
    > sub-second parsing. Aside from making everything look much nicer in
    > general, setting room avatars make it easier to discern between rooms in
    > one's client, when joined to many different rooms on many servers.
    > Unlike the other 2 suggestions, this one requires a small amount of
    > work, of course, in that someone has to create square room avatar images
    > before configuring/uploading them from a client.

So, since most rooms are associated with WGs, it seems that really, each WG
needs to come up with a reasonable WG avatar.  Some have them (6tisch comes
to mind).  Most don't, but might want to think about it, because it also
helps with slides, etc.

What kind of resolution can/should this square room avatar be?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Tom Pusateri <[email-masked]>
Date: Sun, 15 Nov 2020 10:42:25 -0500

> On Nov 14, 2020, at 9:05 PM, Michael Richardson <[email-masked]> wrote:
> 
> 
> helps with slides, etc

When I was coming up with ways to distinguish working groups visually in the iPhone/iPad app, I ended up using a color by Area. Many people work inter-area but having an anchor like the area color helps quickly distinguish groups.

I suggest just creating the WG abbreviation inside a colored square that is the same background color for all working groups in an area.

I don’t mind doing this for each working group if that becomes the consensus moving forward.

Tom

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 16 Nov 2020 01:29:14 -0500

> I suggest just creating the WG abbreviation inside a colored square that is the same background color for all working groups in an area.

I've worked with people with different forms of color blindness over the
years.  Color as a primary identifier seldom works as nicely as you might
want it to.

A variant that doesn't have that issue is listing WG followed by the area in
things like badge.  Binding area to a color lets you visually shortcut it
still.

E.g. "BFD - RTG" on a "routing colored field".

Of course, now you have to choose colors that aren't overlapping our dots.

Sumptuary laws for IETF start getting strange after that.

-- Jeff