Subject: Fwd: problem with recent drafts on tools.ietf.org? {35440727}

From: Lou Berger <[email-masked]>
Date: Wed, 3 Mar 2021 18:54:59 -0500

Well this is a troubling response -- does anyone know if there's plans 
for tools.ietf.org? I would have thought that some thought would be 
given to this and maybe some announcement made to the IETF.  Did I miss 
it???  Are we just destined to the whims of bit rot?

Lou
-------- Forwarded Message --------
Subject: 	RE: problem with recent drafts on tools.ietf.org? {35440727}
Date: 	Wed, 03 Mar 2021 19:48:14 +0000
From: 	
Reply-To: 	[email-masked]
To: 	[email-masked]

^-- --reply above this line--

The ticket has been closed

https://ietf.jitbit.com/helpdesk/User/AutoLogin?username=lberger%40labn.net&email=lberger%40labn.net&userHash=d2b353395ed17180429bd7cea7b75beb&ReturnUrl=https%3a%2f%2fietf.jitbit.com%2fhelpdesk%2fTicket%2f35440727 
<https://ietf.jitbit.com/helpdesk/User/AutoLogin?username=lberger%40labn.net&email=lberger%40labn.net&userHash=d2b353395ed17180429bd7cea7b75beb&ReturnUrl=https%3a%2f%2fietf.jitbit.com%2fhelpdesk%2fTicket%2f35440727>

From: *Glen Barney*
3/3/2021 11:48:14 AM
------------------------------------------------------------------------
Lou -

As you are probably aware, tools.ietf.org is owned and operated by 
Henrik who has, unfortunately, departed the IETF.

Any URLs starting with tools.ietf.org are outside of our ability to 
diagnose or manage.

You can email Henrik at [email-masked] and submit the report 
to him.

However, the best thing to do here is to use the Datatracker to view 
drafts, instead of Tools.

I'm sorry for the confusion and inconvenience.

Glen

Hi,

I'm having an issue with some versions of the tools html files?  Is this 
a general issue?

Thanks,

Lou

for example I see (both from my lan and via my mobile provider):

  Thistools.ietf.orgpage can’t be found

No webpage was found for the web 
address:*https://tools.ietf.org/html/draft-dang-queuing-with-multiple-cyclic-buffers-00 
<https://tools.ietf.org/html/draft-dang-queuing-with-multiple-cyclic-buffers-00>*

HTTP ERROR 404

/NOTE: When replying to this email please leave the subject-line intact./

---

From: Paul Wouters <[email-masked]>
Date: Wed, 3 Mar 2021 19:11:28 -0500 (EST)

On Wed, 3 Mar 2021, Lou Berger wrote:

> Well this is a troubling response -- does anyone know if there's plans for tools.ietf.org? I would have thought that some thought would be given to this and
> maybe some announcement made to the IETF.  Did I miss it???  Are we just destined to the whims of bit rot?

> As you are probably aware, tools.ietf.org is owned and operated by Henrik who has, unfortunately, departed the IETF.

I would really like some clarification about what happened, and who owns
the rights of the content on tools.ietf.org, and if it is not IETF or
ISOC, how we ended up in a position where we didn't own what we
published for many years. And what the plans are with regard to ensuring
URLs posted there remain valid - even if only to redirect back to
something that _is_ under IETF / ISOC change control.

Paul

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Mar 2021 14:29:31 +1300

Hi Paul, Lou and others

> On 4/03/2021, at 1:11 PM, Paul Wouters <[email-masked]> wrote:
> 

I do not know the full details and history of how we got here.  Here is the background I provided to the LLC Board for their February meeting and is now published in the minutes of that meeting [1]:

> As background, our ex-contractor and long term community member Henrik Levkowetz, controls tools.ietf.org and operates it on servers donated by other community members over the years. tools.ietf.org runs a set of services, some of which are maintained by the IETF such as the ​online xml2rfc​ and code repositories for ​datatracker​ and x​ml2rfc,​ and some of which are maintained by Henrik such as the HTMLized ​RFCs​ and I-Ds. Over time, some of these services have become mission critical.
> 
> Henrik asserts that the domain name tools.ietf.org was delegated to him personally (by the IETF Chair in 2004) and the servers were donated to him personally not the IETF and that he should retain full control of what runs on these servers and how they are managed. Some of the servers are physically based in AMS operated datacenters.
> 
> We recently had an incident where one of the servers operating tools.ietf.org failed irreparably. There were some services running exclusively on that server that therefore needed to be moved to other servers, which Henrik and another volunteer were able to do. However some performance issues remained on other services for a few days due to DNS configuration issues. To prevent a recurrence, we proposed to Henrik that the management of the DNS move to AMS so that they can make emergency changes in situations like this. Henrik’s response to this proposal was quite intense and included a threat to turn off tools.ietf.org and all its services if we made this change.
> 
> The Tools Team PM (Robert Sparks) already had a partial plan in place to migrate services off tools.ietf.org but this combination of failing servers, a single person in control and threats of service shutdown have significantly increased the risk this situation poses and consequently I am reprioritising work to assist and accelerate the migration. The good news is that Robert and Henrik have been working cooperatively to effect the migration, though Robert needs additional resources to complete this and other work (see below). 

This plan includes, in rough priority order, the following (Robert may wish to correct me if this is wrong):

1.  Reproducing the same htmlised I-Ds and RFCs on Datatracker
2.  Moving the xm2rfc and ietfbd (Datatracker) trac/svn instances to GitHub
3.  Moving the other trac instances to a new wiki product (while these have now moved off of tools.ietf.org they were still maintained by Henrik)
4.  Moving the web based tools (rfcdiff, idspell, xm2rfc, idnits) elsewhere
5.  Reproducing the bibxml service elsewhere

The additional resources mentioned is the new Senior Software Development Engineer that we are recruiting for [2].

Discussions are still ongoing to see if certain portions of tools.ietf.org can be turned off as and when they either break or are reproduced or moved, and what redirections are possible and how.

Jay

[1]  https://www.ietf.org/media/documents/2021-02-18-llc-board-minutes.pdf
[2]  https://mailarchive.ietf.org/arch/msg/ietf-announce/rCLegOyqbYcE8no8riO96F8BDdM/

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 3 Mar 2021 17:32:01 -0800

Lou --

Agree that this is troubling. SDOs often reference specification versions
on the tools.ietf.org, and I regularly use the tools there to do tasks
relating to IETF draft submission.  So if at all possible, we should try to
maintain the site in operation.

On Wed, Mar 3, 2021 at 3:55 PM Lou Berger <[email-masked]> wrote:

> Well this is a troubling response -- does anyone know if there's plans for
> tools.ietf.org? I would have thought that some thought would be given to
> this and maybe some announcement made to the IETF.  Did I miss it???  Are
> we just destined to the whims of bit rot?
> Lou
> ----reply above this line--
>
> ------------------------------
> Lou -
>
> As you are probably aware, tools.ietf.org is owned and operated by Henrik
> who has, unfortunately, departed the IETF.
>
> You can email Henrik at [email-masked] and submit the report to
> him.
>
> I'm having an issue with some versions of the tools html files?  Is this a
> general issue?
>
> Thanks,
>
> Lou
>
> This tools.ietf.org page can’t be found
>
> No webpage was found for the web address: *https://tools.ietf.org/html/draft-dang-queuing-with-multiple-cyclic-buffers-00
> *NOTE: When replying to this email please leave the subject-line intact.*
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 4 Mar 2021 02:46:59 +0100

On 2021-03-04, at 02:32, Bernard Aboba <[email-masked]> wrote:
> 
> SDOs often reference specification versions on the tools.ietf.org

… and that list of SDOs includes ourselves.
I found 785 references out of recent RFCs to tools.ietf.org hosted Internet-Drafts.

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Thu, 4 Mar 2021 09:49:39 -0800

Bernard,

> On Mar 3, 2021, at 5:32 PM, Bernard Aboba <[email-masked]> wrote:
> 
> Lou --
> 
> Agree that this is troubling. SDOs often reference specification versions on the tools.ietf.org, and I regularly use the tools there to do tasks relating to IETF draft submission.  So if at all possible, we should try to maintain the site in operation.

I agree, most time I do a search for a draft a link to the tool.ietf.org comes up first.  I think it is a big IETF operational problem now that the site has stopped working as expected.

It’s unfortunate that the LLC didn’t think this through when they did the things that caused Henrik to step away.

Bob

> Well this is a troubling response -- does anyone know if there's plans for tools.ietf.org? I would have thought that some thought would be given to this and maybe some announcement made to the IETF.  Did I miss it???  Are we just destined to the whims of bit rot?
>

---

From: Martin Duke <[email-masked]>
Date: Thu, 4 Mar 2021 09:52:27 -0800

IMO the problem is not the LLC's recent actions, but that important IETF
resources were the personal property of a volunteer.

On Thu, Mar 4, 2021 at 9:50 AM Bob Hinden <[email-masked]> wrote:

> > Agree that this is troubling. SDOs often reference specification
> versions on the tools.ietf.org, and I regularly use the tools there to do
> tasks relating to IETF draft submission.  So if at all possible, we should
> try to maintain the site in operation.
>
> I agree, most time I do a search for a draft a link to the tool.ietf.org
> comes up first.  I think it is a big IETF operational problem now that the
> site has stopped working as expected.
>
> for tools.ietf.org? I would have thought that some thought would be given
> to this and maybe some announcement made to the IETF.  Did I miss it???
> Are we just destined to the whims of bit rot?
> >
>
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 4 Mar 2021 19:11:06 +0000

Sent from my iPad

> On 4 Mar 2021, at 17:50, Bob Hinden <[email-masked]> wrote:
> 
> Bernard,
> 

+1

---

From: Fred Baker <[email-masked]>
Date: Thu, 4 Mar 2021 11:15:44 -0800

> On Mar 3, 2021, at 3:54 PM, Lou Berger <[email-masked]> wrote:
> 

I think there was an announcement that Henrik was leaving, and I certainly knew that there was a conflict between him and DMS/Glen's work. What might be nice wold be if people could somehow advise the LLC that they use some specific tool, and would like to see it ported into the AMS toolset. I would include the ability to subscribe to a meeting calendar attached to or derived from derived from the IETF Agenda. I use the "tools style" calendar and subscribe to it - in large part because I keep all of my calendars in one tool and have calendars that are unrelated to the IETF, so the ability to subscribe to a calendar that lists a subset of the meetings at a given IETF meeting is very useful to me.

For clarity, I am attaching what my calendar looks like fr the week of IETF 110, and includes IETF meetings, ICANN's prep week for ICANN 070, and some work in the ITU, in addition to personal events. If I have a complaint in that, it is that ICANN and ITU don't seem to see the value of subscribing to a calendar, but rather send out events - when then become outdated as time goes on. I would not want IETF to become deficient in that respect.

---

From: Robert Sparks <[email-masked]>
Date: Thu, 4 Mar 2021 13:20:54 -0600

> For clarity, I am attaching what my calendar looks like fr the week of IETF 110, and includes IETF meetings, ICANN's prep week for ICANN 070, and some work in the ITU, in addition to personal event…

Fred - you can subscribe to a subset of meetings at IETF 110 using the 
datatracker. Looking at the image you sent, I think this is what you want:

https://datatracker.ietf.org/meeting/110/agenda?show=6man,dprive,add,v6ops,qirg,plenary,add,dnsop,tcpm,danish,dnssd,opsawg

Look at the page that brings up and make any adjustments to what you 
want included, then subscribe to the link labelled "Customized schedule".

If you make no changes, that link for you would be

https://datatracker.ietf.org/meeting/110/agenda.ics?show=6man,dprive,add,v6ops,qirg,plenary,add,dnsop,tcpm,danish,dnssd,opsawg

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 4 Mar 2021 19:27:40 +0000

> most time I do a search for a draft a link to the tool.ietf.org comes up first.

This can be solved via search engine optimization to be sure. As well I think many of us might find it confusing and duplicative to have IETF drafts show up on so many URLs? Right now RFCs show up at the RFC Editor site, the Datatracker, and the Tools website and drafts at the Datatracker and the Tools site. The Datatracker arguably provides better functionality that the Tools site for drafts and the history on a draft, given things like the tabs across the top.

Jason

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 4 Mar 2021 19:28:16 +0000

It seems to me this is a bit of ‘administrative debt’ – as no one ever seems to have clearly established to whom tools servers were donated, who had access/control to the servers, who owned the code itself, who was in charge of making sure each tool continued to work, etc. This certainly all pre-dates the creation of the LLC by many years, especially given some of these tools seem to have stopped working many years ago.

Jason

On 3/4/21, 2:12 PM, "Stewart Bryant" <[email-masked]> wrote:

    Sent from my iPad

    +1

---

From: Alexa Morris <[email-masked]>
Date: Thu, 4 Mar 2021 12:04:37 -0800

Hi Fred,

> On Mar 4, 2021, at 11:15 AM, Fred Baker <[email-masked]> wrote:
> 
> 
> 
> I think there was an announcement that Henrik was leaving, and I certainly knew that there was a conflict between him and DMS/Glen's work.

AMS’s IT team (Glen and Ryan) worked closely with Henrik for many years and were deeply saddened by his departure. They were not just professional colleagues and collaborators; they were friends. I just wanted to clarify that, since it appears that you had a different understanding. 

Best,
Alexa

> What might be nice wold be if people could somehow advise the LLC that they use some specific tool, and would like to see it ported into the AMS toolset. I would include the ability to subscribe to a meeting calendar attached to or derived from derived from the IETF Agenda. I use the "tools style" calendar and subscribe to it - in large part because I keep all of my calendars in one tool and have calendars that are unrelated to the IETF, so the ability to subscribe to a calendar that lists a subset of the meetings at a given IETF meeting is very useful to me.
> 
> <Calendar — Week — 3-7-21 to 3-13-21.pdf>

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Mar 2021 09:14:03 +1300

Bob

> On 5/03/2021, at 6:49 AM, Bob Hinden <[email-masked]> wrote:
> 

> It’s unfortunate that the LLC didn’t think this through when they did the things that caused Henrik to step away.

This is a complex situation and the seeds for this were planted a long time before the LLC came into operation, so crude assertions like this do not help us either understand how we got here or how to move forward.

The LLC inherited four complex starting positions:

1.  tools.ietf.org delegated to Henrik in such a way that he asserts it was a personal delegation

2.  servers donated to 'tools' (in the broadest sense) under the sole control of Henrik such that he asserts ownership

3.  while Henrik was contracted to work on IETF full time for many years, there were multiple critical projects he asserted he worked on outside of those hours and therefore had full control/ownership of

4.  a decision made by the Tools Team to break up the work that Henrik was responsible for into multiple RFPs that had to go to different parties in order to reduce the reliance on Henrik

The LLC picked up with 4 and started the RFP process, which led to two further issues - NetNod ceased their funding as they felt being asked to bid for a donation was wrong, and there was a practical issue around the length of the contract, which Henrik was very upset about and which we addressed with a significant uplift in the value of the contract.

When we offered Henrik a renewal of this contract he refused and he made it clear that he would not do any work for us at all under any form of contract.  The only way he would consider doing any work (such as maintaining the tools.ietf.org site) was if he was free to do whatever he wanted and we paid him for that without any form of contract.  Clearly, those were not terms I could agree to.

The underlying issue is that Henrik started off as a volunteer and therefore able to work on what he liked with very few existing tools in place, and while that quickly transitioned to him being contracted full time to work on IETF tools, there was significant 'looseness' around the whole relationship.   Over time, more people have got involved in tools development, both volunteers and contractors, the tools landscape has matured significantly (in large part due to Henrik’s efforts) and we have tightened up our admin/contractual process in direct response to community wishes.  The impact has been to squeeze out the freedom/fun/control that Henrik had at the very beginning to the point where he no longer wanted to be involved, but that has been an organic process over many years and not something the LLC did in the last 18 months.

If you think we could have done something different then or now, then I would very interested in hearing that.  I can see some important things the IAOC should have done differently, but I don’t think it will help if I go over that ground now.

Jay

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Thu, 4 Mar 2021 21:21:46 +0100

> On 4 Mar 2021, at 21:14, Jay Daley <[email-masked]> wrote:
> 
> If you think we could have done something different then or now, then I would very interested in hearing that

But not here, please.  We are simply picking at old wounds now.

Eliot

---

From: Glen <[email-masked]>
Date: Thu, 4 Mar 2021 12:22:40 -0800

> AMS’s IT team (Glen and Ryan) worked closely with Henrik for many years and were deeply saddened by his departure. They were not just professional colleagues and collaborators; they were friends. I…

Since I was mentioned by name twice, I will take the opportunity to 
clarify one more thing, if I may:

Under the paradigm designed by Russ Housley when he was Chair, the Tools 
Team (which included Henrik at the time, and is now led by Robert), does 
"Engineering" - software design, coding, code debugging, and overall 
oversight of Tools generally.  In contrast, I and my team at AMS do 
"Operations" - we run the IETF production servers, a number of backup 
servers, and do our best to keep things alive and running well 
generally.  That is a clearly defined and bright line which has worked 
well for us all these years.

So a conflict wasn't really a realistic thing, because our roles were 
clearly defined.  And unless there was conversation I was not aware of 
(possible, but I never got a hint of it), "conflict" was always the 
farthest thing from my relationship with Henrik.  He and I worked 
closely on production-related things, our working relationship was 
always excellent and enjoyable, and I was completely blindsided by his 
departure.  Any concepts to the contrary are, at least from my point of 
view, completely inaccurate.

All that said, I never worked on the "tools.ietf.org" servers, I never 
had regular access to them and, apart from doing the occasional hard 
reset, I never was involved with them in any way.  I think he had others 
in that role, but I was not ever a part of the "tools" inner circle. 
That was fine with me, since as he would say, "There is always more to 
do" and I am busy with my own work, which consists primarily of being 
the IETF's operator, and doing everything I can to support everyone 
behind the scenes.

And for what it's worth, speaking personally for a moment, Henrik was 
one of the very few people who put up with what he called my "brashness" 
with both patience and tolerance.  He knew that my tone was always 
unintentional, and he was never offended by it; instead, he took the 
time to educate me about it and help me try to be less "curt."  I 
actually cried actual literal tears when I learned of his departure, and 
his absence still hurts my soul.

Glen
--
Glen Barney
IT Director
AMS (IETF Secretariat)

---

From: Margaret Cullen <[email-masked]>
Date: Thu, 4 Mar 2021 15:57:29 -0500

Henrik has done a lot of wonderful things for the IETF community for many years as a volunteer tools developer, as the former head of our tools development effort, and as a contractor.  He deserves to be respected and admired for those contributions.  I also understand that he has developed some intellectual property that he owns, and I think that we should respect his rights to that intellectual property.

However, pointing a subdomain of our DNS space at a service that someone is running does not result in that person “owning” that subdomain.  This is done all of the time with hosting services, and it is often done specifically to remove the possibility of lock-in to the hosting service — www.mydomain.com <http://www.mydomain.com/> can point to one web hosting service today and to a different web hosting service tomorrow.  

IMO, if the IETF community needs a specific set of URLs in our domain to point to a specific set of resources (such as tools.ietf.org/html <http://tools.ietf.org/html> URLs pointing to an up-to-date set of Internet Drafts), we should make it so.  I think that Jay and Robert are the right people to figure out the best way to make that happen.

Margaret

> On Mar 3, 2021, at 8:29 PM, Jay Daley <[email-masked]> wrote:
> 
> Hi Paul, Lou and others
> 
>> As background, our ex-contractor and long term community member Henrik Levkowetz, controls tools.ietf.org <http://tools.ietf.org/> and operates it on servers donated by other community members over the years. tools.ietf.org <http://tools.ietf.org/> runs a set of services, some of which are maintained by the IETF such as the ​online xml2rfc​ and code repositories for ​datatracker​ and x​ml2rfc,​ and some of which are maintained by Henrik such as the HTMLized ​RFCs​ and I-Ds. Over time, some of these services have become mission critical.
>> 
>> Henrik asserts that the domain name tools.ietf.org <http://tools.ietf.org/> was delegated to him personally (by the IETF Chair in 2004) and the servers were donated to him personally not the IETF and that he should retain full control of what runs on these servers and how they are managed. Some of the servers are physically based in AMS operated datacenters.
>> 
>> We recently had an incident where one of the servers operating tools.ietf.org <http://tools.ietf.org/> failed irreparably. There were some services running exclusively on that server that therefore needed to be moved to other servers, which Henrik and another volunteer were able to do. However some performance issues remained on other services for a few days due to DNS configuration issues. To prevent a recurrence, we proposed to Henrik that the management of the DNS move to AMS so that they can make emergency changes in situations like this. Henrik’s response to this proposal was quite intense and included a threat to turn off tools.ietf.org <http://tools.ietf.org/> and all its services if we made this change.
>> 
>> The Tools Team PM (Robert Sparks) already had a partial plan in place to migrate services off tools.ietf.org <http://tools.ietf.org/> but this combination of failing servers, a single person in control and threats of service shutdown have significantly increased the risk this situation poses and consequently I am reprioritising work to assist and accelerate the migration. The good news is that Robert and Henrik have been working cooperatively to effect the migration, though Robert needs additional resources to complete this and other work (see below). 
> 
> 3.  Moving the other trac instances to a new wiki product (while these have now moved off of tools.ietf.org <http://tools.ietf.org/> they were still maintained by Henrik)
> Discussions are still ongoing to see if certain portions of tools.ietf.org <http://tools.ietf.org/> can be turned off as and when they either break or are reproduced or moved, and what redirections are possible and how.
> 
> Jay
> 
> [1]  https://www.ietf.org/media/documents/2021-02-18-llc-board-minutes.pdf <https://www.ietf.org/media/documents/2021-02-18-llc-board-minutes.pdf>
> [2]  https://mailarchive.ietf.org/arch/msg/ietf-announce/rCLegOyqbYcE8no8riO96F8BDdM/ <https://mailarchive.ietf.org/arch/msg/ietf-announce/rCLegOyqbYcE8no8riO96F8BDdM/>
> 
>> 
>> Paul
>> 
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>

---

From: Luigi Iannone <[email-masked]>
Date: Fri, 5 Mar 2021 06:58:51 +0100

> On 4 Mar 2021, at 20:15, Fred Baker <[email-masked]> wrote:
> 
> 
> 

+ 1

I also use the tools style calendar, is a very nice feature that should be Included in the main IETF agenda on the datatracker.

Ciao

L.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 5 Mar 2021 08:39:13 +0000

To whom do we send a list of the tools resources that we use?

- Stewart

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 5 Mar 2021 09:51:14 +0100

> To whom do we send a list of the tools resources that we use?

We could start a discussion thread on tools-discuss.

But maybe we want to give the Tools Team (which is certainly drowned at the moment because of IETF110) some time to organize a more structured solicitation of requirements.

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Mar 2021 08:28:11 -0600

> I also use the tools style calendar, is a very nice feature that should be Included in the main IETF agenda on the datatracker.

Luigi -

I think it is already available at the datatracker.

I sent an example to Fred on list. Did it help you?

In addition to that example, please note the individual calendar icons 
at, e.g. https://datatracker.ietf.org/group/lisp/meetings/ (or choose 
some other group to look at since lisp cancelled for 110).

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Mar 2021 08:36:12 -0600

Please drop notes to the tools-discuss list or directly to me as you 
think of things. I'd like for you to catch them as you see you need them.

Carsten's idea of something more structured is a good one, and I hope to 
build on it.

And, yes, we're dealing with the meeting and more, so please be patient 
if you don't see an immediate response.

I think we can take this as an opportunity to constructively assess 
where some near-term efforts would he helpful. Try to keep that 
perspective in mind as you capture things to comment on.

RjS

---

From: "Leslie Daigle" <[email-masked]>
Date: Fri, 05 Mar 2021 15:03:05 -0500

On 5 Mar 2021, at 9:28, Robert Sparks wrote:

>>>> Well this is a troubling response -- does anyone know if there's 
>>>> plans for tools.ietf.org? I would have thought that some thought 
>>>> would be given to this and maybe some announcement made to the 
>>>> IETF.  Did I miss it???  Are we just destined to the whims of bit 
>>>> rot?
>>> I think there was an announcement that Henrik was leaving, and I 
>>> certainly knew that there was a conflict between him and DMS/Glen's 
>>> work. What might be nice wold be if people could somehow advise the 
>>> LLC that they use some specific tool, and would like to see it 
>>> ported into the AMS toolset. I would include the ability to 
>>> subscribe to a meeting calendar attached to or derived from derived 
>>> from the IETF Agenda. I use the "tools style" calendar and subscribe 
>>> to it - in large part because I keep all of my calendars in one tool 
>>> and have calendars that are unrelated to the IETF, so the ability to 
>>> subscribe to a calendar that lists a subset of the meetings at a 
>>> given IETF meeting is very useful to me.
>>>
>> + 1
>>
>> I also use the tools style calendar, is a very nice feature that 
>> should be Included in the main IETF agenda on the datatracker.
>
> Luigi -
>

Speaking only for myself — it helps me, insofar as I appreciate having 
something I can put in my calendar.

Here’s what I miss from the tools-style agenda/calendar:
	. picking items based on where they are in the agenda, not just by name
	. subscribing to the calendar, so that schedule changes are reflected 
in my calendar.

Leslie.

>>> For clarity, I am attaching what my calendar looks like fr the week 
>>> of IETF 110, and includes IETF meetings, ICANN's prep week for ICANN 
>>> 070, and some work in the ITU, in addition to personal events. If I 
>>> have a complaint in that, it is that ICANN and ITU don't seem to see 
>>> the value of subscribing to a calendar, but rather send out events - 
>>> when then become outdated as time goes on. I would not want IETF to 
>>> become deficient in that respect.
>>>

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

---

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Mar 2021 14:10:19 -0600

On 3/5/21 2:03 PM, Leslie Daigle wrote:
>                 Well this is a troubling response -- does anyone know
>                 if there's plans for tools.ietf.org? I would have
>                 thought that some thought would be given to this and
>                 maybe some announcement made to the IETF. Did I miss
>             I think there was an announcement that Henrik was leaving,
>             and I certainly knew that there was a conflict between him
>             and DMS/Glen's work. What might be nice wold be if people
>             could somehow advise the LLC that they use some specific
>             tool, and would like to see it ported into the AMS
>             toolset. I would include the ability to subscribe to a
>             meeting calendar attached to or derived from derived from
>             the IETF Agenda. I use the "tools style" calendar and
>             subscribe to it - in large part because I keep all of my
>             calendars in one tool and have calendars that are
>             unrelated to the IETF, so the ability to subscribe to a
>             calendar that lists a subset of the meetings at a given
>             IETF meeting is very useful to me.
>
>         + 1
>
>         I also use the tools style calendar, is a very nice feature
>         that should be Included in the main IETF agenda on the
>         datatracker.
>
>     Luigi -
>
If you're ok subscribing to lots of little calander feeds, you can use 
the calendar icon at the end of each row that you are interested in on

https://datatracker.ietf.org/meeting/110/agenda

(Am I understanding the use case?)

> . subscribing to the calendar, so that schedule changes are reflected 
The button on the page is a https link, so if you click it it will 
download. You can copy the link location and subscribe to it with your 
calendar handler.

For some other pages, we've been experimenting with providing webcal: 
links (which browsers usually route to calendar handlers in a way that 
they subscribe rather than just pull a single snapshot). It would crowd 
this page even more to do so on each row, but maybe it's needed.

> Leslie.
>
>     In addition to that example, please note the individual calendar
>     icons at, e.g. https://datatracker.ietf.org/group/lisp/meetings/
>     <https://datatracker.ietf.org/group/lisp/meetings/> (or choose
>             For clarity, I am attaching what my calendar looks like fr
>             the week of IETF 110, and includes IETF meetings, ICANN's
>             prep week for ICANN 070, and some work in the ITU, in
>             addition to personal events. If I have a complaint in
>             that, it is that ICANN and ITU don't seem to see the value
>             of subscribing to a calendar, but rather send out events -
>             when then become outdated as time goes on. I would not
>             want IETF to become deficient in that respect.
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Bob Hinden <[email-masked]>
Date: Sat, 6 Mar 2021 17:30:32 -0800

Hi Robert,

>> 
>> Speaking only for myself — it helps me, insofar as I appreciate having something I can put in my calendar.
>> 
> If you're ok subscribing to lots of little calander feeds, you can use the calendar icon at the end of each row that you are interested in on

I would not be OK with that.

> (Am I understanding the use case?)

I like the Tools style because I can select all of the sessions I want to attend (as in put on my calendar in the case of conflicts), then get a custom link I can subscribe to.  It’s fairly efficient to do it this way.   Having to subscribe to each individually would be not very usable to me.

Bob

---

From: Fred Baker <[email-masked]>
Date: Sun, 7 Mar 2021 19:22:30 -0800

> On Mar 4, 2021, at 11:20 AM, Robert Sparks <[email-masked]> wrote:
> 
> Fred - you can subscribe to a subset of meetings at IETF 110 using the datatracker. Looking at the image you sent, I think this is what you want:
> 

You have correctly intuited what I would be looking for. Where is this documented?

---

From: Lars Eggert <[email-masked]>
Date: Mon, 8 Mar 2021 10:25:32 +0200

Hi,

> I like the Tools style because I can select all of the sessions I want to attend (as in put on my calendar in the case of conflicts), then get a custom link I can subscribe to.  It’s fairly efficie…

that is how I use the datatracker calendar. FWIW, here is the URL that I am subscribed to, which I customized to the meetings I care to see:

https://datatracker.ietf.org/meeting/110/agenda.ics?show=gen,iab,officehours,iesg,ietf,plenary,quic,tcpm,tsvarea,tsvwg,tls,add,intarea,saag,hrpc,iccrg,irtfopen,maprg,pearg,bof,hackathon,tools,hotrfc&hide=rfceditorofficehours,ianaofficehours

(That URL comes from the "Customize the agenda view" functionality on https://datatracker.ietf.org/meeting/agenda/ by doing "Copy Link" on the "Customized schedule" button.)

For a new meeting, I typically just replace "110" with the meeting number of that meeting and it all rolls forward.

Thanks,
Lars

---

From: "Leslie Daigle" <[email-masked]>
Date: Mon, 08 Mar 2021 07:21:05 -0500

Hi,

On 5 Mar 2021, at 15:10, Robert Sparks wrote:

[snip]
>> Speaking only for myself — it helps me, insofar as I appreciate 
>> having something I can put in my calendar.
>>

Except for the fact that I don’t need or want to have 10 - 15 
individual calendar subscriptions, you have not missed the use case.

To reiterate:  Tools-style calendar subscription means I go through the 
agenda for the whole IETF meeting, SELECT the sessions that are of 
potential interest to me (the groups in which I am active, plus any 
other sessions that I am interested in, balanced by where they are in 
the whole meeting agenda) and have ONE calendar subscription for the 
IETF meeting.

> download. You can copy the link location and subscribe to it with your 

It’s good that this is subscribable.  But it makes the workflow:  
select all WGs/BoFs/Sessions that MIGHT be of interest, subscribe, and 
then see what calendar mess ensues.

Useful, no doubt, but not actually a replacement for the Tools calendar 
subscription.

> they subscribe rather than just pull a single snapshot). It would 
> crowd this page even more to do so on each row, but maybe it's needed.

I’m not sure this would help.

Leslie.

--

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 10 Mar 2021 12:02:21 +0100

Hi Fred,

Someone alerted me to this.  I don't read any IETF lists any more, so
needed the nudge:

On 2021-03-04 20:15, Fred Baker wrote:
> work.

There has been no conflict between me and AMS/Glen, none at all.  There
has been a great deal of conflict with the way the LLC Board and Jay
has been running things and what they have put me through, and I'm deeply
unhappy with them, but not at all with AMS or Glen.

The latest incident was with Jay at the beginning of February, after
the end of my contract but at a time when I was still committed to
maintaining tools.ietf.org as I have been doing it.  That February
encounter did however completely zap my motivation for keeping
tools.ietf.org up, and I now just want to be able to get completely
away from it.

It used to give me great pleasure, thanks to the appreciation of all
the good people in the IETF community, but now after the latest Jay
incident it only reminds me of the pain of last year.

Best regards,

	Henrik

> What might be nice wold be if people could somehow advise the
> LLC that they use some specific tool, and would like to see it ported
> into the AMS toolset. I would include the ability to subscribe to a
> meeting calendar attached to or derived from derived from the IETF
> Agenda. I use the "tools style" calendar and subscribe to it - in
> large part because I keep all of my calendars in one tool and have
> calendars that are unrelated to the IETF, so the ability to subscribe
> to a calendar that lists a subset of the meetings at a given IETF
> meeting is very useful to me.
>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 10 Mar 2021 11:17:33 +0000

This is most disturbing.

Who is Jay’s boss?

Stewart

> On 10 Mar 2021, at 11:02, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Fred,
>

---

From: David Noveck <[email-masked]>
Date: Wed, 10 Mar 2021 06:37:31 -0500

I believe it is the IETF Administration LLC Board of Directors.

---

From: Jay Daley <[email-masked]>
Date: Thu, 11 Mar 2021 06:59:51 +1300

> We recently had an incident where one of the servers operating tools.ietf.org <http://tools.ietf.org/> failed irreparably. There were some services running exclusively on that server that therefore…

You are of course welcome to escalate any concerns about this to the LLC board of directors (start with Jason as the Chair).

Jay

> On 11/03/2021, at 12:17 AM, Stewart Bryant <[email-masked]> wrote:
> 
> This is most disturbing.
> 
> Who is Jay’s boss?
> 
> Stewart
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Wed, 10 Mar 2021 10:24:19 -0800

Thanks for clearing this up. I obviously forr, and repeated, some bad data.

I don’t blame you for discounting IETF lists. I’m back on it now, but dropped ietf@ after the Buenos Aires meeting. The meetings committee got a load of crap on that list for quite some time, and I had had enough.

Sent using a machine that autocorrects in interesting ways...

> On Mar 10, 2021, at 3:37 AM, David Noveck <[email-masked]> wrote:
> 
> 
>> On Wed, Mar 10, 2021, 6:17 AM Stewart Bryant <[email-masked]> wrote:
>> This is most disturbing.
>> 
>> Who is Jay’s boss?
>> 
>> Stewart
>>

---

From: Fred Baker <[email-masked]>
Date: Wed, 10 Mar 2021 10:28:47 -0800

Apologies for sending this to the folks listed; I thought I was replying privately to Henrik. There are days I want to kill my mail tool…

> On Mar 10, 2021, at 10:24 AM, Fred Baker <[email-masked]> wrote:
>