Subject: Early review by the directorates

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 21 Apr 2021 05:41:31 +0000

Dear WG chairs,

We simply want to remind you that many directorates/area review teams have specific knowledge and that you should never hesitate to ask for an ‘early review’, e.g., before the WGLC. Requesting a directorate review is not reserved for the Area Directors. ;-)

The different directorates are (see also https://datatracker.ietf.org/dir/):

  1.  Security Area Directorate
  2.  General Area Review Team (Gen-ART)
  3.  Internet Area Directorate: about DNS, or IPv6, or tunnels, or sub-IP
  4.  Internet of Things Directorate: when your document could be used in constrained networks
  5.  Ops Directorate
  6.  Routing Area Directorate
  7.  Transport Area Review Team
  8.  YANG Doctors (very useful for an early review)
  9.  ART Area Review Team: application and real-time
  10. Internationalization Directorate: especially when you have UTF-8 or any character strings

It is very simple to request one or more reviews by:

  1.  connecting to the datatracker with your credentials, visiting the document page (like you do to request some actions for the document),
  2.  clicking on the ‘request review’ button,
  3.  selecting ‘early review’ as the type,
  4.  putting a checkmark for one or several directorates,
  5.  adding a deadline (such as 2 weeks),
  6.  writing some text in the instructions box,
  7.  clicking on the ‘request review’ button.

The earlier a WG can have reviewers outside the WG, the more efficient the whole process will be for the IETF community.

Regards

-éric vyncke (for the IESG)

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 21 Apr 2021 07:43:44 +0000

Hi,

As one of the secretaries for TSVART I want to second Eric’s message to don’t hesitate to ask us for reviews. I would also note that some of the directorate have additional resources that could be useful. For example in TSVART’s wiki there is this page with common transport issues.

https://trac.ietf.org/trac/tsv/wiki/tsvart-common-issues

I know that other areas have similar list, and maybe the best direct collection of these are on the IESG wiki:

https://trac.ietf.org/trac/iesg/wiki/ExpertTopics

Cheers

Magnus Westerlund

From: WGChairs <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
Sent: den 21 april 2021 07:42
To: Working Chairs <[email-masked]>
Subject: Early review by the directorates

Dear WG chairs,

Regards

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 21 Apr 2021 11:24:57 -0400

I have been under the impression that there is also an SDP Directorate. 
(I was asked to be on it back in 2011.) But I don't see it listed below 
or in https://datatracker.ietf.org/dir. I was never informed of it being 
disbanded. (OTOH I don't recall the last time it was invoked.)

	Thanks,
	Paul

On 4/21/21 1:41 AM, Eric Vyncke (evyncke) wrote:
> Dear WG chairs,
> 
> We simply want to remind you that many directorates/area review teams 
> have specific knowledge and that you should never hesitate to ask for an 
> ‘early review’, e.g., before the WGLC. Requesting a directorate review 
> is not reserved for the Area Directors. ;-)
> 
>  1. connecting to the datatracker with your credentials, visiting the
>     document page (like you do to request some actions for the document),
> The earlier a WG can have reviewers outside the WG, the more efficient 
> the whole process will be for the IETF community.
> 
> Regards
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 23 Apr 2021 16:45:12 -0400

> We simply want to remind you that many directorates/area review teams have specific knowledge and that you should never hesitate to ask for an ‘early review’, e.g., before the WGLC. Requesting a di…

While not a directorate, if you have BFD questions, part of the BFD WG's
charter is to help the other Working Groups review the use of BFD in your
protocol/mechanism/app.  

A separate directorate list likely doesn't make sense since the active
members would largely be the same subset as those who regularly participate
in our small plumbing Working Group. :-)

-- Jeff

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 23 Apr 2021 13:34:43 -0700

I found extended reviews very useful, especially in pointing out cases that we (wg/area) consider obvious/given but is not necessarily so for others. In wg’s I co-chair -  I’m trying to always have these (early) reviews done before adoption and then before wglc.

Regards,
Jeff

> On Apr 23, 2021, at 13:22, Jeffrey Haas <[email-masked]> wrote:
>