Subject: v3 XML resources

From: Sandy Ginoza <[email-masked]>
Date: Thu, 8 Apr 2021 16:34:14 -0700

Greetings all,

There has been some confusion about where documentation for v3 XML is available.  Below is a list of helpful v3 resources.  Please share with others looking for guidance.  

Thanks,
Sandy Ginoza 
(for the RFC Production Center)

What about v3 XML?

- FAQ:
https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html

- Schema documentation:
https://xml2rfc.ietf.org/xml2rfc-doc.html

- Where to run the v2->v3 converter on the web:
https://xml2rfc.ietf.org/experimental.html
(select "convert v2 to v3 XML")

What about SVG?

- FAQ: 
https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html#name-how-do-i-generate-svg-that-

- SVG Tips:
https://www.rfc-editor.org/rse/wiki/doku.php?id=svg_files

- Use svgcheck to convert your SVG file to meet the requirements of the profile: 
https://xml2rfc.ietf.org/experimental.html#svg12checker or
https://pypi.org/project/svgcheck

Where's the schema for this?
- https://svn.ietf.org/svn/tools/xml2rfc/trunk/cli/xml2rfc/data/v3.rnc
- https://svn.ietf.org/svn/tools/xml2rfc/trunk/cli/xml2rfc/data/SVG-1.2-RFC.rnc

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Apr 2021 14:04:23 +1000

Hi Sandy,

Thanks!

Are these links collected somewhere in one place on the RFC Editor web site?

Cheers,

> On 9 Apr 2021, at 9:34 am, Sandy Ginoza <[email-masked]> wrote:
> 
> Greetings all,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 9 Apr 2021 11:05:25 -0700

Hi Mark,

Yes, these are all available from the xml2rfc FAQ <https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html>.  

Thanks,
Sandy 

> On Apr 8, 2021, at 9:04 PM, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Sandy,
> 
> Thanks!
>