Subject: Holding an action

From: Yaron Sheffer <[email-masked]>
Date: Fri, 14 May 2021 12:01:50 +0300

Hi,

As a co-author, I am marked as an “action holder” with a bright red “for 35 days” on my draft [1].

Which action is it I’m expected to do? How is it useful to mark people as action holders without saying what action? If we had a good concrete definition of this “action” we could manage it, e.g. by nagging people periodically. But the current situation is IMHO not effective at all.

Thanks,

Yaron

[1] https://datatracker.ietf.org/doc/draft-ietf-acme-star-delegation/

---

From: S Moonesamy <[email-masked]>
Date: Fri, 14 May 2021 02:11:36 -0700

Hi Yaron,
At 02:01 AM 14-05-2021, Yaron Sheffer wrote:
>As a co-author, I am marked as an "action 
>holder" with a bright red "for 35 days" on my draft [1].

There is a "discuss" from one of the Security 
Area Directors.  The usual practice in such cases 
is to discuss the "discuss" with the Area Director.

Regards,
S. Moonesamy

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 14 May 2021 12:18:33 +0300

Yes, and I know that. My point is: there is no use telling people that they have an action without telling them what it is.

On 5/14/21, 12:12, "S Moonesamy" <[email-masked]> wrote:

Hi Yaron,

Regards,

S. Moonesamy

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 14 May 2021 12:21:02 +0200

> On 14. May 2021, at 11:18, Yaron Sheffer <[email-masked]> wrote:
> 

Actually, there is a lot of use in telling people they are blocking something.
If they don’t know how they do, they then know they can ask their friendly chair/AD.
(I wouldn’t mind adding more information, but the feature is useful as it is.   And someone would need to add that information...)

Grüße, Carsten

---

From: Barry Leiba <[email-masked]>
Date: Fri, 14 May 2021 09:07:22 -0400

We discussed that quite a bit while I was on the IESG recently, and
also discussed it with the tools team.  In the end, we decided that it
can't, in general, be done automatically, and the best approach is
that if one needs to remember what the action is, one should
(manually) put a comment in the datatracker as a reminder (which I
often did as AD, and which I will do as WGC when I need to).

Barry

---

From: Robert Sparks <[email-masked]>
Date: Fri, 14 May 2021 11:01:56 -0500

I think there is a bug in the new code that should remove the authors as 
action holders when a new revision is submitted.

I just created https://trac.ietf.org/trac/ietfdb/ticket/3281

The relevant code starts here:

https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/utils.py#L469

RjS

---

From: Fred Baker <[email-masked]>
Date: Fri, 14 May 2021 09:06:40 -0700

> On May 14, 2021, at 2:18 AM, Yaron Sheffer <[email-masked]> wrote:
> 

I would suggest looking at the GenArt and Security reviews, find out what is behind the Security AD's "discuss", and post a new draft that he agrees addresses the issues.

---

From: Fred Baker <[email-masked]>
Date: Fri, 14 May 2021 09:08:23 -0700

> is to discuss the "discuss" with the Area Director.

I think https://datatracker.ietf.org/doc/review-ietf-acme-star-delegation-06-secdir-lc-housley-2021-03-14/ might be an important clue.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 14 May 2021 09:12:55 -0700

> I think https://datatracker.ietf.org/doc/review-ietf-acme-star-delegation-06-secdir-lc-housley-2021-03-14/ might be an important clue.

https://mailarchive.ietf.org/arch/msg/acme/tJyPWlXh9CcQOrwvmxaXQIPz8UQ/
might be a more recent/relevant reference in this case (which I still owe a
response to).

-Ben

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 14 May 2021 19:35:51 +0300

Thank you Robert! I agree this should have happened when we submitted the new rev.

Yaron

On 5/14/21, 19:02, "Robert Sparks" <[email-masked]> wrote:

RjS

---

From: Daniel Migault <[email-masked]>
Date: Fri, 14 May 2021 13:15:26 -0400

+1
Depending on the possible flows it might not be relevant, but with the one
I have in mind authors might be replaced by the AD and the AD may not even
appear in the first place.

Yours,
Daniel

On Fri, May 14, 2021 at 12:36 PM Yaron Sheffer <[email-masked]>
wrote:

> >> Yes, and I know that. My point is: there is no use telling people that
> they have an action without telling them what it is.
>
> >>
>
> >>
>
> >>
>

-- 
Daniel Migault
Ericsson

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 14 May 2021 17:23:51 +0000

Agreed.  Barry’s response was entirely correct in the general case.  The state + action holder bug highlighted by draft-ietf-acme-star-delegation-08 and now tracked in https://trac.ietf.org/trac/ietfdb/ticket/3281 is that documents changing state from “IESG Evaluation::Revised I-D Needed” to “IESG Evaluation::AD Followup” should have their corresponding Action Holders field changed from the authors to the responsible AD.

Roman

From: WGChairs <[email-masked]> On Behalf Of Daniel Migault
Sent: Friday, May 14, 2021 1:15 PM
To: Yaron Sheffer <[email-masked]>
Cc: [email-masked]; Robert Sparks <[email-masked]>
Subject: Re: Holding an action

+1
Depending on the possible flows it might not be relevant, but with the one I have in mind authors might be replaced by the AD and the AD may not even appear in the first place.

Yours,
Daniel

On Fri, May 14, 2021 at 12:36 PM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
Thank you Robert! I agree this should have happened when we submitted the new rev.

                Yaron

On 5/14/21, 19:02, "Robert Sparks" <[email-masked]<mailto:[email-masked]>> wrote:
I think there is a bug in the new code that should remove the authors as
action holders when a new revision is submitted.

RjS

On 5/14/21 8:07 AM, Barry Leiba wrote:
> On Fri, May 14, 2021 at 5:19 AM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
>> On 5/14/21, 12:12, "S Moonesamy" <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Hi Yaron,
>>

--
Daniel Migault
Ericsson