Subject: IETF 111 Preliminary Agenda

From: IETF Agenda <[email-masked]>
Date: Fri, 25 Jun 2021 12:55:04 -0700

The IETF 111 preliminary agenda has been posted. The final agenda will be published on Friday, July 2, 2021.  

If you would like to request a change to the preliminary agenda, please send a message to [email-masked] with “Agenda” in the subject line and copy all relevant Area Directors.

https://datatracker.ietf.org/meeting/111/agenda.html
https://datatracker.ietf.org/meeting/111/agenda.txt

The preliminary agenda includes all planned WG, RG, and BoF sessions. We are still finalizing details for a few of our usual meeting-adjacent events, so please look out for further details about those. Information about side meeting signups will be available when the final agenda is posted.

Please note the agenda times are listed in PDT (UTC -7) by default. You may select which time zone is displayed on the HTML version of the agenda with a menu on the right side of the page. Choose “Meeting Time” for PDT, “Local Time” for your own current time zone, “UTC” for UTC, or choose any other time zone from the drop down list. 

Thank you!

IETF Secretariat

---

From: Michael Richardson <[email-masked]>
Date: Fri, 25 Jun 2021 16:51:53 -0400

http://www.sandelman.ca/tmp/ietf111-conflicts2.png

So, except for Monday first session, where I got nothing, I have conflict on
every single session.
I haven't gone back yet to look for any new BOFs that might matter to me,
like APN.  I just copied my list from the last IETF.

I'm CC'ing Rob Wilton, because a lot of this is basically the IOT conflict
list.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 26 Jun 2021 06:42:34 +0000

Michael

Having interest in 36 WG (if I counted them correctly) and having only 5 days of meeting with 3 slots per day, i.e., 15 slots => you are doomed to have conflict of course ;-)

A big constrain is the 6 hours per day when being remote.

-éric

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 26 Jun 2021 11:34:58 +0200

> A big constrain is the 6 hours per day when being remote.

So we (T2TRG) went out of the way and had an interim instead (yes, before Juhannus/Midsommar :-).

Maybe it would help if we could qualify specific interims as “milestone meeting” or some such.  To distinguish working interims (where we usually discuss a single subject or a block of closely related ones) from milestone, whole-WG interims (like IETF meeting slots tend to be).  Just a thought.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sun, 27 Jun 2021 11:02:55 -0400

Eric Vyncke (evyncke) <[email-masked]> wrote:
    > Having interest in 36 WG (if I counted them correctly) and having only
    > 5 days of meeting with 3 slots per day, i.e., 15 slots => you are
    > doomed to have conflict of course ;-)

Yes, doomed.  I've only just finished watching all the youtube for conflicts
from IETF110.

Perhaps you remember me suggesting that WGs should each start with 1x 1hr
slot, and then negotiate for more time on a basis that conflicts will be
ignored?  If all five days were like Thursday, then there would be 20 slots.

It's not 36 WGs, but about 26, as there are some repeats like RATS.

There are two "*dispatch" groups included, plus IOTOPS, as well as some BOFs.
Do I care about ohttp?  probably not enough to go to the BOF, but I'm also
starting to fall into the "I object" camp.  It's one of the few places I have
no conflict though.

Also, the IESG has preferred to make more WGs with smaller focuses.

There is a scheduling impact of doing that.  I also think that we may have
reached the bottom of the well of available WG chairs.
A number of WGs that I participate in are little more than large design
teams.

    > A big constrain is the 6 hours per day when being remote.

Yeah. I have written lots in SHMOO about this, including a draft that wasn't
well received.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Michael Richardson <[email-masked]>
Date: Sun, 27 Jun 2021 11:08:21 -0400

> Maybe it would help if we could qualify specific interims as “milestone
    > meeting” or some such.  To distinguish working interims (where we
    > usually discuss a single subject or a block of closely related ones)
    > from milestone, whole-WG interims (like IETF meeting slots tend to be).
    > Just a thought.

Well, the bi-weekly CORE, COSE, CBOR meetings at which you and are often
present are essentially very close to design team meetings.  Get rid of
slides, and just screen share github, and the transformation would be
complete.   Those are three sessions at IETF111 which I likely won't attend,
or won't pay as much attention to.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 28 Jun 2021 11:09:03 +0000

Hi Michael,

Thanks for raising this.

Having looked at the number of conflicts that you have, and your lack of free sessions, then it seems like having a reasonable degree of conflicts is probably somewhat unavoidable for you.    I think that the only solution that could reasonably work would be to have more sessions available (longer days, or more days), or reduce the amount of time that WGs are allowed to meet during a virtual IETF week.

Even for an in-person meeting, there would only be 2 extra meeting slots (i.e., on the Friday morning, which are often not so well attended), but many of the other slots would be for longer sessions.  Hence, I still think that you would end up with a fair number of conflicts.

It is worth noting that running up to the scheduling for IETF 111, we did encourage WG chairs to try and allocate less time with the aim of avoiding the need of running 9 parallel tracks if possible, which IIRC, reduced the number of sessions by 3, and 14 hours less total meeting time, but this wasn't enough to avoid going to 9 tracks for some sessions.

I appreciate that none of the above helps with your scheduling problem.  Whilst we are trying to cope with the pandemic, then I think that we are just trying to do the best we can, but I do see your feedback as being pertinent when considering possible future online-only meetings when we get back to meeting in person again - a topic for SHMOO.

One final suggestion: Are the conflicts between the WGs listed on the WG scheduling page?  If not, then would it be possible to please follow up with the chairs to see if there are any WG conflicts missing - although it is unclear which of these conflicts are specific to you, and just listing them doesn't fundamentally change the constraints of the scheduling that we are operating under.

It would also be interesting to hear if other IOT focussed participants are also having similar scheduling problems.  Perhaps worth discussing in IOTOPS (or the IOT directorate)?

Thanks,
Rob

> From: iesg <[email-masked]> On Behalf Of Michael Richardson
> Sent: 25 June 2021 21:52
> To: Rob Wilton (rwilton) <[email-masked]>; Working Group Chairs
> <[email-masked]>