Subject: New Meetecho feature

From: Meetecho IETF support <[email-masked]>
Date: Sat, 17 Jul 2021 15:32:45 +0200

Dear Chairs,

for IETF 111 we made available a new feature that has been requested 
quite a few times by some of you: you can now make presentations by 
sharing pdf slide decks, rather than sharing your screen.

This feature requires wg chairs to select which deck they want to make 
available to other participants to present. Decks can be retrieved from 
the datatracker meeting materials of the wg, or uploaded directly via 
Meetecho.

This short video describes the functionality in more details:

	https://youtu.be/VBZSmIjYro0

Cheers,
the Meetecho team

---

From: Russ Housley <[email-masked]>
Date: Sat, 17 Jul 2021 10:48:02 -0400

This looks extremely useful.  Thanks!

Russ

> On Jul 17, 2021, at 9:32 AM, Meetecho IETF support <[email-masked]> wrote:
> 
> Dear Chairs,
> 
> for IETF 111 we made available a new feature that has been requested quite a few times by some of you: you can now make presentations by sharing pdf slide decks, rather than sharing your screen.
> 
> This feature requires wg chairs to select which deck they want to make available to other participants to present. Decks can be retrieved from the datatracker meeting materials of the wg, or uploaded directly via Meetecho.
>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 17 Jul 2021 17:54:27 +0200

> On 2021-07-17, at 15:32, Meetecho IETF support <[email-masked]> wrote:
> 

Very nice!

So, as a chair that has done their homework (all slides are in the datatracker), before the start of the meeting I just have to remember to “compression process” all the slides that are in the datatracker.  You showed the process per slide deck.  Is there a way to start that in bulk?

Grüße, Carsten

---

From: Meetecho IETF support <[email-masked]>
Date: Sat, 17 Jul 2021 20:36:33 +0200

Hi Carsten!

> So, as a chair that has done their homework (all slides are in the datatracker), before the start of the meeting I just have to remember to “compression process” all the slides that are in the data…

You can just click all "upload" buttons in a row. There's no need to 
wait for a conversion process to complete before starting another one, 
they can all run in parallel.

As a note, you can test this out by scheduling your own test session via 
the same scheduler you used for interim meetings:

	https://meetings.conf.meetecho.com/scheduler

Cheers,
the Meetecho team

---

From: Michael Richardson <[email-masked]>
Date: Sat, 17 Jul 2021 19:46:42 -0400

Meetecho IETF support <[email-masked]> wrote:
    > available to other participants to present. Decks can be retrieved from the
    > datatracker meeting materials of the wg, or uploaded directly via
    > Meetecho.

So, if the deck is already on the DT, does it still require an upload/conversion step?
What does the conversion do?

    > https://youtu.be/VBZSmIjYro0

Thanks.

Some questions:

1) Can participants browser the slides?
   Can participants change the slide they see independantly of the presenter?
2) Will participants see the mouse pointer for the presenter?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 20 Jul 2021 12:26:03 +0200

Yesterday, at the hackathon kickoff, the slide presentation feature worked great.

One nit is that the resolution of the processed slides is a bit low.
The slides came over at 720x405 (*) PNGs.  While it is generally great that the files are so small (30–50 kB) and use so little network capacity, there were a few slides with images on them that had print that was no longer very well readable.

Maybe this can be notched up one √2, to 1024x576.  Most slides these days are still built to be useful on a 1024xnnn projector.  While this is twice as many pixels as 720xnnn, PNG will probably compress away large parts of that increase.

Grüße, Carsten

(*) if you know about the history of TV, the number 405 makes one think about https://en.wikipedia.org/wiki/405-line_television_system — but that is just a coincidence and would have been only 376i really anyway.

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 20 Jul 2021 16:34:36 +0200

I had never tried o analyse efffective resolution in meetecho.
How does the resolution of the uploaded slide now (720x405)
compare in your eperience with the resolutions you would
get when live presenting the slides in meetecho ?

Thanks
    Toerless

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 20 Jul 2021 17:31:56 +0200

> get when live presenting the slides in meetecho ?

I didn’t look at the actual resolution (video coding!) for screen sharing.  But I had less problems reading the same kind of slides.
Note that you can make the window larger and that should potentially renegotiate the video (no idea whether meetecho does all that recoding).

Grüße, Carsten

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 27 Jul 2021 00:04:34 +0200

As some of you noticed, Meetecho is currently generating slides images 
by picking the very same size as the source pdf. This sometimes causes 
issues when the original size is too small, making slides blurred or 
pixelated.

While we work on a fix for this issue, David Schinazi shared a 
workaround he found when generating pdf files from Google Slides: go to 
File > Page Setup > Custom and replace "10 x 5.63 inches" with "64 x 36 
inches" (or any other ratio that is much higher). This does not change 
the PDF file size at all (it's vectorized) but looks much better in 
Meetecho.

Hope this helps,
best,
the Meetecho team

---

From: Bob Hinden <[email-masked]>
Date: Tue, 27 Jul 2021 07:00:54 -0700

Hi,

Will the same approach work with Powerpoint?   I use MacOS and print to a PDF file.

Bob

> On Jul 26, 2021, at 3:04 PM, Meetecho IETF support <[email-masked]> wrote:
> 
> As some of you noticed, Meetecho is currently generating slides images by picking the very same size as the source pdf. This sometimes causes issues when the original size is too small, making slides blurred or pixelated.
> 
> While we work on a fix for this issue, David Schinazi shared a workaround he found when generating pdf files from Google Slides: go to File > Page Setup > Custom and replace "10 x 5.63 inches" with "64 x 36 inches" (or any other ratio that is much higher). This does not change the PDF file size at all (it's vectorized) but looks much better in Meetecho.
> 
> Hope this helps,
> best,
> the Meetecho team
>

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 27 Jul 2021 16:23:46 +0200

Hi Bob,

> Will the same approach work with Powerpoint?   I use MacOS and print to a PDF file.

when you generate PDFs with PowerPoint, it keeps the size set in the 
Design tab >> Page Setup. Standard (4:3) or Widescreen (16:9) formats 
should work just fine.

The Meetecho team

---

From: Bob Hinden <[email-masked]>
Date: Tue, 27 Jul 2021 08:00:12 -0700

Thanks, I will try that.

Bob

> On Jul 27, 2021, at 7:23 AM, Meetecho IETF support <[email-masked]> wrote:
> 
> Hi Bob,
> 
> when you generate PDFs with PowerPoint, it keeps the size set in the Design tab >> Page Setup. Standard (4:3) or Widescreen (16:9) formats should work just fine.
> 
> The Meetecho team
> 
>> Bob

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Jul 2021 21:00:12 +0200

The core chairs just did a quick training session with the presenters in the minutes leading up to the meeting.

That’s the way to do it…

Grüße, Carsten

---

From: Michael McBride <[email-masked]>
Date: Wed, 28 Jul 2021 19:39:12 +0000

Good idea, thanks. 

Please remind me, what's the earliest we can join our wg mtg to do this?

mike

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Carsten Bormann
Sent: Wednesday, July 28, 2021 12:00 PM
To: Meetecho IETF support <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: [irsg] Uploadable slides (Re: New Meetecho feature)

That’s the way to do it…

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Jul 2021 21:49:19 +0200

I think it was 10 or 15 minutes, not quite sure, but i just
yelled "Help" to my WG on monday and figured out that
slide uploading within the 5 minutes before the meeting
started, e.g.: uploading and conversion for each of 6 presentations
was done in 2 minutes or so. But you can also do it in parallel
during the session.

-- 
---
[email-masked]

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 28 Jul 2021 16:00:06 -0400

The Meetecho room opens 15 minutes ahead of session start. It took me less
than a minute to convert the slides. You can do them in parallel, you don't
have to wait for one to finish before you start the next.

I'm not sure why they can't convert the slides uploaded to meeting
materials automatically, but doing the manual conversion is easy and fast.

Cheers,
Andy

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 28 Jul 2021 23:04:29 +0200

> On 28. Jul 2021, at 21:00, Carsten Bormann <[email-masked]> wrote:
> 
In TCPM it just worked... So the UI is intuitive and the features
worked. Thank you very much for implementing it.

Best regards
Michael

---

From: "Ciavaglia, Laurent" <[email-masked]>
Date: Wed, 28 Jul 2021 21:17:16 +0000

Hello,

Question on this new feature, which works well (tested in our RG yesterday): 
  - Is it possible to give control to progress the slides to a particular participant (e.g. the authors of the slides), or is it only possible for the session chairs to do it?

Apologies if this is already possible and I overlooked it; I've tried to find such a command on Meetecho but haven't found it.

Thanks, best regards, Laurent

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Michael Tuexen
Sent: mercredi 28 juillet 2021 23:04
To: Carsten Bormann <[email-masked]>
Cc: Working Group Chairs <[email-masked]>
Subject: Re: [irsg] Uploadable slides (Re: New Meetecho feature)

[EXTERNAL] This message comes from an external organization.

> The core chairs just did a quick training session with the presenters in the minutes leading up to the meeting.
In TCPM it just worked... So the UI is intuitive and the features worked. Thank you very much for implementing it.

Best regards
Michael

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Jul 2021 23:20:36 +0200

On 2021-07-28, at 23:17, Ciavaglia, Laurent <[email-masked]> wrote:
>  - Is it possible to give control to progress the slides to a particular participant (e.g. the authors of the slides),

Yes.  They have to request it (the “A4 piece of paper” icon), and you have to grant it, like you would have granted screen sharing.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 29 Jul 2021 17:20:40 -0400

Ciavaglia, Laurent <[email-masked]> wrote:
    > - Is it possible to give control to progress the slides to a particular
    > participant (e.g. the authors of the slides), or is it only possible
    > for the session chairs to do it?

It's not.

But it would be a good thing so that the chairs can have a unified
slide deck, can reduce error in selecting the right deck, but the speaker can
control slides.

I forget where we send meetecho suggestions, or if Greg will collect them
from this list.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Bob Hinden <[email-masked]>
Date: Thu, 29 Jul 2021 14:23:17 -0700

Michael,

> On Jul 29, 2021, at 2:20 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

I believe it is <[email-masked]>.

Bob

---

From: Christian Amsüss <[email-masked]>
Date: Fri, 30 Jul 2021 11:41:43 +0200

Hi chairs,

On Tue, Jul 27, 2021 at 12:04:34AM +0200, Meetecho IETF support wrote:
> While we work on a fix for this issue, David Schinazi shared a workaround he
> found when generating pdf files from Google Slides: go to File > Page Setup
> > Custom and replace "10 x 5.63 inches" with "64 x 36 inches" (or any other
> ratio that is much higher). This does not change the PDF file size at all
> (it's vectorized) but looks much better in Meetecho.

for anyone who still needs to fix slide resolution and either has only
the PDF or produces them with a tool that doesn't take "just scale
everything up 10 times" easily (looking at you, LaTeX beamer), the
pdfjam tool (shipped with texlive[1]) provies an easy way to do this:

$ pdfjam --suffix upscaled --papersize "{1600mm,900mm}" slides.pdf

HTH
Christian

[1]: https://tug.org/texlive/

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom