Subject: is there a way to re-title slides in dataracker?

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 09:06:36 -0400

Hi

Does anyone know if there's a way to retitle slides in DT without 
reuploading?  I'd really like to avoid downloading/uploading just to add 
numbers to our session's slides -- to get around the forced 
alphabetization  of uploaded slides in the new (and very nice) meetecho 
upload/sharing feature.

Thanks!

Lou

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 30 Jul 2021 15:30:31 +0200

You can adjust the order of slides in the datatracker. I guess the right fix is for meetecho to retain this order. Maybe check with them directly as that might be a minor fix they could maybe implement right away...

> On 30. Jul 2021, at 15:06, Lou Berger <[email-masked]> wrote:
> 
> Hi
> 
> Does anyone know if there's a way to retitle slides in DT without reuploading?  I'd really like to avoid downloading/uploading just to add numbers to our session's slides -- to get around the forced alphabetization  of uploaded slides in the new (and very nice) meetecho upload/sharing feature.
> 
> Thanks!
> 
> Lou
> 
> 
>

---

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 09:46:35 -0400

I mentioned it to them on monday-- thanks

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 30 Jul 2021 14:46:43 +0100

I *think* I went to the reload, changed the name, but didn't upload a new copy.

A

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Lou Berger
Sent: 30 July 2021 14:07
To: Working Group Chairs <[email-masked]>
Subject: is there a way to re-title slides in dataracker?

Hi

Thanks!

Lou

---

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 10:32:38 -0400

I tried that and it said I needed to select a file to upload ;-(

I just re-uploaded  to solve the issue for today....

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Jul 2021 16:49:36 +0200

+1 for this being a good, missing datatracker feature.
I also went through download, upload to have titles with numbers.

Open an RFE on trac, Lou ?

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Jul 2021 10:14:30 -0500

If you go to the /doc/ page for the slides (follow the link in 
parentheses on your session materials page, you can edit the title.

For instance, for Lou with detnet, starting at

https://datatracker.ietf.org/meeting/111/session/detnet

Follow the link for the chair slides to

https://datatracker.ietf.org/doc/slides-111-detnet-intro-wg-status-draft-status/

and edit the title there.

A painful bit of navigation for lots of slides, for sure - I'll look 
into making the title editable directly from the <mtg>/session/<acronym> 
view.

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Jul 2021 17:23:11 +0200

Excellent. Just numbered all 15 slot titles of my WG
I feel so much more organized now ;-))

Thanks
   Toerless

On Fri, Jul 30, 2021 at 10:14:30AM -0500, Robert Sparks wrote:
> If you go to the /doc/ page for the slides (follow the link in parentheses
> on your session materials page, you can edit the title.
> 
> A painful bit of navigation for lots of slides, for sure - I'll look into
> making the title editable directly from the <mtg>/session/<acronym> view.
> 
> RjS
> 

-- 
---
[email-masked]

---

From: "MORTON JR., AL" <[email-masked]>
Date: Fri, 30 Jul 2021 15:26:50 +0000

+1, and not painful, Robert. 

I find it difficult to remember the navigation sometimes, especially when the reinforcements only come 3/year...
Al

> From: WGChairs <[email-masked]> On Behalf Of Toerless Eckert
> Sent: Friday, July 30, 2021 11:23 AM
> To: Robert Sparks <[email-masked]>
> Cc: [email-masked]
> Subject: Re: is there a way to re-title slides in dataracker?
> 
> https://urldefense.com/v3/__https://datatracker.ietf.org/meeting/111/session/d
> etnet__;!!BhdT!12IZWparJCIVTpFCTAofNDwI2yFbDDy5sC3UKDK1W6cRdcD83WdQViJDCDtCnHk
> $
> >
> > https://urldefense.com/v3/__https://datatracker.ietf.org/doc/slides-111-
> detnet-intro-wg-status-draft-
> status/__;!!BhdT!12IZWparJCIVTpFCTAofNDwI2yFbDDy5sC3UKDK1W6cRdcD83WdQViJDD72tH
> tg$
> >

---

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 11:29:33 -0400

Go for it!

Thanks

Lou

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Jul 2021 18:07:37 +0200

Nah, just threatening with a trac did produce the solution ;-))

-- 
---
[email-masked]

---

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 12:43:33 -0400

Robert

Thank you for the pointer and the investigation!

Lou

---

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 17:31:33 -0400

oh well it turns out the meetecho uses the 'file name' to sort and I 
just changed the title. So maybe the fix is to be able change the 
filename too without deleting and re-uploading.

Lou

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Jul 2021 16:38:20 -0500

That we really can't do - the document name is the filename, and the 
document name is fixed, as for drafts, when a -00 is uploaded.

You could work-around that for now, if you wanted to, be creating an 
entirely new set of -00 slide documents by uploading slides with a 
different filename, but what you really want, I think, is to ask 
Meetecho (and the datatracker) to show things by the order field.

RjS

---

From: Lou Berger <[email-masked]>
Date: Fri, 30 Jul 2021 18:42:10 -0400

I think the right answer is for meetecho to support ordering based on 
upload or user choice...