Subject: Closing the queue

From: Jen Linkova <[email-masked]>
Date: Fri, 30 Jul 2021 11:58:19 +1000

While I'm very happy with Meetecho (wow, I've just managed to chair a
session single-handed!), there is one missing feature which would make
me very happy.

Wouldn't it be great if we have a button to mark the queue "closed"?
It might be just me but I really, really hate interrupting people just
to say "I'm closing the queue after". Having smth like "The queue will
be closed in 5..4..3..2..1" would be even better..

Is there anyone else missing this feature? Or I'm just not aware of
the best current practices in keeping the session on time?

-- 
SY, Jen Linkova aka Furry

---

From: tjw ietf <[email-masked]>
Date: Thu, 29 Jul 2021 22:07:37 -0400

+1

Doesn’t allow folks to add themselves after it’s been stated. Allows chairs to add a request (author/AD)

Tim

Sent from my iPhone

> On Jul 29, 2021, at 21:58, Jen Linkova <[email-masked]> wrote:
>

---

From: Bob Hinden <[email-masked]>
Date: Thu, 29 Jul 2021 20:16:45 -0700

+1

I agree this would helpful.   It will, of course, require the chair(s) to remember to turn the queue back on for the next presentation.

Bob

> On Jul 29, 2021, at 7:07 PM, tjw ietf <[email-masked]> wrote:
> 
> +1
>

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 30 Jul 2021 10:06:12 +0100

> On 30 Jul 2021, at 02:58, Jen Linkova <[email-masked]> wrote:
> 

+1.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 14:45:56 +0200

> I agree this would helpful.   It will, of course, require the chair(s) to remember to turn the queue back on for the next presentation.

It is probably better not to “close the queue” (i.e., make the hands-up button inactive), but simply to change the color of the next hands-up entry that is made.  Rotate through 3-4 colors (yes, lightnesses, hatchings, …), and we should be safe.  If these were formal meetings, we’d need double-hands (point of order) as well…  and same topic/other topic...

(Ceterum censeo: And move the damn thing BELOW the current speaker.)

Grüße, Carsten

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 30 Jul 2021 15:15:29 -0500

Just following up on these excellent suggestions ("do the right thing", of
course),

I totally agree with Jen on having a button to "close the queue", whether
that's a "hard close", so you can't ignore the close, or a "soft close",
that (new variant) flags the people who added themselves after the line was
closed, but We All Know What You Did Last Session.

If I might make another queue-related suggestion - there are chairs who are
un-distracted enough to consistently remove people from the queue when
they're speaking, but that's asking the chairs to watch ANOTHER thing
during the session, so often, it's up to us to remove ourselves from the
queue.

For me, that means "turn off my raised hand to get out of the queue when
I'm recognized, AND turn on my audio, AND turn on my video if we seem to be
doing that", followed by "turn off my audio, AND turn off my video", or
some variation thereof.

I can't count the number of people this week who

   - turned on the video and started talking with no audio, OR
   - turned on the video and audio and started talking, and only turned off
   one of them, OR
   - my personal favorite - turned off audio and video, and left themselves
   in queue, but since no one else was in queue, the chair didn't realize that
   until the next presentation started and the chair had time to look at the
   queue, and then message *me* privately and say "can you ask that question
   during the general Q&A?" and I had literally no idea what Lars was talking
   about during the plenary (I can't count that one, but I know the number was
   at least "one") 😂

It seems that there are higher level operations that we could be looking at
here ...

Best,

Spencer

On Fri, Jul 30, 2021 at 7:46 AM Carsten Bormann <[email-masked]> wrote:

> > I agree this would helpful.   It will, of course, require the chair(s)
> to remember to turn the queue back on for the next presentation.
>
> It is probably better not to “close the queue” (i.e., make the hands-up
> button inactive), but simply to change the color of the next hands-up entry
> that is made.  Rotate through 3-4 colors (yes, lightnesses, hatchings, …),
> and we should be safe.  If these were formal meetings, we’d need
> double-hands (point of order) as well…  and same topic/other topic...
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 30 Jul 2021 13:33:14 -0700

I would suggest that one say “I’m closing the queue after <nam>”, and have a way to tell meet echo that it should stop putting new people in the queue.

Sent from my iPad

> On Jul 29, 2021, at 6:58 PM, Jen Linkova <[email-masked]> wrote:
>

---

From: Jen Linkova <[email-masked]>
Date: Sat, 31 Jul 2021 08:24:59 +1000

> I would suggest that one say “I’m closing the queue after <nam>”, and have a way to tell meet echo that it should stop putting new people in the queue.

Actually I'd say that "hard lock" might be suboptimal - sometimes we
might still want people joining after the queue is closed as an
exception - like an AD making comments etc. In real life even after
the queue is closed people still can jump to the mic to respond to
comments etc.
Personally I'd be very happy if I can click on "closing the queue in
15 secs" and the queue section goes, for example, orange  and the
title says "QUEUE: CLOSING". After 15 sec it goes red(*) and marked as
CLOSED.
As a result it's clearly visible for the participants that it's closed
and for the chairs that they need to re-open before/during the next
talk, white there is still possible to join it.

(*) color examples are chosen randomly and might not accommodate
color-blind cases.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 30 Jul 2021 17:56:07 -0500

On Fri, Jul 30, 2021 at 5:25 PM Jen Linkova <[email-masked]> wrote:

> > I would suggest that one say “I’m closing the queue after <nam>”, and
> have a way to tell meet echo that it should stop putting new people in the
> queue.
>

I've been wrong before, but I THOUGHT sending audio and/or video was also
on the honor system - I think I've been able to turn on at least audio and
break in for at least comments before the session starts, without queuing.
Am I missing something?

Best,

Spencer

---

From: Jay Daley <[email-masked]>
Date: Sat, 31 Jul 2021 11:01:52 +1200

> On 31/07/2021, at 10:56 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> 
> 
> On Fri, Jul 30, 2021 at 5:25 PM Jen Linkova <[email-masked] <mailto:[email-masked]>> wrote:
> On Sat, Jul 31, 2021 at 6:33 AM Fred Baker <[email-masked] <mailto:[email-masked]>> wrote:
> >
> I've been wrong before, but I THOUGHT sending audio and/or video was also on the honor system - I think I've been able to turn on at least audio and break in for at least comments before the session starts, without queuing. Am I missing something?

Yes it is an honour system.  Meetecho tried a permissions system and nobody liked it.

Jay

> > > On Jul 29, 2021, at 6:58 PM, Jen Linkova <[email-masked] <mailto:[email-masked]>> wrote:
> > >

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 31 Jul 2021 01:10:26 +0200

> I've been wrong before, but I THOUGHT sending audio and/or video was also on the honor system - I think I've been able to turn on at least audio and break in for at least comments before the sessio…

Like in a real meeting — I can always stand up and shout (and/or steal a mike).
(And that is more often necessary than one would think.)

Grüße, Carsten

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 30 Jul 2021 18:13:09 -0500

Hi, Jay,

> Yes it is an honour system.  Meetecho tried a permissions system and

I wonder if that makes providing some way to close queues easier, if all
you have to do is tag anyone going into the queue as "entered after closed"
- and all you personally have to do to clear that, is just pop out of the
queue.

That would let chairs let someone who was marked tardy speak, if everyone
in line in front of them is unexpectedly brief ("have you ever BEEN to the
IETF?", but that has happened to me as a chair).

Best,

Spencer

---

From: Jen Linkova <[email-masked]>
Date: Sat, 31 Jul 2021 09:16:25 +1000

> I've been wrong before, but I THOUGHT sending audio and/or video was also on the honor system - I think I've been able to turn on at least audio and break in for at least comments before the sessio…

You are right indeed - it's the honor system.  I just think that it's
much nicer if everyone who is willing to speak is in the queue.
I'm very confused when people who are not the presenters or the chairs
 (the chairs might don't want to mute all the time) have their audio
enabled - do they want to say smth or they just forgot to mute?